
MUG Meeting McIDAS-V Demo 

Before demo: 

1. Look for areas of active precipitation for examples 

2. Display arcserv1/AH08T/TARGET/05-15/11:45-12:45/10.4um>Temp (to speed up example) 

Display Changes: 

1. Vertical scale labeling.  This allows for controlling how labels are plotted on the vertical scale of 

the wireframe box in the Main Display.  This functionality is new in version 1.5 and matches the 

previously-existing ability to control labeling of the horizontal lat/lon scales 

a. Turn on View > Show Display Scales 

b. Rotate display so vertical component of wireframe is visible 

c. Go to View >Properties and then to the Vertical Scale tab 

i. Min and Max values are the lower and upper bounds of the wireframe 

ii. Axis Label allows to changing the label on the vertical axis 

iii. Units controls the vertical units 

iv. Major Increment controls the interval between numerical labels on the axis 

v. Minor Division can add tick marks between the major divisions 

vi. Visible controls if the vertical axis is visible.  Turning this off allows for the 

horizontal lat/lon scales to be visible, but not the vertical labels 

vii. Font controls the font, style and size of the labels on the vertical scale 

d. Demo the functionality 

i. In the Data Sources tab of the Data Explorer, open the Gridded Data > Remote 

chooser 

1. Note the new default SSEC catalog.  There was a time in early April 2015 

where the motherlode server was down, which made the model data 

from the catalog unavailable.  While SSEC doesn’t serve any of the 

actual data, we now have our own XML catalog that points at different 

servers for the data.  Therefore, if a server goes down in the future, we 

can change the XML catalog to point at an active server which should 

help prevent long periods of data outages in the future 

ii. Add in the latest GFS CONUS 80km data source 

iii. Display 3D > Derived > Speed using the 3D Surface > Isosurface display type.  In 

the Times tab choose ‘Use Selected’, choose just one time, and click Create 

Display 

1. The dropdown in the Times tab is new, this is related to time matching 

which will be covered later 

iv. Change to the south viewpoint (5th viewpoint option down) and translate display 

to left so the vertical scale is visible 

v. In the Properties window, change the font size to 20 to make it easier to see.  

The labels now appear a little cluttered 



vi. Change the Major Increment to 8000.  Now, there are numerical values on the 

wireframe every 8,000 meters instead of 4,000 meters 

vii. Change the Minor Division to 3.  Now, there are two tick marks between each of 

the Major Interval, creating 3 divisions between the major labels 

viii. From the south viewpoint, you can’t see the horizontal lat/lon labels.  In the 

Horizontal Scale tab of the Properties window, turn on ‘Axis label relief’.  This 

angles down the horizontal labels slightly so you can view them from this 

viewpoint, but they are still readable from the overhead view 

ix. The coloring of the labels is set by the foreground color option since the labels 

are a part of the wireframe box 

1. Go to the Main tab of the Properties window and change the 

Foreground color swatch to yellow and hit Apply 

2. Open the Foreground swatch again, and note the Recent panel on the 

right side of the swatches tab.  This remembers the most recently used 

swatch colors both between sessions, and throughout other places in 

McV where you can set color by a swatch.  This feature is new in 1.5 

3. Both the visibility of the display scale labels and the color can be set in 

the Display Window tab of the User Preferences if you find something 

you like and always want to use 

x. There are planed future changes to this functionality, but any other ideas are 

welcome 

xi. Close the Properties window 

2. Adjust contour label interval.  This new functionality allows for setting the frequency of which 

contours are labeled 

a. Demo the functionality 

i. Create a new tab 

ii. Create a Contour Plan View display of MSLP from the gridded data source added 

for the vertical scale demo 

iii. In the Layer Controls, click Change next to Contour to bring up the Contour 

Properties Editor 

iv. Make things easier to see by changing the label Size to 20, and change Align to 

Horizontal 

v. The Frequency slider was added back in version 1.3, but now there is also a new 

option for ‘Label Every Nth Line’.  By default, this is set to 2, so every other 

contour line in the Main Display has a label.  Bring this down to 1 and click 

Apply.  Now, every contour has a label.  This can be used in conjunction with the 

Frequency slider to add more contour labels to the display 

b. Note that this functionality can be used with any contour display, including vertical cross 

sections.  Probably no need to demo, but the Color-Filled Contour Cross Section is a 

good example 

Data Changes: 



1. Improved probe output 

a. Level III Radar demo 

i. Remove all layers and data sources, create a new tab, and remove any 

previously-existing tabs 

ii. Open the Radar > Level III chooser 

iii. Connect to adde.ssec.wisc.edu/RTNEXRAD 

iv. Choose the ‘N0H – Hydrometeor Classification Tilt 1’.  Choose a station where 

precipitation is occurring, the 5 most recent times, and click Add Source 

v. Choose the ‘Band: 16 > Hydro class’ field, the Image Display, and click Create 

Display 

vi. Probe the data with the middle mouse button to see text output like ‘Light – 

Moderate Rain’, ‘Light Rain’, ‘Graupel’, ‘Light Snow’, etc. 

1. In version 1.4, the probe output of the Image Display would be 

numerical values 

b. Suomi NPP demo 

i. Create a new tab 

ii. Using the Suomi NPP chooser, add the granule in the Probe_Demo directory.  

This is an Ice Surface Temperature EDR granule from NOAA CLASS 

iii. Choose the VIIRS-IST-EDR_All/QF2_Cloud_Confidence_Indicator field.  In the 

Region tab, use Shift+left-click+drag to subset an area in the center of the 

granule over Greenland.  This will display just this area at full resolution without 

including the bowtie deletion on the edges of the granule.  Click Create Display 

iv. Change the projection of the Main Display to North Pole and zoom in over 

Greenland.  Probe the display with the middle mouse button to see text output 

like ‘Confidently Cloudy’, ‘Confidently Clear’, ‘Probably Cloudy’, etc. 

v. All of the quality flag fields (field names include ‘QF’) probe with these text 

output in words 

1. In version 1.4, the probe output of the Image Display would be 

numerical values 

vi. We will cover more of the Suomi NPP chooser later on in the demo 

2. GEMPAK upper air data 

a. Remove all layers and data, create a new tab, and close any old tabs 

b. Open the Point Observations > Soundings > Local chooser 

c. Next to File, click Select File 

d. At the bottom of the window, under Files of Type, select ‘GEMPAK Upper Air files 

(*.gem)’ to list out GEMPAK files.  Navigate to the GEMPAK directory and select the file 

e. Using the map, select a couple stations over the United States and choose times for the 

data (probably the two earliest times in the list).  Click Add Source 

f. Click Create Display in the Field Selector 

g. This works the same as other sounding displays, but demo some basic functionality 

i. Play through loop 



ii. Change which station is used in the plot by clicking on a different square in the 

Main Display 

iii. Turn on ‘Consecutive Profiles’ to show 2 time steps at once (current time is 

dashed for T and Td profiles, future time is solid) 

iv. Go to the Hodograph tab and rotate to show 3D 

3. AMSR-E local servers.  Added a new local server for AMSR-E Level 2a 

a. Remove all layers and data, create a new tab, and close any old tabs 

b. Open the ADDE Data Manager with Tools > Manage ADDE Datasets 

c. In the Local Data tab, click Add New Dataset 

d. For Dataset, use: MUG 

e. For Image Type, use: amsr e l 2a 

f. For Format, use: AMSR-E L 2a 

g. For Directory, navigate to the AMSR-E_l2a directory 

h. Add the dataset 

i. Use the Satellite > Imagery chooser to navigate to <LOCAL-DATA>/MUG/amsr e l 2a.  

Use the Absolute tab to select the one time and click Add Source 

j. Choose the 89.0 GHz-V-A Brightness Temperature > Temperature field and click Create 

Display.  CHANGE PIXEL SAMPLING TO 1 TO GET DATA TO DISPLAY ON GRANITE 

k. Change to the World projection to show the swath 

4. Himawari example 

a. Remove all layers and data, create a new tab, and close any old tabs 

b. From the Satellite>Imagery chooser, connect to arcserv1.ssec.wisc.edu/AH08T/TARGET 

from 05/15/15.  In the Absolute tab, select a block of times from 11:45:45 through 

12:15:45 (13 times).  Add Source 

c. In the Field Selector, choose 10.4um > Temperature.  Create Display 

d. Change enhancement range to 185 - 285 

e. Play through loop 

f. Change Time Animation Widget Properties to set a Forward dwell rate of 0.1 

g. Stop loop and turn off Auto-Set Projection in the panel 

h. In the General > Files/Directories chooser, navigate to the ASCAT directory, choose the 

file (ordered from Eumetsat’s EO Portal, data is METOP-A).  This pass over Typhoon 

Dolphin happened right around 12Z on May 15th, so this is right in the middle of the time 

range of Himawari data displayed 

i. In the Field Selector, choose the Derived > Oceanographic Wind Vectors field, the Flow 

Displays > Wind Barb Plan View display, and Create Display 

j. New in 1.5 is that wind barbs or vectors (when derived from speed and direction fields) 

are colored by wind speed automatically.  In the past, they were one solid color.  If you 

still want to use one solid color, change the enhancement in the Layer Controls 

k. The barbs default to units of m/s.  Change this to knots in the Layer Controls through 

Edit > Change Color Units.  In the Change Unit window, change to knot and click OK 



l. To better match the enhancement to the wind speeds, change the enhancement range.  

Click the Windspeed button in the Layer Controls and select Change Range.  In the 

Change Range window, set the values to 0 – 50 and click OK 

m. Play through the loop in the Main Display and the barbs block out the satellite display.  

Make the satellite display more visible by: 

i. Adjust the wind barb size in the Layer Controls to 2 by typing into the text field 

and pressing Enter 

ii. Add a transparency to the barbs by right-clicking on the colorbar in the Legend 

and choosing Transparency > 50% 

n. Now, zoom in a bit on the display to see both the ASCAT winds and the Himawari data 

Other Changes: 

1. Time matching 

a. Time matching is a feature that allows for easy creation of loops of multiple types of 

data that are of differing temporal frequencies.  There are two terms that are going to 

be used in this part of the demo 

i. Driver: The layer or block of times that other layers will match to 

ii. Match time Driver: The layer(s) that match the time driver times 

b. Demo example of the time driver being a data layer 

i. Remove all layers and data, create a new tab, and close any old tabs 

ii. In the Point Observations > Plot/Contour chooser, connect to 

adde.ssec.wisc.edu/RTPTSRC.  Choose the SFCHOURLY point type, the 5 most 

recent times and click Add Source 

iii. In the Field Selector, choose the Point Data field.  In the Times tab, use the 

dropdown to select ‘Set As Time Driver’.  Click Create Display 

iv. In the Satellite > Imagery chooser, connect to eastl.ssec.wisc.edu/EASTL.  

Choose the CONUS image type.  At the bottom of the Times panel, click Match 

Time Driver and click Add Source 

v. In the Field Selector, choose the 10.7 > Temperature field.  Notice the Times tab 

has ‘Match Time Driver’ already selected from the previous step.  Click Create 

Display 

1. Notice that the only satellite times that display are those that match up 

with the point data times.  Since the satellite data is generally available 

four times an hour, and point data is only available once an hour, only 

every fourth satellite time (probably the :45 or :00 time) is used in the 

display 

vi. In the Radar > Level II > Remote chooser, connect to the Catalog and choose the 

NEXRAD Level II Radar from IDD collection.  Select a station with precipitation, 

choose the 5 most recent times and click Add Source 

vii. In the Field Selector, choose the Reflectivity field and in the times tab use the 

dropdown to select ‘Match Time Driver’.  Click Create Display 



1. Similar to above, notice that even though Radar comes in several times 

an hour, only the times that match closest to the hourly point data are 

displayed 

2. Note that you can also set a layer to match the driver times in the Layer 

Controls after the data has been displayed.  To do this, choose View > 

Times > Match Time Driver and then reload the data with File > Reload 

Data.  You can also set a data layer to be the time driver after it has 

been displayed through the View > Times > Set As Time Driver menu 

item in the Layer Controls.  After setting the layer as the driver through 

the Layer Controls, there is no need to reload the data 

c. Demo example of the time driver being a block of times 

i. Remove all layers and data sources.  Create a new tab 

ii. Click the (i) button in the Time Animation Widget to get to the Properties 

window.  The settings tab controls various things with the speed and direction 

of the loop.  Go to the Define Animation Times tab 

iii. Choose ‘Define your own list of times’ 

iv. Click the Predefined button and choose Real Time 

1. Set Time Length to 8 hours (this is the length of the loop) 

2. Set Time Step Every to 2 hours (this is the interval between time steps) 

3. Click OK 

v. Change Round To to 1 hour (this will round down the end time of the loop to 

the beginning of the current hour) 

vi. Click ‘Set as Time Driver’ and click OK 

vii. In the Data Sources tab of the Data Explorer, go to Point Observations > 

Plot/Contour.  Connect to adde.ssec.wisc.edu/RTPTSRC and choose the 

SFCHOURLY point type.  At the bottom of the Times tab, select ‘Match Time 

Driver’ and click Add Source 

viii. In the Field Selector, choose the Point Data field and click Create Display 

1. The times of point data displayed now match up the time animation 

widget driver times 

2. Other layers can be matched here as well, just as they were in the 

previous example 

2. Match display region 

a. Create a new tab and remove all layers/data sources 

b. Add in GFS 80km CONUS data 

c. In the Main Display, zoom in over Wisconsin 

d. Select ‘Temperature @ Specified height level above ground’.  Choose just 1 time.  In the 

Region tab of the Field Selector, open the dropdown to show the different options: 

i. Use Default Region: Displays the default, full domain 

ii. Select A Region: Allows for drawing a bounding box in the Region tab.  Only data 

in this region will be displayed 



iii. Match Display Region: Looks at the geographical domain of the active panel in 

the Main Display and only draws data within these bounds 

e. Choose the Match Display Region option and click Create Display 

f. Zoom out in the Main Display to show that the only data drawn is over Wisconsin 

i. This Match Display Region mode is currently supported for gridded and point 

data.  This feature is under development for satellite data and will be demoed 

later 

3. Sample bundles 

a. We wanted to give new users an easy way to create displays in McV that demonstrate 

both practical uses for McV (like operational forecasting) as well as the 3D capabilities of 

McV 

b. There is a Current WX button that shows up on the Main Toolbar by default in version 

1.5.  This button brings up a dropdown of 5 different bundles that display real time data.  

When loading bundles, choose Replace Session for each one 

i. 4 Panel GFS: 4 panel forecasting chart 

ii. Global Temps and Winds: globe display of surface temperature and isosurface of 

jet stream 

iii. PWAT and Winds: GFS model data.  PWAT at the surface drawn over topography 

(geopotential height at the surface from GFS), cross section of wind speed, 

isosurface of wind speed at 40 m/s and streamlines at 200 hPa 

iv. Satellite and Surface Temps: GOES east 10.7 um IR overlaid with surface 

temperatures colored by temperature 

v. Surface Observations: Background is colored by temperature from surface 

observations, overlaid with METARs 

vi. NOTE that these bundles can be removed from the toolbar through either the 

User Preferences or the Favorite Bundles Manager 

c. There are a variety of archive bundles that can be added through the Plugin Manager 

under Sample Bundles.  Add the ‘Hurricane Sandy Winds’ plugin and restart McV 

i. Notice the Archive WX button on the toolbar.  Click this button and the bundle 

added through the plugin will be listed.  Display the bundle 

4. Scripting changes 

a. getADDEImage has changed to loadADDEImage 

i. getADDEImage returned 2 objects, one with just metadata and one with both 

the data and the metadata (a mega-object) 

ii. loadADDEImage now returns just one object, the mega-object 

iii. The mega-object can be handled the same way as the metadata object from 

getADDEImage was (e.g. pulling the data’s size from getADDEImage’s metadata 

to create the window size) 

iv. Scripts using getADDEImage will continue to work, but we now document 

loadADDEImage and any developments will go to the new function 



b. Additional output formats from captureImage.  Now, you can capture every format from 

the background that you can from the foreground (GIF, JPG, PNG, PS, SVG, PDF, KML, 

KMZ) 

c. New formatting options with captureImage.  Allows you to do a variety of things to the 

output image (clipping, add colorbar(s), an image overlay (logo), matte, resize the 

image, add a text overlay, make the background transparent) 

d. New functions to work with gridded data (much the same as you can with satellite data 

through loadADDEImage) 

i. loadGrid – loads local netcdf, hdf, and grib files 

ii. listGridFieldsInFile – lists the different 2d/3d fields included with the data 

iii. listGridLevelsInField – lists any vertical levels included with a particular field 

iv. listGridTimesInField – lists the times included with a particular field 

Under Development: 

1. Adaptive resolution 

a. Adaptive resolution is a feature designed to load high resolution data efficiently by 

obtaining and loading only the minimum amount of data needed to display all of the 

observable features in the given display size and geographic domain 

b. Since adaptive resolution is still under development, it is disabled by default.  To enable 

adaptive resolution, go to the Display Window tab of the User Preferences.  At the 

bottom of the Panel Configuration panel, select Enable Adaptive Resolution and click OK 

c. Create a new tab, remove all layers and data sources, and close any previously-existing 

tabs 

d. Through the General > Files/Directories chooser, add the grib2 file in the HRRR directory 

e. In the Field Selector, choose 2D > Temperature > Temperature @ Specified height level 

above ground.  In the Times tab choose just one time and click Create Display 

i. Notice in the Legend that if Data Sampling is listed then the data was sampled at 

the time the display was created.  Even though the data was sampled, with the 

current state of the Main Display, it’s at the highest resolution that can be 

perceived 

ii. Zoom in on a region using the scroll wheel and you are no longer at the highest 

resolution that can be viewed.  Use Shift+left-click+drag to subset a region and 

the data will be resampled.  There are two things going on here: 

1. The data is re-displayed at the highest resolution that can be perceived 

at the zoom level.  This will either display the data at full resolution (the 

sampling text goes away) or the sampling will be decreased 

2. Scroll out of the display and you will see that only data drawn in the 

subsetted region will be displayed 

3. Both 1 and 2 above are designed to efficiently display data, by only 

displaying the highest resolution that can be perceived and by only 

displaying data within the bounds of the display 



iii. Use Shift+left-click+drag over a different region to show that you can keep 

subsetting different regions 

iv. Another way of invoking adaptive resolution is by changing the projection.  For 

example, set the projection to US > CONUS 

v. After a layer is displayed, you can turn adaptive resolution off for the layer by 

using the new Resolution Control button in the Legend.  Click this and turn AR 

off.  Now, Shift+left-click+drag  

vi. Adaptive resolution can be turned on or off for an individual panel through the 

View menu item 

f. Demo the Under Development Imagery chooser with adaptive resolution 

i. Create new tab 

ii. Connect to msg.ssec.wisc.edu/MSG and select the FD Image Type.  Use the 

Absolute tab to select the 12:00:00Z.  Add Source 

iii. In the Main Display, change the projection to Africa and zoom in a little bit 

iv. In the Field Selector choose 0.6 um > Brightness.  In the Region tab, click the 

airplane button on the lower left.  This does the same thing that the Match 

Display Region mode from the gridded data example earlier did, but actually 

shows the wireframe box around the domain.  Click Create Display. 

v. Notice the sampling written out in the Legend.  In this example, we combined 

adaptive resolution with the Match Display Region mode to efficiently create a 

display over our area of interest.  Use Shift+left-click+drag to sample over a 

region to demonstrate the adaptive resolution functionality 

g. We are done with the adaptive resolution demo.  Disable adaptive resolution through 

the User Preferences, create a new tab, remove all layers and data sources and remove 

any old tabs 

2. Suomi NPP chooser 

a. Additional support for ATMS (Advanced Technology Microwave Sounder) data 

i. Aggregate and add the three ATMS granules in the ATMS directory (GATMO-

SATMS*) 

ii. Additional displayable fields.  In 1.4, just Brightness Temperature was available.  

Now, any georeferenced data is displayable, including Lat, Lon, Height, and 

Satellite Angles 

iii. In the Field Selector, choose the Brightness Temperature field and the 

MultiSpectral Display.  In the Region tab, use Shift+left-click+drag to subset a 

region over Typhoon Dolphin.  Click Create Display 

iv. Move the probes around so one is over the typhoon and one is over open water 

v. In the Display tab of the Layer Controls, change the wavelength used in the 

display to show how the display changes.  Channel 17 shows the typhoon well 

vi. Overlay the SVI01 granules from the same ATMS directory.  Aggregate them 

together and display using swathToGrid.  Enter 375 for resolution (375m is the 

resolution of SVI bands).  Subset region over the typhoon and display.  Shows 

that you can overlay different types of Suomi NPP data in one display 



b. Test with data in SVM_RGB 

i. Make new tab 

ii. Navigate to the SVM_RGB directory.  This directory contains single-banded 

granules from SSEC’s peate server.  All of these bands contain the same GMTCO 

terrain-corrected geolocation, so they can be added as one data source 

iii. Select all of the SVM03, SVM04, SVM05 files and click Add Source 

iv. Select the VIIRS_M_RGB(M5,M4,M3) formula and Create Display 

v. For M5, select M5/Reflectance.  In the Region tab, use Shift+left-click+drag to 

subset a region from Kentucky southeast into the Atlantic 

1. In the past, you had to subset a region for each color in the RGB, but 

now you only have to do this for one 

2. Only data within the rubber band box will be displayed, it will be 

displayed at full resolution, and the bowtie deletion will be removed 

vi. For M4, select M4/Reflectance 

vii. For M3, select M3/Reflectance 

1. Using M bands 5, 4, and 3 for the RGB creates a true color RGB.  You can 

create any RGB using this formula though; including a natural color RGB 

using bands 10, 7, and 5. 

viii. Click OK 

ix. In the Layer Controls, change the Common Gamma to 0.4.  This controls the 

intensities of the color and is a good value to create a RGB display 

c. Added display units for many Suomi NPP fields 

i. Using the SVM_RGB directory, add the 3 SVM15 (longwave IR granules) 

ii. Create a new tab for the display 

iii. Display the Brightness Temperature field 

iv. Zoom in on region and probe to see values in Kelvin 

v. Use Edit > Change Display Unit in the Layer Controls to change the units to 

Fahrenheit.  Probe the display again to see the Fahrenheit values 

d. Added new QF2 fields 

i. Using the same SVM15 granules from the previous example, go to the Field 

Selector and the bottom four fields are now available: 

1. VIIRS-MOD-GEO-TC_All/QF2_Invalid_Input_Data 

2. VIIRS-MOD-GEO-TC_All/QF2_Bad_Pointing 

3. VIIRS-MOD-GEO-TC_All/QF2_Bad_Terrain 

4. VIIRS-MOD-GEO-TC_All/QF2_Invalid_Solar_Angles 

3. Satellite orbit track chooser 

a. Remove all layers and data sources, make a new tab and remove any old tabs 

b. Keep the world projection in the new tab (don’t do any zooming!) 

c. Open the Under Development > Satellite Orbit Track chooser 

i. Changed names from Polar Orbit Track chooser since geostationary satellites 

and other LEO satellites like TRMM can be plotted as well 



ii. Two parts of the chooser.  The top part is for any local TLE (Two Line Element) 

files.  The bottom part is for remote data including from ADDE and a URL 

d. Select Local > File, navigate to the TLE directory, select SatelliteTracks.txt and Add 

Source 

i. This came from CelesTrak 

e. Choose NPP and go to the Time Range tab 

i. Begin: 06:40:00; May 22, 2015 

ii. End: 07:15; May 22, 2015 

f. Create Display 

g. New stuff with chooser 

i. Separate panels for Swath Controls (line and swath with) and Ground Station 

Controls 

ii. Swath Controls new: 

1. Swath lines: 

a. Turn visibility on/off 

b. Control width and style of lines 

2. Track line: 

a. Turn visibility of swath edges on/off 

b. Set time label interval along line 

c. Set font and style of time labels 

d. Control width and style of line 

iii. Ground Controls new: 

1. Plot multiple stations 

2. Plot custom station at user-defined lat/lon 

3. Control font and style of labels 

4. Control line style of ring around ground station(s) 

h. Demo 

i. Swath Controls 

1. Set Swath Width to 3040km (approx. swath width of VIIRS) and click 

Apply 

2. Change font size to 20 and click Apply 

3. Change label interval to 10 min and click Apply 

4. Change swath edge style to solid line and click Apply 

ii. Ground Station Controls 

1. Click dropdown for Ground Stations Available and type in SSEC.  Click 

Add Selected 

2. Change line style to solid and click Apply 

3. Change antenna angle to 20 and click Apply 

a. Ring gets smaller 

4. For Custom Ground Station, enter the following: 

a. Label: Pacific 

b. Latitude: -25 



c. Longitude: -95 

5. Click Add Custom 

6. Change color to Yellow and click Apply 

7. Remove SSEC from plot by selecting SSEC from the Ground Stations 

Plotted menu and click Remove Selected 

4. Other things to show 

a. Remove all layers and data sources, make a new tab, remove any old tabs 

b. Grid trajectories (2D) 

i. Add GFS CONUS 80km data 

ii. Choose 2D > Derived > Grid 2D Trajectory 

iii. In Times tab, right-click and choose Select Range > First 10.  Create Display 

iv. In Field Selector window, choose a color-by field of ‘2D > Relative humidity @ 

Specified height level above ground.  Click OK 

v. In the Layer Controls, choose the ‘Points’ Trajectory Initial Area and click Create 

Trajectory 

vi. Demonstrate Back Trajectories.  Click the Scissors button in the Layer Controls, 

choose Back Trajectory, the Rectangle Trajectory Initial Area, draw a box around 

Wisconsin and click Create Trajectory 

vii. Trajectories are kind of cluttered.  Shorten the length of each trajectory 

1. In Layer Controls, go to the Times tab and click the Time Mode button 

and set the following: 

2. Start Time: ‘Relative to end time’, -12 hours 

3. End Time: ‘From animation time’ 

4. Play through loop, and trajectories are only 2 timesteps long 

viii. Remove layer (not data) 

c. Grid trajectories (3D) 

i. Choose 3D > Derived > Grid 3D Trajectory 

ii. In the times tab, right-click and choose Select Range > First 10.  Create Display 

iii. In the Field Selector window, choose 3D > Temperature @ Isobaric surface.  

Click OK 

iv. In the Layer Controls, change Levels to 850hPa (initial height of parcels), choose 

Rectangle, draw box somewhere over the CONUS and click Create Trajectory 

v. Play through the loop and rotate the display to see the vertical-component of 

the trajectories 


