McIDAS-V Tutorial
Time Matching
updated May 2015 (software version 1.5)

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data.

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/.

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share information with other users.

In this McIDAS-V Tutorial, some exercises will be explained using different methods of data access: local data files, pre-loaded data bundles and real-time access to default remote servers. If you have access to your own real-time ADDE servers, you may also use those, but be aware that different server configurations may make the explanations in this document not quite applicable to all data that you may load.

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start McIDAS-V. If you cannot start McIDAS-V on your machine, you should follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.

Terminology

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer).

The Data Explorer contains three tabs that appear in bold italics throughout this document: Data Sources, Field Selector, and Layer Controls. Data is selected in the Data Sources tab, loaded into the Field Selector, displayed in the Main Display, and output is formatted in the Layer Controls.

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources).

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).
Introduction

Time matching is a feature designed to create loops that accommodate data with differing temporal frequencies. Time matching involves setting one layer (generally the layer with the lower temporal frequency) as the time driver, and other layers can be set to match the time driver times. An example use case for this would be creating a loop of five hours of METAR surface observations (at hourly intervals), and then overlaying each METAR with a satellite image that matches up closest with the METAR times. Generally, satellite data is available in time intervals of less than an hour. Instead of having to manually select each satellite image that matches the METAR times, McIDAS-V will do this automatically. This tutorial will walk through this example.

There are two locations to set a layer to be the time driver:

- In the \textit{Times} tab of the \textit{Field Selector} use the dropdown to select \textit{Set As Time Driver}, as demonstrated in this tutorial.
- In the \textit{Layer Controls} tab of \textit{Data Explorer} use the \textit{View -> Times -> Set As Time Driver} menu item.

A time driver can also be set through the Time Animation Widget, by setting a block of user-defined times to be the time driver.

Dependent on the chooser, there may be three locations of setting a layer to match the time driver, assuming a time driver has been set:

- In the \textit{Data Sources} tab of the \textit{Data Explorer}, select the \textit{Match Time Driver} checkbox, as demonstrated in this tutorial. This option is available through the \textit{Satellite -> Imagery, Radar -> Level II -> Remove, Radar -> Level III, and Point Observations -> Plot/Contour} choosers.
- In the \textit{Times} tab of the \textit{Field Selector} use the dropdown to select \textit{Match Time Driver}.
- In the \textit{Layer Controls} tab of the \textit{Data Explorer} use the \textit{View -> Times -> Match Time Driver}. Note that if using this option, the layer must be reloaded with \textit{File -> Reload Data}.

Displaying Surface Observation Data and Matching Satellite Times

1. In the \textit{Main Display}, remove all layers and data sources via the \textit{Edit -> Remove -> All Layers and Data Sources} menu item.
2. Create a new tab with the \textit{File -> New Display Tab -> Map Display -> One Tab} menu item.
3. Load in the five most recent surface hourly observations.
   a. In the \textit{Data Sources} tab of the \textit{Data Explorer}, navigate to the \textit{Point Observations -> Plot/Contour} chooser.
   b. For \textit{Server}, select \textit{adde.ssec.wisc.edu}, and for \textit{Dataset} select \textit{RTPTSRC}.
   c. Click \textit{Connect}.
   d. For \textit{Point Type}, select \textit{SFCHOURLY – Real-Time SFC Hourly}.
   e. In the \textit{Times} panel, use the \textit{Relative} tab to select \textit{5 most recent}.
   f. Click \textit{Add Source}.
4. Display METARS, and set the layer to be the time driver.
a. In the **Fields** panel of the **Field Selector**, select the **Point Data** field.
b. In the **Displays** panel, choose the **Point Data -> Point Data Plot** display type.
c. In the **Times** tab, use the dropdown menu to select **Set As Time Driver**.
d. In the **Layout Model** tab, select the **Observations -> METAR** layout model.
e. Click **Create Display**.

5. Load in GOES East 10.7um IR satellite images that match the METAR times.
   a. In the **Data sources** tab of the **Data Explorer**, navigate to the **Satellite -> Imagery** chooser.
   b. For **Server**, select `adde.ssec.wisc.edu`, and for **Dataset** select `RTIMAGES`.
   c. Click **Connect**.
   d. For **Image Type**, select `GE-IR – GOES-East 10.7 um IR`.
   e. In the **Times** panel, at the bottom of the **Relative** tab, select the **Match Time Driver** checkbox.
   f. Click **Add Source**.

6. Display the Temperature field of the satellite data.
   a. In the **Fields** panel of the **Field Selector**, select the **10.7 um IR Surface/Cloud-top Temp -> Temperature** field.
   b. In the **Displays** panel, select **Imagery -> Image Display**.
   c. Click **Create Display**.

Note: The METAR data is in hourly time steps. The satellite data on the server comes in every 30 minutes (can be seen in the **Satellite -> Imagery** chooser by selecting the **Absolute** times tab). The **Match Time Driver** checkbox in the **Satellite -> Imagery** sorted through the list of times, to only load in the time steps that matched closest to the hourly METAR data. This allowed for the creation of a display where both the METAR and satellite data were displayed in hourly intervals.

**Problem Set**

The previous example was intended to give you a general knowledge of how to use time matching. The problem sets below are intended to introduce you to new topics related to the data, as well as challenge your knowledge of McIDAS-V. We recommend that you attempt to complete the problem set before looking at the solution, which is provided below the problem set.

1. Use the Time Animation Widget to create a time sequence starting with the current time (rounded down to the nearest hour), with a range that goes back four hours from the current time in 1 hour intervals. Set this time range to be the time driver. Add the following layers to match the time driver times:
   a. Point data METARs. Set to match the time driver from the **Data Sources** tab of the **Data Explorer**.
   b. 10.7um GOES East satellite temperature data. Set to match the time driver from the **Field Selector** tab of the **Data Explorer**.
   c. L2 Radar reflectivity data. Set to match the time driver from the **Layer Controls** tab of the **Data Explorer**.
Problem Set #1 – Solution

Use the Time Animation Widget to create a time sequence starting with the current time (rounded down to the nearest hour), with a range that goes back four hours from the current time in 1 hour intervals. Set this time range to be the time driver. Add the following layers to match the time driver times:

- Point data METARs. Set to match the time driver from the Data Sources tab of the Data Explorer.
- 10.7um GOES East satellite temperature data. Set to match the time driver from the Field Selector tab of the Data Explorer.
- L2 Radar reflectivity data. Set to match the time driver from the Layer Controls tab of the Data Explorer.

1. Set a block of times to be the time driver through the Time Animation Widget.
   a. From the Main Display Window, open the Time Animation Properties using the  button in the Time Animation Widget.
   b. In the Time Animation Properties window, navigate to the Define Animation Times tab and select Define your own list of times. Set the following:
      i. Start Time: Relative to End Time; Offset: -4 hours
      ii. End Time: Current Time (Now); Offset: 0 minutes
      iii. Interval: 1 hour
      iv. Round To: 1 hour
      v. Set as Time Driver: check this option
   c. Click OK.

2. Display point data METARs that match the time driver times.
   a. In the Data Sources tab of the Data Explorer, navigate to the Point Observations -> Plot/Contour chooser.
   b. For Server, select adde.ssec.wisc.edu, and for Dataset select RTPTSRC.
c. Click **Connect**.
d. For **Point Type**, select **SFCHOURLY – Real-Time SFC Hourly**.
e. In the **Times** panel, at the bottom of the **Relative** tab, select the **Match Time Driver** checkbox.
f. Click **Add Source**.
g. In the **Fields** panel of the **Field Selector**, select the **Point Data** field.
h. In the **Displays** panel, choose the **Point Data -> Point Data Plot** display type.
i. In the **Layout Model** tab, select the **Observations -> METAR** layout model.
j. Click **Create Display**.

3. Display 10.7um GOES East temperature satellite data that matches the time driver times.
   a. In the **Data Sources** tab of the **Data Explorer**, navigate to the **Satellite -> Imagery** chooser.
   b. For **Server**, select **adde.ssec.wisc.edu**, and for **Dataset** select **RTIMAGES**.
   c. Click **Connect**.
   d. For **Image Type**, select **GE-IR – GOES-East 10.7 um IR**.
   e. In the **Times** panel, select the **Relative** tab and choose **5 most recent**.
   f. Click **Add Source**.
   g. In the **Fields** panel of the **Field Selector**, select the **10.7 um IR Surface/Cloud-top Temp -> Temperature** field.
   h. In the **Displays** panel, choose the **Imagery -> Image Display** display type.
   i. In the **Times** tab, use the dropdown menu to select **Match Time Driver**.
   j. Click **Create Display**.

4. Display Level 2 Radar reflectivity data that matches the time driver times.
   a. In the **Data Sources** tab of the **Data Explorer**, navigate to the **Radar -> Level II -> Remote** chooser.
   b. Use the default for **Catalog**.
   c. Click **Connect**.
   d. Use the default for **Collection** (**NEXRAD Level II Radar for IDD**).
   e. Select a Radar station that has seen precipitation over the past four hours.
   f. In the **Times** panel, select the **Relative** tab and choose **5 most recent**.
   g. Click **Add Source**.
   h. In the **Fields** panel of the **Field Selector**, select the **Reflectivity** field.
   i. In the **Displays** panel, choose the **Radar Displays -> Radar Sweep View in 2D** display type.
   j. Click **Create Display**.
   k. To match the radar times to the time driver, in the **Layer Controls** tab of the **Data Explorer** for the Radar layer, select **View -> Times -> Match Time Driver**.
   l. To apply the previous step to the data, the data must be reloaded. In the **Layer Controls** tab of the **Data Explorer** for the Radar layer, select **File -> Reload Data**.

Note: All three methods of setting the layer to match the time driver only displayed times of the data that matched up with the Time Animation Widget times. With the hourly intervals of METAR data, every observation over the previous five hours was displayed. With satellite data having 30 minute intervals on the server, every other image was displayed over the previous five hours. Finally, Radar data can come in around 15 times an hour, meaning that every 15th Radar image was displayed over the previous five hours.
## Zooming, Panning, and Rotating Controls

<table>
<thead>
<tr>
<th>Zooming</th>
<th>Panning</th>
<th>Rotating</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Mouse</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Shift-Left Drag:</strong> Select a region by pressing the <em>Shift</em> key and dragging the left mouse button. <strong>Shift-Right Drag:</strong> Hold <em>Shift</em> key and drag the right mouse button. Moving up zooms in, moving down zooms out.</td>
<td><strong>Control-Right Mouse Drag:</strong> Hold <em>Control</em> key and drag right mouse to pan.</td>
<td><strong>Right Mouse Drag:</strong> Drag right mouse to rotate.</td>
</tr>
<tr>
<td><strong>Scroll Wheel</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Scroll Wheel-Up:</strong> Zoom Out. <strong>Scroll Wheel-Down:</strong> Zoom In.</td>
<td></td>
<td><strong>Control-Scroll Wheel-Up/Down:</strong> Rotate clockwise/counterclockwise. <strong>Shift-Scroll Wheel-Up/Down:</strong> Rotate forward/backward clockwise.</td>
</tr>
<tr>
<td><strong>Arrow Keys</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Shift-Up:</strong> Zoom In. <strong>Shift-Down:</strong> Zoom Out.</td>
<td><strong>Control-Up arrow:</strong> Pan Down. <strong>Control-Down arrow:</strong> Pan Up. <strong>Control-Right arrow:</strong> Pan Left. <strong>Control-Left arrow:</strong> Pan Right.</td>
<td><strong>Left/Right arrow:</strong> Rotate around vertical axis. <strong>Up/Down arrow:</strong> Rotate around horizontal axis. <strong>Shift-Left/Right arrow:</strong> Rotate Clockwise/Counterclockwise.</td>
</tr>
</tbody>
</table>