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Image 1: The McIDAS-V main display window.

What is McIDAS-V?
McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 35-year history of
sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-
dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's
VisAD and Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands and tasks in the
McIDAS-V environment, and an integrated version of SSEC's HYDRA software package.

This McIDAS-V User's Guide is currently under construction. Once completed, it will describe using the features available in the McIDAS-V
application. For a brief description about getting started using McIDAS-V and making displays of common data available, refer to the Getting
Started section.

This Guide was originally developed at the Unidata Program Center by the developers of the Integrated Data Viewer (IDV). The first version of
the McIDAS-V User's Guide was created from the IDV User's Guide (September 2007) and has since been updated to reflect the changes that
have been made to McIDAS-V, IDV, and VisAD (see the Release Notes for details on recent changes).

Development of McIDAS-V is ongoing at the Space Science and Engineering Center (SSEC) at the University of Wisconsin-Madison. The
development is driven by the needs of the community of users. Suggestions, comments, and collaboration are welcomed and encouraged. See
Documentation and Support for more information. The goal is to provide new and innovative ways of displaying and analyzing Earth science data,
as well as provide common displays that many of its users have come to expect.

How can I get McIDAS-V?
See Downloading and Running McIDAS-V for information on how to download McIDAS-V, install McIDAS-V, and run McIDAS-V. For
additional information, refer to the latest McIDAS-V training materials.
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Release Notes
The items below list the changes in McIDAS-V for the most recent released versions. For a current list of known bugs and requested
enhancements, please see the Open Inquiries Report from the McIDAS-V Inquiry System.

 

McIDAS-V 
Version 1.0

The items below reflect changes since the 1.0beta7 release.

Documentation Changes
Updated Content

Other Changes
Improved functionality when saving bundles

Documentation Changes

Updated Content

The McIDAS-V User's Guide has been updated with more detailed content.

 
Other Changes

Improved functionality when saving bundles

The known bugs in version 1.0beta7 have been fixed.

McIDAS-V 
Version 1.0beta7

The items below reflect changes since the 1.0beta6 release.

Documentation Changes
Updated Content

Other Changes
Improved functionality when saving bundles

Documentation Changes

Updated Content

The McIDAS-V User's Guide has been updated with more detailed content.

Other Changes

Improved functionality when saving bundles

One known problem that will be addressed in the next version occurs with zipped data bundles containing image data. When the bundle is
saved it only saves one band per data source, but the problem occurs when the bundle is reloaded. All of the original bands are listed in the
Field Selector, but they all reference the one band that was saved. Also, if the different bands were loaded or displayed with different
geographical coverages, all of the bands will be loaded and displayed with the same geographical region as the first selection.

McIDAS-V 
Version 1.0beta6

The items below reflect changes since the 1.0beta5 release.

Documentation Changes
Updated Content
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Display Changes
New Image Rendering Option
Grid Smoothing

Data Changes
New Grid Diagnostics

Other Changes
New Directory Structure
New Satellite Image Chooser
New ADDE Data Manager

Documentation Changes

Updated Content

The McIDAS-V User's Guide has been updated with more detailed content.

Display Changes

New Image Rendering Option

Added new "Enable access to image data by reference" option in Advanced tab of User Preferences to reduce likelihood of jagged edges at
limb and gaps at dateline.

Grid Smoothing

New grid diagnostics are available in this release. The following have been added:

PVOR(S,V) - Potential Vorticity
QVCL(THTA,V) - Q-Vectors in a layer
SAVG, SAVS - Average over a grid
SM5S, SM9S, SM5V, SM9V, GWFS, GWFV - grid smoothers (5-point, 9-point, Gaussian)

You can use the Grid->Define a grid diagnostic formula to use these functions.

Data Changes

New Grid Diagnostics

Selected grid displays (contours, flow vectors, wind barbs) now have an option to perform smoothing functions on the grid. The GEMPAK 5-
point (SM5S), 9-point (SM9S) and Gaussian Weighted Function (GWFS) smoothing functions have been implemented in McIDAS-V.

Other Changes

New Directory Structure

Renamed the .mcidasv directory to McIDAS-V to make user files more easily accessible.

New Satellite Image Chooser

Redesigned the Satellite Imagery Chooser to include new options, such as an optional preview image in the Region tab of the Field Selector.

One known problem that will be addressed in the next version occurs with zipped data bundles containing image data. When the bundle is
saved it only saves one band per data source, but the problem occurs when the bundle is reloaded. All of the original bands are listed in the
Field Selector, but they all reference the one band that was saved.

Users are encouraged to use this new chooser. Please notify us (via the McIDAS-V Support Forums or McIDAS Help Desk) if you feel there is
something in the previous chooser that should be implemented in the new chooser. The previous chooser is available through the Legacy
Choosers tree.

New ADDE Data Manager

Redesigned the ADDE Data Manager to be more intuitive and include separate local and remote managers.

McIDAS-V 
Version 1.0beta5

The items below reflect changes since the 1.0beta4 release.

Documentation Changes
Updated Content
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Other Changes
Clock Added to Main Display Window
Scatter Analysis with Gridded Data
Fixes to Startup Manager
GOES-R Color Tables Added

Documentation Changes

Updated Content

The McIDAS-V User's Guide has been updated with more detailed content.

Other Changes

Clock Added to Main Display Window

A clock has been added to the Main Display window. To switch between the memory monitor and the clock, left click on the clock/monitor to
switch back and forth.

Scatter Analysis with Gridded Data

The ability to create scatter diagrams was inadvertently omitted from the 1.0beta4 version of McIDAS-V. This function has been restored in
1.0beta5.

Fixes to Startup Manager

A fix has been made to address a problem with the startup manager if used the first time McIDAS-V is installed.

GOES-R Color Tables Added

Color tables to be used with GOES-R data have been added to McIDAS-V. For more information, see the Color Tables section.

McIDAS-V 
Version 1.0beta4

The items below reflect changes since the 1.0beta3 release.

Documentation Changes
Updated Content

Other Changes
Updated Choosers
Opening New Windows on OSX
Spiky Isosurfaces
New Version of netCDF library

Documentation Changes

Updated Content

The McIDAS-V User's Guide has been updated with more detailed content.

Other Changes

Updated Choosers

Several of the Data Choosers have been updated for consistency.

Opening New Windows on OSX

A fix has been made to address the freezing problem that occurred when opening a new window on OSX.

Spiky Isosurfaces

A change has been made that fixes several threading related problems, including spiky isosurfaces, sharing probes, and other issues.

New Version of netCDF library
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The netCDF-Java library has been updated to version 4.0.



System Requirements
McIDAS-V should run on any platform that fully supports Java and Java 3D. It has been tested on Linux, Mac OS X, Solaris, and Windows.
AIX and IRIX support the requirements in certain configurations, but have not been tested.

It is recommended that an Intel system running McIDAS-V have at least a 1.2 GHz processor and 1 GB memory (RAM). Please note that Java
on 32 bit operating systems can only utilize 1536 MB, while 64 bit operating systems can utilize all of the available memory. Performance will be
better with faster processors and more memory.

Detailed requirements for the following are listed below:

Operating Systems
Graphics Cards
Java Versions
System Memory and Processor Speed
Internet Connection for Downloading McIDAS-V and Accessing Data

Operating Systems

McIDAS-V is known to run on the following operating systems:

OS Tested at SSEC (1)

Linux Red Hat Enterprise Linux WS 4.0 (32 bit)
Red Hat Enterprise Linux WS 5.0 (64 bit)

Mac OS X Mac OS X 10.6(2)

Solaris Solaris 10 OS (x86 and SPARC) Platform Edition

Windows Windows XP with Service Pack 3
Windows Vista with Service Pack 2

NOTE: 
(1)The local ADDE servers are distributed as binaries compiled only on these Operating System versions. If you are running versions
other than those listed, the local ADDE servers may not work and give you an error message that the "Local Server is not running". 
(2)Due to changes in the requirements of the netCDF package, McIDAS-V requires Java 1.6. Some Mac OS X systems do not support
Java 1.6 and thus are unable to run McIDAS-V. These include:
- All with PPC processors
- Intel Core Solo and Core Duo running OS X 10.5 or earlier

Graphics Cards

McIDAS-V works on systems with graphics cards that support OpenGL (all systems) and Direct-X (version 8.0+, Windows only). On Linux, the
driver must support GLX, an X windows system extension to OpenGL programs. McIDAS-V also works on systems with stereo video cards. If
you are purchasing a new system, we have seen the best results with NVIDIA hardware and drivers.

McIDAS-V utilizes the latest developments in Java3D programming and video driver updates. If you encounter any problems with system
instability (such as using all of the memory or CPU on your machine, or frequent software crashes) or unusual data displays with "torn" or "gray"
images, you should make sure you have the latest video driver for your system. Even if the system is brand new, the video driver may not be the
most recent version available.

Please Note: We have found that Lenovo products with the GM965 chipset running Windows are not compatible with Java3D and
thus will not work with McIDAS-V.  Other Intel chipsets such as the GMA950 are known to work.

To determine the brand and driver information of your graphics card, follow the guides for each platform below:

Windows
From the Start menu click on Control Panel (click Start->Settings->Control Panel if you have the Classic Start menu), select
Appearance and Themes and double click on Displays (double click on Displays if you have the Classic Control Panel menu). The
graphics card brand and driver information will be under the Adaptor tab.

Linux
Open a command terminal and type the following command "lspci -v". The graphics card information will be listed under "VGA
compatable controller".

Mac OS X
Open the Apple menu and select "About This Mac". Click on the "More Info..." button to open up the System Profiler. Click on
"Graphics/Displays" under the Hardware list on the left hand side.

Once you have determined your graphics card brand and driver information, check the manufacturers web page for information on their updated
versions. Here are links to some of the most common graphic card Original Equipment Manufacturers (OEM):

NVIDIA
Desktop - http://www.nvidia.com/Download/index.aspx?lang=en-us
Laptop - http://www.nvidia.com/object/notebook_drivers.html

ATI - http://support.amd.com/us/gpudownload/Pages/index.aspx

Intel - http://downloadcenter.intel.com/

Java Versions
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McIDAS-V runs on any platform that supports:

Java version 1.6+ (non-beta versions only) AND
Java 3D version 1.3.1+

McIDAS-V is packaged with the following versions included:

 Versions Included with McIDAS-V
JRE (Java Runtime Environment) Java3D JOGL (Java OpenGL)

Linux(1) 1.6.0 1.5.2 n/a
Mac OS X included with Mac OS X(2) 1.5.2 1.1.1
Solaris(3) 1.6.0 1.5.2 n/a
Windows(4) 1.6.0 1.5.2 n/a
other unix none none n/a

The necessary versions of the JRE, Java3D and JOGL are included with the Linux, Mac OS X, Solaris, and Windows installers. On other
platforms, you will need to install Java and Java3D before installing McIDAS-V. If other platforms fully support Java version 1.6+ and Java 3D
version 1.3.1+ (e.g. AIX, IRIX), they should also work, but have not been tested.

NOTES: 
(1)The version of the Mesa library that comes with Red Hat Linux may be incompatible with Java 3D packaged with McIDAS-V. If
you experience X server crashes when exiting McIDAS-V, you will need to build and install Mesa from source available at
http://www.mesa3d.org. 
(2)To find and/or update your default Java version, follow these steps:

1. Open the "Java Preferences" application located in /Applications/Utilities
2. Look for "Java SE 6" in the "Java Applications" section
3. The version at the top of the "Java Applications" list is the version being used by McIDAS-V. If "Java SE 6" is not at the top of

the list, click and drag it to the top of the list (using the 64-bit option, if available). If "Java SE 6" is not in the "Java
Applications" list, you may need to manually run the Software Update feature in the Apple Menu.

(3)OpenGL must be installed for Java 3D to run on Solaris. 
(4)You must have DirectX version 8.0+ installed on your Windows system if you use the DirectX rendering mode of Java 3D (the
default is to use OpenGL).

System Memory and Processor Speed

McIDAS-V can be demanding of hardware speed and memory depending on the size of the datasets you wish to work with. It is recommended
that the system have a minimum of 512 MB of RAM free for McIDAS-V use. Performance is significantly better with 1 GB RAM or more.
Please note that 32 bit Java Runtime Environments (JRE) can utilize a maximum of 1536 MB RAM, while 64 bit JREs can utilize all of the RAM
available to the operating system (64 bit OS required).

The recommended processor speed will vary by platform. You can run on a system as slow as 500 MHz or even less, but response will be
correspondingly reduced. In general, the faster the processor, and the more memory your system has, the better the performance will be.

For reasonable performance, it is recommended that an Intel system running McIDAS-V have at least a 1.2 GHz processor and 1 GB memory
(RAM). Performance will be even better with faster processors and more memory.

Internet Connection for Downloading McIDAS-V and Accessing Data

You will need about 100 MB disk space for the installer file, which will uncompress into twice that size. You will have to download the installer
file in order to begin installing McIDAS-V.

McIDAS-V is designed to access data on remote servers on the Internet, as well as from local files. Downloading data from remote servers
benefits from a fast connection to the Internet, since many data fields are large.

http://www.mesa3d.org/


Downloading and Running McIDAS-V

Note: McIDAS-X users who install McIDAS-V and want to run their McIDAS-X commands in the McIDAS-V environment via the Bridge must
also be running McIDAS-X version 2007a or greater. Sites that have joined the McIDAS Users' Group and purchased McIDAS-X support can
download the current version of McIDAS-X from the McIDAS-X Downloads page.

If you have any trouble downloading and installing McIDAS-V, first check the FAQ, then please report your problem as described in McIDAS-V
Support.

This page contains information on:

Downloading McIDAS-V
Installing McIDAS-V
Running McIDAS-V
Setting Memory Usage
Downloading McIDAS-V Source Code

Downloading McIDAS-V
Check that your system meets the System Requirements for McIDAS-V and download the appropriate package for the following operating
systems:

Linux - 32 bit
Linux - 64 bit
Mac OS X - Intel
Solaris - SPARC
Solaris - x86
Windows
All other UNIX (no Java binaries included)

Note: This file is just the installer and can be placed anywhere on your machine. When you run the installer in the next step, you can
then indicate where you want McIDAS-V to be installed.

Installing McIDAS-V
Start the installer by following the instructions appropriate for your operating system:

Linux    open a terminal window and run sh ./<installer>.sh

Mac OS X    mount the .dmg and double-click the installer

Solaris    open a terminal window and run sh ./<installer>.sh

Windows    double-click the downloaded .exe file

All other UNIX    open a terminal window and run sh ./<installer>.sh

A GUI will walk you through the installation steps and allow you to create a program group and/or desktop icon.

If an error occurs, please see the FAQ for information on solutions to common errors reported by users installing and running McIDAS-V. If you
do not see your error listed, please send a support request to McIDAS-V Support.

Running McIDAS-V

On Mac OS X:

Double-click on the McIDAS-V shortcut icon that was created in /Applications.

On Windows:

Double-click on the McIDAS-V shortcut icon that was created on the Desktop.

On all other platforms:

At the UNIX prompt from the directory where McIDAS-V was installed, run the command: McIDAS-V/runMcV.

If an error occurs, please see the FAQ for information on solutions to common errors reported by users installing and running McIDAS-V. If you
do not see your error listed, send a support request to McIDAS-V Support or use the Support Request Form in the Help menu of McIDAS-V.

Setting Memory Usage
By default, McIDAS-V uses 80% of the available memory on your machine. The maximum amount of memory is determined by the operating
system. To manually change the amount of memory used by McIDAS-V, edit the Maximum Heap Size in the Advanced tab of the Preferences
by selecting Edit->Preferences... from the main menu. The new amount of memory will be saved and used in subsequent sessions. For 32 bit
operating systems, it is recommended to set this to no more than 1250 MB. The maximum value for 32 bit operating systems is 1536 MB. If you
had a previous alpha version of McIDAS-V installed, it will default to the value used in prior sessions. To change the amount of memory used to
a percentage, select the percentage option in the Advanced tab of the Preferences by selecting Edit->Preferences... from the main menu.

Downloading McIDAS-V Source Code
The source code for McIDAS-V is available for download. For instructions on building McIDAS-V from source, see the Building McIDAS-V
from Source document.
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Data Formats and Sources
McIDAS-V can read a variety of data formats either from local files or remote data servers (e.g., HTTP, TDS, ADDE) (1). This page contains
information about some data sources that work with McIDAS-V.

To connect McIDAS-V to data sources, see Choosing Data Sources.

Supported Data Types and Formats
Remote Data Servers
netCDF files
ASCII Text Point Data

Supported Data Types and Formats
Data Type Description Supported Formats Access method

Gridded
Numerical weather prediction models,
climate analysis, gridded oceanographic
datasets, NCEP/NCAR Reanalysis

- netCDF (2) - local files, HTTP, TDS (3)
servers

- GRIB (versions 1&2) - local files, TDS servers
- Vis5D - local files, HTTP
- GEMPAK - local files, TDS servers

Satellite
Imagery

Geostationary and polar orbiter satellite
imagery, derived satellite products

- ADDE (4) - ADDE servers

- McIDAS AREA - local files, local & remote ADDE
servers

- GINI - local files, TDS servers
- AMSR-E Level 1b - local ADDE
- AMSR-E Rain Product - local ADDE
- EUMETCast LRIT - local ADDE
- Meteosat OpenMTP - local ADDE
- Metop AVHRR Level 1b - local ADDE
- MODIS L1b MOD02 (MODIS Level 1b) - local ADDE
- MODIS L2 MOD04 (Level 2 Aerosol) - local ADDE
- MODIS L2 MOD35 (Level 2 Cloud Mask) - local ADDE
- MODIS L2 MODR (Level 2 Corrected
Reflectance) - local ADDE

- MSG HRIT - local ADDE
- NOAA AVHRR Level 1b - local ADDE
- SSMI (TeraScan netCDF) - local ADDE
- TRMM (TeraScan netCDF) - local ADDE

Radar NEXRAD Level II and Level III radar data

- Level II
- local files or TDS 
(bzip2 compressed or
uncompressed)

- Level III - ADDE servers, local files or TDS
- Universal Format  
- Dorade  

Point
Observational

Surface observations (METAR and
SYNOP), earthquake observations

- ADDE - ADDE servers
- netCDF (Unidata, AWIPS/MADIS formats) - local files
- Text (ASCII, CSV), Excel spreadsheet (5) - local files

Trajectory Aircraft observations - netCDF (RAF convention) - local files
- Text (ASCII, CSV) (5)  

RAOB Global balloon soundings
- ADDE - ADDE servers
- netCDF (Unidata, AWIPS/MADIS formats) - local files
- CMA text format - local files

Profiler NOAA Profiler Network winds - ADDE - ADDE servers

GIS Data typically used in Geographic
Information Systems (GIS)

- ESRI Shapefile - local files, HTTP
- USGS DEM - local files

QuickTime QuickTime movies (without extensions) - QuickTime - local files, HTTP

Remote Data Servers
Extensive meteorological and oceanographic data is available from remote data servers for use in research and education. Some of these data have
restrictions on their use, see here for that information.
Abstract Data Distribution Environment (ADDE)
Most of the data choosers in McIDAS-V use ADDE as the access method (satellite imagery, Level III radar, surface, profiler and RAOB). The
ADDE choosers are pre-configured with a list of available servers. SSEC and the Unidata community each maintain a set of cooperating ADDE
servers which serve up real-time and archived atmospheric datasets for use in McIDAS-V. You can use any of these to access the near-realtime
data. For more information on accessing data on ADDE servers, see the Choosing Data Sources section.

SSEC image data sets include:

chinook.ssec.wisc.edu
NPRT: Aqua and Terra Arctic composites and granules.
SPRT: Aqua and Terra Antarctic composites and granules.

rets1.ssec.wisc.edu
CIMSSP1: GOES East and West Cloud mask, imager CTP and ECA, and sounder products.

rets2.ssec.wisc.edu
CIMSSP2: GOES NH and SH wildfire products and GOES sounder products.

rets3.ssec.wisc.edu
CIMSSP3: GOES East and West products (CAPE, LI, TPW, Eff Cld, Ctop Pr).
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Additional image data sets:

adde.ucar.edu*
RTIMAGES: GOES East and West images in native view, not remapped. Also some global Mollweide images, and an Antarctic
composite.
GINIEAST: GOES East images, remapped to conic, Mercator (cylindrical equidistant), or polar projections channel 1.
GINIWEST:GOES West images, remapped to conic, Mercator (cylindrical equidistant), or polar projections channel 2.
GINICOMP: GINIEAST AND GINIWEST composites.
CIMSS: products derived from one or more channels, made by CIMSS, SSEC.
NEXRCOMP: composites of NEXRAD imagery (1km, 6km, 10 km radar coded message, 1-hour precip total, storm total precip).

goessouth.unidata.ucar.edu
SOUTH: GOES South (GOES-10) imager and sounder coverage of South America.

nanuk.eosdis.nasa.gov
NANUK: Aqua and Terra 1km, 500m, and 250m resolution images.

satepsanone.nesdis.noaa.gov
PUB: FY2C, METEOSAT-9 (6-hourly) and MTSAT imagery. GOES-East and West imagery and products.

You can configure defaults for particular images by creating a custom defaults file. For more information, see Configuring Image Defaults.

*Additional alternate servers include: adde.cise-nsf.gov, idd.unl.edu, stratus.al.noaa.gov, twister.millersville.edu, weather2.admin.niu.edu, and
weather3.admin.niu.edu. These alternate servers have most or all of the datasets listed under adde.ucar.edu.
THREDDS Data Server (TDS)/OPeNDAP
McIDAS-V can access gridded data (netCDF/GRIB/GEMPAK) and NEXRAD radar data stored on a THREDDS Data Server (TDS) through the
OPeNDAP (formerly called DODS) protocol. See Choosing a Cataloged Data for more information.
HTTP
Many of the data sources listed in the table above can read files directly from web servers (e.g. Apache) through the HTTP protocol. In most
cases, the server must support the HTTP 1.1 protocol and be configured to set the "Content-Length" and "Accept-Ranges: bytes" headers. See the
Choose a URL for more information.

netCDF files
The Network Common Data Form (netCDF) provides a common data access method for Unidata applications. This format can be used to store a
variety of data types that encompass single-point observations, time series, regular grids, and satellite and radar images. The mere use of netCDF
by itself is not sufficient to make data "self-describing" and meaningful to McIDAS-V.

Generally, McIDAS-V requires that datasets in netCDF format use meta data conventions to be able to fully understand and geolocate the dataset.
These conventions provide documented "best practices". Using conventions with netCDF ensures your data is complete and self-describing, and
can be used by others. We recommend you use CF, COARDS, or NUWG conventions for netCDF data files for McIDAS-V, and be sure to
follow the best practices noted above.

ASCII Text Point Data
McIDAS-V can read point data and trajectories (aircraft tracks) from comma-separated value (CSV) text files. See the documentation on the Text
(ASCII) Point Data Format.
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Documentation and Support
Where to find Help and Support for McIDAS-V
If you are having problems installing or using McIDAS-V, or want to know how to perform a particular task, you have several resources to assist
you.

McIDAS-V Documentation
Other Sources of Help

McIDAS-V Documentation
The first source of support is this McIDAS-V User's Guide. It contains complete instructions for downloading, installing, running, and using the
McIDAS-V reference application and all its features. It also has a Frequently Asked Questions (FAQ) section with answers to many of the most
commonly asked questions. The User's Guide can be accessed from the McIDAS-V Help->User's Guide menu or online at
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/current/.

Additional documentation is available on the McIDAS-V homepage (http://www.ssec.wisc.edu/mcidas/software/v/), including, McIDAS-V
training materials (tutorials and data used in training sessions) and McIDAS-V source code.

Other Sources of Help
If you have questions or encounter problems that the McIDAS-V documentation (described above) doesn't provide sufficient help, there are two
additional sources of help. They are the McIDAS-V Support Forums and the McIDAS Help Desk.

The McIDAS-V Support Forums contain subject-based forums, each with topics and posts relating to the forum's subject. Only registered users
can post on the forums. However, anyone can view the forums and their contents (i.e., visit as an unregistered "Guest").

The McIDAS Help Desk is staffed during business hours with user-support personnel. As noted in the MUG Policy Document, the help desk is
supported by the fees paid by the McIDAS Users' Group (MUG) and thus provides advanced-level support for MUG members. For McIDAS-V
all users (whether or not a MUG member) are welcome to contact the help desk to report software bugs or suggest improvements (enhancements).

When reporting a bug, first check for related error messages in the McIDAS-V Console, and include the appropriate error messages in your email
message. Also include as much information as you can about how you were running McIDAS-V and what happened, including:

the version of McIDAS-V that you are using (use the Help->About McIDAS-V menu.)
your operating system and version level
any messages on the console (to see the console, use the Help->Show Console menu.)
exact data source and parameter choice
types of display being made and in use
the sequence of McIDAS-V actions and choices that caused the problem
a bundle file that recreates the problem if the data sources are network accessible (optional, but desirable)

Send this information to the McIDAS Help Desk using one of the three methods below.

1. Fill out the support form available from the Help->Support Request Form menu. Please include as much information as possible about
the problem. (This is the preferred method.)

2. Fill out the contact form available on the McIDAS Website. Please include as much information as possible about the problem.
3. You may contact McIDAS User Services or the McIDAS Help Desk by postal mail at the following address:

McIDAS User Services 
Space Science and Engineering Center 

University of Wisconsin-Madison 
1225 West Dayton Street 

Madison, WI 53706
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FAQ - Frequently Asked Questions
This section contains a list of questions commonly asked by users. The questions are organized by categories, including General, Using McIDAS-
V, Data, Video Cards, Potential Problems, Common Installation Error Messages, Common Run-Time Error Messages, and Reporting Problems.

 
General

What is McIDAS-V?

Is McIDAS-V still under development?

Using McIDAS-V
Where are the McIDAS-V files stored on my computer?

How can I tell if McIDAS-V is busy doing something?

How can I save a display?

How can I change the start-up settings?

How can I change the amount of memory available to McIDAS-V?

How can I have McIDAS-V start with a particular window size and placement?

How can I reset the map projections?

How can I set the default projection?

How can I change the color table range?

How can I stop McIDAS-V from asking if I really want to exit?

When I set a color table transparent, why doesn't it show up that way?

Data
What is Fast Rendering and when should I use it?

What is the difference between true wind vectors and regular wind vectors?

What is the difference between the Standard Atmosphere and Vis5D pressure to height conversion?

Can I view Level III Radar data in McIDAS-V?

Can I view Level II Radar data in McIDAS-V?

Why do I get an error when I try to load radar data that I downloaded from NCDC?

When I try to read in my GRIB data, why do I get an ucar.grib.NotSupportedException?

How are grids resampled in McIDAS-V?

Why can't I create a time series from single time grids?

Video Cards
Do I need a special video card to run McIDAS-V?

Why does the display go grey or get corrupted when I resize my McIDAS-V display?

If I'm having problems with the OpenGL version under Windows, can I run the Direct-X version Java 3D?

Potential Problems
How do I connect to remote servers through my firewall?

Why do I get an error that starts something like "Unexpected Signal : 11 occurred at PC=0x6F79CE1" when starting McIDAS-V under
Linux?

Common Installation Errors
Upgrade JDK

Write Permissions Error on OSX

Shortcut Permissions Error on OSX

Common Run-Time Errors
Could not create a graphics configuration

JAVA 3D Error: GLX extension is not supported
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Problems connecting to the listed data servers

Drawing problems on Monitor2 of a two-monitor system

No Map in the McIDAS-V main display window

Reporting Problems
What kind of support is provided for McIDAS-V?

How do I report problems?

How do I open the Error Logs Console?

What do I do if McIDAS-V has locked up and is not responding?

General

Q. What is McIDAS-V?

A. McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in the Space Science and
Engineering Center's (SSEC) 35-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including
hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful
mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries, and contains "Bridge" software that enables
McIDAS-X users to run their commands and tasks in the McIDAS-V environment, and an integrated version of SSEC's HYDRA software
package.

Q. Is McIDAS-V still under development?

A. Development of McIDAS-V is ongoing at SSEC and as it progresses new features will be added and any problems/bugs will be fixed. The
development will be driven by the needs of the community of users. Suggestions, comments and collaboration are welcomed and encouraged.
The goal is to provide new and innovative ways of displaying and analyzing data, as well as provide the common displays that many users
have come to expect.

Using McIDAS-V

Q. Where are the McIDAS-V files stored on my computer?

A. McIDAS-V files are divided into two categories: "system files" (supplied files that should not be edited) and "user files" (new user-created
files and supplied ones that contain user settings and preferences). By default, the system files are stored in a directory named McIDAS-V-
System and the user files are stored in a directory named McIDAS-V. The system file directory can be changed during installation and its
location defaults to the OS application directory (e.g., C:\Program Files on Windows, /Applications on OS X). The user file directory is
created in the user's document directory (e.g., C:\Documents and Settings\user\ on Windows, /Users/user/Documents on OS X, /home/user
on Linux).

Q. How can I tell if McIDAS-V is busy doing something?

A. The lower right corner of the main McIDAS-V window shows a box with progress bars if McIDAS-V is busy making a display or doing
anything. In the status bar at the bottom, messages will appear when McIDAS-V is reading data from a server or disk. Also, while the displays
are being created, there is usually a "please wait" notice in the lower left corner of the main display.

Q. How can I save a display?

A. McIDAS-V supports JPEG, PNG, and GIF image formats. McIDAS-V can also write out an image and the corresponding Google Earth
KML or KMZ file. Animations can be captured as Quick Time movies or animated GIFs. See Image Captures for more information.

You can save a particular McIDAS-V state with all displays, data sources, maps, map projection, view point, and color tables, by saving a
"bundle" file with the File->Save Bundle. menu, and naming a file. See Saving State with Bundles. A bundle file lets you reset McIDAS-V to
exactly the same state as before. The file can be emailed to others to recreate your McIDAS-V display, provided they have access to the same
data sources.

Using the favorite bundles with File->Save Favorite menu you can save and use several configurations which are retrieved with the Bundles-
>Favorite Bundles menu.

Q. How can I change the start-up settings?

A. You can customize many of the McIDAS-V properties through Edit->Preferences menu. The preference manager allows you to configure
the many features of McIDAS-V.

You can also create a default McIDAS-V state and save it using the bundle facility. This allows you to override the preferences and also
include datasets and displays to load when McIDAS-V starts. To save a default bundle, use the File->Default Layout->Save menu. See
Saving State with Bundles.
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Q. How can I change the amount of memory available to McIDAS-V?

A. By default, McIDAS-V allocates 512 MB of maximum memory for Java. If your system has more than 1 GB of memory, increasing the
amount of memory available to McIDAS-V can improve performance for displaying large datasets. You can change the amount of memory
used by McIDAS-V by editing the Maximum Heap Size in the Advanced tab of the Preferences by selected Edit->Preferences... from the
main menu. Please note that 32 bit Java Runtime Environments (JRE) can utilize a maximum of 1536 MB RAM, while 64 bit JREs can utilize
all of the RAM available to the operating system (64 big OS required). The new amount of memory will be saved and used in subsequent
sessions. Do not use the maximum amount of memory on your machine as some is needed for the operating system itself. If the system has to
use swap memory, performance will degrade as well. See Running McIDAS-V for more information.

Q. How can I have McIDAS-V start with a particular window size and placement?

A. You can save a particular McIDAS-V set-up, so that subsequent sessions start with the same window arrangement and contents. With
McIDAS-V running, move and re-size the display and data source windows to the arrangement you like. Save the "default layout" with the
File->Default Layout->Save menu. The next time you start McIDAS-V the same arrangement will appear.

Q. How can I reset the map projections?

A. This can be controlled with the Projections->Auto-Set Projection menu check-box. When checked on, the map projection will be
automatically switched to match the native projection of the newest data source added. When checked off, the current map projection will
remain for any additional data source added to the display. This may be desirable when you have set up a view of a particular area and want to
retain it when displaying new data.

You can switch an existing display to its native data set projection using the display control's View->Use Data Projection menu.

Q. How can I set the default projection?

A. The default map projection can be set with the Projection Manager which is accessed from the Projections->New/Edit menu. Select one of
the items in the Default pull down list. The default projection is overridden by the projection saved in the default bundle, or by displaying new
data, if the Projections->Auto-Set Projection menu checkbox is checked on. As a result, you may never see the default map projection unless
your default bundle has the default projection, and you have the checkbox checked off. Choosing a default map projection is not necessary for
good use of McIDAS-V and you can ignore it if you like. It is often simpler to use default bundles.

Q. How can I change the color table range?

A. Many displays have a color table controlling the colors of data values. A color table has a range of minimum and maximum data values.
You can change the range for a display by right clicking on the color bar in the display's legend and selecting the Change Range... menu from
the popup menu. For more information on controlling the color table, see the Color Table Editor documentation.

Q. How can I stop McIDAS-V from asking if I really want to exit?

A. Many features of McIDAS-V can be changed though the User Preferences dialog. Use the Edit->Preferences menu to bring up the dialog.
On the General tab, uncheck the "Confirm Before Exiting" box to stop McIDAS-V from asking if you want to exit. Another option is to check
off the "Always Ask" checkbox on the popup dialog box before exiting McIDAS-V.

Q. When I set a color table transparent, why doesn't it show up that way?

A. Using transparency in a color display may give unexpected results. In general, only the last thing added can be fully transparent. If you
have a display that is transparent, then add in a new display, you may not see it. The problem is caused by the lack of ordering in Java 3D.
You can use the display control's View->Bring to Front menu to remove and re-add the display that you want to be transparent so it is last.

Data

Q. What is Fast Rendering and when should I use it?

A. By default, McIDAS-V will try to adjust the data renderings to account for projection seams. This is computationally intensive in some
cases and slows down the display of data. When you set your preference to "Use Fast Rendering", McIDAS-V will not try to account for the
projection seams. If you are displaying data in its native projection, this will result in faster rendering of the data depiction. However, if you
have several displays of data, each from a different data source and on a different projection, you may see anomalies in the displays (spurious
lines, portions of images). At that point, you can turn off fast rendering for a particular display using the Edit->Properties menu of the
Display Control for that display, or set your system preference back to not use fast rendering.

Q. What is the difference between true wind vectors and regular wind vectors?

A. Some gridded data is produced with the wind components being relative to the model grid instead of the earth. The true wind vectors are
rotated from the grid projection to actual (true) wind direction. For non-projected grids (i.e., lat/lon grids), grid relative is the same as true.

Q. What is the difference between the Standard Atmosphere and Vis5D pressure to height conversion?

A. McIDAS-V displays pressure surfaces by converting the pressure to a height in some reference system. There are two reference systems that
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come standard with McIDAS-V - the U.S. Standard Atmosphere and Vis5D. The U.S. Standard Atmosphere only computes has conversions
for pressures up to about 80 km. The Vis5D coordinate system uses a logarithmic conversion:

P = 1012.5 * e^( H / -7.2 ) (^ denotes exponentiation) H = -7.2 * Ln( P / 1012.5 ) (Ln
denotes natural log)

so it can be used for heights above 80 km.

Q. Can I view Level III Radar data in McIDAS-V?

A. McIDAS-V can load Level III radar products through the Radar->Level III chooser which connects to an ADDE server. Starting with the
2.0 release, McIDAS-V can read some Level III products from local disk or a THREDDS Data Server (TDS). At present, this is limited to
radial products only.

Q. Can I view Level II Radar data in McIDAS-V?

A. McIDAS-V can load Level II radar products through the Radar->Level II->Remote chooser which connects to an ADDE server. The
Level II data is supplied as volume-scan files, each file having all data from one WSR-88D radar for all sweeps for one "time". Archived
Level II radar files can be displayed through the Radar->Level II->Local file chooser. The files should be stored on your file system with
each station's files in a directory (folder) whose directory name is the station 4-character ID (e.g., KTLX for Oklahoma City). In some cases the
data files do not have any location information in them and McIDAS-V uses the directory name as a first guess at the station location.
Archived Level II data is available from the National Climatic Data Center (NCDC).

Q. Why do I get an error when I try to load radar data that I downloaded from NCDC?

A. There are few common problems that can cause this:

1. The files are in a compressed tar file - Typically, when you download Level II data from NCDC, the files are in a compressed TAR
file which holds the individual volume scans. You need to extract the volumes from the TAR file with utilities like tar, gunzip, WinZip
into a directory as described in the previous FAQ item.

2. You are using the Files chooser - You should load the radar data using the Radar->Level II->Local file chooser in the Data Sources
tab of the Data Explorer, not the General->Files chooser. In some cases, the files do not have any location information in them. The
Level II data chooser allows you to associate a station location with the data file, using the directory name as a first guess.

3. You are trying to load Level III raster products - McIDAS-V only handles the Level III data that is stored in radial format (Base
Reflectivity, Storm Relative Velocity, Base Velocity, 1 and 3 hour precipitation, Echo Tops).

Q. When I try to read in my GRIB data, why do I get an ucar.grib.NotSupportedException?

A. For McIDAS-V to read in GRIB data, it needs access to lookup tables for decoding the information in the data. McIDAS-V comes pre-
configured with most of the commonly used tables from NCEP, FNMOC, etc, but some GRIB data from regional centers may use tables other
than the defaults. If McIDAS-V does not have the necessary table, you will get the NotSupportedException. You can add in new tables by
following the instructions in the User's Guide section on Adding in new GRIB tables.

Q. How are grids resampled in McIDAS-V?

A. McIDAS-V uses two methods for resampling data - weighted average and nearest neighbor. These are the default sampling modes for
VisAD, which McIDAS-V is based on. For any grid, the samples are organized in a topology, which may be triangles (Irregular2D), squares
(Gridded2D), tetrahedra (Irregular3D) or cubes (Gridded3D). For target points the system finds which topology element contains the target.
For nearest neighbor, it gets the values at the vertex of that containing topology element closest to the target point. For weighted average, it
computes a weighted average of all vertices of that containing topology element, where the weights are bilinear in 2-D and trilinear in 3-D.
(source: Bill Hibbard, SSEC)

Q. Why can't I create a time series from single time grid files?

A. If you receive an error message similar to the following:

An error has occurred: Creating display: Color-Shaded Plan View org.python.core.PyException
visad.UnitException: visad.UnitException: Set: units dimension 1 does not match Domain
dimension 2

the files may not have a "time" dimension defined in them. It is recommended that you use the NetCDF Markup Language (NcML) to
aggregate the files. See http://www.unidata.ucar.edu/software/netcdf/ncml/v2.2/Aggregation.html for more information on aggregating files.

Video Cards

Q. Do I need a special video card to run McIDAS-V?

A. Your graphics system must support 3D; make sure you have the latest video driver for your graphics card. This is included in the Windows
operating system. On Linux the driver must support GLX, an X windows system extension to OpenGL programs. See Operating System
Requirements for more information.

Q. Why does the display go grey or get corrupted when I resize my McIDAS-V display?
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A. ATI cards do not always work correctly with the OpenGL version of Java 3D under Windows. If you experience problems with corrupted
displays (sets of triangles, spurious lines, weird looking displays) and have an ATI card and are running Windows, try the following:

Right click on the Windows Desktop and select Properties from the pop-up menu.
From the Settings tab, make sure the color quality is 16 bit.
Click the Advanced button and select the OpenGL tab. Depending on your card, either click the button for Force 16 bit buffer (or
something like that) or click on the Compatibility settings button and click the "Force 16 bit" radio button.
Click the OK buttons to exit the Display Properties dialog.
Try McIDAS-V again and see if it works better.
If not, try using the Direct-X installer instead of the OpenGL installer.

Q. If I'm having problems with the OpenGL version under Windows, can I run the Direct-X version Java 3D?

A. If you are using the version of Java 3D distributed with McIDAS-V (1.3.2), you can switch between the OpenGL and Direct-X versions of
Java 3D with a command line switch. If you are using runMcV.bat to start McIDAS-V, edit that file and uncomment the appropriate line. If
you have your own script for starting McIDAS-V, add in the -Dj3d.rend=d3d option to your start line (before -jar or class name).

Potential Problems

Q. How do I connect to remote servers through my firewall?

A. If you have a firewall and are trying to get data from the remote servers (image, radar, point, upper air and profiler data), error messages
such as "Error opening connection ... Operation timed out" or "No Data Available" may occur. For these servers to send data, your firewall
software must allow connections on ports 112 (ADDE) and 8080 (THREDDS Data Server).

Q. Why do I get an error that starts something like "Unexpected Signal : 11 occurred at PC=0x6F79CE1" when starting McIDAS-V
under Linux?

A. If the error message also includes a line that is looking for a Library with "dri" in it's name (e.g.:
Library=/usr/X11R6/lib/modules/dri/i915_dri.so), it means that you are trying to load the DRI library in your X server which is not compatible
with Java 3D. You need to comment out the line:

Load "dri"

in your X server configuration file (xorg.conf or XF86Config).

Common Installation Error Messages

Error #1

A user reported --- The first time I ran the script, it told me I needed to upgrade my JDK. So I installed jdk1.6.0_03 and Java3D 1.3.1. Then
McV installed without any problem.

Error #2 - On Mac OS X only

You have no write premissions for this directory. Please choose another one. 

Solution

Browse for a writable directory (e.g. /Users/mcuser/McIDAS-V). Under "Select Additional Tasks", uncheck "Create Launcher and
Configuration shortcuts in Applications folder"

Error #3 - On Mac OS X only

At Extracting files... McIDAS-V Configuration.app/Contents/Info.plist /Applications/McIDAS-V
Configuration.app/Contents/Info.plist Could not create this file.  Shall I try again?

Solution

Click "Cancel" and restart the installer. Follow instructions under Error #2 above.

Common Run-Time Error Messages

Error #1

Could not create a graphics configuration. Please contact McIDAS-V user support or see the
FAQ.

And this error message in the shell window:

GLX version 1.3 or higher is required The reported version number may be incorrect.  There is
a known ATI driver bug in glXQueryVersion that incorrectly reports the GLX version as 1.2
when it really is 1.3, so Java 3D will attempt to run anyway.

Solution



First, check for the most updated video card driver. If the problem still remains, the 32bit Linux installer comes with an option to install
Java3D 1.3. Rerun the installer and select to install Java3D 1.3.

Error #2

JAVA 3D ERROR: GLX extension is not supported GLX version 1.3 or higher is required.

This error messages echoes to the terminal window. I also get an error popup window stating "Could not create a graphics configuration.
Please contact McIDAS-V users support or see the FAQ." At this point the McIDAS-V startup scroll bar just keeps doing it's thing until I press
"ok" in the error popup window at which point the startup exits back to the terminal window.

Solution

GLX is an extension that must be supported by the graphics card.  This error is most likely occurring because the graphics drivers for RHEL
are not properly configured.

Assuming that the latest graphics drivers are installed, they must be configured in the window system configuration file... since RHEL uses
Xorg, look in the file

    /etc/X11/xorg.conf

and see if there are any references to "GLX" or "glx" (and possibly "dri").  If there are, try uncommenting them and rebooting.

Error #3

I have the viewing and data windows and a user's guide up. But so far I can't talk to any of the listed data servers. The errors are just
'connection refused' and 'no public datasets found' on every server I've tried.

Solution

If you have a firewall and are trying to get data from the remote servers (image, radar, point, upper air and profiler data), error messages such
as "Error opening connection ... Operation timed out" or "No Data Available" are normal.  For these servers to send data, your firewall
software must allow connections on ports 112 (ADDE) and 8080 (THREDDS Data Server).

Error #4

If I move the McIDAS-V windows to Monitor2 of my two-monitor system, some things don't work correctly. For example, if I try to add a
new tab the data display section of the main display window goes blank ("grays out"), or if I try to run a bundle it fails with, "Error loading
bundle C: adding a container to a container on a different GraphicsDevice".

Solution

Some graphics card/driver combinations don't allow these functions to work in Monitor2 of two-monitor systems. For now, you can simply
move the McIDAS-V windows to Monitor1 then successfully add new tabs and run bundles.

If you are running Red Hat with a NVIDIA graphics card using TwinView and are having problems, go to the preferences, click on the primary
display, and make sure the "Make this the primary display..." checkbox is checked.

Error #5

When I start McIDAS-V the main display window is blank - there is no map. There are also no errors in the console.

Solution

Try changing your memory to use 1 GB or lower and restart McIDAS-V. You can change the amount of memory used by McIDAS-V by
editing the Maximum Heap Size in the Advanced tab of the Preferences by selected Edit->Preferences... from the main menu.

Reporting Problems

Q. What kind of support is provided for McIDAS-V?

A. For information about obtaining help and support for McIDAS-V, check out the Documentation and Support page in the McIDAS-V User's
Guide.

Q. How do I report problems?

A. First, check this FAQ and the McIDAS-V Support Forums to make sure this is a problem that has not yet been reported.

If you experience unexpected problems that are not reported in those locations, please let us know. See the Documentation and Support section
of the manual for the procedures on how to do this.

Q. How do I open the Error Logs Console?
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A. Open a console to show error logs with the Help->Show Console menu.

Q. What do I do if McIDAS-V is locked up and not responding?

A. First, you need to retrieve a stack track of the program so we can find out why this is happening. McIDAS-V provides a web-based service
that produces a stack trace. Just view the URL:

http://127.0.0.1:8788/

and send the results to mug@ssec.wisc.edu. Note: This service is only available from browsers running on the machine McIDAS-V is running
on.

You can also use this service to shutdown McIDAS-V.
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License and Copyright
McIDAS-V
Version 1.0

Copyright© 2007-2010
Space Science and Engineering Center (SSEC)
University of Wisconsin - Madison
1225 W. Dayton Street, Madison, WI 53706, USA
http://www.ssec.wisc.edu/mcidas

All Rights Reserved

McIDAS-V is built on Unidata's IDV and SSEC's VisAD libraries, and
some McIDAS-V source code is based on IDV and VisAD source code.

McIDAS-V is free software; you can redistribute it and/or modify
it under the terms of the GNU Lesser Public License as published by
the Free Software Foundation; either version 3 of the License, or
(at your option) any later version.

McIDAS-V is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU Lesser Public License for more details.

You should have received a copy of the GNU Lesser Public License
along with this program. If not, see http://www.gnu.org/licenses.

Other Licenses
McIDAS-V includes software developed by:

The University Corporation for Atmospheric Research/Unidata (IDV) (http://www.unidata.ucar.edu/software/idv/)
The University of Wisconsin-Madison (VisAD) (http://www.ssec.wisc.edu/~billh/visad.html)
The Australian Bureau of Meteorology (AIFS) (http://ssu1.bom.gov.au/pub/ims/aifs.html)
The Apache Software Foundation (http://www.apache.org/)
The Jython project (http://www.jython.org)
The JDOM project (http://www.jdom.org)
The ImageJ project (http://rsb.info.nih.gov/ij/)
The JJ2000 project (http://jpeg2000.epfl.ch/)
The JFreeChart project (http://www.jfree.org/jfreechart/)
The JCommon project (http://www.jfree.org/jcommon/)
The L2FProd.com Common Components 6.9.1 (http://common.L2FProd.com)
The jnumeric package (http://jnumerical.sourceforge.net/)
JAMA: The Java Matrix Package (http://math.nist.gov/javanumerics/jama/)
JTEM: Java tools for experimental mathematics (http://www-sfb288.math.tu-berlin.de/~jtem/numericalMethods/index.html)
FamFamFam Silk icons (http://www.famfamfam.com/lab/icons/silk/)
Tango icons (http://tango.freedesktop.org/Tango_Icon_Library)

Please read the different LICENSE files present in the root directory of the McIDAS-V distribution for restrictions on those packages.
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Getting Started
This section describes how to quickly get started using McIDAS-V and making displays of common data available.

McIDAS-V Main Windows
There are two main windows in the McIDAS-V application - - the Data Explorer window and the Main Display window. Other windows may
appear when needed.

Data Explorer
The Data Explorer window is central to McIDAS-V. It is used to choose data sources and parameters to display, the kinds of displays to make,
and times of data to display. More information about the Data Explorer can be found here.

Main Display
The Main Display (shown below with one Display Tab) includes the McIDAS-V display panels, legend, time animation controls, view point
controls for 3D displays, icons to zoom and pan, menus of projections, and the main McIDAS-V menu. More information about this window can
be found here.
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Common Usage Scenario
To create displays with McIDAS-V, the common usage scenario is:

Choosing sources of data
Selecting parameters and times and creating a display
Controlling the display
Removing the displays

Getting Started Sections
Displaying Satellite Imagery
Displaying Level III Radar Imagery
Displaying Level II Radar Imagery
Displaying Gridded Data
Displaying Surface and Upper Air Point Data
Displaying RAOB Sounding Data
Displaying Profiler Data
Displaying Fronts
Using the Globe Display
Displaying Local Files
Displaying Files From a URL
Displaying Hyperspectral Satellite Imagery Using HYDRA
Using the McIDAS-X Bridge
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Displaying Satellite Imagery
This section describes how to make displays using geostationary and polar orbiting satellite imagery.

The steps include:

Choosing Geostationary Satellite Imagery from a Remote Server

Creating the Display

Displaying a Single Polar Orbiting Satellite Image from a Remote Server

Creating a Loop of Polar Orbiting Satellite Images from a Remote Server

Choosing Satellite Imagery from a Remote Server
In the Data Explorer window select the Data Sources tab. On the left hand side of the tab, select "Satellite Imagery" from the list of available
choosers. For more information about the imagery chooser, see Choosing Satellite Imagery.

1. Choose the ADDE Server: satepsanone.nesdis.noaa.gov and the Dataset: PUB.

McIDAS-V comes pre-configured with a list of ADDE servers and datasets, or you can enter your own. See Available data for a
description of these pre-defined data sets.

2. Press Connect to query the server for available image types.
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3. Select the Image Type to use (in the example below, GEFDSK01V for GOES-East full disk band 1 visible images).

4. Choose the image time(s) you want. Either choose a set of relative times as shown in the example below (5 most recent), or a set of
absolute times as shown in step 5.

5. A set of absolute times (e.g., 08:45:00 UTC, 11:45:00 UTC).

When choosing absolute times for the first time McIDAS-V needs to query the ADDE server for the times. This may take some time. To
select more than one time use Ctrl-Click or Shift-Click.

6. Select the Navigation type (either Default or Lat/Lon). Choose Lat/Lon if you are using Level 1B or POES ADDE servers.
7. If you do not want to create a preview image in the Field Selector, uncheck 'Create preview image' box.
8. When done, load the selected image data with the Add Source button.

Creating the Display
The image data source that you selected will be shown in the Field Selector tab. The available display types are listed in the Displays panel, the
times are listed in the Times tab, the preview image or map is displayed in the Region tab, and the geographical selection parameters are listed in
the Advanced tab.

1. Select the calibration that you wish to display in the Fields panel. In this example, Brightness.
2. "Image Display" should be selected for you in the Displays panel. "Image Display" displays your data as an image and is the display type

used for satellite and Level III radar images in almost all cases.
3. Click the Region tab to view the Preview Image. Use the mouse to shift-left drag and select the geographical boundaries of your image.
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4. Click on Create Display to display the image(s). To control time animation use the Time Animation Widget.

If you want to create another type of satellite display over your current display, click "Image Contours" in the Displays panel to contour your
data. To change your contour colors, right click on the color bar in the Legend, and choose one of the color tables shown in the list. 

Displaying a Single Polar Orbiting Satellite Image from a Remote Server
Return to the Satellite Imagery chooser in the Data Sources tab of the Data Explorer. Selecting polar orbiting satellite data is similar to the method
to select geostationary data.

1. Choose the ADDE Server: nanuk.eosdis.nasa.gov and the Dataset: NANUK and press Connect to query the server for available image
types.

2. Select the Image Type to use (in the example below, Terra 250 meter resolution Calibrated Radiances).

3. Choose to display the most recent image, and click Add Source.
4. In the Fields panel, select the calibration that you wish to view.
5. When done, load the selected image data with the Create Display button.
6. The polar orbiting satellite image will be displayed on top of the existing geostationary satellite image.

Creating a Loop of Polar Orbiting Satellite Images from a Remote Server
When creating loops of polar orbiting satellite images, it is recommended that the Auto-set Projection option be turned off and a global
projection be used in the map display to ensure all images can be viewed. For this example, turn the Auto-set Projection option off by going to
the Main Window and selecting Projections->Auto-set Projection. Under the same menu, change your projection to Projections->Predefined-
>World. These options can also be used for displaying single images of polar orbiting satellite data.

1. Return to the Data Sources tab of the Data Explorer.
2. Select a different Image Type to use (in the example below, Aqua 500 meter resolution Calibrated Radiances).

3. Choose a set of either the 10 most relative times, or a set of 10 absolute times.
4. When done, load the selected images into the Field Selector with the Add Source button.
5. In the Fields tab, select the calibration that you wish to view.
6. In the Advanced tab, change the Coordinate Type to Image Coordinates. There is currently no method of determining the latitude and

longitude boundaries of multiple polar orbiting images. Using the Image Coordinates option ensures the images will be displayed.

7. When done, load the selected images with the Create Display button.
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Displaying Level III Radar Imagery
This section describes how to make displays using NWS WSR-88D Level III data.

The steps include:

Choosing Radar Image Data from a Remote Server
Creating the Radar Display

Choosing Radar Image Data from a Remote Server
In the Data Explorer select the Data Sources tab. From here select the Radar->Level III source to view the Level III radar chooser. For more
information about the Level III radar chooser, see Choosing NEXRAD Level III Radar Data.

1. Choose an ADDE Server and a Dataset to use. For this example, try Server: adde.ucar.edu and Dataset: RTNEXRAD.

 

2. Press Connect to query the server for available radars types:
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3. Select a radar product, such as Base Reflectivity Tilt 1, from the pull-down menu.

4. The map shows the available radar station locations and IDs. Select one by clicking on it.

The Decluttter check box allows you to show all stations (not checked), or only a limited number of stations that do not overlap each
other (checked). You will need to zoom in to see all the stations without overlaps.

5. Either, choose a relative set of times steps (e.g., Last 5 times):

6. Or, choose a set of absolute times:

When choosing absolute times for the first time McIDAS-V needs to query the ADDE server for the times. This may take some time. To
select more than one time use Control-Click or Shift-Click.

7. When done, load the selected radar data with the Add Source button.

Creating the Radar Display
The radar data source that you selected will be shown in the Field Selector tab.

Open up the "Base Reflectivity" tab under the Fields panel ( ) to select a data type. Select "Image display" in the Displays panel and make the
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display by clicking on Create Display.

You can add Radar Range Rings with the Display->Add Range Rings menu item. To control time animation use the Time Animation Widget.
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Displaying Level II Radar Imagery
This section describes how to make displays using NWS WSR-88D Level II data. The steps include:

Choosing Level II Radar Data
Making Level II Radar Displays
2D Displays of Individual Sweeps
3D Displays of Individual Sweeps
Pseudo-RHI Displays in 2D and 3D
All Sweeps in 3D
Radar Isosurfaces in 3D
Choosing Local Level II Radar Data

Choosing Level II Radar Data
In the Data Explorer window select Radar->Level II->Remote from the Data Sources tab to view the Level II radar chooser. The Radar-
>Level II->Local chooser allows you to choose Level II data from your file system. For more information about the Level II radar chooser, see
Choosing NEXRAD Level II Radar Data.

Select a station and a relative set of times. When done, click the Add Source button.

Making Level II Radar Displays
The data source is shown in the Field Selector tab. Level II data has three moments or data types: Reflectivity, Radial Velocity, and Spectrum
Width. McIDAS-V has several kinds of displays for Level II data. Any of the moments can be shown with any of the displays. Here we will use
examples showing reflectivity. Clicking on the "Reflectivity" entry in the Fields panel will show the list of available displays in the Displays
panel.
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Image 1: Level-II 3D Display

2D Displays of Individual Sweeps

Select the Radar Sweep View in 2D under "Radar Views" in the Displays panel and click on Create Display. Radar Sweep View in 2D plots
the data as a colored image on the base of the 3D display area. This mimics conventional PPI plots on a map.

The Radar Sweep Control allows you to change which sweep elevation you want to see. You can add range rings with the Displays->Add Range
Rings menu item. You can modify the range rings with the Radar Range Rings control.

3D Displays of Individual Sweeps
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Image 2: Level-II 3D Display

 
Image 3: Level-II 3D RHI

Select the Radar Sweep View in 3D entry in the Displays panel. Radar Sweep View in 3D plots the data as a colored image, with the data
plotted in 3D space at the elevation where the sweep occurred. You can rotate the display to see the three dimensional nature.

You can use this display to merge radar data displays with upper air data such as McIDAS-V plots of NOAA Profiler data. Since the Earth is
projected onto a flat surface in this display, the sweep has a shape very close to a rotated parabola. The Elevation Angles in the Layer Controls
tab allows you to change which sweep elevation to display.

Pseudo-RHI Displays in 2D and 3D
Select RHI in the Displays panel and press Create Display. RHI plots the data as a colored vertical cross section at the true elevations of the
beams in 3D space (Image 3). This pseudo-RHI is constructed from several horizontal sweeps of the radar. It may be necessary to rotate the
display to see the RHI in 3D.
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Image 4: Level-II 2D RHI

 

Image 5: Level-II Volume Scan

The beam width is indicated by the vertical extent of each colored vertical stripe, corresponding to a bin beam bin sample. The position of the RHI
in azimuth can be adjusted by dragging the little box on the end of the selector line above the RHI.

The 2D plot of pseudo-RHI (Image 4) is shown in the RHI Control in the Layer Controls tab (shown as undocked here). The RHI displays have
an auto-rotate feature and time animation.

All Sweeps in 3D

Select Volume Scan (all sweeps) under the Displays panel in the Field Selector tab. Volume Scan (all sweeps) plots the data as 3D field of
points colored by value. Each point is a bin value; all sweeps and bins are shown.

Radar Isosurfaces in 3D
Select Radar Isosurface under the Displays panel in the Field Selector tab. An isosurface is a 3D analog of a contour line which shows the
location of all data with a single data value. Interpolation is used between sweep altitudes in McIDAS-V isosurface plot of Level II data, and all
data in a volume scan is used. The example shown is the 46 dBZ isosurface from a line of thunderstorms crossing Alabama at 1718Z 19 March
2008.
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Image 6: Level-II Isosurface

Choosing Local Level II Radar Data
To select Level II data from the Radar Imagery->Level II->Local file chooser:

1. Navigate to the desired directory. This chooser works like the Files chooser.
2. Select one or more Level II data files. Use Control-Click or Shift-Click to select multiple files. Each file represents a full volume scan at a

particular time.
3. Alternatively, use the Use Relative Times button to select the latest N files in the directory. You can optionally use the File Pattern field to

specify the pattern for files to look for.
4. Provide a radar station name. For some Level II data, McIDAS-V requires you to provide the radar location. McIDAS-V will try to guess at

the location based on the directory name but you can specify the location using the Radar Location menu.
5. When done, load the selected radar data with the Add Source button. The local data source will be shown in the Field Selector.
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Displaying Gridded Data
This section describes how to make displays using gridded data sets. The steps include:

Connecting to a Data Source on a Remote Server
Creating a Plot of 2D Data
Creating a Plot of 3D Data
Subsetting Times
Spatial Subsetting

Connecting to a Data Source on a Remote Server
In the Data Sources tab in the Data Explorer select Gridded Data -> Remote under the "General" source. For more information about the
catalog chooser, see Choosing Gridded Data.

Choose one of the remote Catalogs: such as http://thredds.cise-nsf.gov:8080/thredds/idv/models.xml for Unidata's catalog of near real-time
model output.

A tree view of the catalog will be displayed. Open one, such as the "NCEP GFS 80km CONUS model data (real and near time)", by clicking on
one of the tab icons ( ).

The list of this model's run times appears. Click on one time to select it, and then click on the Add Source button. You have selected this model
run's output to be accessible by McIDAS-V.

Creating a Plot of 2D Data
The gridded data source that you selected will be shown in the Field Selector tab. The Field Selector tab contains folders of data categorized as
2D and 3D fields. Click on the 2D grid tab ( ) to expand that category list. A list of all 2D grid parameters in the data source appears. When
one of the fields is selected the list of applicable displays will be shown.
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Try creating a Contour Plan View by selecting that display in the list and clicking on the Create Display button. The display will be created and
shown in the main window. The display's legend should also be shown. You can bring up the control window by right clicking on the name in the
legend and selecting Control Window from the popup menu.

Creating a Plot of 3D Data
Click on the 3D grid tab to expand that category. A list of all 3D grid parameters appears. To make a plot, first click on a parameter name such as
"Geopotential height at isobaric levels."

Display types suitable for this parameter are listed in then Displays panel. Select Contour Plan View and click on the Create Display button.

The initial plot is at the lowest level in the data grid, such as 1000 millibar in this example. To shift the level to other levels:

Right click on the legend (such as "T Contour Plan View Level 1000") to get a pop-up menu.
Click on Control Window to bring up this display's Control window.
In the Control window click on the Levels: box to bring up the pop-up menu of native grid levels in the data.
Select the desired level, such as 500, from the list.

The plot will move to 500 millibars.

To zoom, rotate, or pan this 3D display, see Zoom, Rotate, and Pan. Rotate the display by dragging with the right mouse button. (You will see that
the 500 millibar contours are above the surface). The key combination Ctrl-R will restore the display to the original overhead view.

To toggle on the time animation loop, use the Run/Stop icon in the time animation controls.

To remove an existing display, use the File->Remove Display menu of the Layer Controls tab or the popup menu.
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Subsetting Times
McIDAS-V automatically loads data for all data times selected in the data selection step, and loads them as displays for an animation loop.
Creating several displays may take time. If you only need to see one data time, it is better to only create displays for that time.

To make time selections that apply to all data in one data source, double click on the data source name in the left panel of the Field Selector tab
to bring up the Data Source Properties editor. Click on the Times tab to subset the times.

Initially all times are selected for display by McIDAS-V - indicated by the times in this window being grayed out and the box "Use All" being
checked. To limit the selection to fewer times than all times, first check off the box "Use All." Then select the times you want by clicking on the
times (note: you can select multiple times with the Shift and Control keys).

To make time selections for one field, use the Times selector in the lower right panel of the Fields tab, under the Displays panel, after you select
the field, and before you create the display. This will override the default times for the data source.

Spatial Subsetting
You can also spatially subset the grid using the Spatial Subset tab of the Data Source Properties. This works similar to the times subsetting where
you can set the property for all fields in the Data Source or override the default for a particular field.
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Displaying Surface and Upper Air Point Data
This section describes how to make station model plot and contour displays using surface and upper air data. It also explains how to create and
edit station model layouts.

The steps include:

Selecting Surface Observations from a Remote Server

Creating the Plot Display

Creating the Contour Display

Creating and Editing Station Model Layouts

Selecting Surface Observations from a Remote Server
In the Data Sources tab in the Data Explorer select Plot/Contour under the "Point Observations" source. For more information about the Point
Observations Plot/Contour chooser, see Choosing Point Data.

In the Server: and Dataset: entry boxes, use the pulldown lists to select a remote server and a dataset with METAR data, such as adde.ucar.edu
and RTPTSRC. You can also type a different server name into the entry box. Click on Connect to find data on the remote server. In the Point
Type: selection box choose "Real-Time SFC Hourly." You can choose either the latest N times or select specific times. Select the times you
would like to view (note: multiple times may be selected with the Shift and Control keys) as well as the interval. Click on Add Source when you
have made your selection. Only data from today's date will be retrieved from the server.

Creating the Plot Display
The surface observation data will be shown in the Field Selector tab.
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Select "Point Data" in the Fields panel and "Point Data Plot" in the Displays panel. Make the display by clicking on the Create Display button on
the bottom of the Field Selector tab.

To declutter the display, use the Station Model Controls in the Layer Controls tab.

Upper air plots can be created the same way. In the Data Explorer, select a Point Type: of "Real-Time Upper Air (Mandatory)," change the
Interval to "12 hourly" and add the source. In the Field Selector, select a level of 500mb in the Level panel and create the display.

Creating the Contour Display
The "Gridded Fields" tree allows you to use the Barnes analysis to create gridded fields of specific point observation parameters.

Select the SFCHOURLY dataset from the left hand side of the Field Selector. In the Fields panel, open the Gridded Fields tree by clicking on
the tab icon (  )and select the temperature (T) parameter. In the Displays panel, select Contour Plan View and make the display by clicking on
the Create Display button on the bottom of the Field Selector tab.

Upper air gridded fields can be created the same way. In the Field Selector, select the UPPERMAND dataset, open the Gridded Fields tab, select
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a parameter and level, and create the display.

Creating and Editing Station Model Layouts
You can create or edit your own station model layouts by using the Station Model Editor. To access the editor, click on the double down arrow (
) and select Edit under the Layout Model: section in the Layer Controls tab or select Tools->Parameters->Plot Configurations from the main
menu. The display shows a set of axis lines which give a reference point to all the parameters in the model. The station model consists of a set of
shapes which are added by clicking on an item in the left column and then clicking where you want to place it. When a shape is created, a
property dialog box is shown which allows you to control its appearance, as well as delete an item, set its color, change font sizes, view its
properties, etc.

1. Create a new station layout model by selecting File -> New and entering in a layout name.
2. Select the  Value shape and left-click on the model layout space to add the shape.
3. A property dialog box will pop up. Under the Display tab, change the Parameter value to temperature. To do this, delete the default "value"

in the entry box, select TEMP from the dropdown list by clicking on the  arrows and selecting Aliases->Group 1->Temperature
(TEMP).

4. Optionally, change the default unit to be displayed, the font size, or other variables by using the pulldown menus. To change the foreground
or background color, click on the color swath to bring up a pallet of swatches to choose from, as well as the option to choose a color by
HSB (hue, saturation, and brightness) or RGB (red, green, and blue). When finished, click OK.

5. To move the location of the shape, left-click and drag the icon to a new location. You can change the alignment of the shape by right-
clicking and selecting Alignment Point->Choose an alignment point.

6. Follow steps 2-5 to add dewpoint temperature (Aliases->Group 1->Dewpoint) to the station layout model.
7. Select the  Windbarb shape and left-click on the model space to add the shape.
8. The property dialog box will pop up. Change the U or windspeed parameter to Aliases->Group 1->Wind Speed (SPEED) and the V or

direction parameter to Aliases->Group 1->Wind Direction (DIR).
9. If you choose to, edit the other parameters. When done, click OK.

10. Save your layout by selecting File->Save. You can edit or access other station layout models by selecting one under the Layout Models
menu. User created or edited models will have "<local>" after the name.

11. Close the station layout model editor by selecting File->Close.
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Image 1: RAOB Skew-T

Displaying RAOB Sounding Data
This section describes how to make Skew-T plots from RAOB data.

The set of steps include:

Choosing RAOB Sounding Data from a Remote Server
Creating the Sounding Display

Choosing RAOB Sounding Data from a Remote Server
In the Data Sources tab of the Data Explorer select Point Observations->Soundings->Remote. For more information about the soundings
chooser, see Choosing Upper Air Sounding Data .

For the Server and Dataset select adde.ucar.edu and RTPTSRC and click Connect. The list of stations populates in the map. Select the
station(s) you want to use. You can select one or more stations by clicking on them; hold down the Ctrl key to select more than one. You can use
the Declutter check box to show all stations (not checked), or only a limited number of stations that do not overlap each other (checked). When in
declutter mode you can zoom in (by dragging the left mouse) to see more stations. The icons below the map allow you to zoom and pan.

After you choose stations, select the available time(s) you want to view in the Available box. The list of available soundings will be displayed in
the Selected box. When you have made your selection click the Add Source button.
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Creating the Sounding Display
The RAOB data will be shown in the Field Selector tab.

Select "RAOB data" in the Fields panel and "Skew-T" or one of the other sounding types in the Displays panel. Make the sounding display by
clicking on the Create Display button. The sounding will be displayed in the Layer Controls tab. For more information about the Skew-T and
other aerological displays, see Sounding Display and Controls.
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Displaying Profiler Data
This section describes how to make plots from the NOAA National Profiler Network. The set of steps involve:

Connecting to NOAA National Profiler Network
Making the Profiler Displays
Additional Profiler Displays

Connecting to NOAA National Profiler Network
In the Data Sources tab of the Data Explorer select Point Observations->Wind Profiler. For more information about the wind profiler chooser,
see Choosing NOAA National Profiler Network Data.

In the Server: and Dataset: entry boxes, use the pull down list to select a remote server and dataset with Profiler data, such as adde.ucar.edu and
RTPTSRC. Connect to the server and select a profiler type such as "Real-Time Hourly Profiler data."

Select a station by clicking on it on the map. Select a group of stations by dragging the mouse cursor with the shift key to make a rubber band
box, or do shift-click to select more than one station. The map shows Profiler station names.To see more stations check the Declutter box off.
When checked, the Declutter check box allows you to show all stations, and when unchecked, shows only a limited number of stations that do not
overlap each other. As you zoom in, more station will appear, and it may be necessary to zoom in to see all of the stations clearly separated. The
icons below the map allow you to zoom and pan across the map.

Once you have selected one or more stations, select a relative or absolute set of times. For absolute times, check individual times on or off with
control-click. Select end times and times of a range with shift-click.

In the Interval selection box you can choose from Hourly, 30 minute, 12 minute, or 6 minute intervals to determine what time step will be used in
your McIDAS-V displays. Once you have selected an interval, click the Add Source button.

Making the Profiler Displays
A label like "Profiler Hourly - 4 stations" appears in the Data sources panel in the Field Selector tab.
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The "Profiler winds" item in the Fields panel allows you to make any of the Profiler displays for all the stations selected. You can use the
individual station fields to make a display only for that station.

Click on "Time/Height Display" in the Displays panel, to choose this type of display. Then make the display by clicking on Create Display in the
bottom of the Field Selector window.

The time/height plot of Profiler data at this station or stations is made. The colored globe in the lower right corner of the main McIDAS-V
window indicates that processing and making displays is in progress.

Similarly you can choose the Profiler Station Plot display (a mapped plan view of profiler winds at any single level above sea level) , or the 3D
View display which shows winds at all levels and at all stations selected.

Additional Profiler Displays
For examples of the Profiler displays, and how to control them, see Profiler Controls. 
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Displaying Fronts
This section describes how to make plots from the NOAA National Profiler Network.

In the Data Sources tab of the Data Explorer select Front Positions. For more information about the fronts chooser, see Choosing Fronts.

In the Server: and Dataset: entry boxes, use the pull down list to select a remote server and dataset with front data, such as adde.ucar.edu and
RTPTSRC and connect to the server.

Select either analysis or forecast fronts and click the Add Source button. The fronts will automatically be loaded into McIDAS-V.
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Image 1: Globe Display

Using the Globe Display
The illustration below shows a McIDAS-V Globe Display of GFS numerical weather prediction model output of mean sea level pressure (as
color-shaded image and contour lines) and 50 m/s wind speed isosurfaces showing the jet streams.

In the Globe Display version of McIDAS-V, the displays and maps are projected onto a spherical globe. The globe can be rotated by hand or
automatically, along with the usual zooming and time animation of displays on the globe.

To create a Globe View window, use the File->New Display Tab->Globe Display->One Panel menu. This section describes how to make plots
of global satellite imagery on the Globe display. The set of steps include:

Choosing Global Satellite Imagery
Displaying the Data
Using the Display

Choosing Global Satellite Imagery
After starting the Globe version of McIDAS-V, open the Data Sources tab of the Data Explorer and click on the Satellite Imagery tab.

Connect to one of the servers listed using RTIMAGES dataset.
From the Image Data Type selector, choose the Mollweide IR/TOPO Composite type.
Click the Add Source button to load the data source.

Displaying the Data
Once the data source has been selected, you can create the display by doing the following in the Field Selector:

Select the "Mollweide IR/TOPO Composite" data source in the Data Sources panel.
Select the "Band 1" field in the Fields panel.
Select "Image Display" in the Displays panel.
Click the Create Display button to create the display.

Using the Display
When the data are displayed, the default view will be from the North pole. You can move the display using the standard McIDAS-V zoom, pan
and rotate functions. For this exercise try the following:

Use the Viewpoint toolbar or the View->Viewpoint menu to rotate to the West view.
Start the image animation using the Animation Widget.
The Globe display has an extra View->Auto-rotate menu. Check this on to spin the globe along the vertical axis.

Any suitable data with navigation information (latitude, longitude, and altitude) that McIDAS-V can handle can be plotted on the globe display.
Review the section on Plots from Gridded Data.

Notes:

Vertical probes and vertical cross sections do not work in this version of the globe display, though you can plot data above the surface in
isosurfaces, as illustrated by the jet stream cores shown above.
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Displaying Local Files
This section describes how to make a display using files or a directory located on your local machine.

The set of steps include:

Loading Local Files
Loading Local Files from a Directory
Creating the Display

Loading Local Files
In the Data Explorer window select the General->Files data source to view the Local File chooser. For more information about this chooser, see
Choosing Data on Disk.

1. Navigate to the directory that contains the file(s) you are interested in. Use the Look In menu to select directories, or double-click on
directory names.

2. Select a file or files. Multiple files can be selected using Control-Click or Shift-Click.
3. Optionally, specify the type of data the file contains by using the Data Type menu.
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4. When done, load the selected file by clicking Add Source.

Loading Files from a Directory
Loading files from a directory is similar to loading files, however you are limited to one directory. Loading files from a directory also gives you
the options of polling files, as well as limiting files to a specific file pattern.

1. Select the directory you want to poll on.
2. Type in a name for the dataset that you want to show in the Field Selector.
3. Optionally, specify the type of data the URL contains by using the Data Type menu.
4. Choose the number of files you want to to search for. You can select an absolute number of files that have been updated in a certain time

period.
5. When done, load the selected URL by clicking Add Source.

Creating the Display
The local data files will be shown in the Field Selector tab.

The data source name listed in the Field Selector will be based upon whether you loaded files or a directory. If one file is loaded, the name of the
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file is shown. Multiple files will be listed as "N files" where N is the number of files loaded. A directory will be shown as the directory name plus
the file pattern (if used), or ".*" if all files in the directory are loaded. To create the display, proceed exactly as you would with similarily loaded
data from an ADDE server.



Displaying Files From a URL
This section describes how to make a display using files located at a specific URL.

The set of steps include:

Loading Files from a URL

Creating the Display

Loading Files from a URL
In the Data Explorer window select the General->URLs data source to view the URL file chooser. For more information about this chooser, see
Choosing a URL.

1. Enter the URL into the field or choose a previously selected URL from the pull down menu.
2. Toggle the  button to expand the box to allow for the entry of multiple URLs, one per line.
3. Optionally, specify the type of data the URL contains by using the Data Source Type menu.
4. When done, load the selected URL by clicking Add Source.

Creating the Display
The local image data source files will be shown in the Field Selector tab.
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To create the display, proceed exactly as you would in the Field Selector if you had added data through one of the real-time data choosers.



Displaying Hyperspectral Satellite Imagery Using HYDRA
This section describes how to create multispectral displays using HYDRA. The set of steps include:

Creating the Multispectral Display
The Multispectral Display

Creating the Multispectral Display
In the Data Explorer window select Satellite->HYDRA from the Data Sources tab to view the chooser. For more information about the HYDRA
chooser, see Choosing Multispectral Data.

The HYDRA chooser is fairly similar to the File Chooser. Dowload the IASI image from January 15, 2007 located at:
ftp://ftp.ssec.wisc.edu/pub/mug/mcidas-v/training/data/IASI_xxx_1C_M02_20070115_1140.nc. Navigate to the directory the file is in and add it
as a source.

In the Field Selector, select the "Imagery->Multispectral Display" and click Create Display.

There are four aspects to the multispectral display. The first is the image in the main display window. The image will be over Northern Africa and
the Mediterranean Sea. The second aspect is the Spectra. The Spectra is displayed in the Layer Controls tab under "MultiSpectral." The spectra
displayed upon default is the 919.50 cm-1 spectral region (10.8 µm). The final two aspects are the two spectrum probes. In the main display there
are two colored square boxes that represent the main probe (magenta) and the reference probe (light blue). These two probes are listed under
"Readout" under "No Display" in the Layer Controls. Left click and drag either box to view the spectra measured in various pixels around the
image or use one as a reference spectrum.
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The Multispectral Display

Change the wavenumber being displayed to 852.25 cm-1 by entering in the value into the Wavenumber: box in the Multispectral Display and
hitting enter. Move the magenta and light blue spectra probes to the approximate locations in the image below to locate an inversion at the
location of the red box over Albania.

Once the two probes are in the approximate locations, the MultiSpectral window should look similar to the image below.

Zoom in over the 852.25 cm-1 region using the Ctrl+Left Click+Drag combination to create a box of the region to zoom in on. If you miss the
region, or want to return to the full spectra, use Shift+Left Click. The inversion should become clear as you zoom in, as shown in the image
below.



 



Using the McIDAS-X Bridge
This section describes how to create displays from a McIDAS-X bridge session. The McIDAS-X Bridge provides a way to load data from an
active McIDAS-X sesssion into McIDAS-V. Note: The McIDAS-X bridge will only work if you have McIDAS-X, and are updated to at
least version 2007a or later. If you do not, proceed to the next section.

The set of steps include:

Starting the McIDAS-X Bridge Listener
Creating a McIDAS-X Bridge Session
Creating a McIDAS-X Display in McIDAS-V

Starting the McIDAS-X Bridge Listener
To start the McIDAS-X bridge listener, type MCLISTEN START in a running McIDAS-X session (version 2007a or later) on a remote or local
machine.

Creating a McIDAS-X Bridge Session
In the Data Explorer window select McIDAS-X Bridge from the Data Sources tab to view the chooser. For more information about the
McIDAS-X Bridge chooser, see Creating a McIDAS-X Bridge Session.

If you are connecting to the listener on your local macahine, connect to the defaults of localhost listening on port 8080, otherwise enter in a host
name and the corresponding port number and click Add Source. If MCLISTEN START was not run on the local or remote host, an error box
will say that the "Connection to McIDAS-X Bridge Listener at localhost:8080 failed".

The data source is shown in the Field Selector tab. The Frame Sequence will be listed in the "Fields" tab. Click the  tree tab to the left of
"Frame Sequence" to expand that list and list all available frames in the connected McIDAS-X session. You have the option to select all available
McIDAS-X frames, or one single frame. Select the "Frame Sequence", and create a "McIDAS-X Image Display" by clicking the Create Display
button.
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Image 1: McIDAS-X Bridge Controls

Creating a McIDAS-X Display in McIDAS-V
The McIDAS-X bridge session will be in the Layer Controls tab of the Data Explorer mirroring the McIDAS-X frame(s) selected. You can enter
McIDAS-X commands in the "Command Line" text entry box at the bottom of the Layer Controls tab. This will run McIDAS-X commands, and
the McIDAS-V display in the Layer Controls tab will update to reflect the results. Although the bridge session resembles a normal McIDAS-X
session, interactive commands are not implemented, but recall commands do work.

Create a loop of satellite images in the McIDAS-X bridge session without displaying a map. Import these McIDAS-X frames into the current
McIDAS-V 3D panel by selecting the Settings tab and checking the "Display data in main 3D panel" option. This will import all of the navigated
McIDAS-X frames into the 3D panel. It is recommended that you do not use maps from McIDAS-X when importing frames, as their quality
diminishes as you zoom in on the 3D display.

If at any time you receive an error message: Selected image(s) not available, it is due to the fact that McIDAS-V will only import navigated
frames. In cases where you have a combination of navigated and non-navigated frames, McIDAS-V will import the navigated frames into
McIDAS-V. Non-navigated frames will remain in your 2D display in the Layer Controls.





Image 1: McIDAS-V Data Explorer

 
Image 2: Data Explorer Toolbar

Data Explorer
The McIDAS-V Data Explorer window contains many of the common non-view windows:

Data Sources
See here for more information.

Field Selector
See here for more information.

Layer Controls
The Layer Controls tab holds the Display Control windows. For each Display Control there is a small toolbar at the bottom of the tab:

This allows you to undock the window from the Data Explorer, show display control properties, remove the display control, and drag and drop to
a window component.

Once a Layer Control window is undocked from the Data Explorer it can be re-docked through the View->Dock in Data Explorer menu item.
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Choosing Data Sources
McIDAS-V can use data from local files, remote data servers such as OPeNDAP or ADDE and even web servers. You can read further about
specific sources of data available.

The general idea is to select the sources of data that you want to work with within McIDAS-V using the Data Sources tab. Once selected, the data
source will be shown in the Field Selector window where you can choose parameters, times and the displays to create.

McIDAS-V can work with any number of data sources at one time. Choosing a data source with McIDAS-V typically just reads the metadata
(i.e., data about the data), no parameter data values are read until you request a display to be made.

To select the data that is to be used in McIDAS-V you use the Data Sources tab, which is brought up by:

Selecting the Data Sources tab in the Data Explorer.
The Display->Create Layer from Data Source... menu item in the main menu bar.

This section describes:

Choosing Data on Disk
Choosing a URL
Choosing Cataloged Data
Choosing Flat File Data
Choosing Satellite Imagery
Choosing NEXRAD Level III Radar Data
Choosing NEXRAD Level II Radar Data
Choosing Point Data
Choosing Upper Air Sounding Data
Choosing NOAA National Profiler Network Data
Choosing Gridded Data
Choosing Front Positions
Choosing Multispectral Data
Creating a McIDAS-X Session
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Image 1: File Chooser

Choosing Data on Disk
The General->Files/Directories chooser allows you to select data or a directory from your file system. For more information on using this
chooser, see Getting Started.

 

Properties

Data Type:
If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by the filename itself. This can be overridden by
selecting the type of data the file contains from the pull down menu. Click here for a list of available data source types.
Look In:
This pulldown menu allows you to select folders to search for data files, or you can double-click on folder names.

 Up One Level
Moves you up one folder level in your local file system.

 Desktop
Takes you to the Desktop folder of your local file system.

 Create New Folder
Creates a new folder.

 List
Switches the view to a listing of all folders and files in the current path.

 Details
Switches the view to a detailed list of all folders and files in the current path.

 Show History Menu
Shows a list of the last 15 folders that data was loaded from.
File Name
Select a file to populate the entry box to show the full name of the file selected.
Files of Type:
Narrows down the files shown in a folder to a specific data type.
Recent Files:
Choose the number of files you want to search for by an absolute number, or by the files that have been updated in a certain number of
minutes.
Refresh:
When the checkbox is selected, the files and associated displays will automatically update. Change the number of minutes to control the
update frequency.
File Pattern:
You can choose to enter in a patter for the files you want to poll on.
Verify
Click to verify the files that will be scanned.
Include Hidden Files
When clicked, hidden files will be inclucded in the polling.
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Help
Brings up this help page.

Refresh
Rescans the current directory and update the file chooser if the files have changed.

Loads the file(s) selected. The data file(s) will appear in the Field Selector window.
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Image 1: URL Chooser

Choosing a URL
The General->URLs chooser allows you to specify the internet location (URL) of a data source. This URL may be a web page, a bundle or any
data file that McIDAS-V can process from a URL. For more information on using this chooser, see Getting Started.

Properties

Data Type:
If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by the URL itself. This can be overridden by
selecting the type of data the file contains from the pull down menu. Click here for a list of available data source types.
URL:
Enter in a URL or select one from the pull down menu. Change the radio buton to single to enter in one URL. Change it to Multiple to enter
in multiple URL entries. Only URL's using Hypertext Transfer Protocol (HTTP) will load data.

Help
Brings up this help page.

Loads the URL.
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Image 1: Catalog Chooser

Choosing Cataloged Data
The General->Catalogs chooser shows THREDDS catalogs of data holdings on remote data servers (typically TDS or OPeNDAP) and provides
access to remote Web Map Server (WMS) image servers. McIDAS-V provides an initial default catalog, idvcatalog.xml. It should appear in the
Catalogs menu. If not you can directly enter the URL of the catalog: http://www.unidata.ucar.edu/georesources/idvcatalog.xml

This catalog has links to a catalog of real time model data, a collection of county level shapefiles for roads and hydrography features and a
collection of useful Web Map Servers. For more information on using this chooser to display grid data, see Getting Started.

Properties

Catalog:

Enter in a catalog URL (and hit Enter or click  Refresh ) or select a catalog URL from the pull down menu. Use the Select File button
to select a catalog on your local disk.
History:
Use the  and  buttons to switch back and forth between selected catalogs.
Data Type:
If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by the URL itself. This can be overridden by
selecting the type of data the file contains from the pull down menu. Click here for a list of available data source types.
Tree Structure
Open the tree structure by clicking on the  tab icon. Clicking on a data source will enable the Add Source button.
Show Thumbnail Images
When checked, thumbnails are shown in the THREDDS catalog if available.

 Help
Brings up this help page.

 Refresh
Updates the catalog chooser with the most recent data.

Loads the selected data.

The following image displays the WMS chooser:
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Image 2: WMS Chooser

The tree view on the left shows the different image layers available. You can select one image or, using a control-click, select multiple images.
The map on the right is intended to provide an overview of the bounding box area of a selected image.

Properties

Catalog:

Enter in a catalog URL (and hit Enter or click  Refresh ) or select a catalog URL from the pull down menu. Use the Select File button
to select a catelog on your local disk.
History:
Use the  and  buttons to switch back and forth between selected catalogs.
Merge Layers
When checked, multiple data sources selected will be loaded and displayed at the same time. When unchecked, multiple data sources will
be loaded, but not displayed.
Image Bounds:
The map is intended to provide an overview of th ebounding box area of a selected image. Use the following buttons to navigate around the
map:

 Zoom In
Click to zoom in over the current map area.

 Zoom Out
Click to zoom out over the current map area.

 Previous Map Area
Click to return to the previous map area.

 Home Map Area
Click to return to the default map area.

 Move View Up
Click to move the view up (map down).

 Move View Down
Click to move the view down (map up).

 Move View Left
Click to move the view left (map right).

 Move View Right
Click to move the view right (map left).

 Help
Brings up this help page.

 Refresh
Updates the catalog chooser with the most recent data.

Loads the selected data.



Image 1: Flat File Chooser

Choosing Flat File Data
The General->Flat files chooser allows generic flat (2-dimensional) data to be loaded. The user must supply information about the format of the
data by either specifying it directly or by loading a properly formatted header file. Flat files can be binary, ASCII values, or standard images
(JPEG, GIF, etc.), and may contain multiple bands. Navigation may be loaded via separate navigation files or by specifying a bounding box for
the data.

Properties

Files:

Enter in a file location or use the  button to browse your local disk.
Type:
McIDAS-V will attempt to determine the type of file you are loading. If it is an unknown format, Binary, ASCII or Image data will be
displayed.
Description:
If available, a description of the data will be displayed. If no description can be found, the file name is displayed.
Properties->Dimensions:

Elements:
The number of elements (columns) in the data.
Lines:
The number of lines (rows) in the data.
Bands:
The number of bands (layers) in the data.
Units:
The unit type of the data.
Sampling:
The number of points to skip in each dimension when loading the data. Useful with very large data files.

Properties->Navigation:
Files:

Navigation files containing grids of Latitude/Longitude points can by specified by clicking on the  buttons.
Bounds:
A navigation bounding box can be specified by entering Upper Left (UL) and Lower Right (LR) Latitude/Longitude pairs.
Scale:
The scaling factor if the Latitude/Longitude navigation dimensions are different than the data.
East positive:
Checkbox to indicate that the data is East Positive

Properties->Format:
Binary:
When loading binary files the Byte format, Interleave, and Endian-ness must accurately describe the data. A byte Offset into the
data can also be given.
ASCII:
When loading ASCII files the Delimiter character must be given.
Image:



When loading a raw Image this option must be selected.
Missing value:
If there is a value for missing data, enter it here.

 Help
Brings up this help page.

Loads the selected data.



 
Image 1: Image Chooser

Choosing Satellite Imagery
The Satellite Imagery chooser allows you to access satellite imagery on remote ADDE servers. For more information on how to use this chooser,
see Getting Started.

Properties

Server:
Enter in a server name or choose one from the pulldown menu. Right click in the entry box to manage your ADDE servers and to delete the
server from the list.

 Manage
Manages the list of servers.
Dataset:
Enter in a dataset name or choose one from the pulldown menu. Right click in the entry box to delete the dataset from the list.

 Public Datasets
Lists the public datasets available on the server.

Connect
Connects and queries the server for available image types.
Image Type:
Use the pulldown menu to select one of the available image types.
Times: Relative
Allows you to select a group of up to the last 50 times.
Times: Absolute
Allows you to choose one or more absolute times. When choosing absolute times for the first time McIDAS-V needs to query the ADDE
server for the times. This may take some time. To select more than one time use Control-Click or Shift-Click. See the Timeline section for
details on its use. Click on the  Select Archive Day to narrow down a large dataset to one day.
Navigation:
Use the pulldown menu to select one of the available navigation types. Use Default for most images, and Lat/Lon if LALO navigation
should be used. Level 1b servers and POES servers often require Lat/Lon navigation to be selected.
Preview:
Check "Create Preview Image" if you would like to view a preview of the image in the Field Selector. If this box is unchecked, then only a
map of the image coverage will be shown in the Region tab of the Field Selector.

 Help
Brings up this help page.

 Refresh
Updates the Imagery chooser with the most recent data.

 Cancel
Cancels the query of data. The chooser will reset back to default.

Loads the selected imagery data into the Field Selector.
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Image 1: Level III Radar Chooser

Choosing NEXRAD Level III Radar Data
The Radar->Level III chooser allows you to choose NEXRAD Level III data on remote ADDE servers. For more information on how to use this
chooser, see Getting Started.

Properties

Server:
Enter in a server name or choose one from the pull down menu. Right click in the entry box to delete the server from the list.

 Manage
Manages the list of servers.
Dataset:
Enter in a dataset name or choose one from the pull down menu. Right click in the entry box to delete the dataset from the list.

 Public Servers
Lists the public datasets available on the server

Connects to and query the server for available radar types and stations.
Product:
Use the pull down menu to select a radar product.
Station:
Select a station using the map. Once a station and a product have been selected, the ADDE server will be queried as to the available times.
The Declutter checkbox allows you to show all stations (not checked), or only a limited number of stations that do not overlap each other
(checked). You will need to zoom in to see all the stations without overlaps. Use the Zooming and Panning options to locate a station, or
the following buttons:

 Zoom In
Click to zoom in over the current map area.

 Zoom Out
Click to zoom out over the current map area.

 Previous Map Area
Click to return to the previous map area.

 Home Map Area
Click to return to the default map area.

 Move View Up
Click to move the view up (map down).

 Move View Down
Click to move the view down (map up).

 Move View Left
Click to move the view left (map right).

 Move View Right
Click to move the view right (map left).

Times: Relative
Allows you to select a group of up to the last 50 times.
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Times: Absolute
Allows you to choose one or more absolute times. When choosing absolute times for the first time McIDAS-V needs to query the ADDE
server for the times. This may take some time. To select more than one time use Control-Click or Shift-Click. See the Timeline section for
details on its use.

 Help
Brings up this help page.

 Refresh
Updates the Level III radar chooser with the most recent data.

 Cancel
Cancels the query of data and stations. The chooser will reset back to default.

Loads the selected radar data.
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Image 1: Level II Radar Chooser

Choosing NEXRAD Level II Radar Data
The Radar->Level II->Remote chooser allows you to choose Level II data from a remote ADDE server. For more information on how to use
this choosers, see Getting Started.

Properties - Remote Chooser

Catalog
Enter in, or use the default catalog to access the Level II radar data.

Connect to and queries the server for available radar types and stations.
Collections:
Use the pull down menu to choose the collection to use.
Station:
Select a station using the map. The Declutter checkbox allows you to show all stations (not checked), or only a limited number of stations
that do not overlap each other (checked). You will need to zoom in to see all the stations without overlaps. Use the Zooming and Panning
options to locate a station, or the following buttons:

 Zoom In
Click to zoom in over the current map area.

 Zoom Out
Click to zoom out over the current map area.

 Previous Map Area
Click to return to the previous map area.

 Home Map Area
Click to return to the default map area.

 Move View Up
Click to move the view up (map down).

 Move View Down
Click to move the view down (map up).

 Move View Left
Click to move the view left (map right).

 Move View Right
Click to move the view right (map left).

Times: Relative
Allows you to select a group of up to the last 50 times.
Times: Absolute
Allows you to choose one or more absolute times. To select more than one time use Control-Click or Shift-Click. See the Timeline section
for details on its use.

 Help
Brings up this help page.

 Refresh
Updates the Level III radar chooser with the most recent data.
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Image 2: Level II Local Radar Chooser

 Cancel
Cancels the query of data and stations. The chooser will reset back to default.

Loads the selected radar data.

Local Level II Radar Chooser
The Radar->Level II->Local chooser allows you to choose Level II data from your file system.

Properties - Local Chooser

Station:
Use the pull down menu to select the radar location. By default, McIDAS-V will use the folder name to determine the radar location.
Look In:
This pull down menu allows you to select folders to search for data files, or you can double-click on folder names.

 Up One Level
Moves you up one folder level in your local file system.

 Desktop
Takes you to the Desktop folder of your local file system.

 Create New Folder
Creates a new folder.

 List
Switches the view to a listing of all folders and files in the current path.

 Details
Switches the view to a detailed list of all folders and files in the current path.

 Show History Menu
Shows a list of the last 15 folders that data was loaded from.
File Name:
Select a file to populate the entry box to show the full name of the file selected.
Files of Type:
Narrow down the files shown in a folder to a specific data type.
Times:
Use the pull down menu to select the option to use the selected file(s) or to select the latest N files in the directory.
File Pattern:
Specify the pattern for files to look for if Relative Times is set to "Use the N most recent times.

 Help
Brings up this help page.

 Refresh
Updates the Level III radar chooser with the most recent data.

Loads the selected radar data.



 
Image 1: Point Data Chooser

Choosing Point Data
The Point Observations->Plot/Contour chooser allows you to choose surface, upper air, and other types of point data (eg: aircraft data) to plot or
contour for today's date. For more information on how to use this chooser, see Getting Started.

Properties

Server:
Enter in a server name or choose one from the pull down menu. Right click in the entry box to delete the server from the list.

 Manage
Manages the list of servers.
Dataset:
Enter in a dataset name or choose one from the pull down menu. Right click in the entry box to delete the dataset from the list.

 Public Servers
Lists the public datasets available on the server

Connects to and queries the server for available times.
Point Type:
Use the pull down menu to select the Point Type to display.
Times: Relative
Allows you to select a group of up to the last 50 times, for today's date only.

Relative Time Increment:
Set a time increment to use with relative times. For example, using "3 most recent" times with a "3" hour time increment would result
in the most recent time, one from 3 hours ago and one from 6 hours ago.

Times: Absolute
Allows you to choose one or more absolute times from today's date only. When choosing absolute times for the first time McIDAS-V needs
to query the ADDE server for the times. This may take some time. To select more than one time use Control-Click or Shift-Click. See the
Timeline section for details on its use.
Interval:
Select the time interval to use when displaying this data.

 Help
Brings up this help page.

 Refresh
Updates the Level III radar chooser with the most recent data.

 Cancel
Cancels the query of data and stations. The chooser will reset back to default.

Loads the selected radar data.
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Image 1: RAOB Chooser

Choosing Upper Air Sounding Data
Upper air RAOB data can be displayed as atmospheric balloon soundings. You can access RAOB data as atmospheric balloon soundings either
from remote ADDE servers (using the Point Observations->Soundings->Remote chooser, pictured below) or from local files (using the Point
Observations->Soundings->Local chooser). The only difference between these two choosers is specifying the source of data. You either select
an ADDE server and press Connect or you select a file containing RAOB data. For more information on how to use these choosers, see Getting
Started.

Properties

Server:
Enter in a server name or choose from the pulldown menu. Right click in the entry box to delete the server from the list.

 Manage
Manages the list of servers.
Dataset:
Enter in a group name or choose one from the pulldown menu. Right click in the entry box to delete the group from the list.

 Public Servers
Lists the public datasets available on the server

Connects to and queries the server for available times.
Station Map
Click on one more more stations to populate the Selected Soundings: box. Left clicking on a station will select it. For multiple selections,
Shift-drag will select all stations within a region. Control-drag will add the stations in the selected region to the set of already selected
stations. Pressing the Control-A key will select all stations. Right clicking in the map will bring up a menu that allows you to select all
stations and to clear the selection. The Declutter checkbox allows you to show all stations (not checked), or only a limited number of
stations that do not overlap each other (checked). You will need to zoom in to see all the stations without overlaps. Use the Zooming and
Panning options to locate a station, or the following buttons:

 Zoom In
Click to zoom in over the current map area.

 Zoom Out
Click to zoom out over the current map area.

 Previous Map Area
Click to return to the previous map area.

 Home Map Area
Click to return to the default map area.

 Move View Up
Click to move the view up (map down).

 Move View Down
Click to move the view down (map up).

 Move View Left
Click to move the view left (map right).

 Move View Right
Click to move the view right (map left).
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Available Times:
Select a single or set of dates and times to use. To select more than one time use Control-Click or Shift-Click.
00 & 12Z only
When checked, only 00Z and 12Z soundings will be listed in Available Times:.
Selected Soundings:
Soundings available for the times selected in the Available Times: will be shown for all stations selected.

 Help
Brings up this help page.

 Refresh
Updates the RAOB chooser with the most recent data.

 Cancel
Cancels the query of data and stations. The chooser will reset back to default.

Loads the selected RAOB data.



 
Image 1: Profiler Chooser

Choosing NOAA National Profiler Network Data
The Point Observations->Wind Profiler chooser allows you to access NOAA National Profiler Network data on ADDE servers. For more
information on how to use this chooser, see Getting Started.

Properties

Server:
Enter in a server name or choose one from the pull down menu. Right click in the entry box to delete the server from the list.

 Manage
Manages the list of servers.
Dataset:
Enter in a dataset name or choose one from the pull down menu. Right click in the entry box to delete the server from the list

 Public Servers
Lists the public datasets available on the server

Connects to and queries the server for available times.
Profiler Type:
Use the pull down menu to select a profiler type.
Station Map
Select a station using the map. Left clicking on a station will select it. For multiple selections, Shift-drag will select all stations within a
region. Control-drag will add the stations in the selected region to the set of already selected stations. Pressing the Control-A key will select
all stations. Right clicking in the map will bring up a menu that allows you to select all stations and to clear the selection. The Declutter
checkbox allows you to show all stations (not checked), or only a limited number of stations that do not overlap each other (checked). You
will need to zoom in to see all the stations without overlaps. Use the Zooming and Panning options to locate a station, or the following
buttons:

 Zoom In
Click to zoom in over the current map area.

 Zoom Out
Click to zoom out over the current map area.

 Previous Map Area
Click to return to the previous map area.

 Home Map Area
Click to return to the default map area.

 Move View Up
Click to move the view up (map down).

 Move View Down
Click to move the view down (map up).

 Move View Left
Click to move the view left (map right).

 Move View Right
Click to move the view right (map left).
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Times: Relative
Allows you to select a group of up to the last 50 times.
Times: Absolute
Allows you to choose one or more absolute times. When choosing absolute times for the first time McIDAS-V needs to query the ADDE
server for the times. This may take some time. To select more than one time use Control-Click or Shift-Click. See the Timeline section for
details on its use.
Interval:
Use the pull down menu to select an interval to use for the data.

 Help
Brings up this help page.

 Refresh
Updates the Level III radar chooser with the most recent data.

 Cancel
Cancels the query of data and stations. The chooser will reset back to default.

Loads the selected radar data.
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Image 1: Remote Grid Chooser

Choosing Gridded Data
The Gridded Data -> Remote chooser shows THREDDS catalogs of gridded data holdings on remote data servers (typically TDS or
OPeNDAP). The pull down menu has several catalog options. For more information on using this chooser to display grid data, see Getting
Started.

Properties

Catalog:

Enter in a catalog URL (and hit Enter or click  Refresh ) or select a catalog URL from the pull down menu. Use the Select File button
to select a catalog on your local disk.
History:
Use the  and  buttons to switch back and forth between selected catalogs.
Data Source Type:
If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by the URL itself. This can be overridden by
selecting the type of data the file contains from the pull down menu. Click here for a list of available data source types.
Tree Structure
Open the tree structure by clicking on the  tab icon. Clicking on a data source will enable the Add Source button.
Show Thumbnail Images
When checked, thumbnails are shown in the THREDDS catalog if available.

 Help
Brings up this help page.

 Refresh
Updates the catalog chooser with the most recent data.

Loads the selected data.

The following image displays the Gridded Data -> Local chooser:
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Image 2: Local Grid Chooser

Properties

Data Type:
If left as "I'm Feeling Lucky", McIDAS-V will figure out what kind of data is in the file by the filename itself. This can be overridden by
selecting the type of data the file contains from the pull down menu. Click here for a list of available data source types.
Look In:
This pulldown menu allows you to select folders to search for data files, or you can double-click on folder names.

 Up One Level
Moves you up one folder level in your local file system.

 Desktop
Takes you to the Desktop folder of your local file system.

 Create New Folder
Creates a new folder.

 List
Switches the view to a listing of all folders and files in the current path.

 Details
Switches the view to a detailed list of all folders and files in the current path.

 Show History Menu
Shows a list of the last 15 folders that data was loaded from.
File Name
Select a file to populate the entry box to show the full name of the file selected.
Files of Type:
Narrows down the files shown in a folder to a specific data type.
Recent Files:
Choose the number of files you want to search for by an absolute number, or by the files that have been updated in a certain number of
minutes.
Refresh:
When the checkbox is selected, the files and associated displays will automatically update. Change the number of minutes to control the
update frequency.
File Pattern:
You can choose to enter in a patter for the files you want to poll on.
Verify
Click to verify the files that will be scanned.
Include Hidden Files
When clicked, hidden files will be inclucded in the polling.

Help
Brings up this help page.

Refresh
Rescans the current directory and update the file chooser if the files have changed.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_DataSources__FILE


Loads the file(s) selected. The data file(s) will appear in the Field Selector window.
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Image 1: Front Chooser

Choosing Front Positions
The Front Position chooser allows you to access analysis or forecast fronts on ADDE servers. For more information on using this chooser, see
Getting Started.

Properties

Server:
Enter in a server name or choose one from the pull down menu. Right click in the entry box to delete the server from the list.

 Manage
Manages the list of servers.
Dataset:
Enter in a dataset name or choose one from the pull down menu. Right click in the entry box to delete the server from the list

 Public Servers
Lists the public datasets available on the server.

Connects to and queries the server for available times.
Latest:
Click a radio button to select analysis or forecast fronts.

Help
Brings up this help page.

 Refresh
Updates the Front Position chooser with the most recent data.

 Cancel
Cancels the query of data. The chooser will reset back to default.

Loads the selected front data.
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Image 1: HYDRA Chooser

Choosing Multispectral Data
The Satellite->HYDRA chooser allows you to select data from your local file system to be displayed using HYDRA. For more information on
using this chooser, see Getting Started.

 

Properties

Look In:
This pull down menu allows you to select folders to search for data files, or you can double-click on folder names.

 Up One Level
Moves you up one folder level in your local file system.

 Desktop
Takes you to the Desktop folder of your local file system.

 Create New Folder
Creates a new folder.

 List
Switches the view to a listing of all folders and files in the current path.

 Details
Switches the view to a detailed list of all folders and files in the current path.
File Name:
Select a file to populate the entry box to show the full name of the file selected.
Files of Type:
Narrow down the files shown in a folder to a specific data type.

Help
Brings up this help page.

Refresh
Rescans the current directory and update the file chooser if the files have changed.

Loads the file(s) selected. The data file(s) will appear in the Field Selector window.
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Image 1: McIDAS-X Bridge Chooser

Creating a McIDAS-X Bridge Session
The McIDAS-X Bridge chooser allows you to create a McIDAS-X bridge session which provides a way to load data from an active McIDAS-X
session (version 2007a or later) into McIDAS-V. For more information on using this chooser, see Getting Started.

Properties

Host:
Enter in a host address or leave as localhost if connecting to a McIDAS-X session on your local machine.
Port:
Enter in a valid port number which corresponds to the McIDAS-X bridge listener.

 Help
Brings up this help page.

Loads the McIDAS-X bridge session.
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Image 1: Field Selector Window

The Field Selector
The Field Selector is used to list the loaded data sources, view their available fields, subset (time and space) the field and create displays.

Overview
After choosing some data creating a display is just a couple of steps away:

1. Click on the data source of interest in the Data Sources list:

2. Select the field you want to display:

3. Select the display type:

4. Optionally subset the times by clicking off the Use Default button and selecting the times:
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5. For grids, optionally subset the levels and/or spatial area:

6. For images, optionally subset the spatial area to be displayed. 

Use the Region tab to left-click drag to select a geographical region to display:

Use the Advanced tab to further refine your data selection and refer back to the Region tab to view the image you've selected:

Image Properties
The image properties in the Advanced tab allow you to override the default properties McIDAS-V uses to specify aspects of the image
data. The widgets show the defaults McIDAS-V will use. By changing any of the widgets you can override the default value.

Coordinate Type:
Change the coordinate type used to specify the data location.
Location:
Specify the placement point of the image at either the center or the upper left.
Lat:/Lon:
Enter in a latitude and longitude to place the image.
Line:/Element:
Enter in a line and element to place the image.

 Center Display
Click to center the image over the center, upper left, upper right, lower left, or lower right latitude and longitude coordinates of the of
the current main display.
Image Size:



 
Image 2: Data Source Popup Menu

Change the size of the image.
 Lock Image Size 

Unlock to automatically change size when changing magnification.
 Full Resolution

Click to set the image size to the full resolution size of the image.
Raw Size:
Lists the full size of the image on the server.
Magnification:
Use the  sliders to change the magnification of the image, or manually type the Line and Ele magnification in the Mag= fields.
Res=
Lists the approximate resolution of the image, if displayed with the current Image Properties.
Approx. Area:
Lists the center, upper left, upper right, lower left, and lower right coordinates of the selected image, if displayed with the current
Image Properties.

7. Press "Create Display":

Data Sources
The left panel shows Data Sources, chosen as described in Choosing Data Sources. You can right click on a data source in the list to show a
popup menu:

This allows you to Remove the data source, reload its data, change the data source, show its Properties window, etc.

The Save as Quick Link item will save this data source off as a favorite and make it available in the "Favorite Data Sources" tab of the Quick
Links tab of the Data Explorer. Gridded data has additional options that allow you to make the grid local, or write a field mask plugin.

Fields
Selecting a data source in the left panel will list the available fields in the Fields tree. This list is usually hierarchical showing different categories
of fields (e.g., 2D grids, 3D grids, image sequences, etc.). To see the fields under a particular category click on the toggle icon .

Selecting a field will show the list of displays available in the Displays list and subsetting information (e.g., times, spatial subset).

Subsetting
The "Subsetting" component of the Field Selector allows you to subset the data in both time and space (if possible). If there are times in the data
source you are viewing they will be shown in this area. Likewise, if it is possible to do spatial subsetting or decimation a "Spatial Subset" tab will
be shown.

Time and spatial subsetting defaults can be applied to the data source itself through the Data Source Properties dialog or the defaults can be
overwritten through the Field Selector window.

Creating Displays
The Display tree shows a hierarchical list of the available displays for a particular field. Click on the type of display you want from the choices
listed in the Displays tree. You can see examples of Display Types in this User's Guide.

You can select two or more displays (different display types) at one time. For an additional display, hold down the CTRL key and click on the
second display type desired. Then go ahead and create the display as normal; all selected displays will be made. To make the display click on the
button Create Display (or double click on the display).

Derived Parameters
McIDAS-V provides derived parameters -- parameters not provided by the original source data, but made from the source data with
computations by McIDAS-V. The intent is to provide commonly used fields (such as dewpoint when dewpoint is not provided by the data source),
but when it can be derived from source data (such as humidity and temperature).

These automatic derived parameters are offered when the required data to compute them are available, based on parameter names.

Since few data sets use the same names for parameters, McIDAS-V keeps of a list of "aliases" or particular parameter names that match with
"canonical" names which are generally understood by all McIDAS-V users and which McIDAS-V uses for computations. You can add your
special parameter names to the list of aliases. Read the Parameter Alias section in this guide for information on using that facility.

All needed source parameters for one derived parameter must come from one single data source (e.g. from one single netCDF file). McIDAS-V
attempts to find derived parameters that can be made from data in each data source in the data source panel, but not from all possible combination
of data sources. If you had separate files of u and v wind components, for example, the parameter names or aliases will not create Derived wind
vectors.

Formula Data Source
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You can create your own formulas using the McIDAS-V Formulas facility. The Formulas data source in the Field Selector is a special data
source and lists all of the available end user formulas. You can right-click on the data source to create new formulas and import and export
formulas. The formulas are listed in the Fields tree. Right clicking on one of the formulas listed in the Fields tree allows you to edit, copy or
evaluate the formula.

You can select a formula just like any other field and create a display from it. However, the formula, when evaluated to create the display, usually
needs one or more other data fields to act on. In this case a special Field Selector window is shown that allows the user to select the fields for the
formula. (Note: the fields you select here can also be formula fields resulting in further field selection).
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Data Source Properties
To set the defaults for a data source bring up the Properties dialog by right clicking (or double clicking) on the data source name in the data
sources panel of the Field Selector window and select Properties:

The Properties Dialog is different for different types of data sources. Here is the dialog window for a gridded data source:

Any displays that are showing data from a data source can be automatically updated by selecting the Reload Displays button. When this is
selected all data will be reloaded and the displays will be updated when the user presses Apply or OK.

Basic Properties
You can change the displayed name with the Name field.

Some data sources can automatically update themselves by selecting the Active button. For example, if you had a set of most recent satellite
images you can turn on Polling and have the data update to the latest images every N minutes.

For point data you can define Time Binning settings (not shown) by selecting a Bin Size (e.g., 5 minutes, 1 hour) and a Round To value (e.g., On
the hour, 15 minutes after the hour). This will map all the observation times into the nearest bin. The smallest time is rounded with the Round To
value (e.g., if Round To was "10 after" and the smallest time was 10:23 then this time would be rounded to 10:20). This is the base time. Each
actual observation time is mapped into a set of bins of Bin Size starting at the base time.

Times
The Times tab allows you to select the times to use. Click off the Use All button and select individual times. You can right mouse click in the list
to show a popup menu that allows you to select different strides (e.g., every 3rd time).



Spatial Subsetting
For grids and other data source types the data can be subset and decimated with the Spatial Subset tab. The X Stride, Y Stride and Z Stride
menus allow you to decimate a grid, selecting every Nth point. The Bounding Box allows you to define a spatial area to load. The default spatial
domain of the data is shown by the blue outline box. To select an area just drag on the map. Once a subset is selected it can be resized (grab on
the little black selection points) moved (grab somewhere near the box) and delete (press the Delete key). Specific lat/lon values can be entered in
the fields on the left.

A version of this spatial subsetting window is used in the Field Selector. Here, you explicitly enable these settings. The decimation and spatial
subset are shown in different tabs:

Details
The Details tab shows further information about the data source, e.g.: any documentation associated with the data, what files or urls are used, etc.

Metadata
For grid data sources the Metadata tab shows the NetCDF metadata.



 
Image 1: McIDAS-V Main Window

Main Window
The main window within McIDAS-V contains:

A 3 dimensional view of the displays.
A legend panel that shows information about the current displays.
A main menu bar and main toolbar that allow you to control the application.
A subsidiary view menu bar that is relevant to the 3 dimensional display.
Time animation display and control widgets.
Navigation toolbars.

The following sections describe features of a main window display:

Menu Bar
Main Toolbar
Drag and Drop Tabs
Display Menus
Time Animation
Zooming, Panning and Rotating
Transect Views
Legend
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Menu Bar
The main menu bar shown at the top of the main window has several different menus associated with it.

File Menu
Edit Menu
Display Menu
Tools Menu
History Menu
Bundles Menu
Windows Menu
Help Menu

File Menu

New Display Window
Opens a new display window which can be a map or globe display with one to four panels. Other speciality displays are also available.

New Display Tab
Opens a new display tab which can be a map or globe display with one to four panels. Other speciality displays are also available.

Open File...
Opens a file on disk.

Save Favorite
Save the state off as a specially located and named favorite. This allows you to easily create a set of favorite bundles and readily access
them through the Bundles menu.

Save Bundle
Allows you to save the current application state as a bundle.

Default Layout
This menu allows you to manage the default layout in McIDAS-V. The default layout saves the window placement and the number of tabs
and panels.

Save
Save the current panel and tab state as the default layout.

Remove
Removes the current panel and tab state as the default layout.

Note: Saving the Default Layout does not affect the maps displayed in each panel or the data loaded at the beginning of each McIDAS-V
session. To change map defaults, use the Edit->Save as the Default Map Preference menu item from the Map Layer Controls. Change the
Default Projection in the Display Window preferences, or automatically load a Favorite bundle by selecting a default bundle in the
Advanced Preferences.

Exit
Exits McIDAS-V.

Edit Menu

Remove
This menu lets you choose to remove all layers, all data, or all layers and data from the main display.

All Layers and Data Sources
Removes all layers and loaded data sources.

All Layers
Remove all layers.

All Data Sources
All loaded data sources. The layers are unaffected.

Preferences...
Show the User Preferences window, allowing you to edit standard settings for McIDAS-V.

Display Menu
The display menu contains facilities to create new displays.

Create Layer from Data Source...
Takes you to the Data Sources tab in the Data Explorer.

Layer Controls...
Takes you to the Layer Controls tab in the Data Explorer.

Add Range Rings
Create a radar range ring display. Radar range rings are a set of concentric rings centered on a point, and radial lines, used to show distance
and bearing from the center. The initial position is at the center of the view's current projection. For more information see Range Rings.
You do not need to use radar data to see this measuring device.

Add Range and Bearing
Creates a display to show the distance, azimuth, and back azimuth of a great circle line connecting two positions on the Earth's surface. The
initial position is near the center of the current entire map area. If you are zoomed in, the range and bearing line may be off screen. For
more see Range and Bearing Line.

Draw Transect...
Create a drawing tool that allows you to view, create and modify transects for the Transect View

Drawing Freely...
Create a drawing tool that allows you to draw polygons, lines, shapes, and annotate McIDAS-V displays.
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Add Location Indicator
Creates a location indicator cross-hair on the display. See the Location Indicator Control.

Plot Location Labels
This menu lists a variety of point location plots that can be created: NEXRAD sites, state names, state locations, etc. It will create a
Location Control with the chosen location information.

Add Background Image
Adds a background image to the display that can be changed using the Background Image Controls.

Reset Map Layer to Defaults
Resets the map layer to default, or redisplays the map if it has been deleted.

Tools Menu
This menu allows you to configure and edit different McIDAS-V resources.

Manage ADDE Datasets
Show the ADDE Data Manager, which allows you to create and edit remote and local datasets.

Text Data
This menu allows you to bring up the or allows you to access local text products or ATCF storm data.

Weather Text Products (from server)
Shows the Weather Text Products window

Weather Text Products (from NWX files)
Shows the Weather Text Products window

ATCF Tropical Storm Data
Shows the Weather Text Products window

Color Tables
Show the Color Table Editor, which allows you to view, create and modify color tables.

Station Model Template
Show the Station Model Editor, which allows you to view, create and modify station models for plotting point data.

Parameters
This menu contains items related to parameters in McIDAS-V.

Aliases
Show the Parameter Alias Editor, which allows you to define aliases for parameters in data sets that McIDAS-V does not know about.

Defaults
Show the Parameter Defaults Editor, which allows you to define the default display conventions (e.g., color tables, ranges, etc.) for
parameters.

Groups
Show the Parameter Groups Editor, which allows you to define the groups of parameters for use in derived data formulas.

Projections Manager
This menu contains items related to projections.

Edit Map Projections
Show the Projection Manager, which allows you to choose, edit and save map projections for use in McIDAS-V.

Restore Saved Views
Lets you restore a saved view.

Delete Saved Views
Deletes a saved view.

Save Current View
Saves the current view.

Formulas
This menu contains items related to end user formulas.

Create Formula
Show the Formula dialog window to create a new formula.

Edit Formulas
Gives a list of all current formulas to edit.

Jython library
Show the Jython library editor.

Jython Shell
Brings up the Jython Shell.

Import
Import a formula from a file.

Export
Export a formula to a file.

Plugins
Create
Allows you to create plugins.

Manage
Allows you to manage McIDAS-V plugins.
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History Menu
This menu lists the recently accessed data sources and layers and allows you to easily load them.

Bundles Menu
This menu lets you manage and load your favorite bundles.

Manage...
Brings up the bundle manager.

Favorite Bundles
Brings up the folders and list of bundles saved as favorites.

Windows Menu
This menu lets you bring up the Data Explorer as well as tabs or windows to the front.

Show Data Explorer
Brings the Data Explorer to the front.

Next Display
Brings the next display tab/window to the front.

Previous Display
Brings the previous display tab/window to the front.

Select Display...
Lets you choose which display tab/window to bring to the front.

Help Menu
This menu allows you to view this user's guide, show error messages, etc.

User's Guide
Go to the top-level user guide page

Getting Started
A quick overview of McIDAS-V

Show Help Tips
Shows the help tips window.

Show Console
Shows a console window which has the error messages and other text output from McIDAS-V.

Show Support Request Form
Shows a form that allows you to post support requests to the McIDAS Help Desk.

Visit Online Forums
Brings up the McIDAS-V forums in your default browser.

Check for new version
Checks to see if your current version of McIDAS-V is up to date.

Check for new notice
Checks to see if a new notice about McIDAS-V is available.

Release Notes
Displays the release notes for this version of McIDAS-V.

About McIDAS-V
Gives information about this version of McIDAS-V.



 
Image 1: Main Toolbar

Main Toolbar
Below the main menus you will find the Main Toolbar.

Many of the more commonly used features of McIDAS-V can be accessed here. Hold your mouse over a tool bar button to get a popup tip on
what that button does. The Main Toolbar is user configurable. Right click on the toolbar to change the icon sizes and select "Customize" to bring
up the preferences to add, remove and organize the buttons. See the section on setting User Preferences for more information.
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Image 1: Main Display Window with drag and drop tabs.

Drag and Drop Tabs
McIDAS-V has drag and drop tabs which allow you to organize multiple tabs and windows.

Drag and drop tabs allow you to separate tabs into individual windows, combine windows into tabs, as well as reorganzie the layout of tabs in a
window. Drag tabs into separate windows by using the left click+drag option to drag the tab outside of the main display window. When the last
tab in a window is moved into another window, the window will disappear. When tabs are rearranged or added from a different window, green
arrows will point to the location the new tab will be placed.

Rename the tab by double clicking on it. Close a tab by clicking on the "x" on the right side of the tab. Closing a tab will remove all layers
associated with the display, but will not remove the data sources.



Display Menus
The View and Projections menus are associated with the 3D display.

View Menu
Projection Menu

View Menu
Each display has a View and Projections menu. The View menu lists the displays shown in this window, allows you tochange the point of view,
capture images and movies, and make some other changes in the overall view.

Displays
This menu deals with the displays that are shown in this particular view, which are shown at the bottom of the menu.

Hide/Embed Legend
Hides or shows the legend in the main display window.

Float/Embed Legend
Floats or redocks the legend in the main display window.

Remove All Displays
Remove the displays shown in this view.

Visibility Animation
Cycle through the visibility of each layer, showing one at a time. Click the check box "on" to start animation, check off to stop. You
can increase or decrease the speed with the provided Faster and Slower choices. Note this is not a time animation loop; it loops
through the visibility of the layers present in this view window.

Capture
You can capture the current view as an image, send it to a printer, or capture a movie. See here for more information about available image
and movie types.

Show
Allows you to turn on or off different flags relating to the 3D display.

Viewpoint
This menu allows you to change the point of view.

Top View through West
These 5 items reset the point of view to one of the orthogonal directions.

Perspective View
Provides an alternate 3D view of the display. The default is a parallel projection.

Viewpoint Dialog
This shows a dialog box for you to enter the azimuth and tilt of a desired point of view. Azimuth is from North, clockwise to 360
degrees. Tilt is degrees down from overhead, vertical. A top view has tilt of 0. Oblique views from the southeast have azimuth 135,
and a tilt of about 45 degrees. A view from the "east" has an azimuth of 90, tilt 90.

Vertical Scale
This shows a dialog box to set the vertical scaling between the top and bottom of the wire frame box. The scale is linear. You can
specify the units for the max and min values. Units must be convertible with meters (e.g., km, ft, fathoms, etc)

Auto-rotate View
Turns on/off an automatic rotation of the main display.

Color
Change the background and foreground colors of the view (not the map lines) to predefined colors or set your own. When setting your own
colors you can also save off the chosen color pair as a named predefined color pair which will appear in the list.

Full Screen
Show the current view in full screen mode.

Animation Timeline
Show the Animation Timeline

Properties
Show the properties dialog for the view. Allows you to set aspect ratio, vertical scale, flags, color, etc.

Projections Menu
The Projections menu lets you change the map projection in the 3 dimensional display.

Predefined
Contains the list of pre-defined projections you can choose from, including both system-supplied and your own projections.

From Displays
Lists the native data projections of any displays being show.

Viewpoints
Allows you to define, select, or delete saved viewpoints.

History
Contains the projections that have been used for this view. It allows you to easily go back to prior projections.

New/Edit
Show the Projection Manager dialog to view, create and edit projections.

Use Displayed Area
Resets the projection to that of the current zoom level.

Go to Address

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_DisplayMenus__viewmenu
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_DisplayMenus__projectionmenu
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImageCaptures__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Timeline__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ProjectionManager__FILE


Change the projection to a given address, zip code, city, etc.

The formats include:

12345 oak street, my town, my state my town, my state 80303 (zip code) latitude longitude
"ip" for the location of this computer

Auto-Set Projection
Toggles the behavior of automatically setting the projection to the projection of the most recent display that has been added.

Share Views
Control whether Sharing is turned on or off for this view. If sharing is turned on then view point and projection changes are shared with any
other views that also have sharing turned on.

Set Share Group
Enables you to select different share groups for multiple panels.
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Time Animation
Time Animation Widget
Time Animation Properties Dialog
Settings Tab
Define Animation Times Tab

Time Animation Widget
Each McIDAS-V display area has a set of time animation controls above the main display window.

The Time Animation Widget controls looping of displays through time. A series of small green boxes is displayed representing each frame of the
animation. The box corresponding to the current time is colored blue. Click on a box to select a different time. Right click on a box to disable that
frame in the animation. Disabled boxes will be colored red. The time of the data is displayed in the labeled pull-down list and in the entries of the
pull down list on the left. The toolbar of button icons, on the right, control time animation. Reading from left to right, the icons on the Time
Animation Widget do the following:

Show the first frame, and stop looping if looping is on.
Step Back one frame.
Toggle looping on or off.
Step Forward one frame.
Show the last frame, and stop looping if looping is on.
Show the Time Animation Properties dialog box.

Time Animation Properties Dialog
Click on the  in the animation controls to see the Time Animation Properties Dialog box. This dialog has two tabs.

By pressing Apply or OK you will set the properties in the Animation Widget. If you have the Save As Default button checked then the
properties will be saved off and used every time a new Animation Widget is created. For example, you may find that you are always setting the
dwell rate to a particular value. You can save that state off as the default state for all Animation Widgets that are subsequently created, both in the
current run of McIDAS-V and in future runs.

Settings Tab
The first tab allows you to change the values that control looping.

The Dwell controls how fast the animation occurs. Click on the slider icon:  to change the values. Values are seconds/frame.

Forward controls speed of looping forward.
Reverse controls speed of looping backwards.
First how long first frame is seen.
Last how long last frame is seen.

Select the looping style with the Direction menu.

Forward Loop forward in time
Backward Loop backward in time
Rocking Looping alternates between forward and backward directions.

Share the time animation in a display with the animation in other displays with the Share Times button. See here for more information.

Check Boxes Visible to show the boxes in the Time Animation Widget. The time boxes allow you to configure which frames will be disabled in
the Time Animation Widget. This behaves the same as the boxes in the main widget.
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You can also set the behavior for when the set of times available changes with the Reset->To menu. The options are the Start Time, End Time, or
No Change.

Define Animation Times Tab
The second tab allows you to define a custom animation time set.

By default, the times used in the animation time set are all of the times from the data that is being displayed. However, you can define your own
time set by selecting the Define your own list of times button.

You define how to determine the start time, end time and a time interval. The time interval is used to create the set of time steps (inclusive)
between the start and end times. The start time and end time modes are determined one of four ways:

Use Minimum/Maximum Time from Data This takes the time from the data that is being displayed.
Current Time (Now) This automatically updates the animation time set to use the current clock time. This is useful for animation of real
time data. If you select this option you can then define how often the animation set is updated with the Refresh Rate field. The Round To
field allows you to specify a rounding factor.
Fixed This mode allows to you to specify a fixed date/time.
Relative to End/Start time This mode uses the other time as the base time. For example, you could set the end time to be the Current
Time. And set the start time to be relative to the end time minus 1 hour (using the start time offset field). Note: you cannot have start and
end times both be relative to one another.

Once you select the start and end time modes you can define an offset which is added (or subtracted) to the base time. To change the offset select
the  button. When you do this the Offset Dialog will be shown:

This allows you to define a time offset by entering years, days, hours and minutes. Note, you can also specify a sign, "-" or "+".

By pressing apply you can apply the changes that you have made. This is also a good way to see if there are any errors. For example, the end time
cannot be less than the start time.



Zooming, Panning and Rotating
There are several methods to zoom, pan, and rotate in McIDAS-V. You can use the mouse, the arrow keys, a rubber band box, or the Zoom/Pan
Toolbar. To reset to the initial base viewpoint use the key combination Control-r.

Note: You need to click in the view window when using key combinations.

Note: If you are using an Apple Mac with a single button mouse, see below.

Zooming Panning Rotating
Mouse

Shift-Left Mouse Drag: Select a region by
pressing the Shift key and dragging the left
mouse button (MB1). 
Shift-Right Mouse Drag: Hold Shift key and
drag the right mouse button (MB3). Moving up
zooms in, moving down zooms out.

Control-Right Mouse Drag: Hold Control
key and drag right mouse to pan.

Right Mouse Drag: Drag right mouse to rotate.

Scroll Wheel
Scroll Wheel-Up: Zoom out. 
Scroll Wheel-Down: Zoom in.

 Control-Scroll Wheel-Up/Down: Rotate
clockwise/counter clockwise. 
Shift-Scroll Wheel-Up/Down: Rotate
forward/backward clockwise.

Arrow keys
Shift-Up Arrow: Zoom in. 
Shift-Down Arrow: Zoom out.

Control-Up arrow: Pan down. 
Control-Down arrow: Pan up. 
Control-Right arrow: Pan left. 
Control-Left arrow: Pan right.

Left/Right Arrow: Rotate around vertical axis. 
Up/Down Arrow: Rotate around horizontal
axis. 
Shift-Left/Right Arrow: Rotate
clockwise/counter clockwise.

The default mouse and keyboard controls can be customized using the Navigation controls preferences tab by selecting Edit->Preferences from
the main menu.

Apple Mac One Button Mouse Controls
Mouse controls are a bit more challenging if you are running McIDAS-V on a Mac with a single mouse button. The typical left mouse button
(MB1) functions are done with a click of the button. Right mouse options (MB3) are simulated using the Option key with a mouse click. Use the
following:

Option + click to rotate

Shift + Option + click to zoom

There is no replacement for the mouse panning actions on the Mac. Use the keyboard arrow functions or the Viewpoint toolbar instead.

The Viewpoint Toolbar

The Viewpoint Toolbar allows you to quickly switch the point of view to any of six choices, including from overhead (the same as you
see in a new display), from below, and from north, east, south or west. The buttons show the side of the point of view looking into the
3D display volume. Click on any of the buttons to change the point of view. The top button for overhead is also useful if the display is
in a confusing state and you want to get oriented. 

The other three buttons allow you to switch perspective between converging to infinity and not converging, define your own viewpoint
settings, and set the vertical limits. 

You can "tear away" the toolbar and place it elsewhere on your screen as a tiny window by dragging with the right mouse button on the
textured area above the toolbar. Clicking on the x on the toolbar will then restore the toolbar to its original location. 

You can specify any viewpoint exactly from any angle in 3D you like using the View->Viewpoint->Viewpoint Dialog menu choice.

The Zoom/Pan Toolbar

The Zoom/Pan Toolbar allows you to zoom and pan. Clicking on the "plus" icon zooms in, centered on the center of the display.
Clicking on the "minus" icon zooms out, centered on the center of the display. Clicking on the "house" icon restores the initial point of
view of this projection (overhead, centered on center of the map projection in use). Clicking on one of the arrow buttons moves the point
of view in the direction of the button; the display moves in the opposite direction. If you click on the up button, the map and display
move down. 

You can "tear away" the toolbar and place it elsewhere on your screen as a tiny window by dragging with the right mouse button on the
textured area above the toolbar. Clicking on the x on the toolbar will then restore the toolbar to its original location.

The Viewpoint Undo/Redo Buttons

The Undo and Redo buttons allow you to undo or redo viewpoint changes.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Navigation__mac
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_NavigationPreferences__FILE


 
Image 1: Transect view of wind speed.

Transect Views
The Transect View is a 2-Dimensional display that shows data along a transect line. This type of view can be created through the File->New
Display Tab(Window)->Transect Display menu.

The left vertical axis shows altitude in meters, the right axis shows pressure levels. The horizontal axis shows distance along the transect. You can
zoom and pan in this display with the normal key and mouse combinations.

The transect line that is being used in this view can be displayed or changed through the Transects->Edit menu. This creates a Transect Drawing
Control that is shown in another Map View. The Transect Drawing Control allows you to create or modify transect lines. Note, when you change
a transect line the Transect View is automatically changed. You can also select any of the pre-defined or user created transects from the
Transects menu as well.

In the Transects tab of the Properties dialog for the Transect View (from View->Properties) you can define a maximum distance to show.
Normally, data that lies with the bounding lines that are orthogonal to the transect line is shown in this display. The max distance gives a display
radius. Data that lies past this max distance is not displayed.
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Layer Controls
Overview
Gridded Data Displays
Satellite and Radar Displays
Profile Controls
Probes
Mapping Controls
Observation and Location Controls
Miscellaneous Controls
Charts
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Image 1: Side Legend

Overview
A Layer Control is the interface through which a layer can be managed. A layer is usually shown in a view though they can be stand-alone.

Legend
The legend in the Main Window lists the set of Layer Controls within that view. In the image below, the legend has been floated from the main
view window into its own window. This is done with the  Float Window button (the  Embed Window button will move the legend back into
the main window).

The legend shows each layer under the "layer category" of that display. For example, the legend in the above image shows the categories "Maps",
"Plan Views", "Probes", "3D Surface" and "Imagery". The layer category may be changed (see below). This is useful for grouping and controlling
the visibility of a group of layers.

The legend label shows the parameter or field name, the display type, and sometimes other information such as the level of a plan view or value
of an isosurface. The label may be changed by a user using items under the Edit->Properties menu item (described below). Clicking on the
highlighted part of the label will bring up the layers control window. Right clicking will bring up the layers control menu.

Each layer category within the legend can be toggled to show or hide the layers under that category with the Toggle Category button. The details
of a layer can also be toggled with the Toggle Details button. The visibility of the layers under a category (i.e., the graphical display within the
main view window) can be changed with the Category Visibility Checkbox. The visibility of an individual layer can be changed with the Layer
Visibility Checkbox

The  Remove button allows you to quickly remove a layer. The  Visibility Toggle Lock allows you to "lock" the current visibility of the layer
and not change it while doing the visibility cycling.

Detailed information about a layer may also be shown in the legend. For example, for those layer that use a color table, the color bar will also be
shown in the legend. Moving the mouse over the color bar shows intermediate values. Click on the color bar to get a Color Table Editor with the
color table for that layer.

Drag and Drop
A display control's drag and drop button  is shown in the Data Explorer when the display control is docked. By clicking and dragging on this
button you can drop it into another View to change which View the display control is in. Also, within the data explorer you can drop it onto one
of the View labels to also change the View. Within the legend you can also drag the button onto another Category label to change the display
category.

Menus
All layer control windows share a common set of File, Edit, View, and Help menu items, shown in the menu bar. Different controls may also
have custom items in these menus as well.

The File menu has these common choices:

Remove Display
Remove the display.

Save
A variety of ways of saving the state of the display.

Save Data in Cache
This allows you to save the current data of the display in a Cache Data Source as a new Field. You will be prompted for the name of
the field. You can use this in a variety of ways:

After calculating a complex formula, selecting operands for the formula, etc., to create the data in a display you can save off the
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formula and the data that was calculated. Then you can create new displays from that formula without having to reselect the
operands and recalculate the final data.
In a Web Map Server (WMS) display this allows you to capture the image and then make use of it in formulas and in other
displays. For example, you can drape the image over topography.

Save As Parameter Defaults
Allows you to save the current display state for the parameter as the default for that parameter in the future. See the Parameter
Defaults Editor page for more information.

Save Display as Favorite
Allows you to save the current display state (without the data) as a Favorite Display.

Save Display as Bundle
Allows you to save the current application state as a bundle or Web Start JNLP file.

Reload Data
Reload the data for this display.

Close Window
If the Display Control is shown in its own window this is used to close the control window. It normally doesn't remove the control (unless a
preference has been set).

The Edit menu has these common choices:

Color Table
For displays that have a color table this menu allows you to edit the color table, change the range, choose a new color table, etc.

Selector Color, et. al.
Some displays (e.g., data probe) use a single color in the display (e.g., for showing the selector point or line). Use this menu to set the color.

Change Parameter
Some displays allow you to change the data parameter that is being used.

Change Display Unit
Some displays allow you to change the unit that is used in the display, e.g., changing temperature plots in Kelvin to Celsius.

Change Contours
Displays with contours allow you to change the unit that is used in the display.

Use Times in Animation
For displays that have a time associated with them, you can select whether the times are used to calculate the animation steps.

Sharing
This sub-menu allows you to turn on/off sharing and to set the "share group". When sharing is turned on certain state is shared among
displays of the same type that are in the same share group. The share group can be an arbitrary name.

For example, the location of a vertical cross section, the color table, location of a probe point, etc., can all be shared.

Properties
The Properties dialog allows you to change the display label, the display category, the id and the color scale properties for this display.

The View menu has these common choices:

Visible
Checkbox allows you to toggle visibility.

Lock Visibility
Checkbox allows you to toggle the visibility lock (see visibility cycling below).

Bring To Front
If this display is showing at the same level in 3D as another (e.g., satellite and radar images in the same display), you can use this menu to
select which display is on top.

Show View Window
Show the View Window that holds this layer control.

Use Times in Animation
For layers that have a time associated with them, you can select whether the times are used to calculate the animation steps.

Display List
Allows you to set the color and visibility of the label for this control in the display list.

Use Data Projection
This will change the projection used in the view to the native projection of the display.

The Help menu has these common choices:

Details
Selecting this item brings up a window that shows detailed information about the display and any associated data.

User's Guide
Bring up the user guide entry for the particular display.

Properties Dialog
The Properties dialog is brought up with the Edit->Properties menu:
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Image 2: Display Control Properties

The Display Category field is arbitrary text and is used to organize the legend. The "<<" button shows a list of all of the current display
categories and allows you to easily set this field.

The Legend Label field is the label used in the legend of this display control. It can contain arbitrary text as well as a set of "macros". The
macros can be added to the label with the Add Macro button:

Short Name This is the short name of the parameter being displayed.
Long Name This is the long name of the parameter being displayed.
Data Source Name This is the name of the data source that produced the parameter being displayed.
Display Name The name of the display.
Timestamp The time of the data that is currently being displayed using the default time format preference. You can also use a macro of the
form %time:<time pattern>% to set a specific time format other than the default. <time pattern> follows the same rules defined in the User
Preferences section. For example, %time:HHz EEE dd MMM yyyy% would give something like 12GMT Fri 16 Feb 2007.
... And other values depending on the display.

The Extra Legend Labels field acts like the Legend Label field (e.g., with macros).

The Layer Label field acts like the Legend Label field to define the text label that is shown in the display list. The colored rectangle to the right
of the layer label changes the color. Left click and use the pull down menu to specify a color or create a custom color.

The Id field is used to define an ID for this display. The ID is used for accessing particular displays from the McIDAS-V Scripting Language.

There may be a variety of check boxes:

Show In Layer List Allows you to toggle the visibility of the label in the view window. Note that you must enable showing the list of
display labels that are toggled on using the View->Properties dialog of the view window, or by setting the global property for all display
through the User Preferences dialog.
Lock Visibility Toggle Locks/unlocks visibility toggling.
Show Note Text Arbitrary text notes can be added to a display. This checkbox menu item shows or hides the text field that allows you to
edit the notes.
Use Fast Rendering When this is checked on, McIDAS-V will not try to account for projection seams. This will cause displays to be
rendered faster at the expense of accuracy.

There may be other tabs shown, depending on the display. For example, the Color Scale tab allows you to configure where the color scale bar is
shown. The Spatial Subset tab allows you to define further spatial subsetting of the data.

Color Scale
For those controls that include color tables, you can display the color scale (legend) in the main view window. Use the options under the Color
Scale tab to configure the positioning and labelling of the color scale.
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Image 3: Color Scale Properties

Display Visibility

In the legend the Display Visibility checkbox to the left of the label can be used to toggle the visibility of that layer.
The function keys F1, F2, F3* can be used to cycle visibility as follows:

The F1 key cycles visibility through all non-locked layers, looping through each layer one at a time.
The F2 turns on all non-locked layers.
The F3 turns off all non-locked layers.

*On a Mac laptop, you may need to press the "Fn" key along with the particular function key.

The padlock icon  on the right side of the legend bar is used to block the effects of the visibility toggling described above. When locked
the visibility of a layer is not affected by the toggling.
Use the View->Visible checkbox menu item in each layer control's menu.



Gridded Data Displays
Plan View Controls
Flow Plan Controls
Vertical Cross-section Controls
Isosurface Controls
Volume Rendering Controls
Point Volume Controls
Value Plot Controls
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Image 1: Contour Plan View

Image 2: Color Shaded Plan View

Plan View Controls
Overview
Plan views can be made in three types of displays: contour lines, color-filled contours, and as a color-shaded image.

Properties

Contours

For the Contour and Color-Filled Contour Plan View there is a Contour: Change button that brings up the Contour Properties Editor. The
current contour interval is shown.

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc. This menu can also be accessed through the Edit->Color Table menu.

Vertical Position

This slider allows you to set the verical position of the image (For 2D displays).

Visible Range

In the Color Shaded Plan View the Visible Range allows you to set the range that determines what parts of the data is actually shown.
When checked, use the Change button to set the range of data shown.

Texture Quality

The Texture Quality slider allows you to set the quality of the displayed texture of the Color Shaded Plan View. A higher quality will take
longer to render and user more memory.

Smoothing

This control has an option to smooth the grid that can be used to smooth contour lines or flow fields for display. There are three types of
smoothing: 5-point, 9-point and gaussian weighted smoothers. The amount of smoothness can be set for the gaussian smoother. The higher
the amount, the smoother the grid.

Levels

Click on the Levels box to see a pull down menu of the native grid levels. Click on one level value to reset the plan to that level. The plan
level in use is shown in the data's native altitude units. The Levels box is editable. Click in the box, enter a value and hit return to set your
own value.

Additionally, you can click on the arrows to the right of the Levels box to switch levels, or click on the Cycle check box to animate
vertically through all available levels.

Shade Colors

The color-shaded display has two modes. It comes up with interpolated colors: every pixel is colored to give a smooth gradation of color.
The alternative is coloring an area of pixels corresponding to a single data grid cell with one color. Click off the Shade Colors box in the
control window to see this display.

Mode

The Mode selector allows you set the way the texture is displayed. You can select Solid, Mesh, or points. This is useful for looking at the
structure of the underlying data used to create the Color Shaded Plan View.

Plan Selector
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Another way to adjust the height of a Plan View through a 3D field is to drag the selector point (a colored rectangle) near the lower left
corner of the plot to a new height. The 3D display has to be rotated to see the display somewhat from the side to do this. The color of this
selector point can be changed through the Edit->Selector Color menu.



Flow Plan Controls
Overview
The Flow Plan View Controls are used to control plan (horizontal) displays (flow vectors, wind barbs, streamlines) of vector based data (e.g.,
wind components). They are similar to the Plan View controls. You can toggle between the vector and streamlines view and control the vector
size, color and skip interval.

Properties

Show:

Use the radio buttons to switch between displaying vectors and streamlines.

Vector Size

The length of the vectors can be changed with the Scale: box. This is an editable box where you can enter a new size and press return, or
use the  slider to change the value.

Streamline Density

Use the slider to change the density of the streamlines on the display.

Skip:

To avoid cluttering the display you can define the number of grid points that are skipped with the Skip combo box. A skip interval of 0
mean show all vectors, 1 means skip every other vector, 2 means show every third vector, etc. This is also an editable box, enter a new skip
interval and press return.

Range:

Lists the current range of values. Click on the  Edit icon to change the range.

Color:

Use pull down menu in the layer controls or the Edit->Color menu to change the color of the selector point and the vectors in the display.

Line Width:

Set the line width in the display. Click on the  or put in a value and hit enter to change the value.

Smoothing

This control has an option to smooth the grid that can be used to smooth contour lines or flow fields for display. There are three types of
smoothing: 5-point, 9-point and gaussian weighted smoothers. The amount of smoothness can be set for the gaussian smoother. The higher
the amount, the smoother the grid.

Levels:

Click on the Levels box to see a pull down menu of the native grid levels. Click on one level value to reset the plan to that level. The plan
level in use is shown in the data's native altitude units. The Levels box is editable. Click in the box, enter a value and hit return to set your
own value.

Click on the Cycle check box to animate vertically through all available levels.

Plan Selector

Another way to adjust the height of a Vector Plan View through a 3D field is to drag the selector point (a colored rectangle) near the lower
left corner of the plot to a new height. The 3D display has to be rotated to see the display somewhat from the side to do this. The color of
this selector point can be changed through the Edit->Color menu.
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Vertical Cross-section Controls
Overview
The Vertical Cross-section Controls are used to adjust vertical cross section displays. The control window has two tabs. The first includes a
duplicate of the display in the main McIDAS-V view window:

The second shows the settings for this display control:

Vertical cross sections can be made in three types of displays, with contour lines, color-filled contours, and as a color-shaded image.

Properties

Location:

This shows the location of the end points of the cross section. You can change the endpoints of the cross section by entering in new values
and hitting Enter.

Contour:

To set contour information use the Contour: Set button, which brings up the Contour Properties Editor.

Color Table:

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Visible Range

In the Color Shaded Cross Section View the Visible Range allows you to set the range that determines what parts of the data is actually
shown.

Selector Color

Select a color for the cross section position line and end points by selecting Edit->Selector Color.

Smoothing

This control has an option to smooth the grid that can be used to smooth contour lines or flow fields for display. There are three types of
smoothing: 5-point, 9-point and gaussian weighted smoothers. The amount of smoothness can be set for the gaussian smoother. The higher
the amount, the smoother the grid.

Selector Position:
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Use the slider to change the position of the selector in the main display.

Vertical Scale:

Click on Change to change the vertical axis range of the cross-section.

Shade Colors

The Color-Shaded display has two modes. It comes up with interpolated colors: every pixel is colored to give a smooth gradation of color.
The alternative is coloring an area of pixels corresponding to a single data grid cell with one color. Click off the Shade Colors box in the
control window to see this display.

Autoscale Y-Axis

When selected, the display will automatically scale the Y Axis to the data range along the selector line.

Time Animation Control

These controls start and stop looping of displays when more than one data time is loaded. See more in Time Animation Control.

Display

Use left-mouse button drag on the colored squares on the positioning line in the main view window to reposition the cross section.
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Isosurface Controls
Overview
Isosurfaces can be made in two types of displays, regular isosurfaces, and isosurfaces colored by another field. An isosurface is a 3D surface
mapping the location of a single parameter value through a 3D field. Isosurfaces are a 3D analog of a single contour line in a 2D plot; the
intersection of an isosurface and any plane is a contour line of the same value in that plane.

You can request an isosurface colored with a range of colors, where colors indicate the values of another field, not the one used to make the shape
of the surface. A common use is to color isosurfaces by height (geopotential height in some grid output) to show height of features above the
surface by color.

Properties

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Isosurface Value

Click on the  button or enter a value in the field and press return to set the value of the isosurface.
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Volume Rendering Controls
Overview
3D grids can be rendered as a volume display.

You can use the transparency features of the color table to see into the cloud.

Properties

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Visible Range

The Visible Range allows you to set the range that determines what parts of the data is actually shown. Check the box to enable the widget
and use the Change button to set the data range.

Use 3D Texture

When checked, the volume rendering display will use 3D texture.
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Point Volume Controls
Overview
The Point Volume display shows the grid points in a volume of data as individual points in the display. The controls are used to change color
tables, the number of points to skip, and the point size.

You can change the visible range and the transparency features of the color table to view sections of the 3D volume of data.

Properties

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Visible Range

The Visible Range allows you to set the range that determines what parts of the data is actually shown. Check the box to enable the widget
and use the Change button to set the data range.

Skip

Move the slider to skip a certain number of grid points to make a less dense display.

Point Size

Change the size of the displayed points by entering in a point size and hitting return.
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Image 1: Value Plot Controls

Value Plot Controls
Overview
The Value Plot controls are used to adjust the display of individual grid point values.

Properties

Declutter

Click on the Declutter checkbox to see all data points. The display otherwise shows only selected points that do not overlap.

Layout

The Layout model , the choice of how the data points are displayed, is named. Click on the model name to select other previously-defined
models, either provided by McIDAS-V or defined by users.

You can change the model, and create new models with the  Edit icon.

Scale

Move the slide to scale up or down the size of the displayed elements.

Skip

Adjust the slider to change the sampling factor. A higher value will mean less data points.

Levels

Click on the Levels box to see a pull down menu of the native grid levels. Click on one level value to reset the value plots to that level. The
level in use is shown in the data's native altitude units. The Levels box is editable. Click in the box, enter a value and hit return to set your
own value.

Additionally, you can click on the arrows to the right of the Levels box to switch levels, or click on the Cycle check box to animate
vertically through all available levels.



Satellite and Radar Displays
Image Controls
HYDRA Controls
WSR-88D Level III Controls
Level 2 Radar Layer Controls
Range Rings
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Image Controls
Overview
The Image Controls are used to adjust displays of satellite imagery.

Properties

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Vertical Position

This slider allows you to set the vertical position of the Image.

Resampling

Adjust the Pixel Sampling slider to change the resolution of the image. A larger number makes a lower resolution (coarser) display.
Texture Quality

This slider allows you to set the quality of the displayed texture of Image Control. A higher quality will take longer to render and more
memory.
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HYDRA Layer Controls
MultiSpectral Display Controls
Linear Combination Controls
4 Channel Combination Controls
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MultiSpectral Display Controls
Overview
HYDRA MultiSpectral Display controls are used to create a multispectral display within McIDAS-V. There are two sets of controls - The
MultiSpectral Display, and the MultiSpectral Probes. The Multispectral Display consists of three tabs. The first tab shows the spectra:

Use the Ctrl+Left Click+Drag combination to create a box of a region to zoom in on. To return to the full spectra, use Shift+Left Click. Middle
clicking on a point in the spectra will change the wavelength/wavenumber of the image displayed. Right Click+Drag will move the spectra left
or right. Left Click+Drag on the green wavelength/wavenumber selector bar will allow you to change the wavelength displayed in the image. The
selected wavelength/wavenumber will be displayed in the upper left corner of the spectra window.

The second shows the settings for this display control and the readout probes:

The third shows a histogram for the image:



Modify the color table range by left clicking and dragging on the histogram, or enter in a set of minimum and maximum values.

Multispectral Display Properties

Wavenumber:

Change the wavelength/wavenumber displayed in the image by entering in a new value and hitting Enter.

Band

Change the band displayed in the image by selecting a new value from the pull down menu.

Color Table:

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Vertical Position:

This slider allows you to set the vertical position of the image.

Readout Probes:

This section allows you to modify the probe visibility and color. Information regarding the probe value and lat/lon location are also listed.

Add Probe

This button allows you to add a new probe to the MultiSpectral Display.

Remove Probe

This button allows you to remove a probe from the MultiSpectral Display.

Range

The Range setting allows you change the minimum and maximum values shown in the image in the main display window.

Reset

Click the Reset button to reset the histogram back to the default range.
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Linear Combination Controls
Overview
The Linear Combinations controls are used to create and perform functions beyond the standard arithmetic functions in McIDAS-V. The console
tab consists of two parts - The spectra and the console:

The console allows a user to define multiple spectra and perform more complex mathmatical operations.

Command line functions

selector(wavenumber, color )

The selector Jython function creates a spectra line with a optionally defined color and wavelength. If no wavenumber parameter is found, a
data-dependent default value will be used. If no color parameter is found, the color of the selector bar will default to green. The spectra line
can be dragged between wavelength/wavenumbers.

Examples:

a = selector() [ Creates a green selector named "a" at a data-dependent wavenumber or
wavelength]

b = selector(1000) [ Creates a green selector nambed "b" at wavenumber 1000.0 ]

c = selector('cyan') [ Creates a cyan selector named "c" at a data-dependent wavenumber or
wavelength]

d = selector(919.5,
'red') [ Creates a red selector named "d" at wavenumber 919.5 ]

e = selector('40',
'orange')

[ Creates a orange selector named "e" at the wavenumber? associated with
band 40 ]

f = selector('11') [ Creates a green selector named "f" at the wavenumber assocaited with band 11
]

combine(combination, name )

The combine Jython function computes the mathmatical operation corresponding to the expression entered. The results are available in the
Field Selector under the "MultiSpectral" tree in the Fields tab listed under the optional name. If no name was specified, the results will be
displayed using the expression that was computed. A combination is required for this function.

Examples:
a = selector('2', 'red') [ Creates a red selector named "a" at the wavenumber associated with band 2]
b = selector('1',
'yellow')

[ Creates a yellow selector nambed "b" at the wavenumber associated with band
1]

c = ((a-b)/(a+b)) [ Creates a variable c that corresponds to the expression ((a-b)/(a+b))]

combine(c, 'NDVI') [ Results of the "c" variable will appear in the Field Selector as the "NDVI"
entry ]

combine((a-b)/(a+b)) [ Results of the expression in the combination field will appear in the Field
Selector ]

print()

The print function prints out information about the current wavelength/wavenumber of a selector, or its value.

Linear Combination Properties

Spectra Window



Use the Ctrl+Left Click+Drag combination to create a box of a region to zoom in on. To return to the full spectra, use Shift+Left Click.
Middle clicking on a point in the spectra will change the wavenumber of the image displayed. Right Click+Drag will move the spectra left
or right. Left Click+Drag on the wavelength/wavenumber selector bar(s) will allow you to change the wavelength displayed in the image.



4 Channel Combination Controls
Overview
The 4 Channel Combination controls are used to create a basic linear combination of spectral bands. There are two sets of controls - The top of
the controls shows the spectra, while the bottom half gives the linear combination option:

Use the Ctrl+Left Click+Drag combination to create a box of a region to zoom in on. To return to the full spectra, use Shift+Left Click. The
Middle Click+Drag feature will list the wavelength/wavenumber as well as the reflectance or Brightness Temperature at a point along the spectra.
Use the Left Click+drag option to move the spectra selector bar(s) to a different value.

The 4 Channel Combination tool allows you to specify arithmetic expressions for four spectral bands. Use the pull down menus between variables
to select the appropriate arithmetic expression for the equation. To apply a multiplier to any of the variables, change the value ahead of the
wavelength/band.

Multispectral Display Properties

4 Channel Combination Equation

Change the wavenumber displayed in the image by entering in a new value and hitting Enter or use the pull down menus to select a band.

Compute New Field

Click to compute the expression. The resulting image will show up in the Field Selector under the "Multispectral" field in the Fields tab.



WSR-88D Level III Controls
Overview
The controls for Level III radar imagery are similar to the Image Control and are used to adjust image displays of these imagery.

Properties

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Vertical Position

This slider allows you to set the vertical position of the Radar Image.

Resampling

Adjust the Pixel sampling slider to change the resolution of the image. A larger number makes a lower resolution (coarser) display.
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Level 2 Radar Layer Controls
Radar Sweep Controls
Radar RHI Display Controls
Radar Volume Controls
Radar Isosurface Controls
Radar Cross Section Controls
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Image 1: Level II Radar Controls

Radar Sweep Controls
Overview
The Radar Sweep Controls are used to control displays of single level sweeps of radar data. The controls can be used for either 2D or 3D views.

Properties

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Visible Range

The Visible Range allows you to set the range that determines what parts of the data is actually shown. Check the box to enable the widget
and use the Change button to set the data range.

Texture Quality

Use the slider to change the texture quality of the display.

Elevation Angles

Elevation Angles allows you to select which of several radar tilts or elevations is displayed. Click on the Cycle check box to animate
vertically through all available angles. The Cycle option works when the top level of the data type in the Fields section of the Field
Selector is selected, which makes all angles available in the display.

Display Mode

Use the pull down menu to change the display mode of the sweep view.

Station

Shows the station location id, latitude, longitude, and altitude.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ColorTableEditor__FILE


RHI Display Controls
Overview
The RHI display appears in the main 3D window and as a 2D plot in its display control. In order to display the RHI, the top level of the data type
in the Fields selection of the Field Selector must be selected. The control window contains two tabs. The first shows the RHI in 2D:

The second shows settings to control the display:

Properties

Station

Shows the station location id, latitude, longitude, and altitude.

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Selector Position:

Use the slider to change the position of the selector in the main display.

Vertical Scale

Changes the vertical axis range of the RHI line.

Autorotate RHI

Starts and stops autorotation of the RHI in the main 3D window. The 2D plot changes with the 3D RHI display when autorotate is on.

Selector Line color

Select the color of the selector line controlling the RHI azimuth in the main 3D window from the Edit->Select Line Color menu.
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Radar Volume Scan Controls
Overview
The radar volume scan controls are used to show a radar volume as a series of nested cones. In order to display the volume, the top level of the
data type in the Fields selection of the Field Selector must be selected.

Properties

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Visible Range

The Visible Range allows you to set the range that determines what parts of the data is actually shown. Check the box to enable the widget
and use the Change button to set the data range.

Station

Shows the station location id, latitude, longitude, and altitude.
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Isosurface Controls
Overview
Displays of Level II isosurfaces are controlled by the Isosurface controls. In order to display an isosurface, the top level of the data type in the
Fields selection of the Field Selector must be selected.

Properties

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Isosurface Value

Click on the  button or enter a value in the field and press return to set the value of the isosurface.
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Cross Section Controls
Overview
The radar vertical Cross-section Control is used to adjust vertical cross section displays of radar volume data. In order to display the cross-section,
the top level of the data type in the Fields selection of the Field Selector must be selected. The control window has two tabs. The first includes a
duplicate of the display in the main McIDAS-V display window:

The second shows the settings for this Layer Control:

Properties

Location

This location shows the location of the end points of the cross section.

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Selector Position

Move the slide to change the vertical position of the selector line.

Selector Color

Use the Edit->Selector Color option to change the color of the selector line.
Visible Range

When checked, the Visible Range checkbox allows you to set the range that determines what parts of the data is actually shown.

Vertical Scale

Click to change the vertical scale of the 2D cross section view. The Auto-scale checkbox, when checked, will scale the Y-AXis of cross
section to the sampled data range.

Shade Colors

When checked, color will be blended between the radar data bins. The shaded display usually is not preferred for radar displays.

Display

Use left-mouse button drag on the colored squares on the positioning line in the main view window to reposition the cross section.
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Range Rings
Overview
The Range Rings control show a set of concentric circles labeled by distance from the central point, with radial lines, useful for judging distance
and angle from a geographic location. Range Rings are often used with radar imagery. The control window is composed of two tabs. The first
allows the user to specify the location of the range rings:

The second tab allows the user to control how the rings are displayed:

The Range Rings are oriented with local north-south on the displayed map projection. In some cases the eastward radial line may not be
horizontal.

You display Range Rings from the main menu with the Display->Add Range Rings menu. The Range Rings will appear centered on the map
projection. You can move them by resetting the latitude-longitude or station as described below. McIDAS-V can display several radar images at
once, and range rings can be displayed for each one. You may display as many range rings at one time as you like, centered anywhere, not just
radar locations.

Properties

Location

The position of the center of the rings is shown in the text fields Center latitude and Center longitude To re-center the rings, you can
select a radar station by name from the pull-down list, or you give new lat/lon values by entering values in a text field and pressing return.
Note: west longitudes are negative.

Position at click

When this check box is selected the range rings will be centered where you click in the main display

Vertical Position

This slider allows you to set the vertical position of the Range Rings.

Visibility

You can toggle the visibility of the range rings, labels, and radials on and off with the Visible checkboxes. To toggle the entire radar grid at
once, use View->Visible checkbox menu.

Spacing

You can change the ring spacing, the label spacing, and the azimuth interval of the radials, using the control window. The values appear in
the text fields under Spacing. You can give new values two ways: enter a new value in the text field by clicking in the field, entering the
new value, and pressing Enter, or click on the pull-down arrow on the right side of the text field to see a list of common values.

Color

You can change the color of the lines and labels with the Color pull-down lists.

Line Width

You can change the width of the lines and labels with the Line Width pull-down lists.

Max. Radius

Use the pull down menu to select the maximum radius size of the range ring.



Profiler Controls
McIDAS-V Profiler displays show wind data from the NOAA National Profiler network. There are three different types of displays available:

Profiler Time/Height Controls
Profiler Station Plot Controls
Profiler 3D Multi-station Controls
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Image 1: Time/Height Display

Profiler Time/Height Controls
Overview
The Profiler Time/Height display shows winds at all levels above one station, for one or more times. Winds are shown with the meteorological
wind barb symbol. The location of the barb on the plot shows wind observation height above mean sea level; the barb's orientation gives wind
direction on a map view.

The map position of the vertical profile is indicated by the "Lat: Long:" readout above the graph. The time and height values on the plot can be
sampled by dragging the middle mouse button over the plot.

Properties

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Windbarb size

Use the Windbarb size box to enlarge or reduce the wind barbs.

Vertical interval

Use the Vertical interval box to change the vertical separation between wind barbs.

Stations

If more than one station was selected in the data selection, the Stations box appears with a list of all stations selected. Use it to switch
between stations displayed.

Latest data on left

The Latest data on left checkbox is used to change the order of times displayed. When checked, the most recent data time is on the left;
and the oldest on the right.
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Image 1: 2D Multi-station Control

Profiler Station Plot Controls
Overview
The Profiler Station Plot display shows winds at one levels above one or more station, on the main 3D mapped view window. Winds are shown
with the meteorological wind barb symbol.

Properties

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Windbarb size

Use the Windbarb size box to enlarge or reduce the wind barbs.

Plan level

Use the Plan level box to change the level above mean sea level of the wind barbs.
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Image 1: Profiler 3D Multi-station Control

Profiler 3D Multi-station Controls
Overview
The Profiler 3D View shows winds at all levels above one or more stations in the main 3D view window. Winds are shown with the
meteorological wind barb symbol.

Properties

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Windbarb size

Use the Windbarb size box to enlarge or reduce the wind barbs.

Vertical interval

Use the Vertical interval box to change the vertical separation between wind barbs.
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Probes
Data Probe/Time Series
Time-Height Controls
Vertical Profile Controls
Data Transect Controls
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Data Probe/Time Series
Overview
The data probe shows a time series chart of one or more fields at a single location. It also shows a tabular readout of the value at the current
animation time step. In the image below we have a Probe Control showing three parameters: T, RH and windspeed. Their values at the current
animation time step are shown in the table and their time series are shown. Note, the T and RH fields are shown in one chart and the windspeed is
shown in another chart. You can have any number of fields and any number of charts. You can configure the layout of the charts, the chart
properties and the line properties for each parameter. See here for more information.

A small colored square Selector Point in the main McIDAS-V display shows where the probe is located. You can drag the probe point over the
map in the main display. You can change the probe point vertically as well.

The table shows the parameters with their values, the level at which the value is sampled, and the type of sampling. The location of the probe is
shown, in latitude, longitude, and altitude. When surface data is probed the height of the probe point does not matter.

You can add new parameters a number of ways:

Right click on the table and select Add Parameter...
Through the Edit->Add Parameter... menu.
Through the View->Parameters->Add Parameter... menu.

Parameter Properties
These parameter actions can be accessed by right clicking on the parameter row in the table or through the View->Parameters menu.

Copy

Copy the selected parameter. This allows you view the same parameter value at different locations or with different sampling methods.

Chart Properties

Allows you to change how the parameter is displayed in the chart. See here.

Change Unit

You can change the display unit for the selected parameter.

Set Sound...

You can define a sound type and range for the parameter. As the probe is moved around or the time animation is run a sound is applied
based on the value.

Remove

Remove the selected parameter.

Displays

You can directly create new display using the selected parameter.

Probing on Point Data

When probing on point data, the control will find the closest observation to the probe position and use that data to sample on.

Properties

Export Current Time as CSV

Export the current time step's data or all times as a comma separated file (CSV) by selecting the File->Save menu.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Chart__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Chart__FILE


Export All Times as CSV

Export all times as a comma separated file (CSV) by selecting the File->Save menu.

Change Display Format

Change how the data is displayed in the table by selecting this option from the Edit menu. This template is html with macros that get
replaced with the display value, unit, raw value and raw data unit.

Add Parameter...

Add a new parameter to the list using the Edit->Add Parameter menu.

Probe Position

Reset the probe position and fix the x, y or z axis of movement by using the View->Probe->Position menu. Resetting the probe position is
useful when the probe point gets lost in the displays.

Probe Size

Increase and decrease the probe size by using the View->Probe->Size menu.

Probe Shape

Change the shape of the probe by using the View->Probe->Probe Shape menu.

Location

Enter a latitude, longitude or altitude in the location fields on the bottom right side of the Layer Controls and press return to set the
location of the probe.

Levels

The Level column in the table shows the height of the sample point. Click in the level value box, and you can reset the level for that
parameter to other altitude values (in the native data set) with a selector list of levels that pops up. The level "Probe's" is whatever level the
probe happens to be at, which may not be a native level of the data. Note that once you set the level to a level not at the probe point, the
probe point no longer shows where the sample is from. The probe does have the same latitude and longitude as the data shown, but not the
altitude.

Sampling

Probe values can be interpolated from neighboring grid values, since the probe position almost never coincides exactly with the location of
a data point. The Sampling column shows if this interpolation is used. "Weighed average" uses interpolation of nearby data points; "Nearest
neighbor" gives the exact value of the datum in the grid cell where the probe is located .Click in the sampling column box, and you can set
the sampling method for that parameter.



Time-Height Controls
Overview
A time-height display is a display of samples of a 3D parameter along a vertical profile line from top to bottom of the available data, with time as
the independent coordinate (x axis). You can choose both a contour time height display and a color shaded time height display.

Properties

Position

The map position of the vertical profile is indicated by the "Lat: Long:" readout below the graph. Enter a value in the latitude or longitude
field and press return to set the value.

The map position of the profile is shown in the main 3D view window by a colored vertical line. There is a Selector Point on top of the
vertical line. You can move the vertical profile line over the map by dragging the Selector Point with the left mouse button. You can zoom
in on the display graph by holding down the Shift key and dragging the mouse pointer up while pressing the left mouse button; drag down
to zoom out. You can pan the graph by holding down the Ctrl key and dragging the mouse pointer in any direction while pressing the left
mouse button.

Contour

To set contour information use the Contour: Change button, which brings up the Contour Properties Editor.

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Latest Data on Left

This checkbox reorders the x axis of the display to show the latests data on the left when checked, and on the right when unchecked.

Reset Probe Position

Resets the location of the probe to the default location of the center of the data boundaries. This option is found under the Edit menu.

Selector Color

Change the color of the selector point on top of the vertical profile line by using the Edit->Selector Color menu.

Change Parameter

Change the parameter of the vertical profile by using the Edit->Change Parameter menu.

Change Display Unit

Change the unit of the parameter to be displayed by using the Edit->Change Display Unit menu.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ContourDialog__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ColorTableEditor__FILE


Vertical Profile Controls
Overview
The Vertical Profile display controls show a plot of any number of field values versus altitude. You can add new fields to show with the Edit-
>Add Parameter... menu. See here for more information about customizing the chart.

Properties

Position

The map position of the vertical profile is indicated by the "Lat: Lon:" readout below the graph. Enter in a value in the latitude and/or
longitude field and press return to set the value to move the location of the probe.

The map position of the profiel is shown in the main 3D view window by a colored vertical line. There is a Selector Point on top of the
vertical line. You can move the vertical profile line over the map by dragging the Selector Point with the left mouse button.

Time Animation Control

controls looping of displays when more than one data time is loaded. See more in Time Animation Control.

Reset Probe Position

Resets the location of the probe to the default location of the center of the data boundaries. This option is found under the Edit menu.

Selector Color

Change the color of the selector point on top of the vertical profile line by using the Edit->Selector Color menu.

Add Parameter...

Add a new parameter to the vertical profile chart using the Edit->Add Parameter menu.

Probe Position

Reset the probe position and fix the x, y, or z axis of movement by using the View->Probe->Position menu. Resetting the probe position is
useful when the probe point gets lost in the displays.

Probe Size

Increase and decrease the probe size by using the View->Probe->Size menu.

Probe Shape

Change the shape of the probe by using the View->Probe->Probe Shape menu.
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Data Transect Controls
Overview
The data transect controls are used to adjust data transect displays. The control window includes a display of the profile of the data along the
transect. The vertical axis is the parameter value and the horizontal axis is the distance along the cross section. In the main window, a transect
selector allows you to position the location of the transect by dragging the selector points along the line.

The control window consists of two tabs. The first shows the the profile of the data along the transect:

The second contains widgets for changing properties of that display:

Properties

Location:

Shows the starting and ending points of the data transect line. You can change the endpoints of the data transect by entering in new values
and hitting Enter.

Time Animation Control

These controls start and stop looping of displays when more than one data time is loaded. See more in Time Animation Control.

Color Table:

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Selector Position:

This slider allows you to set the vertical position of the data transect line.

Vertical Scale:

Click Change to modify the vertical axis range.

Autoscale Y-Axis

When selected, the display will automatically scale the Y Axis to the data range along the selector line.

Line Width:

Use the slider to change the width of the data transect line.
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Selector Color

Change the color of the selector point on top of the vertical profile line by using the Edit->Selector Color menu.

Change Parameter

Change the parameter of the vertical profile by using the Edit->Change Parameter menu.

Change Display Unit

Change the unit of the parameter to be displayed using the Edit->Change Display Unit menu.



Mapping Controls
Map Controls
Topography Controls
Shapefile Controls
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Map Controls
Overview
Maps in McIDAS-V are shown using the Map display controls. There are two ways these controls are used: for the default background maps and
for a user created map display. The control window is composed of two tabs. The first lists the set of available maps:

The second allows the user to control the display of the latitude/longitude lines and control the Z level of the maps:

New maps may be added through the Edit menu. You can choose to add any of the predefined maps available to McIDAS-V or you can select a
map file (e.g., a shape file) from the file system.

The File->Default Maps-> Save as the Default Map Set menu item allows you to save the current set of maps in a display as the default maps.
When a new view window is created the maps that are saved as the default are used as the background maps. To clear the default maps, choose
the menu item File->Default Maps->Remove Local Map Defaults.

Properties

Maps

This list shows the set of currently loaded maps. In this list you can remove a map, change its visibility, line width, style and color. The
Fast Rendering button, when on, can save on rendering time by not checking for projection seam crossings. Note: some maps will display
incorrectly when fast rendering is turned on.

Latitude/Longitude lines

These controls allow you to display latitude and longitude lines. You can set the visibility, spacing, line width, line style and color. There is
also an option to choose to turn on Fast Rendering.

Map position

This slider allows you to set the vertical position of the maps.



Topography Controls
Overview
The Topography controls allow you to display topography datasets. The above image shows the control user interface which allows you to change
the color table, shading and display mode.

The following image shows the actual display:

Properties

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Shade Colors

Turning Shade Colors off will provide for a blocky effect.

Display Mode

There are 3 Display modes: solid, mesh and points, each providing a different type of display.

Point Size

Change the point size by entering a value into the box.
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Image 1: Shape File Control Filters Tab

Image 2: Shape File Control Table Tab

Shapefile Controls
Overview
McIDAS-V supports the ability to load and display GIS shapefiles. You can select and load a shape file (i.e., a file that ends with .shp) from the
file chooser. The zipped (.zip) version of shapefiles can also be loaded.

For shape files that also have a data base file (.dbf) you can control what shape segments are shown with the Filters tab. For a further description
see here.

Note: McIDAS-V supports a simple XML format for maps. The Shapefile Control can export the displayed shapes in this XML format the File-
>Save->Export Displayed Shapes... menu.

When the shape file has an associated data base file (.dbf) a tabular listing of the attributes is shown in the Table tab. Use the Select Fields to
Show button to select what fields to show. The table can be exported as a CSV file with the File->Save->Export Table... menu.

Properties

Vertical Position

This slider allows you to set the vertical position of the Shapefile display.

Set Line Width

Use the Set Line Width slider to change the width of the lines in the display. Note on some versions of Java3D on Windows platforms line
width does not work.
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Line Color

Use the Edit->Line Color menu to select a color for the position line and its end points.

Apply Filters

Click to immediately apply one or more filters to the current shape file display.

Filters Enabled

When checked, the filters will be enabled. You can choose to match all or any of the filters with the radio buttons.

Property

Select a property to filter. Use the =, >, <, and additional search conditions to apply the filter conditions.

Value

Enter in a value to be applied to the filter.

Select Fields to Show

Click to bring up a box which allows you to add, remove, and organize the list of fields to show.

Select Unique Fields

Click to bring up a box which allows you to add, remove, and organize the list of unique fields to show.

Line Color

Change the shapefile line color by using the Edit->Line Color menu.



Observation and Location Controls
Point Data Plot Controls
Observation List Controls
Gridded Point Data
Sounding Display Controls
Front Controls
Location Controls
WorldWind Controls
Track Controls
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Point Data Plot Controls
Overview
The Point Data Plot Controls show a set of observations using a station model. The control window consists of four tabs. The first tab allows you
to control basics of the display:

The second tab allows you to change the observation times that are shown in the display. By default, data for a single time corresponding to the
current animation time will be shown. Using this widget allows you to show multiple times at once.

Clicking on  opens a menu that allows you to select specific start and end times.

The third tab provides a time series chart and a data readout table of a selected station. To use this simply click on a station in the main display.
Use the Select Fields button to show a dialog that allows you to select what fields are displayed in the table. Double click or right click on a table
row to add it to the time series chart. See here for more information about customizing the chart. The File->Save->Save Plot Preferences menu
item allows you to save the current set of selected fields and their chart line properties as the default to use for all future point data plots. The
View->Show Raw Data menu controls whether the data in the table is formatted or show as raw data. The File->Export Table menu item allows
you to export the table as a comma separated value (CSV) file.
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The fourth tab allows you to specify a set of visibility filters. See below for further discussion on this.

Properties

Declutter

Click on the Declutter checkbox to see all locations or stations. The display otherwise shows only selected stations that do not overlap.
When decluttering is turned on then, as you navigate through the display (e.g., through zooming) then the decluttering will be progressively
applied. The small "lock" icon allows you to lock the stations that are currently being displayed and not have their display changed when
navigating.

Density

This slider allows you to change how dense the display of stations is when decluttering.

Only Show Every

This field allows you to sub-set the data that is being displayed by only showing every N minutes. For normal observation data (e.g., station
data) this field is not needed. However, for observation data that contains many times (e.g., airplane track data) you can use this field to
subset the times.

Note: If you are displaying point data that has a large number of times you will be prompted whether you want to view all of the times. If
Yes then this is automatically set.

For most of the point data sources you can specify a time binning through the data source properties.

Layout Model

The Layout model, the choice of data and layout design for data display at each station, in use is named. Click on the model name to select
other previously-defined station models, either provided by McIDAS-V or defined by users.

You can change the station model (plot layout), and create new station models, with the Layout Model Editor by clicking on the  Edit
icon.

Scale

You can scale up or down the size of the displayed elements with this field. Click Apply to make the changes.

Line Width

Enter in a line width and hit enter or use the  slider to choose a value.

Vertical Position

You can choose to display the locations at their altitude (if there is one) or you can override this and specifically define the vertical position.

Show

Click to show either individual or multiple times at once.

Range

Click on the  Edit icon to change the range of time and day.

Declutter

When enabled, allows you to change how often data is displayed based upon time.

Filters

The Point Data Plot Control provides the ability to define a set of filters to show or hide particular observations based on the values they
hold.
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The above image shows the tab with which you define filters. This image shows two filter expressions, one that states the T field needs to
be greater that 35 F, the other states that the SPD value needs to be greater than 10. The unit of the value you enter (e.g., F) is defined with:

[unit_name]

If you do not provide a unit then the comparison is done using the native unit of the observation value.

You can define any number of expressions, disable/enable the filters, and define whether any expression can match or if all expressions
must match.



Observation List Controls
Overview
The Observation List Controls show a set of observation data in a textual list format.

Properties

Select Fields

Use the Select Fields button to show a dialog that allows you to select what fields are displayed in the table.

Only Show Every

This field allows you to sub-set the data that is being displayed by only showing every N minutes. For normal observation data (e.g., station
data) this field is not needed. However, for observation data that contains many times (e.g., airplane track data) you can use this field to
subset the times.

Show Raw Data

The Show Raw Data button controls whether the data in the table is formatted or show as raw data.

Exporting Data

The File->Save->Export Table menu item allows you to export the table as a comma separated value (CSV) file.



Gridded Point Data
Overview
McIDAS-V can create gridded fields of numeric data using the Barnes Objective Analysis. You can control the parameters used to create the grid
from the Data Source Properties or using the "Grid Parameters" tab in the Data Subset panel of the Field Selector:

The resulting grid can be displayed using any of the Gridded Data Displays.

Properties

Spacing

You can set the grid spacing as follows:
Automatic - grid spacing will be calculated from the observation density
Degrees - use a specific lat/lon spacing
# Points - set the number of grid points in the x and y direction

Grid Size

Specify the grid spacing if not using automatic calculation.

Passes

Set the number of passes for the Barnes analysis to do 4 passes recommended for analysing fields where derivative estimates are important
(Ref: Barnes 1994b) 3 passes recommended for all other fields (with gain set to 1.0) (Ref: Barnes 1994c "Two pass Barnes Objective
Analysis schemes now in use probably should be replaced by appropriately tuned 3pass or 4pass schemes") 2 passes only recommended for
"quick look" type analyses.

Search Radius

Set the search radius (in grid units) for the weighting of points in determining the value at a specific grid point. Should be in the range 0.2
to 1.0. Data are fitted more closely with a gain of 0.2 (at the expense of less overall accuracy over the entire grid); larger values smooth
more.

Gain

Factor by which scaleLength is reduced for the second pass. Should be in the range 0.2 to 1.0. Data are fitted more closely with a gain of
0.2 (at the expense of less overall accuracy over the entire grid); larger values smooth more. Suggested default: 1.0f Set the gain for each
pass after the first.

First Guess Field

You can use a model grid as a first guess field for the analysis. Select the "Grid Parameters (with first guess)" field and you will be
prompted to select the gridded field to use for the first guess.

References

Barnes, S.L., 1994a: Applications of the Barnes objective analysis scheme Part I: Effects of undersampling, wave position, and station
randomness. J. Atmos. Oceanic Technol. 11, 1433-1448.

Barnes, S.L., 1994b: Applications of the Barnes objective analysis scheme Part II: Improving derivative estimates. J. Atmos. Oceanic
Technol. 11, 1449-1458.

Barnes, S.L., 1994c: Applications of the Barnes objective analysis scheme Part III: Tuning for minimum error. J. Atmos. Oceanic
Technol. 11, 1459-1479.
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Image 1: The Grid Sounding Control with a Skew-T

Sounding Display Controls
Overview
The meteorological sounding display is available for:

RAOBs (balloon soundings)
numerical weather prediction model output with temperature and humidity. The dew-point temperature is computed by internal code from
temperature and relative humidity grids.
from a local file that contains aircraft track data.

To load sounding data see Choosing RAOB Sounding Data and Displaying Gridded Data. The sounding display consists of a table of aerological
parameters and three tabs in the Layer Controls . The first includes an aerological (thermodynamic) diagram (e.g., skew-T, Stuve, Emagram):

A label at the top of the sounding window shows the latitude-longitude position of the sounding. The RAOB station location is shown on the main
McIDAS-V display as a small colored square. When displaying sounding plots made from gridded model output, the position of the sounding is
shown in the main 3D view window by a solid-color selector point and vertical line. You can move this model-output-based sounding position
over the map by dragging the selector point with the left button.

When displaying a sounding diagram made from gridded numerical weather model output, there is a pull-down selector menu of the model output
valid times in the upper right corner.

The animation control buttons are available in either case:

To increase precision using the sounding diagram, enlarge the window by dragging on the edges. You can zoom the sounding diagram by holding
down the Shift key and dragging the right button upwards; drag downwards to zoom out. You can pan the diagram by dragging the mouse pointer
in any direction while pressing the right mouse button.

The temperature and dew-point traces can be modified via the cursor. Press the left button on the first data-point to be modified and drag it
horizontally along an isobar to the desired position, then move the pointer diagonally along an isotherm to keep the data-point at the desired
position and to pick-up the next data-point. Repeat until done and then release the mouse button.

The second tab shows a 3D hodograph display:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Sounding__connecting
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Grids__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Animation__FILE


Image 2: The Grid Sounding Control with a 3D Hodograph

Image 1: The Grid Sounding Control with a Table of all Sounding Values

The hodograph is enabled if the plotted data includes wind fields. It can be rotated into 3D using the mouse and keyboard combinations. To reset
the hodograph use Ctrl+R.

The third tab shows a table of all values in the sounding:

Aerological Parameters
The table to the left of the sounding diagram contains aerological parameters determined from the atmospheric sounding displayed in the diagram.
The following abbreviations are used:

LCL
Lifting Condensation Level: the level at which a pseudo-adiabatically lifted air-parcel becomes saturated with water-vapor.

LFC
Level of Free Convection: the level at which the virtual temperature of a pseudo-adiabatically lifted air-parcel changes from being less than
the environment's virtual temperature to being greater than the environment's.

LNB
Level of Neutral Buoyancy: the level above the LFC at which the virtual temperature of a pseudo-adiabatically lifted air-parcel equals the



environment's virtual temperature.
CAPE

Convective Available Potential Energy: the area between the virtual temperature trace of the pseudo-adiabatically lifted air-parcel and the
virtual temperature trace of the environment from the LFC to the LNB in which the parcel's virtual temperature is greater than the
environment's (positive CAPE connotes convective development).

CIN
Convective Inhibition: the negative of the area between the virtual temperature trace of the pseudo-adiabatically lifted air-parcel and the
virtual temperature trace of the environment from the parcel's initial conditions to the LFC in which the parcel's virtual temperature is less
than the environment's (negative CIN connotes initial positive work to lift the parcel).

Properties

Soundings

When displaying multiple sounding locations, use the pull down menu to select a station to display.

Dry Adiabats

When checked, displays the dry adiabats on the diagram.

Saturation Adiabats

When checked, displays the saturation adiabats on the diagram.

Mixing Ratio

When checked, displays the mixing ratio lines on the diagram.

Parcel Path

When checked, displays the path of a parcel of air lifted pseudo-adiabatically from the initial point to the top of the diagram.

Virtual Temperature

When checked, the virtual temperatures of the environmental profile and pseudo-adiabatically lifted air-parcel are displayed.

Grid Points

When checked, turns on the display of the grid points in the main display.

Stations

Toggle the visibility of the RAOB station location mark in the main display window.

Parcel mode

Use the pull down menu to specify how the initial conditions of the pseudo-adiabatically lifted air-parcel (i.e. the parcel's pressure,
temperature, and moisture content at the start of the pseudoadiabatic lifting) are determined from the environmental sounding (i.e. the
temperature and dew-point profiles according to the mode indicated. The choices are:

Bottom of Sounding - The initial conditions of the parcel are determined from the temperature and dew-point at the lowest (i.e.
highest pressure).

Below Cursor - The initial conditions of the parcel are determined from the temperature and dew-point profiles by computing the
pressure-weighted mean potential temperature and water-vapor mixing-ratio of the atmosphere that lies below the cursor when the
middle mouse button is pressed. Thus, pressing the middle button at 950 hPa for a sounding that starts at 1000 hPa will effectively mix
the lower 50 hPa of the atmosphere and lift the resulting parcel starting at 975 hPa.

At Cursor Pressure - The initial pressure, in-situ temperature, and moisture content of the parcel are taken from the temperature and
dew-point profiles at the pressure of the cursor when the middle mouse button is pressed. In At Cursor (Press, Temp) mode, the
initial pressure and in-situ temperature of the parcel equal the pressure and temperature values under the cursor when the middle
mouse button is pressed. The initial moisture content is determined from the dew-point profile at the initial pressure.

At Cursor (Press, Temp) - The computed path of a lifted parcel is automatically updated when appropriate. In both Below Cursor,
At Cursor Pressure, and At Cursor (Press, Temp) modes, the path will update as the cursor is dragged. In all modes, the path will
update whenever the profiles change.

Wind spacing

Allows the user to control which wind levels are shown in the display.

Reset Sounding

Reset the temperature and dewpoint profiles back to their original values by selecting Edit->Reset Sounding.

Show U and V

When checked, Speed and Direction values in the table are changed to U and V.

Export Sounding Table to File

Save the sounding table as an Excel or CSV file by selecting File -> Save -> Export Sounding Table to File....

Selector Color

Change the color of the selector in the main display by selecting Edit -> Selector Color.



Front Controls
Overview
The Front Controls show a list of the high and low pressures and fronts in a textual list format.

Double clicking on an element will show its properties editor through which you can view its times and change visibility, position, or pressure
values.

Properties

Z Position

Allows you to define what is the fixed Z position.



Location Controls
Overview
McIDAS-V provides a collection of locations. These may be NEXRAD stations, states, counties, geographical features, countries, etc. The
Location Controls are used to display these locations. The list of locations is accessed through the Display->Plot Location Labels ->... menu.

The user interface consists of four tabs. The first allows the user to control the display.

The second tab shows two sub-tabs that list all the locations and the currently displayed locations. Shown at the bottom are the details of a
location.

The third tab lists all of the location files that are being displayed.



The Filters tab allows you to filter what locations are being shown based on their internal attributes. There is more information about the filter
mechanism in the documentation for the Point Data Plot Control.

Properties

Declutter

Click off the Declutter checkbox to see all locations. The display otherwise shows only selected locations that do not overlap. As you zoom
or pan in the display different locations will be shown. When decluttering is turned on you can change the density level of the locations.
The small "lock" button allows you to fix the currently displayed/decluttered locations. Using the lock button allows you to zoom or pan
without changing what locations are displayed. Use the slider to control the density.

Display

The display of the locations can be done through a fixed specification of a symbol and/or and identifier as well as by using one of the
station models available.

Use the options under the Predefined button to control what station information is displayed. Use the Visible checkbox to toggle the
visibility of the identifier in the plot. Use the options in the Symbol panel to control what marker symbol is displayed. Clicking an item will
immediately change the display. Use the Visible checkbox to toggle the visibility of the symbol in the plot.

When you select the Layout Model radio button the station model facility is used to display the location. You can edit and/or create new
station models by clicking on the  Edit icon . The predefined "Location" station model is a good one to use for display and as a basis to
create your own.

Vertical Position

You can choose to display the locations at their altitude (if there is one) or you can override this and specifically define the vertical position.

Add Locations

Add additional locations with the Edit->Add Locations menu. You can remove a set of locations by selecting the location entry in the list
and pressing the "delete" key.

Color

Change the color of the location labels and markers by using the Edit->Color menu.

Listen for clicks

When checked, clicking on a location in the main display window will update the current location information to the one selected.

Center on selected

When checked, clicking on a location in the layer controls will automatically center the main display window over the selected location.

Apply Filters

Click to immediately to apply one or more filters to the current list of locations to display, choosing to show only the filtered locations, or
to always show the filtered locations.

Filters Enabled

When checked, the filters will be enabled. You can choose to match all or any of the filters with the radio buttons.

Property

Select a property to filter. Use the =, >, <, and additional search conditions to apply the filter conditions.

Value
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Enter in a value to be applied to the filter.



WorldWind Controls
Overview
The WorldWind controls are a special version of the Location Controls. They provide access to a large collection of locations from Nasa's
WorldWind Viewer project.

As the display is panned or zoomed more locations different location sets are retrieved and displayed.
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Track Controls
Overview
The track controls display trajectory data sets, e.g., aircraft track, ship, buoys, etc. The track controls consist of two tabs. The first controls the
layout:

The second tab controls the times:

Properties

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Visible Range

The Visible Range allows you to set the range that determines what parts of the data is actually shown. Check the box to enable the widget
and use the Change button to set the data range.

Marker and Marker Color

You can define an end point symbol and text as well as its color with these fields. By default, "Location" is selected as the default marker.
Click the checkbox to the left of the "Location" box to enable the marker. Click on "Location" to choose another marker from the list of
layouts. Click on the  Edit icon to edit a current layout, or to create a new one. Use the slider or enter in a value and hit enter in the Scale
option to set the scale of the marker.

Line Width

This slider allows you to set the width of the displayed trajectory line.

Times to Use

Choose to use either nominal times, or the track times from the data. You can also choose to limit the times of data shown by checking
enabled.

Time Mode

Even though a track represents a set of observation times there is not time set defined for animating in the main display. The time mode
allows for the control of how much of the track is shown and from what time. Select the Change button to show the Time Settings dialog:
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This dialog allows you to define the time range to show of the track. The image above defines that the end time is the current animation
time. The start time is relative to the end time less 30 minutes.

This time setting is similar to that used for the general time animation.

Change Parameter

Change the parameter displayed by using the Edit->Change Parameter menu.

Change Display Unit

Change the unit of the parameter displayed by using the Edit->Change Display Unit menu.
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Miscellaneous Controls
Storm Track Controls
Scatter Analysis Controls
McIDAS-X Bridge Controls
Range and Bearing Controls
Drawing Controls
Transect Drawing Controls
Location Indicator Controls
Omni Controls
QuickTime Movie Controls
Web Map Server (WMS)/Background Image Controls
Jython Controls
Weather Text Product Controls
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Storm Track Controls
Overview
The Storm Track Control displays tropical storm observation and model output tracks. Currently the McIDAS-V supports both the Automated
Tropical Cyclone Forecasting System (ATCF) data as well as data from the Shanghai Typhoon Institute.

To load in ATCF data select the Tools->Text Data ->ATCF Tropical Storm Data menu. This creates a data source with a predefined path to the
National Hurricane Center ftp site. Then, create the Storm Track display.

The display control shows the set of available storms on the left panel organized by year and basin, e.g., Atlantic (AL), Eastern Pacific (EP) and
Central Pacific (CP).

Year Display
At the top of the list is an option (Yearly Tracks) which allows the user to display the observed tracks for all the storms in a given year. You can
load and/or unload any number of years worth of observed tracks. The color swatch changes the color of the tracks for a given year. The Time
Mode menu allows one to change the animation mode, e.g., use the year or use the storm start time.

Storm Display
To show the observation and all of the model results for a single storm select the storm in the list and press the Load Tracks button. You can load
any number of storms but they are shown in different panels. You can use the View->Storm Tracks menu to list out all of the loaded storms,
remove them all, etc. Once a storm is loaded it can be removed with the small "scissors" icon shown in the upper right.

Once a storm is loaded the first thing you should do is to specify which "Techs" (or models) to use by bringing up the control's Properties dialog
Edit->Properties menu. In the "Techs to use" tab, select all of the Techs in the "Use" list (click and press control-a) and press Remove. This
places them in the "Don't Use" list. Select the desired Techs in the "Don't use" list and press Add. You can also choose what parameters are to be
used and displayed in the "Chart Parameters" tab, repeat the same step to select the desired parameters. If you want these selections to be saved as
a preference, please check the "Save as Preference" box.
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The Storm display panel consists of three tabs: Tracks, Table and Storm Chart.

Tracks

The Tracks tab controls the display and animation of the tracks.

The Points menus specify which Layout Model to use for both the Observation as well as the Forecast tracks.

The Animation is the layout model to use for the Observation track that moves along with the time animation.

The Animation Mode determines whether to animate the tracks or show all of the tracks.

Using the Color By menus one can specify whether the track is shown with a fixed color or using a color table. The color table used is a single
one for the entire display control and is set through the main Edit menu.

Under the Show table one can specify what is to be shown. One can toggle on/off the visiblity of the Observation track, all of the forecast tracks
or individual forecast tracks.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_StormTrackControl__tracks
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_StormTrackControl__table
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_StormTrackControl__chart


Table
The Table tab shows a tabular listing of all of the observational track data and individual forecast model runs. On the left is a tree view organized
by the Tech and model run time. Selecting one of the model runs will display the data in the table. The main File->Save->Export to Spreadsheet
menu allows you to export the track data to an Excel spreadsheet. In the File Dialog are options to select what is to be saved.

Storm Chart
The Storm Chart tab shows time series charts of selected tracks. Under the main Edit menu you can any number of new forecast time or forecast
hour charts. The forecast time chart is based around the model run time of the selected forecasts. The forecast hour charts selects data across the
different model run times, e.g., you can show the 12 hour forecast from each model run.

To do the charting of the storm track, one or more Techs need to be selected. Once selected the Forecast Hour/Forecast Time list is populated.
One or more times can be selected (control-click). Each Parameter that is selected will result in a new chart shown on the right.

The Use Difference button, when selected, results in the display of the difference between the forecast value and the observed value.



Scatter Analysis Controls
Overview
The Scatter Analysis controls are used to create a scatter plot within McIDAS-V. The scatter controls show three different panels:

The plot on the left represents the first field selected, the plot in the middle represents the second field and the plot on the right is the scatter
analysis of the two fields. The first field selected is represented on the x-axis (abscissa) and the second field selected represents the y-axis
(ordinate). The x-axis is selected in the Field Selector - what you have selected in the lower right Channels tab will be used as the x-axis.

The scatter plot and images can be analyzed by highlighting a box or region in either display. To draw a box, click the “Box” radio button, select
one of the colored boxes (magenta, blue, green) to the right of the radio buttons, and use the Shift+Left click and drag option to draw a box over a
region of the scatter plot. The corresponding points in the image will be highlighted. Conversely, one can select a region of interest in one of the
images and then the corresponding points in the scatter plot will be highlighted. To select your own shape, click the “Curve” radio button, a color,
and use the Left Click and drag option to draw an enclosed shape. Currently, you are allowed one box or curve per color for the scatter plot and
one for the images.

To change the color bar or other color bar properties, right click to access a popup menu.



McIDAS-X Bridge Controls
Overview
The McIDAS-X Bridge Controls are used to create and import a McIDAS-X session into McIDAS-V. The control window has two tabs. The first
includes a pseudo duplicate of the two main McIDAS-X windows:

The second shows the settings for this display control:

Vertical cross sections can be made in three types of displays, with contour lines, color-filled contours, and as a color-shaded image.



Properties

Command Line

McIDAS-X commands can be entered through the "Command Line" text entry box at the bottom of the Layer Controls tab. Interactive
commands are not implemented. Recall commands (Shift+6 and Shift+7) do work in the bridge session.

Smooth images

When checked, anti-aliasing will be used to smooth images when resizing to fit the frame display.

Time Animation Controls

Controls looping of displays when more than one data time is loaded. See more in Time Animation Control.

Color Table

The control has a color bar showing the active color table and the associated high and low data values in the units the display is made in. As
the mouse pointer is moved over the color bar, the value at a particular color is shown. Click on the color bar to start the Color Table Editor.
Or click on the button that displays the name of the color table to show a popup menu that allows you to change the range, select other color
tables, etc.

Vertical Position

This slider allows you to set the vertical position of the image.

Pixel Sampling

Adjust the Pixel Sampling slider to change the resolution of the image. A larger number makes a lower resolution (coarser) display.

Texture Quality

Use the slider to change the texture quality of the display.

Display data in the main 3D panel

When checked images, graphics, and/or annotation lines from navigated frames in the McIDAS-X Bridge session will be imported into the
main 3D panel in McIDAS-V. Non navigated frames are not imported into McIDAS-V and will be skipped.

Use McIDAS-X frame order to override data time with frame number

When checked, navigated data will be imported into McIDAS-V based upon their order within the McIDAS-X frame order instead of by
time.

Use McIDAS-X data projection

When checked, the default data projection from McIDAS-X will be used when displayed navigated data in the main 3D panel in McIDAS-
V. When unchecked, the McIDAS-V default data projection will be used.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Animation__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ColorTableEditor__FILE


Range and Bearing Controls
Overview
The Range and Bearing Controls show the distance, azimuth, and back azimuth of a great circle line connecting two positions on the Earth's
surface.

When the range and bearing controls are first created a range and bearing line is added to the main view window. The distance and azimuth
values are shown on the Legend in the main view window, and at the top of the range and bearing control window. The latitude-longitude position
values of the end points are also shown. Computations are based on the WGS-84 reference ellipsoid, using computation code from the U.S.
National Geodetic Survey.

Note The line shown on the display is not the great circle path connecting the end points. The values are computed for a great circle path on the
ellipsoidal earth, using the numerical latitude and longitude values, not the line on the display. The line shown in the display is a straight line on
whatever map projection you happen to have; usually it will not coincide with the great circle line.

Note If you change the map projection, an existing range and bearing map line will stay at the same location in the display, hence the end points
on the map are in new locations. The distance, azimuth, etc. values in the control window reflect the latitude-longitude positions in the control
window and hence do not match the display picture until an end point is moved by hand.

Properties

Positioning the line

You can re-position the end points of the line in the display by dragging the end points with the left mouse button, or by selecting positions
from the pull-down menus. You can change what pre-defined positions are used with the Edit->Set Locations menu.

You can move the entire set of selector line and both end points at once by dragging mouse pointer on the the square at the center of the
line. The orientation across the display is maintained while the line moves.

End points

You can enter the latitude and longitude values of either end point of a line. Click in the text window of "From:" or "To" as to which
value(s) you want to save. Use the backspace key to remove unwanted numbers, and enter the new values. Clicking Apply or pressing the
Enter key will move the end point of the line to the new position, and show the new distance and azimuth values. You can also select a state
from the pull down tab.

Vertical Position

This slider allows you to set the vertical position of the range and bearing line.

Selector Color

Change the color of the range and bearing line by using the Edit->Selector Color menu.

Change Display Unit

Change the unit used to display the distance by using the Edit->Change Display Unit menu.



Drawing Controls
Overview
The drawing controls consists of a drawing editor that supports polygons, lines, shapes and text. It behaves like other two-dimensional drawing
editors - you can choose the tool to use (e.g., move, create graphic, etc.), apply the tool in the main 3D window, select graphic objects, etc.

A caveat: drawing and selecting in 3D is at times tricky. Sometimes it is best to be in the main overhead view.

The user interface consists of three tabs. The first allows for the user to set the drawing mode:

The second sets the drawing style:

And the third lists all of the graphical elements:

Double clicking on an element will show its properties editor through which you can change its color, line width, position, etc.



Image 1: Shape Properties

Note: The drawing control will only respond to events (e.g., mouse drag to draw) when its window is being show. For example, if it is not visible
in the Data Explorer tab then no drawing will take place.

The distance and area of a shape will be shown when it is being drawn, in the Shapes list and in the shape properties. You can change the distance
unit through the Edit->Change Display Unit... menu.

Properties

Mode

There are three editing modes, select, move and reshape:
 Allows you to select one or more drawing objects. To select multiples press the control key. The selected objects will be shown

with small magenta rectangles. Once selected you can bring up the object's property editor by pressing Control-P. You can also delete
the selected objects by pressing Control-X. You can select all of the objects by pressing Control-A.

A caveat: Some objects can only be selected by clicking on or near certain points. Rectangles and diamonds click near the upper left
or lower right. For text click near the beginning of the text string for left justified text, near the center for center justified text or near
the end for right justified text.

 Allows you to move an object.
 Allows you to move one of the points that define the location of an object.

Enabled

This checkbox allows you to disable/enable drawing. For example, if you wanted to manipulate other elements in the display (e.g., probe
point, cross section, other drawing controls), you can disable the drawing control so that it does not respond to any mouse events in the main
display.

Shapes

The shape buttons allow you to create:
 Click and drag in the main display to create a smooth polygon. Check the Straight checkbox, then click and drag to create a

straight line polygon.
,  Click and drag in the main display to create the shape.
 Click in the main display and type to enter text. When done entering text hit
 Click in the main display to create a waypoint - text and a shape.
 Click in the main display to create an image. Select an image file from the file chooser. Note: drawing with the image is a bit

flaky. The Full Lat/Lon button controls how the corners of the image are positioned.
 Click in the main display to create a movie. Select a movie file from the file chooser. Note: drawing with the movie is a bit flaky.
 Click in the main display to create a symbol.

Fronts - The drawing control also supports drawing a number of front and high/low symbols:

 Click in the main display to create a high pressure symbol.
 Click in the main display to create a low pressure symbol.
 Click and drag in the main display to create a cold front.
 Click and drag in the main display to create a warm front.
 Click and drag in the main display to create an occluded front.
 Click and drag in the main display to create a stationary front.
 Click and drag in the main display to create a trough.

While the icon buttons only allow you to draw 5 different front types, there are 20+ front types to choose from in the Properties
dialog for the shape.

Location

The drawing control allows you to draw in four different coordinate systems:
Lat/Lon/Alt - The points of the shapes are defined by Latitude/Longitude/Altitude. When you reproject the display the shape will also
be reprojected.
Lat/Lon - Like Lat/Lon/Alt but the z position is fixed using the Z Position slider.
X/Y/Z - Draw in the 3D box coordinate space. Re-projections will no effect the shape.
X/Y - Like X/Y/Z but the z position is fixed.

For now the Full Lat/Lon is not fully implemented.



Z Position

Allows you to define what is the fixed Z position.

Time

If you have the Draw in current time checkbox turned on then the graphic shapes that that you are drawing will only be shown in the
current animation time in the 3D view. This facility allows you to, for example, annotate features through time by drawing on the feature,
stepping the time animation, and then drawing in the next time. To see all of the objects irrespective of their display times select the Show
all checkbox.

A graphic can be shown in more than one times using the property editor. Select the object and press Control-P to bring up the property
editor. Select the times to be displayed in in the Times list (Shift-click or Control-click to select multiples) and press Apply or Ok.

Color, Line Width, etc.

These widgets allow you to define the color, line width, font, and text justification.

Edit Menu

There is a "Remove All" entry in the edit menu that removes all graphic objects from the display.

File Menu

Under the file menu you can choose to export the objects in the drawing control. This creates a simple xml file (a .xgrf file suffix) that
defines the objects and that can be re-imported.



Transect Drawing Controls
Overview
The transect drawing controls are a version of the Drawing Controls that allows you to view, create and modify the transect lines that are used in
the Transect Views.

This display is either created through the Display->Draw Transect menu or through the Transects menu in the Transect View.

This display control is a representation of the set of transects that are defined by the transect resource. Not only does it have its own state (that can
be saved in a bundle for example) it also writes out any transects you may create or change into your local McIDAS-V state directory in a
transects.xml file.

In this control there is only one shape that you can draw with, the Transect Line. This control also shows a non-editable Transect Shape which
displays the full transect line used by any Transect Views. We call these the "Active Transects". There are also a set of transect lines that are non-
editable that are from the system transects property.

For an active transect, if the Transect View that it represents has a max distance set then the transect will show this max distance as a rectangular
box.

Properties

Mode

 Click and drag in the main display to create a transect.

There are three editing modes, select, move and reshape:

 Allows you to select one or more transect drawings. To select multiples press the control key. The selected transects will be
shown with small magenta rectangles. Once selected you can bring up the transect's property editor by pressing Control-P. You can
also delete the selected objects by pressing Control-X. You can select all of the objects by pressing Control-A.

 Allows you to move a transect.
 Allows you to move one of the points that define the end points of a transect.

Z Position

Allows you to define what is the fixed Z position.

Automatically update transects

When this is selected any changes you do are automatically applied to any Transect Views and are also written out into the transects.xml
file.

Show transects

This toggles the visibility of the regular transects.

Show active transects

This toggles the visibility of the active transects.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_DrawingControl__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_TransectViewManager__FILE


Image 1: Location Indicator Location Tab

Image 2: Location Indicator Display Tab

Image 3: Location Indicator Orient Tab

Location Indicator Controls
Overview
The location indicator controls display a configurable axis in the main 3D display and (optionally) a bearing point. The user interface is composed
of three tabs. The first displays and allows you to modify the position of the origin and the bearing point.

The second allows for the configuration of display options.

The third allows for the orienting the display based on the location.

To change the origin click and drag in the main display. To show and/or change the bearing point do a control-drag in the main display. The x/y/z
locations of the bearing point are shown on the origin axis as tick marks and, optionally, as longitude/latitude/altitude readouts.



Properties

Origin

Enter in a latitude, longitude, and altitude to set the location of the origin point in the 3D display window.

Point

Enter in a latitude, longitude, and altitude to set the location of the bearing poing in the 3D display window.

Bearing

Lists the bearing point degree.

X Tick

Enter in a latitude, longitude, and altitude to set the location of the X tick mark in the 3D display window.

Y Tick

Enter in a latitude, longitude, and altitude to set the location of the Y tick mark in the 3D display window.

Z Tick

Enter in a latitude, longitude, and altitude to set the location of the Z tick mark in the 3D display window.

Move

Use this checkbox to constrain along which axis points are moved.

Keep in Box

When checked, constrains the movement to be within the main 3D bounding box.

Enabled

When checked, the option to drag points will be enabled.

Visibility

Turn on/off the visibility of the X, Y, and Z axes in the 3D display window.

Labels

Turn on/off the visibility of the X, Y, and Z labels in the 3D display window.

Solid

When checked, a solid plane along any of the axes will be displayed. You can also change the color and the transparency of the plane with
the pull down menus.

Bearing Lines

Show or hide the bearing lines. These are dashed lines from the respective axis to the bearing point.

Bearing Point

Turn on/off the display of the bearing point with the Show point checkbox.

Axis size

Use the slide to control to expand/contract the length of the origin axis.

Line Width

Use the pull down menu to set the line width of the origin axis.

Color

Use the pull down menu to set the color of the origin axis.

Center At Origin

Click to center the display at the origin point.

Center At Point

Click to center the display at the point of the location indicator.

Set origin to address

Enter in an address to center the origin on using the View->Set origin to address menu. For valid formats, see here.

Set point to address

Enter in an address to center the point of the location indicator on using the View->Set point to address menu. For valid formats, see here.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_DisplayMenus__goto
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_DisplayMenus__goto


Omni Controls
Overview
The Omni controls consist of a VisAD Spread Sheet, loaded with the parameter selected and its coordinates and units. The Spread Sheet is used to
create a display where you have complete control over which coordinates are the axes, how it is colored, and so on. Use of the VisAD Spread
Sheet is not described here. See the VisAD Spread Sheet document at http://www.ssec.wisc.edu/~curtis/ss.html.

Properties

Mappings

The Mappings button brings up the VisAD Math Type and display mappings control box shown on the right in the image above.

Controls

The Controls button brings up the spreadsheet Controls box (not shown).

Add Parameter

Add a new parameter to the omni control using the Edit->Add Parameter menu.

http://www.ssec.wisc.edu/~curtis/ss.html


QuickTime Movie Controls
Overview
McIDAS-V can display QuickTime movies. You can pause, single step and play a movie.

Properties

 Play

Click to start the QuickTime movie.

 Pause

Click to pause the QuickTime movie.

 Step Backward

Click to move backwards a single step in the movie.

 Step Forward

Click to move forwards a single step in the movie.

 Media Properties

Left-click to bring up the QuickTime media properties. Right-click to change the rate of the movie.

The media properties is composed of three tabs. The first display the general information about the QuickTime movie, including location,
duration, and frame rate.



The second lists the specific video information, including encoding type and size.

The third has access to the PlugIn Viewer details.



Web Map Server(WMS)/Background Image Controls
Overview
The WMS Controls display imagery from WMS servers. A set of predefined links to WMS servers for topographic, shaded relief and aerial
imagery is also provided with the Background Image control.

To use the pre-defined Background images, select the Display->Add Background Image menu item. To choose imagery from web map servers
bring up the Data Source Chooser, go to the Catalogs tab and enter the url that points to the Capabilities document of the desired WMS. We also
provide links to a set of useful WMSs from the idvcatalog. If it is not in the Catalog pull down menu simply enter the url:

http://www.unidata.ucar.edu/georesources/idvcatalog.xml

From this catalog open the Web Map Servers tab and select the WMS you would like to access.

The WMS Controls makes a request to the Web Map Server for an image that covers the area currently being displayed in the main display. Due
to the time it takes to access remote servers the WMS Control does not request new images when the user pans and zooms.

Properties

Layer

If multiple layers have been selected (using control-click in the WMS Chooser or in the Background Image control) you can choose which
layer to view with this menu.

Image Buttons

 Click to reload the image from the server at the current screen location.

 Click to set the projection in the display to the current image bounds.

When the Auto-Reload button is selected, the WMS control will automatically fetch a new image every time the main display is panned or
zoomed. There is a slight delay so that successive zooms do not cause successive image requests.

Resolution

The Resolution menu allows you to make requests for lower resolution images. This results in a smaller image file size and quicker
requests from the server.

Vertical Position

This slider allows you to set the vertical position of the image.

Transparency

You can adjust the overall transparency of the image. Note: Some Web Map Servers provide images that contain transparent sections.
Currently, McIDAS-V does not support the display of transparent sections.

Dimension Scale

By default the bounds of the image that is retrieved from the server is the size of the display. This slider allows you to fetch an even larger
image.

Save as Image Xml/Kml File

This is available under the File->Save menu. It takes the most recently displayed image and writes it out (e.g., as a jpeg file) and also
writes out McIDAS-V's ximg xml file that contains the reference to the image file and the lat/lon position of the image.

This allows the user to load this image back in without being connected to the original web map server.

If a .kml or .kmz file suffix is given then the Google Earth file is created and the image can be loaded into Google Earth.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_CatalogChooser__FILE


Jython Controls
Overview
The Jython Controls allow for the development of custom layer controls written in Jython. The controls operate in two modes.

First is the "developer" mode. Here the developer can create a Jython Control; specify the name of the display, any data categories, and the probe
type; and write the Jython that creates a GUI and responds to data, animation time and probe position changes.

The default Jython code has examples of accessing data, etc.

The second mode is "user" mode. In developer mode you can write out an specification of the Jython Control to a plugin through the File->Save-
>Write to Plugin menu. This plugin, when loaded, will only show the user interface that is created by the developer-written Jython.



Weather Text Product Control
Overview
This control is used to display weather text products (forecasts, warnings, watches, etc) produced by the National Weather Service and other
international meteorological agencies.

The user interface consists of 3 tabs. The first allows the user to select and display the text products. The Products panel allows the user to select
the type of product to view. When a product is selected, the available stations are plotted in the associated view window. One or more stations can
be selected by clicking on the station in the view window (or Ctrl-click for multiple stations). When a station is selected, the text product for that
station is displayed.

The user can select between displaying the products as raw text or as HTML by clicking on the tab at the bottom of the text display area.

In the HTML view, you can toggle on a glossary which will highlight certain meteorological terms. When the links are clicked, a dialog will pop
up with an explanation of the term.



By default, the most recent text product is displayed. Multiple products can be displayed by selecting a time range from the Time Covered
selector. You can loop through multiple products using the Time Animation widget. The time animation will be synched with any other data in the
associated view window.

The second tab controls the display of the station locations in the associated View window. It is the same as the Station Location Control's
Display tab.

When you select a product, the available stations are shown in the View window. This tab can be used to control the station density and the layout
of the station identifiers.

The third tab lists information about the selected location and shows lists of all the locations and the displayed selections.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Animation__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_StationLocationControl__FILE


It is the same as the Locations tab in the Station Location Control.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_StationLocationControl__FILE


Charts
Overview
A number of the layer controls make use of a charting facility. The charts have a common set of properties and facilities. Each of these layer
controls will show a thumbnail image of their charts in the legend. This can be toggled using the View->Chart->Show Chart Thumbnail option.

There are four levels of configuration available to the user.

Chart Line Properties
At the lowest level you can set the properties of how each parameter or field is shown. This is done through the Chart Line properties dialog
which is brought up typically through the View->Chart menu or by right clicking on the fields table.

Full Plot

Allows you to toggle the visibility of the line on or off.

Axis

Allows you to toggle the visibility of the axis on or off.

Chart Name

Select a chart name from the pull down menu, or create a new chart by entering a new name in the field. The display will automatically
create a new chart with the new name.

Axis Side

Use the pull down menu to specify what side of the chart the axis and axis label is shown.

Range

Enter in minimum and maximum values to fix the axis range to remain constant as the chart values change.

Includes Zero

When checked, zero is included on the axis range.

Type

Allows you to specify the display of the line. It can be a line, line and shape, shape, area, area and shape, or a bar chart.

Shape

Allows you to specify the shape to displayed.

Line

Allows you to specify the line stroke, width, and color to be displayed.

Vertical Position

Allows you to define where in the chart special shapes are shown (e.g., wind barbs, cloud coverage, text).

Plot Properties
For each individual plot, there are a number of settings that can be changed through the Plot Properties dialog. This is also accessed through the
View->Chart menu.



Name

Allows you to edit the name of the chart.

Color

Allows you to change the background and chart colors.

Domain Lines

Allows you to change the domain lines properties including the stroke, width, and color. The visibility of the domain lines can also be
toggled on and off with the Visible checkbox.

Range Lines

Allows you to change the range lines properties including the stroke, width, and color. The visibility of the range lines can also be toggled
on and off with the Visible checkbox.

Title

Toggle the Title checkbox to determine its visibility on the chart.

When right clicking on a chart you can also zoom in and out and write the chart as an image. There are also a number of key and mouse bindings
on the chart:

Control-R: Reset any zooming.
Up/Down/Left/Right Arrows: Pan p
Left mouse drag - zoom

Chart Properties
There are several chart properties that can be changed through the Chart Properties dialog box. This is accessed by right clicking on the chart and
selecting "Properties." The Chart Properties dialog box consists of three tabs. The first tab deals with the title and its attributes.

Show Title

When checked, the title will show up on the chart in the Layer Controls tab of the Data Explorer.

Text

Lists the current title for the chart. Edit the text to change the title.

Font

Click on the Select button to change the font of the title.



Color

Click on the Select button to change the color of the title.

The second tab deals with the plot axes and their attributes including tick marks. Within this tab are multiple tabs, two of which are very similar.
The Domain and Range axis tabs have many identical options, listed below.

Label

Lists the current label for the axis. Edit the text to change the label.

Font

Click on the Select button to change the font of the title.

Paint

Click on the Select button to change the color of the title.

Show tick labels

When checked, the labels for the tick marks will be shown.

Tick label font

Click Select to change the tick label font.

Show tick marks

When checked, the tick marks will be shown.

Auto-adjust range

When checked, the range axis minimum and maximum will automatically be computed. When unchecked, you can enter in a minimum and
maximum value to set the range. This option exists only under the "Range Axis" tab under the "Range" tab of the "Other" section.

There are also parameters for changing the appearance of the plot



Outline stroke

Click Select to change the chart outline stroke style.

Outline paint

Click Select to change the color of the chart outline.

Background paint

Click Select to change the color of the chart plot background.

Orientation

Use the pull down menu to change the orientation of the chart.

The third tab deals with general chart properties.

Draw anti-aliased

When checked, the chart will be drawn using anti-aliased techniques to reduce distortion.

Background paint

Click Select to change the chart background color.

Series

Series and Series Outline options are not implemented at this time.

Chart Layout
When you have multiple charts you can define different layouts for them using the View->Chart->Layout menu. There are a number of pre-
defined layouts: Vertical, Horizontal, 2 Column, 3 Column, Tabs. The Grid Layout allows for much flexibility in how the charts are organized and
laid out. The View->Chart->Layout->Change Grid Layout menu brings up the Grid Layout Editor:



The idea here is the overall window is divided up into a number of rows and columns. You can add/remove rows and columns with the "+" and "-
" buttons. You can then drag the little graphical representations of the charts to place them in the grid. A chart can also span multiple rows or
columns. Just grab the little black square on one side of the chart image and drag it to change the row or column.



Tools
User Preferences
Remote Data Manager
Local Data Manager
Projection Manager
Color Table Editor
Layout Model Editor
Display Settings
Parameter Alias Editor
Parameter Defaults Editor
Parameter Groups Editor
Contour Properties Editor
Image and Movie Capture
Timeline
Message Console
Support Request Form
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User Preferences
Preferences are used to save standard settings of McIDAS-V, such as the map projection to show when McIDAS-V starts. The Preferences Dialog
is opened through the Edit menu with Edit->Preferences.

Click on Cancel if you wish to exit preferences setting, Ok to accept the changed preferences and close this window, and Apply to accept the
preferences and keep this window open.

Note: Some of these preferences only take effect the next time you run McIDAS-V or when you create a new view window. The preferences also
may be overwritten when you use bundles. See here for more information about the bundle facility.

The follow sections describe the different preference options for McIDAS-V:

General Preferences
Display Window Preferences
Toolbar Option Preferences
Data Sources Preferences
ADDE Server Preferences
Available Display Preferences
Navigation Control Preferences
Formats and Data Preferences
Advanced Preferences
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Image 1: General Preferences

User Preferences - General

General

Show Help Tip dialog on start. Should the help tip window be shown at start up.

Show Data Explorer on start. Should the Data Explorer window be shown when McIDAS-V starts.

Check for new version on start. If checked on, will check at startup to see if your current version of McIDAS-V is up to date.

Confirm before exiting. Ask user to confirm before the application exits.

Automatically save default layout at exit. Stores the position of the Data Explorer for the next session.

Save visibility of Data Explorer. Stores the visibility of the Data Explorer for the next session.

Confirm removal of all data sources. Ask user to confirm before removing all data sources.

Confirm removal of all layers. Ask user to confirm before removing all layers.

Confirm removal of all layers and data sources. Ask user to confirm before removing all layers and data sources.

When Opening a Bundle

How to open bundle . The pull down menu contains four options for opening bundles: Create new window(s), Merge with active tab(s), Add
tab(s) to current window, and Replace Session.

Prompt when opening bundles . When checked, the window asking how to open the bundle will pop up, allowing you to choose each time
you open a bundle.

Prompt for location for zipped data . Allows you to specify a directory to place zipped data files, or choose to create a temporary directory.

Layer Controls

Show windows when they are created. Specifies that when a display is created its control window is automatically shown.

Use fast rendering. Should the displays always use fast rendering. This allows for faster display rendering at the risk of incorrect displays
(e.g., when display lines cross projection seams).

Auto-select data when loading a template. A display can be saved as a template without data. When it is created should McIDAS-V attempt
to automatically select the appropriate data fields.

When Layer Control Window is Closed

Remove the layer(s) . Specifies that when a display's window is closed then the layer itself is removed.

Remove standalone layer . When the window is closed for a stand alone layer (i.e., one that does not have a display component in a main
view window) should the layer be removed.



 
Image 1: Display Window Preferences

User Preferences - Display Window

The Display Window tab allows you to set preferences related to the main 3D window.

Navigation Toolbars

Show Globe Background. Display a solid globe background.

Show Earth Navigation Panel. Show a graphical navigation panel.

Show Viewpoint Toolbar. Enable the Viewpoint toolbar.

Show Zoom/Pan Toolbar. Enable the Zoom/Pan toolbar.

Show Undo/Redo Toolbar. Enable the Undo/Redo toolbar.

Legends

Show Side Legend. Do you prefer the side display legend.

Show Bottom Legend. Do you prefer the bottom display legend.

Panel Configuration

Show Wireframe Box. Toggles the visibility of a 3D wireframe box around the data. This box helps provide orientation in 3D views.

Show Cursor Readout. Display a label of latitude, longitude, and altitude of the cursor position over the display, shown in the lower border of
the view window.

Clip View At Box. Allows you to elide from view all display elements outside the wireframe box. This is helpful to remove map lines outside
the area of data.

Show Layer List in Panel . Should a listing of the titles and times of the layer controls be shown in the main view window.

Show Times In Panel . Turn on the label, shown inside the main display, that shows the current animation time.

Show Map Display Scales. Show a vertical scale in the map displays.

Show Transect Display Scales. Show a vertical scale in the transect displays.

Show "Please Wait" Message. Display the "Please Wait" message in the display.

Reset Projection With New Data. When checked will cause each new display made in McIDAS-V to snap the whole view window to the
native projection of the data. This can be undesirable if you are overlaying several kinds of some of which have differing projections.

Color Scheme
You can specify the default foreground/background/globe background colors. The foreground color is applied to the bounding box lines and
the time readout. The color of the maps is controlled by the individual map control. The selected panel color changes the color used to highlight
the current panel.

Layer List Properties
You can specify the layer list font, size, and color.

Default Projection
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You can specify the default projection that McIDAS-V uses upon startup.
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User Preferences - Toolbar Options

The Toolbar Options tab allows you to define what action/icons are displayed in the toolbar. The list on the left shows all of the available
actions. The list on the right shows the actions which make up the toolbar. You can add/remove actions to/from the toolbar list. The Add space
button adds a space between toolbar entries. The Reload Original resets the toolbar list to the one before any changes have been made.
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User Preferences - Data Sources

The Data Sources tab allows you to define what types of data choosers to use. This is a way to simplify the Data Explorer window, only showing
those tabs that you want to use. You can either select to "Use all data sources " or "Use selected data sources " and select individual choosers to
use.
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User Preferences - ADDE Server Manager
The ADDE Server Manager is currently managed through the Edit->Preferences menu under the "ADDE Servers" tab and allows you to add and
manage your list of servers.

The ADDE Server Manager allows you to add and manage a list of ADDE servers separated by data type and removes the need to manually enter
in each server and group information, as well as the need to enter in logon information (if required). To turn all servers on/off in the data
choosers, click the All on/All of button.

To add a server to the manager, click the Add button to bring up a dialog box with the following properties:

Server: Enter in a server name or IP address.

Dataset(s): Enter in a group or set of group names. To add multiple groups, separate each with a comma.

Need accounting information Check if the server being added requires a logon and project number.

User ID: If the Need accounting information box is checked, enter in the user ID to logon to the server.

Project # If the Need accounting information box is checked, enter in the project number used to logon to the server.

Automatically capitalize groups and user ID When checked, the Dataset name(s) and user ID will be automatically converted to uppercase.

Data Types Use the check boxes to select all data types associated with the group(s).

Verify and Add Click to verify the data types available on the server, and add all existing data types with the group to the server manager.

Verify Click to verify the data types available on the server manager. Data types available will be checked.

Add Click to add all checked data types to the server manager. No verification of the data types will be performed.

To delete a server from the list, left click on one or more server/dataset entry and click Delete.

The Import from McIDAS-X button allows you to import MCTABLE.TXT from a McIDAS-X session. McIDAS-V requires server verification
in order for the servers to be listed in the proper choosers under the proper data source type. When Verify imported servers is checked, the
automatic server verification checks the availability of each data type on each server in your text file and imports the available servers into your
server list. Disabling the automatic server verification will still import the servers, but will list them as Unverified in the ADDE Server Manager.
In order to manually verify the servers and have them listed in the data choosers, you will need to use the ADDE Server Manager to individually
edit the servers to define their appropriate data type.

The Import from URL button allows you to import a XML file containing a list of ADDE servers into McIDAS-V.

The server manager can filter the list of servers depending upon the source. Use the following checkboxes to turn on and off specific sets of
servers.

Include McIDAS-X Servers When checked, all servers imported through the Import From McIDAS-X button will be displayed in the list of
servers.

Include Default Servers When checked, all default servers included in McIDAS-V will be displayed in the list of servers.

Include Your Servers When checked, all servers manually added through the Add button will be displayed in the list of servers.
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User Preferences - Available Displays

The Available Displays tab allows you to specify what types of displays to fuse. You can either select to "Use all displays" or "Use selected
displays". The list of displays is hierarchical. You can turn on or off the user of all displays, specific groupings or individual displays.
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User Preferences - Navigation Controls
The Navigation Controls tab allows you to change how McIDAS-V interprets mouse and keyboard events for navigating in 3D space. For each
combination of mouse button and control/shift keys you can select an action.

The Cursor/Data Readout option brings up a latitude, longitude, and data value readout in the upper left part of the display on a mouse drag.

There are a number of navigation functions (e.g., rotate) that can be triggered by a key press. The Keyboard preference tab allows you to define
the key and any modifier (i.e., control, shift):



 
Image 2: Keyboard Event Preferences
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User Preferences - Formats and Data
The Formats and Data tab allows you to define data formats and defaults to be used when displaying data.

Date Format. This allows you to define how McIDAS-V displays dates. The date format string uses the following symbols. Note, these symbols
can be repeated to give different results.

For example:

"MMMM" gives full month name "MMM" gives short month name "MM" gives 2 digit month
number "M" gives 1 or 2 digit month number

Symbol Description Example
G Era designator AD
y Year 1996; 96
M Month in year July; Jul; 07
w Week in year 27
W Week in month 2
D Day in year 189
d Day in month 10
F Day of week in month 2
E Day in week Tuesday; Tue
a Am/pm marker PM
H Hour in day (0-23) 0
k Hour in day (1-24) 24
K Hour in am/pm (0-11) 0
h Hour in am/pm (1-12) 12
m Minute in hour 30
s Second in minute 55
S Millisecond 978
z Time zone Pacific Standard Time; PST; GMT-08:00
Z RFC 822 Time zone -0800

Time Zone. Choose the time zone to display time with.

Lat/Lon Format. Format used when showing lat/lon. This is a normal decimal format that can contain the symbols:

0 Digit
# Digit, zero shows as absent
. Decimal separator or monetary decimal separator
- Minus sign
, Grouping separator
E Separates mantissa and exponent in scientific notation.

; Subpattern boundary Separates positive and negative
subpatterns

The table below shows a list of example formats and the resulting display in the latitude and longitude values.



Format Example
##0 -95
##0.0 -94.6
##0.0# -94.56
##0.0## -94.563
0.0 -094.6
0.00 -094.56
0.###E0 1.04E2
000.#E0 104.6E0

Probe Format. This defines an html template that is used to display data readouts in the data probe display. This html template can contain
macros that are replaced with the probed values. Macros are: 

%value% Formatted value 
%unit% Display unit 
%rawvalue% Unformatted value 
%rawunit% Original unit

Distance Unit. When displaying distances (e.g., in the Range and Bearing Control) this is the default unit that is used.

Sampling Mode. You can specify the type of sampling you want for the various data probes. Choose between a weighted average sampling or
nearest neighbor.

Pressure to Height. You can specify the type of algorithm you want to use for converting from pressure coordinates to height. See the FAQ for
more information on this option.

Cache Data in Memory. McIDAS-V normally tries to cache data that it loads in memory. You can turn this behavior off with a preference.

Disk Cache Size. McIDAS-V will cache some data sets to disk to eliminate network latency. Specify the maximum amount of disk size with this
preference.

Max Image Size. This field allows you to set a maximum image size (in pixels) that is to be displayed. When this preference is set the image
display will adjust the Pixel Sampling to reduce the image to less than the preferred value. This allows for the initial display of large images
without causing memory issues.

Grid Threshold. This field allows you to set a size limit for holding grids in memory. Grids larger than this size will be cached to disk instead of
held in memory during the McIDAS-V session. This allows loading large grids and long loops of grids without a major performance hit.
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User Preferences - Advanced
The Advanced tab lets you change options that require a restart in order for them to take effect. This tab is also accessed by using the startup
manager to configure settings before running McIDAS-V (runMcV-Config.bat or runMcV-Config).

Memory. Change the amount of memory used by McIDAS-V to use either a percentage or a set value. The new amount of memory will be saved
and used in subsequent sessions. For 32 bit operating systems, it is recommended to set this to no more than 1250 MB. The maximum value for 32
bit operating systems is 1536 MB.

Enable 3D controls. When checked, McIDAS-V uses the default 3D behavior. Uncheck to override the default 3D behavior of McIDAS-V and
use a 2D View for Map Views.

Enable JOGL. Choose to use or not use Java OpenGL (JOGL).

Enable Direct3D. Windows-only: choose to use or not use Direct3D.

Specify Default Bundle. When checked, select a bundle from your list of favorites (found in the Bundles menu) to load upon startup.

Load Default Layout. When checked, McIDAS-V will load the default layout upon startup. Uncheck to use the default layout of McIDAS-V
(one window with one panel).

Enable Geometry by Reference. Choose to use or not use Java Geometry by Reference. Try this option unchecked if random/extraneous map
lines are drawn - a problem that may occur more frequently on systems with ATI graphics cards.

Enable Concurrent Mark-Sweep Garbage Collector. Choose to use or not use Java Concurrent Mark-Sweep Garbage Collector.

Enable Non-Power of Two (NPOT) Textures. Choose to use or not use Java Non-Power of Two (NPOT) Textures.

Enable Access to Image Data by Reference. Choose to use or not use Java Access to Image Data by Reference. We recommend that this option
be checked, as it often removes the jagged edges at the limb and/or gaps at the dateline that sometimes appear in displays of image data.

Java Rendering. Use the pull down menu to select the number of Java threads to use for rendering.

Java Reading. Use the pull down menu to select the number of Java threads to use for reading.



Image 1: Remote ADDE Data Manager

Remote ADDE Data Manager
The Local and Remote ADDE Data Managers are available through the Tools->Manage ADDE Datasets menu. Click the "Remote Data" tab to
manage access to data on other workstations, or the "Local Data" tab to manage access to data on your workstation. Continue below for more
information about the Remote ADDE Data Manager, or go here for more information about the Local ADDE Data Manager.

The Remote ADDE Data Manager lets you add, delete or edit access to remote datasets that are available through the Data Explorer. You can also
import a MCTABLE.TXT file that contains a preexisting set of entries for the Remote ADDE Data Manager.

The columns in the main table are defined below.

Valid:
An empty column (no icon) means that the entry passed a verification check (the specified dataset and data type exists on the server) when it
was added. A sad-face icon ( ) indicates that the entry failed the verification check and thus will not work if you attempt to access data
from the dataset.
Source:
Indicates the source of the entry. System entries ( ) are ones supplied in the McIDAS-V package and thus are not editable. User entries (

) are ones that were added by the user and thus are editable. MCTABLE entries ( ) are ones that were added by importing
MCTABLE.TXT file and are also editable.
Dataset:
Lists the server IP address and dataset name for the entry. When you access the dataset (by pressing the "Connect" button in the Data
Explorer), an ADDE request is sent to the server, which then returns the requested data.
Accounting:
Indicates whether the entry includes accounting information (username and project number) for the server. These are the values specified in
the Username and Project # fields in the Define New Remote Dataset window that appears when the "Add New Dataset" button is
clicked. If accounting information was not specified, then the Accounting field entry says "public dataset".
Data Types:
Indicates the values that were selected in the Dataset Types section in the Define New Remote Dataset window that appears when the
"Add New Dataset" button is clicked.

The four buttons at the bottom of the window are described in the corresponding section below.

Add New Dataset
Edit Dataset
Remove Selection
Import MCTABLE...

The window below appears if you click the  button or select the File->New Remote Dataset menu in the main Remote
ADDE Data Manager window.
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Image 2: Define New Remote Dataset window

The Define New Remote Dataset window lets you add access to remote datasets so they are available through the Data Explorer.

The fields and buttons are defined below.

Server:
Enter the IP address of the server workstation.
Dataset:
Enter the ADDE dataset name. In McIDAS-X, this is often called the ADDE group name.
Specify accounting information:
If the server uses ADDE accounting to require users to enter a username and project number to access the dataset, click this checkbox to
enable text entry into those fields. If the dataset is a public dataset, meaning that the server allows users to access the dataset without
specifying a username and project number, then leave this box unchecked. If you are unsure whether it's a public dataset or one that requires
a username and project number, click the "Verify Server" button and the Status field will say "Incorrect accounting information" if it's
required.
Username and Project #:
If you've been granted access to a dataset on a server that uses ADDE accounting to limit access to specific users, click the "Specify
accounting information" checkbox then enter your username and project number for that server. The valid usernames and project numbers
for each server are assigned and maintained by the server administrator.
Dataset Types:
Click the checkboxes for each of the types of data in the dataset. To find which types are available, click the "Verify Server" button and it
will check the box of each available type.
Status:
Indicates the status and provides instructions.

First completes the procedure listed in the Verify Server section below. Then, if everything is passes the verification tests, it adds a new
entry to the Remote ADDE Data Manager containing the information specified in this window.

Contacts the server and verifies whether the dataset exists. If so, it also verifies which dataset types it contains and, if a username and
project number is required, whether the specified ones are valid.

Adds a new entry to the Remote ADDE Data Manager containing the information specified in this window. This option does not do any
verification testing, so it's possible to add an incorrect dataset name, username, project number, etc.

Closes the window and discards any information that was entered.

If you highlight an editable entry then click the  button in the main Remote ADDE Data Manager window, the window and
fields are the same as above, except that the window title is Edit Remote Dataset and the bottom buttons say Verify and Save Changes, Verify
Changes, and Save Changes (rather than Verify and Add Server, Verify Server, and Add Server).

 

If you highlight an editable entry then click the  button in the main Remote ADDE Data Manager window, it immediately
removes the entry from the table. There is no recovery option, so if you accidentally remove an entry you need, you will have to remake the entry
using the "Add New Dataset" button.

 

The window below appears if you click the  button in the main Remote ADDE Data Manager window.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_DataExplorer__FILE


Image 3: Import MCTABLE window

The Import MCTABLE window lets you import a MCTABLE.TXT file that contains a preexisting set of entries for the Remote ADDE Data
Manager. For example, McIDAS-X users may have added access to many servers via the DATALOC command. Those entries are stored in the
MCTABLE.TXT file, which can be imported to McIDAS-V.

The fields and buttons are defined below.

Look In:
This pulldown menu allows you to select folders to search for data files, or you can double-click on folder names.

 Up One Level:
Moves you up one folder level in your local file system.

 Desktop:
Takes you to the Desktop folder of your local file system.

 Create New Folder:
Creates a new folder.

 List:
Switches the view to a listing of all folders and files in the current path.

 Details:
Switches the view to a detailed list of all folders and files in the current path.
Use ADDE Accounting?:
If the servers in the MCTABLE.TXT file you are importing use ADDE accounting to require users to enter a username and project number
to access their datasets, click this checkbox and then enter your username and project number. If you use different usernames and/or project
numbers on some servers, you can edit them (via the Edit Dataset button in the main Remote ADDE Data Manager window) after you
import the file.
File Name:
Select a file to populate the entry box to show the full name of the file selected.
Files of Type:
Narrows down the files shown in a folder to a specific data type.

Imports the selected file so that its entries are added to the Remote ADDE Data Manager.

Closes the window and discards any information that was entered.
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Image 2: Add Local Dataset window

Local ADDE Data Manager
The Local and Remote ADDE Data Managers are available through the Tools->Manage ADDE Datasets menu. Click the "Local Data" tab to
manage access to image data on your workstation, or the "Remote Data" tab to manage access to data on other workstations. Continue below for
more information about the Local ADDE Data Manager, or go here for more information about the Remote ADDE Data Manager.

The Local ADDE Data Manager lets you add, delete or edit access to local image datasets that are available through the Satellite Imagery chooser
(where you select <LOCAL-DATA> in the Server: field).Other types of data (e.g., grid or point) in local files can be accessed directly through
other choosers (e.g., the General Files chooser).

 

The contents of the four columns in the table (i.e., Dataset, Image Type, Format and Directory) are described in the section below. The status line
in the lower left corner gives information about the operating status of the local image server. If the server has stopped or is not running as

expected the status line will say "Local server is not running". In this case you can click the  button to restart the server.

 

To add a new local dataset entry, select File->New Local Dataset from the main menu and the window below appears.

The Add Local Dataset window lets you add access to local image datasets so they are available through the Satellite Imagery chooser.

The fields and buttons are defined below.

Dataset:
Enter a dataset name for the local server entry. The dataset name is limited to eight characters or less and cannot be entirely numeric.
Image Type:
Enter an image type name for the new local server entry. This will appear under the Image Type pull down menu in the Satellite Imagery
chooser. The image type name is limited to twelve characters or less.
Format:
Select the format of the image files. The following formats are supported in McIDAS-V:

AMSR-E Level 1b
AMSR-E Rain Product
GINI
LRIT
McIDAS AREA
Meteosat OpenMTP
Metop AVHRR Level 1b
MODIS L1b MOD02 (MODIS Level 1b)
MODIS L2 MOD04 (MODIS Level 2 Aerosol)
MODIS L2 MOD06 (MODIS Level 2 Cloud Top Properties)
MODIS L2 MOD07 (MODIS Level 2 Atmospheric Profile)
MODIS L2 MOD28 (MODIS Level 2 Sea Surface Temperature; note: when loading this data, you must use line/element for the
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Location, and use the raw size of the image, or a magnification with the lock icon unlocked)
MODIS L2 MOD35 (MODIS Level 2 Cloud Mask)
MODIS L3 MODR (MODIS Level 2 Corrected Reflectance)
MSG HRIT
MTSAT HRIT
NOAA AVHRR Level 1b
SSMI (TeraScan netCDF)
TRMM (TeraScan netCDF)

Directory:
Select the location of the local files using the pop up navigation box. At this time, only a directory can be selected. An option to add
files by file mask will be added in the future.

Adds a new entry to the Local ADDE Data Manager containing the information specified in this window.

Closes the window and discards any information that was entered.

 

To edit an existing entry, bring up the main window and click on the entry to highlight it then either select Edit->Edit Entry... from the main
menu or double click on the entry so that the Edit Local Dataset window appears. Then make the needed changes and click the "Save Changes"
button (or click the "Cancel" button to discard any changes and close the window). To delete an entry, click on the entry to highlight it then select
Edit->Remove Selection from the main menu.
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Image 1: Projection Manager

Projection Manager
The Projection Manager allows you to choose, edit and save map projections for use in McIDAS-V.

A projection is a way of mapping the surface of the earth (a curved 2D surface) onto a plane (a flat 2D surface). A projection transforms a point
on the earth (specified by latitude, longitude) to a point on the projection plane.

In the Projection Manager, both the projection -- which kind of mapping to use -- and the area of the Earth can be specified. You can make a
Lambert Conformal map of North America, and a Lambert Conformal map of Sedgwick County, Kansas. Same projection, different areas.

McIDAS-V provides several basic types of projections: Lat/Lon, Lambert Conformal, Transverse Mercator, Stereographic, , Mercator,
Albers Equal Area, Lambert Azimuth Equal Area, Orthographic, Vertical Perspective View. Each of these can be parameterized (e.g.,
tangent point, origin longitude) to create a specific projection area of that type. When you define a projection and area, you specify the type of
projection and its parameters.

Projection Manager Window
You can bring up the Projection Manager with the Projections->New/Edit menu option, or through the Tools->Projections->Edit Map
Projections. Projections supplied with McIDAS-V are shown in the list. There may be additional projections you have created and named. In the
figure, the McIDAS-V US->CONUS projection is highlighted, and displayed on the left.

To use a projection in the application: select it from the list by clicking on the name (it turns blue), and press Apply which leaves the projection
manager on screen, or press Ok and the projection manager is removed.

To modify or create a new projection: choose Edit or New from the menu; the Define/Edit Projection dialog box appears (see below).

McIDAS-V starts with a default projection. Use the Default pull-down menu to select the projection that will be shown each time your McIDAS-
V starts. (The default projection may not be used if you are starting McIDAS-V with a Bundle of configuration information.)

You can also Export a projection to a file.

You can remove any projection from the main list by clicking on its name to highlight it, and then clicking on the Delete button.

Define/Edit Projection Window
This allows you to define new projections, and to modify existing ones. Remember that a Projection not only consists of the mathematical
projection, but also the area of the Earth that is seen.

Here is how to create a new or revised projection:

Choose Edit or New from Projection Manager Window.
Choose a Projection Type from the pull-down menu.
Fill in the projection parameters.
Set the map area shown with this named projection by zooming and panning the view on the left. To zoom, drag the left mouse button. Use
the other buttons in the window to zoom out and move around.
Give it a new or revised name if necessary. See the Properties section below for more information about naming and creating hierarchies.
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Image 2: Projection Editor

In the example shown, a Lambert Conformal projection is being defined with the projection parameters as shown in the figure.

Properties

Edit Projection

Use the Zooming and Panning options to define a new map area, or the following buttons:

Click to turn on/off maps in the map area while defining a new projection.
 Zoom In

Click to zoom in over the current map area.
 Zoom Out

Click to zoom out over the current map area.
 Previous Map Area

Click to return to the previous map area.
 Home Map Area

Click to return to the default map area.
 Move View Up

Click to move the view up (map down).
 Move View Down

Click to move the view down (map up).
 Move View Left

Click to move the view left (map right).
 Move View Right

Click to move the view right (map left).
Name

Enter in a new or revised name if necessary (projection names are unique). Use ">" between names to create a category hierarchy.
Type

Use the pull down menu to select the projection type. Each projection type will have their own specific parameters to define.
Save

Click to move the projection to the main projection manager.
Preview

Click to see what the projection looks like.
Cancel

Click to exit the Define/Edit manager and return to the Projection Manager.



Color Table Editor
Introduction
Starting the Color Table Editor
Color Legend
Painting and Editing Colors
Breakpoints
Saving, Importing and Exporting
Color Chooser

Introduction
The Color Table Editor supports editing existing color tables and creating new ones. A color table is an ordered collection of colors that is used to
color a display according to a range of data values.

Starting the Color Table Editor
The Color Table Editor can be used stand-alone by selecting the Tools->Color Tables menu item from the main menu bar. It can also be used or
in conjunction with a particular display by clicking on the display's color bar in the legend, or through the display's edit menu. When used in
conjunction with a particular display the changes you make to the color table are applied to the display as you make them. To turn this off use the
Auto Update check box in the lower right corner of the window.

The Color Table Editor starts with a color table loaded in it. If you are working with a data display, the color table in the editor is the same as in
the display. If you want to use or edit a different color table, use the Color Tables menu to select from the categorized list of color tables:
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Color tables are grouped into categories, as illustrated. The illustration shows the color tables for the "Basic" category. Click on a category and
then on a "color table to select.

To switch to the newly selected color table for a display on screen, click on OK in the bottom of the Color Table Editor, and the editor will close,
or click on Apply to keep the editor in use. If Auto Update is checked the change takes place without further action by you, as soon as you select
a new color table.

Color Legend

The color table is shown in the bar of color across the window, the color legend. How many colors are in the table is shown in a label in the upper
center, such as "135 colors." You can reduce or increase the number of colors by clicking on the -/+ choices near the left and right ends of the
legend. New colors are added or removed at each end of the legend with the same color as the end color. Pressing Shift-Click on any of these
buttons will add/remove 10 color slots at a time.

Underneat the color legend is a black and white checker board to help show the degree of transparency. Most color tables have zero transparency
and the checker board is not visible.

The History undo/redo buttons in the upper left allow you to step forward and backward through the changes you have made. Pressing Shift-
Click on these buttons will step forward/back 10 changes.

The spectrum of colors spans a range of data values. The values are shown at the ends of the color legends. You can change the max and min of
the range with the Range: pair of dialog boxes on the right. Enter the minimum and maximum values of the range you need, and click Apply or
Ok, or press the Enter key. If the Color Table Editor is being used in conjunction with a display then when you change the range that range is
applied to the display as well.

Painting and Editing Colors
You can "paint" in the color bar by just dragging the mouse within it. When your mouse is over the color bar the cursor will change to a
paintbrush and a gray line is drawn to indicate the position of the cursor.

The type of painting is specified by the Paint Mode buttons.

Fill. When you drag the slider, it will fill the color table with the currently selected color in the color chooser.
Interpolate. Apply a linear interpolation from where you started dragging the breakpoint to the color value of where the breakpoint is
currently located while dragging.
Transparency. Apply the given transparency value (in the editable pull-down menu) to the color table where you are dragging the
breakpoint.

Breakpoints
The editor uses "breakpoints" indicated along the top of the color legend bar with little triangles and a number. Clicking on a break point makes it
active. The number on an active breakpoint is in bold characters. There is only one active breakpoint at a time. Making a new breakpoint makes
the new breakpoint active.

Breakpoints are used for a number of things: showing the data and transparency values at a point along the color table and changing the colors
(fill, interpolation or transparency) directly below the breakpoint by dragging the breakpoint and changing colors through a popup menu.

The values on the breakpoints are determined by the position of the breakpoint along the legend, proportional to the min and max of the Range.
Changing the minimum and maximum of the Range changes the break point values.

You can move the active breakpoint several ways:

Drag on it with the mouse pointer;
Move in small increments with the right or left arrow keys. (If there is no response, first mouse click on the breakpoint.)
Move in bigger steps with the shift-arrow keys.
Right-click on the breakpoint and use the pop-up menu item Change Breakpoint.

If you have the "Actively set color" checkbox selected, when you change the color in the color chooser at the bottom that color will be applied to
the color slot under the selected breakpoint. This allows you to set the color of a specific color slot.

You can also change colors and manipulate breakpoints using a right mouse click popup menu on a breakpoint:



The choices are:

Remove Breakpoint.
Remove the active breakpoint.
Lock/Unlock Breakpoint
Lock of unlock the active breakpoint.
Change Breakpoint.
Set the breakpoint to a new value.
Add Breakpoint->Here.
Add a new breakpoint where the legend was clicked.
Add Breakpoint->At Data Point.
Add a new breakpoint at a data value. You will be given a dialog box to enter the value in.
Add Breakpoint->At Beginning.
Add a new breakpoint on the left end.
Add Breakpoint->At End.
Add a new breakpoint on right end.
Edit Colors-> Interpolate Left.
Starting with the color at the active breakpoint, interpolate colors to the left up to the next breakpoint.
Edit Colors->Interpolate Right.
Starting with the color at the active breakpoint, interpolate colors to the right up to the next breakpoint.
Edit Colors->Fill Left.
Starting with the color at the active breakpoint, fill colors to the left up to the next breakpoint with that single color.
Edit Colors->Fill Right.
Starting with the color at the active breakpoint, fill colors to the right up to the next breakpoint with that single color.
Edit Colors->Transparency Left.
All color table values from the active breakpoint to the next breakpoint to the left are set with the transparency value.
Edit Colors->Transparency Right.
All color table values from the active breakpoint to the next breakpoint to the right get the transparency value.
Edit Colors->Brightness Left.
All color table values from the active breakpoint to the next breakpoint to the left are set with the brightness value.
Edit Colors->Brightness Right.
All color table values from the active breakpoint to the next breakpoint to the right get the brightness value.
Replicate Color Table
A dialog box will pop up asking how many times the color table should be replicated. It then replicates your current color table that many
times (i.e. If you have a color table with 100 slots and enter 3, the resulting color table will look like 4 of the original color tables, each with
25 slots).
Invert Color Table
Reverses the order of the color table.

Saving, Importing and Exporting
You can modify an existing color table, or edit an existing color table and save it with a new name to make a new color table. Any new or
modified color table can be saved for future use.

To save a new or modified color table simply select the the File->Save menu item or Save button. To save a modified color table as a new color
table, select File->Save As and enter the new name in the dialog box that appears. This new color table will now be permanently saved in your
local collection of color tables.

To save a color table as a file which can be shared with others in their McIDAS-V, select the File->Export menu item. A file dialog will appear
that will allow you to save the color table as an XML-format file. We suggest you use a file extension of .xidvct.

To use a color table as a file which has been supplied to you by another McIDAS-V user, select the File->Import menu item. A file dialog will
appear that will allow you to find the color table as an XML-format file. The following types of color tables can be imported:

McIDAS-V (IDV) color tables (*.xml)
GEMPAK color tables (*.tbl)
McIDAS-X color tables (*.ET)
3-column RGB color table (*.ascii)

3-column RGB color table

The definitions of the 3-column RGB color table are divided over a range of values. Each line represents one of the equal sized blocks on the color
bar. If there are ten lines in the file, they show up on the color bar as ten equal-sized blocks, with the first line's color being applied to the first
block, the second line's color applied to the second, etc. Currently, there needs to be five or more lines in the file in order for the color table to
work.

Color Chooser



 
Image 1: The Color Chooser, HSB panel

 
Image 2: The HSB Hue chooser, set on green with high S and high B

 
Image 3: The HSB Saturation chooser set on the same green

The Color Chooser, in the lower half of the Color Table Editor window, allows you to select any possible color.

There are two tabs on the chooser, HSB and RGB, each with its own control panels. The RGB panel shows a window that lets you specify any
color by slider bars for R, G, and B values. R, G, and B are red-green-blue settings that control the intensity of the color guns in a CRT. The only
color sample of an RGB value is the color of the active breakpoint in the legend, which can be pretty small and hard to see clearly. Also, RGB
values are not intuitive -- to get yellow you mix equal amounts of red and green in RGB. We recommend you use the HSB chooser panel unless
you have specific RGB values to set.

The HSB Chooser

The HSB chooser allows you to control color by hue, saturation, and brightness, thereby making any color. With the HSB panel and tab shown,
click on one of the circles marked H, S , or B for the corresponding control for hue, saturation, or brightness.

Hue is the term indicating a pure color selection from the spectrum. Saturation is an indication of how much white is added to the hue. 100%
saturation is pure hue with no white. Brightness is an indication of how much black is added to the hue. 100% brightness has no black and
maximum brilliancy, but can be any saturation from the hue to pure white. 0% brightness is solid black.

Some "colors" are not found in the spectrum and are a mixture of a hue and black or white or both black and white. For example, brown is red-
orange and some black. Grays are any hue with low saturation and some degree of brightness from black to white -- basically a mixture of white
and black.

You need only use one of the controls for H, S, or B to make any color. It's merely a matter of which one is easiest for you. Often the H control is
the easiest and most intuitive to use. We often think first in terms of colors (hues), and next in terms of how pale or dark a color of that hue we
want. The H control works that way. You can select any possible color with the HSB color chooser in the H setting.

All this is easier to understand while using the HSB panel, with H clicked on:

The slider bar chooses the pure hue. Once you have chosen a hue, clicking or dragging the mouse on the square color display chooses degrees of
saturation and brightness -- how much white or black is added in -- for that hue. Using the HSB Hue display you can make any color after a little
practice.

Note that the right edge of every hue chooser is a gray scale, and the bottom is pure black.

The Saturation Chooser (S) has a slider bar with the full range of saturation (how much white is added to the color):

Select hue and brightness by dragging the mouse over the colored square.The bottom is always solid black. If you want true shades of colors --
pure hue with only black and no white -- use the S control with the slider at the top. There are no grays or pale colors in this case.



 
Image 4: The HSB Brightness chooser set on the same green

The Brightness Chooser (B) has a slider bar with the full range of brightness (how much black is added to the color):

Select hue and saturation by dragging the mouse over the colored square.The bottom is always pale gray going to white. If you want to use colors
that are all at full brightness, use the B control with the slider at the top. Note that colors such as brown are not available in this setting, and there
are no dark colors.

All controls in the HSB panel show the RGB values for any color selected, in case you need to know the RGB values for another use.



 
Image 1: Layout Model Editor

Layout Model Editor
The Layout Model Editor composes the layout and style used to plot data on a map from observations at discrete points (e.g., weather
observations).

The Layout Model Editor is used to edit existing models or to create new models. The Editor is opened with the Tools->Station Model Template
menu.

To see any model, use the Layout Models menu. The models that the user has edited or created will have "(local)" after the name.

The display shows a horizontal line and a vertical line through the observation location. These axis lines give a reference point. A station model
consists of a set of shapes which are added by clicking on an item in the left column and then clicking where you want to place it (relative to the
observation center point or location point). It will appear with a surrounding outline box and 8 control points you can drag to resize the item.
When a shape is created its property dialog is shown (described below).

Shapes can be moved by dragging with the mouse. Click on any item with the right mouse button to see a pop-up menu of choices to control its
appearance. You can delete an item, set its color, or change font sizes, view its properties, etc.

Each item has a single red "Alignment point" that is used for to locate the actual displays with respect to the center point of the observation. So,
for example, say you want a text label (whose actual width in the main display depends on the data it is showing) to be aligned so that its upper
right corner is at the latitude of the observation and a little right. You would set the shape's alignment point to be "NW" and then position the
shape so that the Y of the alignment point is on the X-axis and the X of the point is a bit right of center.

The Center menu in the popup-menu allows you to center the alignment point vertically and horizontally.

You can also align a collection of shapes. First select the shapes (shift-click). Then select one of the six alignment icons under the top menu bar;
the left most icon means align all the selected items under a horizontal line.

To save a station model you have composed, use the File->Save or File->Save As... menu items. When you save a station model any point data
displays that are using it will be updated. To remove a model, use the File->Remove menu item. You cannot remove a model supplied with
McIDAS-V, but you can remove local models.

You use the Properties choice in the pop-up menu to show the properties dialog window for that shape. The properties dialog is made up of a
number of tabs.

Note: The Apply and OK buttons applies the properties to the shape in the editor. The OK and Cancel buttons closes this dialog. The
Save button does and apply and also saves the station model as a whole (just like doing File->Save). When the station model is saved
then any displays that are using it are updated. The Save button allows you to see what your changes to the properties will look like in
the main display.

Properties Dialog - Display Tab



Image 2: Properties Dialog - Display

 
Image 3: Properties Dialog - Color By

This tab allows you to assign which observation variable is associated with that item. Numerical values should appear in a "Value" item, text in a
"Text" item, etc. You can also set units and the display format.

Parameter identifiers within a station model can hold embedded Jython code. This allows you to do operations on the values and provide more
extensive formatting. Any parameter that begins with "=" is treated as a Jython expression. For example, you can enter:

=T-TD

to calculate the dewpoint depression. You can format the text that is shown. For example you can enter:

='TD:'+str(T-TD)

This will result in the calculation of T-TD, a conversion of that result to a string which is then concatenated to the string 'TD:'. If you want to
format the result of the numeric calculation using the format specifier from the properties dialog simply enter:

='TD:'+format(T-TD)

Properties Dialog - Color By Tab

This tab allows you to specify a parameter that is used to color the shape. You can specify a data range (and a corresponding unit for the data
range, e.g., celsius). This data range is used as the end point ranges for the specified color table.

For example, in the above image the Temperature parameter has been specified with data range -90-45 celsius. For each display McIDAS-V will
find the Temperature value (e.g., 15 celsius), convert it, if necessary to the specified unit, find its where is lays within the range and use the
corresponding color from the color table.



 
Image 4: Properties Dialog - Color From

 
Image 5: Properties Dialog - Scale Size By

This allows you to specify parameter, a set of (regular expression) patterns and a corresponding color. If the text value of the parameter matches
one of the patterns then the given color is used to color the shape. For example, if your point data had a "fruit" field in it (e.g., fruit=banana,
apple, tangerine) you could define different colors for different values of fruit.

To get more lines press the Apply button.

Properties Dialog - Scale Size Tab

This allows you to specify a parameter to scale the shape by. It works similarly to the Color By facility described above. You specify a parameter,
a data range (with a unit if desired), and a scale factor range. For each point display McIDAS-V will find the value of the parameter, determine
where that value lies within the data range and find the corresponding scaling from the scale factor range.

Properties Dialog - Rotate Tab



 
Image 6: Properties Dialog - Rotate By

This works like the scale and color by facilities. Specify a parameter, data range and rotation range. Note, the rotation is about the Z axis in X/Y/Z
space. It is not a rotation in Lat/Lon space.



 
Image 1: Display Settings Dialog

Display Settings
The Display Settings facility allows you to select a set of properties from a display control (e.g., color table, contouring info, isosurface value,
label template, etc.) and apply them to other display controls and/or save them as preferences to be used when creating new display controls.

The Display Settings dialog, pictured below, can be brought up from a layer control's Edit->Display Settings... menu.

On the left is a list of all of the source display controls in McIDAS-V. In the middle are the properties of the currently selected display control
which is shown highlighted in blue on the left. On the right is also a list of the display controls. These are the target display controls.

The idea is that you can select properties in the middle panel that you want to apply to the selected target display controls (via the checkboxes) on
the right. Many of the properties can be changed by clicking on the  buttons.

The View menu is a handy way of selecting different groups of target display controls. For example, you can select All Displays, displays of
certain types, displays that have the same data sources, etc.

Display Settings Examples
For example, say you have two different data sources loaded with 3 or 4 displays created from each. Normally, the legend will list all of the
displays based on some display category (e.g., Plan Views). However, you want to be able to change their display category so that each group of
displays that are from one data source have the same category (e.g., "Data source 1", "Data source 2"). What you would do in this case is change
the "Display Category" property under "Labels" to "Data Source 1".

Then, you could manually select the displays you want to change but an easier way is to use the Display Groups menu and choose "Displays
with data source ...":



 
Image 2: Save Settings Dialog

 
Image 3: Display Settings in Field Selector

This selects the displays with the data source of the currently selected display (the one highlighted in blue).

Once selected you then hit Apply. This will set the "Display Category" property on the selected display controls.

To do the next set of displays select a new Source display control in the list on the left. This will select this display and reset the properties list in
the middle. Then when you do the Display Groups->Displays with data source the displays that share the data source from this new display will
be selected.

Saving Display Settings
You can save the set of selected settings with the Save button. The Save Settings dialog will be shown:

You can enter a category and a name. The saved settings will be shown under the Saved Settings menu. When selected they will be applied to the
list of properties on the left. The Applicable only to displays of type button, will be used when showing the saved settings in the Field Selector
(described below).

Using Display Settings in the Field Selector
The set of saved display settings are also shown in the field selector:

You can select any number of these and, when a new display control is created, these settings will be applied to the new display. The Show All
check box allows you to list all of the settings, regardless if they were saved off for a particular type of display.



Parameter Alias Editor
The Parameter Alias Editor is opened through the Tools menu with Tools->Parameters->Aliases menu and allows for the association between
"canonical" parameter names used by McIDAS-V for physical quantities, such as TEMP for temperature, and parameter names used in particular
data sets for the same quantity, such as for example "jan_mean_temp."

Different data sets often have different names for the same physical quantity, such as for the quantities temperature or easterly wind speed
component. You can make McIDAS-V recognize any particular data name as representing a standard quantity. The Alias Editor associates any
particular variable name that may appear in a data set (right column) with a canonical or McIDAS-V name or alias (left column).

The Alias Editor has a number of tabs that display the user editable aliases and the non-editable system aliases. You can right-click on a row in
the system alias tab to copy that row to the user's tab. You can also add a new alias with the New Alias button. You can edit a user's entry by
right-clicking on the table row.

When you do this the alias properties dialog is shown where you can edit the name, label (descriptive text) and the aliases:
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Image 1: Parameter Defaults Editor

 
Image 2: Parameter Defaults Properties

Parameter Defaults Editor
The Parameter Defaults Editor is opened through the Tools menu with Tools->Parameters->Defaults and allows for the specification of default
color tables, ranges, units, and contouring values for different parameters.

This feature lets you preset conventional color and contouring choices, and lets you override system defaults.

There are two sets of defaults: user defaults in the tab User defaults, and system defaults supplied with McIDAS-V in the System defaults tab.
Look at the system defaults for examples. These are general common parameter names, such as u for the eastward wind component, and special
names we have encountered that our users may also use, such as p_msl for mean sea level pressure.

The system settings cannot be edited by the user, but right clicking a row allows you to copy a parameter to the "user defined" table. When you do
this the Parameter Defaults Properties window allows you to define what properties you want to define:

Simply check or uncheck the Defined buttons and define the settings as desired. From the user defined table you can also right click on a row to
add a new row, edit the settings for the row or delete the row.

The parameter names are given in regular expression syntax to help match with actual data names. Plain text is matched exactly. The string dot
star, ".*", means "any text here." The ^ means "begin with the following text exactly."
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Image 1: Parameter Groups Editor

 
Image 2: Parameter Groups Properties

Parameter Groups Editor
The Parameter Groups Editor is opened through the Tools menu with Tools->Parameters->Groups and allows for the specification of
"parameter groups", named groups of parameter names.

There are two sets of defaults: user defaults in the tab User Groups, and system groups supplied with McIDAS-V in the System Groups tab.
Look at the system defaults for examples.

The system settings cannot be edited by the user, but right clicking a row allows you to copy a group to the "user defined" table. When you do
this the Parameter Groups Properties window allows you to define the sets of parameters that fall under this group.
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Contour Properties Editor
The Contour Properties Editor is invoked from any contour display control with the Contour: Change button or through Edit->Change
Contours....

Use the items in this window to set contouring properties.

Contour Interval determines the spacing (difference in value) between contours.Set it to a single value to specify a regular interval between
contours. You can specify irregular contour intervals with a semi-colon separated list of the values. For example:

5400;5460;5800

would only show the 5400, 5460 and 5800 contour lines.

You can also specify different contour intervals for different ranges with the following syntax:

cint1/min1/max1;cint2/min1/max2;....;cintn/minn/maxn

For example, for geopotential heights:

30/0/4200;60/4200/8600;120/8600/24000

would draw contours at 30 gpm between 0 and 4200, 60 gpm between 4200 and 8600 and 120 gpm between 8600 and 24000.

To show a single contour line, specify the contour interval, min and max as the same value. For example:

5400/5400/5400

would only show the 5400 line.

Base contour is the value on which all contours are based. All contours will be integer multiples of the contour interval from the base value. For
example, with a base value of 0 and a contour interval of 3 contours would be created at ..-6, -3, 0, 3, 6... A base of 1 with that interval would
create contours at ..-5, -2, 1, 4, 7... The base value need not be the lowest contour level on a plot, or inside the range of values plotted; it is only a
computational reference point. The base contour value is also used for controlling which lines are dashed.

Minimum value is a limit below which no contour lines are shown. The minimum may be larger than the base value, so that the base value may
never appear on a plot.

Maximum value is an upper limit above which no contour lines are shown. The minimum and maximum values need not match contour line
values; they are only limits.

Line width sets the line width (in pixels) of the contour lines and labels.

You can toggle the labels by clicking the Labels check box.

If Dash is checked, values less than the base value are dashed. If base is set higher than maximum value, then all lines are dashed. Use the
pulldown menu to select the dash pattern to use.

Click on OK to set the values you want and close this window. Click Apply to set the values but leave this window open.



Image and Movie Capture
You can capture the main 3D view as an image, a QuickTime movie or an animated GIF.

Saving Images
Print Current View
Save QuickTime Movies
Play QuickTime Movies

Saving Images
You can save a display as an image. Select the View->Capture->Image... menu item. A file dialog will popup where you can enter a file name
for the image file. McIDAS-V supports JPEG, PNG, GIF, PDF, PS, and SVG formats. From this File Dialog you can also specify the image
quality (only used for JPEGs) and what to capture. You can also select whether or not the background is transparent.

Note: when capturing a image the screen cannot be obscured.

McIDAS-V can also write out an image and the corresponding Google Earth KML or KMZ file. For this to be correct the projection must be a
Lat/Lon geographic projection (i.e., rectilinear) and in an overhead view. Some of the default projections that are Lat/Lon include World, Africa,
Asia, Australia, and the individual state projections (US->States->...). You can also create your own Lat/Lon projection using the Projection
Manager. The simplest way to get a correct projection is to select the Projections->Set Current View as Projection menu item. If you specify a
.kml file McIDAS-V will generate an image with the same file prefix and the kml file that refers to the image. If you specify a .kmz file (which is
a zip format) it will contain the image and the kml file.

Print Current View
You can send any display to a printer. Select the View->Capture->Print... menu item. A Print dialog will popup where you can configure and
print an image.

Save Movies
You can save any sequence of displays as a movie. Select the View->Capture->Movie... menu item to bring up the "Movie capture" window:

To make a movie there are three steps: capturing the frames, previewing the frames, and creating the movie. McIDAS-V supports QuickTime
movie, animated GIF, AVI file, Google Earth KMZ and ANIS Applet HTML file formats.

To capture frames, in the Capture section of the "Image capture" window, do one of the following three choices:

click on the Capture one image button to make a single frame of the current McIDAS-V display. Then you change the display to exactly
what you want in the next frame, capture that new image, and continue through the movie.
Click on Capture animation to automatically capture all frames in a display time sequence which you can animate with the usual
McIDAS-V Time Animation Controls. Check Reset to start time to ensure that you capture the entire animation sequence. The QuickTime
animation capture starts on the first frame visible in McIDAS-V and goes to the end. So you can use this to capture part of a sequence.
Click on Capture automatically to start taking snapshots of frames from the McIDAS-V display while you make changes, such as while
you change the viewpoint by zooming, rotation, and panning, and combinations of all three. To stop the automatic snapshots, click on the
button again (which now says Stop). You can set the automatic snapshot sampling rate with the Rate field.

You can combine these different methods of capture. The list of frames is additive.

If you want to save the individual intermediate files that are used to create the movie, check the Save files to box and specify a directory and file
name format. Otherwise, the intermediate files will be saved in a temporary directory and will be removed.

You can use the following templates to customize the name of the output file:

%count% is the image counter
%count:decimal format% allows you to format the count using the same rules defined in the lat/lon format section of the User
Preferences. (or Google 'java decimalformat' for more information).
%time% is the animation time in the default format
%time:time format% a template that begins with "time:" and contains a time format string using the the same date formatting rules
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described in the User Preferences.

You can Preview the movie and remove individual frames or Delete All the frames.

When done capturing frames select the Save movie button to specify the name and format of the file you want to save.

Play QuickTime Movies
McIDAS-V supports displaying certain types of Quicktime movies (including the ones McIDAS-V generates). Load in the Quicktime movie from
the File Data Chooser.
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Timeline
McIDAS-V makes use of a timeline widget in a variety of areas. The timeline allows you to see the temporal distribution of a set of times and
easily select them. There can also be a date selection mechanism (see below) that allows you to select based on a range, interval, etc.

Date Selection
The date selection is defined by:

Start/End date: These define the range to look within.
Interval: If defined, this allows you to select dates every N time units. For example, you can set the interval to be one hour. The times that
are selected are the ones closest to the one hour interval ticks.
Before/After Range: These are displayed by the little gray triangles in the timeline. By default, the ranges that we use are one half the size
of the interval. However, you can set the range both before and after the interval tick. So for example, if you want to just consider times
within 15 minutes before the interval but nothing after the interval set the Before Range to be 15 minutes and the After Range to be 0
minutes.
Count: You can specify a max number of times that will be selected. Only the most recent N times will be selected.
Skip Factor: This says to skip every N'th time that would be selected. For example, the date selection first considers the interval/ranges (if
defined), then it applies the skip (e.g., only every 3rd time), then it looks at the max count.

These can be accessed by right-clicking in the timeline to show a popup menu. The menu allows you explicitly define these settings through a
Properties dialog or (much more easy) set them directly with sub-menu choices.

The View Managers use the timeline to show the animation time set and the times of the different displays. Here, the timeline is used for
informational purposes and is not used to select times. This can be shown through the View->Animation Timeline menu. The gray timeline
represents non-visible displays. Double clicking in a timeline sets the animation step to that time.

Timeline Navigation
The timeline supports a variety of navigation mechanisms:
Event Action
Left Mouse Drag Change visible range or date selection range.
Left/Right Arrow Change visible range. 

Use Control-Key to change date selection. 
Use Shift-Key to use larger increment.

Up/Down Arrow Zoom in/out visible range. 
Use Control-Key to change date selection. 
Use Shift-Key to use larger increment.

Mouse Click; Control-
Click; Shift-Click

Select individual times, multiple times or a range of times

Shift-Drag When not showing the date selection mechanism you can choose a range of times with shift-drag
Right Mouse Click This brings up a popup menu that allows you to show the properties dialog, go to particular current date ranges, set the

interval, range, skip factor and count of the date selection.



Message Console
Clicking on the main menu bar choice Help->Show console shows a console window which has error messages and other text output from
McIDAS-V. Error messages created before you open the console are shown, as well as later ones.

The console is useful if you encounter an error as you can save the console message to a file and include it in email to McIDAS-V Support at
SSEC or attach it in the Support Request Form.
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Support Request Form
Clicking on the main menu bar choice Help->Support Request Form... shows a form to post a support request to the McIDAS Help Desk. This
form can also be brought up from the Error Dialog.

If you encounter a problem or have a comment to share, you can use this form to do so. You can also add attachments to your submission.

When the Include Current State as Bundle button is checked, the current state of McIDAS-V will be submitted along with your request.

When the Send Copy of Support Request to Me is checked, a copy of the email will be sent to the email address you provided in the request.



Miscellaneous
Bundles
McIDAS-V Scripting
Sharing
Data Analysis
Site Configuration
McIDAS-V Special Data Formats
Actions
Command Line Arguments
Performance Tuning
Building McIDAS-V from Source
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Bundles
Bundles let you save a quick "snapshot" of McIDAS-V, including data sources, maps, and data displays. Bundles are small information files that
specify the state of McIDAS-V. They are a kind of configuration file. They include information about what data sources are in use, and which
parameters from the data sources are displayed, and how they are displayed.

The purpose of bundles is for you to save a particular McIDAS-V setup and display. A bundle can be used for your own reference at a later time,
or others using McIDAS-V can use bundles you made to see data the same way you did.

Saving a Bundle
To make a new bundle file, select the File->Save Bundle menu. A pop-up window will let you set a new file location and name:

The customary McIDAS-V bundle filename extension is .mcv; if you do not enter a file extension, .mcv will be appended. When saving a .mcv
file, no data is saved with the bundle, only references to the remote or local Data Sources are saved.

McIDAS-V does support a zipped data bundle format: .mcvz. This is a zip file that contains a regular bundle (.mcv) and a set of data files. When
the user does a "Save Bundle" or "Save Favorite " and specifies a .mcvz file extension, McIDAS-V prompts the user to select the data sources that
should be written into the zip file. When opening a .mcvz file, McIDAS-V needs to unzip the data files, so it prompts the user as to where to
place the files - a temporary directory or a user selected directory (this is a preference as well).

Note: In order for bundle files to work, the data must be available in exactly the same way you made connection to it when you made
the bundle file. Others who use your bundles must have access to the same file system or to the same remote or local data servers you
use, so that file paths or URLs to the data are exactly the same.

The file dialog has a set of buttons to define how parts of your bundle is saved.

The Jython menu allows you to save the Jython code you may have in your library in different ways. For example, you may have written
some custom Jython code that implements a Formula. You have a display that uses the results of that computation. To include your local
Jython code just select All Jython or Selected Jython. When loading in a bundle that has had Jython code saved with it, the user will be
prompted for what to do with the Jython.
 One can save a bundle with data paths that are relative to where the bundle is loaded from by checking the Save with relative paths
checkbox. McIDAS-V will change the file based data sources to point to the directory where the bundle is loaded from. For example, you
can use this to save a bundle that references model files on disk. Copy the bundle and the model files over to a thumb drive or CD. Then
when you load the bundle the files are relative to the bundle path.

Saving a Bundle as a Favorite
Favorite bundles are just normal bundles that are categorized and saved off in a particular location on disk and serve as a convenience to the user.
This allows the user to organize their favorites by category and readily load them in. Favorite bundles are easily available through the Bundles
menu and can also be displayed on the toolbar of the Main Display window.

A favorite bundle can be created through the File->Save Favorite ... menu:

Define your favorite bundle by specifying a category in the Category field and a name in the Name field. Categories can be hierarchical; by
using a ">" as a separator (e.g. Toolbar>sounding) the categories will appear as a tree structure in the Local Favorites Bundles Manager. The



 
Image 3: Favorites Manager

"Toolbar" category is a special category in the Favorite Bundles Manager. The bundles in the Toolbar category will also appear as links in the
toolbar of your Main Display window.

The Local Favorite Bundles Manager, accessed through the Bundles->Manage... menu, allows you to reorganize the categories and favorites by
drag-and-drop, or right click on a favorite or a category to delete it, export it, etc.:

Opening a Bundle
Use the File->Open File menu to open a bundle. When loading in a new bundle you will be prompted whether the current displays and data
should be removed. You can also start up McIDAS-V with a bundle file or URL in the command line.

Copying Data Locally
For most remote data types, data can be copied from the server to the local disk using the "Make Remote Data Local" facility. The following
ADDE types are supported: satellite, radar, point, sounding and forecast fronts. There is also preliminary support for grids on remote servers* (see
below).

This is used in two ways. First, the user can right click on a data source in the Field Selector and select "Make Data Local" for remote data
sources. McIDAS-V prompts for a file directory and a file prefix (the default is to use the name of the data source) and the remote data is copied
over. For multiple files the format used is: <directory><prefix><file count>.<suffix>. The data source object within McIDAS-V is then changed
to point to the new file paths.

The second way this is used is when a .mcvz file is saved. The user is prompted for both the local data sources to be saved off as well as for the
remote data sources. For the remote ones, McIDAS-V automatically copies the files over and zips them.
*Grids: There is preliminary support for grids. This support relies on some extra service information in the catalogs which, right at this moment,
is not included in the regular IDV gridded data catalog but is included for model data under the "File_Access" dataset in the main motherlode
catalog: http://motherlode.ucar.edu:8080/thredds/catalog.xml When saving gridded data the user is prompted for the fields to save and the geo-
spatial subset is used to subset the grids. As of right now, there is not yet support for sub-setting on times and grid stride/decimation.

IDV Bundles
McIDAS-V has the ability to load and save IDV bundles (.xidv and .zidv), but all of the features between the two software packages may not be
compatible, and therefore the bundles may not load properly in the other software package.
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McIDAS-V Scripting
McIDAS-V can be scripted to create and manipulate images and movies. The scripting is accomplished using Jython or through an XML file:
IDV Scripting Language (ISL). The ISL file can be opened from a running McIDAS-V or one can be passed to McIDAS-V as a command line
argument:

runMcV capture.isl

A Jython script can be invoked as a command line argument:

runMcV -islfile capture.py

You can also run McIDAS-V in interactive mode using an ISL script to set up the state of McIDAS-V (e.g., loading data, displays, etc.) with the -
islinteractive argument:

runMcV capture.isl -islinteractive

McIDAS-V can run in "offscreen" mode (see more) with an ISL or with Jython. The user interface won't be shown. However, McIDAS-V still
needs to be run with an active window system (e.g., X, MS Windows) for it to run. If running under a Linux/Unix machine and you don't have an
X server running you need to run McIDAS-V under the X virtual frame buffer: xvfb.

If running under a Windows machine, it is necessary to use "\\" instead of "\" in scripts when specifying directory paths to avoid Windows
interpreting it as an escape sequence.

The usual mode of use of the ISL is to load in an McIDAS-V bundle which defines the data and displays that you want captured. In Jython, this is
a call to the loadBundle() method. As a convenience, when you go to save a bundle (e.g., using the File->Save As menu), you can specify a .isl
file suffix. When you do this McIDAS-V will write out both the bundle file and an example ISL file. It will first prompt you for some basic ISL
information:

You can, for example, include the text of the bundle file directly within the ISL file (so you only have one file to deal with). You can also specify
how many iterations of the loop to do and whether to create an image and/or a movie. When using Jython, you would simply use the feature of
the Jython language to accomplish list.

In the rest of this section we will cover:

ISL Overview
Basic ISL Tags
File ISL Tags
ISL Data and Displays
ISL Images and Movies
Writing Text Files
Scripting with Jython
Tag Index
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ISL Overview
A note: in this documentation required attributes are shown in bold.

ISL and XML
Before we start a couple of comments about writing the ISL. ISL files are written in XML and they need to be syntactically correct. A couple of
reminders:

XML is fully nested. There is only one root tag and all other tags are descendants of the root.
All tags have to be closed. Either do:

<sometag/>

or

<sometag> <i>contained tags</i> </sometag>

If you want to include special characters like '<', '>' and '"' you need to escape them with: '&lt;', '&gt;', '&quot;'.
You can comment out sections of XML with '<!--' ... '-->'. e.g:

... <!-- <sometag/> -->

The ISL file starts with a isl tag:

<isl debug="true"> ... ISL tags ... </isl>

If there is a debug="true" in the isl tag then McIDAS-V will print out processing messages.

Here is a simple isl file:

<isl> <image file="test.png"/> </isl> capture1.isl

You can run this by going:

runMcV capture1.isl

or through the File->Open menu from a running McIDAS-V.

Notice when you run this from the command line that no image is created. That is because there are no view windows. We can load in a bundle
before we capture the image. Note, if you run this isl file you should have a test.xidv bundle file around.

<isl> <bundle file="test.xidv"/> <pause/> <image file="test.png"/> </isl> 
capture2.isl

A caveat: Right now McIDAS-V does not gracefully handle when you have a bundle that has more than one view window.

The pause tag has McIDAS-V wait until all displays have been created. The bundle tag loads in the specified bundle. Note, this file is relative to
the directory where McIDAS-V is running. You can provide an absolute path or even a URL as a file:

<bundle file="/some/path/test.xidv"/> <bundle
file="http://www.somesite.edu/test.xidv"/>

The file for the output image is also relative to where McIDAS-V is running. The type of image that is created is determined by the file suffix.
McIDAS-V can generate gif, jpg and png. You can have multiple image tags:

<isl> <bundle file="test.xidv"/> <pause/> <image file="test.png"/> <image
file="test.gif"/> <image file="test.jpg"/> </isl> multi.isl

The isl tag can have a loop and a sleep argument. The sleep argument is the number of seconds to sleep after each iteration of the loop.

<isl loop="100" sleep="600"> <bundle file="test.xidv"/> <pause/> <image
file="test.png"/> </isl> loop.isl

This will loop through the set of commands 100 times. After each iteration of the loop McIDAS-V will sleep for 10 minutes (600 seconds).

Note: the above loop example will keep writing out to the same image file. We can use the macro expansion facility, described here: property, to
change the file name every loop iteration:

<isl loop="100" sleep="600"> <bundle file="test.xidv"/> <pause/> <image
file="test${loopindex}.png"/> </isl> loop2.isl

This will write out the images test0.png, test1.png, test2.png, etc.

One can use group tags to hold a set of children tags. There can be any level of nesting. The group tag can also hold a loop and sleep attribute

<isl loop="100" sleep="600"> <group loop="2" sleep="60"> <image file="test.png"/>
</group> </isl> nested.isl
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Basic ISL Tags
<isl> Top level ISL tag
<isl 
    debug="'true' or 'false'" 
    offscreen="'true' or 'false'" 
    loop="integer loop count" 
    sleep="seconds to sleep" >

The isl tag is the top level tag. It acts just like the group tag but it can also hold a debug attribute which results in status messages being printed
out. The offscreen attribute allows you to turn off offscreen rendering (the default is to do offscreen rendering).

<group> Group a set of tags. Possibly loop.
<group 
    loop="integer loop count" 
    sleep="seconds to sleep after each loop iteration" >

The group tag holds an arbitrary number of children tags.

<property> Define a property
<property 
    name="property name" 
    value="property value" 
    fromfile="filename to read contents from" 
    global="true/false" >

You can define properties with the property tag. Any subsequent tag may have these property values substituted by using:

${propertyname}

e.g.:

<property name="basedir" value="/some/directory"/> <property name="fromfile"
fromfile="${islpath}/template.txt"/> <property name="imagetype" value="png"/> <image
file="${basedir}/theimage.${imagetype}"/>

The state within an ISL is stack based - i.e., if you are in a group tag or calling a procedure (see below) the properties defined there are local to
that group or procedure call. When you leave that group or procedure call, any properties that are defined are removed. However, you can specify
global="true" in the property tag; this will cause the property to be defined globally.

There is a set of predefined properties that can be used. As described above, if you are in a loop the property ${loopindex} will be set to the loop
index. e.g.:

<isl loop="1000" sleep="3600"> <bundle file="test${loopindex}.xidv"/> </isl>

The set of date and time values for the current time is also available. The property names are those defined for the Java SimpleDateFormat class.

If you preface any of these properties with "anim:" then the current animation time (if defined) is used. e.g.:

${anim:yyyy}

The time properties are:

${yyyy} Year
${yy} Last 2 yar digits
${M} month number
${MM} two character month number
${MMM} Short month name
${MMMMM} Full month name
${D} Day in year
${d} Day in month
${dd} two character day in month
${EEE} Day name
${H} 0 based hour in day (24 hour)
${HH} 0 based two character hour in day (24 hour)
${k} 1 based hour in day (24 hour)
${kk} 1 based two character hour in day (24 hour)
${K} Hour in am/pm (12 hour)
${KK} two character hour in am/pm
${a} am/pm
${mm} two character minute in hour
${s} second in minute
${ss} two character second in minute
${S} Millisecond
${Z} Timezone
${G} Era designator

You can also define a property with "now:<some date format>" in it. This takes the current time and formats it with the full date format. e.g.,:

${now:yyyy-MM-DD} ${now:yyyy_MM_DD:hh:mm}
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You can also use "time:" to use the current animation time as the time to format:

${time:yyyy-MM-DD} ${time:yyyy_MM_DD:hh:mm}

<append> Append to a property
<append 
name="property name" 
value="property value" 
fromfile="filename to read contents from" >

This is just like the property tag but it appends the value.

<idvproperty> Define one of the McIDAS-V properties
<idvproperty 
    name="property name" 
    value="property value" 
    fromfile="filename to read contents from" 
    global="true/false" >

This allows you to set properties in McIDAS-V that may affect image capture behavior, etc. For example, doing:

<idvproperty name="idv.capture.sleep" value="1000"/>

sets the pause between each movie frame capture to be 1000 milliseconds.

<echo> Print a message
<echo 
message="text to print out" >

The echo tag allows you to print out a message. Here, for example, we are printing out the loop index and the date/time:

<isl loop="10" sleep="1"> <echo message="Loop iteration: ${loopindex} at: ${yyyy}-
${MM}-${dd} ${HH}:${mm}:${ss}"/> <echo> The message can also be contained by the echo
tag </echo> </isl> echo.isl

<import> Import another isl file
<import 
file="isl file" >

The import tag allows you to import another ISL file. For example, using the import tag here:

<isl> <import file="systemdefs.isl"/> </isl> import.isl

Where systemdefs.isl has:

<isl> <property name="prop1" value="somevalue"/> <property name="prop2"
value="somevalue"/> </isl> systemdefs.isl

Will result in something like:

<isl> ... <group> <property name="prop1" value="somevalue"/> <property name="prop2"
value="somevalue"/> </group> ... </isl>

You could use the import, for example, as a way of having common property definitions (e.g., location of data, images, etc.) shared by a set of
ISL files.

<procedure> Define an isl procedure
<procedure 
name="procedure name" >

The procedure tag allows you to define a "procedure" that can be called with the call tag.

<call> Call an isl procedure
<call 
name="procedure name to call" >

The call tag allows you to call a procedure. The attributes within the call tag are set as properties and can be referenced within the procedure tags.
For example, here we have a procedure called "makeImage" It is called two times, passing in values for bundlefile and imagefile. As noted, you
can also drop the call tag and use the procedure name as the tag name.

<isl> <procedure name="makeImage"> <bundle file="${bundlefile}"/> <pause/> <image
file="${imagefile}"> <thumbnail width="25%"/> </image> </procedure> <call
name="makeImage" bundlefile="test1.xidv" imagefile="test1.png"/> <call name="makeImage"
bundlefile="test2.xidv" imagefile="test2.png"/> <!-- Note: you can also call the
procedure directly with: --> <makeImage bundlefile="test2.xidv" imagefile="test2.png"/>
</isl> procedure.isl

<jython> Evaluate some Jython
<jython 
code="inline jython code to evaluate" 
file="jython file to evaluate" >
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The jython tag allows you to evaluate jython. The Jython is specified both in line as well as file based:

<isl> <jython file="somejython.py"/> <!-- Or: --> <jython code="some jython code"/> <!-
- Or: --> <jython> <![CDATA[ some jython code ]]> </jython> </isl> jython.isl

This Jython is evaluated by an interpreter that has all of the normal McIDAS-V Jython libraries. The global variable "idv" points to the
IntegratedDataView. The global variable "ig" points to the instance of the ImageGenerator class that is running the ISL.

All attribute values can also be prefixed with "jython:". This allows you to write a snippet of jython code that will return an attribute value:

<isl loop="10"> <echo message="jython:'number = ' + str(${loopindex}*50)"/> </isl> 
jythoninattr.isl

<stop> Stop all processing
The stop tag allows you to stop processing the ISL file and exit:

<stop/>

<pause> Pause for some time
<pause 
seconds="number of seconds to pause" 
minutes="number of minutes to pause" 
hours="number of hours to pause" 
every="number of hours past midnight" >

The pause tag can have a number of attributes:
<pause/> No arguments will pause until all displays have been created.
<pause seconds="10"/> Pause for 10 seconds.
<pause minutes="5.5"/> Pause for 5.5 minutes.
<pause hours="12.5"/> Pause for 12.5 hours.
<pause every="1"/> Pause until the next hour. The 'every' attribute means every N hours after midnight.
<pause every=".5"/> Pause until the next hour or half hour.
<pause every="0.25"/> Pause until the next 15 minute time. e.g., on the hour, quarter after, half past, etc.

<foreach> For each loop
<foreach 
value1="comma separated values" 
...="..." 
valuen="comma separated values" >

The foreach tag allows you to iterate across a set of comma separated values.

<foreach fruit="apple,orange,banana" color="red,green,blue" ... valueN="..."> ... Any
ISL tags. The property references ${fruit}, ${color}, etc., will be replaced the values
above. e.g., First time in the loop ${fruit} will be replaced with 'apple', ${color}
with 'red', etc. ... </foreach>

For example, here we are generating three different image types:

<isl> <foreach suffix="png,jpg,gif"> <echo message="Creating test.${suffix}"/> <image
file="test.${suffix}"/> </foreach> </isl> foreach.isl

<exec> Execute a shell command
<exec 
command="some shell command to exec" >

The exec tag allows you to execute external programs. For example, if you were generating images on one machine and then need to scp them to
your web server you could do:

<isl> <property name="imagefile" value="test.png"/> <group loop="1000" sleep="3600">
<bundle file="test.xidv"/> <pause/> <image file="test.png"/> <exec command="scp
${imagefile} yourwebserver:/imagedir/${imagefile}"/> </group </isl> exec.isl

<if> An if statement
<if 
expr="jython expression to evaluate" >

The if tag allows you to have decision structures in your ISL. The form is:

<if expr="some jython expression"> <then> ... The then block ... </then> <else> ... The
optional else block ... </else> </if>

For example, say you only wanted to generate a particular image when the hour of the day is after 12 noon. You could do:
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<isl loop="1000" sleep="3600"> <!-- Note the less than sign is escaped --> <if
expr="${k}>12"> <then> <echo message="Generating image at ${k}:${mm}"/> <image
file="test.png"/> </then> </if> <!-- Or you can include the expression in a CDATA
block: so you don't have to escape anything --> <if> <![CDATA[${k}>12]]> <then> <echo
message="Generating image at ${k}:${mm}"/> <image file="test.png"/> </then> </if>
</isl> if.isl
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File ISL Tags
The ISL supports a variety of file manipulation functions.

<fileset> Specify a set of files for use with other tags
<fileset 
    dir="directory to look at" 
    pattern="regular expression pattern to match files" 
    file="the single file to select" >

The fileset tag does not execute anything. Rather, it is used by other tags to specify a group of files.

<fileset dir="the directory to look at" pattern="file pattern to match"/> Or: <fileset
file="somefile"/>

<mkdir> Make a directory
<mkdir 
    file="The directory to create" >

The mkdir tag creates a directory specified by the file attribute:

<mkdir file="somedirectory"/>

There is no error if the directory already exists.

<rename> Rename a file
<rename 
    from="The file to rename" 
    to="The new file name" >

The rename tag allows you to rename a file:

<rename from "somefile" to="newfile"/>

<delete> Delete a file
The delete tag deletes a set of files:

<delete> <fileset dir="/some/directory" pattern="*.png"/> <fileset name="somefile"/>
</delete>

<move> Move a file
The move tag moves a set of files to a destination directory.

<move dir="destination directory"> <fileset dir="/some/directory" pattern="*.png"/>
<fileset name="somefile"/> </move>

<copy> Copy a file
The copy tag copies a set of files to a destination directory.

<copy dir="destination directory"> <fileset dir="/some/directory" pattern="*.png"/>
<fileset name="somefile"/> </copy>
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ISL Data and Displays
<bundle> Load a bundle

<bundle 
    file="bundle file or url" 
    width="view window width" 
    height="view window height" 
    times="List of times to use" 
    clear="default is true. remove all existing displays and data" 
    wait="default is true. wait until all displays have been rendered." >

The bundle tag lets you load in a new bundle and takes the form:

<bundle file="some_bundle_file.xidv"/>

By default it will remove all currently loaded data and displays. If you don't want to clear out the data and displays then add a clear="false"
attribute:

<bundle file="some_bundle_file.xidv" clear="false"/>

The wait attribute, if true (the default), will essentially do a pause, waiting until all displays have been rendered.

The times attribute allows you to override the set of time indices that are used in the data sources in the bundle. Note: this overrides the times for
all data sources in the bundle.

The value is a comma separated list of time specifiers where the specifier can be a single time, a time range or a time range with a step. The time
indices are 0 based, e.g., the first time index is 0. The time range is of the form "firsttime:lasttime". To specify a step do: "firsttime:lasttime:step"

For example, we have:

times="0" -- Just use the first time times="2" -- Just use the third time times="0,1,2" -- Just
use the first 3 times times="0:10" -- 0 through 10 times="0:10:2" -- 0,2,4,6,8,10
times="0:10:2, 20:30" -- 0,2,4,6,8,10 20-30 times="1,2,3,5:11:2,20,30" -- 1,2 3, 5,7,9,11, 20,
30

<setfiles> Override the files or urls used in a bundle
<setfiles 
datasource="identifier of the data source" 
file="new file or url path" >

The bundle tag can contain any number of "setfiles" tags. Each of these setfiles tags has a datasource attribute which is used to find the data
source in the bundle by name. There is also a file attribute which defines a file to use for that data source.

e.g.:

<isl debug="true" offscreen="false"> <bundle file="test.xidv"> <setfiles
datasource=".*" file="/upc/share/testdata/grid/netcdf/nuwg/ruc.nc"/> </bundle> <image
file="test.png"/> </isl>

The bundle above only has one data source. The:

datasource=".*"

identifies the data source by name. In this case it is a regular expression that matches anything. If you had multiple data sources you can change
their name before you save the bundle (right click on the data source in the field selector and got to the Properties dialog.) You can then use these
names to match. e.g.:

<isl debug="true" offscreen="false"> <bundle file="test.xidv"> <setfiles
datasource="datasource1" file="file for first data source"/> <setfiles
datasource="datasource2" file="file for 2nd data source"/> </bundle> <image
file="test.png"/> </isl>

If you have a data source with multiple files (e.g., radar) you can use an embedded fileset tag:

<setfiles datasource="datasource1"> <fileset file="some file"/> <fileset file="some
other file"/> ... </setfiles>

<datasource> Create a data source
<datasource 
url="url or file name to load" 
type="data source type" >

The datasource tag lets you create a new data source. The url attribute is required and specifies the file or url to load. The type attribute is
optional and defines the data source type from the datasources.xml file in the source release. For a text listing see Datasources.html. For now you
can only specify a data source that takes a single url (or filename). This will change in the future.

<isl> <datasource url="dods://motherlode.ucar.edu/cgi-bin/dods/DODS-3.2.1/nph-
dods/dods/casestudies/idvtest/grids/small_ruc_grid.nc"> <!-- Set the name on the data
source --> <property name="name" value="the name"/> </datasource> </isl> 
datasource.isl

<display> Create a display
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<display 
type="display type" 
param="parameter name" >

The display tag lets you create a display and can exist either on its own:

<display type="somedisplaytype" param="some_parameter"/>

or as a child tag of the datasource tag:

<isl> <!-- Create a datasource. Note: you can also have a template attribute that
points to a bundle xidv file that was saved from a data source:
bundle="${islpath}/datasource.xidv" --> <datasource
url="dods://motherlode.ucar.edu:8080/thredds/dodsC/casestudies/idvtest/grids/small_ruc_grid.nc"
id="datasource1"> <!-- Set the name on the data source --> <property name="name"
value="Example data source"/> <!-- Create a display of RH. Here we load in the display
from a template. --> <!-- <display param="RH" template="${islpath}/template.xidv">
<property name="id" value="display1"/> <property name="displayCategory" value="Category
1"/> <property name="legendLabelTemplate" value="%datasourcename% - %shortname%"/>
</display> --> <!-- Create a display of T. Here we create the display from the type -->
<display type="planviewcontour" param="T"> <property name="displayCategory"
value="Category 1"/> <!-- The contour info can be set with: interval;base;min;max
<property name="contourInfoParams" value="10;40;-30;100"/> Or it can have names in it:
--> <property name="contourInfoParams" value="interval=10;base=40;min=-
30;max=100;dashed=true;labels=false"/> <property name="legendLabelTemplate"
value="%datasourcename% - %shortname%"/> <!-- This sets the level to be 500
hectopascals --> <!-- Note: this can also be of the form #<index>, eg. #4 will select
the 5th level (this is zero based) --> <property name="dataSelectionLevel"
value="500[hectopascals]"/> </display> </datasource> <!-- Set the projection to the
data projection of the display we created above --> <!-- <center display="display1"
useprojection="true"/> --> </isl> display.isl

The type attribute is one of the display control types defined in the controls.xml file from the source release and is required. For a text listing see
controls.txt.

The param attribute is not required. If specified, it is the name of a parameter in either the containing datasource tag or in one of the currently
loaded data sources. The display tag will evolve in time to provide a richer set of facilities for setting values on the display.

<removedisplays> Remove all displays
<removedisplays 
display="display id to remove" >

This removes all current displays. If the display attribute is set, then it removes that display. (See below).

<removedisplays/>

<removeall> Remove all data and displays
Remove all current data and displays.

<removeall/>

<reload> Reload all loaded data
The reload tag tells all of the loaded data sources to reload, resulting in updated displays.

<reload/>

<center> Center a display at a lat/lon, or from a display control
<center 
lat="latitude" 
lon="longitude" 
north="latitude" 
south="latitude" 
east="longitude" 
west="longitude" 
display="display id to center at" 
useprojection="Use the projection from the display" >

The center tag comes in a number of forms, depending on the attributes:

<isl> <bundle file="test.xidv"/> <pause/> <echo message="Set the projection to be the
projection of the first display"/> <center/> <pause seconds="10"/> <echo
message="Center at a point"/> <center lat="15" lon="-65"/> <pause seconds="10"/> <echo
message="Set the projection to be the lat/lon box"/> <center north="40.0" south="30"
east="-90" west="-100"/> <pause seconds="10"/> <echo message="Set the projection from
the specified display"/> <center display="display1" useprojection="true"/> <pause
seconds="10"/> <echo message="Center at the center of the given displays projection"/>
<center display="display1" useprojection="false"/> <pause seconds="10"/> </isl> 
center.isl

Using the display attribute specifies a display control to use. This can take two forms. First, you can specify a simple text pattern that we try to
match to the display's id. The id can be set from the display controls property dialog.
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display="some name"

The second method is to specify a class name or partial class name:

display="class:ucar.unidata.idv.TrackControl" or: display="TrackControl"

<viewpoint> Change the viewpoint or aspect ratio of a view
<viewpoint 
    rotx="Rotation X" 
    roty="Rotation Y" 
    rotz="Rotation Z" 
    transx="Translation X" 
    transy="Translation Y" 
    transz="Translation Z" 
    scale="Scale" 
    aspectx="Aspect ratio x" 
    aspecty="Aspect ratio y" 
    aspectz="Aspect ratio z" 
    tilt="Tilt degrees" 
    azimuth="Asimuth degrees" >

The viewpoint tag comes in a number of forms, depending on the attributes:

<?xml version="1.0" encoding="ISO-8859-1"?> <isl debug="true" loop="1"
offscreen="false" sleep="60.0minutes"> <bundle clear="true" file="${islpath}/test.xidv"
wait="true"/> <pause seconds="5"/> <!-- Specify a rotation, translation and scale.
These values are shown in the Aspect Ratio tab of the View Manager properties dialog --
> <viewpoint rotx="75" roty="62" rotz="-3.3" scale="0.399" transx="0.0" transy="0.0"
transz="0.0"/> <pause seconds="5"/> <!-- You can also set the aspect ratio -->
<viewpoint aspectx="2" aspecty="5" aspectz="10"/> <pause seconds="5"/> <!-- You can
also specify a tilt and azimuth. This is the same as you can do interactively in the
viewpoint dialog --> <viewpoint tilt="45" azimuth="180"/> <pause seconds="5"/> </isl> 
viewpoint.isl

The rot/trans/scale values can be viewed in the Aspect Ratio tab of the View Manager properties dialog.
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ISL Images and Movies
The image and movie tag are the ones used to create images and movies. Both of these tags can contain subtags that allow you to manipulate the
image or images.

<image> Generate and manipulate images
<image 
    file="image file, e.g., gif, png or jpg" 
    quality="image quality, 0.0-1.0" 
    view="view name or names to match" 
    display="display id" 
    what="what part of the display control should be captured" >

The image tag allows you to capture an image from a main display or from the GUI of a display control.

The file attribute defines the image file. For image formats that support it you can also specify a quality attribute that can range from close to
0.0(worst) to 1.0 (best and default).

The view attribute allows you to specify a name of a view it use. This can also be a regular expression pattern to use to match on multiple views.
If there are multiple views in existence and there is no view attribute specified or if there multiple views resulting from a view name attribute you
should use the viewindex and viewname in your filenames, etc., The viewindex property is the number of the view, e.g., the first view we capture
has viewindex of 0, the second viewindex = 1, etc.

The display attribute allows you to specify a display control to use to capture. For its use see here. The what attribute allows you to specify what
part of the display control gui should be captured. For now McIDAS-V only supports what="chart" to capture the time series chart of the station
model and data probe displays.

<movie> Create a Quicktime movie, animated GIF or Google Earth KMZ file
<movie 
    file="movie file" 
    view="view name or names to match" 
    imagedir="The directory to place the images." 
    imagetemplate="The file name template to use" 
    imagesuffix="Should be jpg if generating a QuickTime movie but can be gif or png as well">

The movie tag allows you to capture a time animation as a Quicktime movie or as an animated gif.

The view attribute is the same as in the image tag.

If the file ends with .mov then a Quicktime movie is created. If the file ends with .gif then an animated gif is created. If the file ends with .kmz
then a Google Earth KMZ file is created each being time stamped. Note: The file attribute can be a comma separated list of files, e.g.:

<movie file="test.mov,test.kmz,test.gif"/>

This allows you to capture multiple types of movie products in one call.

If no file attribute is specified then this just generates the images, not the movie. For example, you can not specify the file name but do specify the
imagedir and this will generate the images and place them in the imagedir for later processing.

The imagetemplate is a template filename that can contain text and three different macros, e.g.:

imagetemplate="image_%time%" Include the animation time formatted in the default format
imagetemplate="image_%count%" Include which image imagetemplate="image_%count%_%time:any date
format%" Include animation time in any date format. e.g.:
imagetemplate="image_%count%_%time:yyyyMMddHHmm%"

The generic date format can contain a specification that is used by the Java SimpleDateFormat and is described in Basic Tags.

KML Attributes
The movie tag also supports a set of KML specific attributes that allow you to configure the generated KML file.

<movie file="test.kmz" kml_desc="<a href="${wwwroot}/${bundle}">Run in the IDV</a>
(Needs Java Webstart)" kml_name="${label}" kml_visibility="0" kml_open="0">

kml_desc is the description for the KML Folder that holds the images. It can contain html.
kml_name is the folder name.
kml_visibility specifies whether the images are shown initially or not.
kml_open specifies whether the Folder is open or not.

Using your own images

You can also use any number of contained fileset tags to define a custom list of images that are used instead of the default images derived from
an animation capture.

<movie file="test.mov"> <fileset file="image1.png"/> <fileset file="image2.png"/>
<fileset file="image3.png"/> </movie>

Images Manipulation
There are a set of tags that can be contained by both the image and movie tags that support processing of the image. Most of these tags work on
the initial image and act as a filter pipeline. For example, the ISL:

<image file="test.png"> <clip north="40" south="30" east="-80" west="-90"/> <matte
bottom="150"/> </image>

Will generate an image from the main display. It will then clip the image at the given lat/lon bounding box and then add a matte with spacing of
150 pixels at the bottom of the image. It will then write out the image to the file test.png.
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You can modify this behavior in a variety of ways. For example, the ISL:

<image file="test.png"> <clip north="40" south="30" east="-80" west="-90" copy="true"
file="clippedimage.gif"/> <matte bottom="150"/> </image>

will clip the original image but not alter it (the copy="true") and then will write out the clipped image to the given file. The original image will be
passed to the matte tag which will matte it.

The image manipulation tags can be nested. e.g. the ISL:

<image file="test.png"> <clip north="40" south="30" east="-80" west="-90" copy="true"
file="clippedimage.gif"> <matte bottom="150"/> <write file="somefile.jpg"/>
<transparent color="black"/> </clip> <matte bottom="150"/> </image>

Will clip a copy of the image, matte the copy, write out the matted image as somefile.jpg, set the color black to be transparent and then write it
out as clippedimage.gif. The original image is then matted and written out as test.png.

<panel> Create a gridded layout of a set of images. This is just like the movie tag and support all of the above attributes
<panel 
    file="output image file" 
    movieattributes="All of the movie tag attributes" 
    columns="Number of columns" 
    width="Resize the images to width" 
    space="Spacing between each grid cell" >

The panel tag acts just like the movie tag except that it merges all of the images into one image in a panelized or gridded fashion. It is column
oriented so you specify the number of columns:

<panel file="test.gif" width="400" columns="2" space="10"/>

<html> Create an image from rendered html
<html 
    file="output image file" 
    fromfile="Optional name of file to read in html" 
    width="Fixed width of image" >

The html tag allows you to specify html that is rendered into an image. It acts just like the image tag in that in can contain image manipulation
commands. The html is either from a file (specified by the fromfile attribute) or contained in a CDATA block:

<html file="foo.png"> <![CDATA[ hello there <hr> This is my test ]]> <matte bottom="50"
background="red"/> </html>

Images Manipulation
There are a set of tags that can be contained by both the image and movie tags that support processing of the image. Most of these tags work on
the initial image and act as a filter pipeline. For example, the ISL:

<image file="test.png"> <clip north="40" south="30" east="-80" west="-90"/> <matte
bottom="150"/> </image>

Will generate an image from the main display. It will then clip the image at the given lat/lon bounding box and then add a matte with spacing of
150 pixels at the bottom of the image. It will then write out the image to the file test.png.

You can modify this behavior in a variety of ways. For example, the ISL:

<image file="test.png"> <clip north="40" south="30" east="-80" west="-90" copy="true"
file="clippedimage.gif"/> <matte bottom="150"/> </image>

will clip the original image but not alter it (the copy="true") and then will write out the clipped image to the given file. The original image will be
passed to the matte tag which will matte it.

The image manipulation tags can be nested. e.g. the ISL:

<image file="test.png"> <clip north="40" south="30" east="-80" west="-90" copy="true"
file="clippedimage.gif"> <matte bottom="150"/> <write file="somefile.jpg"/>
<transparent color="black"/> </clip> <matte bottom="150"/> </image>

Will clip a copy of the image, matte the copy, write out the matted image as somefile.jpg, set the color black to be transparent and then write it
out as clippedimage.gif. The original image is then matted and written out as test.png.

<clip> Clip an image
<clip 
north="latitude" 
south="latitude" 
east="longitude" 
west="longitude" 
top="pixels or %" 
bottom="pixels or %" 
left="pixels or %" 
right="pixels or %" 
display="The id of a display which we use its data's map projection to clip with" >

The clip tag allows you to clip the image. The clipping can either be defined in lat/lon coordinates, with x/y image coordinates or from the
projection used from a display. The image coordinates can be specified as percentages.
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Clip in image space:

<clip top="10" bottom="0" left="10%" right="0"/>

Clip in lat/lon space:

<clip north="40" south="30" east="-80" west="-90"/>

If there is a display attribute defined then we get the lat/lon bounds of its data to clip with. Use the display control Properties dialog to set the id
that you reference in the ISL.

Clip using a display id:

<clip display="displayid"/>

<matte> Matte an image
<matte 
background="color name or r,g,b"
top="pixel spacing" 
bottom="pixel spacing" 
left="pixel spacing" 
right="pixel spacing" 
space="pixel spacing" 
hspace="pixel spacing" 
vspace="pixel spacing" >

The matte tag allows you to add a space around any of the sides of an image. e.g:

<matte top="100" bottom="20"/>

You can also simply specify a space, hspace (horizontal space), or vspace (vertical space) attributes:

<matte space="10"/> <matte hspace="20"/> <matte vspace="20"/>

You can also specify a background color. The color can be a named color or a comma separated list of red/green/blue values:

<matte top="100" background="black"/> or: <matte top="100" background="red,green,blue
values"/>

<overlay> Annotate an image with text or a logo
<overlay 
image="file or url to image" 
text="text to draw" 
place="rectangle point on base image" 
anchor="rectangle point on overlay" 
fontsize="font size for text" 
fontface="font face for text" 
color="color for text" >

The overlay tag allows you to add an icon or text as an image overlay. You can either specify and image or text. The place and anchor tags
specify the location of the overlay. They take the form: "rectpoint,offsetx,offsety" Where rectpoint is a point on a rectangle:

UL UM UR ML MM MR LL LM LR Where U=upper,M=middle,L=lower R=right,L=left

The offsetx and offsety are optional. The idea is you define a point on the base image, e.g., the upper left corner ("ul"). Then you define an anchor
point on the overlay that will be placed at the place point. So for example, if you wanted the upper left corner of the image overlay to be drawn 10
pixels right and 20 pixels below the upper left corner of the base image then you would do:

place="UL,10,20" anchor="UL"

If you wanted some text overlay to be placed so that its bottom center was in the middle of the image, 30 pixels from the bottom of the image you
do:

place="LM,0,-30" anchor="LM"

If you wanted some overlay to be placed so that its upper right was placed at the center of the image you do:

place="M" anchor="UR"

<displaylist> Render the display list
<displaylist 
    valign="'bottom' or 'top'" 
    mattebg="<color> If defined then we matte the image with the given color the size that the display list takes up" 
    fontsize="optional font size" 
    fontface="optional font face">

The displaylist tag renders the display list (normally shown at the bottom of the view) directly into the image. The text rendering is a bit higher
quality because we are using direct Java drawing code and not the 3D rendering. Also, you can matte an image and then render the list of displays
in the matted area.

You will want to turn off the visibility of the display list for the view (under View->Show->Display List menu) when you save the bundle.

<show> Show the current image in a dialog
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<show 
    message="optional message to show">

You can use the show tag inside an image or movie tag to show the current image in a dialog. This allows you to see what is going on and debug
your isl image generation.

<resize> Resize an image
<resize 
width="pixels or percent"" 
height="pixels or percent" >

The resize tag allows you to resize an image. You specify either a width or a height:

<resize width="200"/> <resize height="150"/>

The width or height can also be a percentage:

<resize width="50%"/> <resize height="10%"/>

<thumbnail> Generate a thumbnail of an image
<thumbnail 
file="image file name" 
width="pixels or percent" 
height="pixels or percent" >

The thumbnail tag is just like the resize tag except that it will also write out the image. e.g:

<thumbnail width="50%" file="thumbnail.png"/>

<write> Write out an image
<write 
file="file to write to" >

The write tag allows you to write out an intermediate image file at any time.

<write file="somefile.png"/>

<colorbar> Add a color bar to an image
<colorbar 
width="bar width" 
height="bar height" 
orientation="tick mark location, 'right', 'left', 'bottom', 'top'" 
tickmarks="number of tick marks" 
interval="interval value" 
values="comma separated list of values" 
place="rectangle location" 
anchor rectangle location="showlines" 
'true' or 'false', draw tick lines="linecolor" 
line color=""" >

The colorbar tag allows you to add a color bar from the color tables in the layer controls. Currently, it does not do a perfect job when there are
more than one color tables present.

The orientation attribute specifies where the tick marks are drawn, e.g., to the left, right, top or bottom of the color bar. This also implicitly
specifies the horizontal (top, bottom) or vertical (right, left) orientation of the color bar. Note, placing a vertical color bar is a bit tricky.

You can specify how ticks are drawn. You can give a number of tickmarks, a value interval or a specific list of values.

The location of the color bar is defined using the anchor and place points as described for the overlay tag.
Here is an example that loads a bundle, creates an image, mattes the image and then shows the color bar of a display with id "planview". "

<?xml version="1.0" encoding="ISO-8859-1"?> <isl debug="true" loop="1" offscreen="true"
sleep="60.0minutes"> <bundle clear="true" file="${islpath}/colorbar.xidv" wait="true"/>
<image file="${islpath}/colorbar.png"> <matte space="100" background="gray"/> <colorbar
display="planview" orientation="top" tickmarks="3" width="400" showlines="true"
anchor="LM" place="UM,0,100" showunit="true"/> <colorbar display="planview"
orientation="bottom" tickmarks="3" width="400" showlines="true" anchor="UM"
place="LM,0,-100" showunit="true"/> <colorbar display="planview" orientation="top"
tickmarks="3" width="400" showlines="true" anchor="LM" place="LM" showunit="true"/>
<colorbar display="planview" orientation="left" tickmarks="3" width=""20" height="400"
showlines="true" anchor="MR" place="ML,100,0" showunit="true"/> <colorbar
display="planview" orientation="left" tickmarks="3" width="20" height="400"
showlines="true" anchor="MR" place="MR" showunit="true"/> </image> </isl> 
colorbar.isl

That makes:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__resize
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__resize
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__resize
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__resize
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__thumbnail
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__write
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__overlay
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_BasicTags__isl
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_DataAndDisplays__bundle
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__colorbar
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__image
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__colorbar
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__matte
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__colorbar
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__colorbar
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__colorbar
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__colorbar
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__colorbar
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ImagesAndMovies__image
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_BasicTags__isl
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_colorbar.isl_FILE


<kmlcolorbar> Write a colorbar into the kmz file
<kmlcolorbar 
    width="width of color bar image" 
    height="height of color bar image" 
    file="file to write color bar image to" 
    space="extra padding around image" 
    suffix="label suffix - can include "%unit%&quot" 
    kml.name="Name used in kml for this image" 
    kml.overlayXY.x="see below" 
    kml.overlayXY.y="see below" 
    kml.overlayXY.xunits="see below" 
    kml.overlayXY.yunits="see below" 
    kml.screenXY.x="see below" 
    kml.screenXY.y="see below" 
    kml.screenXY.xunits="see below" 
    kml.screenXY.yunits="see below">

The kmlcolorbar tag acts just like the colorbar tag but is intended to generate a separate color bar image (written to the file specified by the file
attribute) and include it into a KMZ file.

All of the kml. attributes are simply passed into the generated KML file and are used to place the image into Google Earth. These attributes are
the attributes and tags in the KML. For example, the attribute kml.overlayXY.x ends up being the x attribute of the overlayXY tag in the KML. See
here http://code.google.com/apis/kml/documentation/kmlreference.html#screenoverlay for more info on the KML.

Here is an example:

<?xml version="1.0" encoding="ISO-8859-1"?> <isl debug="true" loop="1" offscreen="true"
sleep="60.0minutes"> <bundle clear="true" file="${islpath}/testtwoview.xidv"
wait="true"/> <image file="${islpath}/test.kmz"> <kmlcolorbar width="400" height="20"
showlines="true" tickmarks="4" fontsize="12" background="white" color="black"
file="${islpath}/testcolorbar.png" space="20" suffix=" %unit%" kml.name="Color bar"
kml.overlayXY.x="0" kml.overlayXY.y="1" kml.overlayXY.xunits="fraction"
kml.overlayXY.yunits="fraction" kml.screenXY.x="10" kml.screenXY.y="1"
kml.screenXY.xunits="pixels" kml.screenXY.yunits="fraction"/> </image> </isl> 
kmlcolorbar.isl

<transparent> Set transparency on an image
<transparent 
color="color to set to transparent" >

The transparent tag allows you to set a particular color in an image to be transparent.

<transparent color="black"/> or: <transparent color="red,green,blue"/>
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<backgroundtransparent> Set transparency on an image. Use the background color of the view.

The backgroundtransparent tag allows you to use the background color of the view as the transparent color in the image..

<backgroundtransparent/>

<split> Split an image into sub-images
<split 
file="base file name" 
columns="number of columns" 
rows="number of rows" >

The split tag splits up an image by a given number of rows and columns. The file attribute should contain properties for each image: ${row},
${column} and ${count}.



Writing Text Files
<output> Write output to file
<output 
    file="the file to write to" 
    template="inline text of 'file:filename' of the template file" 
    fromfile="filename to read contents from" 
    text="text to output" >

The output tag allows you to generate text files. For example, this could be used to generate html pages, xml files, etc.

The output tag is used in two modes. First it is used to define the output file name, and possibly some templates. Then, the output tag is used to
write text output into that file.

You can write text a number of ways:

<isl> <output file="output.txt"> <output text="Some text to write"/> <!-- Read in the
contents of the file. Apply properties to the name and the contents --> <output
fromfile="${islpath}/file.txt"/> <output>Some more text</output> <output><![CDATA[ Some
text in a CDATA Section. This allows you to have " and < without escaping the in the
xml >]]></output> </output> </isl> output.isl

To be even more complicated the output tag can specify templates to write into. For example, in output1.isl below, we are writing an output1.txt
file. Its template has some text and a ${text} macro. The text macro corresponds to the text that gets written into the template:text template. The
two following output tags use the template:text template, writing in the values of the thetext attribute.

<isl> <output file="output1.txt" template="Here is the text: ${text}"
template:text="${thetext} "> <output template="text" thetext="The text I am writing"/>
<output template="text" thetext="More text I am writing"/> </output> </isl> 
output1.isl

The result of running this is:

Here is the text: The text I am writing More text I am writing

Here we have two different entry templates, place1 and place2.

<isl> <output file="output2.txt" template="Place 1 text: ${place1} Place 2 text:
${place2}" template:place1="${value1} -- ${value2} " template:place2="
${someothervalue} " > <output template="place1" value1="the value 1" value2="the value
2"/> <output template="place2" someothervalue="some value"/> <output template="place2"
someothervalue="some other value"/> </output> </isl> output2.isl

The result of running this is:

Place 1 text: the value 1 -- the value 2 Place 2 text: some value some other value

Here we are generating an html file showing the thumbnail images that are generated with links to the actual image and a caption for each
thumbnail:

<isl> <bundle file="test.xidv"/> <pause/> <output file="images.html"
template="file:template.html" template:header="${text}"
template:imagehtml="file:imagetemplate.html"> <output template="header" text="Here are
the images"/> <image file="test1.png"> <thumbnail file="test1thumb.png" width="25%"/>
</image> <output template="imagehtml" thumb="test1thumb.png" image="test1.png"
caption="Test1"/> <image file="test2.png"> <thumbnail file="test2thumb.png"
width="25%"/> </image> <output template="imagehtml" thumb="test2thumb.png"
image="test2.png" caption="Test2"/> <image file="test3.png"> <thumbnail
file="test3thumb.png" width="25%"/> </image> <output template="imagehtml"
thumb="test3thumb.png" image="test3.png" caption="Test3"/> </output> </isl> 
output3.isl

In this example the templates are defined as files: template.html:

<html> <body> ${header} ${imagehtml} </body>

and imagetemplate.html.

<a href="#TARGET_${image}_FILE"><img border="0" src="${thumb}"></a> ${caption} <p>
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Scripting with Jython
Jython and ISL
McIDAS-V also supports writing scripts in Jython. This means that you can create a Jython script that includes calls to special methods (defined
below), and also does "normal" Jython things.

Please Note: Some of the APIs described below will likely change in the coming months!

To start with, here is an example Python script. This example script loads a bundle in the background containing a loop of images. It then saves
an image and a movie. The image saved is the first image of the loop. At this point, each individual image within a loop can not be saved through
this method.

Scripting in Jython allows for flexibility and a more "programming" flavor for McIDAS-V scripting, though you can still do much of the
functionality using Jython that you can do using ISL. The benefit of the ISL is that it is more declarative and requires (hopefully) less knowledge
of programming.

To run McIDAS-V with a Jython script, do:

runMcV -islfile your-script.py

Below, each of the available methods in the Jython scripting interface will be described.

setOffScreen(value)

If you want to do your rendering in the "background", then the value should be set to 1 (true). If you want the window(s) to pop-up, set the
value to 0 (false).

setDebug(value)

To enable some debug during your development, set the value to 1 (true).
loadBundle(filename, data_files)

Loads a bundle with the given filename. You may also provide a dictionary of datasource:file items similar to the ISL setfiles.
pause()

Pause until all displays have been created. This is useful between loadBundle() and writeImage() for example.
writeImage(filename, parameters, quality)

Write out an image file. The filename should have the file extension of the type of image file you want to write (.jpg, .gif, .png).

The parameters variable is a string that contains any parameter information (see the ISL description of parameters) It is in the form:

"clip north=40; matte background=green top=20; resize height=300 width=300"

The quality value is 1.0 for the best, down to 0.0 for, well, no quality at all...
writeMovie(filename, parameters) Write out the display as a movie. The filename should have the file extension of the type of image file
you want to write (.mov)

The parameters variable is a string that contains any parameter information (see the ISL description of parameters) It is in the form:

"clip north=40; matte background=green top=20; resize height=300 width=300"

An alternative way to get an Image, manipulate it and then save it:
getImage()
resizeImage(image, width, height)
matteImage(image, color, top, bottom, left, right)
df = findDisplayControl(id) then "dc.getImage()"
writeImageToFile(image, filename)
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Tag Index
<append> 
<bundle> 
<call> 
<center> 
<clip> 
<colorbar> 
<copy> 
<datasource> 
<delete> 
<display> 
<echo> 
<exec> 
<fileset> 
<foreach> 
<group> 
<if> 
<image> 
<import> 
<isl> 
<jython> 
<matte> 
<mkdir> 
<move> 
<movie> 
<output> 
<overlay> 
<pause> 
<procedure> 
<property> 
<reload> 
<removeall> 
<removedisplays> 
<rename> 
<resize> 
<setfiles> 
<split> 
<stop> 
<thumbnail> 
<transparent> 
<write>

Append to a property
Load a bundle
Call an isl procedure
Center a display at a lat/lon, or from a display control
Clip an image
Add a color bar to an image
Copy a file
Create a data source
Delete a file
Create a display
Print a message
Execute a shell command
Specify a set of files for use with other tags
For each loop
Group a set of tags. Possibly loop.
An if statement
Generate and manipulate images
Import another isl file
Top level ISL tag
Evaluate some Jython
Matte an image
Make a directory
Move a file
Create a Quicktime movie, animated GIF or Google Earth KMZ file
Write output to file
Annotate an image with text or a logo
Pause for some time
Define an isl procedure
Define a property
Reload all loaded data
Remove all data and displays
Remove all displays
Rename a file
Resize an image
Override the files or urls used in a bundle
Split an image into sub-images
Stop all processing
Generate a thumbnail of an image
Set transparency on an image
Write out an image
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Display Properties
Name ID Value Example
Display Category displayCategory String <property name="displayCategory" value=""/>
Legend Label legendLabelTemplate String <property name="legendLabelTemplate" value=""/>
Extra Legend Labels extraLabelTemplate String <property name="extraLabelTemplate" value=""/>
Layer Label displayListTemplate String <property name="displayListTemplate" value=""/>
Display Unit settingsDisplayUnit unit, e.g.,celsius <property name="settingsDisplayUnit" value=""/>
Color Table colorTableName Temperature <property name="colorTableName" value=""/>
Color Range range min:max <property name="range" value=""/>
Contour Settings contourInfo semi-colon delimited string:

"interval=<interval>;
min=<min>;
max=<max>;
base=<base>;
dashed=true/false;
labels=true/false;"

<property name="contourInfo" value=""/>

Color Scale Settings colorScaleInfo semi-colon delimited string:
"visible=true|false;
color=somecolor;
orientation=horizontal|vertical;
placement=top|left|bottom|right
"

<property name="colorScaleInfo" value=""/>

Visibility displayVisibility true|false <property name="displayVisibility" value=""/>
Lock Visibility Toggle lockVisibilityToggle true|false <property name="lockVisibilityToggle" value=""/>
Show In Layer List showInDisplayList true|false <property name="showInDisplayList" value=""/>
Use Fast Rendering useFastRendering true|false <property name="useFastRendering" value=""/>
Use Times In Animation useTimesInAnimation true|false <property name="useTimesInAnimation" value=""/>
Include in cursor readout doCursorReadout true|false <property name="doCursorReadout" value=""/>
Remove on Remove All canDoRemoveAll true|false <property name="canDoRemoveAll" value=""/>
Show Note Text showNoteText true|false <property name="showNoteText" value=""/>
Level settingsLevel Real value, e.g., 1000.0[hPa] <property name="settingsLevel" value=""/>
Texture Quality textureQuality integer <property name="textureQuality" value=""/>
Colors Shaded smoothed true|false <property name="smoothed" value=""/>
Isosurface Value levelWithRawValue double <property name="levelWithRawValue" value=""/>



Sharing
Sharing is a mechanism to share control operations between two or more displays. For example, you can have one animation control control
animation in two windows at once.

For sharing animation in two windows, such as in the main McIDAS-V view window and a vertical cross section control, open the animation
properties dialog in each animation control by clicking on the i icon. Toggle on the Shared box and click on Ok. Then using either animation
control will effect animation in both windows.

You can share other kinds of layer controls, such as sharing one selector line in vertical cross sections. This is toggled on by clicking on the Share
check box under the View menu in the control window.
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Data Analysis
Formulas
Jython Methods
Derived Data
Jython Shell
Jython Library
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Formulas
McIDAS-V provides techniques to make computations with data sources, and display the results. The simplest technique is using McIDAS-V
"formulas" which are named one-line mathematical expressions. The steps for computing and displaying an McIDAS-V formula are

Defining an McIDAS-V formula by name, description, and mathematical formula.
Saving the formula.
Selecting what kind of display to use.
Selecting exactly which particular data you want to use in the formula-based computation.

You can make formulas more powerful by writing methods (subroutines) in the Jython computer language, which is described in Jython Methods.

When you define an McIDAS-V formula, it is saved and will appear in future runs of your McIDAS-V.

To create a formula select the Tools->Formulas->Create Formula menu item. This brings up the Formula Editor dialog box used to define a
formula:

The minimal information you need to provide is the name of the formula and the actual formula.

If the formula name matches a name in the main Tools Menu Parameter defaults, then color tables and other settings may be automatically
assigned, which may or may not be desirable for you. For example, if you choose a formula named T its displays would get the color tables
associated with temperature.

In the formula itself you can use common mathematical operators much as +, -, * for multiply, / for divide, and ** for power. Other Jython
operations such as sqrt(a), max(b), pow(a,b), and sin(c) are available. In the Jython Methods section of the User Guide you will see how to write
complete complete multi-line functions or methods in Jython that you can call in one-line formulas.

The variable names in the formula definition, such as "NIR" in the figure above, are operands and do not need to exactly match any particular
parameter name in any data source; the association is made later, in the parameter selection step.

Do not use spaces in formula variable names, such as "wind speed." The formula is an expression in the Jython language. Start each variable name
with a letter.

It is best to use variable names that suggest the parameter data they represent, so that later you can easily remember what the variables should
represent. Use names like Temp500m, RelHum_surf, absvort, sst_jan, density, or whatever makes sense to you. If you use a variable names like
V1 and V2, then later when the formula requests which real parameter name goes with which variable name you may be puzzled which is which.

Variable names can have extra "syntactic sugar" attached to them that McIDAS-V uses for a variety of purposes. The "sugar" consists of a set of
name/value pairs contained in brackets ("[...]") after the variable name.

For example, normally variables are used to select and define data choices. You can also have variables that are simple text input from a user. For
example, evaluating the following expression:

someProcedure(someValue[isuser=true])

will result in a dialog box being shown to allow for the user to enter a text value (e.g., a number) for the variable someValue.

You can provide default values with:

someProcedure(someValue[isuser=true,default=some default])

You can specify the types of data that can be selected for a variable with the categories name. e.g.:

someProcedure(someDataValue[categories=param:ALTITUDE])

If you want multiple data categories separate them with a ";":

someProcedure(someDataValue[categories=param:ALTITUDE;param:elevation])

If you only want to select 3D grids do:
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someProcedure(someDataValue[categories=GRID-3D-*])

If you only want to select 3D or 2D grids do:

someProcedure(someDataValue[categories=GRID-3D-*;GRID-2D-*"])

You can also specify a regular expression pattern that is used to pre-select the first data choice whose description matches the pattern.

someProcedure(someValue[pattern=some_pattern])

In the advanced section you can enter a description of the formula, its group or category and you can define what types of displays are applicable
for the given formula (the default is to be able to use all displays).

The group is used to display the formula in the Field Selector window and can be any alphanumeric text including spaces, numbers, and
punctuation characters. Hyphens ("-") define sub-categories.

To save the formula, click on Add formula. A new entry appears in the selector panel. By right clicking on the formula entry in the Field Selector
window you can edit the formula. To remove a formula, click on Remove Formula in the pull down menu.

Different data sources and automatic navigation
McIDAS-V hides much of the computational complexity. You can write a simple formula such as (CT*1.8 + 32.0) - dewptF and McIDAS-V will
automatically apply the calculation to every element in large 3D grids referred to as CT and dewptF. No loops over grid points are needed; and
you don't even need to know anything about how the grid is defined, mapped on the Earth, or the data format. You can even use different sources
for the individual parameters, for example, CT can come from an Eta model output grid and dewptF from your own local weather model. The two
grids need hot have the same grid point locations nor the same areal coverage. The results are computed in the area of overlap, on the grid points
locations of the first grid. Interpolation is automatically applied where needed.

Creating a Display with a Formula
Using a formula as the data when creating a display is just like using any other data. You select the formula entry in the Field Selector window,
the list of applicable displays will be shown and you create the display.

When you create a display McIDAS-V needs to know what actual data should be bound to the operands within your formula. A Field Selector
window will appear that allows you to select the actual data for each operand. You can select parameters from more than one data source for use
in a single formula, for example, you can pick the same parameter from data sources of different times to compute a time difference in the
parameter.

Open the data source to see the names of parameters available. Click on the parameter needed for each variable. Then click on OK. The result of
the formula is computed, for every data point in the source, and the result shown in the view window.



Description of Formulas - Image Filters
The follow describes each formula included in the Image Filter Formulas section of McIDAS-V.

Cloud Image Filter (replace, constant)

This formula applies a cloud filter to an image by comparing each element to the elements of another image. Use this filter to mask off a portion
of the first source image.

Input parameters:

replace replacement value (default=minimum value in either sdataset)

constant additive constant (default=0)

Core Image Filter (brkpoint1, brkpoint2, replace1, replace2)

This formula applies a core filter to two images by comparing elements to breakpoints. The resulting image has only two values.

Input parameters:

brkpoint1 breakpoint value (default=minimum value in either sdataset)

brkpoint2 breakpoint value (default=maximum value in either sdataset)

replace1 success condition replacement value (default=maximum value in either sdataset)

replace2 failure condition replacement value (default=minimum value in either sdataset)

Equation for each ddataset element:

 if (sdataset1 > brkpoint1) and (sdataset2 > brkpoint2) 
then ddataset = replace1
else ddataset = replace2

Discriminate Image Filter (brkpoint1, brkpoint2, brkpoint3, brkpoint4, replace)

This formula applies a discriminate filter to two images by comparing elements in each image to different high and low breakpoints. Use this
filter to mask off a portion of the first source image.

Input parameters:

brkpoint1 low end breakpoint value for sdataset1 (default=minimum value in either sdataset)

brkpoint2 high end breakpoint value for sdataset1 (default=maximum value in either sdataset)

brkpoint3 low end breakpoint value for sdataset2 (default=minimum value in either sdataset)

brkpoint4 high end breakpoint value for sdataset2 (default=maximum value in either sdataset)

replace failure condition replacement value (default=minimum value in either sdataset)

Equation for each ddataset element:

 if (brkpoint1 < sdataset1 < brkpoint2) and (brkpoint3 < sdataset2 < brkpoint2) 
then ddataset = sdataset1 
else ddataset = replace

Gradient Image Filter

This formula applies a gradient filter to the source image.

Equation for each ddataset element:

 ddataset = ABSOLUTE(sdatasetn - (sdatasetn+1) )

High Pass 2D Image Filter

This formula applies a two-dimensional high-pass filter to each element in the source image. It eliminates low-frequency deviations by clustering
them around the distribution's midpoint. A sample average is calculated by the program using values in a two-dimensional region around the
source element.

Equation for each ddataset element:

 ddataset = (sdataset - (sample average ) + (sample midpoint) )

High Pass Image Filter (radius, leak)

This formula applies a one-dimensional high-pass filter to each element in the source image. It eliminates low-frequency deviations by clustering
them around the distribution's midpoint. A sample average is determined using values on either side of the source element and the percentage of
filter efficiency.

Input parameters:

radius sample length surrounding the source element; used for sample average (default=50)

efficiency filter efficiency (default=100)

Equation for each ddataset element:

 ddataset = (sdataset - (sample average) + (sample midpoint) )



Hole Image Filter (brkpoint1, brkpoint2)

This formula searches for missing data and fills the holes in the image using the average of the surrounding element values.

Input parameters:

brkpoint1 low end breakpoint value (default=minimum sdataset value)

brkpoint2 high end breakpoint value (default=maximum sdataset value)

Equation for each ddataset element:

 if (brkpoint1 < sdataset < brkpoint2)
then ddataset = (average of the surrounding sdataset element values) 
else ddataset = sdataset

Low Pass 2D Image Filter (linecoef, elecoef)

This formula applies a two-dimensional low-pass filter to each element in the source image. It eliminates high-frequency deviations by replacing
the source image data values with the average of the values in the sample defined with the line and element coefficients.

Input parameters:

linecoef line coefficient; 0.0 < linecoef < 1.0 (default=0.5)

elecoef element coefficient; 0.0 < elecoef < 1.0 (default=linecoef)

Equation for each ddataset element:

 ddataset = (sample average)

Low Pass Image Filter (radius, leak)

This formula applies a one-dimensional low-pass filter to each element of the source image. It eliminates high-frequency deviations by replacing
the source image data values with the average of the values on either side of the source element. The sample average is determined using the
percentage of filter efficiency.

Input parameters:

radius sample length in pixels surrounding the source element; used for sample average (default=50)

leak filter efficiency (default=100)

Equation for each ddataset element:

 ddataset = (sample average)

Replace Image Filter (replaceVal, bline, eline, belem, eelem)

This formula replaces selected elements in the defined region of the source image with the specified replacement value.

Input parameters:

replaceVal replacement value (default=0)

bline beginning line in the source image region (default=first line)

eline ending line in the source image region (default=last line)

belem beginning element in the source image region (default=first element)

eelem ending element in the source image region (default=last element)

Equation for each ddataset element:

 if sdataset lies outside the region defined by the line and element ranges
then ddataset = sdataset
else ddataset = replaceVal

Shot Image Filter (bline, eline, pdiff)

This formula cleans an image by applying a shot noise filter to each element in the source image. Each element is compared to the elements on
either side and replaced if the values are significantly different.

Input parameters:

bline beginning line in the source image to clean (default=first line)

eline ending line in the source image to clean (default=last line)

pdiff maximum percentage of the product range to allow before a new value for the pixel is derived using
the
average of two adjacent pixels (default=15)

Equation for each ddataset element:

 if the difference between sdataset and the surrounding elements is < pdiff 
then ddataset = sdataset
else ddataset = (average of the surrounding sdataset element values)



Description of Formulas - Export
The follow describes each formula included in the Export Formulas section of McIDAS-V.

Export Grid to Excel (Excel File)

This formula exports a field to an Excel (.xls) file and creates a display of the field.

Export Grid/Image to netCDF (netCDF File)

This formula exports a grid or image field to a netCDF (.nc) file and creates a display of the field.



Description of Formulas - Imagery
The follow describes each formula included in the Imagery Formulas section of McIDAS-V.

Geolocate an Image (Upper Left Lat, Upper Left Lon, Lower Right Lat, Lower Right Lon

This formula takes an image data object and a lat/lon bounding box and adds a lat/lon domain to the data. This formula is commonly used in
conjunction with another formula.

Input parameters:

Upper Left Lat Upper left latitude value . (default = 90)

Upper Left Lon Upper left longitude value . (default = -180)

Lower Right Lat Lower right latitude value. (default = -90)

Lower Right Lon Lower right longitude value. (default = 180)

Image over topography

This formula obtains the latitude coordinate from the grid and returns a grid of the latitudes at each point.

Three Color (RGB) Image

This formula combines three images as a RGB image.

Three Color (RGB) Image (Auto-scale)

This formula combines three images as a RGB image displayed over topography.



Jython Methods
McIDAS-V allows you to write your own Jython methods using the Jython Library editor. From the main menu bar, select the Tools->Formulas-
>Jython Library menu item.

The Jython Library window has a tree view on the left that shows the different (categorized) library files available. The files that are listed under
"Local Jython" are those that you can edit. The System files cannot be edited. On the right is the edit panel for the selected file.

There is documentation available for the System Jython Libraries.

FAQ
What is Jython?

How do I learn to write Jython?

How does Jython work with my data in McIDAS-V?

Creating/Removing library files

Calling procedures from formulas

Create a formula from my procedure

FAQ

Q. What is Jython?

A. Jython is a Java implementation of the Python language. It is used within McIDAS-V for data analysis. Complex routines can be written in
the McIDAS-V Jython editor and called from the McIDAS-V Formulas.

Q. How do I learn to write Jython?

A. There are a number of books available on the language as well as a number of web sites:

http://www.python.org
http://www.jython.org

Q. How does Jython work with my data in McIDAS-V?

A. McIDAS-V uses the VisAD package as as an underlying data model. There is a VisAD/Jython Tutorial available.

Q. Creating/Removing library files

A. To create a new file use the File->New Jython Library... menu. To remove the currently displayed library file use the File->Remove

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_JythonLib__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Jython__faq1_cat1_
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Jython__faq1_cat1_0
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Jython__learn
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Jython__faq1_cat1_2
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Jython__faq1_cat1_4
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Jython__faq1_cat1_5
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Jython__faq1_cat1_6
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Formulas__FILE
http://www.amazon.com/s/ref=nb_ss_gw/002-3107995-7532045?url=search-alias%3Daps&field-keywords=jython&x=0&y=0
http://www.python.org/
http://www.jython.org/
http://www.ssec.wisc.edu/~billh/visad.html
http://www.ssec.wisc.edu/~tomw/visadtutor/


Library menu.

Q. Calling procedures from formulas

A. When creating a formula with the Formula Editor you can call any routines you have defined in the Jython Library. Simply enter the
procedure name in the formula with appropriate arguments, if any. For example a formula might be "convertCToF(atemp)". When evaluating
the formula for display, this will call the routine that you define in the Jython Library.

Q. Create a formula from my procedure

A. Right click on a procedure definition within the McIDAS-V editor window and choose Make formula for .... This is a convenience that
brings up the Formula creation dialog with a call to that procedure.

As another convenience you can also right-click on the Formula: field of the Formula Editor to show the Insert Procedure Call menu. This
lists all of the currently defined procedures in the other Jython libraries.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Formulas__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Formulas__FILE


Derived Data
McIDAS-V uses the formula mechanism to automatically create "derived" quantities based on the fields in a particular data source. When the data
source is read in, the list of derived quantities is evaluated against the list of variables in the data. Users can define their own derived quantities
by:

Defining an McIDAS-V formula by name, description, and mathematical formula.
Using special operators (D1, D2, ... DN) for the variable names.
Specifying the binding between the special operators and the parameters names or system aliases.
Saving the formula and loading or reloading a data source.

See the Formulas section for an overview of creating McIDAS-V formulas.

Create a formula select the Tools->Formulas->Create Formula menu item. This brings up the Formula Editor dialog box used to define a
formula:

The minimal information you need to provide is the name of the formula and the actual formula.

You can use the Derived tab in the Formula Editor to set the bindings between formula parameters and fields/aliases. You need to check the
Create derived quantities checkbox to enable this as a system formula.

The parameters to be bound are denoted by operands D1, D2, D3, etc in the formula itself. If you need user input, you can use other field names
and the users will be prompted to supply those fields.

You can define the bindings for the operands using parameter groups or by specifying the parameters to use. Right clicking in the Parameter
input field will pop up a menu that allows you to select system parameter aliases or parameters from fields loaded into McIDAS-V already.

Categories specify the types of data that are allowed in this formula. For example, if your derived formula is valid only for 3D Grids, you can
select that category from the popup list. Access the list by right clicking in the Categories input fields.

You can define specific output categories if the type of the data that the formula creates is different from the categories that the input operands
require. In general, the output categories will be the same as the input categories. For more information on data categories, see the Formulas
section.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Formulas__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Formulas__FILE


To save the formula, click on Add formula. A new entry appears in the Fields panel of the Field Selector. If you want to apply the formula to an
existing data source, you need to reload that data source. Right click on the name of the data source in the Data Sources section of the Field
Selector and select Reload Data.



Jython Shell
The Jython Shell is an interactive command line interface to the McIDAS-V Jython interpreter that allows the user to type in arbitrary jython to
evaluate. It is brought up with the Tools->Formulas->Jython Shell menu.

The User Interface

The Jython shell consists of an output window on the top and an input field on the bottom. The user enters Jython into the input field. When
"return" or "Evaluate" is pressed the Jython is evaluated and any ouput is shown in the output window.

The icons shown with every Jython entry in the output window allow you to select the particular Jython or re-evaluate it.

The entry window can be expanded with the down arrow icons on the right.

Pressing the "Up" arrow and "Down" arrow (also control-P, control-N) in the entry field goes up and down through the history of commands.

Right clicking in the entry field brings up a menu that allows you to:

Add an entry from the history.
Insert the identifier for a display control type when creating a display.
Insert the text of a procedure call from any of the McIDAS-V Jython Library modules. Note: the shell utilities module has a number of
useful Jython shell related commands. Click here for more information.
Insert any of the defined McIDAS-V actions (e.g., Edit color table, Show window, etc.)

Menus

File
Export Commands Allows you to take the commands that have been entered and add them into the Jython Library to be used to
create a fixed procedure.
Save History Writes out the history of commands the have been entered. When you restart McIDAS-V those commands will be in
your history.
List History Shows the history of commands in the output window.
List Variables Shows all global Jython variables defined.

Edit
Clear All Clears the history and anything in the output window.
Clear Output Clears the output window.
Auto-select Operands When selected, this causes the Jython shell to analyze every command entered to see if there are references to
variables that have not been set. It will bring up the Data Selection dialog to allow you to choose the fields to use.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_JythonLib__FILE


Jython Library

Module: grid
This is the doc for the grid module

applyToRange(function, data):
Apply the function name to each timestep of the data

applyToRangeValues(function, data):
Apply the function name to each value in each timestep of the data

averageOverTime(field, makeTimes):
Average the values in each time step If makeTimes is true (1) then we return a field mapping all of the times to the average. Else we just return
the average

combineFields():
combine several fields together

extractLatitudeFromNWPGrid(fieldimpl):
Get the latitude coordinate from a grid. Return a grid of the latitudes at each point.

extractPressureFromNWPGrid(fieldimpl):
Get the pressure coordinate from a time series grid and return a grid of the pressure at all points. Input grid must have pressure or height
(which is converted to pressure in the standard atmosphere). User must be sure input is a suitable FlatField.

getAltitude(z):
Change units from geopotential meters to meters

getNthTimeGrid(fieldimpl, Nth):
Get the Nth grid in time series of grids; User must be sure input is a suitable data field. returns a single time. Nth is an integer, >=0, <= max
index of grid time series.

getSliceAtAltitude(fieldimpl, alt, unit):
Extract a 2D horizontal slice from a 3D grid at the given altitude; level is a real number; if unit is supplied, it must be compatible with meters
(ft, fathoms, etc) param fieldimpl is a grid which may have one or more time steps.

getSliceAtLevel(fieldimpl, level):
Extract a 2D horizontal slice from a 3D grid at "Level." level is a real number; must be appropriate for the grid. param fieldimpl is a grid
which may have one or more time steps.

horizontalAdvection(param, u, v):
horizontal advection

horizontalDivergence(param, u, v):
horizontal flux divergence

layerAverage(grid, top, bottom):
Wrapper for calculating layer average

layerDiff(grid, top, bottom):
Wrapper for calculating layer difference

make2D(slice):
Make a 2D slice from a 3D slice at a single level

makeFlowField(a, b, c):
Make a vector from 3 components
makeVector(a,b) = [a,b,c]

makeTimeSequence(g):
Merge a set of single time grids/images into a time sequence

makeTrueVector(u, v):
true wind vectors

makeVector(a, b):
Make a vector from 2 components
makeVector(a,b) = [a,b]

newName(field, varname, copy):
create a new field with a new parameter name

newUnit(field, varname, unitname):
set the name and unit on a grid

resampleGrid(oldGrid, gridwithNewDomain):
display gridded data on a new domain

windShear(u, v, z, top, bottom):
calculate the wind shear between discrete layers
shear = sqrt((u(top)-u(bottom))^2 + (v(top)-v(bottom))^2)/zdiff

windShearVector(u, v, top, bottom):
calculate the u and v layer difference and return as vector

writeGridToXls(grid, filename):
Write out the grid data to an excel spreadsheet

Module: griddiag



This is the doc for the Grid Diagnostics module. These functions are based on the grid diagnostics from the GEneral Meteorological PAcKage
(GEMPAK). Note that the names are case sensitive and some are named slightly different from GEMPAK functions to avoid conflicts with
Jython built-ins (e.g. str).

In the following operators, scalar operands are named Si and vector operands are named Vi. Lowercase u and v refer to the grid relative
components of a vector.

GRAVITY():
Gravity constant

add(S1, S2):
Addition

ADD (S1, S2) = S1 + S2
adv(S, V):

Horizontal Advection, negative by convention
ADV ( S, V ) = - ( u * DDX (S) + v * DDY (S) )
age(obs, geo):

Ageostrophic wind
AGE ( S ) = [ u (OBS) - u (GEO(S)), v (OBS) - v (GEO(S)) ]
atn2(S1, S2):

Wrapper for atan2 built-in
ATN2 (S1, S2) = ATAN ( S1 / S2 )
avg(S1, S2):

Average of 2 scalars
AVG (S1, S2) = ( S1 + S2 ) / 2
avor(V):

Absolute Vorticity
AVOR ( V ) = VOR ( V ) + CORL(V)
corl(S):

Coriolis Parameter for all points in a grid
CORL = TWO_OMEGA*sin(latr)
cros(V1, V2):

Vector cross product magnitude
CROS ( V1, V2 ) = u1 * v2 - u2 * v1
ddx(S):

Take the derivative with respect to the domain's X coordinate
ddy(S):

Take the derivative with respect to the domain's Y coordinate
defr(V):

Total deformation
DEF ( V ) = ( STRD (V) ** 2 + SHR (V) ** 2 ) ** .5
div(V):

Horizontal Divergence
DIV ( V ) = DDX ( u ) + DDY ( v )
dot(V1, V2):

Vector dot product
DOT ( V1, V2 ) = u1 * u2 + v1 * v2
dvdx(V):

Partial x derivative of a vector
DVDX ( V ) = [ DDX (u), DDX (v) ]
dvdy(V):

Partial x derivative of a vector
DVDY ( V ) = [ DDY (u), DDY (v) ]
frnt(S, V):

Frontogenesis function from theta and the wind
FRNT ( THTA, V ) = 1/2 * MAG ( GRAD (THTA) ) * ( DEF * COS (2 * BETA) - DIV ) Where: BETA = ASIN ( (-DDX (THTA) * COS (PSI)
- DDY (THTA) * SIN (PSI))/ MAG ( GRAD (THTA) ) ) PSI = 1/2 ATAN2 ( SHR / STR )
geo(z):

geostrophic wind from height
GEO ( S ) = [ - DDY (S) * const / CORL, DDX (S) * const / CORL ]
grad(S):

Gradient of a scalar
GRAD ( S ) = [ DDX ( S ), DDY ( S ) ]
inad(V1, V2):

Inertial advective wind
INAD ( V1, V2 ) = [ DOT ( V1, GRAD (u2) ), DOT ( V1, GRAD (v2) ) ]
jcbn(S1, S2):

Jacobian Determinant
JCBN ( S1, S2 ) = DDX (S1) * DDY (S2) - DDY (S1) * DDX (S2)
lap(S):



Laplacian operator
LAP ( S ) = DIV ( GRAD (S) )
latr(S):

Latitudue all points in a grid
lav(S, level1, level2):

Layer Average
LAV ( S ) = ( S (level1) + S (level2) ) / 2.
ldf(S, level1, level2):

Layer Average
LDF ( S ) = S (level1) - S (level2)
mag():

Magnitude of a vector
mixr(temp, rh):

Mixing Ratio from Temperature, RH (requires pressure domain)
mul(S1, S2):

Multiply
MUL (S1, S2) = S1 * S2
quo(S1, S2):

Divide
QUO (S1, S2) = S1 / S2
qvec(S, V):

Q-vector at a level ( K / m / s )
QVEC ( S, V ) = [ - ( DOT ( DVDX (V), GRAD (S) ) ), - ( DOT ( DVDY (V), GRAD (S) ) ) ] where S can be any thermal paramenter, usually
THTA.
sdiv(S, V):

Horizontal Flux Divergence
SDIV ( S, V ) = S * DIV ( V ) + DOT ( V, GRAD ( S ) )
shr(V):

Shear Deformation
SHR ( V ) = DDX ( v ) + DDY ( u )
strd(V):

Stretching Deformation
STRD ( V ) = DDX ( u ) - DDY ( v )
sub(S1, S2):

Subtract
SUB (S1, S2) = S1 - S2
thrm(S, level1, level2):

Thermal wind
THRM ( S ) = [ u (GEO(S)) (level1) - u (GEO(S)) (level2), v (GEO(S)) (level1) - v (GEO(S)) (level2) ]
thta(temp):

Potential Temperature from Temperature (requires pressure domain)
thte(temp, rh):

Equivalent Potential Temperature from Temperature and Relative humidity (requires pressure domain)
un(V):

North relative u component
ur(V):

Grid relative u component
vadd(V1, V2):

add the components of 2 vectors
VADD (V1, V2) = [ u1+u2, v1+v2 ]
vecr(S1, S2):

Make a vector from two components
VECR ( S1, S2 ) = [ S1, S2 ]
vlav(V, level1, level2):

calculate the vector layer average
VLDF(V) = [(u(level1) - u(level2))/2, (v(level1) - v(level2))/2]
vldf(V, level1, level2):

calculate the vector layer difference
VLDF(V) = [u(level1) - u(level2), v(level1) - v(level2)]
vmul(V1, V2):

Multiply the components of 2 vectors
VMUL (V1, V2) = [ u1*u2, v1*v2 ]
vn(V):

North relative v component
vor(V):

Relative Vorticity
VOR ( V ) = DDX ( v ) - DDY ( u )



vquo(V1, V2):
Divide the components of 2 vectors

VQUO (V1, V2) = [ u1/u2, v1/v2 ]
vr(V):

Grid relative v component
vsub(V1, V2):

subtract the components of 2 vectors
VSUB (V1, V2) = [ u1-u2, v1-v2 ]
wshr(V, Z, top, bottom):

Magnitude of the vertical wind shear in a layer
WSHR ( V ) = MAG [ VLDF (V) ] / LDF (Z)

Module: image

combineRGB(red, green, blue):
combine 3 images as an RGB image

makeNavigatedImage(d, ulLat, ulLon, lrLat, lrLon):
This takes a image data object and a lat/lon bounding box and adds a lat/lon domain to the data. Use it in conjunction with a formula:

Module: maps

averageFromMap(field, mapSets):
mapSets defines a set of polygons. This procedure fills the areas in the field are enclosed by each polygon with the average value within that
area

averageRangeFromMap(range, timeStep, mapSets):
mapSets defines a set of polygons. This procedure fills the areas in the field are enclosed by each polygon with the average value within that
area

filterMaps(mapSets, propName, operator, value):
Return a new set of maps whose property propName satisfies the given operator/value. The operators can be ==,!=, <,>,<=,>=, match, !match

getMapProperty(polygon, propName):
Get the named property from the given mapData

getMapsWithProperty(mapSets, propName, value):
Return a new set of maps that have the given property value

make3DMap(map, topo):
Make a 3d map. map - map line data - topo - topography dataset

makeFieldFromMapBounds(mapSets, length1, length2, fill, unit):
Make a field whos lat/lon area is the bounds of the given mapSet. It has length1 points in the x and length2 in the y. Fill it with the fill value
and the given unit

subsetFromMap(field, mapSets, fillValue, inverse):
mapSets defines a set of polygons. This procedure fills the areas in the field that are not enclosed by the polygons with the fill value. If inverse
is 1 then it fills the areas that are enclosed

subsetRangeFromMap(range, timeStep, mapSets, fillValue, inverse):
mapSets defines a set of polygons. This procedure fills the areas in the field that are not enclosed by the polygons with the fill value. If inverse
is 1 then it fills the areas that are enclosed

subsetRangeWithProperty(range, mapSets):
test code

subsetWithProperty(field, mapSets):
test code

Module: shell
A set of utilities for selecting data and creating displays. For use from the Jython shell.

clear():
Clear the shell

createDisplay(displayType, data, dataName):
create a display of type displayType. Right click in input field to select particular displayType. The data is can be a data object, a datachoice
or a list of data or datachoices The dataName is used to name the data, i.e., its the parameter name

findDataSource(name):
Find the data source object with the given name. If no name is given then this will return the first (non-formula) data source

getData(dataSourceName, dataChoiceName):
Find the data source with the given name and the data choice on that data source with the given name. If no dataSourceName is given then use
the first one in the list If no dataChoiceName is given then use the first one held by the data source Return the data for the data choice. If no
data source or data choice is found then return null

getDataChoice(dataSourceName, dataChoiceName):
Find the data source with the given name and the data choice on that data source with the given name. If no dataSourceName is given then use
the first one in the list If no dataChoiceName is given then use the first one held by the data source Return the data choice If no data source or
data choice is found then return null



listVars():
List all of the variables defined in the shell's interpreter

makeDataSource(path, type):
Create a datasource from the given file name or url. The optional type parameter is used to specify the type of data

printType(data):
Print out the math type of the given data

selectData(name1, name2, name3, name4, name5):
Select up to 5 data fields. This returns a List of the actual Data objects

selectDataChoice(name1, name2, name3, name4, name5):
Select up to 5 data choices. This returns a List of the data choices, not the actual Data To get the data do:

dataList.get(0).getData(None)
setDataChoices(dataSource):

The given dataSource can be an actual data source or the name of a data source. This procedure will define a set of jython variables that
correspond to the data choices held by the given data source.

setDataSources():
This procedure will define a set of jython variables, 'dataSource0, dataSource1, ...' that correspond to loaded data sources.

showLib():
Bring up the jython library dialog

Module: misc
A set of miscellaneous utilities.

idveval(formula):
evaluate a formula

makeFloatArray(rows, cols, value):
A utility to make a 2 dimensional float array filled with the given value



Site Configuration
You can customize McIDAS-V for yourself and your site in a variety of ways. McIDAS-V is configured through a set of resource files. These are
typically eXtensible Markup Language (XML) files that define things such as:

Color tables
The data chooser user interface
The derived quantities and formulas
Jython libraries
Display defaults for parameters
Parameter aliases
Help tips
Projections
Available data sources
Available displays
Where the favorite bundles are
Maps
Station models

Most of these files (with the exception of the chooser UI, help tips, data sources, displays and favorite bundle locations) are created through
facilities provided by McIDAS-V (e.g., color table editor, formula editor, etc.)

By default McIDAS-V looks in three places for the resources it uses to configure itself:

User path. This is the ~user/.metapps/<Application name> directory that gets created for each user. Note: the "Application name" is usually
"DefaultIdv"
Site path. This is the file directory or URL directory that can be defined as a command line argument, -sitepath, or through the user
preferences dialog.
System path. This is a directory, /ucar/unidata/idv/resources, in the system Java jar files.

When McIDAS-V first starts up it reads the system properties file: mcv.properties. This defines some basic information (e.g., title, splash icon,
ADDE servers, etc.) as well as defining where to find other properties files. By default it looks for idv.properties files under the site path and the
user path:

idv.properties = %SITEPATH%/idv.properties;%USERPATH%/idv.properties;

You can also specify one or more properties files as command line arguments:

-properties your_properties_file

McIDAS-V processes these properties files in order, with properties defined in later files overriding those defined previously.

Once the properties have been processed McIDAS-V initializes its resources by reading in one or more resource definition files. We call these
files "RBI" files - (Resource Bundle for the IDV). These are XML files, the locations of which are defined by the idv.resourcefiles property:

idv.resourcefiles=%USERPATH%/idv.rbi;%SITEPATH%/idv.rbi;%IDVPATH%/idv.rbi

When you first run McIDAS-V, the application, as a thoughtful convenience, writes out an example RBI file into your local .metapps/DefaultIdv
directory. This example file has documentation that describes how to add in new resources.

These RBI files define the location of different collections of resources. For example, from the system RBI file, idv.rbi, we have the entry that
defines where McIDAS-V can find the XML files that define the color tables:

<resources name="TARGET_SiteConfiguration__idv.resource.colortables"> <resource
location="%USERPATH%/colortables.xml"/> <resource location="%SITEPATH%/colortables.xml"/>
<resource location="%IDVPATH%/colortables.xml"/> </resources>

This says to look for colortables in the user path, sitepath and McIDAS-V system path. McIDAS-V uses the first entry in this list as the file path
to write out color tables that are created using the color table editor.

Note: as a further complexity, errr, convenience, if there is a property defined in the properties file which is the resource name then McIDAS-V
just uses the value of the property (it treats it as a semi-colon delimited list of paths) as the resources and ignores the resources in the RBI file.
So, for example, if you had a property:

idv.resource.colortables=%USERPATH%/colortables.xml;http://yourwebsite.edu/specialtables.xml

then McIDAS-V would only load in these colortables.

Using the RBI file, what are the set of steps you need to take to configure your site to use a set of special color tables that you have created. What
you would do is bring up McIDAS-V. Create the color tables. They would get saved off in your local .metapps/DefaultIdv directory in the file
colortables.xml (as defined by the resource paths defined in the default RBI). You could simply copy that file to an area on your web site or on a
shared file system that is pointed to by the McIDAS-V sitepath. Now, your users simply need to define the sitepath and they will naturally pick up
the color tables you have created.

Most site configuration can be accomplished through the default user/site/system resource locations. However, you can modify the RBI file to
include other resources. For example, you could add in an entry:

<resource location="http://yourwebsite.edu/specialcolortables.xml"/>

to make available some special color tables at a particular URL.

Resource
Here is the list of the resource identifiers, description and file pattern (for use with plugins) of the different resources McIDAS-V uses.

Resource Identifier Description File Pattern
idv.resource.colortables Color tables used in the application colortables.xml$



idv.resource.projections Map projections projections.xml$
idv.resource.transects Map transects transects.xml$
idv.resource.messages Message catalog messages.properties$
idv.resource.grib1lookuptables Grib 1 Lookup tables grib1lookuptable.lst$
idv.resource.grib2lookuptables Grib 2 Lookup tables grib2lookuptable.lst$
idv.resource.jython Jython libraries .py$
idv.resource.stationmodels Station models stationmodels.xml$
idv.resource.imagedefaults ADDE Image Defaults imagedefaults.xml$
idv.resource.backgroundwms Background WMS images backgroundwms.xml$
idv.resource.imagesets Image Sets imagesets.xml$
idv.resource.autodisplays Automatic display creation autodisplays.xml$
idv.resource.skin UI Skin skin.xml$
idv.resource.toolbar Tool bar toolbar.xml$
idv.resource.actions Actions actions.xml$
idv.resource.stationsymbols Station model symbols stationsymbols.xml$
idv.resource.colorpairs Color pairs no pattern
idv.resource.bundlexml Bundle xml no pattern
idv.resource.aliases Data aliases aliases.xml$
idv.resource.datasource Specification of the data sources datasource.xml$
idv.resource.derived Derived quantities derived.xml$
idv.resource.choosers The definition of the user interface for data choosers choosers.xml$
idv.resource.bundles Default bundles that are evaluated at start up no pattern
idv.resource.controls Display controls controls.xml$
idv.resource.helptips Help tips shown in the help tips dialog helptips.xml$
idv.resource.locations Fixed station locations locations.xml$
idv.resource.maps Maps for the displays maps.xml$
idv.resource.menubar Commands in the menu bar (defaultmenu.xml$|menubar.xml$)
idv.resource.paramdefaults Display defaults for data paramdefaults.xml$
idv.resource.paramgroups Parameter groups paramgroups.xml$
idv.resource.userchooser End user constructed data choosers no pattern
idv.resource.preferences User preferences no pattern
idv.resource.plugins Plugins no pattern
idv.resource.prototypes Prototypes no pattern



 
Image 1: Plugin Manager

Plugins
McIDAS-V plugins are a way to add to or modify the functionality of McIDAS-V. Plugins can range from adding new resources (e.g., color
tables, layout models, maps) to changing the entire application. Plugins are typically Java JAR archive files that can contain a set of McIDAS-V
resources and Java code. They are kept in a special directory on disk and are loaded at run time.

Plugin Command Line Arguments
You can load a plugin (one time only) with the:

-plugin <plugin file or URL>

command line argument.

You can install a plugin with the:

-installplugin <plugin file or URL>

command line argument.

You can start McIDAS-V without any plugins with the:

-noplugins

command line argument.

Plugin Manager
The Plugin Manager, accessed through the Tools->Plugins->Manage... menu, allows you to list, install and manage plugins.

A list of the installed and available plugins is shown. The available plugins are those the McIDAS-V development team makes available through.
One can install plugins that are not in this list through the File->Install Plugin from File and File->Install Plugin from URL menu items. When
you install a plugin you will need to restart McIDAS-V for the plugin to take effect.

For installed plugins the Manager allows you to delete and reinstall the plugin. Note: When you delete a plugin it is only deleted when you exit
McIDAS-V.

The small binocular icon allows you to list the files that the plugin contains. This brings up the Plugin List dialog:



 
Image 2: Plugin List

You can view the contents of a file and/or extract a file through this dialog.
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Plugin Creator
The Plugin Creator, accessed through the Tools->Plugins->Create... menu, allows you to create new plugins.

Note: This is a new facility within McIDAS-V and is a work in progress. Some things, like reading in a plugin, have yet to be implemented.

A plugin is a Java JAR file that contains a set of resource files. These resource files can include things like the color tables you have created,
projections, layout models, formulas, etc. The plugin manager supports both adding in a whole file (e.g., all of the color tables you have created)
as well as adding in individual resource objects (e.g., a specific color table you have created).

Adding Resources
To add in a file use the File->Add File menu. The file dialog will come up listing the contents of your local .metapps directory. This is where all
of the various resources that are created are stored. For example, if you wanted to include all of your color tables then add the colortables.xml
file.

You can also add individual resources through the File->Add Resource menus. You can also add resources through the various resource editors
(e.g., Jython Editor, Parameter Defaults,Parameter Aliases). Typically this facility is available through the editor's File menu.

Resources List
Each file or resource that is added into the Plugin Creator is listed under the Resource tab:

You can delete the selected resource in the list with the trash can button or the delete key.

Excludes
The excludes tab allows you to exclude system default resources. For example, in the below screen shot we are excluding color tables and
projections. When the plugin that is defined here is loaded into McIDAS-V the excludes will result in only the color tables and projections that are
defined in this plugin to be used.
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Properties
The Properties tab allows you to overwrite different properties McIDAS-V uses. This listing is broken up into three categories: User Interface,
Data and Miscellaneous.

Writing the Plugin
To write the plugin simply click on the Write Plugin button. If you have not specified a plugin file name (i.e., a .jar file) you will be prompted. If
you also want to install the plugin to your local McIDAS-V plugins area select the Install checkbox. Note: You will need to restart McIDAS-V
for any installed plugins to take effect.



Plugin Jar Files
Note: This page is intended for someone who wants to create an McIDAS-V plugin. A description of installing and managing plugins is here.

McIDAS-V supports a plugin architecture that allows for the easy extension and addition of functionality. A plugin is most commonly a Java Jar
file that contains a set of resource files (e.g., color tables) and/or Java class files. The plugins are stored on a local directory or could be loaded
form a web site. McIDAS-V processes the plugin Jar file at run time loading in the contained resources and code.

Basic Plugin
Lets suppose you have created a set of color tables and some Jython code that you want to make a plugin with. As described in the Site
Configuration docs McIDAS-V stores these user created files in <user home>/.metappps/DefaultIdv as colortables.xml and default.py.

To make these into a plugin, e.g., myplugin.jar, simply jar the the files (you need to get a Java SDK for this):

jar -cvf myplugin.jar colortables.xml default.py

Now this plugin can be distributed to others and loaded into their McIDAS-V environment.

So, you might ask how does McIDAS-V recognize these files in the plugin and treat them appropriately? McIDAS-V loads in a set of resources
(e.g., color tables, Python libraries). Each resource type is identified by a regular expression as shown in the resource list. In our example above
the file name colortables.xml matches the pattern for color table xml resources.

Now, what happens if you have some file whose name does not match a pattern? Say, you have a color table xml file called myspecialtables.xml
that you want to include in a bundle. In that case you can add a .rbi file, as described here, that defines this file as a resource:

<?xml version="1.0" encoding="ISO-8859-1"?> <resourcebundle> <resources
name="TARGET_PluginJarFiles__idv.resource.colortables"> <resource
location="/myspecialtables.xml"/> </resources> </resourcebundle>

This acts as a table of contents for the plugin. Make sure that the location is not relative. Note: Jar files can contain directory trees. e.g.,
/tables/myspecialtables.xml. In this case just have the location point to:

... <resource location="/tables/myspecialtables.xml"/> ...

Including Code
You can also include code that implements certain functionality by just including the Java .class files in the Jar. When you do this you need to
include them like a normal class containing Jar file, i.e., the package structure of your code (e.g., edu.ucar.app.Test) needs to be reflected in the
directory structure of the Plugin Jar file:

/edu/ucar/app/Test.class

For a single class file this is not necessarily required but if there are multiple class files that have interdependency among themselves then you
will get into trouble if you don't follow this structure.

Now, what this code does can be anything and is best left up to the developer's guide.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Plugins__FILE
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Configuring Image Defaults
The defaults for the advanced settings of the Image Chooser is set for particular images through a configuration file. You can override the system
defaults by creating your own configuration file and placing it in the user directory or sitepath See the section on Site Configuration for more
information on the location of these directories. The configuration file (imagedefaults.xml) has the following format:

<?xml version="1.0" encoding="ISO-8859-1"?> <imagedefaults> <default pattern="" key="" place=""
loc="" unit="" user="" band="" proj=""/> </imagedefaults>

The attributes that can be overridden are:
pattern dataset identifier (format: host:group/desc)
key type of location (LINELE or LATLON)
place placement (ULEFT or CENTER)
loc location of placement (line ele or lat lon)
size resulting image size (lines eles)
mag magnification factor (lmag emag)
unit default calibration unit
band band number
proj project number
user user id (case sensitive)
debug (true to print lots of debug information)
Except for pattern, key and debug, McIDAS-V uses the same keywords/syntax as McIDAS (longitudes are entered as degrees east, however). The
entries are hierarchical, so if you specify some defaults for the server, they apply to all datasets on that server unless overridden for specific
datasets.

Here are a few examples:

<imagedefaults> <default pattern="*" debug="true"/> <default
pattern="adde.ucar.edu:RTIMAGES/GE-IR" key="LATLON" place="CENTER" loc="40 -90" unit="BRIT"
user="foo" proj="9999"/> <default pattern="EUM_AD/M8" loc="46 10" band="9" unit="TEMP"
size="512 512"/> <default pattern="CIMSS/CTP" key="LATLON" loc="35 -100" mag="1 1"
unit="CTOP"/> <default pattern="GINICOMP/GSN8KVIS" key="LINELE" place="CENTER" loc="504 768"
size="504 768" mag="-2 -2"/> <default pattern="CCS039/G81KVIS" key="LINELE" place="ULEFT"
loc="0 0" size="ALL"/> </imagedefaults>

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_SiteConfiguration__FILE


Adding in new GRIB tables
McIDAS-V can read Gridded Binary (GRIB) files in both GRIB-1 and GRIB-2 formats. Decoding GRIB files requires a set of lookup tables for
parameters, issuing centers, etc. McIDAS-V comes pre-configured to support commonly used tables, but regional models and modeling centers
may use tables that are not in the distribution.

You can add in specialized tables for both GRIB-1 and GRIB-2 using the steps below. Documentation on the format of the files can be found
here.

GRIB-1 tables
GRIB-2 tables

GRIB-1 tables
To add in new GRIB 1 tables, you will need to create a file listing the special tables and the special table files themselves.

To add in a new parameter file, McIDAS-V would need to have access to a file called grib1lookuptable.lst which would list the parameter table
(e.g.: gwctab_2.tab) and the parameter table itself.

The format of grib1lookuptable.lst is:

<center>:<subcenter>:<version>: <table location>

so it would look like:

57: 1: 2: gwctab_2.tab

gwctab_2.tab can be a relative or absolute path. The tables are in ncep format:

-1:57:-1:2 0:var0:undefined 1:PRES:Pressure [Pa] 2:PRMSL:Pressure reduced to MSL [Pa]
3:PTEND:Pressure tendency [Pa/s] 4:PVORT:Pot. vorticity [km^2/kg/s] 5:ICAHT:ICAO Standard
Atmosphere Reference Height [m] :GP:Geopotential [m^2/s^2] ...

(You can read more information about the format of this file and the parameter table here)

Once you've created this file, you would access it by putting the grib1lookuptable.lst in your <home>/.metapps/DefaultIdv directory and put the
corresponding table files where they are pointed to in the file. This can be a relative path or a web server. Alternatively, you could place the
grib1lookuptable.lst and associated parameter tables on a local web server and use McIDAS-V's sitepath parameter (startup option or user
preference) to point to the location where the files are.

GRIB-2 tables
To add in new GRIB 2 parameter, you would create a file named grib2lookuptable.lst which lists the parameters.

The format of grib2lookuptable.lst is:

<Discipline> <Category> <Parm #> <Name> <Units> <Desc>

Parameters are listed by row, fields are separated by tabs, so it would look like:

#Dis Cat Parm # Name Units Desc 0 0 0 Temperature K Temperature

(This is a sample table, the lines starting with # are not include in table.) (You can read more information about the format of this file and the
parameter table here)

Once you've created this file, you would access it by putting the grib2lookuptable.lst in your <home>/.metapps/DefaultIdv directory. Alternatively,
you could place the grib2lookuptable.lst on a local web server and use McIDAS-V's sitepath parameter (startup option or user preference) to point
to the location of the file.

http://www.unidata.ucar.edu/software/decoders/javadoc/Parameters.txt
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McIDAS-V Special Data Formats
Text (ASCII) Point Data Format
Location XML Files
Image XML Files
Image Movie Files
XGRF Symbols

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_TextPointData__FILE
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Text (ASCII) Point Data Format
If your point (in situ) data is not available in one of the file formats that McIDAS-V can handle, but you can output it into a column-oriented
ASCII text file, you may still be able to use the McIDAS-V displays. McIDAS-V supports reading in point observation data in a text comma
separated value (CSV) file format.

You need to specify the metadata of this point data. This can be done in two ways. First, the file can have two extra header lines that defines for
McIDAS-V the fields that are within the file and the types of the fields. The only other requirement is that there must be a latitude, longitude and
time field in the data. See below.

Secondly, if there are no metadata header lines defined, the Text Point Data Source will show the Metadata GUI described below.

Examples:

Comma separated numeric values

In the simplest form, each line line is an observation at one time and one location:

(index) -> (Time,Latitude,Longitude,Altitude,PSL,GUS,SPD,DIR,TD,T) Time[fmt="yyyy-MM-dd
HH:mm:ss"],Latitude[unit="deg"],Longitude[unit="degrees
west"],Altitude[unit="m"],PSL[unit="hPa"],GUS[unit="m.s-1"],SPD[unit="m/s"],DIR[unit="deg"],
TD[unit="celsius"],T[unit="celsius"] 2007-01-07 16:00:00Z,32.9,117.1,145.0,1026.1,NaN,0.0,0.0,-
2.8,12.8 2007-01-07 16:00:00Z,48.3,92.5,341.0,1003.7,NaN,1.5,170.0,-2.0,-0.99 2007-01-07
16:00:00Z,36.8,98.7,449.0,1024.0,12.4,9.8,330.0,-3.0,3.0 2007-01-07
16:00:00Z,44.3,121.2,938.0,1030.1,NaN,2.1,110.0,-3.3,-1.7

Note also that the first line's structure is quite rigid -- you must have a variable (e.g., index, recNum) that is the domain parameter; this should
map to the range values. The second line defines the formatting and units of the parameters. Unit names should be standard international unit
specifications (udunits compatible). A list of valid names can be found here. (A complete description of this format is contained in the VisAD
README.text file.)

Also note that you need to set the name of the variable for time as "Time", as well as the locations as "Latitude", "Longitude" and "Altitude" (if
needed).

Text fields

If you have text fields (i.e., non-numeric data) in your observation just do this:

(index) -> (Time,Latitude,Longitude,Altitude,ST(Text),T) Time[fmt="yyyy-MM-dd HH:mm:ss
z"],Latitude[unit="deg"],Longitude[unit="degrees
west"],Altitude[unit="m"],ST(Text),T[unit="celsius"] 2007-02-16 11:00:00
MST,32.9,117.1,145.0,CA ,20.6

Here we have a ST field (State from metars). Its field name is defined as "ST(Text)" and its entry in the second line is the same.

Time in multiple columns

If you have time fields that span multiple columns, you can use the colspan keyword:

(index) -> (IDN, Latitude, Longitude, Time, WDIR, WSPD, GST) IDN, Latitude[unit="deg"],
Longitude[unit="deg"], Time[fmt="yyyy MM dd HH mm" colspan="5"], WDIR[unit="deg" miss="MM"],
WSPD[unit="m/s" miss="MM"], GST[unit="m/s" miss="MM"] 41001 34.68 -72.66 2007 07 17 20 50 210
4.0 6.0 41004 32.5 -79.09 2007 07 17 20 50 210 6.0 MM 41008 31.4 -80.87 2007 07 17 21 50 170
7.0 8.0

Skipping columns

You can use the "skip" parameter if you want to ignore (not read) values in your text file that you don't want to use:

(recNum)->(Latitude, Longitude, Altitude, type(Text), time, turb_intensity)
Time[fmt=yyyyMMddHH], obtime, skip, type(Text), skip, skip, Latitude, Longitude[scale=-1],
Altitude[unit=ft], Altitude2[unit=ft], turb_intensity, skip 2004050100 0005 34 C210 1 T 38.82
92.22 7000 7000 0 -9 2004050100 0004 35 PA32 0 T 35.40 98.62 4000 4000 0 -9 2004050100 0008 58
A36 0 T 29.18 81.05 5000 5000 2 -9

Fixed values for several observations

If you have values (like time or location) that are fixed for several observations, you may use this construct:

(index) -> (Longitude,Latitude,Time,ST(Text),SPD,DIR,TD,T) Longitude[unit="degrees
west"],Latitude[unit="deg"],Time[fmt="yyyy-MM-dd HH:mm:ss
z"],ST(Text),SPD[unit="m/s"],DIR[unit="deg"],TD[unit="celsius"],T[unit="celsius"] Longitude=-
117.1 Latitude=32.9 ST=MSN 2007-02-20 11:00:00 ST ,0.0,0.0,8.9,13.3 2007-02-20 12:00:00 ST
,0.0,0.0,11.9,15.0 Longitude=-89.4 Latitude=43.1 ST=DEN 2007-02-20 11:00:00 ST ,1.5,160.0,-
7.0,-2.0 2007-02-20 12:00:00 ST ,1.5,160.0,-7.0,-2.0 Longitude=-121.2 Latitude=44.3 ST=ORD
2007-02-20 11:00:00 ST ,10.8,230.0,-1.1,6.7

Loading into McIDAS-V
Finally, after you have created your file, you will want to tailor your McIDAS-V display in two ways:

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_TextPointData__metadatagui
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http://www.ssec.wisc.edu/~billh/README.text


1. Create a Layout (station) model for those variables using the McIDAS-V's "Tools->Layout Model Editor" menu

Then, when you run McIDAS-V to read your data:

1. Use Data Source Type as "Text Point Data files"
2. Use the "Point Data Plot" for the Display
3. Select your newly created Layout model

Using the Text Point Metadata Gui
If your text data does not have the metadata header lines the Text Point Data Source will show the following dialog which allows you to specify

the meta data.

Skipping lines

At the top a number of the initial lines from the text data are shown. The arrow keys allow you to specify the start line. For example, if you had
some other header information you can skip over those lines.

Specifying metadata 
For each column of text data there is a row shown in the bottom of the dialog. This shows the sampled value and allows you to enter a name, unit,
date format, missing value and extra information. There are some names that McIDAS-V treats special: "Latitude", "Longitude", "Altitude", and
"Time". You must have at least Latitude, Longitude and Time specied.

The Unit/Date Format field allows you to specify the Unit for data fields and the date format. For text fields choose Misc->Text as the unit.

The Extra fields must be of the form:

name="value"

Don't forget the quotes!

Skipping columns 
You can skip over certain columns by entering the Name: "skip"

Saving this as a preference 
After all of your hard work to keep from having to do this again next time you load a new text point data of the form simply press the
"Preferences" button and select Save Current. This allows you to save these metadata settings and reapply them later using the "Preferences"
button.



Location XML Files
McIDAS-V supports a variety of location text file formats. All of these formats can be loaded through the File Chooser. Select the "Location"
data type.

Locations XML
CSV Format
GeoRSS Format

Locations XML
The main one format McIDAS-V uses is a custom locations xml format. This format still has some nomenclature from when it was atmospheric
science related (e.g. "stations"). A simple example:

<?xml version="1.0" encoding="ISO-8859-1"?> <stationtable
name="TARGET_LocationXml__Example"> <station name="TARGET_LocationXml__station 1"
lat="65:02:06" lon="-147:30:06" elev="790"/> <station name="TARGET_LocationXml__station
2" lat="40.3" lon="-107.5" elev="10"/> ... </stationtable>

The lat and lon attributes can be of the form:

+/- ddd:mm, ddd:mm:, ddd:mm:ss, ddd::ss, ddd.fffff ===> [+/-] ddd.fffff +/- ddd, ddd:, ddd::
===> [+/-] ddd +/- :mm, :mm:, :mm:ss, ::ss, .fffff ===> [+/-] .fffff +/- :, :: ===> 0.0 Any of
the above with N,S,E,W appended

The elev attribute is optional. By default it is in meters. You can override this default with an elevunit in the stationtable tag. e.g.:

<?xml version="1.0" encoding="ISO-8859-1"?> <stationtable
name="TARGET_LocationXml__Example" elevunit="feet"> <station
name="TARGET_LocationXml__station 1" lat="65:02:06" lon="-147:30:06" elev="5340"/> ...

The station tags can have an id attribute as well:

<station id="APD" name="TARGET_LocationXml__Fairbanks/Pedro Dome" lat="65:02:06" lon="-
147:30:06" elev="790"/>

The station tags can also have any other attributes:

<station id="APD" name="TARGET_LocationXml__Fairbanks/Pedro Dome" st="AK" co="US"
lat="65:02:06" lon="-147:30:06" elev="790"/> <station id="FTG"
name="TARGET_LocationXml__Denver/Boulder" st="CO" co="US" lat="39:47:12" lon="-
104:32:45" elev="1675"/>

These can be displayed by the station model used in the Location Display Control.

CSV Format
Location data can be defined in a CSV (Comma Separated Value) format. The first line is a comma separated list of column names. There must
be columns that are latitude and longitude. These are denoted with (case insensitive):

latitude lat longitude lon long

Altitude is given by the column names:

alt altitude

The altitude value, if defined, is by default in meters. You can optionally specify a unit with the suffix: "[unit name]" (see example).

The first column that is found that is not one of the location columns is taken to be the name of the location.

Example:

Name,Latitude,Longitude,Altitude,State Boulder,40,-107,5430[feet],CO Miami,30,-95,0[feet],FL
...

GeoRSS Format
McIDAS-V can also read GeoRSS formats. This is a geocoded RSS feed. An example is the USGS earthquake feed:

http://earthquake.usgs.gov/eqcenter/recenteqsww/catalogs/eqs7day-M2.5.xml
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Image XML Files
The Image Xml file format (.ximg) allows one to define collections of geolocated images (and also shapefiles). The simplest file can define one
geolocated image:

<image url="sboulder.jpeg" name="South Boulder-aerial photo" ullat="39.98890" ullon="-
105.22782" lrlat="39.98755" lrlon="-105.22548"/>

The url attribute can be an absolute or relative url or file path. The ullat, ullon, lrlat and lrlon attributes are the upper left and lower right lat/lon
of the image. It is assumed that the image is in a geographic (i.e., rectilinear, lat/lon) projection.

Collections
You can also define a collection of images:

<collection name="TARGET_ImageXml__Boulder Images"> <image url="sboulder.jpeg"
name="South Boulder-aerial photo" ullat="39.98890" ullon="-105.22782" lrlat="39.98755"
lrlon="-105.22548"/> <image url="bouldertopo.jpeg" ullat="40.06654" ullon="-105.34710"
lrlat="39.98040" lrlon="-105.19676" name="Boulder topo"/> <image url="bigtopo.jpeg"
ullat="40.22807" ullon="-106.66437" lrlat="39.54718" lrlon="-105.45623" name="Mountains
topo"/> </collection>

Collections can contain other collections:

<collection name="TARGET_ImageXml__My Images"> <collection
name="TARGET_ImageXml__Madison Images"> <image url="madison_aerial.jpeg"
ullat="43.09444" ullon="-89.52626" lrlat="43.01143" lrlon="-89.36579" name="Madison
aerial"/> <image url="madison_topo.jpeg" ullat="43.09444" ullon="-89.52626"
lrlat="43.01143" lrlon="-89.36579" name="Madison topo"/> </collection> <collection
name="TARGET_ImageXml__Boulder Images"> <image url="sboulder.jpeg" name="South Boulder-
aerial photo" ullat="39.98890" ullon="-105.22782" lrlat="39.98755" lrlon="-105.22548"/>
</collection> </collection>

There is also a shape tag for defining shape files:

<collection name="TARGET_ImageXml__Shapes"> <shape url="boulder_roads.zip"
name="TARGET_ImageXml__Boulder roads"/> <shape url="boulder_rivers.zip"
name="TARGET_ImageXml__Boulder rivers"/> </collection>

Grouping
The group tag allows you to group a set of images in time or space:

<group name="TARGET_ImageXml__group of images" format="yyyyMMddhhmm" ullat="39.991856"
ullon="-105.226944" lrlat="39.989426" lrlon="-105.222656"> <image date="200610011000"
url="sketch.jpg"/> <image url="map.jpg" date="200610011100"/> </group>

The format attribute defines the date/time format of the date attributes. The location attributes (ullat,ullon, etc.) can be defined both in the group
tag as well as in each individual image tag.

If there are no date attributes then the group of images are aggregated together, each potentially covering a different area.

Images in 3D Space
One is not limited to just specifying the positions of the upper left and lower right corners of the image. There is support for defining the latitude
and longitude for any of the four corners of the image:

<image url="image.jpeg" name="Image" ullat="40" ullon="-100" lllat="30" lllon="-100"
urlat="50" urlon="-90" lrlat="30" lrlon="-90" />

One can also specify the altitude of any of the points. The unit specification is not required and will default to meters.

<image url="image.jpeg" name="Image" ullat="40" ullon="-100" ulalt="20000[feet]"
lllat="30" lllon="-100" llalt="0[feet]" urlat="50" urlon="-90" uralt="5000[feet]"
lrlat="30" lrlon="-90" lralt="0[feet]" />

McIDAS-V will try to fill in defaults. So, for example, if you wanted to have an image be a vertical cross section you could do:

<image url="topo.jpg" name="Image" ullat="40" ullon="-100" urlat="50" urlon="-90"
ulalt="20000[feet]" llalt="0[feet]"/>

Here, we define the lat/lon of the upper left and upper right of the image. We define the altitude of the upper left and lower left corners of the
image. The altitude of the upper right corner defaults to that of the upper left and the altitude of the lower right defaults to the lower left altitude.



Image Movie Files
McIDAS-V can display a sequence of time-stamped images as an animation.

One can write their own xml file and display the images within McIDAS-V using this xml format.

There are really two xml formats used. The first defines a set of imagesets:

<imagesets base="http://www.unidata.ucar.edu/georesources/webcams/images"
name="TARGET_ImageMovie__McIDAS-V Webcams"> <group name="TARGET_ImageMovie__Rockies">
<imageset name="TARGET_ImageMovie__Boulder, CO" index="boulder_co/index.xml" lat="40.0"
lon="-105.27"/> <imageset name="TARGET_ImageMovie__Denver, CO"
index="denver_co/index.xml" lat="39.75" lon="-105"/> </group> <group
name="TARGET_ImageMovie__National Parks"> <imageset name="TARGET_ImageMovie__Theodore
Roosevelt National Park, ND" index="theodorerooseveltnationalpark_nd/index.xml"
lat="46.94889" lon="-103.43306"/> <imageset name="TARGET_ImageMovie__Big Bend National
Park,TX" index="bigbendnationalpark_tx/index.xml" lat="29.25" lon="-103.25"/> <imageset
name="TARGET_ImageMovie__Olympic National Park" index="olympicnationalpark/index.xml"
lat="48.26667" lon="-124.675"/> </group> ... </imagesets>

This is a "table of contents". The base attribute, if defined, is used as a url base to prepend to the urls defined by the index attributes. The lat and
lon attributes are optional and are used to locate the source of the movie on a map for the user to select.

Each of the index attributes refers to an images xml file of the form:

<images base="http://www.unidata.ucar.edu/georesources/webcams/images/boulder_co"
name="Boulder, CO" group="Rockies" format="yyyyMMddHHmmz" desc="From:
http://9news.com"> <image time="200607251446GMT" file="image_200607251446GMT.jpeg"/>
<image time="200607251430GMT" file="image_200607251430GMT.jpeg"/> <image
time="200607251414GMT" file="image_200607251414GMT.jpeg"/> <image
time="200607251357GMT" file="image_200607251357GMT.jpeg"/> <image
time="200607251344GMT" file="image_200607251344GMT.jpeg"/> ... </images>

The images tag defines a base attribute (optional, used to prepend to any image urls), a name, a (optional) group and a date format and a
description (desc). Each image tag has a time in the format specified in the images tag and a file attribute which refers to some image. This may
be an absolute or relative url or file path.



XGRF Symbols
The drawing control can export and import its drawings in an xgrf format. In this format you can specify a symbol type. The symbol tag in the
xgrf has a symbol attribute, the value of which can be any of the below symbols.

General Symbols
PIN - Pin
PLUS - Plus
MINUS - Minus
CROSS - Cross
SQUARE - Square
FILLED_SQUARE - Filled Square
TRIANGLE - Triangle
FILLED_TRIANGLE - Filled Triangle
CIRCLE - Circle
FILLED_CIRCLE - Filled Circle
DIAMOND - Diamond
FILLED_DIAMOND - Filled Diamond
STAR - Star
FILLED_STAR - Filled Star
HORLINE - Hor. Line
VERTLINE - Vert. Line
LEFTARROW - Left Arrow
RIGHTARROW - Right Arrow
UPARROW - Up Arrow
DOWNARROW - Down Arrow
CUBE - Cube
DOWNLINE - Down Line
PYRAMID_4FACE - 4 Face Pyramid
PYRAMID_5FACE - 5 Face Pyramid
FILLED_SPHERE - Sphere
AIRPLANE - 2-D Airplane
AIRPLANE3D - 3-D Airplane
NONE - None

Present Weather
WX_PRESENTWX_0 - Cloud development not observed or not observable
WX_PRESENTWX_1 - Clouds generally dissolving or becoming less developed
WX_PRESENTWX_2 - State of sky on the whole unchanged
WX_PRESENTWX_3 - Clouds generally forming or developing
WX_PRESENTWX_4 - Visibility reduced by smoke
WX_PRESENTWX_5 - Haze
WX_PRESENTWX_6 - Widespread dust in suspension in the air, not raised by wind
WX_PRESENTWX_7 - Dust or sand (or spray) raised by wind
WX_PRESENTWX_8 - Well developed dust or sand whirl(s)
WX_PRESENTWX_9 - Duststorm or sandstorm within sight or during preceding hour
WX_PRESENTWX_10 - Mist
WX_PRESENTWX_11 - Patches of shallow fog or ice fog (less than 2m land, 10m sea)
WX_PRESENTWX_12 - Continuous shallow fog or ice fog (less than 2m land, 10m sea)
WX_PRESENTWX_13 - Lightning visible, no thunder heard
WX_PRESENTWX_14 - Precipitation in sight, not reaching the ground
WX_PRESENTWX_15 - Precipitation in sight, reaching the ground, more than 5km away
WX_PRESENTWX_16 - Precipitation in sight, reaching the ground nearby
WX_PRESENTWX_17 - Thunderstorm, but no precipitation at time of observation
WX_PRESENTWX_18 - Squalls within sight during the preceding hour
WX_PRESENTWX_19 - Funnel cloud(s) within sight during the preceding hour
WX_PRESENTWX_20 - Recent drizzle or snow grains
WX_PRESENTWX_21 - Recent rain
WX_PRESENTWX_22 - Recent snow
WX_PRESENTWX_23 - Recent rain and snow or ice pellets
WX_PRESENTWX_24 - Recent freezing drizzle or freezing rain
WX_PRESENTWX_25 - Recent rain showers
WX_PRESENTWX_26 - Recent showers of snow, or of rain and snow
WX_PRESENTWX_27 - Recent showers of hail, or of rain and hail
WX_PRESENTWX_28 - Recent fog
WX_PRESENTWX_29 - Recent thunderstorm
WX_PRESENTWX_30 - Slight or moderate duststorm or sandstorm, has decreased in last hour
WX_PRESENTWX_31 - Slight or moderate duststorm or sandstorm, no change in last hour
WX_PRESENTWX_32 - Slight or moderate duststorm or sandstorm, has increased in last hour
WX_PRESENTWX_33 - Severe duststorm or sandstorm, has decreased in last hour
WX_PRESENTWX_34 - Severe duststorm or sandstorm, no change in last hour
WX_PRESENTWX_35 - Severe duststorm or sandstorm, has increased in last hour
WX_PRESENTWX_36 - Slight or moderate drifting snow (below eye level)
WX_PRESENTWX_37 - Heavy drifting snow (below eye level)
WX_PRESENTWX_38 - Slight or moderate blowing snow (above eye level)
WX_PRESENTWX_39 - Heavy blowing snow (above eye level)
WX_PRESENTWX_40 - Fog extending above observer in distance
WX_PRESENTWX_41 - Fog in patches
WX_PRESENTWX_42 - Fog has become thinner in last hour, sky visible
WX_PRESENTWX_43 - Fog has become thinner in last hour, sky invisible
WX_PRESENTWX_44 - Fog, no change in last hour, sky visible
WX_PRESENTWX_45 - Fog, no change in last hour, sky invisible



WX_PRESENTWX_46 - Fog has become thicker in last hour, sky visible
WX_PRESENTWX_47 - Fog has become thicker in last hour, sky invisible
WX_PRESENTWX_48 - Fog depositing rime, sky visible
WX_PRESENTWX_49 - Fog depositing rime, sky invisible
WX_PRESENTWX_50 - Slight intermittent drizzle
WX_PRESENTWX_51 - Slight continuous drizzle
WX_PRESENTWX_52 - Moderate intermittent drizzle
WX_PRESENTWX_53 - Moderate continuous drizzle
WX_PRESENTWX_54 - Heavy intermittent drizzle
WX_PRESENTWX_55 - Heavy continuous drizzle
WX_PRESENTWX_56 - Slight freezing drizzle
WX_PRESENTWX_57 - Moderate or heavy freezing drizzle
WX_PRESENTWX_58 - Slight rain and drizzle
WX_PRESENTWX_59 - Moderate or heavy rain and drizzle
WX_PRESENTWX_60 - Slight intermittent rain
WX_PRESENTWX_61 - Slight continuous rain
WX_PRESENTWX_62 - Moderate intermittent rain
WX_PRESENTWX_63 - Moderate continuous rain
WX_PRESENTWX_64 - Heavy intermittent rain
WX_PRESENTWX_65 - Heavy continuous rain
WX_PRESENTWX_66 - Slight freezing rain
WX_PRESENTWX_67 - Moderate or heavy freezing rain
WX_PRESENTWX_68 - Slight rain or drizzle and snow
WX_PRESENTWX_69 - Moderate or heavy rain or drizzle and snow
WX_PRESENTWX_70 - Slight intermittent fall of snow flakes
WX_PRESENTWX_71 - Slight continuous fall of snow flakes
WX_PRESENTWX_72 - Moderate intermittent fall of snow flakes
WX_PRESENTWX_73 - Moderate continuous fall of snow flakes
WX_PRESENTWX_74 - Heavy intermittent fall of snow flakes
WX_PRESENTWX_75 - Heavy continuous fall of snow flakes
WX_PRESENTWX_76 - Ice prisms
WX_PRESENTWX_77 - Snow grains
WX_PRESENTWX_78 - Isolated starlike snow crystals
WX_PRESENTWX_79 - Ice pellets
WX_PRESENTWX_80 - Slight rain showers
WX_PRESENTWX_81 - Moderate or heavy rain showers
WX_PRESENTWX_82 - Violent rain showers
WX_PRESENTWX_83 - Slight showers of rain and snow mixed
WX_PRESENTWX_84 - Moderate or heavy showers of rain and snow mixed
WX_PRESENTWX_85 - Slight snow showers
WX_PRESENTWX_86 - Moderate or heavy snow showers
WX_PRESENTWX_87 - Slight showers of ice or snow pellets
WX_PRESENTWX_88 - Moderate or heavy showers of ice or snow pellets
WX_PRESENTWX_89 - Slight hail showers
WX_PRESENTWX_90 - Moderate or heavy hail showers
WX_PRESENTWX_91 - Slight rain, thunderstorm in last hour
WX_PRESENTWX_92 - Moderate or heavy rain, thunderstorm in last hour
WX_PRESENTWX_93 - Slight rain and/or snow or hail, thunderstorm in last hour
WX_PRESENTWX_94 - Moderate or heavy rain and/or snow or hail, thunderstorm in last hour
WX_PRESENTWX_95 - Slight or moderate thunderstorm with rain and/or snow
WX_PRESENTWX_96 - Slight or moderate thunderstorm with hail
WX_PRESENTWX_97 - Heavy thunderstorm with rain and/or snow
WX_PRESENTWX_98 - Thunderstorm combined with duststorm or sandstorm
WX_PRESENTWX_99 - Heavy thunderstorm with hail

Low Cloud
WX_LOCLD_1 - Cu of fair weather, little vertical development, seemingly flattened
WX_LOCLD_2 - Cu of considerable development, generally towering, with or without other Cu or Sc bases all at same level
WX_LOCLD_3 - Cb with tops lacking clear cut outlines, but distinctly no cirriform or anvil-shaped; with or without Cu, Sc, or St
WX_LOCLD_4 - Sc formed by spreading out of Cu; Cu often present also
WX_LOCLD_5 - Sc not formed by spreading out of Cu
WX_LOCLD_6 - St or Fs or both, but no Fs of bad weather
WX_LOCLD_7 - Fs and/or Fc of bad weather (scud)
WX_LOCLD_8 - Cu and Sc (not formed by spreading out of Cu) with bases at different levels
WX_LOCLD_9 - Cb having a clearly fibrous (cirriform) top, often anvil-shaped, with or without Cu, Sc, St, or scud

Cloud Coverage
WX_SKY_0 - No clouds
WX_SKY_1 - Less than one-tenth or one-tenth
WX_SKY_2 - two-tenths or three-tenths
WX_SKY_3 - four-tenths
WX_SKY_4 - five-tenths
WX_SKY_5 - six-tenths
WX_SKY_6 - seven-tenths or eight-tenths
WX_SKY_7 - nine-tenths or overcast with openings
WX_SKY_8 - completely overcast
WX_SKY_9 - sky obscured
WX_SKY_10 - missing

Mid Clouds
WX_MIDCLD_1 - Thin As (most of cloud layer semi-transparent)
WX_MIDCLD_2 - Thick As, greater part sufficiently dense to hide sun (or moon), or Ns
WX_MIDCLD_3 - Thin Ac, mostly semi-transparent; cloud elements not changing much and at a single level
WX_MIDCLD_4 - Thin Ac in patches; cloud elements continually changing and/or occurring at more than one level



WX_MIDCLD_5 - Thin Ac in bands or in a layer gradually spreading over sky and usually thickening as a whole
WX_MIDCLD_6 - Ac formed by spreading out of Cu
WX_MIDCLD_7 - Double-layered Ac, or a thick layer of Ac, not increasing; or Ac with As and/or Ns
WX_MIDCLD_8 - Ac in the form of Cu-shaped tufts or Ac with turrets
WX_MIDCLD_9 - Ac of a chaotic sky, usually at different levels; patches of dense Ci are usually present also

High Clouds
WX_HICLD_1 - Filaments of Ci, or "mares tails", scattered and not increasing
WX_HICLD_2 - Dense Ci in patches or twisted sheaves, usually not increasing, sometimes like remains of Cb; or towers or tufts
WX_HICLD_3 - Dense Ci, often anvil shaped derived from or associated with Cb
WX_HICLD_4 - Ci, often hook shaped, spreading over the sky and usually thickening as a whole
WX_HICLD_5 - Ci and Cs, often in converging bands, or Cs alone; generally overspreading and growing denser; the continuous
layer not reaching 45 degrees altitude
WX_HICLD_6 - Ci and Cs, often in converging bands, or Cs alone; generally overspreading and growing denser; the continuous
layer exceeding 45 degrees altitude
WX_HICLD_7 - Veil of Cs covering the entire sky
WX_HICLD_8 - Cs not increasing and not covering the entire sky
WX_HICLD_9 - Cc alone or Cc with some Ci or Cs, but the Cc being the main cirriform cloud

Pressure Tendency
WX_TNDCY_0 - rising then falling
WX_TNDCY_1 - rising then steady; or rising, then rising more slowly
WX_TNDCY_2 - rising steadily or unsteadily
WX_TNDCY_3 - falling or steady, then rising; or rising, then rising more quickly
WX_TNDCY_4 - steady, same as 3 hours ago
WX_TNDCY_5 - falling then rising, same or lower than 3 hours ago
WX_TNDCY_6 - falling then steady; or falling, then falling more slowly
WX_TNDCY_7 - falling steadily, or unsteadily
WX_TNDCY_8 - steady or rising, then falling; or falling, then falling more quickly

Icing
WX_ICING_0 - No icing
WX_ICING_1 - Trace icing
WX_ICING_2 - Trace to light icing
WX_ICING_3 - Light icing
WX_ICING_4 - Light to moderate icing
WX_ICING_5 - Moderate icing
WX_ICING_6 - Moderate to heavy icing
WX_ICING_7 - Heavy or moderate to severe icing
WX_ICING_8 - Severe icing
WX_ICING_9 - Light superstructure icing
WX_ICING_10 - Heavy superstructure icing

Turbulence
WX_TURBULENCE_0 - No turbulence
WX_TURBULENCE_1 - Light turbulence
WX_TURBULENCE_2 - Light turbulence
WX_TURBULENCE_3 - Light to moderate turbulence
WX_TURBULENCE_4 - Moderate turbulence
WX_TURBULENCE_5 - Moderate to severe turbulence
WX_TURBULENCE_6 - Severe turbulence
WX_TURBULENCE_7 - Extreme turbulence
WX_TURBULENCE_8 - Extreme turbulence

Miscellaneous
WX_MISC_0 - Square (outline)
WX_MISC_1 - Square (filled)
WX_MISC_2 - Circle (outline)
WX_MISC_3 - Circle (filled)
WX_MISC_4 - Triangle (outline)
WX_MISC_5 - Triangle (filled)
WX_MISC_6 - Diamond (outline)
WX_MISC_7 - Diamond (filled)
WX_MISC_8 - Star (outline)
WX_MISC_9 - Star (filled)
WX_MISC_10 - High Pressure (outline)
WX_MISC_11 - Low Pressure (outline)
WX_MISC_12 - High Pressure (filled)
WX_MISC_13 - Low Pressure (filled)
WX_MISC_14 - Plus sign
WX_MISC_15 - Minus sign
WX_MISC_16 - Tropical Storm (NH)
WX_MISC_17 - Hurricane (NH)
WX_MISC_18 - Tropical Storm (SH)
WX_MISC_19 - Hurricane (SH)
WX_MISC_20 - Triangle with antenna
WX_MISC_21 - Mountain obscuration
WX_MISC_22 - Slash
WX_MISC_23 - Storm Center
WX_MISC_24 - Tropical Depression
WX_MISC_25 - Tropical Cyclone
WX_MISC_26 - Flame
WX_MISC_27 - X Cross
WX_MISC_28 - Low pressure with X (outline)
WX_MISC_29 - Low pressure with X (filled)
WX_MISC_30 - Tropical Storm (NH)



WX_MISC_31 - Tropical Storm (SH)
WX_MISC_32 - Volcanic activity
WX_MISC_33 - Blowing spray



Actions
Below is a list of the actions that can be used in menubars, skins and in the html or qhtml pages.

To use these in an html or qhtml file simply specify a link with the href:

action:the_action_id

e.g.:

action:bundle.open

new.datachooser 
Show data sources window

show.dataselector 
Show field selector window

show.dashboard 
Show Data Explorer

ui.closewindow 
Close Window

new.displaywindow 
New view window

bundle.open 
Open a bundle

bundle.save 
Save bundle

bundle.default.save 
Save as default

bundle.default.open 
Reload default bundle

bundle.default.remove 
Delete default bundle

bundle.favorite.save 
Save as favorite bundle

bundle.favorite.manage 
Manage favorites

plugins.install.file 
Install a plugin from a file

plugins.install.url 
Install a plugin from a url

plugins.manage 
List plugins

plugins.create 
Create plugin

edit.preferences 
Edit user preferences

edit.formula.create 
Create formula

edit.formula.import 
Import formula

edit.formula.export 
Export formula

edit.jython 
Edit Jython library

edit.colortables 
Edit color tables

edit.stationmodels 
Edit station models

edit.paramaliases 



Edit parameter aliases

edit.projections 
Edit projections

edit.paramdefaults 
Edit parameter defaults

edit.paramgroups 
Edit parameter groups

edit.autodisplays 
Auto-create displays

edit.views.delete 
Delete Saved Views

edit.removedisplays 
Remove all displays

edit.removedisplaysanddata 
Remove all displays and data

view.reloadalldata 
Reload all data sources

edit.removedata 
Remove all data sources

exit 
Exit

idv.stopload 
Stop current loads

capture.all 
Capture All Images

collab.showcapture 
Event Capture

collab.showwindow 
Show Window

collab.shareall 
Share All State

help.introduction 
Show help

help.showconsole 
Show Console

help.showhelptips 
Show Help Tips

help.showsupportform 
Submit support request

help.showabout 
About...

display.curvedrawer 
Create Drawing Control

display.locationindicator 
Create Location Indicator

display.backgroundimage 
Create Background Image

display.rangeandbearing 
Create Range and Bearing

display.imagemovie 
Create Image Movie Display



Command Line Arguments
There are a number of command line arguments for McIDAS-V. To view them provide the argument: -help:
mcv -help

-help (prints this message)
-properties <property file>
-installplugin <plugin jar file to install>
-plugin <plugin jar file, directory, url for this run>
-noplugins (do not load any plugins)
-cleardefault (clear the default bundle)
-nodefault (do not read in the default bundle file)
-default <.xidv file>
-bundle <bundle file or url>
-oneinstanceport <port number>
  (check if another version of McIDAS-V is running, and if so, pass command line arguments to it and shut down)
-nopref (do not read in the user preferences)
-userpath <user directory to use>
-sitepath <url path to find site resources>
-nogui (do not show the main window GUI)
-data <data source> (load the data source)
-display <parameter> <display>
-islinteractive (run the ISL file in interactive mode)
scriptfile.isl (run the McIDAS-V script in batch mode)
-image <image file name> (create a jpeg image and then exit)
-movie <movie file name> (create a quicktime movie and then exit)
-imageserver <port number or .properties file> 
  (run McIDAS-V in image generation server mode, and support http requests on the given port)
-Dpropertyname=value (define the property value)
-catalog <url to a chooser catalog>
-connect <collaboration hostname to connect to>
-server (run in collaboration server mode)
-port <port number collaboration server should listen on>
-chooser (show the data chooser on start up)
-printjnlp (print out any embedded bundles from jnlp files)
-setfiles <datasource pattern> <semi-colon delimited list of files> 
  (use the list of files for the bundled datasource)
-currenttime <dttm> (override current time for ISL processing)
-listresources (list out the resource types)
-debug (turn on debug printing)
-debugmessages (turn on language pack debug)
-recordmessages <language pack file to write missing entries>
-trace (print out trace messages)
-traceonly <trace pattern> (print out trace messages that match the pattern)

Specifying data source type
If you load in a data source from the command line using the -data argument McIDAS-V tries to figure out what type of data it is by looking for
patterns in the file or url you specify. If it cannot determine the type McIDAS-V will prompt the user for the type.

You can add in a "type:" prefix to the argument that will specify the type with:

mcv -data type:somedatatype:the_file_or_url_to_the_data

The different values for the "somedatatype" are listed in here.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Datasources__FILE


Performance Tuning
If you are running into issues with memory consumption or slow response of McIDAS-V, there are several things you can do.
The amount of memory used by McIDAS-V will depend on the size of the datasets you use and the types of displays. Datasets rendered as 2D
depictions (plan views - contours or color shaded displays) use much less memory than 3D displays (isosurfaces, cross sections). Large datasets
(images, dense grids) will use much more memory.

There are several features in McIDAS-V that allow you to more efficiently view large datasets:

Temporal/Spatial Subset of Data
Subsetting the data before display reduces the memory and display time
Memory allocation
Change the amount of memory allocated to McIDAS-V
Data Caching
Data caching uses more memory
Maximum grid/image size
Reducing the maximum size of a display can reduce the memory used
Fast Rendering
Fast Rendering reduces memory and time at the expense of accuracy
Parallel Rendering and Data Reading
Parallel Rendering and Data Reading can reduce data reading and rendering time

Temporal/Spatial Subset of Data
Some data sources allow you to subset the data temporally and spatially. You can set these properties for all fields in a dataset through the
Properties menu of the data source (double click on the Data Source in the Field Selector) or you can set these for individual field using the tabs
in the lower right corner of the Field Selector. For more information, see the Data Source Properties section of McIDAS-V User's Guide.

Memory allocation
By default, McIDAS-V allocates 512 megabytes of maximum memory for Java. This is usually the optimum amount for a Windows system with
1 gigabyte of physical memory (RAM). Windows takes up half of that anyway and once Windows has to start swapping, performance severely
degrades. On a Linux system, you can probably get away with 700m for 1 Gb of memory as it does a much better job of swapping. All this also
depends on what else you are running on the machine and how much memory those applications use.

If your system has more than 1 Gb of memory, increasing the amount available to McIDAS-V can improve performance for displaying large
datasets. You change the amount of memory used by McIDAS-V by editing the Maximum Heap Size in the Advanced tab of the Preferences by
selected Edit->Preferences... from the main menu. The new amount of memory will be saved and used in subsequent sessions. Do not use the
maximum amount of memory on your machine as some is needed for the operating system itself. If the system has to use swap memory,
performance will degrade as well. It is recommended to set this to no more than 1250 MB (i.e. -Xmx1250m). For more information see the
Running McIDAS-V section of the McIDAS-V User's Guide.

Data Caching
By default, McIDAS-V caches the data used for a display in memory. If a field is used more than once for several displays, caching the data
prevents an additional reading from of the data from disk or a remote server. If you are only displaying/using a field (i.e. not using it for multiple
displays or calculations), you can keep McIDAS-V from caching it in memory. You can turn off data caching by unchecking the Cache data in
memory checkbox on the Data & Formats tab of the user preferences (accessible from the Edit->Preferences menu).

Maximum grid/image size
You can also set the maximum size of a grid or image that will be displayed. This will allow you to download a large image or grid, but it will be
re-sampled before displaying if it is larger than the maximum size you have asked for. You can set the maximum image/grid size under the Data
& Formats tab of the user preferences (accessible from the Edit->Preferences menu).

Fast Rendering
By default, McIDAS-V will try to adjust the data renderings to account for projection seams. This is computationally intensive in some cases and
slows down the display of data. When you set your preference to "Use Fast Rendering" (under the General tab of the user preferences (Edit-
>Preferences menu)), McIDAS-V will not try to account for the projection seams. If you are displaying data in its native projection, this will
result in faster rendering of the data depiction. However, if you have several displays of data, each from a different data source and on a different
projection, you may see anomalies in the displays (spurious lines, portions of images). At that point, you can turn off fast rendering for a particular
display using the Edit->Properties menu of the Display Control for that display, or set your system preference back to not use fast rendering.

To change fast rendering options for maps, click here.

Parallel Rendering and Data Reading
If you are running McIDAS-V on a multi-core machine you can configure it to render individual time steps in parallel. You can also do remote
data reads in parallel. This typically results in a 50% reduction in overall data reading and rendering time.

There are 2 preferences in the Preferences->Advanced tab. One is the number of threads used for rendering. This defaults to the number of
processors on your machine. The second is the number of threads used for data reading. This defaults to 4.

For rendering McIDAS-V will render each time step in parallel. Note: since the rendering processes can allocate temporary memory it is possible
to exhaust the available memory if too many threads are running concurrently. Linear speedup with the number of cores available for rendering
(probably due to memory contention issues) is not seen, however a 40%-50% performance improvement is seen for complex rendering tasks (e.g.,
contouring).

The second preference is used when reading individual time steps of data from remote ADDE and OpenDAP servers. This parallelization takes
advantage of the multiple cores available on the remote server and somewhat the available bandwidth on the network. A linear speed up in
accessing remote data based on the number of cores on the remote server (ADDE or OpenDAP) has been seen. However, if you load the server
too much your performance is degraded, probably due to file system issues. 

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_PerformanceTuning__subset
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_PerformanceTuning__heap
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_PerformanceTuning__cache
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_PerformanceTuning__maxsize
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_PerformanceTuning__fastrender
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_PerformanceTuning__parallelrender
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_DataSourceProperties__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Starting__run
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_MapDisplayControl__fastrendering


Building McIDAS-V from Source
Developers can download the source files for McIDAS-V and build it from scratch.

Before building McIDAS-V you need to first install Java and Java 3D on your system. You need to use the Java SDK, because the Java RunTime
Environment (JRE) does not contain the Java compiler (javac). You need to use a version of Java 1.6 or above. You can use either the Java 3D
SDK or JRE, version 1.3.x.

You will also need to install Ant 1.7 (http://ant.apache.org/) on your machine. Ant is similar to make - instead of a Makefile, Ant uses a
build.xml file. Be sure to follow the instructions for installing Ant, especially those for setting up environment variables.

Build steps:

1. Download the compressed source files from the McIDAS-V Download Page.
2. Uncompress the .zip file. This will create a new directory containing the McIDAS-V source and Unidata IDV .jar files.

The resulting directory structure will be:

mc-v/ mc-v/build.xml mc-v/... <-- McIDAS-V source directories idv/ idv/lib <-- Unidata IDV
.jar files

The Ant build script "mc-v/build.xml" is be used to build and run McIDAS-V.
3. Change to the mc-v directory and run:

"ant jar" to create the McIDAS-V .jar files in mc-v/dist.
"ant run" to run McIDAS-V with a small java heap size for testing.

http://ant.apache.org/
http://www.ssec.wisc.edu/mcidas/software/v/download.html
http://www.unidata.ucar.edu/software/idv


Appendix
Examples of Display Types

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_examples__FILE


Examples of Display Types
Plan Views
3D Surface
Imagery
Radar -- Level II WSR-88D Data Displays
Soundings
Profiler Winds
Flow Displays
Observations
Miscellaneous Display Types

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_PlanViews__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_3DSurface__FILE
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http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Radar__FILE
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500 hPa height contours

 
Oblique view in 3D of colored contours of wind speed at 250 hPa

Plan Views



 
Color-filled contours of surface temperature

 
Mean sea level pressure as a color-shaded image, and contour lines

A plan view is a horizontal display of 2D data on the map, or a horizontal cross-section of 3D data. Conventional contour plots of data on a map
are a plan view.

Plan views can be displayed in several ways:

with solid or dashed contour lines
with contour lines colored by value
with color-filled contours
with "color-shaded" images (all data grid cells colored by value, which may be smoothed)

Colors help distinguish values and subtle features, and if used carefully can be an intuitive indication of value and trend, such as using "hot"
colors for higher or important values.

An McIDAS-V 3D Plan View can be set to any level of the data levels in the data source, or between data levels, in which case interpolation is
used to estimate the data values in the plan view. A colored square selector point in the left corner of the 3D plan view can be moved up and
down by dragging the mouse button to re-position the level. You can make several 3D plan views at the same time, for one or more parameters in
3D data. To learn how to make a display, see Getting Started: Displaying Gridded Data.

You can control the display appearance of plan views with the associated Plan View Control

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Grids__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_PlanViewControl__FILE


 
3D Isosurface for 50 m/s wind speed

 
Relative Humidity isosurface of 89%, colored by air temperature.

3D Surface
Isosurfaces
Topography Display
2D Data Draped Over Topography

Isosurfaces
An isosurface is a surface of a single value in a 3D parameter field. Isosurfaces are the 3D analog of a single-valued contour line in a 2D plot.
The intersection of an isosurface and a plane is a contour line of the same value. Isosurfaces may form closed surfaces enclosing regions of higher
or lower value, but not always.

McIDAS-V also supports isosurface displays that are colored from another parameter, not the parameter used to make the shape of the surface.
The example here shows an isosurface of 89% relative humidity over North America colored by air temperature. A useful plot is to color
isosurfaces by height (geopotential height) to show height of features by color.

Topography Display
For data sources that include topography or terrain data, such as the "terrain" parameter in Eta and RUC model output or DEM data, McIDAS-V
can display a 3D relief map. Select "Topography" for the display type.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_3DSurface__isosurface
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_3DSurface__topography
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_3DSurface__2dtopo


 
DEM data of the Arno river basin in Italy

 
RUC model terrain

 
Sea level pressure over topography

2D Data Draped Over Topography
Two dimensional grid data can be draped over a topography field to provide a terrain following representation of the data.

For more information see Getting Started: Displaying Gridded Data.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Grids__FILE


 
GOES Visible Satellite Image

 
Level III Base Reflectivity Radar Image

Imagery
Satellite Image Display

Extensive satellite image data are available from both local files and remote ADDE servers. For more information see Getting Started: Displaying
Satellite Imagery .

Radar -- Level III WSR-88D Image Displays

For more information see Getting Started: Displaying Level III Radar Imagery .

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Satellite__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_RadarLevelIII__FILE


 
2D Level II Radar Sweep View

 
3D Level II Radar Sweep View

Radar -- Level II WSR-88D Data Displays
McIDAS-V can read and use WSR-88D Level II data, including reflectivity, radial velocity, and spectrum width, and display it in several ways.



 
Level II Radar Volume Scan

 
Level II Radar Isosurface



 
3D Level II pseudo-RHI in main view window

 
Level II pseudo-RHI control window

For more information see Getting Started: Displaying Level II Radar Imagery.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_RadarLevelII__FILE


 
Skew-T display

 
Stuve display

Soundings
The meteorological sounding display is available with a choice of thermodynamic diagrams (Skew-T, Stuve and Emagram), with a table of related
aerological parameters.



 
Emagram display

A sounding diagram can be made for any point inside a data grid of numerical weather prediction model output with temperature and humidity
(the dew-point temperature is computed by Unidata code from temperature and relative humidity grids), or from balloon soundings (RAOBs). The
sounding display and its table and controls appear in a separate window. To learn more about the aerological displays see the Sounding Display.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_AerologicalSoundingControl__FILE


 
Profiler Time/Height Plot

 
Profiler Station Plot

Profiler Winds
McIDAS-V Profiler Time/Height plot shows wind data from any of the NOAA National Profiler Network stations. You can choose hourly, 30
minute, 12 minute, or 6 minute data.

Other displays provided include Profiler Station plot, which shows a plan view at one level, and the Profiler 3D View.



 
Profiler 3D View

For more information see Displaying Profiler Data .

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_ProfileControl__FILE


 
Vector display

 
Streamline display

Flow Displays
For parameters with a vector nature such as wind, vector and streamline displays of flow are available. The display types available are Vector
Plan View, Vector Cross Section, Streamline Plan View, and Wind Barb Plan View.



 
Meteorological wind barb display

Starting with vector or wind barb plan displays, you can switch to a streamline display using the wind display Control. Make sure the skip interval
is zero to see the best streamlines. The Control also allows you to change size and color of the vectors and barbs, skip data points to declutter the
display, change the level of plan views, toggle visibility, and remove the display.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_FlowPlanViewControl__FILE


Observations
Point Data Displays
Track Displays

Point Data Displays
You can make plots of point data such as meteorological surface (METAR) and synoptic surface weather station observations.

For more information see Getting Started: Displaying Surface and Upper Air Point Data . You can change the plot layout with the Station Model
Editor. You can plot non-meteorological point data as well. The image below depicts the locations of earthquakes, sized by magnitude and colored
by depth.

Track Displays
Aircraft and drifting buoy tracks can be plotted to show the path of the sensor. You can also plot the track data as observations along with the
track.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Observations__obs
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Observations__track
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Point__FILE
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_StationModelEditor__FILE


 
Track display showing observations along the track and an airplane indicator at the end



 
The Globe display

 
Two Panel Map Display

Miscellaneous Display Types
Globe Display
Multi-Panel Display
Omni Display

Globe Display

The illustration shows a McIDAS-V globe display of the earth, with AVN numerical weather prediction model output of mean sea level pressure
(as color-shaded image and contour lines) and 50 m/s wind speed isosurfaces showing the jet streams. The upper vertical scale is set to 32,000.

For more about this display and how to make it, see Getting Started: Using the Globe Display.

Multi-Panel Display
You can create multi-panel map and globe displays through the File->New Display Tab (Window)->Map (Globe) Display-># panel(s) menu.
Below is an example of a two panel display comparing visible and IR satellite imagery.

Omni Display
The Omni display is a VisAD Spread Sheet, loaded with the parameter selected and its coordinates and units. The Spread Sheet is used to create a

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Miscellaneous__globedisplay
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Miscellaneous__multipanel
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Miscellaneous__omnidisplay
http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_Globe__FILE


display where you have complete control over which coordinates are the axes, how it is colored, and so on. See more in the Omni Control.

For use of the Spread Sheet, see the VisAD Spread Sheet document at http://www.ssec.wisc.edu/~curtis/ss.html.

http://www.ssec.wisc.edu/mcidas/doc/mcv_guide/working/combine_all.php#TARGET_OmniControl__FILE
http://www.ssec.wisc.edu/~curtis/ss.html

