[Go to Previous] [Go to Next]

Plugin Creator

The Plugin Creator, accessed through the Tools->Plugins->Create... menu item in the Main Display window, allows you to create new plugins. The Plugin Creator is broken up into three tabs: Resources, Excludes, and Properties.

A plugin is a Java JAR file that contains a set of resource files. These resource files can include things like the color tables you have created, projections, layout models, formulas, etc. The plugin manager supports both adding in a whole file (e.g., all of the color tables you have created) as well as adding in individual resource objects (e.g., a specific color table you have created).

Adding Resources

To add in a file, use the File->Add File menu item. The file dialog will come up listing the contents of your local McIDAS-V directory. This is where all of the various resources that are created are stored. For example, if to include all of the color tables, add the colortables.xml file. Use the File->Add Preferences menu item to add your User Preferences to a resource, such as a bundle you are creating or editing. Individual resources can be added through the File->Add Resource menu item. Resources can also be added through the various resource editors (e.g., Jython Editor, Parameter Defaults, Parameter Aliases). Typically this facility is available through the editor's File menu.

Resources List

Each file, preference, and resource that is added into the Plugin Creator is listed under the Resources tab:

Image 1: Resources Tab of the Plugin Creator
Image 1: Resources Tab of the Plugin Creator

Resources can be deleted by clicking the Delete a plugin button button or by pressing the delete key when a resource is selected.


The Excludes tab allows for the exclusion of system default resources. For example, in the below image, Color tables and Map projections are excluded. When the plugin that is defined here is loaded into McIDAS-V, the excludes will result in only the Color tables and Map projections that are defined in this plugin to be used.

Image 2: Excludes tab of the Plugin Creator
Image 2: Excludes Tab of the Plugin Creator

The Properties tab allows the user to overwrite different properties McIDAS-V uses. This listing is broken up into three categories: User Interface, Data, and Miscellaneous.

Image 3: Properties Tab of the Plugin Creator
Image 3: Properties Tab of the Plugin Creator

The User Interface category primarily affects the aesthetic appearance and basic usability in McIDAS-V. These options allow you to decide if you want to do the following:

The Data category affects what sources of data you will have available when selecting data in the Data Sources tab of the Data Explorer. These options allow you to decide the following:

The Miscellaneous category affects many features of McIDAS-V. While these options affect many things that go on 'under the hood' of McIDAS-V, there is a great deal that can be changed with these options. These options allow you to decide the following:

Writing the Plugin

To write the plugin, click the Write Plugin button button. If you have not specified a plugin file name, (i.e., a .jar file) you will be prompted. If you also want to install the plugin to your local McIDAS-V plugins area, select the Install checkbox. You can choose a specific location to save the plugin to by selecting the Browse button button, or by typing the file path into the field. Note: You will need to restart McIDAS-V for any installed plugins to take effect.


Many of the menu items seen utilizing the Plugin Creator tool are unique to this menu item.

The File menu has these unique options:

[Go to Previous] [Go to Next]