McIDAS-V Workshop

Introduction to McIDAS-V
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V| [The MeiDAS- Bridge provides  way 1o load data from an active MelDAS-X session (version 2007 or later) inta
MCIDAS-V.

To start the McIDAS-X bridge listener, yoe MCLISTEN START in a running McIDAS-X sessian on your lacal machine. To
connectto the listener fom MIDAS-Y, Select the "McIDAS-X Bridge” data source inthe Data Selector, and click the "Ad
Source” button to connectto the defaults of localhost listening on port 8080, IfMCLISTEN START was not un on the
localhost listening on port8080, an sior boxwill say that the "Connection to McIDAS-X Bridge Listener at
localhost:8080 falec

Ifthe MeIDAS-X bridge listener is running, clicking*Add Sourcewill bring up the Field Selector and list the Frame
Sequence s the available Field. Clickthe circls o the lef of 'Frame Ssqusnce” to expand that list and list all available
frames in the connected McIDAS-X session. Sslect a frame (or the sniire Frame Sequence), and dlick the *Create
Display’ button. This wil create 3 new display in the Layers tab of the Data Sslector mirmoring the McIDAS-X frame(s)
selected. You can enter MEIDAS-X commands in theCommand Line” tex enty box at the botiorm of the Layers tab,
‘This will un McIDAS-3 commands, and the MelDAS-V display in the Layers tab will update to reflectthe results

To import these MeIDAS-X frames into the current MeIDAS-Y 3D panel, select the Settings tab and check the "Display.
data in main 3D panet® option. This will import allof the navigated McIDAS-X frames into the 3D panel.

Host: localnost

Add Source





Loading Satellite Images and Loops
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1. Click on the left most menu button on the Main Window toolbar to go to the Data Explorer.  Select the Satellite Imagery source from the Data Explorer and connect to the unidata2.ssec.wisc.edu server with the dataset EAST.  Choose the GOES 12 full disk Image Type and select an absolute time of 14:45 UTC from the previous day.  Change the Magnification to -4, -4 and click Add Source.  The default of McIDAS-V is to have the Create Display checkbox on, which will automatically load the data and create the display.  The most recent 0.65 μm image with a magnification of -4, -4 is displayed in the satellite projection, as the default is to use the projection of the most recent layer added.
2. Use the zooming and panning controls (in the toolbar to the left of the image) to inspect the image.  Reset the display projection by clicking on the house icon below the zooming buttons on the left toolbar.  When you are finished remove the satellite image layers from the display by Edit ->Remove All Layers.  Go to the Data Sources tab, alter the parameters so you are displaying the three latest 0.65 μm channel GOES 12 southern hemisphere images with a Magnification of -4, -8 and create the display (Data bundle 2 has been set up to load this data).  Use the Time Animation Controls to start the loop.  Use the zooming and panning controls while the loop is running.
Loading Level II radar images:  3D reflectivity swath, RHI and Volume Scan
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1. Start by removing the data and layers from the previous display by selecting Edit ->Remove All Layers and Data Sources (or by clicking the scissors toolbar button in the Main Window).  Select the Radar Imagery ->Level II ->Remote source and select a station. Select the 6 most recent images and click Add Source.  In the Fields panel of the Field Selector tab select the Reflectivity entry.  The available displays will show up in the Displays panel.  Choose the Radar Sweep View in 2D and click Create Display.  Return to the Field Selector tab in the Data Explorer and create the Radar Sweep View in 3D display.  There will be no difference between the two layers until you rotate your view away from the top.  Turn looping on and off as you rotate the 3D reflectivity image.
2. Turn the looping off and return to the Field Selector tab of the Data Explorer.  Add a RHI layer to the current display.  Use the left-mouse button drag on the colored square to change the position of the RHI line.  The 2D display in the Layer Controls tab will automatically update as you move the RHI line.  The Autorotate RHI button in the Settings tab of the Layer Controls will loop the reflectivity azimuth in both the 2D and 3D displays.  
3. Remove all layers and add the Volume Scan (all sweeps).  Turn off the Use Default checkbox in the Times tab of the Field Selector tab and select only one image time before clicking Create Display.  Use the zooming and rotating controls to observe the 3D view of all radar sweeps.

Display Point Observations around the world: Surface
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1. Remove all layers and data sources from the previous display.  Select the Point Observations -> Surface Plot source and connect to adde.ucar.edu (alternatives: adde.cise-nsf.gov, stratus.al.noaa.gov, or weather2.admin.niu.edu) with the data type Surface (METAR) Data.  Select a group of times from the absolute time tab.  When choosing absolute times for the first time, McIDAS-V needs to query the ADDE server for the times, which may take some time.  To select more than one time, use Control-Click or Shift-Click.Choose the layout model Observations>METAR and add the source.  Make sure the Create Display checkbox is on.  The default display is a world projection with surface plots from around the world.  As you zoom in you will see more stations appear in the plot.
2. Change the layout model to one of the other Observations choices (i.e. Temperature).  Then, turn off the decluttering option on the Layer Controls tab to see every station across your current observing area that reported a temperature observation at the selected times.
Display Point Observations around the world: Upper Air
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1. Remove the surface observations layer from your current display by clicking on the trashcan icon in the Legend.  Change your projection to Australia and turn off Auto-set Projection.  Return to the Data Sources tab of the Data Explorer by selecting Display ->Create Layer from Data Source from the main menu bar.  Select the Point Observations ->Upper Air ->Plot source and connect to adde.ucar.edu with the data type Upper Air Data (alternatives: adde.cise-nsf.gov, stratus.al.noaa.gov, or weather2.admin.niu.edu).  Select the most recent time and add the source without creating the display.

2. In the Field Selector, select 850 mb in the Level tab and create your display.  Notice zooming in and panning around will again add more stations if available.
3. Pan around and pick a station to display a sounding.  Select the Point Observations ->Upper Air -> Soundings ->Remote source from the Data Sources tab.  Connect to adde.ucar.edu with the Group RTPTSRC (alternatives: adde.cise-nsf.gov, stratus.al.noaa.gov, or weather2.admin.niu.edu).  Select an available time and click on your station in the main window to see if a sounding is available.  Use the zooming and panning buttons below to find a station.  Available soundings will show up in the Selected Soundings box.  If more than one is available for your station, select the most recent station and add your source without creating the display.  Under the Displays tab of the Field Selector, you have the option to choose which type of thermodynamic diagram to display (Skew-T, Stuve, Emagram).

4. The sounding will show up in a 2D display in the Layer Controls tab along with a list of thermodynamic parameters.  As you move the mouse over the sounding, the thermodynamic parameters will update.  The temperature and dew-point traces can be modified via the cursor. Press the left button on the first data-point to be modified and drag it horizontally along an isobar to the desired position, then move the pointer diagonally along an isotherm to keep the data-point at the desired position and to pick-up the next data-point. Repeat until done and then release the mouse button.  To reset the sounding, go to Edit ->Reset Sounding in the main menu of the Layer Controls tab.  You can also choose to display the parcel path or vertical temperature on the sounding.  If you turn off or remove the upper air data from the Legend of the Main Window, you will see a square box on the map displaying the location of the sounding.
5. Remove all layers and data and turn the Auto-set Projection option.  Select the Point Observations ->Wind Profiler source from the Data Sources tab.  Connect to adde.ucar.edu with a 30 minute interval (alternatives: adde.cise-nsf.gov, stratus.al.noaa.gov, or weather2.admin.niu.edu).  Select a group of three or more stations across the central US and load the four most recent times.  Opening up the tree of the Fields tab in the Field Selector will allow you to choose to display each profiler individually, or as a group if you leave Profiler winds selected.  Display all stations as a Time/Height Display.  The data will be displayed in the 2D display in the Layer Controls tab.  It may be necessary to expand the tab by clicking on the two down arrows on the bottom left of the display.  The four most recent times (if available) will be displayed, with the latest data on the left.  This can be switched by turning off the Latest Data on the Left checkbox.  Change the display to different stations using the Stations pull down tab.  Modify the windbarb size as well as the vertical interval to see how the display changes.
6. Return to the Field Selector and create a 3D view display.  Zoom out of the display to see all of the stations, as the default zooms in on one of the stations.  Rotate the view so you are looking at the profiler displays from the south.  Use the Time Animation Controls to loop through the selected times and observe how the profiler displays change.  The windbarb size and vertical interval can be modified in the Layer Controls tab.
Display Gridded data: 2D
1. Remove all layers and data.  Select the General ->Catalogs source from the Data Sources tab.  Select and add the IDV catalog ->Unidata IDD Model Data ->UCAR (motherlode) ->Global Forecast System Model ->NCEP GFS Northern Hemispheric 381 km ->Latest source.  In the Field Selector select the 2D Pressure reduced to MSL @msl and display six times as a Color-Shaded Plan View.  In the Layer Controls turn on the option to Shade Colors.  Overlay the same parameter but as a Contour Plan View.  Change the color table of the contours to Solid ->Black.  
2. Remove all layers and data and select the Latest NCEP GFS Global 1 degree source.  Select and display the 2D Downward short wave flux @ surface and the 2D Downward long wave flux @ surface for the next 24 hour period.  Shade both sets of contours and use the checkbox toggles in the Legend to turn each layer on and off to observe the differences between the two.  
Gridded Data:  2D
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Gridded Data:  3D
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Display Gridded data: 3D
1. Remove all layers from the display.  Select and display the 2D Geopotential height @ surface valid for 6Z tomorrow as a 3D Topography display.  Add the 2D Pressure reduced to MSL @ surface and display it as a 3D Color-Shaded Contour Plan View Over Topography.  You will be prompted for the Topography field.  Select the 2D Geopotential height @ surface field from the selector, the 6Z time for tomorrow, and press OK.  The 2D field will be displayed as topography.  Shade the colors, and use the zooming and rotating controls to see the display in 3D over the world.

2. Reset the display projection and add the latest NCEP NAM CONUS 80 km grid and display tomorrow’s 6Z 3D Absolute Vorticity @ isobaric as a 3D isosurface (Data bundle 5 is set up to load this data).  Zoom in over the US and rotate the display to see the absolute vorticity isosurface over the continental US.  The Isosurface Value in the Layer Controls can be used to change the value of absolute vorticity to be displayed.
Create a 3D globe display of jet stream winds and 2D surface pressure from grids:
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1. Remove all layers.  Add a one panel globe display tab by selecting File ->New Display Tab -> Globe Display ->One Pane.  In this display tab, load the most recent GFS Global 1° grid (General ->Catalogs ->Unidata IDD Model Data-> UCAR ->GFS).  Display three 2D Temperature at Surface grids every six hours up to the most recent time as a color-filled contour plan view.  Then, overlay it again as contours.  Next, display the 3D derived wind speed grid as a 3D isosurface for the same times.  

2. Use the Layer Control panel to change the contour interval for temperature to 5K.  Change the World Coastlines map color to RGB 0-153-204, and the World Political Boundaries map color to RGB 0-255-255.  Start looping and turn on the Auto rotate view option (View ->Viewpoint).

3. Use the Zooming and Panning controls to observe the data from different views.  Depending on preference, it might help to turn the Auto rotate view option off.

Loading data using the McIDAS-X Bridge:  Displaying non-navigated data
1. Start a McIDAS-X session with 10 frames and start the listener by entering in the command: MCLISTEN START.  Return to McIDAS-V and remove all layers and data.  Select the McIDAS-X Bridge source and connect to localhost on port 8080.  In the Fields panel of the Field Selector tab you have the option to select all available McIDAS-X frames or one single frame.  Select the Frame Sequence and create the display as a McIDAS-X Image Display.  This will create a new display in the Layer Controls tab of the Data Explorer mirroring the McIDAS-X frames selected. Enter McIDAS-X commands in the "Command Line" text entry box at the bottom of the Layer Controls tab. This will run McIDAS-X commands and the McIDAS-V Layer Controls tab display will update to reflect the results. 
2. Run the command SFCMG EGLL DAY=15/Oct/07 TIME=23 DAT=M/M.1.  This will plot a 24-hour surface meteorogram for London/Heathrow Airport, ending at 23 UTC on 15 October 2007 using data from position 1 of the M/M dataset.
Loading data using the McIDAS-X Bridge: Satellite Images

1. Display a loop of MSG full disk satellite images in band 4:  IMGDISP A/A.1 BAND=4 REP=9  Use the Time Animation Controls to loop through the 10 McIDAS-X frames in the Layer Controls tab.  By default, McIDAS-V does not automatically import McIDAS-X frames into the McIDAS-V 3D panel because non-navigated frames can not be displayed.  To import these McIDAS-X frames into the current McIDAS-V 3D panel, select the Settings tab and check the Display data in main 3D panel option. This will import all of the navigated McIDAS-X frames into the 3D panel. 
2. If you receive an error message: Selected image(s) not available, it is due to the fact that McIDAS-V will only import navigated frames.  Frame 1, consisting of a surface meteorogram, is a non-navigated display.  View the McIDAS-V main window to see the McIDAS-X images in the 3D display.  It is recommended that you do not use the maps from McIDAS-X, as their look diminishes as you zoom in with the 3D display.  To turn the option off to import graphics, uncheck the Graphics box under the Data section of the Settings tab in McIDAS-X layer controls.  Use the zooming and panning controls, as well as the time animation controls to loop the display of images from McIDAS-X.
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Summary of McIDAS-V Controls
McIDAS-V Main Window… shows the Display tab with legend, the main menu bar, and the main toolbar.  The display panel shows a world map in the default colors with a 3D wire frame box.
File offers…
New Display Window opens a new display window.

New Display Tab opens a new display tab.

Open File…opens a file on disk.

Save As…saves a file on disk.

Save Bundle saves a bundle as a favorite or as the default bundle.

Exit exits McIDAS-V.

Edit has…
Remove lets you choose to remove all layers, all data, or all layers and data.
Preferences allows you to edit standard settings for McIDAS-V.
Display has the options…
Create Layer from Data Source takes you to the Sources tab of the Data Selector.
Layer Controls… takes you to the Layers tab of the Data Selector.
Add Range Rings adds concentric circles labeled by distance over a specified point.

Add Range and Bearings shows the distance, azimuth, and back azimuth of a great circle line connecting two positions on the Earth's surface.
Draw Transect... lets you view, create and modify transect lines.
Draw Freely... brings up an editor to draw polygons, lines, shapes and text.
Add Location Indicator displays a configurable axis and bearing point.
Plot Location Labels plots locations such as stations, states, counties, geographical features, and countries.

Reset Map Layer to Defaults resets the map layer to default, or redisplays the map if it has been deleted.
Tools offers…


Color Tables shows an editor to manage predefined and user created color tables.

Parameters shows an editor for parameters, aliases and plot configurations.

Projections shows an editor for existing map projections and existing views.

Formulas shows an editor for creating, editing, importing and exporting formulas.

Plugins shows a manager for listing, installing and managing plugins.
History shows a list of the previously used sources and layers.
Bundles lets you manage and load your favorite bundles.
Window has…

Show Data Explorer brings the Data Explorer to the front.

Next Display brings the next display tab/window to the front.

Previous Display brings the previous display tab/window to the front.

Select Display… lets you choose which display tab/window to bring to the front.
Help has the options…

User’s Guide goes to the top-level user guide page.

Getting Started goes to a quick overview of McIDAS-V.

Show Help Tips brings up the help tips window.
Show Console brings up a console window with error messages and other text output from McIDAS-V.
Support Request Form brings up a form allowing you to send a support request to the McIDAS Help Desk.

Release Notes will display the release notes in a future version of McIDAS-V.

About McIDAS-V provides information about this version of McIDAS-V.

View lets you select…

Displays lists the current layers in the display tab/window as well as…


Legend shows the legend in a separate window.


Remove All Displays removes all layers in the display tab/window.
Visibility Animation cycles through each layer in the display tab/window one at a time.
Capture lets you capture the current display tab/window as a JPEG image, send it to the printer, or capture a QuickTime movie.

Show turns on/off different display options.

Viewpoint changes the point of view.

Color changes the background and foreground colors of the display panel.
Saved State allows you to save the current view state (e.g. projection, colors, viewpoint) and load previously saved states.

Full Screen shows the current panel in full screen mode.
Animation Timeline brings up a window showing the animation time set and the times of different layers.
Properties show the properties of the panel, allowing you to set aspect ratio, vertical scale, flags, color, etc.

Projections has…

Predefined allows you to select system and user defined projections.

From Displays lists the native projections from each layer being shown.
History lists the projections that have been used in the panel display, allowing you to go back to prior projections.
New/Edit… brings up the projection editor to edit existing map projections.

Use Displayed Area resets the projection to that of the current zoom level.

Go to Address changes the projection to a given address, city, zip code, etc.
Auto-set Projection toggles the behavior of automatically setting the projection to that of the most recent layer that has been added.
Share Views controls whether sharing is turned on or off for the selected panel.  If sharing is turned on, view point and projection changes are shared with any other views that also have sharing turned on.

Set Shared Group allows you to set each panel to a specific group.  Each group will have their own shared views.

McIDAS-V Data Explorer… shows the Data Sources, Field Selector, and Layer Controls tabs.

Data Sources is used to list the data sources available as well as their individual data choosers.

Field Selector is used to list the loaded data sources and available fields, subset (time and space) the field and create layers.


Layer Controls is used to list the layer controls for each layer in the display panel.
Zooming, Panning, and Rotating Defaults
	Zooming
	Panning
	Rotating

	
	Mouse
	

	Shift-Left Drag: Select a region by pressing the Shift key and dragging the left mouse button.

Shift-Right Drag: Hold Shift key and drag the right mouse button. Moving up zooms in, moving down zooms out.
	Control-Right Mouse Drag: Hold Control key and drag right mouse to pan.
	Right Mouse Drag: Drag right mouse to rotate.

	
	Scroll Wheel
	

	Scroll Wheel-Up: Zoom Out.

Scroll Wheel-Down: Zoom In.
	
	Control-Scroll Wheel-Up/Down: Rotate clockwise/counter clockwise.

Shift-Scroll Wheel-Up/Down: Rotate forward/backward clockwise.

	
	Arrow Keys
	

	Shift-Up: Zoom In.

Shift-Down: Zoom Out.
	Control-Up arrow: Pan Down.

Control-Down arrow: Pan Up.

Control-Right arrow: Pan Left.

Control-Left arrow: Pan Right.
	Left/Right arrow: Rotate around vertical axis.

Up/Down arrow: Rotate around horizontal axis.

Shift-Left/Right arrow: Rotate Clockwise/Counterclockwise.











