
McIDAS-X GOES-R Tutorial 
November 2016 (software version 2016.2) 

 

 

In existence since 1973, McIDAS (Man computer Interactive Data Access System) is a suite of sophisticated 

software packages that perform a wide variety of functions with satellite imagery, observational reports, 

numerical forecasts, and other geophysical data. Those functions include displaying, analyzing, interpreting, 

acquiring and managing the data. 

 

McIDAS-X is supported for the current GOES GVAR and upcoming GOES-R satellite series (currently 

estimated as being in service until 2036), with no end date in sight. 

 

In this McIDAS-X tutorial, some exercises will be completed using different methods of data access:  local data 

files and real-time access to default remote servers.  If you have access to your own real-time ADDE servers, 

you may also use those, but be aware that different server configurations may make the explanations in this 

document not quite applicable to all data that you may load. 

 

This tutorial assumes that you have McIDAS-X installed on your machine, and that you know how to start 

McIDAS-X.  

 

The data herein is test data only, and the Government is furnishing the data in as-is condition. The user bears all 

responsibility for inspecting such data prior to use, and for the manner in which it utilizes the data. The 

Government makes no warranty of any kind with respect to this data. 
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ABI Background 

 
 

 

Image from J. Gerth, CIMSS.   

 

 

There will be a 60-fold increase in the amount of data sent by the ABI compared to GOES-13 through -15.  The 

ABI on GOES-R acquires a full-disk image 5 times faster than the imager on GOES-13 through GOES-15.   

The spatial resolution on the ABI compared to present GOES increases by a factor of 2 in both horizontal 

directions.  There are about 3x more spectral bands on GOES-R.  The cubes represent the data volumes from 

present GOES, in dark orange, and GOES-R, in beige.   The combination of increased resolutions means a 60-

fold increase in data; about a terabyte of data will flow daily from GOES-R! 
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Image from Tim Schmit, Mat Gunshor and Scott Lindstrom (Satellite Foundational Course – GOES-R)  

 

 

 

There are two main scanning modes for GOES-R, Mode 3 and Mode 4. The most likely default mode is Mode 

3, where one FD image is scanned, 3 CONUS sectors are scanned, and 30 30-second mesoscale sectors are 

scanned in each 15 minutes.  Those 2 mesoscale sectors could be split in two locations so you'd get 2 separate 

views with 1-minute imagery during the 15 minutes. 
  

Mode 4 is the highest data rate for GOES-R's ABI and results in a full disk every 5 minutes.  This might be used 

if multiple high-impact weather/volcanic events are happening, say a volcano in Chile, strong hurricanes over 

the Atlantic or Pacific basins, and high-impact severe weather over the central United States. 
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Image from Tim Schmit, Mat Gunshor and Scott Lindstrom (Satellite Foundational Course – GOES-R)  

 

 

 

 

This comparison table shows the improvements in spectral, spatial and temporal coverage that GOES-R has 

over its predecessors. 
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GOES-R ABI Band List  
 

 

 

 

 

 

Creating Local Datasets 
 

You can access GOES-R Series netCDF format files with the IMG* commands by using DSSERVE to assign a 

dataset name to the files. When doing so, specify "ABIN" in the format parameter, TYPE=IMAGE, and the 

directory and file masks in the DIRFILE keyword. The files must be mission-standard Level 1b or Level 2 files 

in netCDF-4 format, like those from NOAA CLASS or from the GRB data stream after they've been decoded 

with CSPP Geo or other software. The names of files should look similar to ABI-L1b-RadC-

M3C01_G16_s2015229195720.nc (current CSPP Geo naming convention) or OR_ABI-L1b-RadC-

M4C16_G16_s20151702215532_e20151702220362_c20151702220394.nc (GOES-R Ground System naming 

convention). 

 

1. Create a local dataset to access the ABI netCDF files on your local machine in the Data/ABI/NetCDF 

directory.  

   

OR_ABI-L1b-RadC-M3C02_G16_s20162491825085_e20162491827460_c20162491827483.nc 

OR_ABI-L1b-RadC-M3C14_G16_s20162491825085_e20162491827460_c20162491827489.nc 

OR_ABI-L2-TPWC-M3_G16_s20162152257163_e20162152259535_c20162152301341.nc 

 

a. Run the DSSERVE command to access the Level 1b netCDF imagery files. 

 

DSSERVE ADD ABI/CONUS ABIN TYPE=IMAGE DIRFILE= '<local-

path>/Data/ABI/NetCDF/*RadC*' 
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b. Use the IMGLIST command to list the most recent image in the dataset. 

 

IMGLIST ABI/CONUS 

 

c. Datasets can be organized however the user chooses.  Run DSSERVE to include all of the files in the 

data directory. 

 

DSSERVE ADD ABI/DATA ABIN TYPE=IMAGE DIRFILE= '<local-path> 

/Data/ABI/NetCDF/*' 

 

d. IMGLIST can list the image directory and band information with the FORM=ALL keyword.  Your 

IMGLIST command should match the image. 

 

IMGLIST ABI/DATA.ALL FORM=ALL 

 

 
 

 

e. Another IMGLIST keyword, FORM=BAND, lists the band and resolution without the file’s expanded 

listing. 

 

IMGLIST ABI/DATA.2 BAND=2 FORM=BAND 
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2. The data can be displayed and inspected with the IMGDISP and IMGPROBE commands. 

 

a. Run this series of commands to display BAND 2 of an ABI Level 1b file, display a navigated map over 

the image, place the cursor at the center of the image and run an IMGPROBE command to inspect the 

pixel values under the cursor. 

 

IMGDISP ABI/CONUS BAND=2 MAG= -16 

MAP X X LALO 

PC C 

IMGPROBE MODE=N 
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b. Display BAND 14 with a yellow map on a new frame which is automatically displayed with the 

SF=YES keyword.  Move the cursor to a latitude/longitude point (29° N, 91° W), and list the statistics of 

the pixel values under the cursor. 

 

IMGDISP ABI/CONUS 2 BAND=14 LATLON=29 91 SF=YES ; MAP X 3 

PC E 29.4 90.7 ; IMGPROBE STAT BOX TEMP   
 

Move the cursor around and press alt-g or the right mouse button over desired features.  Be sure to quit 

each interactive IMGPROBE command with Alt-Q or by clicking the right and center mouse buttons. 

 

c. Display the Total Precipitable Water Level 2 product file in the local dataset by specifying the absolute 

position number of the data.  Plot a map and inspect the data in the middle of the frame with the 

IMGPROBE command. 

 

IMGDISP ABI/DATA.1 3 SF=YES ; MAP 

PC C ; IMGPROBE 

 

 

Accessing Remote ADDE Datasets 
 

3. To access a remote ADDE server with Level 1b ABI netCDF image files, follow these steps.   

 

a. Modify your client routing table with the DATALOC command so that commands requesting data from 

a dataset in the group ABIL1B are routed to the SSEC remote server with the IP address 

PAPPY.SSEC.WISC.EDU. 

 

DATALOC ADD ABIL1B PAPPY.SSEC.WISC.EDU  

 

b. List all datasets available in the ABIL1B group with the DSINFO command. 

 

DSINFO ALL ABIL1B 

 

c. Run IMGLIST commands to see the available data in the datasets.  Using a position number of .-2 will 

list the 3 most recent times in the dataset.  Not specifying a position number will default to listing the 

most recent time. 

 

IMGLIST ABIL1B/CONUS.-2 FORM=BAND 

IMGLIST ABIL1B/FD FORM=ALL 

 

d. Run the following list of commands to erase the frames and display a loop of 4 BAND 9 CONUS 

images centered on Madison with a map.  Use the images in positions 5 through 8 and the REFRESH 

keyword to display a map on each frame.  Then set the loop sequence with the LS command and 

animate the loop. 

 

ERASE X 1 4 

IMGDISP ABIL1B/CONUS.5 1 REP=4 BAND=9 STATION=KMSN SF=YES  

REFRESH='MAP GRA=(GRA) IMA=(IMA)' 

LS 1-4 

Alt-L (Press Alt-L again to stop the looping.) 
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e. Run the following list of commands to erase frames 1-4 and fill the frames with the four most recent 

BAND 2 times in the full disk dataset and a map.  The LATLON= keyword centers the image at 20° N, 

80° W.  The MAG= -10 blows down the data by 10.  

 

ERASE X 1 4 

IMGDISP ABIL1B/FD 1 ALL=1 4 BAND=2 MAG= -10 LATLON=0 90  

REFRESH='MAP GRA=(GRA) IMA=(IMA)' 

Alt-L (Press Alt-L again to stop the looping.) 

 

4. To access a remote ADDE server with Level 2 ABI netCDF product data, follow these steps. 

 

a. Add the group name to modify your client routing table with the ABIL2 group that exists on the server 

PAPPY.SSEC.WISC.EDU. 

 

DATALOC ADD ABIL2 PAPPY.SSEC.WISC.EDU 

 

b. Run DSINFO to find the available dataset names.  In this example, use “I” instead of “ALL” to list only 

the image datasets available in the ABIL2 group. 

 

DSINFO I ABIL2 

 

 
 

c. Run IMGLIST with FORM=ALL for the expanded image list for the Cloud Top Temperature product. 

 

IMGLIST ABIL2/ACHT FORM=ALL 
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d. Display a loop of the Cloud Top Pressure product with a map. 

 

ERASE X 1 4 

IMGDISP ABIL2/CTP.4  1 REP=4 LAT=29 91 REFRESH='MAP GRA=(GRA) IMA=(IMA)' 

Alt-L (Press Alt-L again to stop the looping.) 

 

e. The DSI (Derived Stability Indices) product has multiple bands.  List the bands and display BAND 9 

which is the CAPE product (Convective Available Potential Energy).  Use Alt-D to probe the data (Alt-

D is a shortcut to execute IMGPROBE LIST POINT MODE=N). 

 

IMGLIST ABIL2/DSI FORM=BAND 

SF 5 ; IMGDISP ABIL2/DSI BAND=9 ; MAP 

Alt-D 

 

 

Using Other IMG* Commands with GOES-R Data 
 

The ADDE ABIN server reads netCDF files directly to do IMGLIST and IMGDISP display commands.  

IMGCOPY uses the ADDE ABIN server to read the netCDF file and to outputs a McIDAS AREA file. 

 

5. Use the ADDE commands to copy an ABI netCDF file to a McIDAS AREA file.   

(The following exercises will overwrite AREA0001 through AREA0009 files on your local machine.) 

 

a. Assign the MYDATA/TEST-IMAGES data to all of the AREA files on your local workstation.   

 

DSSERVE ADD MYDATA/TEST-IMAGES AREA 1 9999 "ALL AREA FILES 

 

b. Create the alias TI for the MYDATA/TEST-IMAGES dataset. 

 

AKA ADD TI MYDATA/TEST-IMAGES 

 

c. Copy the band 2 image from a local netCDF file to a local AREA file. 

 

IMGCOPY ABI/DATA.2 TI.1 BAND=2 STATION=KMSN 

 

d. Copy the band 14 image to a local AREA file at full resolution and list your new local AREA files. 

 

IMGCOPY ABI/DATA.2 TI.2 BAND=14 SIZE=SAME 

 

e. Copy a remote SST product file and list your new local AREA file. 

 

IMGCOPY ABIL2/SST TI.3 LAT=0 89 SIZE=960 1280 

IMGLIST TI.1 3 FORM=ALL 

 

f. Display the AREA files. 

 

IMGDISP TI.1 6 REFRESH='MAP GRA=(GRA) IMA=(IMA)' 

IMGDISP TI.2 7 LAT=33 77 MAG=-2 REFRESH='MAP GRA=(GRA) IMA=(IMA)' 

IMGDISP TI.3 8 MAG=-2 REFRESH='MAP X X LALO GRA=(GRA) IMA=(IMA)' 
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g. Use the SF command to show each frame and inspect the data with the IMGPROBE command. Be sure 

to quit each IMGPROBE command with Alt-Q or by clicking the right and center mouse buttons. 

 

SF 6 ; IMGPROBE 

IMGPROBE HIST BOX BRIT 

 

h. Use the cursor size and IMGPROBE to inspect calibrated values on the IR and product images. 

 

CUR 11 11 

SF 7 ; IMGPROBE STAT BOX TEMP 

SF 8 ; IMGPROBE HIST LINE SST OUTL=YES 

 

6. Use IMGREMAP to read the local netCDF file and create a remapped product AREA file. 

 

a. Create a rectilinear remapped product image at 4 km resolution.   

 

IMGREMAP ABIL1B/CONUS.1 TI.4 PRO=RECT LAT=29 91 BAND=12 SIZE=480 640 RES=4 

 

b. Display the new rectilinear AREA file. 

 

IMGDISP TI.4 9 SF=YES ; MAP X X LALO 

  

c. Use the PRO=DEST keyword in the IMGREMAP command to use an AREA file as the domain for a 

remapped product image. 

 

IMGREMAP ABIL2/ACM TI.4 PRO=DEST 

 

d. Now the cloud mask data will be in the product image AREA file. 

 

IMGDISP TI.4 10 SF=YES ; MAP X X LALO 

 

7. IMGOPER is used to perform mathematical operations on images.  The domain of the source imagery must 

be the same for the operations to work correctly.  The source imagery can reside on remote servers, local 

ABI netCDF files or local AREA files.  Use IMGOPER to create a temperature difference image. 

 

a. Create a temperature difference image from two Land Surface Temperature product files on an ADDE 

server.  The output values are the product name DIFF and multiplied by 10.  The product values from -

50 to 50 are scaled from brightness 0 to 255. 

 

IMGOPER ABIL2/LST.4 ABIL2/LST.9 TI.5 STA=KSTL SIZE=480 640 UNIT=LST   

FORM=ADD COEF=1 -1 SCALE=-50 50 0 255 MCON=10 PROD=DIFF 

 

b. Display, draw a map, place the cursor, and probe the data with 4 concatenated commands. 

 

IMGDISP TI.5 11 SF=YES ; MAP ; PC C ; D 

 

c. Probe the data with the interactive IMGPROBE command and note the DIFF values in the image. 

 

IMGPROBE 
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Problem Set 
 

Create an Airmass RGB jpeg image with the IMGOPER, IMGDISP, COMBINE and FRMSAVE 

commands for the most recent image in the ABIL1B/RGB dataset. 

 

EUMETSAT has created many different useful RGB composites for their SEVIRI instrument, and many 

can be applied to GOES-R.  (http://oiswww.eumetsat.org/IPPS/html/MSG/RGB/) 

 

Airmass is an RGB composite based upon data from infrared and water vapor channels. It is designed and 

tuned to monitor the evolution of cyclones, in particular rapid cyclogenesis, jet streaks and PV (potential 

vorticity) anomalies. Due to the incorporation of the water vapor and ozone channels, its usage at high 

satellite viewing angles is limited. The Airmass RGB can be composed from a scaled combination of 

GOES-R bands 8 (6.19 um high-level water vapor), 10 (7.34 um lower/mid-level water vapor), 12 (9.61 um 

ozone), and 14 (11.2 um longwave infrared). 

 

From http://www.eumetrain.org/RGBguide/recipes/recipe_Airmass_RGB.pdf: 

 

 

Color beam  Channel (difference)  Range [K]  

Red  WV6.2 – WV7.3  -25  0  

Green  IR9.7 – IR10.8  -40  +5  

Blue  WV6.2 inverted  243  208  
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Problem Set Solution 

 
1. Run the following commands to create and display the scaled products for the RGB combination. 

 

IMGOPER ABIL1B/RGB ABIL1B/RGB TI.6 BAND=8 10 COEF=1 -1 MAG= -10 LAT=0 89 

UNIT=TEMP MISS=NONE SCALE=-25 0 0 255 

IMGOPER ABIL1B/RGB ABIL1B/RGB TI.7 BAND=12 14 COEF=1 -1 MAG= -10 LAT=0 89 

UNIT=TEMP MISS=NONE SCALE=-40 5 0 255 

IMGOPER ABIL1B/RGB TI.8 MAG= -10 BAND=8 LAT=0 89 UNIT=TEMP SCALE=243 208 0 255 

IMGDISP TI.6 12 REP=3 SF=YES 

 

2. Use COMBINE to combine the displays in three frames into an RGB image in memory with the 

VIEW=NO keyword.  FRMSAVE will convert the image into a jpeg file. 

 

COMBINE 0 12 13 14 VIEW=NO 

FRMSAVE 0 AIRMASS_RGB TYPE=COMBINE 

 

FRMSAVE will list the output file path where the jpeg file is created.  Go to that directory and display it 

with a jpeg viewing application. 

 

  
Note the following in the image: 

o Dry sinking air masses appear red in the Airmass RGB image. 

o In tropical and subtropical regions the RGB depicts hot and dry air masses in red-orange tones. 

o High reaching opaque clouds appear white in the image. Lower clouds turn into red, green or blue 

depending on the air mass they lay within. 

o Polar air masses appear blue in the image. 

o The blue color can also come from the so-called "limb cooling effect" at the edge of the image.  



McIDAS-V Tutorial  
Using Simulated ABI Data 

Created November 2016 (software version 1.6) 
 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 

SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 

(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 

manipulate data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's 

IDV libraries. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V 

for viewing and analyzing hyperspectral satellite data. 

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 

McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 

the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 

http://www.ssec.wisc.edu/mcidas/software/v/. 

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 

Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share 

information with other users. 

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 

McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the 

document entitled McIDAS-V Tutorial – Installation and Introduction. 

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 

Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 

Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 

Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources). 

 

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag). 

Introduction 

McIDAS-V currently supports ABI DOE-4 netCDF data through remote servers as well as through the local file 

chooser on all platforms.  Local servers for ABI DOE-4 data are currently available on OS X and Linux 

platforms.  This tutorial will cover how to access this data through remote servers and the local file chooser, and 

different ways that the data can be displayed and interrogated in McIDAS-V. 

  

http://www.ssec.wisc.edu/mcidas/software/v/
http://www.ssec.wisc.edu/mcidas/forums/
http://www.ssec.wisc.edu/mcidas/forums/
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Accessing ABI DOE-4 Data from a Remote Server – 1 Timestep 
 

1. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and 

Data Sources menu item from the Main Display. 

 

2. Create a remote ADDE dataset pointing towards one of the SSEC testing servers. 

 

a. From the Main Display, select the Tools -> Manage ADDE Datasets menu item.  In the ADDE Data 

Manager window, navigate to the Remote Data tab and click the Add New Dataset button (or use the 

File -> New Remote Dataset menu item). 

 

b. In the Add Remote Dataset window, enter the following: 

i. Server: pappy.ssec.wisc.edu 

ii. Dataset: ABIL1B  

 

c. Click the Verify and Add Server button.  This will verify that ABIL1B is an Imagery dataset and 

allows it to be accessed in the Satellite -> Imagery server.  Click Ok to close the window. 

 

3. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  Select 

pappy.ssec.wisc.edu as the Server and ABIL1B as the Dataset.  Click Connect. 

 

4. Select ALL – All ABIN test DOE4 netcdf files as the Image Type. 

 

5. In the Times panel, select the Absolute tab.  This lists out all of the dates/times included in this dataset.  

Choose the 2016-08-03 18:00:34 time and click Add Source. 
  

6. Display band 1 brightness data. 

 

a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the 

data.  Select the 0.47 um VIS aerosol-over-land -> Brightness field. 

 

b. From the Displays panel, select the Imagery -> Image Display display type. 

 

c. Select the Region tab to see a low-resolution preview image of the data.  Note that there is a green box 

drawn around the preview image.  This is the bounding box showing which data will be displayed. 

 

d. Select the Advanced tab to see information about the band and calibration selected.  These values match 

the domain of the data selected in the Region tab, so it covers the entire domain of the data.  Notice that 

the Image Size is only 986 x 988 when the raw size of the data is 10848 x 10848.  The magnification if 

the data is set to -11, -11.  This reduction in resolution is the default to allow for an efficient display of 

the data.  Modify this Advanced tab to display full resolution data over Wisconsin and Illinois. 

i. Coordinate Type: Latitude/Longitude 

ii. Location: Center 

iii. Lat: 42; Lon: -89.6 

iv. Image Size: 900 x 900 

v. Magnification: 1 x 1 

 

e. Click Create Display. 
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7. Investigate the display. 

 

a. In the Main Display window, practice navigating around in the display.  To do this, use Control+Right-

Click+Drag to translate the display.  This shifts the data left/right and up/down without rotating the 

display.  Zoom in on the display by scrolling down on the mouse wheel.  As an alternative, select a 

region in the Main Display by using Shift+Left-Click+Drag to zoom in on a specific domain. 

 

b. Probe individual pixel values by holding down the middle mouse button over the display.  This will print 

out probe values at the bottom of the display.  Notice that latitude, longitude, and brightness values are 

included in the probe output. 

 

8. Add a data transect to the display. 

 

a. From the Field Selector tab of the Data Explorer, select the Data Transect display type and click 

Create Display. 

 

b. In the Main Display window, there is a red line that is referred to as the data transect.  The values along 

this transect line are output in the Layer Controls tab of the Data Explorer.  The two end points of the 

transect can be moved around by Left-Clicking+Dragging them, or by entering new Lat/Lon values at 

the bottom of the Display tab in the Layer Controls.  The transect line as a whole can be moved by Left-

Clicking+Dragging the triangle in the middle of the transect line.  

 

9. Create a histogram display. 

 

a. From the Field Selector tab of the Data Explorer, select the Histogram display type and click Create 

Display. 

 

b. Navigate to the Layer Controls tab of the Data Explorer to see a histogram of band 1 brightness values. 

 

10. Create a display of the 10.4 micron temperatures so only values of 273K and less are plotted. 

 

a. Add a new two-paneled map display by selecting File -> New Display Tab -> Map Display -> Two 

Panels menu item. 

 

b. Left-Click in the left panel to make this panel active.  The active panel has a blue frame around it, and 

this is the panel any displays will be added to. 

 

c. In the Field Selector tab of the Data Explorer, select the 10.4 um IR Surface & cloud -> Temperature 

field.  Choose the Imagery -> Image Display display type and click Create Display.  

 

d. Create the cloud mask display. 

 

i. Left-Click in the right panel to make this panel active.  The active panel has a blue frame around it, 

and this is the panel any displays will be added to. 

 

ii. In the Field Selector tab of the Data Explorer select Formulas. 
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iii. Select the Imagery -> Mask Value formula, the Imagery -> Image Display display type and click 

Create Display. 

 

iv. In the Select input window, enter the following and then click OK: 

 

1. comparison: < 

2. cutoff: 273 

3. useNaN: 1 

Notes: The comparison is set to < or ‘less then’ since the goal is to display values less than 273, 

which was set as the cutoff value.  Setting useNaN to 1 makes it so that if the pixels were probed 

outside of the masked range (where values are greater than 273) they wouldn’t show a value.  

useNaN can be set to 0 as well, and in this case pixel values greater than 273 would probe as 0.  

Note that if these pixel values are set to 0, then these 0 values will be included in any 

calculations with the data that may be done later. 

 

v. In the new Field Selector window, for inputFieldForMask, select ABIN * -> 10.4 um IR Surface 

& cloud -> Temperature.  This is the field that is being masked. 

 

vi. For displayFieldToBeMasked, select ABIN * -> 10.4 um IR Surface & cloud -> Temperature.  

This is the field that will be displayed where the inputFieldForMask is less than 273 degrees.  In 

this case, we are displaying the same field that is being masked. 

 

vii. Click OK. 

 

e. Investigate the display.  Note that as one of the panels is navigated, the other will be navigated in the 

same way.  This is because by default panels in the same window are set to share views.  This setting 

can be disabled in a panel by unchecking Projections -> Share Views. 

 

11. Create a display of a subtraction of two bands. 

 

a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One 

Panel menu item, or by clicking the Add new tab ( ) button in the Main Toolbar. 

 

b. In the Field Selector tab of the Data Explorer select Formulas. 

 

c. Select the Miscellaneous -> Simple difference a-b formula, the Imagery -> Image Display display type 

and click Create Display. 

 

d. In the new Field Selector window, for a, select the 8.50 um IR Total WV cloud phase, dust -> 

Temperature field.  For field b, select the 7.34 um IR Low-level WV, winds & SO2-> Temperature 

field. 

 

e. Click OK in the Field Selector window to display the band subtracted data. 

 

f. Right-Click on the colorbar of the ABIN layer in the Legend and select the System -> Inverse Gray 

Scale enhancement. 
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g. Add latitude and longitude labels to the display. 

 

i. Click on the blue text for the Default Background Maps layer in the Legend to get to the Layer 

Controls tab of the Data Explorer for the layer. 

 

ii. From the Lat/Lon tab of the Layer Controls, set the following: 

 

1. Check the visibility checkboxes for Lines and Labels to plot them in the display. 

2. Lines: Interval: 5.0 

3. Labels: Interval: 5.0; At Longitudes: -90.0, At Latitudes: 40.0, Color: light blue 

4. Font: Arial; Bold; 14 

 

 
 

h. Investigate the display to see the latitude and longitude lines and labels.  Probe the data to see the 

temperature difference between the two bands. 

 

12. Capture an image of the display. 

 

a. From the Main Display, select the View -> Capture -> Image menu item. 

 

b. In the Save As text field, enter the name to give your image, for example: band_subtraction.gif. 

 

c. Use the dropdown below Save As to select the directory to save your image to. 

 

d. Under Capture What, select Current View.  This will capture an image of the display without including 

any other components of the Main Display such as menu items and the Legend. 

 

e. Click Save. 

 

f. View your saved image to verify the image was captured correctly. 
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Accessing ABI DOE-4 Data from a Remote Server – 5 Timesteps 
 

13. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and 

Data Sources menu item from the Main Display. 

 

14. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel 

menu item.  Close any previously-existing tabs. 

 

15. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  In the 

Relative tab of the Times panel, choose 5 most recent and click Add Source. 

 

16. Display a loop of 10.4um Temperature data over Wisconsin and Illinois. 

 

a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the 

data.  Select the 10.4 um IR Surface & cloud -> Temperature field. 

 

b. From the Displays panel, select the Imagery -> Image Display display type. 

 

c. Navigate to the Advanced tab, and enter the following information: 

i. Coordinate Type: Latitude/Longitude 

ii. Location: Center 

iii. Lat: 42; Lon: -89.6 

iv. Image Size: 450 x 450 

v. Magnification: 1 x 1 

 

d. Click Create Display. 

 

17. Investigate the display. 

 

a. The Main Display now has a loop of the 5 most recent times of data in the ABIN dataset.  As done in 

step 8 earlier, navigate around and zoom in/out of the display.  Probe the display by holding down the 

middle mouse button over the data. 

 

b. Use the Time Animation Widget at the top of the display panel to play through a loop of the data. 

 

 
 

c. Click the Properties button ( ) in the Time Animation Widget to modify settings of the animation 

including the dwell rate (the time spent on each frame in the animation).  As an example, set the 

Forward, First, and Last dwell rates to 0.2 and click OK.  This reduced dwell rate allows the display to 

loop faster. 
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18. Change the enhancement used in the display. 

 

a. Stop the animation by clicking the Stop Animation button in the Time Animation Widget ( ). 

 

b. Right-Click on the colorbar of the ABIN layer in the Legend and select the Satellite -> Longwave 

Infrared Deep Convection enhancement. 

 

c. Notice that the rainbow part of the enhancement is used to color the higher temperature values as can be 

observed by looking at the enhancement range values in the Legend.  Invert the enhancement so that the 

colder temperatures (the clouds) are colored by the rainbow part of the enhancement. 

 

i. Right-Click on the color bar of the ALL - All ABIN layer in the Legend and select Edit Color Table. 

 

ii. In the Color Table Editor window, Right-Click on the colorbar and choose Invert Color Table. 

 

iii. Click OK. 

 

iv. Investigate the display once again to see how the display has changed. 

 

19. Add a color scale to the display. 

 

a. Right-Click on the ALL – All ABIN layer in the Legend and select Edit -> Properties. 

 

b. In the Properties window, navigate to the Color Scale tab and set the following: 

i. Visible: Check this option to add the color scale to the display. 

ii. Position: Top.  This will position the color scale at the top of the display. 

iii. Labels -> Visible: Check this option to add numerical labels to the color scale. 

iv. Labels -> Show Unit: Check this to add the display unit to the color scale labels. 

v. Labels -> Font: Set the size to 32. 

 

 
 

c. Click Apply. 
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20. Create a Data Probe/Time Series display of band 13 temperature data.  This display type allows for plotting 

how temperature values at a specific location change through time throughout the loop. 

 

a. In the Field Selector tab of the Data Explorer, select the Data Probe/Time Series display type and 

click Create Display. 

 

b. The Layer Controls tab of the Data Explorer now shows a time series display of temperature values at 

the location of the probe in the Main Display.  Change the range of the y-axis (temperature values) to 

match the range of the data. 

 

i. At the bottom of the Layer Controls tab, Double-Click on the 186-Band13_TEMP parameter to open 

the Properties window. 

 

ii. In the Properties window, change the Range text boxes to a Min of 180 and a Max of 320 to match 

the range of the enhancement in the Main Display. 

 

iii. Click OK to apply the new range in the Layer Controls and close the Properties window. 

 

c. Move the data probe in the Main Display around with Left-Click+Drag.  The time series display in the 

Layer Controls automatically updates itself as the probe’s location changes. 

 

d. The data probe in the Main Display can also be set to a specific latitude/longitude value by using the 

Lat and Lon text boxes at the bottom of the Layer Controls.  For example, enter values of 38.6 for Lat 

and -88.1 for Lon.  Note that you must press Enter in each text field for latitude/longitude to update the 

location of the data probe. 

 
 

Accessing ABI DOE-4 Data from a Remote Server through Scripting 
 

Both of the previous sections of this tutorial can be replicated through scripting.  This section covers creating a 

loop of ABI data and applying an enhancement to the display. 
 

21. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and 

Data Sources menu item from the Main Display. 

 

22. From the Main Display, select Tools -> Formulas -> Jython Shell  to open the Jython Shell. 

 

23. The Jython Shell defaults to single-line input mode, where only one line of code can be executed at a time.  

This script is more than one line long, so it requires multi-line input.  To switch to multi-line input, click 

the double-down blue arrow button ( ) to the right of the text entry box. 

 

24. In a text editor, open the Data/ABI/abiLoop.py file.  Copy this text and paste it into the Jython Shell. 

 

25. To evaluate this code, click the Evaluate button, or use Shift+Enter.  In-line documentation of what the 

script is doing can be found in the script (lines that begin with ‘#’ are comments).  More information about 

McIDAS-V scripting can be found in the User’s Guide as well as the Scripting and User Functions 

tutorials. 

 

26. After you are done analyzing the display created with the script, close the new display window. 
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Accessing ABI DOE-4 Data from the Local File Chooser 
 

27. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and 

Data Sources menu item from the Main Display. 

 

28. In the Data Sources tab of the Data Explorer, navigate to the General -> Files/Directories chooser.  In 

the Files panel, navigate to the Data/ABI/NetCDF directory and select the OR_ABI-L1b-RadC-

M3C14_G16_s20162491825085_e20162491827460_c20162491827489.nc file.  Click Add Source.  This 

is a Level 1b DOE-4 netCDF CONUS band 14 file. 

 

29. Display the band 14 radiance data over Illinois. 

 

a. Create a new one-panel map display and removed any previously-existing tabs. 

 

b. In the Main Display, zoom in and center the display over Illinois. 

 

c. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the 

data.  Select the 2D grid -> ABI L 1b Radiances field. 

 

d. In the Displays panel, select Plan Views -> Color-Shaded Plan View. 

 

e. In the Region tab, use the dropdown menu to select Match Display Region.  This will display data only 

over the domain visible in the active display, which was set to Illinois above.  Another way of doing this 

is to use the dropdown menu and choose Select A Region and draw a bounding box over Illinois. 

 

f. Click Create Display. 

 

30. Inspect the display, and modify the enhancement so the clouds are white and land is darker. 

 

a. As the display is zoomed in on, individual blocks of data will be visible.  These boxes can be shaded 

together to create a smoother image.  To do this, go to the Layer Controls tab of the Data Explorer and 

click the Shade Colors checkbox. 

 

b. To make the clouds white, Right-Click on the colorbar in the Legend and select System -> Inverse Gray 

Scale. 

 

c. Zoom out of the display to notice that only data necessary to fill the geographical domain visible in the 

display was drawn.  This saves time in creating the display by not displaying data that the user might not 

be interested in. 

 

31. Display Level 2 total precipitable water ABI data. 

 

a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One 

Panel menu item. 

 

b. In the Data Sources tab of the Data Explorer, navigate to the General -> Files/Directories chooser.  In 

the Files panel, navigate to the Data/ABI/NetCDF directory and select the OR_ABI-L2-TPWC-

M3_G16_s20162152257163_ e20162152259535_c20162152301341.nc file.  Click Add Source. 
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c. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the 

data.  Select the 2D grid -> ABI L2 + Total Precipitable Water field. 

 

d. In the Displays panel, select Plan Views -> Color-Shaded Plan View. 

 

e. Click Create Display. 

 

32. Investigate the display and change the unit used to display the data. 

 

a. Probe the data to see that precipitable water is displayed with units of ‘mm’ for millimeters. 

 

b. Change the display unit to ‘in’ (inches). 

 

i. Right-Click on the blue text of the OR_ABI-L2* layer and choose Edit -> Change Display Unit.  

Note that this is the same as going to the Layer Controls tab for the layer and going to Edit -> 

Change Display Unit. 

 

ii. In the Change unit window, use the dropdown menu to select in. 

 

iii. Click OK. 

 

c. Probe the display to see units of ‘in’.  Also, notice that the colorbar range automatically adjusted itself 

for the numerical values for the new unit of inches. 

 

 

Using Adaptive Resolution with ABI DOE-4 Data from the Local File Chooser 

Adaptive resolution is a feature that is still under development in McIDAS-V.  Adaptive resolution is a feature 

designed to load high resolution data efficiently by obtaining and loading only the minimum amount of data 

needed to display all of the observable features in the given display size and geographic domain.  If the domain 

is subsequently changed by using either Shift+left-click+drag or the Projections menu, adaptive resolution 

automatically reloads the data at a higher resolution (if available) if the user zoomed in to a more detailed view, 

or reloads the data at a lower resolution (sampled) if the user zoomed out to a wider view. 
 

33. Adaptive resolution is disabled by default.  Enable adaptive resolution. 

 

a. From the Main Display, select the Edit -> Preferences menu item to open the User Preferences 

window. 

 

b. In the User Preferences window, navigate to the Display Window tab. 

 

c. Under Panel Configuration, enable the bottom option for Enable Adaptive Resolution. 

 

d. Click OK. 

 

34. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel 

menu item. 
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35. Display local band 2 ABI data using adaptive resolution.  This band 2 data is 0.5 km resolution. 

 

a. In the Data Sources tab of the Data Explorer, navigate to the General -> Files/Directories chooser.  In 

the Files panel, navigate to the Data/ABI/NetCDF directory and select the OR_ABI-L1b-RadC- 

OR_ABI-L1b-RadC-M3C02_G16_s20162491825085_e20162491827460_c20162491827483.nc file.   

 

b. Click Add Source. 

 

c. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the 

data.  Select the 2D grid -> ABI L1b Radiances field. 

 

d. In the Displays panel, select Plan Views -> Color-Shaded Plan View. 

 

e. Click Create Display. 

 

36. Investigate the display. 

 

a. Notice that a Data Sampling value is written out in the Legend for the layer that was just displayed.  

McIDAS-V took into account the size of the window at the time of the display’s creation, and only 

displayed the highest resolution that can be viewed in the display’s current state.  This sampling value 

informs the user the resolution that the data was displayed at as far as x and y sampling values.  For 

example only every 17
th

 by 13
th

 grid point may be displayed. 

 

b. Zoom in on the display with the mouse wheel.  This does not cause the display to be re-sampled, so the 

resolution remains at what it was when the data was originally displayed.  The display will become 

blocky, and it is no longer at full resolution. 

 

c. Sample the display by using Shift+Left-Click+Drag over a domain, such as Wisconsin.  Notice two 

things: 

 

i. The display resolution has now improved, as noted by the Data Sampling values in the Legend. 

 

ii. Zoom out with the mouse wheel, and you will note that no data outside of this current domain is 

displayed.  This data can be re-obtained by doing Shift+Left-Click+Drag over a different area (for 

example, over Texas). 

 

d. Sample the display by changing the projection. 

 

i. From the Main Display, select the Projections -> Predefined -> US States -> N-Z -> Pennsylvania 

menu item. 

 

ii. Notice that the data was re-sampled over this new domain. 

 

37. Disable adaptive resolution to return it to the default setting.  Follow the first step in this section to 

accomplish this, but disable the Enable Adaptive Resolution setting instead of enabling it. 
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Problem Set 

 

The previous examples were intended to give you a general knowledge of how to load and display ABI 

data.  The problem set below is intended to introduce you to a new topic related to the data, as well as challenge 

your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem set before looking 

at the solutions, which are provided below the problem set. 

 

1.Use the data in pappy.ssec.wisc.edu/ABIL1B/AREAS to create an airmass RGB display.  Use only the 

2016-09-06 17:36:27Z time.  There are three bands in this data which aren’t actually native bands of ABI 

data, but rather band subtractions that were scaled and generated in McIDAS-X for the ease of this 

tutorial.  Use the Three Color (RGB) Image (Auto-scale) formula to generate the RGB display with the 

following: 

 

Red: Band 1 -> Brightness 

Green: Band 2 -> Brightness 

Blue: Band 3 -> Brightness 

 

As a reference, here is how the AREA files were created in McIDAS-X: 

 

Band 1:  

IMGOPER ABIL1B/FD ABIL1B/FD TI.6 BAND=8 10 COEF=1 -1 MAG= -10  

LAT=0 89 UNIT=TEMP MISS=NONE SCALE=-25 0 0 255 

 

Band 2:  

IMGOPER ABIL1B/FD ABIL1B/FD TI.7 BAND=12 14 COEF=1 -1 MAG= -10  

 LAT=0 89 UNIT=TEMP MISS=NONE SCALE=-40 5 0 255 

IMGCHA A/A.7 BAND=2 
 

Band 3:  

IMGOPER ABIL1B/FD TI.8 MAG=-10 BAND=8  

 LAT=0 89 UNIT=TEMP SCALE=243 208 0 255 

IMGCHA A/A.8 BAND=3 
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Problem Set #1 – Solution 

Use the data in pappy.ssec.wisc.edu/ABIL1B/AREAS to create an airmass RGB display.  Use only the 2016-09-

06 17:36:27Z time.  There are three bands in this data which aren’t actually native bands of ABI data, but rather 

band subtractions that were scaled and generated in McIDAS-X for the ease of this tutorial.  Use the Three 

Color (RGB) Image (Auto-scale) formula to generate the RGB display with the following: 

 

Red: Band 1 -> Brightness 

Green: Band 2 -> Brightness 

Blue: Band 3 -> Brightness 

1. Remove all layers and data sources and create a new tab. 

 

2. Load the ABI AREA data into the Field Selector. 

 

a. From the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser. 

 

b. Select pappy.ssec.wisc.edu as the Server and ABIL1B as the Dataset.  Click Connect. 

 

c. Select AREAS – IMGOPER AREA files for Airmass RGB as the Image Type. 

 

d. In the Times panel, select the Absolute tab.  This lists out all of the dates/times included in this dataset.  

Choose the 2016-09-06 19:21:42 time and click Add Source. 

 

3. From the Field Selector, create the airmass RGB display. 

 

a. Under Data Sources, select Formulas. 

 

b. In the Fields panel of the Field Selector, select the Imagery -> Three Color (RGB) Image (Auto-scale) 

formula and the RGB Composite display type. 

 

c. Click Create Display. 

 

d. In the Field Selector window, select the following: 

 

i. red: AREAS -> Band 1 -> Brightness 
 

ii. green: AREAS -> Band 2 -> Brightness 

 

iii. blue: AREAS -> Band 3 -> Brightness 
 

e. Click OK to display the data. 

  



Page 27 of 28 

 

McIDAS-X/ V GOES-R Tutorial                  November 2016 – McIDAS-X version 2016.2; McIDAS-V version 1.6 

 

Zooming, Panning, and Rotating Controls 
 

Zooming Panning Rotating 

 Mouse  

Shift-Left Drag: Select a region by 

pressing the Shift key and dragging the 

left mouse button. 

Shift-Right Drag: Hold Shift key and 

drag the right mouse button. Moving up 

zooms in, moving down zooms out. 

Control-Right Mouse Drag: Hold 

Control key and drag right mouse to 

pan. 

Right Mouse Drag: Drag right mouse 

to rotate. 

 Scroll Wheel  

Scroll Wheel-Up: Zoom Out. 

Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-Up/Down: 

Rotate clockwise/counter clockwise. 

Shift-Scroll Wheel-Up/Down: Rotate 

forward/backward clockwise. 

 Arrow Keys  

Shift-Up: Zoom In. 

Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 

Control-Down arrow: Pan Up. 

Control-Right arrow: Pan Left. 

Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate around 

vertical axis. 

Up/Down arrow: Rotate around 

horizontal axis. 

Shift-Left/Right arrow: Rotate 

Clockwise/Counterclockwise. 
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File Used in this Tutorial 
 
abiLoop.py 

# Python dictionary to pass through loadADDEImage(). 

# For more information on the keywords and values 

# that can be passed through loadADDEImage(), consult 

# the documentation (available through Help > User's 

# Guide in the Main Display window). 

addeParms = dict( 

    server = 'pappy.ssec.wisc.edu', 

    dataset = 'ABIL1B', 

    descriptor = 'ALL', 

    band = 13, 

    unit = 'TEMP', 

    coordinateSystem = LATLON, 

    location = (42,-89.6), 

    place = CENTER, 

    size = (450,450), 

    ) 

 

# Loop through positions -4 through 0 (most recent) 

# and append them to a list defined as abiLoop. In python, 

# the last value in the loop is not used, so only values 

# -4 through 0 are used, as the default skip value is 1. 

abiLoop = [] 

for pos in range(-4,1): 

    data = loadADDEImage(position=pos,**addeParms) 

    abiLoop.append(data) 

 

# Build a window referenced as abiPanel 

abiPanel = buildWindow(height=600,width=800) 

 

# Display the data, reference this layer as abiLayer. 

# The window contains a list of panels for future support 

# of working with multi-panelled displays in scripting. 

# For now, specify [0] in the window name to use the one 

# panel in the abiPanel window. 

abiLayer = abiPanel[0].createLayer('Image Sequence Display',abiLoop) 

 

# Add a temperature enhancement to the display 

abiLayer.setEnhancement('Longwave Infrared Deep Convection',range=(320,180)) 

 

# Add a color scale to the display 

abiLayer.setColorScale(size=32,showUnit=True) 

 

 

 


