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Note: The data files referenced in this document can be found at: 

ftp://ftp.ssec.wisc.edu/pub/mug/mug_meeting/2018/presentations/2018_McIDAS-V_demo.zip 

 

1. GOES-16  
a. New freely available remote ADDE server from Unidata (L1b)  

i. Go to the Satellite>Imagery chooser  

ii. Connect to lead.unidata.ucar.edu/RTGOESR  

iii. Choose Image Type CONUSC14  

iv. In the Relative Times tab, there is now a text box to enter the number of relative 
times. This used to be a dropdown list where you could choose only the last 100 
images. This may not be enough if you want to look at 1-minute mesoscale data. Now, 
you can type whatever value in you want.  

1. Enter a value of 10 and click Add Source  
v. In the Field Selector, choose Temperature.  

vi. Note there was a big performance improvement here in that there is only one ADDE 
server call to generate the preview image. In the past, an ADDE call was made for 
each image in the dataset. This allows for a major speedup in this step (by several 
minutes in some cases)  

vii. Show the Region tab for preview image.  

viii. In the Advanced tab, click the 4 green arrow button to get full res full domain  

ix. In the Region tab, draw a box over some area with interesting weather  

x. Click Create Display  

xi. Play through the loop and probe data to see temperature values  

xii. Right-click on enhancement in Legend and choose Satellite>GOES-R. Some of these 
enhancements are new or changed from previous versions of McV. Choose “ABI IR 
Temperature”  

xiii. Create a new 1 paneled tab  
b. New freely available remote ADDE server from Unidata (L2)  

i. Go to the Satellite>Imagery chooser  

ii. Connect to lead.unidata.ucar.edu/NPGOESR  

iii. Choose Image Type CTPRCN – GOES-16 L2 CONUS Cloud Top Pressure Product  

iv. In the Relative Times tab, set the value to 1 and click Add Source  

v. Choose Ctpr as the field and click Create Display  
1. A couple things here:  

a.  We can now work with L2 data  

b. Through a plugin I currently have installed (will be in the nightly 
eventually), the enhancement is automatically applied. These 
enhancements were CMAP files from AWIPS imported into McV. The 
enhancements can be found through Satellite>GOES-R>L2  

c. Local servers will need to be updated in the nightly so the new 
min/max values in McX 2018.1 are included.  

c. GOES-16 netCDF files can also be loaded through the General>Files/Directories chooser  



 
i. Go to General>Files/Directories and load the /Data/GOES16/OR_ABI-L2-CPSC (cloud 

particle CONUS domain) as a gridded data source.  

ii. Create a 2 paneled display.  

iii. In the left panel, display the top CPS field (not quality flags) using Image Display  

iv. n the right panel, display the derived field using Image Display  

v. Again, the same enhancement is used in each panel. When loading the data through 
General>Files/Directories, you have access to the CPS field as well as the data quality 
flags. There are several quality flag values included in the data which you can see from 
doing a ncdump of the file. Certain values that aren’t 0 are invalid in several different 
ways, including failing various threshold tests. Displaying the original CPS field of the 
data does not take these quality flags into account. This derived field is in an attempt 
to replicate AWIPS displays that uses the quality flags.  

vi. Remove all Layers and Data Sources. Create a new tab. Remove previous tabs.  
d. Local servers  

i. Set up a local ABI dataset pointing to /Data/GOES16/LocalServer/. This contains 5 
timesteps of band 16 CONUS data. These local servers are updated and available in 
McV on OS X and Linux platforms.  

ii. Note that the file search window when selecting the directory for your local dataset 
has improved to match the file-selection window native to your OS instead of a McV-
specific window. This makes it easier to navigate to your desired directory.  

iii. Connect to local dataset. In the Absolute tab, select all times and click Add Source.  

iv. In the Field Selector, select Brightness. In the Advanced tab, click full size button, 
unlock lock icon, and then set mag to -2, -2. Click Create Display.  

v. Play through loop. Change forward dwell rate and first to 0.2 to make it go faster.  

vi. Remove all Layers and Data Sources. Create a new tab. Remove previous tabs.  
e. Update to Absolute Times tab  

i. Through Satellite>Imagery, connect to easta.ssec.wisc.edu/EASTAL. Choose M1 as the 
Image Type.  

ii. Go to the Absolute Times tab.  
1. In the past, this would have listed ALL of the images in the dataset. It was 

found that this would take quite a long time with larger datasets, so a new 
text entry box was added that allows you to enter a numerical value of image 
times to list. This defaults to “100”.  

2. Type a new value into this field (e.g. 150) and see how the list changes. 
However, this still doesn’t go back too far. What if you want to look at just the 
times between 1 and 2Z? In the nightly, you can do this.  

3. Click the Date button and enter “Beg Time” of 01:00 and “End Time” of 02:00. 
Click OK.  

4. Look at the listing in the Absolute tab to see how it matches the time range 
requested.  

f. This same enhancement of being able to select a time range in the Absolute Times tab also 
exists when working with an archive server.  

i. Through Satellite>Imagery, connect to geoarc.ssec.wisc.edu/AGOES16. Choose FD. 
Select a date of 09/24/2017 and a time range of 4:00 to 10:00.  

ii. Choose the 06:30:43 time and click Add Source.  



iii. Choose the 10.3um>Temperature field, go to the Advanced tab and click the 4 green 
arrow button to get full res, and from the Region tab draw a box around Hurricane 
Maria (off southeast USA coast). Click Create Display.  

iv. Go back to the Field Selector and choose the ADT display type (bottom of list). Click 
Create Display.  

v. Move the probe to the eye of the hurricane and click Run Analysis. Show the ADT 
results window. Move the probe outside the eye of the hurricane and see how the 
values change.  

vi. This example was done with GOES-16 data, but it should work with any geostationary 
satellite.  

vii. Close ADT results window  
g. Not ABI, but overlay some CALIPSO data.  

i. Go to General>Files/Directories and choose the /Data/CALIPSO/ directory. Select the 
file and click Add Source.  

ii. In the Fields panel, choose the Total_Attenuated_Backscatter_532 field  

iii. Disable Auto-Set Projection in display  

iv. In the Track tab, note some of the new features  
1. You now select the portion of the track you want to display with the slider. 

Moving it left/right moves the selected part of the track to the beginning/end 
of the data path.  

2. You can increase the length of the track to be displayed by typing a new value 
into the Length% field. Enter a value of 15. This selects 15% of the track.  

3. Set the Track stride (stride along the x/y) to 1 to use every point.  

4. Set the Vertical stride (stride along the z) to 1 to use every point.  

5. Click Create Display  
v. Investigate the display.  

1. Remove Wireframe Box  

2. Rotate display to see how the backscatter is higher up in the atmosphere over 
clouds. With no clouds, the backscatter is near the surface, likely sea spray.  

vi. Interactively modify the enhancement to make the blues 100% transparent  
1. Right-click on the enhancement and choose Edit Color Table  
2. For Paint Mode, select Transparency and change the value to 100%  

3. Left-click+drag along the left end of the enhancement to make all of the blue 
colors transparent.  

4. Look at the display to see that you can now see the satellite data through the 
display.  

h. Demo a few different bundles. These bundles were made based on posts to the Satellite 
Liaison blog. All bundles in GOES-16 directory. Replace Session each time.  

i. G16_Rotating_Updraft.mcvz – An hour of M1 sector band 2 data from 05/01 and 
05/02. You can see a rotating updraft.  

ii. G16_Dust.mcvz – Two paneled display of dust event over Colorado. This is CONUS 5 
minute data. The left panel is full res band 2 data. The right panel is 10.3 -12.3um data 
where values less than -2 are colored to make the dust stand out. The training session 
will cover how to do band subtractions.  

iii. G16_GLM_Winds.mcv – One time of band 14 temperatures and satellite derived 
winds colored by speed. Pink pluses are GLM group data which is an aggregation of 6 



files (2 minutes of data). The training session will cover creating a display very similar 
to this one.  

iv. Open Joleen’s 2018-May01 movie in Quicktime. This is an animation of a sandwich 
product display, which merges IR and Visible into the same layer. This function is 
available through the Jython Library.  

i. Remove all Layers and Data Sources. Create a new tab. Remove previous tabs.  
 

2. JPSS  
a. Changed name of chooser from “Suomi NPP” to “JPSS” since the chooser works not only with 

Suomi NPP data, but also NOAA-20. Currently, we can work with VIIRS (SVM, SVI, DNB, EDRs), 
CrIS, and ATMS.  

b. Changed ordering of fields in the Field Selector:  
i. Load the /Data/NPP/GMODO-SVM01-SVM02* file  

ii. This is a multi-banded SVM file from Suomi NPP containing all 16 bands  

iii. In the Field Selector, all bands are now ordered in numerical order with the quality 
flag fields grouped with the calibrated values (e.g. Radiance, Brightness Temperature) 
of each band.  

iv. Geolocation data and quality flags are at the bottom of the list  

v. This is in the nightly  
c. New “Show Descriptions”/”Show Variables” buttons in the Field Selector if the variable names 

and descriptions (long_name attribute) differ. This is the case with NASA-formatted Suomi 
NPP VIIRS data.  

i. Load the /Data/NPP/VL1BM* file. Note that the data (VL1BM) and geolocation 
(VGEOM) are in separate files. This differs from the last example from NOAA CLASS 
where by default the geolocation and data are packaged in the same file.  As long as 
the geolocation and data are in the same directory then you can work with VIIRS, CrIS, 
or ATMS.  

ii. From the Field Selector, expand Image and notice that there is a descriptive listing of 
the fields that lets you know if you are working with reflectance, radiance, or 
brightness temperature. Click the “Show Variables” button at the top and you’ll 
switch to showing the variable names, which is less descriptive. In previous versions of 
McIDAS-V, only the variable names were available.  

iii. Note that this button is not available with CLASS data since the variable names and 
long_name attributes match up.  

d. Added support for VICMO cloud mask product which was released in March 2017. The 
previous naming convention of the file (IICMO) is still supported  

i. Load the /Data/NPP/GMODO-VICMO* file  

ii. Select the QF6_Cloud_Phase field and subset an area in the Region tab near the 
center of the granule. Click Create Display.  

iii. In the display window, probe around and you’ll see text output like “Clear” 
“Supercooled Water”, “Partly Cloudy”. The QF fields are numerical values which map 
to these text values. This probing has been around in McV since at least version 1.6 
and also applies to hydrometeor classification with L3 radar  

iv. Remove all Layers and Data Sources. Create a new tab. Remove previous tabs.  

e. Added support for SCRIF (CrIS Full Spectral Science SDR). The other version of CrIS (SCRIS – 
CrIS Science SDR) has worked in McV for a while.  

i. Load the /Demo/NPP/GRCSO-SCRIF* file  



ii. Choose the MultiSpectral Display and click Create Display  

iii. Position one probe over clouds and one over cloud-free ocean.  

iv. In the Layer Controls, investigate the spectra differences between the probe 
locations. Move the green selector line left/right to change the display to use a new 
wavenumber.  

v. When comparing this SCRIF data with SCRIS at the same time, there are differences 
throughout the spectra, but most notably in the middle and upper ends.  

vi. Note at you can use this display type with ATMS data as well.  
vii. Remove all Layers and Data Sources. Create a new tab. Remove previous tabs.  

f. Added support for NOAA-20 data  
i. Aggregate a few of the /Data/NOAA20/ SVM03 files together.  

ii. Display radiance at full resolution over a subsetted area that includes the bowtie 
deletion lines.  

iii. Mention there is a plugin available in the Plugin Manager to remove the bowtie and 
create RGBs. It will be covered how to do interactively in the training with NOAA-20 as 
well as Suomi NPP data.  

g. Modified the names of the scripting functions to use JPSS instead of VIIRS since the functions 
work with CrIS and ATMS as well as VIIRS.  

i. Through the Jython Shell, run /Demo/jpss_rgb.py 
ii. This script uses all 3 of the newly named JPSS functions and uses the VIIRS Formulas 

plugin RGB formula to create a true color RGB while also removing the bowtie 
deletion lines.  

iii. Close new window.  

iv. Remove all Layers and Data Sources. Create a new tab. Remove previous tabs.  
 

3. Range Rings  
a. Click Display>Add Range Rings  

i. In 1.7, we added the ability to link colors and line width between the Range Rings 
(circles), Radials (straight lines), and Labels.  

ii. In the Layer Controls, go to the Settings tab. Change the color of the range rings to 
yellow. Unlink things and then change Range Rings to red.  

iii. Another major improvement in the nightly is that the label sizes behave better. In 
core, if you zoomed in and changed the radial spacing the label sizes could get very 
large.  

iv. Note that this label size issue has also been improved with the satellite track chooser  
 

4. Sat Track Chooser  
a. Connect to noaaport.ssec.wisc.edu/TLENAV and choose NPP – NPP  

b. In the Field Selector (in the nightly) you’ll see that only NPP is listed. In the past, all satellites 
in the TLENAV dataset would have been listed.  

c. In the Time Range tab, select:  
i. Begin: 19:25:00 May 17, 2018  

ii. End: 19:35:00 May 17, 2018  
d. Click Create Display  

e. In the Layer Controls, enter a Swath Width value of 3000 (swath width of VIIRS instrument).  

f. Change the projection of the display to CONUS.  



i. Here is where label sizes would have gotten very large in the past  
g. Add a new tab.  

 
5. Logo  

a. New default logo. See the lower left corner of the Main Display. There are two ways to set the 
logo:  

i. As a preference through Edit>Preferences Display Window tab  

ii. On a display-by-display basis through View>Properties  
b. Add a new tab.  

c. In View>Properties, change logo position to upper right.  

d. Create new tab, and logo is still in lower left since preferences weren’t updated.  
e. Things can be controlled such as:  

i. The logo file  

ii. Placement of the logo in the display  

iii. Size of the logo  
 

6. Scripting  
a. Remove all Layers and Data Sources. Create a new tab. Remove previous tabs.  

b. Have only one window up with one tab. Make the window somewhat large.  

c. Paste the /Data/writeMovie.py script into the Jython Shell  
i. New thing here is the framesPerSecond keyword of writeImage, which allows the user 

to control how many frames per second will used in the animation. Increasing this 
value speeds the loop up. The default value is 2.  

ii. Enter a value of 10 (dwell rate of 0.1) and run the script.  

iii. Play the movie in Sarari  

iv. Note that there is also a new keyword for endFramePause, which is the number of 
seconds to sit on the last frame of the loop. This defaults to 2 seconds, which is what 
I’m using in this movie  

v. describe() has been around in McV since 1.6, but it could be useful to users so run:  
1. describe(satLoop[29])  

2. This prints out the statistical information for the last image  
d. Remove all layers and data. Load the displayUnit.py script into the Jython Shell  

i. This loads the most recent band 14 CONUS temperature data  

ii. In the Jython Shell, run:  
1. layer.getDisplayUnit()  

iii. Probe the display to see that units are in Kelvin  

iv. In the Jython Shell, run:  
1. layer.setDisplayUnit(‘F’)  

v. Probe the display again to see that units are in Fahrenheit  

e. Added a new keyword to annotate() that allows for adding a background color. In the Jython 
Shell, run the following two commands:  

i. activeDisplay().annotate('No Background', lat=40, lon=-89, size=40)  

ii. activeDisplay().annotate('Background', lat=30, lon=-89, size=40, bgColor='black')  
f. Not scripting related, but we added display labels for the Great Lakes.  



g. From the Display window, choose Display>Plot Location Labels>US>Great Lakes. Zoom in over 
Great Lakes so all of them are drawn Again not scripting, but related to annotate(),we added 
the ability to draw areas of High and Low pressure through the drawing controls as “A” and 
“B” for Spanish.  

i. In the Main Display, go to Display>Draw Freely  

1. In the Controls tab of the Layer Controls, select “L” and plot it over some 
clouds. Set pressure value as 990.  

2. In the Controls tab of the Layer Controls, select “H” and plot it over a cloud-
free area. Set pressure value as 1020.  

3. Note that right now the low has a label of “L” and high has a label of “H”.  

4. In the Shapes tab of the Layer Controls, double-click on Glyph 1 and set Label 
Convention as Spanish.  

5. Repeat this for Glyph 2.  

6. Go back to the Main Display and note that low is now denoted as “B” and 
high is denoted as “H”.  

7. This was requested by a user on the McIDAS-V forums  
 

7. Trajectories  
a. Remove all Layers and Data Sources. Create a new tab. Remove previous tabs.  

b. Add a data source of the most recent NAM 80km CONUS  

c. Choose the 2D>Derived>Grid 2D Trajectory field. Choose the 2D Grid Trajectory Colored By 
Speed display type. Click Create Display.  

d. Demo 1:  
i. From the Layer Controls, hit Create Trajectory  

ii. This draws trajectories colored by wind speed over the entire domain of the data.  

iii. By default, no arrow heads are drawn on the trajectories. Enable this by clicking the 
Arrow button.  

e. Demo 2:  
i. Decrease the density to make the trajectories easier to see. At the top of the Layer 

Controls, enter a value of 2 and hit Enter. Click Create Trajectory.  

ii. Again, this draws trajectories over the entire domain of the data, but the display is 
sampled to initiate the trajectories at every other x/y point in the grid.  

iii. Play the loop and cycle through the different Trajectory Forms. Points are newer.  
f. Demo 3:  

i. In the past, we had the ability to set these trajectory forms, but not in combination 
with setting the trajectory initial area. These controls were both available, but not in 
the same display type.  

ii. Set the TIA as Rectangle and draw a box in the display.  

iii. Click Create Trajectory.  
iv. Play through the loop. Note that the trajectories originate in the box, but can travel 

outside of the box through time.  
 

8. Remove the layer. Choose 3D>Derived>Grid 3D Trajectory for the field and 3D Grid Trajectory 
Colored by Speed as the display type. Hit Create Display.  

a. Demo 1:  



i. Set the Trajectory Start Level as 850  

ii. Set the Initial Area Skip Factor as 3 and hit Enter  

iii. Draw 3 different relatively small boxes in the Main Display  

iv. Click Create Trajectory  

v. Change the Trajectory Form to Cylinder  

vi. Rotate the display and step through the loop  


