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McIDAS-X Workshop 
May 2018 (software version 2018.1) 

 
 

In existence since 1973, McIDAS (Man computer Interactive Data Access System) is a suite of sophisticated 
software packages that perform a wide variety of functions with satellite imagery, observational reports, 
numerical forecasts, and other geophysical data. Those functions include displaying, analyzing, interpreting, 
acquiring and managing the data. 
 
McIDAS-X is supported for the current GOES-R satellite series (currently estimated as being in service until 
2036), with no end date in sight. 
 
In this McIDAS-X tutorial, some exercises will be completed using different methods of data access:  local data 
files and real-time access to default remote servers.  If you have access to your own real-time ADDE servers, 
you may also use those, but be aware that different server configurations may make the explanations in this 
document not quite applicable to all data that you may load.  A source for free data served via ADDE is 
Unidata’s LEAD.UNIDATA.UCAR.EDU server. 
 
This tutorial assumes that you have McIDAS-X installed on your machine, and that you know how to start 
McIDAS-X.  
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ABI Background 

 
 
 
Image from J. Gerth, CIMSS.   
 
 
There is a 60-fold increase in the amount of data sent by the ABI compared to GOES-13 through -15.  The ABI 
on GOES-R acquires a full-disk image 5 times faster than the imager on GOES-13 through GOES-15.   The 
spatial resolution on the ABI compared to present GOES increases by a factor of 2 in both horizontal directions.  
There are about 3x more spectral bands on GOES-R.  The cubes represent the data volumes from present 
GOES, in dark orange, and GOES-R, in beige.   The combination of increased resolutions means a 60-fold 
increase in data; about a terabyte of data is flowing daily from GOES-R! 
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Image from Tim Schmit, Mat Gunshor and Scott Lindstrom (Satellite Foundational Course – GOES-R)  
 
 
 
There are two main scanning modes for GOES-R, Mode 3 and Mode 4. The most likely default mode is Mode 
3, where one FD image is scanned, 3 CONUS sectors are scanned, and 30 30-second mesoscale sectors are 
scanned in each 15 minutes.  Those 2 mesoscale sectors could be split in two locations so you'd get 2 separate 
views with 1-minute imagery during the 15 minutes. 
  
Mode 4 is the highest data rate for GOES-R's ABI and results in a full disk every 5 minutes.  This might be used 
if multiple high-impact weather/volcanic events are happening, say a volcano in Chile, strong hurricanes over 
the Atlantic or Pacific basins, and high-impact severe weather over the central United States. 
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Image from Tim Schmit, Mat Gunshor and Scott Lindstrom (Satellite Foundational Course – GOES-R)  
 
 
 
 
This comparison table shows the improvements in spectral, spatial and temporal coverage that GOES-R has 
over its predecessors. 
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Image from the RAMMB/CIRA website, VIIRS Imagery and Visualization Team:  
http://rammb.cira.colostate.edu/projects/npp/VIIRS_bands_and_bandwidths.pdf 

Visible Infrared Imaging Radiometer Suite (VIIRS) SDR imagery from the NASA/NOAA Joint Polar Satellite 
System (JPSS)-1 spacecraft (NOAA-20) and from Suomi National Polar-orbiting Partnership (SNPP) can be 
utilized in McIDAS-X and McIDAS-V. 
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GOES-R ABI Band List  
 
 

 

 
 
 
Creating Local Datasets 
 
You can access GOES-16 netCDF format files with the IMG* commands by using DSSERVE to assign a 
dataset name to the files. When doing so, specify "ABIN" in the format parameter, TYPE=IMAGE, and the 
directory and file masks in the DIRFILE keyword. The files must be mission-standard Level 1b or Level 2 files 
in netCDF-4 format, like those from NOAA CLASS or from the GRB data stream after they've been decoded 
with CSPP Geo or other software. The names of files should look similar to ABI-L1b-RadC-
M3C01_G16_s2015229195720.nc (current CSPP Geo naming convention) or OR_ABI-L1b-RadC-
M4C16_G16_s20151702215532_e20151702220362_c20151702220394.nc (GOES-R Ground System naming 
convention). 
 
1. Create a local dataset to access the ABI netCDF files on your local machine in the 

Data/GOES16/ABI/NetCDF directory.  
   
OR_ABI-L1b-RadC-M3C02_G16_s20180041657204_e20180041659577_c20180041700012.nc 
OR_ABI-L1b-RadC-M3C14_G16_s20180041657204_e20180041659577_c20180041700023.nc 
OR_ABI-L2-TPWC-M3_G16_s20180041657204_e20180041659577_c20180041701161.nc 
 
a. Run the DSSERVE command to access the Level 1b netCDF imagery files. 

 
DSSERVE ADD ABI/CONUS ABIN TYPE=IMAGE DIRFILE= '<local-
path>/Data/GOES16/ABI/NetCDF/*RadC*' 
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b. Use the IMGLIST command to list the most recent image in the dataset. 
 
IMGLIST ABI/CONUS 
 

c. Datasets can be organized however the user chooses.  Run DSSERVE to include all of the files in the 
data directory. 
 
DSSERVE ADD ABI/DATA ABIN TYPE=IMAGE DIRFILE= '<local-path> 
/Data/GOES16/ABI/NetCDF/*' 
 

d. IMGLIST can list the image directory and band information with the FORM=ALL keyword.  Your 
IMGLIST command should match the image. 
 
IMGLIST ABI/DATA.ALL FORM=ALL 
 

 
 

 
e. Another IMGLIST keyword, FORM=BAND, lists the band and resolution without the file’s expanded 

listing. 
 
IMGLIST ABI/DATA.1 BAND=2 FORM=BAND 
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2. The data can be displayed and inspected with the IMGDISP and IMGPROBE commands. 
 
a. Run this series of commands to display BAND 2 of an ABI Level 1b file, display a navigated map over 

the image, place the cursor at the center of the image and run an IMGPROBE command to inspect the 
pixel values under the cursor. 
 
IMGDISP ABI/CONUS BAND=2 MAG= -16 
MAP X X LALO 
PC C 
IMGPROBE MODE=N 

 

 
 
  



Page 9 of 47 
 

McIDAS Workshop                                                                           May 2018 – McIDAS-X version 2018.1; McIDAS-V version 1.7u1  

b. Display BAND 14 with a yellow map on a new frame which is automatically displayed with the 
SF=YES keyword.  Move the cursor to a latitude/longitude point (29° N, 91° W), and list the statistics of 
the pixel values under the cursor. 
 
IMGDISP ABI/CONUS 2 BAND=14 LATLON=29 91 SF=YES ; MAP X 3 
PC E 29.4 90.7 ; IMGPROBE STAT BOX TEMP   
 
Move the cursor around and press alt-g or the right mouse button over desired features.  Be sure to quit 
each interactive IMGPROBE command with Alt-Q or by clicking the right and center mouse buttons. 

 
c. Display the Total Precipitable Water Level 2 product file in the local dataset by specifying the absolute 

position number of the data.  Plot a map and inspect the data in the middle of the frame with the 
IMGPROBE command. 
 
IMGDISP ABI/DATA.2 3 SF=YES ; MAP 
PC C ; IMGPROBE 
 
 

Accessing Remote ADDE Datasets 
 
3. To access a remote ADDE server with Level 1b ABI netCDF image files, follow these steps.   

 
a. Modify your client routing table with the DATALOC command so that commands requesting data from 

a dataset in the group EAST are routed to the remote server with the IP address 
EASTA.SSEC.WISC.EDU.  (You may prefer to use your own data source or the RTGOESR group that 
can be routed to the remote server with the IP address LEAD.UNIDATA.UCAR.EDU.) 
 
DATALOC ADD EAST EASTA.SSEC.WISC.EDU  

 
b. Logon to the workstation to access the EAST dataset. (This step may be skipped when using RTGOESR 

from Unidata’s server.  All real time GOES commands for the remainder of the McIDAS-X tutorial will 
use the EAST group.) 
 
LOGON TEST 6999 
 

c. List all datasets available in the EAST group with the DSINFO command. 
 
DSINFO ALL EAST 

 
d. Run IMGLIST commands to see the available data in the datasets.  Using a position number of .-2 will 

list the 3 most recent times in the dataset.  Not specifying a position number will default to listing the 
most recent time. 
 
IMGLIST EAST/CONUS.-2 FORM=BAND 
IMGLIST EAST/FD FORM=ALL 

 
 



Page 10 of 47 
 

McIDAS Workshop                                                                           May 2018 – McIDAS-X version 2018.1; McIDAS-V version 1.7u1  

e. Run the following list of commands to erase the frames and display a loop of 4 BAND 9 CONUS 
images centered on Madison with a map.  Use 4 images and the REFRESH keyword to display a map on 
each frame.  Then set the loop sequence with the LS command and animate the loop. 
 
ERASE X 1 4 
IMGDISP EAST/CONUS.16 1 REP=4 BAND=9 STATION=KMSN SF=YES  

REFRESH='MAP GRA=(GRA) IMA=(IMA)' 
LS 1-4 
Alt-L (Press Alt-L again to stop the looping.) 
 

f. Run the following list of commands to erase frames 1-4 and fill the frames with the four most recent 
BAND 2 times in the full disk dataset and a map.  The LATLON= keyword centers the image at 20° N, 
80° W.  The MAG= -10 blows down the data by 10.  
 
ERASE X 1 4 
IMGDISP EAST/FD 1 ALL=1 4 BAND=2 MAG= -10 LATLON=0 90  

REFRESH='MAP GRA=(GRA) IMA=(IMA)' 
Alt-L (Press Alt-L again to stop the looping.) 

 
4. To access a remote ADDE server with Level 2 ABI netCDF product data, follow these steps. 
 

a. Add the group name to modify your client routing table with the ABIL2 group that exists on the server 
PAPPY.SSEC.WISC.EDU. 
 
DATALOC ADD ABIL2 PAPPY.SSEC.WISC.EDU 
 

b. Run DSINFO to find the available dataset names.  In this example, use “I” instead of “ALL” to list only 
the image datasets available in the ABIL2 group. 

 
DSINFO I ABIL2 
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c. Run IMGLIST with FORM=ALL for the expanded image list for the Cloud Top Temperature product. 
 
IMGLIST ABIL2/ACHTF FORM=ALL 
 

d. Display a loop of the Cloud Top Pressure product with a map and enhancement. 
 
ERASE X 1 4 
IMGDISP ABIL2/CTPC.4  1 REP=4 LAT=29 91 REFRESH='MAP GRA=(GRA) IMA=(IMA)' 
EU REST L2-CTP 1 4 
Alt-L (Press Alt-L again to stop the looping.) 
 
Note: In McIDAS-X 2018.1, 22 L2-*.ET files were added to the McIDAS-XRD distribution.  The 
calibration and related L2-*.ET files were updated to best match the color enhancements of AWIPS II.  
When McIDAS-XRD is installed, these files are added to the /home/mcidas/data directory and are 
named with the corresponding L2 product name. (e.g., L2-ACHA.ET, L2-TPW.ET, L2-DSI-CAPE.ET, 
etc.)  To list the files run the DMAP command. 
 
DMAP L2-*.ET 
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e. The DSI (Derived Stability Indices) product has multiple bands.  List the bands and display BAND 9 

which is the CAPE product (Convective Available Potential Energy).  Add the corresponding 
enhancement and use Alt-D to probe the data (Alt-D is a shortcut to execute IMGPROBE LIST POINT 
MODE=N). 
 
IMGLIST ABIL2/DSIC FORM=BAND 
SF 5 ; IMGDISP ABIL2/DSIC BAND=9 LAT=30 87 MAG=2 
EU REST L2-DSI-CAPE ; BAR ; MAP 
Alt-D 
 

f. Note the BAR on frame 5 is labeled with the 0-255 BRIT values. Make a BAR that is labeled with the 
calibrated CAPE values. 
 
SU INI DEMO X CAPE 
SU MAKE DEMO 0 5000 0 255 
EG LEV=3 ; BAR SU=DEMO RANGE=0 5000 LINT=200 
 
 

Using Other IMG* Commands with GOES-R Data 
 

The ADDE ABIN server reads netCDF files directly to do IMGLIST and IMGDISP display commands.  
IMGCOPY uses the ADDE ABIN server to read the netCDF file and to outputs a McIDAS AREA file. 
 

5. Use the ADDE commands to copy an ABI netCDF file to a McIDAS AREA file.   
(The following exercises will overwrite AREA0001 through AREA0009 files on your local machine.) 

 
a. Assign the MYDATA/TEST-IMAGES data to all of the AREA files on your local workstation.   

 
DSSERVE ADD MYDATA/TEST-IMAGES AREA 1 9999 "ALL AREA FILES 
 

b. Create the alias TI for the MYDATA/TEST-IMAGES dataset. 
 
AKA ADD TI MYDATA/TEST-IMAGES 

 
c. Copy the band 2 image from a local netCDF file to a local AREA file. 

 
IMGCOPY ABI/DATA.1 TI.1 BAND=2 STATION=KMSN 

 
d. Copy the band 14 image to a local AREA file at full resolution and list your new local AREA files. 

 
IMGCOPY ABI/DATA.1 TI.2 BAND=14 SIZE=SAME 
 

e. Copy a remote SST product file and list your new local AREA files. 
 
IMGCOPY ABIL2/SSTF TI.3 LAT=0 89 SIZE=960 1280 
IMGLIST TI.1 3 FORM=ALL 
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f. Display the AREA files. 
 
IMGDISP TI.1 6 REFRESH='MAP GRA=(GRA) IMA=(IMA)' 
IMGDISP TI.2 7 LAT=33 77 MAG=-2 REFRESH='MAP GRA=(GRA) IMA=(IMA)' 
IMGDISP TI.3 8 MAG=-2 REFRESH='MAP X X LALO GRA=(GRA) IMA=(IMA) ; EU REST 
L2-SST (IMA) (IMA)' 
 

g. Use the SF command to show each frame and inspect the data with the IMGPROBE command. Be sure 
to quit each IMGPROBE command with Alt-Q or by clicking the right and center mouse buttons. 
 
SF 6 ; IMGPROBE 
IMGPROBE HIST BOX BRIT 
 

h. Use the cursor size and IMGPROBE to inspect calibrated values on the IR and product images. 
 
CUR 11 11 
SF 7 ; IMGPROBE STAT BOX TEMP 
SF 8 ; IMGPROBE HIST LINE SST OUTL=YES 
 

6. Use IMGREMAP to create a remapped product AREA file. 
 

a. Create a rectilinear remapped product image at 4 km resolution.   
 
IMGREMAP EAST/CONUS.-1 TI.4 PRO=RECT LAT=38 91 BAND=12 SIZE=480 640 RES=4 
 

b. Display the new rectilinear AREA file. 
 
IMGDISP TI.4 9 SF=YES ; MAP X X LALO 
  

c. Use the PRO=DEST keyword in the IMGREMAP command to use an AREA file as the domain for a 
remapped product image. 
 
IMGREMAP ABIL2/ACMC TI.4 PRO=DEST SAVESRC=YES 
 

d. Now the cloud mask data will be in the product image AREA file. 
 
IMGDISP TI.4 10 SF=YES ; MAP X X LALO 

 
 
Problem Set 

 
IMGOPER is used to perform mathematical operations on images.  The domain of the source imagery must 
be the same for the operations to work correctly.  The source imagery can reside on remote servers, local 
ABI netCDF files or local AREA files.  Use IMGOPER to create a temperature difference image between 
two images in the ABIL2/LSTC dataset, make an enhancement for the difference, and put a color bar on the 
image that matches the scale of the data. 
 
 
 



Page 14 of 47 
 

McIDAS Workshop                                                                           May 2018 – McIDAS-X version 2018.1; McIDAS-V version 1.7u1  

 
Problem Set Solution 

 
1. Create a temperature difference image from two Land Surface Temperature product files on an ADDE 

server.  The output values are the product name DIFF and multiplied by 10.  The product values from -50 to 
50 are scaled from brightness 0 to 255. 

 
 IMGOPER ABIL2/LSTC.1 ABIL2/LSTC.4 TI.5 STA=KSTL SIZE=480 640 UNIT=LST   

FORM=ADD COEF=1 -1 SCALE=-50 50 0 255 MCON=10 PROD=DIFF 
 

2. Display, draw a map, place the cursor, and probe the data with 4 concatenated commands.  This will aid in 
creating the enhancement and color bar. 

 
IMGDISP TI.5 11 SF=YES ; MAP X 8 ; PC E 34 93 ; D 
 

3. The difference AREA file contains difference from the calibrated LST value, which is a temperature.  
Enhance the image from blue (cold negative values) to red (warm positive values), then make BRIT value 1 
black. 
 

EU MAKE 0 255 BLUE RED 
EU MAKE 0 1 BLACK 

 
 
4. Create the stretch table for the difference area file, then use SU= in the BAR command to display the color 

bar. 
 

SU INI DIFF X DIFF                   
SU MAKE DIFF -50 50 0 255            
BAR SU=DIFF 

 
 
 

Using GLM Data with GLM* Commands 
 

You can access GOES-R Series (GOES-16 and later) netCDF Geostationary Lightning Mapper (GLM) 
point files with the GLMDISP, GLMLIST and PT* commands by using DSSERVE to assign a dataset name 
to the files. When doing so, specify "GLMN" in the format parameter, TYPE=POINT, the directory and file 
masks to the netCDF point files in the DIRFILE keyword, and the configuration file that maps the netCDF 
file parameter names to McIDAS parameter names in the INFO keyword. The files must be mission-
standard format and follow the GRB naming convention, and thus look similar to OR_GLM-L2-
LCFA_G16_s20172151749200_e20172151749400_c20172151749467.nc. Three configuration files for 
GLM data are provided in the ~mcidas/data directory: GLM_EVENT.cfg, GLM_FLASH.cfg and 
GLM_GROUP.cfg. 
 
GLM data processing in the Ground System groups lightning flashes from the smallest increments (Events), 
to aggregates of Events (Groups) to aggregates of Groups (Flashes). Thus, Events are on a rectangular grid 
wherein each gridpoint is a GLM Field of View. Groups are plotted at the centroid of the Events that 
comprise the Group, and Flashes are plotted at the centroid of the Groups that comprise the Flash. Typically, 
the number of Events is greater than the number of Groups, which is greater than the number of Flashes. 
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Real-time GLM datasets normally consist of netCDF files that each contain 20 seconds of data. For 
example, there are separate files at 21:25:00, 21:25:20, 21:25:40, 21:26:00, 21:26:20, etc., assuming the 
GLM detected lightning during each of the corresponding 20 second intervals. 
 

1. Create local datasets to access the GLM netCDF files on your local machine in the 
Data/GOES16/GLM/NetCDF directory.  
   
OR_GLM-L2-LCFA_G16_s20180041656400_e20180041657000_c20180041657016.nc 
OR_GLM-L2-LCFA_G16_s20180041657000_e20180041657200_c20180041657218.nc 
OR_GLM-L2-LCFA_G16_s20180041657200_e20180041657400_c20180041657427.nc 
 
a. Run the DSSERVE command to access the Level 1b netCDF GLM point data files for each type of 

GLM data. 
 
DSSERVE ADD GLM/EVENT GLMN TYPE=POINT DIRFILE= '<local-
path>/Data/GOES16/GLM/NetCDF/OR_GLM*' INFO='<mcidas-
path>/mcidas/data/GLM_EVENT.cfg' 
DSSERVE ADD GLM/GROUP GLMN TYPE=POINT DIRFILE= '<local-
path>/Data/GOES16/GLM/NetCDF/OR_GLM*' INFO='<mcidas-
path>/mcidas/data/GLM_GROUP.cfg' 
DSSERVE ADD GLM/FLASH GLMN TYPE=POINT DIRFILE= '<local-
path>/Data/GOES16/GLM/NetCDF/OR_GLM*' INFO='<mcidas-
path>/mcidas/data/GLM_FLASH.cfg' 
 
 

b. Use the GLMLIST command to list each type of data and note the number of records for each type. 
 

GLMLIST NA TYPE=EVENT DATASET=GLM/EVENT DAY=4 TIME=16:58 
GLMLIST NA TYPE=GROUP DATASET=GLM/GROUP DAY=4 TIME=16:58 
GLMLIST NA TYPE=FLASH DATASET=GLM/FLASH DAY=4 TIME=16:58 

 
c. Use the MAP and GLMDISP commands to display each type over a small area. Inspect the differences 

with Alt-A and Alt-B to switch between the frames. 
 
SF 12;MAP DEF LAT=-7 0 LON=72 82 GRA=12-14 
GLMDISP TYPE=EVENT DATASET=GLM/EVENT DAY=4 TIME=16:58 
GLMDISP X 13 TYPE=GROUP DATASET=GLM/GROUP DAY=4 TIME=16:58 COL=3 
GLMDISP X 14 TYPE=FLASH DATASET=GLM/FLASH DAY=4 TIME=16:58 COL=2 
 

d. Display a conus image and use the time matching keywords in GLMDISP to overlay the corresponding 
GLM lightning GROUP display.  Then use the zoom feature to inspect the data closer. 
 
IMGDISP ABI/CONUS 15 BAND=2 MAG=-8 LAT=36 74 SF=YES 
GLMDISP TYPE=GROUP DATA=GLM/GROUP DAY=IMA 
Alt-Z (Move the cursor over the region with lightning strikes, press Alt-Z to toggle the zooming.) 
 

e. Display the same conus image at full resolution and use the POSITION= in GLMDISP to overlay the 
corresponding GLM lightning GROUP display with and without the parallax correction.  (Note: the 
default is POSITION=GROUND which plots the lightning strikes at the corrected ground positions, 
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keeping the native parallax correction in the GLM file.  POSITION=CLOUDTOP plots the lightning 
strikes at the approximate cloudtop positions as viewed from the GOES-R series satellite, removing the 
native parallax correction in the GLM file.) 
 
IMGDISP ABI/CONUS 16 BAND=2 LAT=39 63 SF=YES 
GLMDISP TYPE=GROUP DATA=GLM/GROUP DAY=IMA 
GLMDISP TYPE=GROUP DATA=GLM/GROUP DAY=IMA POSITION=CLOUDTOP COL=3 

 
2. To access a remote ADDE server with GLM netCDF point files, follow these steps to use the EAST dataset 

that was previously added.   
 

a. Inspect the dataset to identify the name of the GLM realtime datasets. 
 
DSINFO P EAST 
 

b. Display the most recent hour of FLASH data with a time step of 15 minutes over a specific domain.  
(Note: the GLM* commands default to the EAST servers in Satellite Data Services at SSEC.  If using 
other servers, DATASET= will need to be used with GLMLIST/GLMDISP, or the GLM.SITE or 
GLM.USER file will need to redefine the default GLM servers.)  
 
SF 17; GLMDISP TYPE=FLASH INC=60 15 LAT=-25 25 LON=40 90 

 
c. Display a band 13 full disk image and overlay the corresponding GLM GROUP data.  Display the data 

as asterisks (*). 
 
IMGDISP EAST/FD.-5 18 BAND=13 LAT=0 75 MAG=-10 SF=YES 
GLMDISP DAY=IMA LOC=* 
 

d. Display a band 2 full disk image and overlay the corresponding GLM GROUP data.  Display the 
GLMDISP data on the full image window and echo the PT* commands that are being executed to the 
text frame. 
 
IMGDISP EAST/FD.-5 19 BAND=2 LAT=0 75 MAG=-20 SF=YES 
GLMDISP TYPE=GROUP TIME=IMA ECHO=YES LEGEND=OFF 

 
e. Display a loop of band 9 full disk imagery with GLM FLASH data and a map overlaid one each frame. 

 
IMGDISP EAST/FD BAND=9 ALL=21 24 LAT=0 75 SF=YES MAG=-8 REFRESH=’MAP X X 
LALO IMA=(IMA) GRA=(GRA);GLMDISP X (GRA) TYPE=FLASH TIME=IMA’ 

 
 
Using the MCSTRETCH= Keyword When Displaying Imagery 
 

McIDAS-X versions 2017.2 and later include improvements to visualize more bit-depth in the data and 
provide more contrast in the images.  
 
This expanded stretch feature was added to increase the detail shown in visible, water vapor and short-wave 
infrared imagery when displayed with IMGDISP from an updated ADDE server or copied to a 1-byte Area 
file using commands like IMGCOPY with STYPE=VISR or IMGREMAP. This is done by expanding the 
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range of data values stretched out over the 8-bit brightness values in the higher reflectances in visible bands, 
and in the very hot temperatures in short-wave IR bands. The range of data values is narrowed in both 
colder and warmer temperatures in the water vapor bands. 
 
 
The examples and the list of satellites and bands can be found here:  
http://www.ssec.wisc.edu/mcidas/software/x/mcstretch_info.html 
 
Or the text file is included in the distribution and can be viewed with the SEE command: 
  
 SEE MCSTRETCH.TXT 
 

1. Display a current GOES-16 image in a paneled frame with and without MCSTRETCH. 
 

SF 25 ; PANEL 1 2 25 
IMGDISP EAST/FD.-1 STA=KSTL BAND=9  MAG=-2 PANEL=1 
IMGDISP EAST/FD.-1 STA=KSTL BAND=9  MAG=-2 PANEL=2 MCS=ORIG 
 

2. Analyze the data by using IMGPROBE/Alt-D to compare the BRIT values between the images.  (Note: The 
RAW/RAD/TEMP calibrated values remain the same.  The only difference is in the BRIT value for the 0-
255 value the pixel is displayed at.) 
 

PC C PANEL=1 ; D 
PC C PANEL=2 ; D 
 

3. Because EU tables are based on BRIT display values, the EU command was enhanced with a conversion 
option to convert old *.ET files to match the new stretched display BRIT values.  This option is EU CONV.  
 
The Data/MCSTRETCH directory contains a pre-2017.2 enhancement table: 
 
SPECTRUM_ORIG.ET 
 
a. Copy the SPECTRUM_ORIG.ET file to your local mcidas/data directory in a Unix terminal. 

 
b. Display a band 2 GOES-16 image with an original stretch and enhance it with SPECTRUM_ORIG.ET. 

 
IMGDISP ABI/CONUS 26  SF=YES BAND=2 LAT=15:38 75:08 MCS=ORIG 
EU REST SPECTRUM_ORIG  
 

c. Convert the SPECTRUM_ORIG file with EU CONV and use the converted *.ET file to display an 
enhanced (the default) display for the GOES-16 image.  (Note: The original file is saved in 
SPECTRUM_ORIG_OLD.ET.)  Compare frames 26 and 27 and place the cursor over the whitish areas 
and compare BRIT values 
 
EU CONV SPECTRUM_ORIG VIS 
IMGDISP ABI/CONUS 27  SF=YES BAND=2 LAT=15:38 75:08 
EU REST SPECTRUM_ORIG 
D 
 

http://www.ssec.wisc.edu/mcidas/software/x/mcstretch_info.html
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d. Display a current band 7 GOES-16 image in a paneled frame with and without MCSTRETCH and 
inspect the data. 
 
SF 28 ; PANEL 1 2 28 
IMGDISP EAST/FD.-1 STA=KMIA BAND=7  MAG=2 PANEL=1 
IMGDISP EAST/FD.-1 STA=KMIA BAND=7  MAG=2 PANEL=2 MCS=ORIG 
PC L KMIA PANEL=1 ; D 
PC L KMIA PANEL=2 ; D 
SU TAB SWIRCORE 
 
 

RGBDISP – Displaying and Looping RGB Imagery 
 

The RGBDISP command works similar to the COMBINE command, except that it displays its output color 
image in a regular image frame in the Image Window rather than in a separate Combine Window. 
RGBDISP uses the brightness (BRIT) values of the three input frames or datasets to calculate the red, green 
and blue components, respectively, of the output color image.  This allows the user to interactively use the 
RGB displays and create loops. 
 
The Data/RGBDISP/ directory contains AREA files that are used in the following examples. 
 
AREA3000 – 0.64um Himawari Band 3 
AREA3001 – 0.51um Himawari Band 2  
AREA3002 – 0.47um Himawari Band 1 
AREA3010 – 0.70um Meteosat-11 HRV Band 12 
AREA3011 – All bands Meteosat-11 Band 1-11 
 
Copy these files to your local mcidas/data directory or use the REDIRECT command to point to them: 
 
REDIRECT ADD AREA30* “<local-path>/Data/RGBDISP 
DSSERVE ADD AREA/RGB AREA 3000 3020 “AREA FILES FOR RGB 
 

4. Use the RGBDISP command to do a variety of RGB displays and loops. 
 
a. Display a True-Color RGB composite with the 0.64, 0.51 and 0.47 um images from the Himawari 

satellite, and echo the IMGDISP commands being executed. 
 
SF 29 ; RGBDISP AREA/RGB.1 AREA/RGB.2 AREA/RGB.3 MAG=-40 -20 -20 BAND=3 2 1 
ECHO=YES  
 

b. Display the RGB composite E-View display from Meteosat-11, a procedure developed by Eumetsat.  It 
is dedicated to detailed cloud monitoring including water clouds.  Use different LINELE= values to 
match up the images. 
 
SF 30 ; RGBDISP AREA/RGB.11 AREA/RGB.11 AREA/RGB.12 BAND=X X 9 MAG=-15 -15 -5 
PLACE=CENTER LIN='5580 5573' '5580 5573' '5583 5583' I 
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c. Create a loop of ‘Icing RGB’ in AWIPS (also called the ‘Day Land Cloud’ RGB) images using the real 

time GOES-16 server. 
 
SF 31 ; RGBDISP EAST/FD.-4 MAG=-6 -6 -12 BAND=5 3 2 STA=KSTL 
RGBDISP EAST/FD.-3 32 MAG=-6 -6 -12 BAND=5 3 2 STA=KSTL 
RGBDISP EAST/FD.-2 33 MAG=-6 -6 -12 BAND=5 3 2 STA=KSTL 
RGBDISP EAST/FD.-1 34 MAG=-6 -6 -12 BAND=5 3 2 STA=KSTL 
LS 31-34 ; Alt-L 

 
 

Problem Set 
 

Create an Airmass RGB jpeg image with the IMGOPER, IMGDISP, RGBDISP and FRMSAVE commands 
for the most recent image in the real-time ABI dataset. 
 
EUMETSAT has created many different useful RGB composites for their SEVIRI instrument, and many 
can be applied to GOES-16.  (http://oiswww.eumetsat.org/IPPS/html/MSG/RGB/) 
 
Airmass is an RGB composite based upon data from infrared and water vapor channels. It is designed and 
tuned to monitor the evolution of cyclones, in particular rapid cyclogenesis, jet streaks and PV (potential 
vorticity) anomalies. Due to the incorporation of the water vapor and ozone channels, its usage at high 
satellite viewing angles is limited. The Airmass RGB can be composed from a scaled combination of 
GOES-16 bands 8 (6.19 um high-level water vapor), 10 (7.34 um lower/mid-level water vapor), 12 (9.61 um 
ozone), and 14 (11.2 um longwave infrared). 
 
From http://www.eumetrain.org/RGBguide/recipes/recipe_Airmass_RGB.pdf: 
 

 
 

Color beam  Channel (difference)  Range [K]  
Red  WV6.2 – WV7.3  -25  0  
Green  IR9.7 – IR10.8  -40  +5  
Blue  WV6.2 inverted  243  208  

 
 
  

http://www.eumetrain.org/RGBguide/recipes/recipe_Airmass_RGB.pdf
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Problem Set Solution 
 

1. Run the following commands to create and display the scaled products for the RGB combination. 
 

IMGOPER EAST/FD.-1 EAST/FD.-1 TI.6 BAND=8 10 COEF=1 -1 MAG= -10 LAT=0 75 
UNIT=TEMP MISS=NONE SCALE=-25 0 0 255 

IMGOPER EAST/FD.-1 EAST/FD.-1 TI.7 BAND=12 14 COEF=1 -1 MAG= -10 LAT=0 75 
UNIT=TEMP MISS=NONE SCALE=-40 5 0 255 

IMGOPER EAST/FD.-1 TI.8 MAG= -10 BAND=8 LAT=0 75 UNIT=TEMP SCALE=243 208 0 255 
ERASE X 1 34 ; EU REST X 1 34 
IMGDISP TI.6 1 REP=3 SF=YES 
 
2. Use RGBDISP to combine the displays in three frames into a RGB image then FRMSAVE will convert 

the image into a jpeg file. 
 

      RGBDISP 1 2 3 4 
      SF 4 

FRMSAVE 4 AIRMASS_RGB 
 
FRMSAVE will list the output file path where the jpeg file is created.  Go to that directory and display it 
with a jpeg viewing application. 
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Note the following in the image: 

o Dry sinking air masses appear red in the Airmass RGB image. 
o In tropical and subtropical regions the RGB depicts hot and dry air masses in red-orange tones. 
o High reaching opaque clouds appear white in the image. Lower clouds turn into red, green or blue 

depending on the air mass they lay within. 
o Polar air masses appear blue in the image. 
o The blue color can also come from the so-called "limb cooling effect" at the edge of the image.



Page 22 of 47 
 

McIDAS Workshop                                                                           May 2018 – McIDAS-X version 2018.1; McIDAS-V version 1.7u1  

McIDAS-XRD: Servers for VIIRS/NOAA-20 Data  
 

McIDAS-XRD is a package containing research and development software that is not part of the core 
supported McIDAS-X package. The -XRD software is provided on an "as is" basis, meaning it is not MUG-
supported. 
 
Included in the –XRD package are servers that will serve VIIRS instrument data from the Suomi NPP and 
NOAA 20-24 JPSS satellites.  When using DSSERVE to create a VIIRS dataset, specify "VIIR" in 
the format parameter, TYPE=IMAGE, the directory and file masks to the data files in the DIRFILE= 
keyword, the directory and file masks to the geolocation files in the INFO= keyword, and "SVI" or "SVM" 
for the dataset descriptor (e.g., VIIRS/SVM). Also, the data (SVM*, SVI*) and terrain-corrected 
geolocation (GMTCO*, GITCO*) must be in separate files in the NOAA CLASS naming format.  
 

1. Create a local dataset to access the NOAA-20 HDF files on your local machine in the Data/NOAA20/VIIRS 
directory.  
   
GMTCO_j01_d20180513_t1811286_e1812531_b02503_c20180513183337907316_noac_ops.h5 
GMTCO_j01_d20180513_t1812544_e1814189_b02503_c20180513183342266088_noac_ops.h5 
GMTCO_j01_d20180513_t1814201_e1815447_b02503_c20180513183356170645_noac_ops.h5 
SVM03_j01_d20180513_t1811286_e1812531_b02503_c20180513183516946272_noac_ops.h5 
SVM03_j01_d20180513_t1812544_e1814189_b02503_c20180513183532011739_noac_ops.h5 
SVM03_j01_d20180513_t1814201_e1815447_b02503_c20180513183542156909_noac_ops.h5 
SVM04_j01_d20180513_t1811286_e1812531_b02503_c20180513183516953162_noac_ops.h5 
SVM04_j01_d20180513_t1812544_e1814189_b02503_c20180513183532023286_noac_ops.h5 
SVM04_j01_d20180513_t1814201_e1815447_b02503_c20180513183542163590_noac_ops.h5 
SVM05_j01_d20180513_t1811286_e1812531_b02503_c20180513183516968584_noac_ops.h5 
SVM05_j01_d20180513_t1812544_e1814189_b02503_c20180513183532035203_noac_ops.h5 
SVM05_j01_d20180513_t1814201_e1815447_b02503_c20180513183542171287_noac_ops.h5 
 

DSSERVE ADD NOAA20/SVM VIIR TYPE=IMAGE DIRFILE='<local-path> 
/Data/NOAA20/VIIRS/SVM*' INFO='<local-path>/Data/NOAA20/VIIRS/GMTCO*' 

 
2. Use the IMG* commands and RGBDISP to display and manipulate the data. 
 

a. Use IMGLIST to list out NOAA-20 band information. 
 
IMGLIST NOAA20/SVM.1 FORM=BAND 
 

b. Display an image with IMGDISP and use Alt-D to inspect it. 
 
IMGDISP NOAA20/SVM.2 5 SF=YES LAT=41 80 BAND=10 
Alt-D 
 

c. Use IMGCOPY with STYP=VISR, IMGREMAP, and IMGOPER to merge together Band 9 for two 
consecutive granules. 

 
IMGCOPY NOAA20/SVM.2 TI.9 BAND=9 SIZE=SAME STYPE=VISR 
IMGCOPY NOAA20/SVM.1 TI.10 BAND=9 SIZE=SAME STYPE=VISR 
IMGREMAP TI.9 TI.11 PRO=RECT RES=8 BAND=9 LAT=36 78 
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IMGREMAP TI.10 TI.12 PRO=RECT RES=8 BAND=9 LAT=36 78 
IMGOPER TI.11 TI.12 TI.13 FORM=CMIN MISS=NONE 
IMGDISP TI.12 6 SF=YES ; MAP 
 

d. The image is dark, IMGFILT will brighten the image with the default CLEAN filter. 
 
IMGFILT TI.13 TI.14 
IMGDISP TI.14 7 SF=YES ; MAP 
 

 
 
 
McIDAS-XRD: Creating GLM Density Plots with GLMIMG 
 

The GLMIMG command in the McIDAS-XRD package will take GLMLIST data, aggregate the lightning 
reports into bins and create an AREA file for display. 

 
1. Run GLMIMG to create a density image and merge it with the corresponding imagery with an 

enhancement. 
 
a. Run GLMIMG to create the density AREA file and display it. 

 
GLMIMG 40 'TYPE=EVENT TIME=1 INC=5 POS=CLOUDTOP DAY=#Y' ECHO=Y  
IMGDISP TI.40 8 SF=YES ; MAP 
 

b. Use the density image from the previous step and combine it with the corresponding image using 
IMGDISP, IMGREMAP and IMGOPER.  Then enhance the lightning density points. 
 
DATALOC ADD EASTAL EASTA.SSEC.WISC.EDU 
IMGOPER TI.40 TI.41 SCALE=0 255 0 50 
IMGCOPY EASTAL/CONUS TI.42 TIME=00:55 1:05 DAY=2018141 BAND=13 STYPE=VISR 
LAT=40 96 SIZE=1200 1200 
IMGREMAP TI.41 TI.43 PRO=RECT RES=6 LAT=40 96 
IMGREMAP TI.42 TI.44 PRO=RECT RES=6 LAT=40 96    
IMGOPER TI.43 TI.44 TI.45 FORM=CMIN MISS=NONE 
IMGDISP TI.45 9 SF=YES; MAP  
EU MAKE 0 50 WHITE YELLOW 
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McIDAS-V Tutorial  
Using GOES-16 and JPSS Data 

Created May 2018 (software version 1.7u1) 
 
McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 
SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 
(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 
manipulate data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's 
IDV libraries. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V 
for viewing and analyzing hyperspectral satellite data. 

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 
McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 
the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 
http://www.ssec.wisc.edu/mcidas/software/v/. 

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 
Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share 
information with other users. 

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 
McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the 
document entitled McIDAS-V Tutorial – Installation and Introduction. 

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 
Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 
Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 
Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources). 
 
Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag). 

ABI Introduction 

McIDAS-V currently supports ABI netCDF data through remote servers as well as through the local file 
chooser on all platforms.  Local servers for ABI data are currently available on OS X and Linux platforms.  This 
tutorial will cover how to access this data through remote servers and different ways that the data can be 
displayed and interrogated in McIDAS-V. 
 

 

http://www.ssec.wisc.edu/mcidas/software/v/
http://www.ssec.wisc.edu/mcidas/forums/
http://www.ssec.wisc.edu/mcidas/forums/
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Accessing GOES-16 ABI Data from a Remote Server – 1 Timestep 

 

1. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  Select 
lead.unidata.ucar.edu as the Server and RTGOESR as the Dataset.  Click Connect. 
 

2. Select FD – GOES-16 FD all bands as the Image Type. 
 

3. In the Times panel, select the Relative tab.  For Number of times, enter 1 and click Add Source to create a 
data source of the most recent time. 
  

4. Display band 13 temperature data. 
 
a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the 

data.  Select the 10.3 um IR Surface & cloud -> Temperature field. 
 

b. From the Displays panel, select the Imagery -> Image Display display type. 
 

c. Select the Region tab to see a low-resolution preview image of the data.  Note that there is a green box 
drawn around the preview image.  Any data inside this bounding box will be displayed. 
 

d. Select the Advanced tab to see information about the band and calibration selected.  These values match 
the domain of the data selected in the Region tab, so it covers the entire domain of the data.  Notice that 
the Image Size is only 904 x 904 when the raw size of the data is 5424 x 5424.  The magnification of the 
data is set to -6, -6.  This reduction in resolution is the default to allow for an efficient display of the 
data.  Modify the Advanced tab to display full resolution data over Florida. 
 
i. Coordinate Type: Latitude/Longitude 

ii. Location: Center 
iii. Lat: 28; Lon: -83.5 
iv. Image Size: 400 x 400 
v. Magnification: 1 x 1 

 
e. Click Create Display. 

 
5. Investigate the display. 

 
a. In the Main Display window, practice navigating around in the display.  To do this, use Control+Right-

Click+Drag to translate the display.  This shifts the data left/right and up/down without rotating the 
display.  Zoom in on the display by scrolling down on the mouse wheel.  As an alternative, select a 
region in the Main Display by using Shift+Left-Click+Drag to zoom in on a specific domain. 
 

b. Probe individual pixel values by holding down the middle mouse button over the display.  This will print 
out probe values at the bottom of the display.  Notice that latitude, longitude, and temperature values are 
included in the probe output. 
 

c. Navigate to the Histogram tab of the Layer Controls to see a histogram of band 13 temperature values. 
 



Page 26 of 47 
 

McIDAS Workshop                                                                           May 2018 – McIDAS-X version 2018.1; McIDAS-V version 1.7u1  

6. Add a data transect to the display. 
 
a. From the Field Selector tab of the Data Explorer, select the Data Transect display type and click 

Create Display. 
 

b. In the Main Display window, there is a red line that is referred to as the data transect.  The values along 
this transect line are output in the Layer Controls tab of the Data Explorer.  The two end points of the 
transect can be moved around by Left-Clicking+Dragging them, or by entering new Lat/Lon values at 
the bottom of the Display tab in the Layer Controls.  The transect line as a whole can be moved by Left-
Clicking+Dragging the triangle in the middle of the transect line.  
 

7. Create a display of the 10.3 micron temperatures so only values of 273K and less are plotted. 
 
a. Add a new two-paneled map display by selecting File -> New Display Tab -> Map Display -> Two 

Panels menu item. 
 

b. Left-Click in the left panel to make this panel active.  The active panel has a blue frame around it, and 
this is the panel any displays will be added to. 
 

c. In the Field Selector tab of the Data Explorer, select the 10.3 um IR Surface & cloud -> Temperature 
field.  Choose the Imagery -> Image Display display type and click Create Display.  
 

d. Create the cloud mask display. 
 
i. Left-Click in the right panel to make this panel active.  The active panel has a blue frame around it, 

and this is the panel any displays will be added to. 
 

ii. In the Field Selector tab of the Data Explorer, select Formulas. 
 

iii. Select the Imagery -> Mask Value formula, the Imagery -> Image Display display type, and click 
Create Display. 
 

iv. In the Select input window, enter the following and then click OK: 
 
1. comparison: < 
2. cutoff: 273 
3. useNaN: 1 

Notes: The comparison is set to < or ‘less then’ since the goal is to display values less than 273, 
which was set as the cutoff value.  Setting useNaN to 1 makes it so that if the pixels were probed 
outside of the masked range (where values are greater than 273) they wouldn’t show a value.  
useNaN can be set to 0 as well, and in this case pixel values greater than 273 would probe as 0.  
Note that if these pixel values are set to 0, then these 0 values will be included in any 
calculations with the data that may be done later. 
 

v. In the new Field Selector window, for inputFieldForMask, select 10.3 um IR Surface & cloud -> 
Temperature.  This is the field that is being masked. 
 

vi. For displayFieldToBeMasked, select 10.3 um IR Surface & cloud -> Temperature.  This is the 
field that will be displayed where the inputFieldForMask is less than 273 degrees.  In this case, we 
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are displaying the same field that is being masked. 
 

vii. Click OK. 
 

e. Investigate the display.  Note that as one of the panels is navigated, the other will be navigated in the 
same way.  This is because by default panels in the same tab are set to share views.  This setting can be 
disabled in a panel by unchecking Projections -> Share Views in the display panels. 
 

8. Create a display of a subtraction of two bands. 
 
a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One 

Panel menu item, or by clicking the Add new tab ( ) button in the Main Toolbar. 
 

b. In the Field Selector tab of the Data Explorer, select Formulas. 
 

c. Select the Miscellaneous -> Simple difference a-b formula, the Imagery -> Image Display display type, 
and click Create Display. 
 

d. In the new Field Selector window, for a, select the 8.44 um IR Total WV cloud phase, dust -> 
Temperature field.  For field b, select the 7.34 um IR Lower-level WV, winds & SO2-> Temperature 
field. 
 

e. Click OK in the Field Selector window to display the band subtracted data. 
 

f. Right-Click on the colorbar of the ABI layer in the Legend and select the System -> Inverse Gray Scale 
enhancement. 
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g. Add latitude and longitude labels to the display. 
 
i. Left-Click on the blue text for the Default Background Maps layer in the Legend to get to the Layer 

Controls tab of the Data Explorer for the layer. 
 

ii. From the Lat/Lon tab of the Layer Controls, set the following: 
 
1. Check the visibility checkboxes for Lines and Labels to plot them in the display. 
2. Lines: Interval: 5.0 
3. Labels: Interval: 5.0; At Longitudes: -85.0, At Latitudes: 30.0, Color: light blue 
4. Font: Arial; Bold; 20 

 

  
 

h. Investigate the display to see the latitude and longitude lines and labels.  Probe the data to see the 
temperature difference between the two bands. 
 

9. Capture an image of the display. 
 
a. From the Main Display, select the View -> Capture -> Image menu item. 

 
b. In the Save As text field, enter the name to give your image, for example: band_subtraction.gif. 

 
c. Use the dropdown below Save As to select the directory to save your image to. 

 
d. Under Capture What, select Current View.  This will capture an image of the display without including 

any other components of the Main Display such as menu items and the Legend. 
 

e. Click Save. 
 

f. View your saved image to verify the image was captured correctly. 
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Accessing GOES-16 ABI Data from a Remote Server – 5 Timesteps 
 
10. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and 

Data Sources menu item from the Main Display. 
 

11. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel 
menu item.  Close any previously-existing tabs. 
 

12. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  In the Relative 
tab of the Times panel, for Number of times, enter 5 and click Add Source. 
 

13. Display a loop of 10.4um Temperature data over Wisconsin and Illinois. 
 
a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the 

data.  Select the 10.3 um IR Surface & cloud -> Temperature field. 
 

b. From the Displays panel, select the Imagery -> Image Display display type. 
 

c. Navigate to the Advanced tab, and enter the following information: 
i. Coordinate Type: Latitude/Longitude 

ii. Location: Center 
iii. Lat: 42; Lon: -89.6 
iv. Image Size: 450 x 450 
v. Magnification: 1 x 1 

 
d. Click Create Display. 

 
14. Investigate the display. 

 
a. The Main Display now has a loop of the 5 most recent times of data in the FD dataset.  As done in step 

5 earlier, navigate around and zoom in/out of the display.  Probe the display by holding down the middle 
mouse button over the data. 
 

b. Use the Time Animation Widget at the top of the display panel to play through a loop of the data. 
 

 
 

c. Click the Properties button ( ) in the Time Animation Widget to modify settings of the animation 
including the dwell rate (the time spent on each frame in the animation).  As an example, set the 
Forward, First, and Last dwell rates to 0.2 and click OK.  This reduced dwell rate allows the display to 
loop faster. 
 

15. Change the enhancement used in the display. 
 
a. Stop the animation by clicking the Stop Animation button in the Time Animation Widget ( ). 
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b. Right-Click on the colorbar of the ABI layer in the Legend and select the Satellite -> GOES-R -> ABI 
IR Temperature enhancement.  
 

16. Add a color scale to the display. 
 
a. Right-Click on the ABI layer in the Legend and select Edit -> Properties. 

 
b. In the Properties window, navigate to 

the Color Scale tab and set the 
following: 
i. Visible: Check this option to add 

the color scale to the display. 
ii. Position: Top.  This will position 

the color scale at the top of the 
display. 

iii. Labels -> Visible: Check this 
option to add numerical labels to 
the color scale. 

iv. Labels -> Show Unit: Check this 
to add the display unit to the color 
scale labels. 

v. Labels -> Font: Set the size to 32. 
 

c. Click OK. 
 

17. Create a Data Probe/Time Series display of band 13 temperature data.  This display type allows for plotting 
how temperature values at a specific location change through time throughout the loop. 
 
a. In the Field Selector tab of the Data Explorer, select the Data Probe/Time Series display type and 

click Create Display. 
 

b. The Layer Controls tab of the Data Explorer now shows a time series display of temperature values at 
the location of the probe in the Main Display.  Change the range of the y-axis (temperature values) to 
match the range of the data. 
 
i. At the bottom of the Layer Controls tab, Double-Click on the 186-Band13_TEMP parameter to open 

the Properties window. 
 

ii. In the Properties window, change the Range text boxes to a Min of 180 and a Max of 320 to match 
the range of the enhancement in the Main Display. 
 

iii. Click OK to apply the new range in the Layer Controls and close the Properties window. 
 

c. Move the data probe in the Main Display around with Left-Click+Drag.  The time series display in the 
Layer Controls automatically updates itself as the probe’s location changes. 
 

d. The data probe in the Main Display can also be set to a specific latitude/longitude value by using the 
Lat and Lon text boxes at the bottom of the Layer Controls.  For example, enter values of 38.6 for Lat 
and -88.1 for Lon.  Note that you must press Enter in each text field for latitude/longitude to update the 
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location of the data probe. 
 

 
Accessing ABI Data from a Remote Server through Scripting 
 
Both of the previous sections of this tutorial can be replicated through scripting.  This section covers creating a 
loop of ABI data and applying an enhancement to the display. 
 
18. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and 

Data Sources menu item from the Main Display. 
 

19. From the Main Display, select Tools -> Formulas -> Jython Shell to open the Jython Shell. 
 

20. The Jython Shell defaults to single-line input mode, where only one line of code can be executed at a time.  
This script is more than one line long, so it requires multi-line input.  To switch to multi-line input, click the 
double-down blue arrow button ( ) to the right of the text entry box. 
 

21. In a text editor, open the Data/GOES16/abiLoop.py file.  Copy this text and paste it into the Jython Shell. 
 

22. To evaluate this code, click the Evaluate button, or use Shift+Enter.  In-line documentation of what the 
script is doing can be found in the script (lines that begin with ‘#’ are comments).  More information about 
McIDAS-V scripting can be found in the User’s Guide as well as the Scripting and User Functions tutorials. 
 

23. After you are done analyzing the display created with the script, close the new display window. 
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Using GOES-16 GLM and Satellite Derived Winds 
 
24. This section of the tutorial uses a new Data Type through the General -> Files/Directories chooser as well 

as a new layout model which is must be 
added via a plugin.  Add this plugin.  
 
a. From the Main Display window, 

navigate to the Tools -> Plugins -> 
Manage menu item to open the 
Plugin Manager. 
 

b. The top of the Plugin Manager lists 
plugins currently installed, and the 
bottom panel lists the various 
plugins available for installation.  
Expand the Data Sources tree and 
click the green Install Plugin button 
next to GLM NetCDF Files. 
 

c. This pops up a message notifying 
the user that McIDAS-V must be 
restarted to complete the installation 
of the plugin.  Click OK through 
this message and restart McIDAS-
V. 
 

25. Display GOES-16 band 14 data. 
 
a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/ABI 

directory. 
 

b. Select the GOES16_CONUS* file. 
 

c. From the Data Type dropdown, select Grid files (netCDF/GRIB/OPeNDAP/GEMPAK). 
 

d. Click Add Source. 
 

e. In the Fields panel of the Field Selector, verify that brightness_temperature is selected. 
 

f. In the Displays panel of the Field Selector, select Imagery -> Image Display. 
 

g. Click Create Display. 
 

26. Modify the display of the GOES-16 band 14 data. 
 
a. To make the cold clouds white and the relatively warmer land darker, change the enhancement used by 

the displayed layer by Right-Clicking on the colorbar in the Legend and selecting System -> Inverse 
Gray Scale. 
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b. Disable the wireframe box around the display by selecting View -> Show -> Wireframe Box in the 
display panel. 
 

c. Other layers will be added to the display in the next several steps.  To maintain the current projection, 
from the display panel, disable Projections -> Auto-Set Projection. 
 

27. Add a data source of six consecutive (2 minutes total) GLM files as group data. 
 
a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/GLM 

directory. 
 

b. Use Shift+Left-Click to select all six OR_GLM-L2-LFCA* files. 
 

c. From the Data Type dropdown, select GLM Groups Data files.  This data type was added from the 
plugin that was installed in step 24 above. 
 

d. Click Add Source. 
 

28. By default, each data point in each GLM file has its own timestep, which would create a loop of potentially 
thousands of frames.  Bin all of the times together so each data point plots at the same timestep. 
 
a. From the Field Selector, Right-Click on the 6 Files Data Source and choose Properties. 

 
b. At the bottom of the Properties tab of this window, find the Time Binning section.  Set the following 

using the dropdown menus:  
 
Bin Size: 5 minutes 
Round To: 1 hour 
 
A bin size of 5 minutes is large enough to contain all of the data.  The round to value of 1 hour sets this 
timestep to be right on the hour, 13Z, thus matching the time of the band 14 data displayed earlier. 
 

c. Click OK at the bottom of the Properties window. 
 

29. Display the GLM data. 
 
a. In the Fields panel of the Field Selector, select Point Data. 

 
b. In the Displays panel of the Field Selector, choose the Point Data -> Point Data Plot display type. 

 
c. In the Layout Model subset tab, click the double-down blue arrows next to None and choose GLM -> 

Group.  This layout model was added from the plugin that was installed in step 24 above. 
 

d. Click Create Display. 
 

30. Investigate and modify the display of GLM data.  Note that the points of GLM data are parallax-corrected 
(from the data itself), so they may not perfectly match up with the location of the band 14 imagery, which is 
not parallax-corrected. 
 



Page 34 of 47 
 

McIDAS Workshop                                                                           May 2018 – McIDAS-X version 2018.1; McIDAS-V version 1.7u1  

a. The pink plus signs in the display represent the GLM group data points.  As you zoom in and out of the 
display, you’ll see the number of points change.  This is because of decluttering that McIDAS-V does to 
the display.  To modify the decluttering, Left-Click on the 6 files data source in the Legend to get to the 
Layer Controls of the layer.  Disable the Declutter checkbox to show every point.  Another option 
would be leaving Declutter enabled (checked) and adjusting the Density slider.  As the slider moves to 
the right, more points will be shown. 
 

b. If you wish to change the size of the plus signs in the display, adjust the Scale value in the Layer 
Controls.  Decreasing the value from 1 (for example, 0.5) will make the points smaller.  Increasing the 
value from 1 (for example, 2) will make the points larger. 
 

31. Add a data source of satellite derived winds. 
 
a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/Derived 

Winds directory. 
 

b. Select the OR_ABI-L2-DMWC* file. 
 

c. From the Data Type dropdown, select netCDF/GEMPAK Point Data files. 
 

d. Click Add Source. 
 

32. Display the satellite derived winds. 
 
a. In the Fields panel of the Field Selector, choose the Point Data field. 

 
b. In the Displays panel of the Field Selector, choose the Point Data -> Point Data Plot display type. 

 
c. A new layout model will be imported to plot the satellite derived winds colored by speed.  To do this, go 

to the Layout Model subset tab of the Field Selector and choose Edit. 
 

d. From the Layout Model Editor window, select File -> Import. 
 

e. From the Layout Model import window, select the <local data>/Data/GOES16/G16_Winds.ism file 
and click Open. 
 

f. From the Layout Model Editor window, select File -> Save and close the Layout Model Editor.   
 

g. From the Layout Model subset tab of the Field Selector, click the double-down blue arrows next to 
None and choose G16_Winds <local>. 
 

h. Click Create Display. 
 

33. Investigate and modify the display of GOES-16 satellite derived winds using the same methods used in step 
30 above with GLM data. 
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JPSS Introduction 
 
McIDAS-V has the ability of displaying JPSS (Suomi NPP and NOAA-20) data through the Under 
Development -> Imagery – JPSS chooser.  Among the JPSS products that McIDAS-V can display are data 
from the VIIRS (all bands of SVM and SVI, EDRs, Day/Night band), CrIS, and ATMS instruments.  In order 
for the data to be recognized by McIDAS-V, the geolocation files must be contained within the same directory 
as the data.  Some sources of data, including NOAA’s CLASS, package the data and geolocation files together 
by default.  Other sources of JPSS data may store the geolocation in a separate file from the data.  Note that this 
chooser is still under development and improvements in functionality as well as the ability to utilize different 
JPSS products will be added in the future. 
 
Installing the VIIRS Formulas Plugin 
 
34. This section of the tutorial uses two 

formulas specifically designed to 
work with VIIRS data.  These 
formulas are not packaged as part of 
the core group of formulas in 
McIDAS-V, and must be added via 
a plugin.  Add this plugin. 
 
a. From the Main Display 

window, navigate to the Tools -
> Plugins -> Manage menu 
item to open the Plugin 
Manager. 
 

b. The top of the Plugin Manager 
lists plugins currently installed, 
and the bottom panel lists the 
various plugins available for 
installation.  Expand the 
Miscellaneous tree and click the 
green Install Plugin button next 
to VIIRS Formulas. 
 

c. This pops up a message notifying the user that McIDAS-V must be restarted to complete the installation 
of the plugin.  Click OK through this message and restart McIDAS-V.  

 
 
Display a Single Granule of NOAA-20 Data 
 
35. Load a single granule of NOAA-20 SVM03 VIIRS data. 

 
a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS. 

 
b. Under Files, select the following file: 

 
<local path>/Data/ NOAA20/VIIRS/SVM03_j01_d20180513_t1814201* 



Page 36 of 47 
 

McIDAS Workshop                                                                           May 2018 – McIDAS-X version 2018.1; McIDAS-V version 1.7u1  

 
Note that the <local path>/Data/NOAA20/VIIRS directory contains nine SVM data granules (three 
timesteps of three different bands).  There are also three GMTCO* geolocation files (one for each 
timestep) that are in this directory, but are either not visible or grayed out through this Imagery – JPSS 
chooser. 
 

c. Click Add Source. 
 
Note that the first time a JPSS granule is added through this chooser, a Plugin Compatibility Notice 
window may appear letting users of the older version of the VIIRS Formulas plugin know that a new 
one is available.  In step 34 above the most recent version of this plugin was installed.  Click the Do not 
show this message again checkbox and click OK. 
 

36. Display Radiance data at low resolution. 
 
a. In the Field Selector tab of the Data Explorer, select the VIIRS-M3-SDR_All/Radiance field, and the 

Imagery -> Image Display display type. 
 

b. Note that the Region tab in the Field Selector shows a preview image of the selected field. 
 

c. Click Create Display. 
 

d. Investigate the display and note that the resolution of the display is course, not the native 750 meter 
resolution of the data.  This is because no subsetting of the data was done in the Region tab of the Field 
Selector. 
 

37. Display Radiance data at the full resolution of the data. 
 
a. From the Region tab of the Field Selector, use Shift+Left-Click+Drag to draw a green box in the data.  

Any data contained within this box will be displayed at full resolution.  Note that the entire box must be 
contained within the granule’s data. 
 

b. Click Create Display. 
 

c. Investigate the display and note that the resolution of the data has improved.  However, note that the 
bowtie deletion lines still exist on the east and west edges of the granule. 
 

38. Use the swathToGrid formula to display the Radiance data at full resolution with the bowtie deletion lines 
removed. 
 
a. In the Field Selector tab of the Data Explorer select Formulas. 

 
b. Choose the swathToGrid formula, the Imagery -> Imagery Display display type, and click Create 

Display.  Note that this formula was added as part of the plugin installed in step 34 above. 
 

c. In the Select input window, enter a value of 750 for resolution in meters and click OK. 
 

d. In the Field Selector window, select the VIIRS* -> Image -> VIIRS-M3-SDR_All/Radiance field. 
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e. Wait for the Region tab to appear at the bottom of the Field Selector window showing a preview image 
of the granule and click OK. 
 

f. Investigate the display and notice that the data is now displayed at full resolution with the bowtie 
deletion lines removed. 
 

g. When you are done investigating the display, remove all layers and data sources. 
 
Create a RGB Display with Aggregated Granules 
 
McIDAS-V has the ability to aggregate several small granules into one large one by selecting multiple time-
consecutive granules in the Data Sources tab of the Data Explorer before clicking Add Source.  Multiple 
bands can also be included in the same data source if the times match up between the bands. 
 
39. Create a data source of three time-consecutive granules of three visible SVM bands. 

 
a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS. 

 
b. Use Shift+Left-Click to select all of the SVM* data files. 

 
c. Click Add Source. 

 
d. From the Field Selector tab of the Data Explorer, notice that all three bands (SVM03, SVM04, and 

SVM05) are included in the list in the Fields panel. 
 

40. Use the VIIRS_M_RGB(M5, M4, M3) formula to create a RGB display from the data source. 
 
a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One 

Panel menu item.  Close any previously-existing tabs. 
 

b. In the Field Selector tab of the Data Explorer, select Formulas. 
 

c. Choose the VIIRS_M_RGB(M5, M4, M3) formula, the RGB Composite display type, and click Create 
Display. 
 

d. In the Field Selector window, select the following: 
 
i. Field M5: VIIRS 2018-05-13 18:11:28 GMT -> Image -> VIIRS-M5-SDR_All/Radiance. 

 
Once the Region tab appears, use Shift+Left-Click+Drag to draw a bounding box within the bounds 
of the data.  This subsetting step only has to be done for this field (the Red component of the 
formula) since this domain will be carried over to the Green and Blue fields.  Make sure that the 
subsetted area includes land, water, and data near the east and/or west edges of the granule to include 
the bowtie deletion regions. 
 

ii. Field M4: VIIRS 2018-05-13 18:11:28 GMT -> Image -> VIIRS-M4_SDR_All/Radiance. 
 

iii. Field M3: VIIRS 2018-05-13 18:11:28 GMT -> Image -> VIIRS-M3_SDR_All/Radiance. 
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e. Once all three Region subset tabs are visible, click OK at the bottom of the Field Selector window. 
 

41. Investigate and brighten the display to make it easier to interpret. 
 
a. From the Main Display window, notice that the display looks mainly black and white, though the 

bowtie deletion lines have been removed and the data is at full (750 meter) resolution. 
 

b. Click on the blue RGB Composite text in the Legend of the Main Display to get to the Layer Controls 
tab of the Data Explorer. 
 

c. The intensities of the red, green, and blue colors are controlled by their Gamma values.  Adjust all three 
colors to have a Gamma value of 0.4 by typing 0.4 into the Common Gamma field of the Layer 
Controls and click Apply to All Gamma Fields. 
 

d. Go back to the Main Display and notice how the red, green, and blue colors are now more intense and 
you can see green and brown over the land and blue over areas of water. 
 

e. By default, a wireframe box is drawn in the Main Display.  This is the white box going around and 
partially through the data.  Disable the wireframe box by unselecting View -> Show -> Wireframe Box 
from the panel in the Main Display window. 
 

f. When you are done investigating the display, remove all layers and data sources. 
 
Note that this formula suggests the user selects SVM05 for Red, SVM04 for Green, and SVM03 for 
Blue to create a true color RGB display.  However, any bands can be used to create different types of 
RGB displays. 
 

 
Using CrIS Data in McIDAS-V 
 
This section utilizes CrIS data from NOAA-20.  The <local path>/Data/NOAA20/CrIS directory contains 
SCRIS data files and GCRSO geolocation files.  Only the SCRIS data files will be listed in the Imagery – JPSS 
chooser. 
 
42. Create a data source of nine time-consecutive granules of SCRIS data. 

 
a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS. 

 
b. In the Files panel, navigate to the <local path>/Data/NOAA20/CrIS directory. 

 
c. Use Shift+Left-Click to select all of the SCRIS* data files. 

 
d. Click Add Source. 

 
43. Display the data and investigate the display. 

 
a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One 

Panel menu item.  Close any previously-existing tabs. 
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b. In the Fields panel of the Field Selector, verify that the CrIS-SDR_All/ES_RealLW field is selected. 
 

c. In the Displays panel of the Field Selector, select the Imagery -> MultiSpectral Display display type. 
 

d. Click Create Display. 
 

e. This display type creates a grayscale display in the Main Display window along with two data probes 
(originally stacked on top of each other), as well as a spectra in the Layer Controls.  Move the probes 
around in the Main Display window by using Left-Click+Drag to place one probe over a cloud and one 
over cloud-free land.  Compare the spectras in the Layer Controls. 
 

f. From the Layer Controls tab of the Data Explorer, use Left-Click+Drag to move the green selector line 
to a new wavenumber value.  Notice that the grayscale display in the Main Display window updates 
itself to reflect the new wavenumber. 
 

g. When you are done investigating the display, remove all layers and data sources. 
 
 
Using ATMS Data in McIDAS-V 
 
This section utilizes ATMS data from NOAA-20.  The <local path>/Data/NOAA20/ATMS directory contains 
SATMS data files and GATMO geolocation files.  Only the SATMS data files will be listed in the Imagery – 
JPSS chooser. 
 
44. Create a data source of eight time-consecutive granules of SATMS data. 

 
a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS. 

 
b. In the Files panel, navigate to the <local path>/Data/NOAA20/ATMS directory. 

 
c. Use Shift+Left-Click to select all of the SATMS* data files. 

 
d. Click Add Source. 

 
45. Display the data and investigate the display. 

 
a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One 

Panel menu item.  Close any previously-existing tabs. 
 

b. In the Fields panel of the Field Selector, select MultiSpectral -> ATMS-
SDR_All/BrightnessTemperature. 
 

c. In the Displays panel of the Field Selector, select the Imagery -> MultiSpectral Display display type. 
 

d. Click Create Display. 
 

e. Investigate the display as done in steps 43e and 43f above.  One difference is this ATMS data uses 
channel numbers instead of wavenumbers.  Notice how the longer wavelengths make areas with more 
precipitation stand out over Iowa and the Atlantic Ocean. 

 



Page 40 of 47 
 

McIDAS Workshop                                                                           May 2018 – McIDAS-X version 2018.1; McIDAS-V version 1.7u1  

 
Using Day/Night Band Data in McIDAS-V 
 
This section utilizes VIIRS Day/Night band data from Suomi NPP.  This data, ordered from NOAA CLASS, 
packages the data (SVDNB) and geolocation (GDNBO) into the same file.  Each file includes several small 
granules aggregated together to cover a relatively large geographical area. 

46. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and 
Data Sources menu item from the Main Display. 
 

47. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel 
menu item.  Close any previously-existing tabs. 
 

48. Create a data source of the two time-consecutive files of GDNBO-SVDNB* files. 
 
a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS. 

 
b. In the Files panel, navigate to the <local path>/Data/SuomiNPP directory. 

 
c. Use Shift+Left-Click to select both of the GDNBO-SVDNB* files. 

 
d. Click Add Source. 

 
49. Display the data and investigate the display. 

 
a. In the Fields panel of the Field Selector, select IMAGE -> VIIRS-DNB-SDR_All/Radiance. 

 
b. In the Displays panel of the Field Selector, 

select the Imagery -> Image Display display 
type. 
 

c. In the Region tab of the Field Selector, use 
Shift+Left-Click+Drag to draw a green bounding 
contained entirely within the data over the 
eastern United States extending into the Atlantic 
(similar to this image).  Any data in this 
bounding box will be displayed at the full 
resolution of the data. 
 

d. Click Create Display. 
 

50. Investigate the display. 
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a. In the Main Display window, you will likely notice that no data is visible.  This is due to the 
enhancement range values being set based on the minimum and maximum values contained in the data.  
Adjust the enhancement by Right-Clicking on the enhancement in the Legend and choosing Change 
Range…. 
 

b. In the Change Range window, enter From and To values that better match up with the radiance values 
contained in the display.  For example, you can use values of: 
 
From: 8.8E-10 
To: 1.9E-8 
 

c. This is near full-moon scene, which allows for a display similar to a daytime visible image to be viewed.  
Other features, such as city lights and ships can be viewed in this scene.  The range set in step 50b can 
be expanded or contracted on either end to make different features easier to see.  
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Problem Sets 
 
The previous examples were intended to give you a general knowledge of how to load and display JPSS 
data.  The problem sets below are intended to introduce you to new topics related to the data, as well as 
challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem set 
before looking at the solutions, which are provided below the problem set. 
 
Note that this example utilizes Suomi NPP data from NOAA CLASS.  The files contain both the data and 
geolocation in the same file.  Also, several small granules are aggregated together into one file, so a relatively 
large geographic domain is covered by a single file. 
 
1. Using the <local path>/Data/SuomiNPP/GMODO-SVM03-SVM04-SVM05* file, create an RGB image 

using the Reflectance field of all three bands.  Create the display by using the 
VIIRS_M_RGB(M5,M4,M3) formula.  Display the data at full-resolution and make sure to include a large 
portion of the granule in your subsetted region.  Adjust the Common Gamma field in the Layer Controls to 
make the individual colors stand out more in the display. 
 

2. Looking at the display over the Great Lakes, it is difficult to discern between clouds and snow over the land. 
Using the file loaded from question 1, display SVM14 brightness temperature data with the swathToGrid 
formula over the Great Lakes region.  Adjust the enhancement to make the clouds display as white instead 
of black.  Overlay this display on the RGB image created in problem 1. This longwave infrared band is 
useful to distinguish between clouds and snow.  
 

3. Looking at the RGB display over Louisiana, smoke can be observed.  Using the file loaded from question 1, 
display SVM13 brightness temperature data with the swathToGrid formula over Louisiana.  Overlay this 
display on the RGB image created in problem 1.  This medium-wave infrared band is useful to detect fire 
activity. 
 

4. Determine the smoke concentration from the Louisiana fire using the <local path>/Data/SuomiNPP 
/GMTCO-VSUMO* VIIRS suspended matter EDR data.  Overlay this display on the RGB image created 
in problem 1. 
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Problem Set #1 – Solution 
 
Using the <local path>/Data/SuomiNPP/GMODO-SVM03-SVM04-SVM05* file, create an RGB image 
using the Reflectance field of all three bands.  Create the display by using the VIIRS_M_RGB(M5,M4,M3) 
formula.  Display the data at full-resolution and make sure to include a large portion of the granule in your 
subsetted region.  Adjust the Common Gamma field in the Layer Controls to make the individual colors stand 
out more in the display. 
 
1. Remove all layers and data sources from the previous displays. 

 
2. Select File -> New Display Tab -> Map Display -> One Panel to create a new one-panel map display tab. 

 
3. Load in a granule containing three bands of VIIRS SVM visible data (SVM03, SVM04 and SVM05). 

 
a. In the Data Sources tab of the Data Explorer, select Under Development > Imagery – Suomi NPP 

 
b. Select <local path>/Data/SuomiNPP/GMODO-SVM03-SVM04-SVM05_npp*  

(Note: this file packages the geolocation (GMODO) and the data (SVM*) together into the same file.) 
 

c. Click the Add Source button. 
 

4. Use the VIIRS formula to create a true-color RGB image with the bowtie effect removed. 
 
a. In the Field Selector tab, under Data Sources select Formulas. 

 
b. Under Fields, select the VIIRS_M_RGB(M5,M4,M3) formula.  Click Create Display. 

 
c.  In the new Field Selector window, select:  

 
• For Field: M5, select VIIRS -> 

IMAGE -> VIIRS-M5-
SDR_All/Reflectance  

• For Field: M4, select VIIRS -> 
IMAGE -> VIIRS-M4-
SDR_All/Reflectance 

• For Field: M3, select VIIRS -> 
IMAGE -> VIIRS-M3-
SDR_All/Reflectance 
 

d. In the Region tab of Field: M5, use 
Shift+Left-Click+Drag to select a region to 
display at full-resolution.  Select a region 
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that contains most of the granule, as shown in the image above.  It is not necessary to subset a region in 
for M4 and M3, as the region selected for M5 will be used for all fields. 
 

e. Click OK to display the results of the VIIRS_M_RGB(M5,M4,M3) formula. 
 

5. Adjust the display to enhance the Red, Green, and Blue components of the display. 
 
a. Navigate to the Layer Controls tab of the Data Explorer.  By default, all Gamma values for all colors 

are set to 1.0.  Change this value to 0.4 by entering in 0.4 in the Common Gamma field and clicking the 
Apply to All Gamma Fields button. 
 

b. Return to the Main Display window to observe the RGB display and also notice that the bowtie effect 
has been removed by the formula. 

 
Problem Set #2 – Solution 
 
Looking at the display over the Great Lakes, it is difficult to discern between clouds and snow over the land. 
Using the file loaded from question 1, display SVM14 brightness temperature data with the swathToGrid 
formula over the Great Lakes region.  Adjust the enhancement to make the clouds display as white instead of 
black.  Overlay this display on the RGB image created in problem 1. This longwave infrared band is useful to 
distinguish between clouds and snow. 

1. Use the swathToGrid formula to create a full-resolution display of 
the data without the bowtie effect. 
 

a. In the Field Selector tab, under Data Sources select Formulas. 
 

b. Under Fields, select the swathToGrid formula.  Under Displays, 
select Imagery > Image Display.  Click Create Display.  
 

c. In the new Select input window, enter 750 for res and 1.0 for 
mode.  Click OK. 
 

d. In the Field Selector, select VIIRS* -> IMAGE -> VIIRS-M14-
SDR_All/BrightnessTemperature. 
 

e. In the Region tab, use Shift+Left-Click+Drag to select a region 
over the Great Lakes (as seen in the image on the right) to display 
at full-resolution. 
 

f. Click OK to display the result of the swathToGrid formula. 
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2. Adjust the display to make the clouds over the Great Lakes appear as white instead of black and investigate 
the display. 
 

a. Change the colorbar to Inverse Gray Scale.  To do this, Right-Click on the colorbar in the Legend and 
select System -> Inverse Gray Scale.  This is done to make the lower data values (colder temperatures, 
such as clouds) display as white, while warmer temperatures are darker. 
 

b. Use the visibility checkbox in the Legend to toggle the SVM14 layer on and off to compare with the 
RGB display underneath.  The temperature difference between clouds and snow in this infrared band 
allows the clouds to stand out more than they do in the visible bands used in the RGB display. 

Problem Set #3 – Solution 
 
Looking at the RGB display over Louisiana, smoke can be observed.  Using the file loaded from question 1, 
display SVM13 brightness temperature data with the swathToGrid formula over Louisiana.  Overlay this 
display on the RGB image created in problem 1.  This medium-wave infrared band is useful to detect fire 
activity. 
 

1. Use the swathToGrid formula to create a full-resolution display of the 
data without the bowtie deletion. 
 

a. In the Field Selector tab, select Formulas under Data Sources.  
 

b. Under Fields, select the swathToGrid formula.  Under Displays, 
select Imagery -> Image Display.  Click Create Display. 
 

c. In the new Select input window, enter 750 for res and 1.0 for 
mode.  Click OK. 
 

d. In the Field Selector window, select VIIRS* -> IMAGE -> VIIRS-
M13-SDR_All/BrightnessTemperature. 
 
In the Region tab, use Shift+Left-Click+Drag to select a region over 
Louisiana to display at full-resolution.  Click OK to display the 
result of the swathToGrid formula. 
 

2. Use the visibility checkbox in the Legend to toggle the SVM13 layer 
on and off to compare with the RGB display underneath. 
 

Problem Set #4 – Solution 
 
Determine the smoke concentration from the Louisiana fire using the <local path>/Data/SuomiNPP 
/GMTCO-VSUMO* VIIRS suspended matter EDR data.  Overlay this display on the RGB image created in 
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problem 1. 
 
1. In the Data Sources tab of the Data Explorer, navigate to the Under Development -> Imagery -> Suomi 

NPP chooser. 
 

a. Under Files, select the following file: 
<local path>/Data/SuomiNPP/GMTCO-VSUMO* 
 

b. Click the Add Source button. 
 

2. Display the smoke concentration from the EDR data. 
 

a. In the Fields panel of the Field Selector, select: 
Image -> VIIRS-SusMat-EDR_/All/SmokeConcentration field. 
 

b. Select Imagery -> Image Display in the Displays panel of the Field Selector. 
 

c. In the Region tab of the Field Selector, use Shift+Left-Click+Drag to subset a region over Louisiana.  
Anything within this subsetted region will display at the full resolution of the data. 
 

d. Click Create Display. 
 

3. Investigate the smoke concentration from the Louisiana fire. 
 

a. In the Legend of the Main Display, toggle off the visibilities of the SVM13 and SVM14 data so only the 
RGB and the VIIRS EDR data is displayed. 
 

b. Navigate over the fire in Louisiana and toggle the VIIRS EDR layer on and off with the visibility 
checkbox in the Legend. 
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Zooming, Panning, and Rotating Controls 
 

Zooming Panning Rotating 
 Mouse  
Shift-Left Drag: Select a region 
by pressing the Shift key and 
dragging the left mouse button. 
Shift-Right Drag: Hold Shift key 
and drag the right mouse button. 
Moving up zooms in, moving 
down zooms out. 

Control-Right Mouse Drag: 
Hold Control key and drag right 
mouse to pan. 

Right Mouse Drag: Drag right 
mouse to rotate. 

 Scroll Wheel  
Scroll Wheel-Up: Zoom Out. 
Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-
Up/Down: Rotate 
clockwise/counter clockwise. 
Shift-Scroll Wheel-Up/Down: 
Rotate forward/backward 
clockwise. 

 Arrow Keys  
Shift-Up: Zoom In. 
Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 
Control-Down arrow: Pan Up. 
Control-Right arrow: Pan Left. 
Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 
around vertical axis. 
Up/Down arrow: Rotate 
around horizontal axis. 
Shift-Left/Right arrow: Rotate 
Clockwise/Counterclockwise. 

 
 


	McIDAS-XRD: Creating GLM Density Plots with GLMIMG
	McIDAS-V Tutorial
	This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the document entitled McIDAS-V Tutorial – Installatio...
	Terminology
	McIDAS-V currently supports ABI netCDF data through remote servers as well as through the local file chooser on all platforms.  Local servers for ABI data are currently available on OS X and Linux platforms.  This tutorial will cover how to access thi...
	1. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  Select lead.unidata.ucar.edu as the Server and RTGOESR as the Dataset.  Click Connect.
	2. Select FD – GOES-16 FD all bands as the Image Type.
	3. In the Times panel, select the Relative tab.  For Number of times, enter 1 and click Add Source to create a data source of the most recent time.
	4. Display band 13 temperature data.
	a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the data.  Select the 10.3 um IR Surface & cloud -> Temperature field.
	b. From the Displays panel, select the Imagery -> Image Display display type.
	c. Select the Region tab to see a low-resolution preview image of the data.  Note that there is a green box drawn around the preview image.  Any data inside this bounding box will be displayed.
	d. Select the Advanced tab to see information about the band and calibration selected.  These values match the domain of the data selected in the Region tab, so it covers the entire domain of the data.  Notice that the Image Size is only 904 x 904 whe...
	i. Coordinate Type: Latitude/Longitude
	ii. Location: Center
	iii. Lat: 28; Lon: -83.5
	iv. Image Size: 400 x 400
	v. Magnification: 1 x 1
	e. Click Create Display.
	5. Investigate the display.
	a. In the Main Display window, practice navigating around in the display.  To do this, use Control+Right-Click+Drag to translate the display.  This shifts the data left/right and up/down without rotating the display.  Zoom in on the display by scrolli...
	b. Probe individual pixel values by holding down the middle mouse button over the display.  This will print out probe values at the bottom of the display.  Notice that latitude, longitude, and temperature values are included in the probe output.
	c. Navigate to the Histogram tab of the Layer Controls to see a histogram of band 13 temperature values.
	6. Add a data transect to the display.
	a. From the Field Selector tab of the Data Explorer, select the Data Transect display type and click Create Display.
	b. In the Main Display window, there is a red line that is referred to as the data transect.  The values along this transect line are output in the Layer Controls tab of the Data Explorer.  The two end points of the transect can be moved around by Lef...
	7. Create a display of the 10.3 micron temperatures so only values of 273K and less are plotted.
	a. Add a new two-paneled map display by selecting File -> New Display Tab -> Map Display -> Two Panels menu item.
	b. Left-Click in the left panel to make this panel active.  The active panel has a blue frame around it, and this is the panel any displays will be added to.
	c. In the Field Selector tab of the Data Explorer, select the 10.3 um IR Surface & cloud -> Temperature field.  Choose the Imagery -> Image Display display type and click Create Display.
	d. Create the cloud mask display.
	i. Left-Click in the right panel to make this panel active.  The active panel has a blue frame around it, and this is the panel any displays will be added to.
	ii. In the Field Selector tab of the Data Explorer, select Formulas.
	iii. Select the Imagery -> Mask Value formula, the Imagery -> Image Display display type, and click Create Display.
	iv. In the Select input window, enter the following and then click OK:
	1. comparison: <
	2. cutoff: 273
	3. useNaN: 1 Notes: The comparison is set to < or ‘less then’ since the goal is to display values less than 273, which was set as the cutoff value.  Setting useNaN to 1 makes it so that if the pixels were probed outside of the masked range (where valu...
	v. In the new Field Selector window, for inputFieldForMask, select 10.3 um IR Surface & cloud -> Temperature.  This is the field that is being masked.
	vi. For displayFieldToBeMasked, select 10.3 um IR Surface & cloud -> Temperature.  This is the field that will be displayed where the inputFieldForMask is less than 273 degrees.  In this case, we are displaying the same field that is being masked.
	vii. Click OK.
	e. Investigate the display.  Note that as one of the panels is navigated, the other will be navigated in the same way.  This is because by default panels in the same tab are set to share views.  This setting can be disabled in a panel by unchecking Pr...
	8. Create a display of a subtraction of two bands.
	a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item, or by clicking the Add new tab () button in the Main Toolbar.
	b. In the Field Selector tab of the Data Explorer, select Formulas.
	c. Select the Miscellaneous -> Simple difference a-b formula, the Imagery -> Image Display display type, and click Create Display.
	d. In the new Field Selector window, for a, select the 8.44 um IR Total WV cloud phase, dust -> Temperature field.  For field b, select the 7.34 um IR Lower-level WV, winds & SO2-> Temperature field.
	e. Click OK in the Field Selector window to display the band subtracted data.
	f. Right-Click on the colorbar of the ABI layer in the Legend and select the System -> Inverse Gray Scale enhancement.
	g. Add latitude and longitude labels to the display.
	i. Left-Click on the blue text for the Default Background Maps layer in the Legend to get to the Layer Controls tab of the Data Explorer for the layer.
	ii. From the Lat/Lon tab of the Layer Controls, set the following:
	1. Check the visibility checkboxes for Lines and Labels to plot them in the display.
	2. Lines: Interval: 5.0
	3. Labels: Interval: 5.0; At Longitudes: -85.0, At Latitudes: 30.0, Color: light blue
	4. Font: Arial; Bold; 20
	h. Investigate the display to see the latitude and longitude lines and labels.  Probe the data to see the temperature difference between the two bands.
	9. Capture an image of the display.
	a. From the Main Display, select the View -> Capture -> Image menu item.
	b. In the Save As text field, enter the name to give your image, for example: band_subtraction.gif.
	c. Use the dropdown below Save As to select the directory to save your image to.
	d. Under Capture What, select Current View.  This will capture an image of the display without including any other components of the Main Display such as menu items and the Legend.
	e. Click Save.
	f. View your saved image to verify the image was captured correctly.
	Accessing GOES-16 ABI Data from a Remote Server – 5 Timesteps
	10. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and Data Sources menu item from the Main Display.
	11. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item.  Close any previously-existing tabs.
	12. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  In the Relative tab of the Times panel, for Number of times, enter 5 and click Add Source.
	13. Display a loop of 10.4um Temperature data over Wisconsin and Illinois.
	a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the data.  Select the 10.3 um IR Surface & cloud -> Temperature field.
	b. From the Displays panel, select the Imagery -> Image Display display type.
	c. Navigate to the Advanced tab, and enter the following information:
	i. Coordinate Type: Latitude/Longitude
	ii. Location: Center
	iii. Lat: 42; Lon: -89.6
	iv. Image Size: 450 x 450
	v. Magnification: 1 x 1
	d. Click Create Display.
	14. Investigate the display.
	a. The Main Display now has a loop of the 5 most recent times of data in the FD dataset.  As done in step 5 earlier, navigate around and zoom in/out of the display.  Probe the display by holding down the middle mouse button over the data.
	b. Use the Time Animation Widget at the top of the display panel to play through a loop of the data.
	c. Click the Properties button () in the Time Animation Widget to modify settings of the animation including the dwell rate (the time spent on each frame in the animation).  As an example, set the Forward, First, and Last dwell rates to 0.2 and click ...
	15. Change the enhancement used in the display.
	a. Stop the animation by clicking the Stop Animation button in the Time Animation Widget ().
	b. Right-Click on the colorbar of the ABI layer in the Legend and select the Satellite -> GOES-R -> ABI IR Temperature enhancement.
	16. Add a color scale to the display.
	a. Right-Click on the ABI layer in the Legend and select Edit -> Properties.
	b. In the Properties window, navigate to the Color Scale tab and set the following:
	i. Visible: Check this option to add the color scale to the display.
	ii. Position: Top.  This will position the color scale at the top of the display.
	iii. Labels -> Visible: Check this option to add numerical labels to the color scale.
	iv. Labels -> Show Unit: Check this to add the display unit to the color scale labels.
	v. Labels -> Font: Set the size to 32.
	c. Click OK.
	17. Create a Data Probe/Time Series display of band 13 temperature data.  This display type allows for plotting how temperature values at a specific location change through time throughout the loop.
	a. In the Field Selector tab of the Data Explorer, select the Data Probe/Time Series display type and click Create Display.
	b. The Layer Controls tab of the Data Explorer now shows a time series display of temperature values at the location of the probe in the Main Display.  Change the range of the y-axis (temperature values) to match the range of the data.
	i. At the bottom of the Layer Controls tab, Double-Click on the 186-Band13_TEMP parameter to open the Properties window.
	ii. In the Properties window, change the Range text boxes to a Min of 180 and a Max of 320 to match the range of the enhancement in the Main Display.
	iii. Click OK to apply the new range in the Layer Controls and close the Properties window.
	c. Move the data probe in the Main Display around with Left-Click+Drag.  The time series display in the Layer Controls automatically updates itself as the probe’s location changes.
	d. The data probe in the Main Display can also be set to a specific latitude/longitude value by using the Lat and Lon text boxes at the bottom of the Layer Controls.  For example, enter values of 38.6 for Lat and -88.1 for Lon.  Note that you must pre...
	Accessing ABI Data from a Remote Server through Scripting
	Both of the previous sections of this tutorial can be replicated through scripting.  This section covers creating a loop of ABI data and applying an enhancement to the display.
	18. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and Data Sources menu item from the Main Display.
	19. From the Main Display, select Tools -> Formulas -> Jython Shell to open the Jython Shell.
	20. The Jython Shell defaults to single-line input mode, where only one line of code can be executed at a time.  This script is more than one line long, so it requires multi-line input.  To switch to multi-line input, click the double-down blue arrow ...
	21. In a text editor, open the Data/GOES16/abiLoop.py file.  Copy this text and paste it into the Jython Shell.
	22. To evaluate this code, click the Evaluate button, or use Shift+Enter.  In-line documentation of what the script is doing can be found in the script (lines that begin with ‘#’ are comments).  More information about McIDAS-V scripting can be found i...
	23. After you are done analyzing the display created with the script, close the new display window.
	Using GOES-16 GLM and Satellite Derived Winds
	24. This section of the tutorial uses a new Data Type through the General -> Files/Directories chooser as well as a new layout model which is must be added via a plugin.  Add this plugin.
	a. From the Main Display window, navigate to the Tools -> Plugins -> Manage menu item to open the Plugin Manager.
	b. The top of the Plugin Manager lists plugins currently installed, and the bottom panel lists the various plugins available for installation.  Expand the Data Sources tree and click the green Install Plugin button next to GLM NetCDF Files.
	c. This pops up a message notifying the user that McIDAS-V must be restarted to complete the installation of the plugin.  Click OK through this message and restart McIDAS-V.
	25. Display GOES-16 band 14 data.
	a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/ABI directory.
	b. Select the GOES16_CONUS* file.
	c. From the Data Type dropdown, select Grid files (netCDF/GRIB/OPeNDAP/GEMPAK).
	d. Click Add Source.
	e. In the Fields panel of the Field Selector, verify that brightness_temperature is selected.
	f. In the Displays panel of the Field Selector, select Imagery -> Image Display.
	g. Click Create Display.
	26. Modify the display of the GOES-16 band 14 data.
	a. To make the cold clouds white and the relatively warmer land darker, change the enhancement used by the displayed layer by Right-Clicking on the colorbar in the Legend and selecting System -> Inverse Gray Scale.
	b. Disable the wireframe box around the display by selecting View -> Show -> Wireframe Box in the display panel.
	c. Other layers will be added to the display in the next several steps.  To maintain the current projection, from the display panel, disable Projections -> Auto-Set Projection.
	27. Add a data source of six consecutive (2 minutes total) GLM files as group data.
	a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/GLM directory.
	b. Use Shift+Left-Click to select all six OR_GLM-L2-LFCA* files.
	c. From the Data Type dropdown, select GLM Groups Data files.  This data type was added from the plugin that was installed in step 24 above.
	d. Click Add Source.
	28. By default, each data point in each GLM file has its own timestep, which would create a loop of potentially thousands of frames.  Bin all of the times together so each data point plots at the same timestep.
	a. From the Field Selector, Right-Click on the 6 Files Data Source and choose Properties.
	b. At the bottom of the Properties tab of this window, find the Time Binning section.  Set the following using the dropdown menus:   Bin Size: 5 minutes Round To: 1 hour  A bin size of 5 minutes is large enough to contain all of the data.  The round t...
	c. Click OK at the bottom of the Properties window.
	29. Display the GLM data.
	a. In the Fields panel of the Field Selector, select Point Data.
	b. In the Displays panel of the Field Selector, choose the Point Data -> Point Data Plot display type.
	c. In the Layout Model subset tab, click the double-down blue arrows next to None and choose GLM -> Group.  This layout model was added from the plugin that was installed in step 24 above.
	d. Click Create Display.
	30. Investigate and modify the display of GLM data.  Note that the points of GLM data are parallax-corrected (from the data itself), so they may not perfectly match up with the location of the band 14 imagery, which is not parallax-corrected.
	a. The pink plus signs in the display represent the GLM group data points.  As you zoom in and out of the display, you’ll see the number of points change.  This is because of decluttering that McIDAS-V does to the display.  To modify the decluttering,...
	b. If you wish to change the size of the plus signs in the display, adjust the Scale value in the Layer Controls.  Decreasing the value from 1 (for example, 0.5) will make the points smaller.  Increasing the value from 1 (for example, 2) will make the...
	31. Add a data source of satellite derived winds.
	a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/Derived Winds directory.
	b. Select the OR_ABI-L2-DMWC* file.
	c. From the Data Type dropdown, select netCDF/GEMPAK Point Data files.
	d. Click Add Source.
	32. Display the satellite derived winds.
	a. In the Fields panel of the Field Selector, choose the Point Data field.
	b. In the Displays panel of the Field Selector, choose the Point Data -> Point Data Plot display type.
	c. A new layout model will be imported to plot the satellite derived winds colored by speed.  To do this, go to the Layout Model subset tab of the Field Selector and choose Edit.
	d. From the Layout Model Editor window, select File -> Import.
	e. From the Layout Model import window, select the <local data>/Data/GOES16/G16_Winds.ism file and click Open.
	f. From the Layout Model Editor window, select File -> Save and close the Layout Model Editor.
	g. From the Layout Model subset tab of the Field Selector, click the double-down blue arrows next to None and choose G16_Winds <local>.
	h. Click Create Display.
	33. Investigate and modify the display of GOES-16 satellite derived winds using the same methods used in step 30 above with GLM data.

