
2019 MUG Meeting McIDAS-V Demonstration Outline 
Presented 17 September 2019 by Bob Carp and Jay Heinzelman, SSEC 

Note: The data files referenced in this document can be found at: 
ftp://ftp.ssec.wisc.edu/pub/mug/mug_meeting/2019/presentations/2019_McIDAS-V_demo.zip 

1. Local servers 
a. Bring up ADDE Data Manger (Tools > Manage ADDE Datasets) from the Main 

Display window. 
b. Go to the Local Data tab and click the button to create a new local dataset. 
c. Show the Format dropdown to list the local servers available. 
d. Mention that local servers are updated each time we do a McIDAS-V release to 

the server versions packaged with McIDAS-X. 
 

2. Demonstration of Level 2 ABI enhancements 
a. Through the Satellite > Imagery chooser, connect to adde.ucar.edu/NPGOESR. 
b. Choose the Cloud Top Height CONUS – CTHCN image type. 
c. Select the 1 most recent time from the Relative tab. 
d. From the Field Selector, choose the ‘Cth’ field and the Image Display display. 
e. Note that a special enhancement was applied to the display.  This is done 

through a parameter default, which we have for most of the ABI L2 products.  
You can see the parameter defaults by going to the Parameter Defaults Editor 
and looking in the “Application Defaults” tab. 

 
 

  



3. GLMCN example 
a. From the Satellite > Imagery chooser, change the Image Type to CONUSC13. 
b. In the Relative tab, enter 5 for the 5 most recent times. 
c. Click Add Source. 
d. In the Field Selector, select the Temperature calibration. 
e. In the Advanced tab, click the green arrow button to get full domain/full res. 
f. In the Region tab, subset an area over colder cloud tops w/ potential lightning. 
g. In the Times tab, change the dropdown to “Set As Time Driver”. 
h. Click Create Display. 
i. In the Data Sources tab of the Data Explorer, choose GLMCN for Image Type. 
j. At the bottom of the Times tab, select “Match Time Driver”. 
k. Click Add Source. 
l. In the Field Selector, choose Group Centroid Density > Ggcd 
m. In the Advanced tab, select full domain, full resolution. 
n. Change the enhancement range to 0 – 100. 
o. Change enhancement range to “Radar > Vertically Integrated Liquid” 
p. Edit the enhancement to make 0 100% transparent to see IR data under GLM. 

 

 
 
 

  



4. GLM Point Data 
a. From the Satellite > Imagery chooser, change the Image Type to CONUSC13. 
b. Select 1 in the Relative tab to load in the last most recent time. 
c. Click Add Source. 
d. Display Temperature data at full resolution over a region containing lightning. 
e. Set this to be the time driver and click Create Display. 
f. Using the Under Development > GLM chooser, connect to 

adde.ucar.edu/RTGOESR. 
g. Choose Flash for GLM Type. 
h. Set Increment to 2 minutes. 
i. Select Match Time Driver. 
j. Click Add Source. 
k. From the Field Selector, choose Point Data. 
l. In the Region tab, draw a box roughly covering region where CONUSC13 data is. 
m. Click Create Display. 
n. In the Layer Controls, disable Declutter and enable Show Multiple in the Times 

tab. 

 
 

  



5. GOES 16/17 RGB formula 
a. In the Field Selector, show the GOES 16/17 RGB formula under Imagery. 
b. Show how you could use the function through a script by running 2019_McIDAS-

V_demo/Scripts/G16_RGB.py in the Jython Shell. 
c. Close display window with RGB when done. 

 
 

6. Sandwich function 
a. Mention that function is defined in the Jython Library. 
b. Show how you could use the function through a script by running 2019_McIDAS-

V_demo/Scripts/MesoSandwich.py in the Jython Shell. 
c. Close display window with Sandwich product when done. 

 
 



7. Describe function 
a. Mention that describe() is a McIDAS-V function that can give statistical 

information about a data object.  New functionality includes the ability to specify 
which statistical parameters you want returned. 

b. Show how you could use the function through a script by running 2019_McIDAS-
V_demo/Scripts/Stats.py in the Jython Shell. 

c. The first part of the output is the default for describe(), showing all statistical 
values for the band 12 data object passed through it. 

d. The second part of the output returns only a few statistical parameters for the 
band 12 data object. 

e. The third part of the output returns only the minimum statistical value for bands 
12 – 15. 

f. Close the Jython Shell once you are done. 
 

8. TROPOMI 
a. In the General > Files/Directories, select the 2019_McIDAS-

V_demo/TropOMI/S5P* file with I’m Feeling Lucky as the Data Source. 
b. Mention that Tommy J and Jon B just got this data working in the nightly pretty 

recently.  You can look at the ncdump output through the Properties > Metadata 
tab of the data source to see how the data is organized in groups. 

c. Choose the Product > Total Vertical column of SO2 field. 
d. Choose the Image Display display type. 
e. Hit Create Display. 
f. Change the enhancement to Satellite > MODIS > Aerosol Optical Depth. 
g. Set the minimum value of the enhancement range to 0. 
h. This is an SO2 plume from a volcano in Russia (Shiveluch).  Add volcano labels to 

the display with Display > Plot Location Labels > Earth > Volcanos. 
i. In the Layer Controls of the labels, go to the Filters tab and set the following: 

Property: Name 
String Equals 
Shiveluch 

j. Click Apply Filters 
k. Previously, to change the size/style/color of the text label you would have to 

create a layout model.  Now, even when Predefined is used in the Layer Controls, 
you can set this.  Change to Arial; Plain; 16 

l. Mention that Tommy will discuss TROPOMI further in his talk. 

 



 
 

9. Demonstrate country labels 
a. In the Main Display, choose View > Plot Location Labels > World > Countries. 
b. Previously, some country labels were available, but not all of them and they 

were broken up under different categories.  We have a script that we’ll run each 
release to see if there are any changes with country names/locations to make 
sure that we keep these countries up to date. 
 

10. MiRS v11r4 data 
a. At the time of this demonstration, there are several CF-compliance issues with 

MiRS v11r4 files from NOAA CLASS, both Imager and Sounder data.  We have a 
Plugin that you can install to fix these problems with NcML.  Show the Plugin 
Manager window (Tools > Plugins > Manage) and expand Data Sources to show 
the “MiRS v11r4 Data” plugin. 

b. In the General>Files/Directories chooser, choose the “MiRS v11r4 IMG” data 
type, the 2019_McIDAS-V_demo/MiRS/NPR-MIRS-IMG* file and click Add 
Source. 

c. From the Field Selector, choose “2D > Total Precipitable Water”, the Image 
Display display type, and hit Create Display. 

d. This is total precipitable water over Hurricane Dorian.  Change the max value of 
the enhancement range to 3. 

e. In the General>Files/Directories chooser, choose the “MiRS v11r4 SND” data 
type, the 2019_McIDAS-V_demo/MiRS/NPR-MIRS-SND* file, and click Add 
Source. 

f. From the Field Selector, choose the “3D > Rain Mass Profile” field. 
g. In the Displays panel, choose the Probes > Vertical Profile display type. 



h. In the Level tab, choose 416mb through 1000mb using Shift+click to select the 
range of pressure values. 

i. Click Create Display. 
j. Move the probe over the highest precipitable water values from the 2D display. 
k. In the Layer Controls, right-click in the chart at the bottom and choose 

Parameter PRain > Properties. 
l. In the Properties window, set the range to 0 to 0.005 so the x-axis range better 

fits the actual data values. 
m. Demonstrate how the vertical profile updates as you move the probe around in 

the Main Display window. 

 

 
 

  



11. Profile Along Track Display 
a. From the Satellite > Imagery chooser, connect to geoarc.ssec.wisc.edu/AGOES13 

and choose FD for the Image Type.  Note that this server/dataset requires 
accounting information from SSEC’s Satellite Data Services (SDS). 

b. In the window that appears, choose 10/05/2015 as the date.  Enter a time range 
of 12:00:00 – 20:00:00.  This time range feature is new in version 1.8 and makes 
things much more efficient when working with an archive server, or a realtime 
server that contains a lot of data (e.g. a server that contains the last 2 days of 
mesoscale-sector GOES 16/17 data. 

c. Select the 17:45:00 time and click Add Source. 
d. Choose the 10.7um > Temperature field in the Field Selector. 
e. In the Advanced tab, click the full size/full res button (four green arrow button). 
f. In the Region tab, draw a box over Hurricane Juaquin which is in the Atlantic off 

the northeastern USA coast. 
g. Click Create Display. 
h. From the General>Files/Directories chooser, select the 2019_McIDAS-

V_demo/CALIPSO/CAL_LID_L1* file, the I’m Feeling Lucky data source, and click 
Add Source. 

i. In the Field Selector, choose the ProfileAlongTrack > Total Attenuated 
Backscatter field. 

j. Demonstrate how the Track tab works. 
- Full swath shown in white 
- Part of track that will be drawn is the pink.  You can control the length of the 
pink line using the Length box, where you can enter a higher value 
- The slider moves the pink part of the track closer to the beginning or ending of 
the white track line 
- The sampling fields control the resolution of the data in the horizontal and 
vertical. 

k. Set the swath length to 20%, move it over the hurricane, and display the data 
using the default data sampling to get a reduced resolution image. 

l. Click Create Display and show how you have a vertical curtain of backscatter. 
m. It was asked if you could apply a transparency to the CALIPSO display so you 

could see the cloud data behind it.  This was possible by going to the Color Table 
Editor and setting the lower end of the enhancement (very little backscatter) to 
be 100% transparent. 

n. Back in the Field Selector, change the track length to 10% and display the data at 
full res (1 for both of the strides). 



o. Show how you are now looking at a much higher resolution display. 
 

 

12. JPSS dateline subsetting 
a. From the Under Development > JPSS chooser, select the 2019_McIDAS-

V_Demo/Dateline/GMODO* file.  This is a multi-banded NOAA-20 SDR file.  Click 
Add Source. 

b. In the Field Selector, choose the Image > VIIRS-M3-SDR_All/Radiance field.  Note 
that the fields in the Field Selector are in alphabetical order and grouped 
together.  This means that all of the SVM03 fields (data and quality flags) are 
listed together. 

c. In the Region tab, draw a box over the majority of the granule.  Anything in this 
box will be displayed at full resolution.  Previously, this box could only be drawn 
on one side of the dateline.  Click Create Display. 

d. Note that you can now probe on both sides of the dateline.  Previously, probing 
would have only worked on one side of the dateline. 
 

13. MODIS dateline subsetting 
a. From the Satellite > HYDRA chooser, select the 2019_McIDAS-

V_demo/Dateline/MYD021KM* file and click Add Source. 
b. In the Fields panel, choose Multispectral > Emissive Bands. 



c. In the Region tab, draw a box around the majority of the granule.  Previously, 
this box could only be drawn on one side of the dateline.  Click Create Display. 

d. Note that you can now probe on both sides of the dateline.  Previously, probing 
would have only worked on one side of the dateline. 

e. Back in the Field Selector, choose the MultiSpectral Display display type and hit 
Create Display. 

f. Move the probes around.  Mention that the nightly now has better spacing 
between the box of the probe and the text output.  Previously, the probe 
overlapped the data values making them sometimes hard to read.  Also show the 
Layer Controls just to see the spectral analysis functionality.  MODIS is multi-
spectral, but you’d actually see a real spectral analysis when using hyperspectral 
data (like AIRS data).  AIRS data will be covered  
 

14. Improved layer label rendering 
a. In the Satellite > Imagery, load and display adde.ucar.edu/RTGOESR/CONUSC13 

temperature data. 
b. In the User Preferences, go to the Display Window tab and enable “Use new 

layer label rendering”.  Click Apply/OK to apply and close the User Preferences 
window. 

c. In the Main Display, select View > Properties. 
d. From the Properties window, set the font to Arial size 16 and click OK. 
e. Note that the text here looks better than it would have previously.  Mention that 

a user could set Arial/16 in the User Preferences to always have these nicer 
labels, or they could be set individually in each display panel as we just did. 
 

15. Satellite Orbit Tracks 
a. Note that the chooser has been promoted from out of Under Development.  

Through the Satellite > Orbit Tracks chooser, mention the three ways of loading 
data (local file, ADDE, and URL). 

b. With the default weather.txt URL, click Add Source. 
c. Select Suomi NPP and display a full day’s worth of tracks from 09/17/2019.  Note 

the improvement here in that there are no horizontal lines in the display. 
d. Zoom in over the CONUS and figure out a shorter length of the track that crosses 

over the CONUS.  For example, 18:30:00 – 18:50:00.  Click the trashcan in the 
Legend to remove the tracks layer. 

e. In the Times tab of the Field Selector, enter the beginning/end times of 
18:30:00/18:50:00 and click Create Display. 



f. Note the improvement here that the labels aren’t huge.  In core, if you zoom in 
and then draw the tracks, there is a good chance the time labels will be very 
large.  Modify a few items in the Layer Controls. 
- Enable swath width lines.  Note improvement in nightly that the swath width 
was added for many satellites/instruments.  In core, the swath width for Suomi 
NPP would be N/A.  Now, it’s 3040km. 
- Change the label interval to 1 so you see times every minute. 
- Change the line styles of the tracks 
- Add the SSEC ground station 

 
 

16. New Japan/Korea radar sites 
a. Mention that 3 new radar sites were added, all of which you can order data for 

from NCEI: 
- RKJK: Kunsan, South Korea 
- RKSG: Camp Humphrys, South Korea 
- RODN: Kodena AB, Japan 

b. Through the Radar > Level II > Local chooser, select all of the 2019_McIDAS-
V_demo/Radar/RODN* files and click Add Source. 

c. Choose Reflectivity and hit Create Display.  This is a loop from Typhoon Trami in 
September 2018.  After the last frame, no data is available from the station for 
about 2 days. 



d. Choose the Radar Cross Section display type and hit Create Display to 
demonstrate some of the 3D functionality. 
** Note that we did not display this Radar data during the demo due to time 
constraints ** 
 

 

17. New gridded formulas for working with time series data 
a. Through the Gridded Data > Remote chooser, load the most recent GFS 80km 

CONUS data. 
b. In the Field Selector, expand 2D to see how everything is now in alphabetical 

order.  This alphabetical field listing is now available for remote data (such as 
this) as well as local gridded data sources. 

c. In the Field Selector, choose Formulas in the Data Sources panel and expand 
Grids > Time Mean and Anomaly to see all of the formulas.  These formulas were 
created by a Unidata IDV user who does a lot with climatological data. 

d. Choose the Anomaly from Time Means formula, the Image Display display type, 
and hit Create Display. 

e. In the Field Selector window, choose 2D > Pressure Reduced to MSLP and click 
OK. 

f. Play through the loop.  What this formula did is figure out the average MSLP 
value at each pixel through the entire time range of the data.  At each time step, 
the average pressure is subtracted from the current pressure value at each pixel.  
This shows if each pixel is currently (at the timestep) above or below the average 
MSLP value for the entire loop. 



g. The unit for the display defaults to ‘pa’.  Change to ‘hPa’ through Edit > Change 
Display Unit. 
 

18. Isosurface smoothing 
a. Using the data source loaded from the previous example, select 3D > Derived > 

Speed. 
b. Choose the 3D Surface > Isosurface display type. 
c. In the Times tab, select the first 5 times. 
d. Click Create Display. 
e. From the Layer Controls, change the wind speed isosurface value to 20 m/s. 
f. Rotate the display to a southern viewpoint so you can see more of the 3D 

structure. 
g. From the Layer Controls, change the Smoothing from None to 5 Point, 9 Point, 

Circular, then back to 5 Point. 

 
 

19. Potential temperature isosurface 
a. Using the data source loaded from the previous example, select 3D > Derived > 

Potential Temperature IsoSurface(from theta). 
b. In the Displays panel, select Isentropic Topography. 
c. In the Times tab, select the first 5 times. 
d. Click Create Display. 
e. In the window that appears, enter 330 for the potential temperature value and 

click OK. 



f. In the Main Display, show the 3D structure of the display.  This is the 330K 
potential temperature surface colored by altitude. 

g. In the Field Selector, choose the Potential Temperature vector field, the Vectors 
Colored by Speed display type, and click Create Display. 

h. Enter a value of 330 for the potential temperature value and click OK. 
i. Disable the visibility of the first isosurface display so the vectors are more visible. 

 

 

20. 3D volume streamlines 
a. From the Gridded Data > Remote chooser, load the most recent NAM 80km 

CONUS data source. 
b. In the Field Selector, choose the 3D > Derived > 3D Flow Vectors field. 
c. Select the 3D Volume Vector Colored By Speed display type. 
d. In the Times tab, choose the first 5 times. 
e. Click Create Display. 
f. Rotate the display so you can see that every grid point has a trajectory in the 

entire volume of the data (x, y, and z). 
g. Declutter things a bit by setting the XY Skip in the Layer Controls to 4. 
h. Make the vectors larger by entering a value of 15 into the size field. 
i. Change the display mode to trajectories and play through the loop.  Change the 

trajectory form to Cylinder and loop through again. 
j. Change display to show streamlines using cylinders. 



 
 

21. Color Table Editor transparency readout 
a. Open the Color Table Editor window. 
b. Set the minimum value to be 100% transparent. 
c. Interpolate transparency from the minimum to the maximum value. 
d. Mouse over the enhancement and you’ll see that you have a readout of the 

numerical value you’re at, as well as the transparency value.  The transparency 
output is new. 


