
McIDAS-V Tutorial 
Basic and Advanced Training 

updated September 2023 (software version 1.9) 
 

 
McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 
SSEC's 50-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 
(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 
manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 
Unidata's IDV libraries. The functionality of SSEC's HYDRA software package is also being integrated into 
McIDAS-V for viewing and analyzing hyperspectral satellite data. 
 
More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 
McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 
the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 
https://www.ssec.wisc.edu/mcidas/software/v/. 
 
If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 
Forums - https://mcidas.ssec.wisc.edu/forums/. The forums also provide the opportunity to share information 
with other users. 
 
In this McIDAS-V Tutorial, some exercises will be explained using different methods of data access:  local data 
files, pre-loaded data bundles and real-time access to default remote servers.  If you have access to your own 
real-time ADDE servers, you may also use those, but be aware that different server configurations may make the 
explanations in this document not quite applicable to all data that you may load. 
 
 

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 
Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 
Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 
Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources). 

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag). 
 

https://www.ssec.wisc.edu/mcidas/software/v/
https://mcidas.ssec.wisc.edu/forums/
https://mcidas.ssec.wisc.edu/forums/
https://mcidas.ssec.wisc.edu/forums/


Page 2 of 94 
 

McIDAS-V Tutorial – Basic and Advanced Training                                                               September 2023 – McIDAS-V version 1.9 

Introduction 
Installation of McIDAS-V 
The installation of McIDAS-V is a simple three step procedure (download, install, and run). 
 
1.  Download the appropriate package for your operating system from the McIDAS-V webpage.  This file is 

only the installer and can be placed anywhere on your machine.  When you run the installer in the next step, 
you can then indicate where you want McIDAS-V to be installed.  The system requirements for McIDAS-V 
are also listed on the McIDAS-V webpage. 

 
2.  Install McIDAS-V by starting the installer by following the instructions appropriate for your operating 

system: 
  macOS              mount the .dmg and double-click the installer 
  Windows  double-click the downloaded .exe file 
 All other platforms open a terminal window and run sh ./<installer>.sh 

 

  
 

A GUI will walk you through the installation steps and allow you to create a program group and/or desktop icon. 
 
3.  Run McIDAS-V by following the instructions appropriate for your operating system: 
  
 macOS  Double-click on the McIDAS-V shortcut icon that was created in /Applications. 
 Windows Double-click on the McIDAS-V shortcut icon that was created on the Desktop. 
 All others At the UNIX prompt from the directory where McIDAS-V was installed,  
   run the command: runMcV 
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Note:  By default, McIDAS-V uses 80% of the available memory on your machine. The maximum amount of 
memory is determined by the operating system. To manually change the amount of memory used by 
McIDAS-V, edit the Maximum Heap Size in the Advanced tab of the Preferences by selecting  
Edit -> Preferences... from the main menu. The new amount of memory will be saved and used in 
subsequent sessions. For 32 bit operating systems, it is recommended to set this to no more than 1250 MB. 
The maximum value for 32 bit operating systems is 1536 MB. Exit McIDAS-V and start a new session to 
use this new memory setting. 

 
Welcome Window 
 
Upon initial startup, the Welcome to McIDAS-V window will be displayed. 

 
 
Please be sure to read this IMPORTANT 
NOTICE.  Because McIDAS-V utilizes the 
latest developments in Java 3D 
programming and video driver updates, it is 
often necessary to update video drivers to 
solve some seemingly unrelated 
performance problems.  Do not assume that 
because you have a new machine, you have 
the latest drivers.  We have found brand new 
machines with drivers that are more than 
five years old! 
 
 
After reading the notice in the Welcome 
window, click Quit to close the window, or 
click Start McIDAS-V to close the window 
and start McIDAS-V.  Once McIDAS-V has 
been started, this window will not appear 
again. 
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Introduction to McIDAS-V windows 
 
There are two main windows in the McIDAS-V application - the Data Explorer window and the Main Display 
window. Other windows may appear when needed. 

 
 
 
Data Explorer (shown on the left) 
The Data Explorer window is central to McIDAS-V. It is used to choose data sources and parameters to 
display, the kinds of displays to make, and times of data to display.  The first time McIDAS-V starts up, the 
Data Explorer defaults to the Satellite -> Imagery Chooser.  This chooser, along with several others, uses 
ADDE (Abstract Data Distribution Environment) servers to access data.  McIDAS-V comes with a pre-
configured list of several available free servers which contain real-time and archived atmospheric datasets. 
 
Main Display (shown on the right) 
The Main Display window includes the McIDAS-V display panels, legend, time animation controls, viewpoint 
controls for 3D displays, icons to zoom and pan, menus to control views and projections, and the main 
McIDAS-V menu. Navigating to Help -> User’s Guide in the Main Toolbar brings up the McIDAS-V User’s 
Guide, which has both a table of contents and a search function. 
 
Common Usage Scenario 
To create displays of data with McIDAS-V, the common usage scenario is: 

• Choosing the source of data (local files, remote servers, etc.) 
• Selecting parameters and display type 
• Creating the display 
• Controlling the display 
• Creating a bundle 

 
 

Bundles 
Bundles let you save a quick "snapshot" of McIDAS-V, including data sources, maps, and data displays. 
Bundles are small information files that specify the state of McIDAS-V. They are a kind of configuration file. 
They include information about what data sources are in use, which parameters from the data sources are 
displayed, and how they are displayed. 
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The purpose of bundles is for you to save a particular McIDAS-V setup and display. A bundle can be used for 
your own reference at a later time, or others using McIDAS-V can use bundles you made to see data the same 
way you did. There are two types of bundles, regular *.mcv bundles, and *.mcvz zipped bundles. These serve 
different purposes. 

The *.mcv bundle, along with storing the setup and display options, stores a reference to the particular type of 
data you have loaded into McIDAS-V. For example, if you load in the most recent GFS, display pressure, and 
save your display as a *.mcv bundle, the next  time the bundle is loaded, McIDAS-V will connect to the 
server/catalog where you got the data from originally, and display the most recent GFS pressure data. This type 
of bundle can be very useful in an operational environment, where you often want to look at the same products 
displaying the most recent data. 

The *.mcvz bundle is different from the *.mcv bundle in that it actually stores data along with the bundle. For 
example, if you load in radar data for a tornado case that you want to look at again, but that may not be on the 
server at a later date, you can save your display as a *.mcvz zipped bundle. The next time this bundle is loaded 
in, the same exact data with the same display options will be displayed. This can be useful for case studies, 
where you always want to look at the same data. 

 

 

Data Explorer - Data Sources tab 

  
The Data Sources tab is used to locate remote data servers or local files for display in McIDAS-V.  Once the 
type of data source is selected, a chooser with the appropriate selection criteria is displayed.  Satellite -> 
Imagery is chosen above, and the Satellite -> Imagery chooser is displayed.  Other data source types are the 
HYDRA multi-spectral display, Radar, Point Observations, Gridded Data and General files. 
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Data Explorer - Field Selector tab 

 
The Field Selector tab analyzes the data source to determine the displayable fields and parameters.  With this 
information, a list of available displays is presented.  In the Subset panel of the Field Selector there are tabs to 
select which times to display, which region to use, as well as a variety of advanced options. Note that the tabs in 
the Subset panel will differ dependent on which data source you loaded. 
 
Data Explorer - Layer Controls tab 

 
The Layer Controls tab contains the display options for the displayed fields and parameters which are referred 
to as layers.  Changes made to each layer will be reflected in the Main Display.  Also, if a graph, time series or 
special display was selected, it will display in the Layer Controls. 
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Introduction to McIDAS-V controls 
 
1. Load the <local path>/Data/Installation/Intro-Bundle.mcvz bundle to display NCEP GFS data in the 

Main Display window. 
 

a. In the Main Menu Bar in the Main Display window of McIDAS-V, select File -> Open File…. 
 
b. In the file browser, “Look In” the location where you downloaded the data files for this tutorial, select 

Intro-Bundle.mcvz and click Open. 
 

c. When prompted, select Replace Session to replace the current window with the contents of the bundle 
and click OK. 
 

d. Select Remove all layers. 
 

e. Select Remove all data. 
 

f. Select Write to temporary directory, check Don’t show this again, and click OK. 
 
The Main Display will change to a view from the south, and two new 3D Surfaces will be listed in the 
Legend in the right panel of the Main Display window.  One surface is a color-shaded image over 
topography.  The other surface is an isosurface of a constant wind speed of 40 m/s.  The green isosurface is 
shadowed for perspective, otherwise it would be one block of color. Additionally, a 3D map is listed in the 
legend, allowing the map lines to appear on top of the topographic data. 
 

2. Use Right-Click+Drag to rotate the display.  Use the navigation controls listed on the last page of this 
document or the navigation controls on the left side of the Main Display to zoom in and out, and “move 
through” the data. 
 

3. Toggle the 3D surfaces on and off in the display by clicking the checkbox next to each item in the Legend 
on the right side of the Main Display window. 
 

4. Click on the name of each item in the Legend to bring up the Layer Controls to change the color table or 
the isosurface values.  To change the unit of the isosurface to something other than m/s, in the Layer 
Controls menu select Edit -> Change Display Unit. 
 

5. Use the Time Animation controls at the top of the Main Display to loop through the images, or step 
through them one by one. 
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Below is a list of supported data types, formats, and the method to access them in McIDAS-V. 
 
Data Type Description Supported Formats Access Method 
Satellite 
Imagery 
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  

Geostationary and polar 
orbiter satellite imagery, 
derived satellite products 
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  

ADDE ADDE servers, local & remote 
McIDAS AREA local files, local & remote ADDE 
AIRS local files 
GINI local files, TDS servers 
AMSR-E Level 1b local ADDE 
AMSR-E Level 2a local ADDE 
AMSR-E Rain Product local ADDE 
EUMETCast LRIT local ADDE 
Meteosat OpenMTP local ADDE 
Meteosat Second Generation  
(MSG) Level 1b HRIT and native 

local ADDE 

Metop AVHRR Level 1b local ADDE 
MODIS L1b MOD02  
(MODIS Level 1b) 

local ADDE 

MODIS L2 MOD04  
(Level 2 Aerosol) 

local ADDE 

MODIS L2 MOD06  
(Level 2 Cloud Top Properties) 

local ADDE 

MODIS L2 MOD07  
(Level 2 Atmospheric Profile) 

local ADDE 

MODIS L2 MOD28  
(Level 2 Sea Surface 
Temperature Products) 

local ADDE 
  

MODIS L2 MOD35  
(Level 2 Cloud Mask) 

local ADDE 

MODIS L2 MODR  
(Level 2 Corrected Reflectance) 

local ADDE 

MSG HRIT FD/HRV and native* local ADDE 
MTSAT HRIT local ADDE 
NOAA AVHRR Level 1b local ADDE 
SSMI (TeraScan netCDF) local ADDE 
TRMM (TeraScan netCDF) local ADDE 
Himawari (*.DAT) * local ADDE 
HimawariCast * local ADDE 
INSAT-3D Imager * local ADDE 
INSAT-3D Sounder * local ADDE 
GOES ABI (Level 1b) * local ADDE 

  SCMI * local ADDE 
  GOES GLM local files 
  TROPOMI (netCDF) local files 
  JPSSVIIRS SDR Imagery EDR local files, local ADDE* 
  JPSS ATMS local files 
  JPSS CrIS local files 
  JPSS OMPS (NOAA-21) local files 
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Data Type Description Supported Formats Access Method 
Orbit Tracks Orbit tracks of geostationary and 

LEO (Low-Earth Orbit) satellites 
TLE (Two-Line 
Element) 

local files, ADDE, URL 

Gridded 
  
  
  

Numerical weather prediction 
models, climate analysis, gridded 
oceanographic datasets, 
NCEP/NCAR Reanalysis 

netCDF local files, HTTP, TDS Servers 

GRIB (versions 1&2) local files, TDS Servers 
Vis5D local files, HTTP 
GEMPAK local files, TDS Servers 

Point 
Observational 
  
  
  
  
  

Surface observations (METAR and 
SYNOP), earthquake observations 
  

ADDE ADDE servers 
netCDF (Unidata, 
AWIPS/MADIS 
formats) 

local files 

Text (ASCII, CSV), 
Excel spreadsheet 

local files 

Global balloon soundings (RAOB) 
  
  

ADDE ADDE servers 
netCDF (Unidata, 
AWIPS/MADIS 
formats) 

local files 

CMA text format local files 
Trajectory 
  

Aircraft observations 
  

netCDF (RAF 
convention) 

local files 

Text (ASCII, CSV) local files 
GIS 
  

Data typically used in Geographic 
Information Systems (GIS) 

ESRI Shapefile local files, HTTP 
USGS DEM local files 

QuickTime 
  

QuickTime movies (without 
extensions) 

QuickTime local files, HTTP 
    

Flat Files Flat (2-dimensional) data Binary, ASCII, 
standard images 
(JPEG, GIF, etc.) 

local files; Flat files chooser 

Radar Radar images Level II local files, TDS Servers 
  Level III ADDE servers, local files, TDS 

Servers 
  Universal Format (UF) local files 
  DORADE local files 

 
* The Himawari, HimawariCast, INSAT-3D, ABI, native format MSG, and VIIRS local servers are currently 
supported on Linux and macOS platforms 
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Geostationary Satellite Data 
 
1. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  Select 

adde.ssec.wisc.edu as the Server and EAST as the Dataset.  Click Connect. 
 

2. Select FD – GOES-East FullDisk all bands as the Image Type. 
 

3. In the Times panel, select the Relative tab.  For Number of times, enter 1 and click Add Source to create a 
data source of the most recent time. 
  

4. Display band 13 temperature data. 
 
a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the 

data.  Select the 10.3 um IR Surface & cloud -> Temperature field. 
 

b. From the Displays panel, select the Imagery -> Image Display display type. 
 

c. Select the Region tab to see a low-resolution preview image of the data.  Note that there is a green box 
drawn around the preview image.  Any data inside this bounding box will be displayed. 
 

d. Select the Advanced tab to see information about the band and calibration selected.  These values match 
the domain of the data selected in the Region tab, so it covers the entire domain of the data.  Notice that 
the Image Size is only 904 x 904 when the raw size of the data is 5424 x 5424.  The magnification of the 
data is set to -6, -6.  This reduction in resolution is the default to allow for an efficient display of the 
data.  Modify the Advanced tab to display full resolution data over Florida. 
 
i. Coordinate Type: Latitude/Longitude 

ii. Location: Center 
iii. Lat: 28; Lon: -83.5 
iv. Image Size: 400 x 400 
v. Magnification: 1 x 1 

 
e. Click Create Display. 

 
5. Investigate the display. 

 
a. In the Main Display window, practice navigating around in the display.  To do this, use Control+Right-

Click+Drag to translate the display.  This shifts the data left/right and up/down without rotating the 
display.  Zoom in on the display by scrolling down on the mouse wheel.  As an alternative, select a 
region in the Main Display by using Shift+Left-Click+Drag to zoom in on a specific domain. 
 

b. Probe individual pixel values by holding down the middle mouse button over the display.  This will print 
out probe values at the bottom of the display.  Notice that latitude, longitude, and temperature values are 
included in the probe output. 
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c. Navigate to the Histogram tab of the Layer Controls to see a histogram of band 13 temperature values. 
 

6. Add a data transect to the display. 
 
a. From the Field Selector tab of the Data Explorer, select the Data Transect display type and click 

Create Display. 
 

b. In the Main Display window, there is a red line that is referred to as the data transect.  The values along 
this transect line are output in the Layer Controls tab of the Data Explorer.  The two end points of the 
transect can be moved around by Left-Clicking+Dragging them, or by entering new Lat/Lon values at 
the bottom of the Display tab in the Layer Controls.  The transect line as a whole can be moved by Left-
Clicking+Dragging the triangle in the middle of the transect line.  
 

7. Create a display of the 10.3 μm temperatures so only values of 273K and less are plotted. 
 
a. Add a new two-paneled map display by selecting File -> New Display Tab -> Map Display -> Two 

Panels menu item. 
 

b. Left-Click in the left panel to make this panel active.  The active panel has a blue frame around it, and 
this is the panel any displays will be added to. 
 

c. In the Field Selector tab of the Data Explorer, select the 10.3 um IR Surface & cloud -> Temperature 
field.  Choose the Imagery -> Image Display display type and click Create Display.  
 

d. Create the cloud mask display. 
 
i. Left-Click in the right panel to make this panel active.  The active panel has a blue frame around it, 

and this is the panel any displays will be added to. 
 

ii. In the Field Selector tab of the Data Explorer, select Formulas. 
 

iii. Select the Imagery -> Mask Value formula, the Imagery -> Image Display display type, and click 
Create Display. 
 

iv. In the Select input window, enter the following and then click OK: 
 
1. comparison: < 
2. cutoff: 273 
3. useNaN: 1 

Notes: The comparison is set to < or ‘less than’ since the goal is to display values less than 273, 
which was set as the cutoff value.  Setting useNaN to 1 makes it so that if the pixels were probed 
outside of the masked range (where values are greater than 273) they wouldn’t show a value.  
useNaN can be set to 0 as well, and in this case pixel values greater than 273 would probe as 0.  
Note that if these pixel values are set to 0, then these 0 values will be included in any calculations 
with the data that may be done later. 
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v. In the new Field Selector window, for inputFieldForMask, select 10.3 um IR Surface & cloud -> 
Temperature.  This is the field that is being masked. 
 

vi. For displayFieldToBeMasked, select 10.3 um IR Surface & cloud -> Temperature.  This is the 
field that will be displayed where the inputFieldForMask is less than 273 degrees.  In this case, we 
are displaying the same field that is being masked. 
 

vii. Click OK. 
 

e. Investigate the display.  Note that as one of the panels is navigated, the other will be navigated in the 
same way.  This is because by default panels in the same tab are set to share views.  This setting can be 
disabled in a panel by unchecking Projections -> Share Views in the display panels. 
 

8. Create a display of a subtraction of two bands. 
 
a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One 

Panel menu item, or by clicking the Add new tab ( ) button in the Main Toolbar. 
 

b. In the Field Selector tab of the Data Explorer, select Formulas. 
 

c. Select the Miscellaneous -> Simple difference a-b formula, the Imagery -> Image Display display type, 
and click Create Display. 
 

d. In the new Field Selector window, for a, select the 8.4 um IR Total WV cloud phase, dust -> 
Temperature field.  For field b, select the 7.3 um IR Lower-level WV, winds & SO2-> Temperature 
field. 
 

e. Click OK in the Field Selector window to display the band subtracted data. 
 

f. Right-Click on the colorbar of the ABI layer in the Legend and select the System -> Inverse Gray Scale 
enhancement. 
 

g. Add latitude and longitude labels to the display. 
 
i. Left-Click on the blue text for the Default Background Maps layer in the Legend to get to the Layer 

Controls tab of the Data Explorer for the layer. 
 

ii. From the Lat/Lon tab of the Layer Controls, set the following: 
 
1. Check the visibility checkboxes for Lines and Labels to plot them in the display. 
2. Lines: Interval: 5.0 
3. Labels: Interval: 5.0; At Longitudes: -85.0, At Latitudes: 30.0, Color: light blue 
4. Font: Arial; Bold; 20 
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h. Investigate the display to see the latitude and longitude lines and labels.  Probe the data to see the 
temperature difference between the two bands. 
 

9. Capture an image of the display. 
 
a. From the Main Display, select the View -> Capture -> Image menu item. 

 
b. In the Save As text field, enter the name to give your image, for example: band_subtraction.gif. 

 
c. Use the dropdown below Save As to select the directory to save your image to. 

 
d. Under Capture What, select Current View.  This will capture an image of the display without including 

any other components of the Main Display such as menu items and the Legend. 
 

e. Click Save. 
 

f. View your saved image to verify the image was captured correctly. 
 

 
Accessing GOES-16 ABI Data from a Remote Server – 5 Timesteps 
 
1. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and 

Data Sources menu item from the Main Display. 
 

2. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel 
menu item.  Close any previously-existing tabs. 
 

3. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  In the Relative 
tab of the Times panel, for Number of times, enter 5 and click Add Source. 
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4. Display a loop of 10.3um Temperature data over Wisconsin and Illinois. 

 
a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the 

data.  Select the 10.3 um IR Surface & cloud -> Temperature field. 
 

b. From the Displays panel, select the Imagery -> Image Display display type. 
 

c. Navigate to the Advanced tab, and enter the following information: 
i. Coordinate Type: Latitude/Longitude 

ii. Location: Center 
iii. Lat: 42; Lon: -89.6 
iv. Image Size: 450 x 450 
v. Magnification: 1 x 1 

 
d. Click Create Display. 

 
5. Investigate the display. 

 
a. The Main Display now has a loop of the 5 most recent times of data in the FD dataset.  As done in step 5 

in the previous section, navigate around and zoom in/out of the display.  Probe the display by holding 
down the middle mouse button over the data. 
 

b. Use the Time Animation Widget at the top of the display panel to play through a loop of the data. 
 

 
 

c. Click the Properties button ( ) in the Time Animation Widget to modify settings of the animation 
including the dwell rate (the time spent on each frame in the animation).  As an example, set the 
Forward, First, and Last dwell rates to 0.2 and click OK.  This reduced dwell rate allows the display to 
loop faster. 
 

6. Change the enhancement used in the display. 
 

a. Stop the animation by clicking the Stop Animation button in the Time Animation Widget ( ). 
 

b. Right-Click on the colorbar of the ABI layer in the Legend and select the Satellite -> GOES-R -> ABI IR 
Temperature enhancement.  
 

7. Add a color scale to the display. 
 

a. Right-Click on the ABI layer in the Legend and select Edit -> Properties. 
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b. In the Properties window, navigate to the 
Color Scale tab and set the following: 
i. Visible: Check this option to add the color 

scale to the display. 
ii. Position: Top.  This will position the color 

scale at the top of the display. 
iii. Labels -> Visible: Check this option to add 

numerical labels to the color scale. 
iv. Labels -> Show Unit: Check this to add 

the display unit to the color scale labels. 
v. Labels -> Font: Set the size to 26.  

 
c. Click OK. 

 
8. Create a Data Probe/Time Series display of band 13 temperature data.  This display type allows for plotting 

how temperature values at a specific location change through time throughout the loop. 
 

a. In the Field Selector tab of the Data Explorer, select the Data Probe/Time Series display type and click 
Create Display. 
 

b. The Layer Controls tab of the Data Explorer now shows a time series display of temperature values at 
the location of the probe in the Main Display.  Change the range of the y-axis (temperature values) to 
match the range of the data. 
 
i. At the bottom of the Layer Controls tab, Double-Click on the 186-Band13_TEMP parameter to open 

the Properties window. 
 

ii. In the Properties window, change the Range text boxes to a Min of 180 and a Max of 320 to match 
the range of the enhancement in the Main Display. 
 

iii. Click OK to apply the new range in the Layer Controls and close the Properties window. 
 

c. Move the data probe in the Main Display around with Left-Click+Drag.  The time series display in the 
Layer Controls automatically updates itself as the probe’s location changes. 
 

The data probe in the Main Display can also be set to a specific latitude/longitude value by using the Lat and 
Lon text boxes at the bottom of the Layer Controls.  For example, enter values of 38.6 for Lat and -88.1 for 
Lon.  Note that you must press Enter in each text field for latitude/longitude to update the location of the data 
probe. 
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Using a Local ADDE Dataset 
 
1. Create a local dataset to access the imagery files on your local machine. 

 
a. In the Main Menu Bar of the Main Display, select Tools -> Manage ADDE Datasets. 
 
b. In the ADDE Data Manager, select File -> New Local Dataset.  Enter the following parameters to set 

up a dataset with the AREA files provided with this tutorial: 
 
• Dataset – MSG 
• Image Type – Cyclone Juliette 
• Format – MSG HRIT FD 
• Directory – select the <local path>/Data/Satellite/MSG_data directory 

 

 
 

c. Click Add Dataset.  Close the ADDE Data Manager by clicking Ok or selecting File -> Close. 
 
2. To load the data in this local dataset, follow these steps. 

a. Click on the  button in the main toolbar to go to the Data Explorer. 
 
b. From the Data Sources tab, select the Satellite -> Imagery chooser. 

 
c. Select <LOCAL-DATA> for Server, select MSG for Dataset, click Connect. 

 
d. Choose the MSG satellite data Image Type and select an absolute time of 11:45 UTC. 

 
e. Click Add Source to show the Field Selector. 

 
f. In the Fields panel of the Field Selector, choose 0.6 um VIS Cloud and Surface Features -> 

Brightness. 
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g. In the Advanced tab, set the 
following values: 

a. Coordinate Type: 
Latitude/Longitude 

b. Location: Center 
c. Lat: 40; 9 
d. Image Size: 350 x 352 
e. Line Mag: 1 
f. Ele Mag: 1 

 
h. Click Create Display.  The 11:45 

UTC 0.6 μm is displayed in the 
Main Display window.  The 
image displays Storm Juliette, 
which brought cold temperatures 
and snow to the Balearic Islands. 

 
 
 
 
 
 
Exercise 
 
Create a 2-paneled map display.  In the left panel, display the most recent GOES-16 band 1 CONUS brightness 
data.  In the right panel, display the most recent GOES-East band 13 CONUS temperature data.  This data can 
be accessed from the adde.ssec.wisc.edu server, EAST dataset, and CONUS image type. 
 
Navigate around the displays to observe how the two panels move in sync with each other.  Through the 
Projections menu of one of the display panels, disable Share Views and navigate around one of the panels again.   
 
Change the name of the tab to “GOES-East Vis and IR” by double-clicking on the “untitled” text above the 
panels to open the Rename Tab window. 
 
Change the name of the left panel from “Panel 1” to “Visible” by selecting View>Properties, entering the new 
name into the Name field, and clicking OK.  Repeat this process with the right panel to set its name to 
“Infrared”. 
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 Polar Satellite Data 
 
Displaying Local MODIS Data 

 
 
1. Create a local dataset to access the imagery files on your local machine. 

 
a. In the Main Display window of McIDAS-V, select Tools -> Manage ADDE Datasets. 
 
b. In the ADDE Data Manager, select File -> New Local Dataset.  Enter in the following parameters to 

set up a dataset with the MODIS Level 1b HDF files provided with this tutorial: 
 
• Dataset – MODIS 
• Image Type – Canada Fires 
• Format – MODIS MOD 02 – Level-1B Calibrated Geolocated Radiances 
• Directory – select the <local path>/Data/Polar/modis_files directory 

 

 
 

c. Click Add Dataset. 
 

d. Close the ADDE Data Manager by clicking Ok or File -> Close. 
 
2. To load the data in this local dataset, follow these steps. 

a. Click on the  button in the Main Toolbar to go to the Data Explorer. 
 
b. Select the Satellite -> Imagery chooser from the Data Sources tab. 

 
c. Select <LOCAL-DATA> for the Server, select MODIS for the Dataset, and click Connect. 

 
d. Choose the Canada Fires Image Type and select an Absolute time of 14:55 UTC. 

 
e. Click Add Source to show the Field Selector. 

 
f. Select 0.6465 um Land/Cloud Boundaries -> Brightness. 

 
g. In the Advanced, click the green four arrow button to get the full resolution and full domain of the data. 
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h. Click Create Display.  The 14:55 UTC 0.6465 μm image is displayed in the Main Display window. 

 
3. Use the zooming and panning controls in the left toolbar to inspect the image.  Specifically, notice the 

smoke from the fires in southern Quebec, Canada. 
 

a. Reproject the image with a pre-defined domain.  Select Projections -> Predefined -> World.  Use the 
scroll wheel to zoom into the image or Shift+Left Click+Drag a box around the image. 

 
b. Turn off the Auto-set Projection option under the Projections menu.  When this option is checked, the 

projection will automatically change to the native projection of the new layer.  When this option is 
unchecked, all new layers will be reprojected into the current projection. 
 

4. Return to the Field Selector to load a surface/cloud temperature image. 
 

a. Select 3.7882 um Surface/Cloud Temperature -> Temperature. 
 

b. In the Advanced, click the green four arrow button to get the full resolution and full domain of the data. 
 

c. Click Create Display.  The 3.7882 µm temperature image is overlaid on top of the visible image.  To 
see the visible image, turn off the top HDF MOD02 1km file (All Bands...) checkbox in the Legend.  
Turn the visibility of the 0.6465 μm back on. 
 

5. Modify the enhancement range to make the fire pixels easier to locate. 
 

a. Zoom in on the region where the 
data is displayed in the Main 
Display.  
 

b. Right-Click on the grayscale 
enhancement for the 3.7782 μm 
layer in the Legend and choose 
Change Range. 
 

c. In the Change Range window, 
change the To value to 340 and 
click OK. 
 

d. Right-Click on the grayscale 
enhancement for the 3.7782 μm 
layer in the Legend and choose 
the Satellite -> Fire – 
Transparent enhancement.  
This makes high end temperatures yellow, orange, and red, while the lower end cooler temperatures are 
100% transparent, allowing the 0.6465 μm data to be seen. 

 
6. Use the cursor readout option to see the temperature values for the fire pixels. 
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a. Click and drag the middle mouse button to activate the Cursor/Data Readout option and list the 
latitude, longitude, and data value under the cursor.  Since there are two layers in the main display, there 
are two different readouts with the appropriate values and units.  Notice the high 3.7882 μm temperature 
values are located at the location of the fire.  The data probe from the cursor/data readout option shows 
that values in the fire are approximately 50 degrees K warmer than outside of the fire. 

 
7. Edit the maps in the display by using the options in the Layer Controls. 

 
a. Click on Default Background Maps in the Legend to go to the Layer Controls.  The map controls will 

have two tabs.  The first Maps tab lists the available maps, and the second Lat/Lon tab allows the user to 
control latitude and longitude lines and labels. At the bottom of both tabs, there is a Position slider that 
allows you to control the vertical positioning of the maps in the Main Display. 

 
b. In the Maps tab you can remove a map, change its visibility, line width, style and color.  Use these 

options to create your own map display. 
 

c. If you choose, also add latitude and longitude lines and labels in the Lat/Lon tab. 
 

d. To save a map configuration as the default, in the Layer Controls select File -> Default Maps -> Save 
as the Default Map Set.  The next time you open a new tab, window, or start McIDAS-V, the defaults 
will reflect what you selected.  
 

8. Notice that both layers are labeled the same in the Legend. Change the text of the labels in the Main 
Display. 
  

a. Right Click on the top Canada Fires (All Bands) label in the Legend and select Edit -> Properties. 
 

b. Enter the following for the Legend Label: 3.7882um - %datasourcename% 
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9. Display a true color RGB image of the scene and it with the 3.7882 μm data. 
 

a. In the Field Selector, choose Imagery -> MODIS Functions -> MODIS True Color RGB. 
 

b. In the Displays panel, select Imagery -> 3 Color (RGB) Image. 
 

c. Click Create Display. 
 

d. Inspect the display and notice how the true color RGB image is displayed on top of the other layers.  
Bring the 3.7882um layer to the front Right-Clicking on the blue text of the layer in the Legend and 
selecting View -> Bring to Front. 

 
 
Displaying Local NOAA-19 Data 
 
1. Create a local dataset to access the AVHRR (Advanced Very High Resolution Radiometer) NOAA-19 

HRPT (High Resolution Picture Transmission) polar orbiter imagery files on your local machine. 
 

a. In the Main Menu Bar of the Main Display window, select Tools -> Manage ADDE Datasets. This 
will open the ADDE Data Manager. 

 
b. Select File -> New Local Dataset. Enter the following parameters to set up the dataset: 

 
• Dataset – AVHRR 
• Image Type – NOAA-19 
• Format – NOAA AVHRR L 1b 
• Directory – select the <local path>/Data/Polar/AVHRR directory. 

 

 
 

c. Click Add Dataset. 
 

d. Close the ADDE Data Manager by clicking Ok or select File -> Close. 
 
2. Remove all layers and data sources and display AVHRR 3.74 μm Temperature data.  

 
a. In the Main Display select File -> New Display Tab -> Map Display -> One Panel. 
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b. In the Satellite -> Imagery chooser of the Data Sources tab of the Data Explorer, select <LOCAL-
DATA> for the Server, select AVHRR for the Dataset, and click Connect. 

 
c. Choose the NOAA-19 Image Type and select an Absolute time of 14:06:22 UTC. 

  
d. Click Add Source to show the Field Selector. 

 
e. Select 3.74um IR Low Cloud/Fog, Fire Detection -> Temperature. 

 
f. Under Displays click on the Advanced tab.  Click on the green arrow icon next to Image Size to load 

the full image. Change the Magnification to 1 X 1 with the sliders, and click Create Display.  The 
Magnification of 1 X 1 loads and displays the full resolution of the data.  Negative magnification values 
will reduce the amount of data loaded and displayed.  For example, -5 X -5 will sample the data, and 
every fifth line and every fifth element is sent from the server. 
 

g. Change the display to the World projection through the Projections -> Predefined -> World menu item.  
Use Shift+Left-Click+Drag to zoom in over the data. 
 

h. Optionally, modify the display to highlight the fire activity as was done previously with the MODIS 
data.  This can be done by changing the enhancement and adjusting the enhancement range. 

 
 
 
Exercise 
 
Using the <local path>/Data/Polar/MOD02/* data, create a local dataset, and display an animation of 3 times 
of data.  Disable auto-set projection in the a new display tab and display the data using Line/Element navigation 
so the data will plot at the correct location for each timestep.  These are all daytime images, so displaying any 
visible or infrared band will produce good images.
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Hyper-Multispectral Data 
 
Create a Multispectral Display (AIRS Hyperspectral Data) 
 
1. In the Main Display remove all layers and data sources via the Edit -> Remove -> All Layers and Data 

Sources menu item. 
 
2. Display the data from the AIRS file dated August 08, 2023 at 12:23:21 UTC.    

 
a. In the Data Sources tab of the Data Explorer, open the Satellite -> HYDRA chooser.  

 
b. Navigate to <local path>/Data/Hydra/ 

AIRS.2023.08.08.124.L1B.AIRS_Rad.v5.0.25.0.G23221105157.hdf, and click Add Source. 
 

c. The file loads into the Field Selector with the name of Hydra.  To make the name more descriptive, edit 
the properties of the data source.   
 

• Under Data Sources, Right Click on Hydra.   
• Select Properties.   
• Change Name from Hydra to AIRS 2023/08/08 12:23:21 UTC. 
• Click OK. 

 
d. In the Field Selector, under Fields, select MultiSpectral -> Radiance. 

 
e. In the Field Selector, under Displays, select MultiSpectral Display.  Click Create Display. 

 
3. The MultiSpectral image displays in the 

Main Display. There are four aspects to the 
MultiSpectral display:  

 
• The image in the Main Display.    
• The main spectrum probe in the Main 

Display is the magenta square.  
• The reference spectrum probe in the 

Main Display is the light blue square.    
(NOTE:  The two spectrum probes may 
overlap, with only the magenta square 
visible.   
Left Click+Drag either box to view 
spectra measured in various pixels of 
image.)  

• The spectra of the MultiSpectral layer in 
the Layer Controls.  The default 
wavenumber is 919.50 cm-1 (10.8 µm).   From the Main Display, click Multi Spectral in the Legend to 
view spectra for the AIRS file in the Layer Controls tab of the Data Explorer. 
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4. Add an image description to the Main Display. 
 

a. In the Layer Controls, select Edit -> Properties. 
 

b. In Layer Label field, remove 
%displayname%.  Type 
%datasourcename%.  The macro 
%datasourcename% is linked to the 
description entered in step 2c. 

 
c. If the Show in Layer List box is not 

checked, click to activate this option. 
 

d. Click OK.  The customized label 
appears at the bottom of the Main 
Display. 

 
5. Compare clear vs. cloudy spectra by moving the spectrum probes. 

   
a. In the Main Display, Shift+Left Cick+Drag to zoom the satellite image. 

 
b. Place one probe over a cold cloud top and one over a dark, cloud-free pixel (such as the eye of Hurricane 

Florence).   
 

c. View spectra in the Layer Controls.  (When in the Main Display, click on MultiSpectral in the Legend 
to bring Layer Controls to the front.) 
 

d. Zoom into interesting spectral regions Shift+Left Click+Drag.  Control+Left Click returns the full 
spectra. 
 

e. Choose different wave numbers by Left Click+Dragging the green selector bar or by entering a 
Wavenumber below the spectra. 
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Create a MultiSpectral Display (MODIS data) 
 
1. Remove all layers and data sources from the previous displays. 
 
2. Display the data from the <local path>/Data/Hydra/ 

MYD021KM.A2023230.0930.061.2023230112307.NRT.hdf file. 
 

a. In the left panel of the Data Sources tab of the 
Data Explorer, choose Satellite -> HYDRA, 
navigate to the MODIS file and click Add 
Source. 

 
b. Change data source name. In the Field 

Selector, Right Click on Hydra under Data 
Sources and select Properties. Change Name 
from Hydra to MODIS 2023/08/18 at 
09:30:00 UTC and click OK. 

 
c. Under Fields expand the MultiSpectral drop 

down list and select Emissive_Bands. 
 

d. Under Displays select MultiSpectral Display. 
 

e. Click Create Display. 
 
 An 11.0 µm image over Hurricane Hillary from 09:30:00 UTC on August 18, 2023 is displayed. 
 
3.  Change the band displayed in the 

Main Display.   
 
a. Left Click MultiSpectral in 

Legend to bring Layer 
Controls to front. 
 

b. Change band with either Left 
Click+Drag option to move the 
green selector bar or select the 
Band from the drop-down list 
at the bottom of the Display tab 
of the Layer Controls. 
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Create a Scatter Analysis of two bands 
 
4. Make a scatter analysis (plot) of two bands. 

 
a. In Data Explorer, navigate to the Field Selector tab. If the Data Explorer is not visible, select Window 

-> Show Data Explorer from the Main Display. 
 

b. Select the Emissive_Bands field.  This will be the x-axis in this scatter analysis.  Under Displays, select 
Imagery -> Scatter Analysis.  
 

c. Use the Band dropdown in the MultiSpectral tab in lower right panel to select Band 28 (7.345 µm). 
Click Create Display. 
 

d. A Field Selector window will appear for selection of the y-axis data field.  In this new Field Selector, 
select Emissive_Bands, and then Band 29 (8.503 µm) in the MultiSpectral tab.  Click OK. 
 

5. The scatter analysis will display in the Layer Controls. 
 

• The left image is the first selected field (Emissive_Bands band 28). 
• The middle image is the second selected field (Emissive_Bands band 29).  
• The right plot is the two-field scatter analysis. The x-axis (abscissa values) corresponds to the first 

field selected and the y-axis (ordinate values) corresponds to the second field selected. (In this 
example, band 28 (7.345 µm) versus band 29 (8.503 µm)). 
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6. Analyze the scatter plot and images by highlighting a box or region in any of three panels.  
 

 
 
 

a. To draw a box, click the Box radio button and select one of the colors.  Use Shift+Left Click+Drag 
option to draw box over a region of the scatter plot.  The corresponding points are highlighted in the 
image.  

 
b. Conversely, select a region of interest in one of the images.   The corresponding points are highlighted in 

the scatter plot.   
 

c. To draw a shape, click the Curve radio button.  Use Left Click+Drag option to draw an enclosed shape.  
 

d. To remove a color from the scatter plot, Double Click in that color’s selection box. 
 

7. Click the compute statistics button at the bottom of the Layer Controls. A window with the scatter plot 
statistics will appear.  Also, there is an option to save the statistics as a CSV file. 

 
Exercise/Challenge 
Use the <local path>/Data/Hydra/ MOD021KM.A2023261.1600.061.2023262011632.hdf file to create a 
Normalized Difference Vegetation Index (NDVI) where: 
 
NDVI = [Band 2 (0.86 µm) – Band 1 (0.65 µm)] / [Band 2 (0.86 µm) + Band 2 (0.65 µm)]. 
 
This can be done by displaying the Reflectance data with the “4 Channel Combinations” formula.  Display the 
output of this formula, set the range to -1 to 1, and the enhancement to be Satellite > GOES > NDVI.  
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Exercise/Challenge Solution 
 
1. In the left panel of the Data Sources tab of the Data Explorer, choose Satellite -> HYDRA, navigate to the 

MOD021KM.A2023261.1600.061.2023262011632.hdf MODIS file and click Add Source. 
 

2. In the Fields panel of the Field Selector, choose the MultiSpectral > Reflective_Bands field. 
 

3. In the Displays panel of the Field Selector, choose the Imagery > 4 Channel Combinations display type. 
 

4. Click Create Display. 
 

5. In the Channel Combination Tool tab of the Layer Controls, use the dropdowns to define the bands and 
operators to use to create the NDVI. 
 

 
 

6. Click the Compute New Field button at the bottom of the Layer Controls. 
 

7. In the Fields panel of the Field Selector, choose the MultiSpectral > (((1.0 * a) – (1.0*b)) / ((1.0*c) + (1.0 
*d))) field. 
 

8. In the Displays panel of the Field Selector, choose the Imagery > Image Display display type. 
 

9. Click Create Display. 
 

10. Right-Click on the enhancement in the Legend of the Main Display and choose Change Range.  Enter a 
range of -1 to 1 (the standard range for NDVI) and click OK. 
 

11. Right-Click on the enhancement and select Satellite > GOES > NDVI. 
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Orbit Tracks 
 
Introduction 
 
McIDAS-V has the ability of displaying TLE (Two Line Elements) Satellite Orbit Track data through the 
Satellite Orbit Track chooser.  TLE data can be loaded into the Field Selector in three ways: 
 

• Through a local file on your machine or a mounted drive 
• Through ADDE 
• Through a URL 

This tutorial will describe how to load data through a local file and a URL. Different options for customizing the 
display will be covered as well. 
 
Displaying TLE Data from a Local File 
 
1. In the Main Display, remove all layers and data sources via the Edit -> Remove -> All Layers and Data 

Sources menu item. 
 

2. Create a new tab with the File -> New Display Tab -> Map Display -> One Tab menu item. 
 

3. Create a data source of satellite track data from a local file. 
 
a. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Orbit Track chooser. 

 
b. Under Local, verify that File is selected. 

 
c. Navigate to the <local path>/Data/SatelliteTracks directory and select noaa.txt. 

 
d. Click Add Source. 

 
4. Display a full day’s worth of NOAA-21 (JPSS-2) tracks from August 23, 2023. 

 
a. In the Fields panel of the Field Selector, select the NOAA 21 (JPSS-2) [+] field. 

 
b. In the Displays panel, select Satellite Orbit Track. 

 
c. The Time Range panel allows for selecting the beginning and ending date/time of the track to plot.  

McIDAS-V will default to displaying the tracks from 00:00:00Z – 23:59:59Z on the current date.  To 

display the full track from August 23, 2023, click on the calendar widget ( ) next to Begin Date and 
select Aug 23, 2023.  Repeat this process for the End Date field. 
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d. Click Create Display. 
 

5. Inspect the display of the NOAA-21 tracks. 
 
a. When the display is created, you may see horizontal lines going across the display, as is shown here: 

 
 
If you see these horizontal lines, go to the Layer Controls tab of the Data Explorer for the orbit track 
layer and select Edit -> Properties.  At the bottom of the Properties window, uncheck Use Fast 
Rendering and click OK.  Once this is done, the display may look like the following image: 

 
 
There are times where disabling fast rendering can remove spurious lines.  There are other times where 
enabling fast rendering can fix gaps in lines when viewing a polar projection.  In general, if the display’s 
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lines don’t look correct, changing the fast rendering setting for the layer is a good idea. 
 

b. Zoom in on the region of interest in the Main Display by using Shift+Left-Click+Drag.  For example, 
select an area over the central United States.  Observe the track times, and determine a good time range 
where the track lines cross through the United States.  The times are written along the track.  For 
example, you may determine a time range of 19:20 through 19:35 is good.  In the next section of this 
tutorial, this time range will be plotted. 
 

6. Create a new tab via the File -> New Display Tab -> Map Display -> One Panel menu item. 
 

7. Display NOAA-21 satellite tracks for the time range chosen in step 5b. 
 
a. From the Field Selector tab of the Data Explorer select NOAA 21 (JPSS-2) [+]. 

 
b. In the Time Range panel, verify that Aug 23, 2023 is selected for the Begin Date and End Date fields.  

For Begin Time, enter 19:20:00 (or the start time determined in step 5b) and for End Time enter 
19:35:00 (or the end time determined in step 5b) and click Create Display. 
 

8. Modify different aspects of the track line display. 
 
a. Zoom in over the track data in the Main Display by using Shift+Left-Click+Drag. 

 
b. Add swath edge lines to the display by going to the Layer Controls and enabling Swath Edges On/Off.   

 
c. By default, time labels are drawn along the track every 5 minutes.  Change the display to show time 

labels at every minute by going to the Layer Controls, setting Label Interval to 1, and clicking Apply. 
 

d. From the Layer 
Controls, change the 
color of the lines and 
labels in the display to 
yellow by clicking on 
the green Color 
Swatch, selecting 
Yellow, clicking OK in 
the Color window, and 
clicking Apply. 
 

e. From the Layer Controls, change the Track Style from a solid line to a dashed line by using the 
dropdown menu and click Apply. 
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f. From the Layer Controls, change the Edge Style from a dashed line to a solid line by using the 
dropdown menu and click Apply. 
 

9. Add a SSEC (Space Science and Engineering Center) ground station to the display. 
 
a. From the Ground Stations panel of the Layer Controls, select SSEC for the Ground Stations 

Available menu and click Add Selected. 
 

Investigate the display.  A ground station for SSEC has been added to the display over south central Wisconsin.  
There is a ring around the ground station that denotes the region where an antenna at the SSEC ground station 
can detect the NOAA-21 satellite.  The size of this ring is based on the altitude of the satellite as well as the 
Antenna Angle, which is defined at the bottom of the Layer Controls.  This is the angle that the antenna at the 
SSEC ground station scans at.  Once the ground station is added, the final display may look like: 
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Under Development - JPSS 
 
Introduction 
 
McIDAS-V has the ability of displaying JPSS (Suomi NPP, NOAA-20, and NOAA-21) data through the Under 
Development -> Imagery – JPSS chooser.  Among the JPSS products that McIDAS-V can display are data 
from the VIIRS (all bands of SVM and SVI, Imagery EDRs, Product EDRs, Day/Night band), CrIS, ATMS 
instruments.  OMPS data from NOAA-21 is supported as well.  In order for the data to be recognized by 
McIDAS-V, the geolocation files must be contained within the same directory as the data.  Some sources of 
data, including NOAA’s CLASS, package the data and geolocation files together by default.  Other sources of 
JPSS data may store the geolocation in a separate file from the data.  Note that this chooser is still under 
development and improvements in functionality as well as the ability to utilize different JPSS products will be 
added in the future. 
 
Display a Single Granule of NOAA-21 Data 
 
1. Load a single granule of NOAA-21 SVM15 VIIRS data. 

 
a. Remove all layers and data sources from previous displays. 

 
b. Create a new 2-paneled tab via the File -> New Display Tab -> Map Display -> Two Panels menu item. 

 
c. Remove any older tabs from the Main Display. 

 
d. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS. 

 
e. Under Files, select the following file: 

 
<local path>/Data/JPSS/Harold/ SVM15_j02_d20230822_t1938577 * 
Note that this file contains just the data (SVM).  The matching terrain-corrected-geolocation file 
(GMTCO) is also in this directory.  On some platforms, the GMTCO file might not be visible in the 
JPSS chooser.  On other platforms they may be listed, but grayed-out.  McIDAS-V can also work with 
JPSS files that package the data and geolocation in the same file, such as those distributed by default 
from NOAA CLASS.  This scene is from after Tropical Storm Harold made landfall in Texas. 
 

f. Click Add Source.  
 

2. Display Brightness Temperature data. 
 
a. In the Main Display window, verify that the left panel is active. 
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b. In the Field Selector tab of the Data Explorer, select the VIIRS-M15-
SDR_All/BrightnessTemperature field, and the Imagery -> Image Display display type. 
 

c. Note that the Region tab in the Field Selector shows a preview image of the selected field. 
 

d. Click Create Display. 
 

e. Investigate the display and note that while the display is at the native resolution of the data (750 meters), 
bowtie deletion lines (black stripes) can be seen along the left/right side of the granule. 
 

3. Display Brightness Temperature data without the bowtie deletion lines. 
 
a. In the Main Display window, verify that the right panel is active. 

 
b. In the Field Selector, select Formulas under Data Sources. 

 
c. In the Fields panel of the Field Selector, select the Imagery -> JPSS Functions (Under Development) -

> VIIRS SDR -> Swath To Grid – Bowtie Removal formula. 
 

d. Click Create Display. 
 

e. In the Select input window that appears, enter 750 for resolution in meters and 1.0 for mode.  Click 
OK. 
 

f. In the Field Selector window that appears, select the VIIRS-M15-SDR_All/BrightnessTemperature 
field and click OK. 
 

g. Investigate the display and note that the bowtie deletion lines are removed, but the enhancement and 
range are different between the two panels. 
 

4. Modify the enhancement and range of the display output by the Swath To Grid function to match the 
original data. 
 
a. In the Layer Controls tab of the Data Explorer select VIIRS-M15-SDR/Brigh* under untitled>Panel 1.  

These are the controls for the panel on the left side of the Main Display.  The enhancement should be 
Inverse Gray shade with a range of 180 – 320K. 
 

b. Select Edit -> Display Settings.  This window allows for the properties of one layer to be applied to 
another layer/layers displayed. 
 



Page 35 of 94 
 

McIDAS-V Tutorial – Basic and Advanced Training                                                               September 2023 – McIDAS-V version 1.9 

c. In the Properties panel of the Display Settings window, click the check boxes next to Color Table and 
Color Range. 
 

d. In the Target Displays panel of the Display Settings window, click the VIIRS 2023-08-22* checkbox 
under Panel 2. 
 

e. Click Apply in the Display Settings window. 
 

f. Close the Display Settings window. 
 

 
 

g. When you are done investigating the display, remove all layers and data sources. 
 
Create a Display of Several Aggregated Imagery EDR Granules 
 
McIDAS-V has the ability to aggregate several small granules into one large one by selecting multiple time-
consecutive granules in the Data Sources tab of the Data Explorer before clicking Add Source.  The previous 
examples used VIIRS SDR (Sensor Data Record) data.  VIIRS Imagery EDR (Environmental Data Record) 
files, which are more processed and don’t include bowtie deletion lines, are also supported in McIDAS-V. 
 
1. Create a data source of eight time-consecutive granules of Imagery EDR SVM08 data. 

 
a. Create a new one paneled tab via the File -> New Display Tab -> Map Display -> One Panel menu 

item. 
 

b. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS. 
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c. Navigate to the <local path>/Data/JPSS/Aggregation and use Shift+Left-Click to select all of the 
GMGTO-VM08O* files. 
 

d. Click Add Source. 
 

2. Display the Reflectance field from the data source. 
 
a. In the Field Selector tab of the Data Explorer, select the VIIRS-M8-MOD-EDR_all/Reflectance field. 

 
b. In the Image panel, verify that Imagery -> Image Display is selected. 

 
c. Click Create Display. 

 
3. Adjust the display to make the dust over the Mediterranean Sea easier to see. 

 
a. Use Shift+Left-Click+Drag to zoom in over the location of the data. 

 
b. By default, a wireframe box is drawn in the Main Display.  This is the white box going around and 

partially through the data.  Disable the wireframe box by unselecting View -> Show -> Wireframe Box 
from the panel in the Main Display window. 
 

c. Adjust the enhancement range to better highlight the dust over the Mediterranean Sea southwest of Spain 
and Italy.  To do this, Right-Click on the enhancement in the Legend and select Change Range.  In the 
Change Range window, set the minimum value to -0.05 and the maximum value to be 0.2.  Click OK.  
In the image below, areas of dust are circled in red. 
 

 
 

d. When you are done investigating the display, remove all layers and data sources. 
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Create an RGB Display of Aggregated Imagery EDR Granules 
 
1. Display true color RGB imagery from Suomi NPP data. 

 
a. Create a new one paneled tab via the File -> New Display Tab -> Map Display -> One Panel menu 

item.  Close any other previously-existing tabs. 
 

b. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS. 
 

c. Navigate to the <local path>/Data/JPSS/Canada and use Shift+Left-Click to select both of the 
GMGTO-VM03O* files. 
 

d. Click Add Source. 
 

e. In the Fields panel of the Field Selector, select 
Imagery -> JPSS Functions (Under 
Development) -> VIIRS EDR -> VIIRS EDR 
True Color RGB.  This is a derived formula 
that utilizes the bands/calibrations included in 
the data source to create the RGB. 
 

f. In the Displays panel, select Imagery -> RGB 
Composite. 
 

g. In the Region tab, use Shift+Left-Click+Drag 
to subset a region over the Mid-Atlantic. 
 

h. Click Create Display. 
 

i. Zoom in over the data in the Main Display. 
 

j. In the Layer Controls, brighten the display by adjusting the Common Gamma to 0.4 and click Apply to 
All Gamma Fields. 
 

2. Overlay the True Color RGB display with aerosol optical depth (AOD) from Suomi NPP. 
 
a. In the Main Display window, disable Projections -> Auto-set Projection.  This will keep the Main 

Display in its current projection instead of remapping the display to any new data. 
 

b. In the Data Sources tab of the Data Explorer, select General -> Files/Directories. 
 

c. Navigate to the <local path>/Data/JPSS/Canada and select the JRR-AOD* file. 
 

d. Click Add Source. 
 

e. In the Fields panel of the Field Selector, select 2D Grid -> AOT at 0.55 micron for both ocean and 
land. 
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f. In the Displays panel, select Plan Views -> Color-Shaded Plan View. 
 

g. Click Create Display. 
 

h. In the Layer Controls tab of the Data Explorer for the AOD layer move the Texture Quality slider to 
High to remove the bowtie deletion lines from the display. 
 

i. Toggle the visibility of the AOD layer on and off to see how the higher levels of AOD overlap with the 
smoke.  Note that much of the center of the AOD layer contains no data.  This is because there was no 
retrieval at that location, which can be seen by displaying the 2D grid -> AOD Retrieval quality 
variable. 
 

3. Overlay the True Color RGB and AOD displays with Carbon Monoxide (CO) from gridded NUCAPS data. 
 
a. In the Data Sources tab of the Data Explorer, select General -> Files/Directories. 

 
b. Navigate to the <local path>/Data/JPSS/Canada and select the 20230607_1800_gridded* file. 

 
c. Click Add Source. 

 
d. In the Fields panel of the Field Selector, select 2D Grid -> CO_Total. 

 
e. In the Displays panel, select Plan Views -> Color-Shaded Plan View. 

 
f. Click Create Display. 

 
g. Adjust the enhancement range to make the higher levels of CO easier to distinguish.  To do this, Right-

Click on the enhancement of the CO layer in the Legend and select Change Range.  Enter min/max 
values of 15 – 50 and click OK. 
 

h. Toggle the visibility of the layers in the display on and off to see how they correlate.  Note that the 
NUCAPS data is from NOAA-20, whereas the RGB and AOD data are from Suomi NPP.  However, 
both satellites have the same sensor and they are relatively close in terms of passage time with NOAA-
20 being ~45 minutes after Suomi NPP. 
 
 

Exercise/Challenge 
 
Create a 3-panel display.  Using data in <local path>/Data/JPSS/Harold, display SVM15 brightness 
temperature from NOAA-21 in the left panel.  In the center panel, display ATMS (microwave) NOAA-21 data 
from the GATMO-SATMS* file with the MultiSpectral Display.  In the right panel, display base reflectivity radar 
data from KEWX in Texas at the time of the VIIRS and ATMS imagery.  This data, found in the <local 
path>/Data/JPSS/Harold/Radar directory, can be loaded through the Radar -> Level II -> Local chooser.  
When loading the radar data source, verify that I’m Feeling Lucky is selected in the Station dropdown before 
clicking Add Source.  Investigate the ATMS data to see which channel best depicts the radar reflectivity. 
 
The next page shows what your display may look like in the end. 
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Radar Data 
 
Displaying Level II radar images: 2D and 3D reflectivity swaths 
 
The Radar Sweep View in 2D display creates a 2-dimensional display of 3-dimensional radar data at individual 
elevation angles. While only data from only one elevation angle can be displayed at once, you can cycle through 
different elevation angles to help to determine the 3-dimensional characteristics of the data. 
 
The Radar Sweep View in 3D display creates a 3-dimensional display of radar data at individual elevation 
angles. While only data from only one elevation angle can be displayed at once, you can cycle through different 
elevation angles to inspect the 3-dimensional characteristics of the data. This display appears to be identical to 
the Radar Sweep View in 2D display until the image is rotated, giving a perspective of altitude of the data. 
 
1. From the Data Explorer, navigate to the Radar -> Level II -> Local chooser. 

 
2. Navigate to the <local path>/Data/Radar directory.  Use Shift+Left-Click to select all of the KNKX* files. 

 
3. Verify that I’m Feeling Lucky is selected from the Station dropdown. 

 
4. Click Add Source. 

 
5. Open a two panel map display and change the color of the outline around the active panel.  

 
a. In the Main Display, select File -> New Display Tab -> Map Display -> Two Panels menu item. 

 
b. By default, the right panel is highlighted by a blue box, which means this is where the data will be 

displayed. Click the left panel, and you should see the blue box outline the panel display, indicating it is 
the active panel.  Any displays created will be added to the active panel. 

 
c. To change the outline color, select Edit -> Preferences.  Under the Display Window tab, there is a Color 

Scheme section on the right side.  To the right of Selected Panel, click the blue box to bring up the Set 
Selected Panel Border Color window.  Select a new color from the swatches and click OK.  Click OK 
to close the User Preferences window.  Switch between panels to refresh the box to the selected color. 

 
6. Display the reflectivity data using the Radar Sweep View in 2D display type in the left panel. 

 
a. Select the left panel of the Main Display, and return to the Field Selector tab of the Data Explorer. 

 
b. Under Fields, select Reflectivity.  The available displays will list under Displays.  Choose the Radar 

Displays -> Radar Sweep View in 2D display type.   
 

c. Click Create Display. 
 

7. Display the reflectivity data using the Radar Sweep View in 3D display type in the right panel. 
 
a. Select the right panel of the Main Display, and return to the Field Selector. 
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b. Under Fields, select Reflectivity. The available displays will list under Displays. Choose the Radar 
Displays -> Radar Sweep View in 3D display type. 
 

c. Click Create Display.   
 

8. There is no visible difference between the two layers until the view is rotated away from the top. Right 
Click+Drag or use the navigation toolbar in the left side of the Main Display to rotate the display. Turn 
looping on and off as you navigate through the 3D reflectivity image. 
 

9. A default for multi-panel displays is shared views, which means that as one panel’s navigation changes, they 
all move in sync.  To turn this feature off, go to a panel and uncheck Projections -> Share Views. 
 

Displaying realtime Level II radar data 
 
1. From the Data Explorer, navigate to the Radar -> Level II -> Remote chooser. 

 
2. Using the default catalog htttps://thredds.ucar.edu/thredds/radarServer/catalog.xml, click Connect. 

 
3. For Collection, select NEXRAD Level II Radar from IDD. 

 
4. Left-Click on a station currently experiencing precipitation.  Note that you can zoom in pan the map with 

either the mouse or the buttons below the mouse.  By default, Declutter is enabled, meaning not all stations 
are shown. 
 

5. In the Relative tab of the Times panel, make sure that 5 is entered in the Number of times field. 
 

6. Click Add Source. 
 

7. In the Main Display window, create a new 1-paneled map display. 
 

8. Create a 2D display of radar reflectivity. 
 
a. In the Fields panel of the Field Selector, select Reflectivity. 

 
b. In the Displays panel of the Field Selector, select Radar Displays -> Radar Sweep View in 2D. 

 
c. Click Create Display. 

 
9. Overlay the 2D data in the Main Display with a vertical cross section of reflectivity. 

 
a. In the Fields panel of the Field Selector, select Reflectivity. 

 
b. In the Displays panel of the Field Selector, select Radar Displays -> Radar Cross Section. 

 
c. Click Create Display. 
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d. Maneuver the endpoints of the cross section by Left-Click+Drag over one of the squares at the ends of 
the line, or the entire cross section by Left-Clicking+Dragging over the triangle at the center of the cross 
section.  Rotate the display with Right-Click+Drag or look at the Layer Controls to see the 3D data. 
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Displaying realtime Level III radar data 
 
1. Remove all layers and data sources from the previous examples. 

 
2. Create a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel. 

 
3. Close any other previously-existing displays 

 
4. Load a data source of Hydrometeor Classification data. 

 
a. From the Data Explorer, navigate to the Radar -> Level III chooser. 

 
b. For Server select adde.ssec.wisc.edu and for Dataset select RTNEXRAD.  Click Connect. 

 
c. For Product, select H0H – Digital Hydrometeor Classification 0.5DEG. 

 
d. Using the map, select a station currently experiencing precipitation. 

 
e. In the Relative tab, enter 5 for Number of times. 

 
f. Click Add Source. 

 
5. Display the hydrometeor classification data. 

 
a. In the Field Selector tab of the Data Explorer, select Band: 16 -> Hydro Class in the Fields panel. 

 
b. Verify that the Imagery -> Imagery Display display type is selected in the Displays panel. 

 
c. Click Create Display. 

 
6. Investigate the display. 

 
a. The numerical values of the data are mapped in the colorbar in the Legend. 

 
b. Probe the display by holding down the middle mouse button.  Instead of seeing numerical output at the 

bottom, you are seeing the text description that those numerical values map to.  Assuming the ground is 
receiving liquid precipitation (rain) most pixels close to the location of the radar will likely be green for 
rain or gray for biological (birds/bugs).  As you move further away form the radar and the beam is 
detecting precipitation higher in the atmosphere there will likely be more blue and red colors for snow 
and graupel. 
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Point Observation Data 
 
Plotting and Contouring Surface Point Observations around the world 
 
1. Remove all layers and data sources from the previous displays.  If you have created more than one tab, close 

the extra tabs by clicking on the “X” on the right side of the tabs. 
 
2. From the Data Sources tab of the Data Explorer, select the Point Observations -> Plot/Contour chooser. 
 

a. Connect to adde.ssec.wisc.edu Server with the RTPTSRC Dataset. 
 
b. Choose the SFCHOURLY - Real-Time SFC Hourly Point Type. 
 
c. In the Number of times text entry box of the Relative tab, enter 1 and click Add Source. 
 
d. In the Field Selector, select Point Data in the Fields panel. 

 
e. Select the Point Data -> Point Data Plot display type. 
 
f. In the lower-right panel, click the Layout Model tab and click the double down blue arrows next to 

METAR to select Observations -> Temperature to plot all available temperatures. 
 
g. Click Create Display.  The default display is a world projection with temperatures plotted from around 

the world.  As you zoom in you will see more stations appear in the plot. 
 
3. Reset the display projection using the Reset Display Projection button  on the left side of the Main 

Display or through the Projections -> From Displays menu item. 
 
4. Return to the Data Sources tab of the Data Explorer and select the Satellite -> Imagery chooser. 
 

a. Connect to the adde.ssec.wisc.edu Server with the EAST Dataset. 
 
b. Select an Image Type of FDC14 – GOES-16 Full Disk 11.2 um IR Imagery/SST/clouds/rainfall. 

 
c. In the Absolute tab of the Times panel, select a time close to the point data loaded in step 2 and click 

Add Source. 
 

d. In the Field Selector tab, expand the 11.2um field, and select Temperature. 
 

e. Select the Imagery -> Image Display display type.  Click Create Display. 
 
5. To contour the temperatures plotted on the screen, return to the Field Selector. 

 
a. Select SFCHOURLY in the Data Sources panel. 
 
b. In the Fields panel, select Gridded Fields -> T. 
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c. Select Plan Views -> Contour Plan View in the list of displays, and click Create Display.  The contour 
properties can be changed in the Layer Controls tab of the Data Explorer. 
 

- Note that these contours are drawn from surface observations, which are recorded over land, not water. 
Therefore, contours will look better if you zoom in over a land area in the Main Display. 

 
Creating Time Series of Point Observations 
 
1. Remove all layers and data sources. 
 
2. Return to Point Observations -> Plot/Contour chooser in the Data Sources tab.  Use the adde.ssec.wisc.edu 

Server, the RTPTSRC Dataset, and the SFCHOURLY Point Type. 
 

a. Select a group of times from the Absolute time tab (to select more than one time, use Shift+Click), and 
click Add Source. 

 
b. Select Point Data in the Fields panel and click Create Display to plot the default station models. 

 
c. Zoom in on the display and play through the loop to see how the observations change. 

 
3. In the Layer Controls, follow these steps: 

 
a. Click on the Plot tab to create a time series. 

 
b. Zoom in over a station in the Main Display and Left Click on the center of it.  The station information 

should fill into the table below the plot in the Layer Controls. 
 

c. Add the temperature to the plot by Right Clicking on the T field in the table and selecting Add To 
Chart. 

 
 
Displaying RAOB Sounding Data 
 
1. Remove all layers and data sources. 

 
2. Select the Point Observations -> Soundings -> Remote chooser in the Data Sources tab.  

 
a. Connect to the adde.ssec.wisc.edu Server with the RTPTSRC Dataset. 

 
b. Select UPPERMAND for the Mandatory Levels and UPPERSIG for the Optional Significant Levels. 

 
3. Select a station for your sounding display. 
 

a. Use the zooming and panning buttons to find your station(s).   
 
b. Select an available time and click on your station to see if a sounding is available.  Available soundings 

will show up in the Selected box on the bottom right of the chooser.   
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c. If more than one is available for your station, select the most recent time and add the source.   

 
d. Under the Displays panel of the Field Selector, you have the option to choose which type of 

thermodynamic diagram to display (Skew-T, Stuve, Emagram).   
 

e. Select one of the thermodynamic diagrams and click Create Display. 
 

4. The sounding will show up in a 2D display in the Layer Controls tab along with a list of thermodynamic 
parameters.  As you move the mouse over the sounding, the thermodynamic parameters will update.  
  

  
 
5. The temperature and dewpoint traces can be modified via the cursor.  
 

a. Left Click on the first data-point to be modified and drag it horizontally along an isobar to the desired 
position, then move the pointer diagonally along an isotherm to keep the data-point at the desired 
position and to pick-up the next data-point.  Repeat until done and then release the mouse button.   

 
b. To reset the sounding, use the Edit -> Reset Sounding menu item of the Layer Controls tab. 

 
c. Use the checkboxes below the sounding to configure the sounding chart. When the Stations box is 

checked, you will see a square box in the Main Display indicating the location of each sounding 
selected in the Data Sources tab.  Select a new station by Left Clicking another square box in the Main 
Display, or by choosing a station in the Station dropdown menu in the Layer Controls. 

 
d. In the Layer Controls, in addition to the Sounding Chart, there are also tabs for a Hodograph, and a 

Table of all of the data in the sounding. 
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Gridded Data 
 
Displaying Gridded data: 2D 
 
1. Remove all layers and data sources from the previous displays. 
 
2. If you are using real-time data, skip to step 3. Otherwise, load the file 

  <local path>/Data/Grid/GFS_CONUS_80km_20230825_0600.grib1. 
 
a. In the Data Explorer, navigate to the Gridded Data -> Local chooser. 

 
b. Select the <local path>/Data/Grid/GFS_CONUS_80km_20230825_0600.grib1 file. 

 
c. Click Add Source. 

 
3. If you are using realtime data, follow the instructions below. 
 

a. Select the Gridded Data -> Remote chooser from the Data Sources tab of the Data Explorer.   
 

b. From the Catalog pull down menu, select 
https://www.ssec.wisc.edu/mcidas/software/v/threddsRTModels.xml. 
 

c. Add the Realtime Data -> NCEP Model Data -> Global Forecast System (GFS) -> GFS-CONUS 
80km -> Latest source. 

 
4. Display the MSL Pressure. 
 

a. In the Field Selector, select the 2D grid -> Pressure 
reduced to MSL @ Mean sea level field. 
 

b. Select the Plan Views -> Color-Shaded Plan View 
Display. 
 

c. In the Times tab, use the dropdown to choose Use 
Selected, and select the first six times. 
 

d. Click Create Display. 
 
5. In the Layer Controls, turn on the option to Shade 

Colors. 
 
6. Go back to the Field Selector, change the display type to Contour Plan View, and overlay the same field. 

 
a. Select the 2D grid -> Pressure reduced to MSL @ msl field. 

 
b. Select the Plan Views -> Contour Plan View display type. 
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c. Click Create Display. The contours will now overlay the Color-Shaded Plan View display. 
 

7. In the Layer Controls, click on the Color Table name (PressureMSL) to change the color table of the 
contours to System -> Solid Colors -> Black. 
 

8. In the Layer Controls tab, click the Change button for Contour.  For Labels, change the Align item to 
Horizontal and move the Frequency slider up to a value of Hi.  Click OK. 
 

9. Zoom in over a region to see a display like that on the previous page. 
 
 
Displaying Gridded data: 3D 
 
1. Remove all layers.  In the Field Selector, select the 3D grid -> Temperature @ Isobaric surface field. 

 
a. Select the Plan Views -> Color-Filled Contour Plan View display type. 

 
b. In the Times tab select the first 6 images. 

 
c. In the Level tab, select 500 hPa. 

 
d. Click Create Display.   

 
2. Use the rotating and zooming controls to rotate the Main Display window. You can see that the 500 hPa 

surface is displayed above the map layer. 
 

3. Keep the Main Display rotated so the difference in height between the map and the display can be seen. 
 
4. Change the level of the display.  Note that when the level is changed, both the plotted values and the z-level 

of the display change in the Main Display. 
 
a. Click on Latest NCEP GFS CONUS… in the Legend to go to the Layer Controls for this item. 

 
b. Change the level to 850 hPa by using the Levels menu. 

 
c. Change the contour interval to 2 Celsius by clicking on the Change button in the Contour section of the 

Layer Controls. 
 
5. Reset the projection using the  button on the left side of the Main Display window 

 
6. Change the level to 250 hPa in the Layer Controls using the method in 4b. You should notice that the map 

does not show up on the displayed data. 
 
7. Move the map above the 250 hPa contours and change the map colors to white. 
 

a. In the Layer Controls, select Default Background Maps from the list of layers on the side of the tab. 
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b. At the bottom of the Maps tab, move the Position slider to the z-level of 0.30 to move higher into the 
3D display. You should now see that the map lines are drawn on the data displayed in the Main Display. 
However, the map lines may be hard to see since they are the same color as the data by default. 
 

c. In the Maps tab of the Layer Controls for Default Background Maps, change the map colors of “North 
& Central America”, “World Political Boundaries”, and “World Coastlines” to white. Do this by 
clicking on the colored square next to each of the map lines, selecting white, and hitting OK. The map 
lines should now be more clearly visible in the Main Display window. 
 
 

3D Isosurface Display of Winds over Hurricane Hillary 
 
1. Remove all layers and data sources, create a new tab, and close any previously-existing tabs. 

 
2. Load the <local path>/Data/Grid/GFS_CONUS_80km_20230818_0600.grib1 file. 

 
a. In the Data Explorer, navigate to the General -> Files/Directories chooser. 

 
b. Select the <local path>/Data/Grid/GFS_CONUS_80km_20230818_0600.grib1 file. 

 
c. Click Add Source. 

 
3. Display flow vectors over the location of Hurricane Dorian. 

 
a. In the Fields panel of the Field Selector, choose 

the 2D grid -> Derived -> Flow Vectors (from 
*height_above_ground*) field. 
 

b. In the Displays panel, choose Flow Displays -> 
Vector Plan View. 
 

c. In the Times tab, select the first 10 times. 
 

d. In the Region tab, change the dropdown to Select 
A Region and draw a box over the domain 
pictured here (Florida and out into the 
Caribbean).  Click Create Display. 
 

4. Add an isosurface of wind speed to the display. 
 
a. In the Fields panel of the Field Selector, choose the 3D grid -> Derived -> Speed field. 

 
b. In the Displays panel, choose 3D Surface -> Isosurface. 

 
c. Verify that the Times and Region tabs have the settings specified for the flow vectors in step 3.  In the 

Level tab, select All Levels. 
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d. Click Create Display. 
 

5. Inspect the display and change some properties of the isosurface. 
 
a. Use the mouse and navigation toolbars to rotate the display, and the Time Animation Widget to play 

through the loop. 
 

b. By default, the unit of the wind speed isosurface is set to m/s.  Change these units to miles per hour by 
Right-Clicking on the blue text of the 3D surface layer and selecting Edit -> Change Display Unit.  In 
the Change Unit window, change the dropdown to mi/hr and click OK. 
 

c. In the Layer Controls, change the Isosurface Value to 100 and click Enter to see where the 100mph 
winds are forecasted to be located. 
 

d. In the Layer Controls, change the Isosurface Value to 50 and click Enter to see where the 50mph winds 
are forecasted to be located. 
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Local Files 
 
Plotting Point Observations from a text file 
 
1. Remove all layers and data sources from the previous displays. 
 
2. If there is more than one tab, close the extra tabs by clicking the “X” in the right corner of the tabs. 
 
3. Add the data from the <local path>/Data/Generic/QI_METOPC_2023230_T1850Z file. 
 

a. In the Data Sources tab of the Data Explorer, open the General -> Files/Directories chooser. 
 
b. In the Data Type field, choose Text Point Data files. 

 
c. Navigate to the <local path>/Data/Generic/QI_METOPC_2023230_T1850Z file. 

 
d. Click Add Source. 

 
4. Define the field names and units. 

 
a. In the Point Data window, select Space for the Delimiter. 

 
b. Under Start line, click the down arrow once to skip over the header line. 

 
c. In the lower panel of the Point Data window, fill in the fields exactly as shown below. Note that the 

items in these fields are case-sensitive. Do not use the pull down menus, as the choices are very limited.  
In the table below, any values not listed (e.g. “type”, and “sat”) do not need to be defined. 
 
 
Value Name Unit/Date Format Missing Value Extra 
day Time yyyyMMdd HHmm  colspan=”2” 
hms     
lat Latitude degrees   
lon Longitude degrees   
pre Pressure hPa   
spd Speed m/s   
dir Direction degrees   
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d. Select Preferences -> Save Current. Enter PWinds for the Name and click OK. 

 
e. Click OK at the bottom of the Point Data window. 

 
5. Open the Layout Model Editor to define how the data is displayed. 
 

a. In the Main Display select the Tools -> Layout Model Editor menu item. 
 

b. In the Layout Model Editor, select the File -> New menu item to create a new layout model. 
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c. In the New Layout Model window, enter a name of PWinds and click OK. 
 

6. Add a windbarb to your layout model. 
 
a. In the left panel of the Layout Model Editor, click Windbarb. Left Click in the window to place the 

windbarb object. Left Click+Drag to move the windbarb to the center of the box.  
 

b. In the Display tab of the Properties Dialog – WindBarb Symbol window, click the down arrow  for 
U or windspeed parameter.   Select Current Fields -> QI_METOPC_2023230_T1850Z-> Speed. 
 

c. Click the down arrow  for V or direction parameter.  Select  
Current Fields -> QI_METOPC_2023230_T1850Z -> True Heading Angle – Direction. Click OK to 
close the Properties Dialog window. 
 

7. Add the pressure value to your layout model. 
 

a. In the left panel of the Layout Model Editor, click 123 Value. Left Click in the window to place the 
value object.  Drag the object to above the windbarb.  
 

b. In the Display tab of the Properties Dialog – Value Symbol window, click the down arrow  for 
Parameter.  Select Current Fields -> QI_METOPC_2023230_T1850Z -> Pressure -- Pressure. 
 

c. Under Unit, select hectoPascals 
 

d. Click on Foreground Color box and select yellow. Click OK. 
 

e. Click OK to close the Properties Dialog window. 
 

8. Save your new layout model. 
 

a. In the Layout Model Editor, select File -> Save. 
 

b. Close the Layout Model Editor window. 
 
9. Create the display. 
 

a. In the Fields panel of the Field Selector, select the Point Data field. 
 

b. Select the Point Data Plot display type. 
 

c. In the lower-right panel of the Field Selector, open the Layout Model tab.  Click the down arrows   
and select PWinds <local>.  Click Create Display.  The default display is a world projection with wind 
barbs and pressures plotted.  As you zoom in you will see more stations appear in the plot.   
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Displaying radar imagery from a text file 
 
1. Remove all layers and data sources from the previous displays.  If you have created more than one tab, close 

the extra tabs by clicking the “X” in the right corner of the tab. 
 
2. To add the data source for the <local path>/Data/Generic/RADAR.ASCII file, in the Data Sources tab of 

the Data Explorer, open the General -> Flat files chooser.  In the Flat files chooser: 
 

• Click Open File icon next to File field and navigate to <local path>/Data/Generic/RADAR.ASCII. 
• In the Dimensions section of the Properties panel, enter 1200 for Elements and 1198 for Lines. 
• In the Navigation section of this tab, ensure Files is selected. 
• Click the Open File icon for Latitude and navigate to <local path>/Data/Generic/RADAR.LAT. 
• Click the Open File icon for Longitude and navigate to <local path>/Data/Generic/RADAR.LON. 
• Change the Scale value to 100 and check the East positive box. 
• In the Format section, select ASCII. 
• Click Add Source. 
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3. Display the radar data. 

 
a. In the Fields panel of the Field Selector tab, click key icon  next to RADAR.ASCII to expand the 

field and select Flat data. 
 

b. In the Displays panel, select Image Display. 
 

c. Click Create Display. 
 

4. The default display is a world projection, but this data is only over Oklahoma in the south-central United 
States.  Change the projection of the Main Display to Oklahoma.  
 

a. In the Main Display, navigate to the Projections -> Predefined -> US -> States -> N-Z -> Oklahoma 
menu item. 
 

b. Zoom in on the data by using Shift+Left Click+Drag to create a bounding box around the data. 
 

5. Change the color bar to display the radar data using typical colors used for a base reflectivity display. 
 

a. In the Legend, Right Click on the gray scale color bar. 
 

b. Select Radar -> Base Reflectivity 16 Levels. 
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Time Matching 
 
Introduction 
 
Time matching is a feature designed to create loops that accommodate data with differing temporal frequencies.  
Time matching involves setting one layer (generally the layer with the lower temporal frequency) as the time 
driver, and other layers can be set to match the times of the time driver. An example use case for this would be 
creating a loop of five hours of METAR surface observations at hourly intervals, and then overlaying each 
METAR with a satellite image that matches up closest with the METAR times. Generally, satellite data is 
available in time intervals of less than an hour, so instead of having to manually select each satellite image that 
matches the METAR times, McIDAS-V will do this automatically.  This tutorial will walk through this 
example. 
 
There are two locations to set a layer to be the time driver: 
 

- In the Times tab of the Field Selector use the dropdown to select Set As Time Driver, as demonstrated in 
this tutorial. 
 

- In the Layer Controls tab of the Data Explorer, use the View -> Times -> Set As Time Driver menu 
item. 

 
A time driver can also be set through the Time Animation Widget, by setting a block of user-defined times to be 
the time driver. 
 
Dependent on the chooser, there may be three locations of setting a layer to match the time driver, assuming a 
time driver has been set: 
 

- In the Data Sources tab of the Data Explorer, select the Match Time Driver checkbox, as 
demonstrated in this tutorial. This option is available through the Satellite -> Imagery, Radar -> Level 
II -> Remove, Radar -> Level III, and Point Observations -> Plot/Contour choosers. 
 

- In the Times tab of the Field Selector use the dropdown to select Match Time Driver. 
 

- In the Layer Controls tab of the Data Explorer use the View -> Times -> Match Time Driver. Note that 
if using this option, the layer must be reloaded with File -> Reload Data. 
 

 
Displaying Surface Observation Data and Matching Satellite Times 
 
1. In the Main Display, remove all layers and data sources via the Edit -> Remove -> All Layers and Data 

Sources menu item. 
 

2. Create a new tab with the File -> New Display Tab -> Map Display -> One Tab menu item. 
 

3. Load in the five most recent surface hourly observations. 
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a. In the Data Sources tab of the Data Explorer, navigate to the Point Observations -> Plot/Contour 
chooser. 
 

b. For Server, select adde.ssec.wisc.edu, and for Dataset select RTPTSRC. 
 

c. Click Connect. 
 

d. For Point Type, select SFCHOURLY – Real-Time SFC Hourly. 
 

e. In the Times panel, select the Relative tab.  For Number of times, enter 5 and click Add source to 
create a data source of the 5 most recent times. 
 

f. Click Add Source. 
 

4. Display METARS, and set the layer to be the time driver. 
 
a. In the Fields panel of the Field Selector, select the Point Data field. 

 
b. In the Displays panel, choose the Point Data -> Point Data Plot display type. 

 
c. In the Times tab, use the dropdown menu to select Set As Time Driver. 

 
d. Click Create Display.  

 
5. Load in GOES-16 11.2um IR satellite images that match the METAR times. 

 
a. In the Data sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser. 

 
b. For Server, select adde.ssec.wisc.edu, and for Dataset select EAST. 

 
c. Click Connect. 

 
d. For Image Type, select CONUSC14 – GOES-East CONUS 11.2 um IR Imagery/SST/clouds/rainfall. 

 
e. In the Times panel, at the bottom of the Relative tab, select the Match Time Driver checkbox. 

 
f. Click Add Source. 

 
6. Display the Temperature field of the satellite data. 
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a. In the Fields panel of the Field Selector, select the 11.2 um IR Imagery, SST, clouds, rainfall -> 
Temperature field. 
 

b. In the Displays panel, select Imagery -> Image Display. 
 

c. Click Create Display. 

Note: The METAR data is in hourly time steps.  The satellite data on the server, when in the default scanning 
mode, comes in every 5 minutes (can be seen in the Satellite -> Imagery chooser by selecting the Absolute 
times tab).  The Match Time Driver checkbox in the Satellite -> Imagery sorted through the list of times, to 
only load in the time steps that matched closest to the hourly METAR data.  This allowed for the creation of a 
display where both the METAR and satellite data were displayed in hourly intervals.  
 
 
Exercise/Challenge 
 
Use the Time Animation Widget to create a time sequence starting with the current time (rounded down to the 
nearest hour), with a range that goes back four hours from the current time in 1 hour intervals.  Set this time 
range to be the time driver.  Add the following layers to match the time driver times: 
 

1. METAR point data.  Set to match the time driver from the Data Sources tab of the Data Explorer. 
 

2. 10.7 μm GOES East satellite temperature data.  Set this to match the time driver times from the Field 
Selector tab of the Data Explorer.  
 

3. L2 Radar reflectivity data.  Set to match the time driver from the Layer Controls tab of the Data 
Explorer. 
 

Hint:  This is what the Time Animation 
Widget properties may look like when 
setting the time driver. 
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Bundles 
 
Unzipped Bundles 
 
1. Remove all layers and data sources, create a new one-paneled map display, and close any previously-

existing tabs. 
 

2. From the Satellite -> Imagery chooser of the Data Explorer, create a data source of the most recent GOES-
16 CONUS Cloud Top Pressure level 2 product. 
 
a. Connect to adde.ssec.wisc.edu/L2GEAST. 

 
b. In the Image Type dropdown, select CTPRCN – GOES-East Level2 CONUS Cloud Top Pressure 

Product. 
 

c. From the Relative tab of the Times panel, enter 1 into the Number of times field. 
 

d. Click Add Source. 
 

3. Display the Cloud Top Pressure data. 
 
a. From the Fields panel of the Field Selector, select L2: CTP – Cloud Top Pressure –> Ctpr. 

 
b. From the Displays panel, select Imagery -> Image Display. 

 
c. Click Create Display. 

 
Note that the display automatically uses a parameter default to set the appropriate enhancement and 
range for the product. 
 

4. Save a bundle of the display. 
 
a. From the Main Display window, select File -> Save Bundle. 

 
b. In the Save window, navigate to the directory where you want to save the bundle to. 

 
c. Enter a name of the file in the File Name field. 

 
d. In the Files of Type dropdown menu, choose McIDAS-V Bundles (*.mcv). 

 
e. Click Save. 

 
5. Load the bundle. 

 
a. Remove all layers and data sources, create a new one-paneled map display, and close any previously-

existing tabs. 
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b. From the Main Display window, select File -> Open File. 
 

c. In the Open File window, navigate to the location where the bundle was saved to, select the bundle, and 
click Open. 
 

d. If an Open bundle window appears, use the dropdown to select Merge with active tab(s) and click OK. 
 
With this being an unzipped bundle, no actual data is saved in the bundle file, just a reference to the 
data.  When the bundle is loaded, McIDAS-V will go back to the same server used to create the bundle 
and pull in the most recent version of the data.  The data will be displayed in the same way that it was 
when the bundle was saved. 
 
Bundles like this can be useful to create for forecasting.  For example, a forecaster can create a session 
containing several tabs of radar, grid, point, and satellite data that he/she wants to use again in the future.  
Once this bundle is saved, it’s easy to restore the same setup that was used previously.  Bundle files can 
also be passed around to other McIDAS-V users. 

 
Default Bundles 
 
1. Remove all layers and data sources, create a new one-paneled map display, and close any previously-

existing tabs. 
 

2. From the Satellite -> Imagery chooser of the Data Explorer, create a data source of the most recent GOES-
16 CONUS band 14 data. 
 
a. Connect to adde.ssec.wisc.edu/EAST. 

 
b. In the Image Type dropdown, select CONUSC14 – GOES-East CONUS 11.2 um IR 

Imagery/SST/clouds/rainfall 
 

c. From the Relative tab of the Times panel, enter 1 into the Number of times field. 
 

d. Click Add Source. 
 

3. Display the band 14 temperature data. 
 
a. From the Fields panel of the Field Selector, select 11.2 um IR Imagery,SST,clouds,rainfall -> 

Temperature. 
 

b. From the Displays panel, select Imagery -> Image Display. 
 

c. From the Advanced subset tab, click the four arrow green button to get the full resolution of the data. 
 

d. Click Create Display. 
 

4. Save the display as a favorite bundle. 
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a. From the Main Display window, select File -> Save Favorite. 
 

b. In the Save As Favorite window, make sure that General is chosen for Category. 
 

c. In the Name field, enter a name, such as: GOES_East_Band14. 
 

d. Click OK. 
 

5. Set the favorite bundle that was just saved to be the default bundle, meaning it will be loaded right away 
when McIDAS-V is started up. 
 
a. From the Main Display window, select Edit -> Preferences. 

 
b. In the User Preferences window, open the Advanced tab. 

 
c. Next to Defaults, enable the Specify default bundle option. 

 
d. Click the Browse button next to the Defaults text field. 

 
e. From the Open window, go to the General directory, select the bundle, and click Open. 

 
f. Click OK to close the User Preferences window. 

 
6. Verify that the default bundle works as expected. 

 
a. Exit McIDAS-V. 

 
b. Restart McIDAS-V. 

 
c. Optionally, disable the default bundle so it doesn’t load every time McIDAS-V starts.  To do this, go 

back to the Advanced tab of the User Preferences window, disable Specify default bundle, and click 
OK. 
 

 
Toolbar Bundles 
 
1. Remove all layers and data sources, create a new one-paneled map display, and close any previously-

existing tabs. 
 

2. From the Point Observations -> Plot/Contour chooser of the Data Explorer, create a data source of the 
most recent surface hourly observation data. 
 
a. Connect to adde.ssec.wisc.edu/RTPTSRC. 

 
b. In the Point Type dropdown, select SFCHOURLY – Real-Time SFC Hourly 
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c. From the Relative tab of the Times panel, enter 1 into the Number of times field. 
 

d. Click Add Source. 
 

3. Display the surface hourly data. 
 
a. From the Fields panel of the Field Selector, select Point Data. 

 
b. From the Displays panel, select Point Data -> Point Data Plot. 

 
c. Click Create Display. 

 
4. Save the display as a toolbar bundle. 

 
a. From the Main Display window, select File -> Save Favorite. 

 
b. In the Save As Favorite window, enter Toolbar>Point for Category. 

 
c. In the Name field, enter a name, such as: World METARS. 

 
d. Click OK. 

 
5. Verify that the toolbar bundle works as expected. 

 
a. Remove all layers and data sources, create a new one-paneled map display, and close any previously-

existing tabs. 
 

b. From the Main Toolbar in the Main Display window, select Point -> World METARS. 
 

c. If prompted, choose to replace the session. 
 
Toolbar bundles are an easy way to customize your session to make frequently displays readily 
accessible in an organized way.  In this example, the bundle was saved under a category called “Point”.  
Bundles can be added directly to the toolbar as well by simply specifying “Toolbar” as the Category 
when saving the bundle.  An example of how multiple bundles can be saved to the toolbar can be seen 
under the Current WX button in the toolbar, which contains a variety of unzipped bundles for different 
types of data (grid, point, and satellite). 
 

d. Toolbar buttons can also be accessed through the Local Favorite Bundles Manager window, which can 
be accessed through the Bundles -> Manage menu item in the Main Display.  This window gives the 
ability to load favorite bundles, remove them, or organize them. 
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Zipped Bundles 
 
1. Remove all layers and data sources, create a new one-paneled map display, and close any previously-

existing tabs. 
 

2. From the Under Development -> Imagery - JPSS chooser of the Data Explorer, create a data source of 
Suomi NPP band 13 data. 
 
a. Navigate to the <local path>/Data/JPSS/Canada directory. 

 
b. Select the GMGTO-VM13* file. 

 
c. Click Add Source. 

 
3. Display the brightness temperature over a portion of the 

data containing fire pixels east of the Hudson Bay. 
 
a. In the Fields panel of the Field Selector, select 

Image -> VIIRS-M13-
EDR_All/BrightnessTemperature field. 
 

b. In the Displays panel, select Imagery -> Image 
Display. 
 

c. In the Region tab, use Shift+Left-Click+Drag to 
subset a region east of the Hudson Bay. 
 

d. Click Create Display. 
 

4. Modify the enhancement range to make the fire pixels easier to locate. 
 
a. Zoom in on the region where the data is displayed in the Main Display. 

 
b. Right-Click on the grayscale enhancement in the Legend and choose Change Range. 

 
c. In the Change Range window, change the To value to 340 and click OK. 

 
5. The fire pixels are a little easier to see after the previous step.  Modify the enhancement itself to make them 

stand out even more. 
 
a. Right-Click on the enhancement in the Legend and choose Edit Color Table. 

 
b. The Color Table Editor window works by interpolating colors between breakpoints.  Add a new 

breakpoint at 305 by Right-Clicking above the enhancement and choosing Add Breakpoint -> At Data 
Point.  In the Breakpoint Value window, enter a value of 305 and click OK. 
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c. With the 305 breakpoint active (yellow outline around triangle at breakpoint), use the HSV tab to make 
the breakpoint yellow. 
 

d. Left-Click on the 340 breakpoint to make it active, and set this breakpoint to red using the same process 
to set the 305 breakpoint to yellow. 
 

e. Right-Click on the 340 breakpoint’s triangle and select Edit Colors -> Interpolate -> Left.  This will 
make the upper end of the enhancement shade from yellow to red. 

 

 
 

f. Investigate the display to see how the fires are now easier to see. 
 

6. Save the display as a zipped bundle. 
 
a. From the Main Display window, select File -> Save Bundle. 

 
b. In the Save window, navigate to the directory where you want to save the bundle to. 

 
c. Enter a name of the file in the File Name field. 

 
d. In the Files of Type dropdown menu, choose McIDAS-V Zipped Data Bundles (*.mcvz). 

 
e. Click Save. 

 
f. In the Save Data window, select Save All Displayed Data and click OK.  Wait for the Creating Zipped 

Bundle window to go away, meaning that the bundle has finished writing itself. 
 

7. Load the bundle. 
 
a. Remove all layers and data sources, create a new one-paneled map display, and close any previously-

existing tabs. 
 

b. From the Main Display window, select File -> Open File. 
 

c. In the Open File window, navigate to the location where the bundle was saved to, select the bundle, and 
click Open. 
 
Zipped bundles contain the data within the file itself.  These types of bundles can be useful for case 
studies, where you don’t want to load in the most recent version of the data, but the data for a particular 
date/time of interest.  Just like unzipped bundles, these zipped bundles can be sent to other users of 
McIDAS-V as well. 
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Saving Images and Animations 
 
Single-Paneled Image 
 
1. Remove all layers and data sources, create a new one-paneled map display, and close any previously-

existing tabs. 
 

2. From the Satellite -> Imagery chooser of the Data Explorer, create a data source of the most recent GOES-
16 CONUS band 14 data. 
 
a. Connect to adde.ssec.wisc.edu/EAST. 

 
b. In the Image Type dropdown, select CONUSC14 – GOES-East CONUS 11.2 um IR 

Imagery/SST/clouds/rainfall 
 

c. From the Relative tab of the Times panel, enter 1 into the Number of times field. 
 

d. Click Add Source. 
 

3. Display the band 14 temperature data. 
 
a. From the Fields panel of the Field Selector, select 11.2 um IR Imagery,SST,clouds,rainfall -> 

Temperature. 
 

b. From the Displays panel, select Imagery -> Image Display. 
 

c. Click Create Display. 
 

4. Capture an image of the display. 
 
a. From the display panel in the Main Display, select View -> Capture -> Image. 

 
b. In the Save window, select the directory for where to save the image. 

 
c. Under Capture What, select Current View. 

 
d. In the File Name field, enter a name followed by “.jpg”.  For example, Band_14.jpg. 

 
e. Click Save. 

 
5. Outside of McIDAS-V, open the captured image in a software that allows you to view JPG images.  For 

example, an internet browser. 
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Single-Paneled Animation 
 
1. Remove the currently-displayed layer in the display window. 

 
2. Display the 5 most recent band 14 CONUS images. 

 
a. From the Data Sources tab of the Data Explorer window, navigate to the Satellite -> Imagery chooser. 

 
b. Enter a value of 5 into the Number of times field and click Add Source. 

 
c. From the Fields panel of the Field Selector, select 11.2 um IR Imagery,SST,clouds,rainfall -> 

Temperature. 
 

d. From the Displays panel, select Imagery -> Image Display. 
 

e. Click Create Display. 
 

f. In the Main Display, use Shift+Left-Click+Drag to zoom in on an interesting feature in the display. 
 

3. Capture a movie of the display. 
 
a. From the display panel in the Main Display, select View -> Capture -> Movie. 

 
b. In the Movie Capture window, verify that Current View is selected under What to capture. 

 
c. Click the Time Animation button.  Note that the Main Display will now step through the loop, 

capturing an image of each frame.  While this process is occurring, don’t interact with the display or it’s 
possible that the movie might not save correctly. 
 

d. In the Save window, enter 1 for both Frames per second and End Frame Pause.  Navigate to the 
directory where you want to save the animation.  Enter a file name (for example, Band_14_loop), choose 
MPEG-4 files (*.mp4) for Files of Type, and click Save. 
 

e. Close the Movie Capture window. 
 

4. Outside of McIDAS-V, open the saved animation in a software that allows you to view mp4s.  For example, 
Windows Media Player. 
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Multi-Paneled Image 
 
1. Remove all layers and data sources. 

 
2. In the Main Display window, select File -> New Display Tab -> Map Display -> Four Panels. 

 
3. Remove any old tabs from previous exercises. 

 
4. From the Satellite -> Imagery chooser of the Data Explorer, create a data source of the most recent GOES-

16 CONUS data. 
 
a. Connect to adde.ssec.wisc.edu/EAST. 

 
b. In the Image Type dropdown, select CONUS – GOES-East CONUS all bands. 

 
c. From the Relative tab of the Times panel, enter 1 into the Number of times field. 

 
d. Click Add Source. 

 
5. Display band 1 data in panel 1 of the Main Display window. 

 
a. In the Main Display window, Left-Click in the upper left panel (Panel 1) to make it active.  The active 

panel is the one with the blue border around it.  Any time Create Display is clicked in the Field 
Selector, the display will go to the active panel. 
 

b. In the Fields panel of the Field Selector, select 0.47 um VIS aerosol-over-land -> Brightness. 
 

c. In the Displays panel, select Imagery -> Image Display. 
 

d. Click Create Display. 
 

6. Repeat this process for the other three panels, displaying any band/calibration of your choosing. 
 

7. Capture an image of the display. 
 
a. From the active display panel in the Main Display, select View -> Capture -> Image. 

 
b. In the Save window, select the directory for where to save the image. 

 
c. Under Capture What, select All Views. 

 
d. Enable the Borders Visible box and select a color for the border using the color swatch. 

 
e. In the File Name field, enter a name followed by “.jpg”.  For example, ABI_4_panel.jpg. 

 
f. Click Save.  Outside of McIDAS-V, view the captured image. 
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Data Polling 
 
McIDAS-V has the ability to automatically update displays at a user-defined time interval.  Ever “x” number of 
minutes, McIDAS-V will check the data server to see if new data is available.  If new data exists, the display 
will be updated.  Below is an example of data polling with GOES-West mesoscale-1 sector data, which has a 1-
minute frequency. 
 
1. Remove all layers and data sources, create a new one-paneled map display, and close any previously-

existing tabs. 
 

2. From the Satellite -> Imagery chooser of the Data Explorer, create a data source of the 5 most recent 
GOES-West mesoscale-1 sector band 14 data. 
 
a. Connect to adde.ssec.wisc.edu/WEST. 

 
b. In the Image Type dropdown, select M1C14 – GOES-West Mesoscale-1 11.2 um IR 

Imagery/SST/clouds/rai. 
 

c. From the Relative tab of the Times panel, enter 5 into the Number of times field. 
 

d. Click Add Source. 
 

3. Set up the data polling. 
 
a. From the Field Selector tab of the Data Explorer, Right-Click on the M1C14 – GOES-West data 

source and select Properties. 
 

b. Enable the Active box next to Automatically Reload.  This is the switch that turns polling on for the data 
source. 
 

c. Enter a value of 1 into the Check Every box to have McIDAS-V check for new data every minute. 
 

d. Enable Reload Displays at the bottom of the window.  This toggles the display to update. 
 

e. Click OK and close the Properties window. 
 

4. Display the band 14 Temperature data. 
 
a. From the Fields panel of the Field Selector, select 11.2 um IR Imagery,SST,clouds,rainfall -> 

Temperature. 
 

b. From the Displays panel, select Imagery -> Image Display. 
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c. In the Advanced tab, set the Coordinate 
Type to be Image Coordinates.  Click the 
green arrow button for full size/resolution.  
Choose Upper Left for Location. 
 
When using mesoscale sector data, or any 
other type of imagery data that can change 
position from time to time, Image 
Coordinates is better to use than 
Latitude/Longitude coordinates because it 
does not rely on a specific latitude 
longitude for where to position the data, 
but rather the upper left pixel. 
 

d. Click Create Display. 
 

e. At this point, you will see a Notice 
window.  With mesoscale sector data, the 
display will not automatically remap to the projection of the data.  This is because mesoscale sectors are 
often moved throughout the day to different locations dependent on severe weather or another need for 
frequent imagery. 
 

f. Use Shift+Left-Click+Drag to zoom in over the location of the data. 
 

5. Investigate how the data polling works.  Right when the data displays, take a note of the data times being 
displayed.  After about a minute, check and see if new data is loaded in.  Note that the display still has 5 
timesteps.  This means that newer times were added to the end of the loop, and the older times were 
removed from the beginning of the loop. 
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Different Types of Display Panels 
 
Globe Panel 
 
1. Set up the display window there is only one tab containing a glob panel. 

 
a. Remove all layers and data sources. 

 
b. From the Main Display window, select File -> New Display Tab -> Globe Display -> One Panel. 

 
c. Close any other previously-existing displays. 

 
2. If you are using real-time data, skip to step 3. Otherwise, load the file 

  <local path>/Data/Grid/gfs.t00z.pgrb2.0p25.anl. 
 
a. In the Data Explorer, navigate to the Gridded Data -> Local chooser. 

 
b. Select the <local path>/Data/Grid/gfs.t00z.pgrb2.0p25.anl file. 

 
c. Click Add Source. 

 
3. If you are using realtime data, follow the instructions below. 
 

a. Select the Gridded Data -> Remote chooser from the Data Sources tab of the Data Explorer.   
 

b. From the Catalog pull down menu, select 
https://www.ssec.wisc.edu/mcidas/software/v/threddsRTModels.xml. 
 

c. Add the Realtime Data -> NCEP Model Data -> Global Forecast System (GFS) -> GFS One Degree – 
Global Coverage -> GFS One Degree Analysis -> Latest source. 
 

4. Display the MSL Pressure. 
 
a. In the Field Selector, select the 2D grid -> Mass -> MSLP (Eta model reduction) @ Mean sea level 

field. 
 

b. Select the Plan Views -> Color-Shaded Plan View Display. 
 

c. In the Times tab, use the dropdown to choose Use Selected, and select only one time.  This step is only 
needed with realtime data, as the local file contains only one timestep. 
 

d. Click Create Display. 
 

5. Adjust and inspect the display. 
 
a. From the Layer Controls tab of the Data Explorer, enable Shade Colors. 
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b. In the Main Display, disable View -> Show -> Wireframe Box. 
 

c. Use Right-Click+Drag to rotate the globe.  Also, the auto-rotate button ( ) in the navigation toolbar 
can automatically rotate the globe. 
 

d. Click on the blue Default Background Maps text in the Legend to get to the Layer Controls for the 
maps.  Do the following to make the map lines easier to see: 
 
Disable the checkbox for North & Central America. 
 
Disable the checkbox for World Political Boundaries. 
 
For World Coastlines, change the color to black and use the dropdown menu to change the line width 
from 1.0 to 2.0.  
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Transect and Map Panel 
 
1. Set up the display window there is only one tab containing a transect and a map. 

 
a. Remove all layers and data sources. 

 
b. From the Main Display window, select File -> New Display Tab -> Misc -> Transect And Map. 

 
c. Close any other previously-existing displays. 

 
2. Load the file <local path>/Data/Grid/GFS_CONUS_80km_20190903_1200.grib1. 

 
a. In the Data Explorer, navigate to the Gridded Data -> Local chooser. 

 
b. Select the <local path>/Data/Grid/GFS_CONUS_80km_20230830_0000.grib1 file. 

 
c. Click Add Source. 

 
3. Add a display of wind speed data at the surface for the first timestep to the right map panel in the Main 

Display. 
 
a. In the Main Display, Left-Click in the right map panel to make it active. 

 
b. In the Fields panel Field Selector, select the 2D -> Derived -> Speed (*height_above_ground*) field. 

 
c. In the Displays panel, select Plan Views -> Color-Shaded Plan View. 

 
d. In the Times tab, change the dropdown to Use Selected and choose the first timestep only. 

 
e. Click Create Display. 

 
4. Add a vertical cross section of wind speed to the left transect panel in the Main Display window. 

 
a. In the Main Display, Left-Click in the left transect panel to make it active. 

 
b. In the Fields panel of the Field Selector, select the 3D -> Derived -> Speed field. 

 
c. In the Displays panel of the Field Selector, select Vertical Cross Sections -> Color-Filled Contour 

Cross Section. 
 

d. In the Times tab, change the dropdown to Use Selected and choose the first timestep only. 
 

e. Click Create Display. 
 

5. A vertical cross section of wind speed should now be shown in the left panel in the Main Display.  This 
cross section is drawn using the location of the transect line in the right map panel.  Change the location of 
this transect line so it crosses over Hurricanes Idalia and Franklin. 
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a. In the left transect panel of the Main Display, select the Transects -> Edit menu item.  This opens a 
Transect Drawing Control window. 
 

b. From the Controls tab of the Transect Drawing Control window, select the Create A Transect ( ) 
Mode option. 
 

c. In the right map panel in the Main Display, use Left-Click+Drag to draw a transect line that crosses 
over Hurricanes Idalia (west of Florida) and Franklin (off South Carolina coast).  At this point, you 
should notice that the left transect panel updates to showing a vertical cross section of wind speeds over 
the hurricane. 
 

6. The transect panel can overlay multiple parameters together at once.  For example, add a vertical cross 
section of relative humidity to the transect panel. 
 
a. Left-Click in the left transect panel of the Main Display to make it active. 

 
b. From the Fields panel of the Field Selector, select the 3D grid -> Relative humidity @ Isobaric surface 

field. 
 

c. From the Displays panel, select Vertical Cross Sections -> Contour Cross Section. 
 

d. Verify that only the first time is selected in the Times tab. 
 

e. Click Create Display. 
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Creating a Derived Field 
 
1. Create a new, one-paneled map display and close any previously-existing displays. 

 
2. If using the same local data source from the previous example, continue to step 3.  Otherwise, add a remote 

GFS 80 km CONUS data source. 
 
a. In the Data Sources tab of the Data Explorer, navigate to the Gridded Data -> Remote chooser. 

 
b. Select Realtime Data -> NCEP Model Data -> Global Forecast System (GFS) -> GFS-CONUS 80km 

-> Latest. 
 

c. Click Add Source. 
 

3. Inspect the 2D native and derived fields. 
 
a. Expand the 2D grid tree, and all of the fields listed directly under 2D grid are native fields, or fields 

included with the data. 
 

b. Expand the 2D grid -> Derived tree to see all of the derived fields.  These derived fields are created by 
formulas.  The majority of the formulas from these derived fields can be found by right-clicking on 
Formulas in the Field Selector and navigating to Edit Formulas -> Derived Quantities. 
 

4. Create a new derived quantity to inspect the difference between Pressure and MSLP. 
 
a. In the Field Selector, right-click on Formulas and select Create Formula. 

 
b. At the top of the Formula Editor window, enter the following: 

 
i. Description: MSLP – pressure (from %N1% & %N2%) 

(1) This is how the derived field will list in the Field Selector.  The ‘N1’ and ‘N2’ will allow for the 
name of the derived field to include the names of the two fields that it was derived from: MSLP 
– pressure (from Pressure_reduced_to_MSL_msl & Pressure_surface) 
 

ii. Name: pdiff 
(1) This is how the derived field can be referred to in a parameter default 

 
iii. Formula: sub(D1, D2) 

(1) This is the actual formula.  D1 and D2 are used as placeholders for the two fields to be operated 
on.  These fields will be defined in step 4d. 
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c. Expand Advanced. 
 

d. In the Derived tab, do the following: 
 
i. Uncheck For end user and check Create derived quantities. 

 
(1) Unchecking For end user keeps the formula from being listed out with the rest of the formulas 

in the Field Selector.  Checking Create derived quantities creates a derived quantity (field) 
from this formula. 
 

(2) In the Parameters menu, Right-Click in the text box, navigate through the menu tree to select the 
Pressure_reduced_to_MSL_msl field, type a comma ( , ), and Right-Click again to choose the 
Pressure_surface field.  These fields are the D1 and D2 specified in the formula (step 4b iii 
above). 
 

(3) The Categories menu here doesn’t have to be used since specific field names are being selected.  
If we were using an alias, such as PRESSURE, then this Categories menu could be used to tell 
McIDAS-V to only look for 2D gridded pressure fields by entering GRID-2D-*. 
 

e. Click Add Formula. 
 

5. Investigate the placement of the derived field in the Field Selector and move it under the 2D grid -> Derived 
tree. 
 
a. In the Field Selector, Right-Click on the GFS CONUS 80km data source and select Reload Data.  Once 

this is done, the data source will be re-loaded and the new formula created earlier will generate a derived 
quantity.  Note that this derived quantity is listed at the bottom of the Fields panel, and not under 2D 
grid -> Derived like the other 2D derived formulas (with remote data). 
 

b. Move this new derived field to under 2D grid -> derived by editing the formula.  To do this, Right-Click 
on Formulas in the Field Selector and select Edit Formulas -> Derived Quantities -> MSLP – 
pressure. 
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c. In the Derived tab at the bottom of the Formula Editor window, click the Define Output Categories 
button. 
 

d. This Define Output Categories window allows for specifying where this derived field should be listed.  
To get this field to list under 2D grid -> Derived, select Use Data, choose All for Operand, choose All 
for Category, then enter Derived for Append. 

 
 

- The Operand dropdown refers to which operand in the formula (D1 and D2) will be used.  
This could be useful, for example, if the operands in the formula were from different categories 
such as a 2D and a 3D grid.  Both of these grids are 2D so All can be used. 
 
- The Category dropdown refers to which categories were defined when creating the formula.  In 
this case, no categories were defined since specific field names were used.  This could be used if 
an alias was used in the Parameters menu when creating the formula.  For example, if TEMP 
(temperature) was specified as the alias, then there could be multiple categories (2D grid and 3D 
grid).  This Category dropdown could then be used to say if you are putting the derived field 
under the 2D or 3D tree in the Field Selector. 
 
- The Append menu informs McIDAS-V which menu tree (under the category tree) to place the 
derived field.  In this case, the field is put under a tree called Derived which is under the 2D grid 
tree (the tree where the MSLP and surface pressure fields are). 
 

e. Click OK to close the Define Output Categories window. 
 

f. Click Change Formula save the formula and close the Formula Editor window. 
 

g. Reload the data again using the method from 5a and now the derived field will list under 2D grid -> 
Derived. 
 

6. Display the data to see the difference between MSLP and surface pressure. 
 
a. In the Field Selector, choose the 2D grid -> Derived -> MSLP – pressure field.  Select the Plan Views -

> Contour Plan View and the first 5 times.  Click Create Display. 
 

b. Probe the display with the middle mouse button to see the pressure difference in Pascals.  Change the 
display to hPa by going to the Layer Controls for the layer and selecting Edit -> Change Display Unit.  
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In this Change Unit window, use the dropdown to select hPa.  Click OK. 
 

7. It is possible to create a parameter default so hPa would be used as the display unit by when the display is 
created.  This can be done by creating a parameter default. 
 
a. In the Main Display, select Tools -> Parameters -> Defaults. 

 
b. From the User Defaults tab, select File -> New Row.  In the Parameter menu, enter pdiff.  This pdiff 

was defined in 4b ii as the name associated with the formula.  Enter a Range of -10 to 350 (or whatever 
range you think is suitable for the data).  For Unit, use the dropdown to select hPa.  Click OK. 
 

 
 

c. In the Main Display, create a new tab and then re-display the derived MSLP – pressure field.  Note that 
the display unit and enhancement range specified in the parameter default are used to display the data. 
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Creating a Plugin 
 
1. Remove all layers and data sources from the previous displays.  Create a new, one-paneled map display and 

close any previously-existing displays. 
 

2. Add a new NWS CWA map. 
 
a. From the Main Display window, click on the blue Default Background Maps text in the Legend to get 

to the Layer Controls for the map lines. 
 

b. From the Layer Controls tab of the Data Explorer, select Edit -> Add Your Own Map. 
 

c. Click the Browse button next to Map file or URL. 
 

d. Select the <local path>/Data/Generic/MapLines/w_08mr23.shp file and click Open. 
 

e. For Name, enter NWS CWA. 
 

f. Click OK. 
 

3. Set McIDAS-V to default to drawing the NWS CWA maps in tabs made in the future. 
 
a. In the Layer Controls tab of the Data Explorer, select File -> Default Maps -> Save as the Default 

Map Set. 
 

b. Create a new, one paneled-map display in the Main Display window, and the NWS CWA map will be 
drawn. 
 

4. Create a plugin that contains these map lines. 
 
a. From the Main Display Window, select Tools -> Plugins -> Create. 

 
b. From the Plugin Creator window, select File -> Add File. 

 
c. From the Open window, select the maps.xml file and click Open. 

 
d. From the Plugin Creator window, click the Browse button. 

 
e. From the Save window, navigate to the directory where you want to write the plugin, and enter a name 

such as nws_cwa_map_lines.  Click Save. 
 

f. From the Plugin Creator window, click Write Plugin. 
 

5. This plugin can now be passed around to other users.  To install the plugin, the user would: 
 
a. Select Tools -> Plugins -> Manage from the Main Display. 
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b. From the Plugin Manager, select File -> Install Plugin From File. 
 

c. Select the nws_cwa_map_lines.jar plugin and click Open. 
 

d. Restart McIDAS-V. 
 

6. For now, we will remove these CWA map lines so they no longer appear in all new display panels. 
 
a. From the Layer Controls of the map lines, click the Remove The Map ( ) button next to NWS CWA. 

 
b. Select File -> Default Maps -> Save as the Default Map Set. 

 
c. Create a new tab, and the NWS CWA map lines will not be drawn. 
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Using NcML Aggregation 
 
When working with local netCDF files that contain one timestep per file, to display a loop the easiest way is to 
merge the data from all of the files into one data source.  Generally, this can be done through the Gridded Data -
> Local or General -> Files/Directories chooser by selecting the Aggregate Grids By Time option in the Data 
Type dropdown menu.  This data type uses the “time” dimension of each file to merge them together into one 
data source.  However, not all files contain a “time” dimension, which means that Aggregate Grids By Time 
isn’t an option.  For example, ABI netCDF files don’t contain a “time” dimension.  In this case, NcML can be 
used to create a wrapper file that can specify how the time is defined for each file.  Specifically, in this case, the 
date/time information is extracted from the file names. 
 
1. Remove all layers and data sources, create a new one-paneled map display, and close any previously-

existing tabs. 
 

2. Load a single GOES-16 mesoscale-1 sector netCDF file as a gridded data source. 
 
a. From the Data Sources tab of the Data Explorer, navigate to the General -> Files/Directories chooser. 

 
b. Navigate to the <local path>/Data/Satellite/ABI_data directory. 

 
c. Select the first OR_ABI_L1b file in the listing. 

 
d. Click Add Source. 

 
3. Verify that no time dimension exists in the data. 

 
a. From the Field Selector tab of the Data Explorer, Right-Click on the OR_ABI-L1b data source and 

choose Properties. 
 

b. From the Properties window, open the Metadata tab. 
 

c. This Metadata tab gives an “ncdump –h” output of the file, providing information about the structure of 
the data.  Scroll to the top of this tab to see where the dimensions are defined and note that no “time” 
dimension is listed. 
 

4. Load and display a loop of data from the NcML file. 
 
a. From the General -> Files/Directories chooser, select the meso_aggregate.ncml file. 

 
b. Click Add Source. 

 
c. From the Fields panel of the Field Selector, select 2D grid -> ABI L1b Radiances. 

 
d. From the Displays panel, select Imagery -> Image Display. 
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e. Note that the Times tab lists 10 times, which matches the number of netCDF files in the data directory.  
Click Add Source. 
 

5. Inspect the display in the Main Display window.  The data is displayed at the native resolution of GOES-16 
band 2 ABI data (0.5km).  The Time Animation Widget can be used to play through the loop. 
 

6. This scene is from shortly after sunrise and the display is relatively dark.  To brighten the display, Right-
Click on the enhancement in the Legend and select Change Range.  Enter a new range of 0 to 200 and click 
OK. 

 
The text of this NcML file is: 
 
<netcdf xmlns="http://www.unidata.ucar.edu/namespaces/netcdf/ncml-2.2"> 
  <aggregation dimName="time" type="joinNew"> 
    <variableAgg name="Rad"/> 
    <variableAgg name="DQF"/> 
    <remove name="t" type="variable"/> 
    <scan location="" dateFormatMark="OR_ABI-L1b-RadM1-M6C02_G16_s#yyyydddHHmmss" 
suffix=".nc" subdirs="false"/> 
  </aggregation> 
</netcdf> 
 
The key part in this file is the “scan location” line, where dateFormatMark is used to specify which characters in 
the filename. 
 
Additional information about NcML aggregation can be found here: 
 
https://docs.unidata.ucar.edu/tds/current/adminguide/tutorial/NcMLAggExamples.html 
 
Note that NcML can also be used to fix netCDF files that aren’t CF-Compliant.  If a user tries to load a non-
compliant netCDF file, an Non-Compliant NetCDF Widget tool will appear.  Once this happens, the user can 
run their file through an online CF-Compliance checker, such as: 
 
https://compliance.ioos.us/index.html 
 
Once it has been determined what is wrong with the file, NcML can be written to make corrections to the file.  
This could include removing or editing variables or attributes (variable and global).  A good resource giving 
examples of how this can be done is here: 
 
https://docs.unidata.ucar.edu/thredds/ncml/2.2/ncml_cookbook.html 
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Scripting Introduction 
 
Python vs. Jython 

 

Fact: You will do all of your McIDAS-V programming in the Python programming language. 

Fact: McIDAS-V uses an implementation of the Python programming language called Jython. 

Fact: The original and most widely used implementation of the Python programming language is not Jython; the 
full and proper name for that one is actually CPython.  (In case you're wondering, Jython is implemented in 
Java, and CPython is implemented in C!).  In day-to-day usage, CPython is often referred to as just “Python.” 

What does all that mean? 

As you learn McIDAS-V scripting, you should know that all the documentation you'll find across the web for 
the Python programming language (specifically, version 2.7) is relevant and accurate.  Jython is very careful to 
retain compatibility with the Python language.  This includes almost the entire Python standard library, which is 
why we have access to the functions we need to import, like glob and basename. 

However, the most important distinction between Jython and CPython is the availability of libraries.  Because 
Jython is Java-based, we do not generally get to use the Python libraries that depend on "native" code.  As a 
result, there is a large list of libraries we cannot use in Jython, including: 

• Scipy 
• NumPy 
• matplotlib 
• netcdf4-python 
• h5py 

 
Once you are comfortable with the basics of the Python programming language, the remainder of learning 
McIDAS-V scripting is largely about learning the "McIDAS-V way of doing things": instead of NumPy, 
matplotlib, and netcdf4-python, we will use the VisAD data model, VisAD displays, and NetCDF-Java to get 
our work done. 

In summary, Jython's language and standard library are the same as CPython, but many non-standard Python 
libraries such as NumPy are not available in Jython.  However, McIDAS-V has good alternatives for data 
access, plotting, and numerical computation. 

For more information about McIDAS-V scripting functions, please see the User’s Guide and the McIDAS-V 
scripting and advanced scripting tutorials available online.
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Jython Shell Scripting 
 
The Jython Shell consists of an output window on top and an input field on the bottom.  The user enters Jython 
into the input field.  When the Enter key or "Evaluate" is pressed, the Jython input is evaluated and output is 
shown in the output window.  The Jython Shell is a great tool to begin writing scripts that can be run from the 
background.  When inputting commands, the Jython Shell runs in single or multi-line mode.  You can switch 
modes by using the double down arrows or with the shortcut Ctrl+/.  The Evaluate button also has a shortcut of 
Shift+Enter. 
 
Here is a chart containing keyboard shortcuts for the Jython Shell: 

Enter Evaluate command in single-line input mode 
Shift+Enter Evaluate command in single or multi-line input mode 
Ctrl+/ Switch between single and multi-line input modes 
Ctrl+p Recall a previously evaluated command 
Ctrl+n Recall the next run command, assuming Ctrl+p was already used 
 

 

 
 

1. Using the Jython Shell, create a window with a single panel Map Display. 
 
a. From the Main Display window, select Tools -> Formulas -> Jython Shell to open the Jython Shell. 

 
b. In the input field of the Jython Shell, type: 

 
panel = buildWindow() 
 

c. Click Evaluate. 
 
buildWindow() is the function used to create an object that contains an array of panels.  This created 
a window, just as you would through the GUI with File -> New Display Window -> Map Display -> 
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One Panel. 
 

2. Now, create another window, this time with a globe display. 
 
a. In the input field of the Jython Shell, type: 

 
globePanel = buildWindow(height=600, width=600, panelTypes=GLOBE) 
 

b. Click Evaluate. 
 
Now, there are two single-paneled displays, each of which can be modified. 
 

3. Turn off the wireframe box in the map display window. 
 
a. In the input field of the Jython Shell, type: 

 
panel[0].setWireframe(False) 
 

b. Click Evaluate. 
 
The “[0]” is needed because each window contains a list of panels, and “0” operates on the first one. 
 

4. Enable auto-rotation in the globe display window. 
 
a. In the input field of the Jython Shell, type: 

 
globePanel[0].setAutoRotate(True) 
 

b. Click Evaluate. 
 

5. Close the two display windows created in steps 1 and 2 above. 
 
Basic Jython Terminology 
 
Three important terms are: function, method and object.  In the most general terms, an object is returned from a 
function and a method operates on an object and may return a new object. 
 
In steps 1 and 2, the buildWindow() function was used to create an object, in this case an array of panels.  
Objects can have one or more attributes and these attributes are defined by a class. Methods are used to operate 
on an object.  In step 3, setWireframe() operated on the panel object by turning off the wireframe box.  
 
The word object can be intimidating because it hints at the topic of object-oriented programming, which can be 
complex and confusing.  However, as McIDAS-V programmers, we just need to know that an object is a special 
kind of variable that has functions associated with it.  These special kinds of functions are referred to as 
methods. 
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Display a Remote GOES-16 Image 
 
1. From the Jython Shell, click the Expand Input Field button to allow for multi-line input mode. 

 
2. Create a display of GOES-16 mesoscale-1 sector band 13 temperature data. 

 
a. In the input field of the Jython Shell, type: 

 
panel = buildWindow(height=450, width=800) 
 
addeParms = dict( 
    server = 'adde.ssec.wisc.edu', 
    dataset = 'EAST', 
    descriptor = 'CONUSC13', 
    unit = 'TEMP', 
    size = 'ALL', 
    ) 
 
data = loadADDEImage(**addeParms) 
 
layer = panel[0].createLayer('Image Display', data) 
 

b. Click Evaluate. 
 
As an alternative to typing the above, you can open the <local path>/Data/Scripts/image_display.py 
script in a text editor, and copy/paste its contents into the input field.  Note the 4-space indentation is 
necessary in the addeParms dictionary. 
 

c. Description of the above script: 
 
• panel = buildWindow() 

This function builds a window, as was demonstrated previously 
 

• addeParms 
This is a Python dictionary that contains keys and values matching keywords that the 
loadADDEImage() function accepts.  These keywords are used to define the server where the 
data is being pulled from, along with the dataset and descriptor names.  The display unit and size of 
the image are also defined here. 
 

• data = loadADDEImage() 
This function creates a data object using the keys/values defined in the addeParms dictionary. 
 

• layer = 
This function adds a data layer to the display window created at the beginning of the script 
 



Page 86 of 94 
 

McIDAS-V Tutorial – Basic and Advanced Training                                                               September 2023 – McIDAS-V version 1.9 

• Note that the documentation of the McIDAS-V scripting functions (buildWindow(), 
loadADDEImage(), createLayer(), and subsequent commands) can be found in the 
McIDAS-V User’s Guide. 
 

3. Change the enhancement of the displayed layer. 
 
a. In the input field of the Jython Shell, type: 

 
layer.setEnhancement('ABI IR Temperature') 
 

b. Click Evaluate. 
 

c. Description of the above command: 
 
• The McIDAS-V function setEnhancement() applies an enhancement to the layer object created 

by createLayer() from the script run previously.  This command accepts a string of an 
enhancement name. 
 

4. Add a color scale to the displayed layer. 
 
a. In the input field of the Jython Shell, type: 

 
layer.setColorScale(placement='Left', size=20, showUnit=True) 
 

b. Click Evaluate. 
 

c. Description of the above command: 
 
• The McIDAS-V function setColorScale() adds a color scale associated with the layer object 

created by createLayer() from the script run previously to the display.  This command accepts a 
string for the placement of the color scale, the font, style, color, and size of the label text, and 
True/False for if the display unit should be added to the color scale. 
 

5. Capture an image of the display. 
 
a. In the input field of the Jython Shell, type: 

 
panel[0].captureImage('<local-path>/JythonShellTest.jpg') 
 

b. Note that you should substitute “<local-path>” with a directory location on your machine that you have 
access to.  Click Evaluate. 
 

c. Description of the above command: 
 
• The McIDAS-V function captureImage() captures an image of the display panel returned from 

the buildWindow() function from the script run previously. 
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d. Outside of McIDAS-V, use a software, such as a browser, to view the image captured. 
 

6. Along with displaying data and enhancing displays, McIDAS-V offers a wide variety of functionality to 
analyze the data quantitatively.  Determine statistical information about the data. 
 
a. In the input field of the Jython Shell, type: 

 
print(describe(data)) 
 

b. Click Evaluate. 
 

c. Description of the above command: 
 
• The McIDAS-V function describe() accepts a data object.  Here, we are passing through “data”, 

which is the data object that was returned from loadADDEImage() in the script run previously. 
 

• One thing to note is that there are off-Earth pixels in the upper left corner of the domain in the 
display.  These pixels are assigned a value of 0 which are included in the statistics as the “Min” 
value is 0.00.  These 0.00 values are used in the calculation of all of the statistical values in the 
output. 
 

 
 

7. Compute the statistics of the data without including the 0.00 values. 
 
a. While McIDAS-V does not have access to many libraries such as numpy and scipy, there are a variety of 

JPythonMethods that have similar functionality to operate on arrays.  Information about JPythonMethods 
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can be found here: 
 
https://www.ssec.wisc.edu/visad-docs/javadoc/visad/python/JPythonMethods.html 
 
One of the functions is called setToMissing(), which will replace a numerical value in a data object with 
a missing value (Float.NaN). 
 
In the input field of the Jython Shell, type: 
 
missData = setToMissing(data, 0) 
 

b. Click Evaluate. 
 

c. Description of the above command: 
 
• The JPythonMethod function setToMissing() accepts the data object returned previously from 

loadADDEImage() as well as the value that should be set to missing, which is 0 in this case.  The 
output of this function is in a data object called “missData”. 
 

d. Print the statistical information from this new missData data object. 
 
In the input field of the Jython Shell, type: 
 
print(describe(missData)) 
 

e. Click Evaluate. 
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8. Use the listADDEImages() function to return the metadata of the data object. 
 
a. In the input field of the Jython Shell, evaluate: 

 
dirList = listADDEImages(**addeParms) 
 

b. Use Python’s looping functionality to print the metadata information to the Jython Shell. 
 
In the input field of the Jython Shell, evaluate: 
 
for x in dirList: 
    for key, value in x.iteritems(): 
        print key, value 

 
c. Print the value of the nominal-time key from the data object returned from loadADDEImage() above: 

 
In the input field of the Jython Shell, evaluate: 
 
print(data['nominal-time']) 

 
d. Save an image of the display and name it with the value returned from the nominal-time key with the 

spaces replaced by an underscore: 
 
In the input field of the Jython Shell, evaluate: 
 
dataTime = data['nominal-time'] 
 
Return the type of the dataTime data object.  In the input field of the Jython Shell, evaluate: 
 
type(dataTime) 
 
This says that that the data type is type “visad.DateTime”.  This must be a string in order to be passed 
through the captureImage() function.  In the input field of the Jython Shell, evaluate: 
 
dataTimeStr = str(dataTime) 
 
Verify that this is a string.  In the input field of the Jython Shell, evaluate: 
 
type(dataTimeStr) 
 
This says that the data type is type “str”.  Print the value of the dataTimeStr data object.  In the input 
field of the Jython Shell, evaluate: 
 
print(dataTimeStr) 
 
This may return a value such as “2023-09-18 14:56:17 UTC”.  In order to properly save the image, 
remove the colons and replace the spaces with an underscore.  In the input field of the Jython Shell, 
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evaluate: 
 
dataTimeStr2 = dataTimeStr.replace(':','').replace(' ','_') 
 
Verify that the string is now correct.  In the input field of the Jython Shell, evaluate: 
 
print dataTimeStr2 
 
This may return a value such as “2023-09-18_145617_UTC”.  Use this string as a file name in 
captureImage().  In the input field of the Jython Shell, evaluate: 
 
panel[0].captureImage('<local-path>/%s.jpg' % dataTimeStr2) 
 
Outside of McIDAS-V, use a software, such as a browser, to view the image captured. 



Page 91 of 94 
 

McIDAS-V Tutorial – Basic and Advanced Training                                                               September 2023 – McIDAS-V version 1.9 

Display a Loop of GOES-16 Data 
 
1. From the Jython Shell, click the Expand Input Field button to allow for multi-line input mode. 

 
2. Create a display of GOES-16 mesoscale-1 sector band 13 temperature data. 

 
a. In the input field of the Jython Shell, type: 

 
panel = buildWindow(height=450, width=800) 
 
satLoop = [] 
 
addeParms = dict( 
    server = 'adde.ssec.wisc.edu', 
    dataset = 'EAST', 
    descriptor = 'CONUSC13', 
    unit = 'TEMP', 
    size = 'ALL', 
    ) 
 
for x in range(-10, 0): 
 
    data = loadADDEImage(position=x, **addeParms) 
    satLoop.append(data) 
 
layer = panel[0].createLayer('Image Sequence Display', satLoop) 
 

b. Click Evaluate. 
 
As an alternative to typing the above, you can open the <local path>/Data/Scripts/image_loop.py script 
in a text editor, and copy/paste its contents into the input field.  Note the 4-space indentation is necessary 
in the addeParms dictionary. 
 

c. Description of the above script: 
 
• panel = buildWindow() 

This function builds a window, as was demonstrated previously 
 

• satLoop 
Initializes an empty list for the data objects returned from loadADDEImage() to be added to 
 

• addeParms 
This is a Python dictionary that contains keys and values matching keywords that the 
loadADDEImage() function accepts.  These keywords are used to define the server where the 
data is being pulled from, along with the dataset and descriptor names.  The display unit and size of 
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the image are also defined here. 
 

• for x in range(-10, 0): 
Sets up a loop of relative position numbers to step through.  The “x” variable is used to specify the 
position number to load in each loadADDEImage() call. 
 

• data = loadADDEImage() 
This function creates a data object using the keys/values defined in the addeParms dictionary 
along with the position number. 
 

• layer = 
This function adds a data layer to the display window created at the beginning of the script.  Note 
that when displaying a loop of satellite data, “Image Sequence Display” must be specified as the 
display type in createLayer() instead of “Image Display” which is used with a single timestep. 
 

3. Capture an animation of the display. 
 
a. In the input field of the Jython Shell, type: 

 
writeMovie('<local-path>/JythonShellTest.mp4') 
 

b. Note that you should substitute “<local-path>” with a directory location on your machine that you have 
access to.  Click Evaluate. 
 

c. Description of the above command: 
 
• The McIDAS-V function writeMovie() captures an animation of the display 

 
4. Outside of McIDAS-V, use a software, such as Windows Media Player, to view the animation captured. 
 
 
Exercise 
 
1. Load the most recent GOES-16 CONUS sector band 12 and 15 temperature data with 

loadADDEImage(). 
 

2. Use McIDAS-V’s sub() function to subtract band 12 temperatures from the band 15 temperatures. 
 

3. Build a window and display the data object returned from sub(). 
 

4. McIDAS-V will use the parameter default enhancement range for IR temperature data.  Use the 
JPythonMethod getMinMax() to obtain the min/max temperature values in the data object returned from 
sub() and apply these values to the displayed layer with setEnhancement().  The default “Inverse 
Gray shade” enhancement can be used, or you can specify another enhancement packaged with McIDAS-V. 
 
A sample solution can be found in <local path>/Data/Scripts/example_solution.py 
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Background Scripting 
 
1. Exit McIDAS-V. 

 
2. Using a text editor, edit the <local path>/Data/Scripts/sandwich_example.py script.  The last line in the 

script is the captureImage() command.  In this command, change “local_path” to a directory location 
on your machine that you have write access to.  Save the script. 
 

3. From a Terminal or Command Prompt window, cd to your McIDAS-V-System, which should be located in 
the directory where McIDAS-V was installed. 
 

4. From the Terminal or Command window, run the script using the “-script” flag.  Note that you should 
substitute “local_path” with the location of the script on your machine.  Run the command below matching 
your operating system: 
 
On Windows: 
runMcV.bat –script /local_path/sandwich_example.py 
 
On Linux: 
runMcV –script /local_path/sandwich_example.py 
 
On macOS: 
./runMcV –script /local_path/sandwich_example.py 
 

5. Once the script has completed, use a software, such as an internet browser, to view the captured image. 
 

6. Description of the script: 
 
a. addeParms: 

Dictionary to pass through loadADDEImage().  Two bands are loaded, and the keys/values in this 
dictionary apply to both bands. 
 

b. b3Data/b13Data = loadADDEImage: 
loadADDEImage() commands for band 3 and band 13 data.  A few keywords specific to each band 
are specified, along with the addeParms dictionary 
 

c. rgbData = sandwich: 
Runs the sandwich function to generate a sandwich data source from the band 3 and band 13 data objects 
 

d. visLayer/rgbLayer: 
Individually display the visible and RGB (sandwich) data objects.  The RGB layer is then updated to 
lower the gamma value, making it brighter. 
 

e. panel[0].captureImage: 
Captures an image of the display window. 
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Zooming, Panning, and Rotating Controls 
 

Zooming Panning Rotating 
  Mouse  
Shift-Left Drag: Select a region 
by pressing the Shift key and 
dragging the left mouse button. 
Shift-Right Drag: Hold Shift key 
and drag the right mouse button. 
Moving up zooms in, moving 
down zooms out. 

Control-Right Mouse Drag: 
Hold Control key and drag right 
mouse to pan. 

Right Mouse Drag: Drag right 
mouse to rotate. 

 Scroll Wheel  
Scroll Wheel-Up: Zoom Out. 
Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-
Up/Down: Rotate 
clockwise/counterclockwise. 
Shift-Scroll Wheel-Up/Down: 
Rotate forward/backward 
clockwise. 

 Arrow Keys  
Shift-Up: Zoom In. 
Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 
Control-Down arrow: Pan Up. 
Control-Right arrow: Pan Left. 
Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 
around vertical axis. 
Up/Down arrow: Rotate 
around horizontal axis. 
Shift-Left/Right arrow: Rotate 
Clockwise/Counterclockwise. 

 


	1. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  Select adde.ssec.wisc.edu as the Server and EAST as the Dataset.  Click Connect.
	2. Select FD – GOES-East FullDisk all bands as the Image Type.
	3. In the Times panel, select the Relative tab.  For Number of times, enter 1 and click Add Source to create a data source of the most recent time.
	4. Display band 13 temperature data.
	a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the data.  Select the 10.3 um IR Surface & cloud -> Temperature field.
	b. From the Displays panel, select the Imagery -> Image Display display type.
	c. Select the Region tab to see a low-resolution preview image of the data.  Note that there is a green box drawn around the preview image.  Any data inside this bounding box will be displayed.
	d. Select the Advanced tab to see information about the band and calibration selected.  These values match the domain of the data selected in the Region tab, so it covers the entire domain of the data.  Notice that the Image Size is only 904 x 904 whe...
	i. Coordinate Type: Latitude/Longitude
	ii. Location: Center
	iii. Lat: 28; Lon: -83.5
	iv. Image Size: 400 x 400
	v. Magnification: 1 x 1
	e. Click Create Display.
	5. Investigate the display.
	a. In the Main Display window, practice navigating around in the display.  To do this, use Control+Right-Click+Drag to translate the display.  This shifts the data left/right and up/down without rotating the display.  Zoom in on the display by scrolli...
	b. Probe individual pixel values by holding down the middle mouse button over the display.  This will print out probe values at the bottom of the display.  Notice that latitude, longitude, and temperature values are included in the probe output.
	c. Navigate to the Histogram tab of the Layer Controls to see a histogram of band 13 temperature values.
	6. Add a data transect to the display.
	a. From the Field Selector tab of the Data Explorer, select the Data Transect display type and click Create Display.
	b. In the Main Display window, there is a red line that is referred to as the data transect.  The values along this transect line are output in the Layer Controls tab of the Data Explorer.  The two end points of the transect can be moved around by Lef...
	7. Create a display of the 10.3 μm temperatures so only values of 273K and less are plotted.
	a. Add a new two-paneled map display by selecting File -> New Display Tab -> Map Display -> Two Panels menu item.
	b. Left-Click in the left panel to make this panel active.  The active panel has a blue frame around it, and this is the panel any displays will be added to.
	c. In the Field Selector tab of the Data Explorer, select the 10.3 um IR Surface & cloud -> Temperature field.  Choose the Imagery -> Image Display display type and click Create Display.
	d. Create the cloud mask display.
	i. Left-Click in the right panel to make this panel active.  The active panel has a blue frame around it, and this is the panel any displays will be added to.
	ii. In the Field Selector tab of the Data Explorer, select Formulas.
	iii. Select the Imagery -> Mask Value formula, the Imagery -> Image Display display type, and click Create Display.
	iv. In the Select input window, enter the following and then click OK:
	1. comparison: <
	2. cutoff: 273
	3. useNaN: 1 Notes: The comparison is set to < or ‘less than’ since the goal is to display values less than 273, which was set as the cutoff value.  Setting useNaN to 1 makes it so that if the pixels were probed outside of the masked range (where valu...
	v. In the new Field Selector window, for inputFieldForMask, select 10.3 um IR Surface & cloud -> Temperature.  This is the field that is being masked.
	vi. For displayFieldToBeMasked, select 10.3 um IR Surface & cloud -> Temperature.  This is the field that will be displayed where the inputFieldForMask is less than 273 degrees.  In this case, we are displaying the same field that is being masked.
	vii. Click OK.
	e. Investigate the display.  Note that as one of the panels is navigated, the other will be navigated in the same way.  This is because by default panels in the same tab are set to share views.  This setting can be disabled in a panel by unchecking Pr...
	8. Create a display of a subtraction of two bands.
	a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item, or by clicking the Add new tab () button in the Main Toolbar.
	b. In the Field Selector tab of the Data Explorer, select Formulas.
	c. Select the Miscellaneous -> Simple difference a-b formula, the Imagery -> Image Display display type, and click Create Display.
	d. In the new Field Selector window, for a, select the 8.4 um IR Total WV cloud phase, dust -> Temperature field.  For field b, select the 7.3 um IR Lower-level WV, winds & SO2-> Temperature field.
	e. Click OK in the Field Selector window to display the band subtracted data.
	f. Right-Click on the colorbar of the ABI layer in the Legend and select the System -> Inverse Gray Scale enhancement.
	g. Add latitude and longitude labels to the display.
	i. Left-Click on the blue text for the Default Background Maps layer in the Legend to get to the Layer Controls tab of the Data Explorer for the layer.
	ii. From the Lat/Lon tab of the Layer Controls, set the following:
	1. Check the visibility checkboxes for Lines and Labels to plot them in the display.
	2. Lines: Interval: 5.0
	3. Labels: Interval: 5.0; At Longitudes: -85.0, At Latitudes: 30.0, Color: light blue
	4. Font: Arial; Bold; 20
	h. Investigate the display to see the latitude and longitude lines and labels.  Probe the data to see the temperature difference between the two bands.
	9. Capture an image of the display.
	a. From the Main Display, select the View -> Capture -> Image menu item.
	b. In the Save As text field, enter the name to give your image, for example: band_subtraction.gif.
	c. Use the dropdown below Save As to select the directory to save your image to.
	d. Under Capture What, select Current View.  This will capture an image of the display without including any other components of the Main Display such as menu items and the Legend.
	e. Click Save.
	f. View your saved image to verify the image was captured correctly.
	Accessing GOES-16 ABI Data from a Remote Server – 5 Timesteps
	1. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and Data Sources menu item from the Main Display.
	2. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item.  Close any previously-existing tabs.
	3. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  In the Relative tab of the Times panel, for Number of times, enter 5 and click Add Source.
	4. Display a loop of 10.3um Temperature data over Wisconsin and Illinois.
	a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the data.  Select the 10.3 um IR Surface & cloud -> Temperature field.
	b. From the Displays panel, select the Imagery -> Image Display display type.
	c. Navigate to the Advanced tab, and enter the following information:
	i. Coordinate Type: Latitude/Longitude
	ii. Location: Center
	iii. Lat: 42; Lon: -89.6
	iv. Image Size: 450 x 450
	v. Magnification: 1 x 1
	d. Click Create Display.
	5. Investigate the display.
	a. The Main Display now has a loop of the 5 most recent times of data in the FD dataset.  As done in step 5 in the previous section, navigate around and zoom in/out of the display.  Probe the display by holding down the middle mouse button over the da...
	b. Use the Time Animation Widget at the top of the display panel to play through a loop of the data.
	c. Click the Properties button () in the Time Animation Widget to modify settings of the animation including the dwell rate (the time spent on each frame in the animation).  As an example, set the Forward, First, and Last dwell rates to 0.2 and click ...
	6. Change the enhancement used in the display.
	a. Stop the animation by clicking the Stop Animation button in the Time Animation Widget ().
	b. Right-Click on the colorbar of the ABI layer in the Legend and select the Satellite -> GOES-R -> ABI IR Temperature enhancement.
	7. Add a color scale to the display.
	a. Right-Click on the ABI layer in the Legend and select Edit -> Properties.
	b.  In the Properties window, navigate to the Color Scale tab and set the following:
	i. Visible: Check this option to add the color scale to the display.
	ii. Position: Top.  This will position the color scale at the top of the display.
	iii. Labels -> Visible: Check this option to add numerical labels to the color scale.
	iv. Labels -> Show Unit: Check this to add the display unit to the color scale labels.
	v. Labels -> Font: Set the size to 26.
	c. Click OK.
	8. Create a Data Probe/Time Series display of band 13 temperature data.  This display type allows for plotting how temperature values at a specific location change through time throughout the loop.
	a. In the Field Selector tab of the Data Explorer, select the Data Probe/Time Series display type and click Create Display.
	b. The Layer Controls tab of the Data Explorer now shows a time series display of temperature values at the location of the probe in the Main Display.  Change the range of the y-axis (temperature values) to match the range of the data.
	i. At the bottom of the Layer Controls tab, Double-Click on the 186-Band13_TEMP parameter to open the Properties window.
	ii. In the Properties window, change the Range text boxes to a Min of 180 and a Max of 320 to match the range of the enhancement in the Main Display.
	iii. Click OK to apply the new range in the Layer Controls and close the Properties window.
	c. Move the data probe in the Main Display around with Left-Click+Drag.  The time series display in the Layer Controls automatically updates itself as the probe’s location changes.
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