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Introduction

 McIDAS-V is composed primarily of two windows,
the Main Display window and the Data Explorer
window.

 Main Display window — Where most displays appear

e Data Explorer window — What and how to display.
— Data Sources tab — Select the type of data
— Field Selector tab — Select the variable and display type

— Layer Controls tab — Modify the display




Main Display Window
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Data Explorer Window
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Data Explorer Window
Field Selector Tab
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Data Sources Window
Layer Controls Tab

U McIDAS-V - Data Explorer
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Example 1: Kanlaon Volcano
Steps to Create to Follow

NOAA21 Ash RGB
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Panel 1 — Ash RGB

* Load VIIRS data containing M14, M15, and M16
through the JPSS Chooser. In the Field Selector:

% McIDAS-V - Data Explorer

ey
il Data Sources Id Field Selector I & Layer Controls

Data Sources: Fields 4, | Displays
Formulas IMAGE Imagery
CONUS - GOES-East CONUS Imagery 3 Color (R

IRS 2025.04.08 05:08:19 JF'S_”S_ FL:CN-JHS (Under Development) 3
GG 1250408 VIIRS EDR t rTMage over topography
. L2 20 B Indices Omni Control
S5P_NRTI_LZ__ S02 2 RGBs

VIIRS EDR. Ash RGB 2.

VIIRS EDR Cloud Phase RGB
VIIRS EDR Day Cloud Phase Distinction M-Band RGB
VIIRS EDR Day Cloud Type RGB
VIIRS EDR Day Snow-Fog M-Band RGB
VIIRS EDR Dust RGB
VIIRS EDR Fire Temperature RGB
VIIRS EDR Matural Color M-Band RGB
VIIRS EDR NGFS Microphysics M-Band RGB
VIIRS EDR Mighttime Microphysics RGB
VIIRS EDR Snowmelt RGB
VIIRS EDR True Color RGB

VIIRS EDR Rayleigh Corrected
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Panel 2 — GEMS SO2

* Load GEMS data through the General>Files/
Dir chooser as a gridded data source. Field Selector:

% McIDAS-V - Data Explorer — O *
£
O Data Sources @ Field Selector i@ Layer Controls
Data Sources: Fields | show variables G, ‘| Displays
Formulas ¢ 2D grid o= Imagery -
COMNUS - GOES-East CONUS ¢ Data_Fields ¢ Plan Views H
VIRS 2025.04.08 05:08:19 G = DEta_F!-3|-L'S.-'.-"-‘-.EF-JS.-II|0|:3tIE:3|.DEpthl:.-"—\'.OD; Cantaur Plan View y
(:_, 3 £ Data_Fields/AlgorithmQualityFlag Colt ed-Con Plan View
GH2_GEMS_L2 20250408 1. & Data_Fields/AmfTotal bolor—Shaded Plan View| 3. -
S5P_NRTI_LZ2_SO2__ 2 £ Data_Fields/CloudFraction
- [ Regi Data Sampli
< Data_Fields/ColumnAmountO3 saien Sl
< Data_Fields/ColumnAmountS02 Use Default Region -
< Data_Fields/FinalAlgorithmFlags
£7 Data_Fields/Reflectivity

£ Data_Fields/SlantColumnAmountS02
o= Geolocation_]

Create Display 4.
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Panel 3 — TROPOMI SO2

* Load TROPOMI data through the General>Files/
Dir chooser as a gridded data source. Field Selector:

5 McIDAS-V - Data Explorer — O x

.L] Data Sources ( L@ Field Selector

P
(s —5

i@ Layer Controls

Data Sources: Fields show variables &,
Formulas ¢ 2D grid
CONUS - GOES-East CONUS ¢ PRODUCT

VIIRS 2025-04-08 05:08:19 G

GH2_GEMS_L2_20250408 _

¥S5P_NRTIL2_soz___ 3> | 1.

o= Derived
< data quality value
offset from reference start time of measurement
pixel center latitude
pixel center longitude

Pl
&7
&7
< precision of the 1

& PRODUCT SO2HAYER _HEIGHT
¢ PRODUCT_SUPPORT_DATA_DETAILED_RESULTS
o PRODUCT_SUPPORT_DATA_GEOLOCATIONS

o PRODUCT_SUPPORT_DATA_INPUT_DATA

4]

[ 3

Displays

o= Imagery
¢ Plan Views
Contour Plan View
Color-Filled Contour Plan View

lor-Shaded Plan View? 3,
Region Data Sampling

Use Default Region

N
e

Create Display 4.

Space Science and Engineering Center
University of Wisconsin-Madison

o



Add HYDRA2 Button to Main Display

 From the Main Display window, select Edit >

Preferences. Add HYDRA2 button to toolbar:
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1 Delete default layout

& Disable ADDE Debug Output
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) Edit display settings
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Edit parameter defaults
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(&) Edit projections
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& Enable ADDE Debug Output
€ Exit
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g Import formula
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@ Install plugin from URL
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-space-
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-space-
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-space-
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Start HYDRA2

 From the Main Display window, click the HYDRA2
button.

v McIDAS-V
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Load CrlS Data in HYDRA2

e Start HYDRA2. In the HYDRA Control Window, select
File>Files. Select file. Click Display

<% HYDRA Control Window
File Edit Tools Settings
Diatasets
1. CrlS SDR 2025-04-08 05:06
BrightnessTemperature
Combinations

Display
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Subtract 2 Channels to Show SOZ

* In the HYDRA display window,
choose Tools>Four Channel
Combine. Enter 1345.0-1325.0
and click Create. Channel
1345 is SO2 sensitive, 1325 is
not. Both channels are
similarly sensitive to water
vVapor.

[ <# FourChannelCombine — O Y

(EE [ EE ) [ 0] —
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Display Channel Subtracted Data

* Inthe HYDRA Control Window, display the
Combination in a new window. The dark area circled
represents likely SO2 detection.

% HYDRA Control Window — O % &% Window 2 = 0O %
File Edit Tools Settings Tools Settings
Datasets

1: CrlS SDR 2025-04-08 05:06
BrightnessTemperature

Combinatic
oo TiazED |

s i B T B g meg £
Lon: 123.38 Lat: 5.54 Val: -3.26, 2025-04-08 05:06

v| 11:1345.0-1:1325.0
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Example 2: Tropical Cyclone Zelia
Steps to Create to Follow

et

SNPP Rayleigh Corr
MIRS Water Vapor Profile
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Panel 1 — Rayleigh-Corrected RGB

* Load VIIRS data containing M3, M4, M5, and M15
through the JPSS Chooser. In the Field Selector:

U McIDAS-V - Data Explorer - O X

)

] Data Sources /_5 Field Selector | -’_‘yi Layer Controls
= ) e

Data Sources: Fields 4, | Displays
Formula IMAGE Imagery
} YIRS 2025-02-14 05:19:45 G Imagery 3 Color (RGB) Image
JPSS Functions (Under Development) JRCB Composite[r 3
= VIRS EDR 3 Color (RGB) Image over topography
VIIRS EDR Rayleigh Corrected Omni Contral

Indices
Individual Bands
RGBs

VIIRS EDR RC Cloud Phase RGB
VIIRS EDR RC Day Cloud Phase Distinction M-Band RGB Region
VIIRS EDR RC Day Cloud Type RGB .
VIIRS EDR RC Day Snow-Fog M-Band RGB
VIIRS EDR RC Matural Color M-Band RGB
VIIRS EDR RC Snowmelt RGB

VIRS EDR RC True Color RGE= 2,

Create Display | 4.
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Panel 1 — Water Vapor Profile

e Use the same VIIRS file from the RGB. In the Field
Selector (min/max=180/270; VIS=M4Rad; IR=M15T):

% McIDAS-V - Data Explorer — O x
Ij Data Sources @ Field Selector i/;:.‘\ Layer Controls

Data Sources: Fields 8 Displays
Formulas 1. CLAVRx Functions - Imagery

VIIRS 2025-02-14 05:19:45 G Image Filters 3 Color (RGA) Image

JP33 Functions (Under Development) RGB Co.mposite 3

VIRS EDR OTOTTRGE] Image over topography
Indices Omni Contraol
RGBs
VIIRS EDR Ash RGB
VIIRS EDR Blowing Snow RGB
VIIRS EDR Cloud Phase RGB
VIIRS EDR Day Cloud Phase Distinction I-Band RGB
VIIRS EDR Day Cloud Phase Distinction M-Band RGB
VIIRS EDR Day Cloud Type RGB
VIIRS EDR Day Fire RGB
VIIRS EDR Day Snow-Fog |-Band RGB
VIIRS EDR Day Snow-Fog M-Band RGB
VIIRS EDR Dust RGB
VIIRS EDR Fire Temperature RGB
VIIRS EDR Matural Color I-Band RGB
VIIRS EDR Matural Color M-Band RGB
VIIRS EDR NGFS Microphysics M and | Band RGB
VIIRS EDR NGFS Microphysics M-Band RGB
VIIRS EDR Nighttime Microphysics RGB
2.
VIIRS EDR Sea Spray RGB -

Create Display 4,
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Panel 2 — GEMS SO2

* Load GEMS data through the General>Files/
Dir chooser as a gridded data source. Field Selector:

% McIDAS-V - Data Explorer — O *
£
O Data Sources @ Field Selector i@ Layer Controls
Data Sources: Fields | show variables G, ‘| Displays
Formulas ¢ 2D grid o= Imagery -
COMNUS - GOES-East CONUS ¢ Data_Fields ¢ Plan Views H
VIRS 2025.04.08 05:08:19 G = DEta_F!-3|-L'S.-'.-"-‘-.EF-JS.-II|0|:3tIE:3|.DEpthl:.-"—\'.OD; Cantaur Plan View y
(:_, 3 £ Data_Fields/AlgorithmQualityFlag Colt ed-Con Plan View
GH2_GEMS_L2 20250408 1. & Data_Fields/AmfTotal bolor—Shaded Plan View| 3. -
S5P_NRTI_LZ2_SO2__ 2 £ Data_Fields/CloudFraction
- [ Regi Data Sampli
< Data_Fields/ColumnAmountO3 saien Sl
< Data_Fields/ColumnAmountS02 Use Default Region -
< Data_Fields/FinalAlgorithmFlags
£7 Data_Fields/Reflectivity

£ Data_Fields/SlantColumnAmountS02
o= Geolocation_]
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Start HYDRA2

 From the Main Display window, click the HYDRA2
button.

v McIDAS-V

File Edit Display Tools History Bundles Window Help
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Load CrlS Data in HYDRA2

e Start HYDRA2. In the HYDRA Control Window, select
File>Files. Select file. Click Display

<# HYDRA Control Window — O %
File Edit Tools Settings

Datasets

T
2. Crls SDR 2025-02-14 05:21 | © ¥
C'31+ 3 LT
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Convolve CrlS Bands

& Window 1 — O *

* |In the HYDRA display oo s s o |
. ‘ a 370

window, choose

|

Tools>Convolve. Enter
a range of 1517.5 to
1726.875 and click
Create. This range can
be used to simulate
ABIl upper-level water
vapor band 8.

+r Convolve — O >

1517.5 1726.875| Kernel Create Display
@ 1466.875 v [466.875)
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Display Convolved CrIS Data

* Inthe HYDRA Control Window, display the
Combination in a new window. After inverting the
enhancement, this looks like ABI band 8.

- .
& Window 2 - O X

% HYDRA Contrel Window _ 0O %

Tools Settings

File Edit Tools Settings

Datasets
2:CrlS SDR 2025-02-14 05:21
BrightnessTemperature

Combinatic
1517.5_1726.875TH > |,

28] 5 X
Lon: 121.63 Lat: -11.02 Val: 236.68,

range: |194.69 244272 Gamma: 1.0 reset Save e —
oY & vI(J1517.5_1726.875_TH| ) 4.
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Other New HYDRA2 Functionality

* |In the MultiSpectral display, probes can be added
over the highest and lowest pixel locations.

 The Transect Display is now possible than VIIRS data.
* Multi-variate transect displays are now possible.

e Scatter Analysis displays can be colored by density.

* Note —The goal is to have HYDRA2 replace the
existing HYDRA in McIDAS-V.




Example 3: Hurricane Milton GFS Data
Steps to Create to Follow

urricane Milton MSLP, 74mph Isosurface, Trajectories
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Layer 1 — MSLP

* Add forecast model data through the Gen>Files/Dir
or Gridded>Remote chooser. In the Field Selector:

<7 Geopotential height @ Maximum wind level

<7 Geopotential height @ Tropopause

<7 |CAQ Standard Atmosphere Reference Height @ Maximum wind level
L7 |CAD S p = eight @ Tropopause
MSLP (Eta model reduction) @ Mean sea level

round or water surface

&

<7 Pressure @ Ground or water surface
< Pressure @ Maximum wind level
<7 Pressure @ Specified height level above ground
<7 Pressure @ Tropopause
<7 Pressure of level from which parcel was lifted @ Level at specified pressure dif
<7 Pressure reduced to MSL @ Mean sea lavel
Maisture
Momentum
Physical atmospheric Properties
Soil Products

Tomamarobica

1 »

Create Display 3.

¥ McIDAS-V - Data Explorer - O ¥
N
il Data Sources @ Field Selector g g Layer Controls
Data Sources: Fields | show variables @, | Displays
Formulas 2D grid - Imagery -
¥ 10 files Cloud Image Display
Derived Scatter Analysis
Fire Weather Products Plan Views
Forecast Radar Imagery Contour Plan View
Ice Color-Filled Contour Plan View
Mass [Color-Shaded Plan Vie
<7 Geopotential height @ Cloud ceiling Value Plots -
<7 (Geopotential height @ Ground or water surface
<7 Geopotential height @ Highest tropospheric freezing level Times | Regicn Data Sampling
<7 Geopotential height @ Level of 0 °C isotherm Use Default -
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Layer 2 — 3D Grid Trajectory

e Display Grid 3D Trajectory data. In the Field Selector:

3 MCcIDAS-V - Data Explorer - O *
I
)| Data Sources @ Field Selector | | g Layer Controls
Data Sources: Fields | show variables @, ‘| Displays
Formulas ¢ 3D grid - 9 3D Grid Trajectory
¥ 10 files o Cloud B 30 Grid Trajectory™> 2.
o= Forecast Radar Imagery 3D Grid Streamline
o Mass 30 Grid Trajectory Colored by Speed
o= Maisture 3D Grid Streamline Colored by Speed
2 Momentum Trajectory Colored by Another Parameter
¢ Derived T Streamline Colored by Another Parameter
Jix) 3D Flow Vectors (from u-component_of_wind_isobaric & v-component_of_» Omni Control
Jfix) 3D Flow Vectors (from u-component_of_wind_isobaric & v-component_of_3
Jix) 30 True Wind Vectors (from u-component_of_wind_isobaric & v-componen [ Times [ Level | Region Data Sampling
Sfiw) 30 True Wind Vectors (from u-component_of_wind_isobaric & v-componen| Use Default -

Jfix) Absolute Vorticity (from u-component_of_wind_altitude_above_ms| &v-con| |
Jfix) Absolute Vorticity (from u-component_of_wind_height_above_ground & v-cq
Jfix) Absolute Vorticity (from u-component_of_wind_isobaric & v-component_of |
Jfix) Absolute Vorticity (from u-component_of_wind_potential_voricity_surface &
Jfix) AGeostrophic Horizontal Advection (from u-component_of_wind_isobaric, v
Jfix) AGeostrophic Wind (from u-component_of_wind_isobaric, v-component_of]
Jfix) AGeostrophic Wind Vectors (from u-component_of_wind_isobaric, v-compg
Jfix) Flow Vectors (from u-component_of_wind_altitude_above_masl & v-compon
Jfix) Flow Vectors (from u-component_of_wind_height_above_ground & v-comp
Jfix) Flow Vectors (from u-component_of_wind_isobaric & v-component_of_wing
Jfix) Flow Vectors (from u-component_of_wind_potential_vorticity_surface & v-cg
Jfix) Grid 20 Trajectory (from u-component_of_wind_altitude_above_ms| & v-col
Jfix) Grid 20 Trajectory (from u-component_of_wind_height_above_ground & v-g
Six) Grid 20 Trajectory (from u-component_of_wind_isobaric & v-component_of

Siw) Grid 2 f =TT e _of_wind_pote - ;_surface
1. Grid 3D Trajectory (from u-component_of_wind_isobaric & v-component, =
q Il | e 3

Create Display 3.
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Layer 2 — 3D Grid Trajectory

 Change some of the display characteristics. In the
Layer Controls:

E& 3D Grid Trajectory — O x

File Edit View Help

Trajectory Start Level: [ |100000 - : 1

Trajectory Initial Area: Points:

Controls

ClosePolygon:

Rectangle:

Initial Area SKip Factor: [0 (& 2]

Backward trajectory:

Create Trajectory 2 i

Trajectory Form: 3.
Length Offset: @-- 4

Color: S.

Line Width/Point Size: |1 = a]
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Layer 3 — Wind Speed Isosurface

e Display an isosurface of 3D wind speed data. In the
Field Selector:

U McIDAS-V - Data Explorer — O X

e

@) Data Sources @ Field Selector {{CW Layer Controls

Data Sources: Fields | show variables 4, ‘| Displays
Formulas fix) Grid 2D Trajectory (from u-component_of_wind_isobaric & v-component_of * 9 3D Surface o
» 10 files Fix) Grid 2D Trajectory (from u-component_of_wind_potential_vorticity_surface ¢ 2.
fix) Grid 3D Trajectory (from u-component_of_wind_isobaric & v-component_of |sosurface colored by another parameter
fix) Grid 3D Trajectory (from u-component_of_wind_isobaric & v-compaonent_of Contours Cver Topography
fix) Horizontal Advection (from u-component_of_wind_altitude_above_msl & v-{ Color-Filled Contours Over Topography
fix) Horizontal Advection (from u-component_of_wind_height_above_ground & Color-Shaded Image Over Topography
fix) Horizontal Advection (from u-component_of_wind_izobaric & v-component | Color-Shaded Parameter As Topography
fir) Horizontal Advection (from u-component_of_wind_potential_vorticity_surfag Contoured Parameter As Topography -
Jix) Horizontal Divergence (from u-component_of_wind_altitude_above_msl &¢
Jix) Horizontal Divergence (from u-component_of_wind_height_above_ground [ Times Lewvel Region Data Sampling
Jix) Horizontal Divergence (from u-component_of_wind_isobaric & '\-'-c-:nmp-:nner_ Use Default -

Jix) Horizontal Divergence (from u-component_of_wind_potential_vorticity_surf
Jix) Horizontal Flux Divergence (from u-component_of_wind_altitude_above_m
Jix) Horizontal Flux Divergence (from u-component_of_wind_height_above_gro
Jix) Horizontal Flux Divergence (from u-component_of_wind_isobaric & v-comp
Jix) Horizontal Flux Divergence (from u-component_of_wind_potential_vorticity_|
Jix) Relative Voricity (from u-component_of_wind_altitude_above_msl| & v-com
Jir) Relative Yoricity (from u-component_of_wind_height_above_ground & v-co
Jir) Relative Voricity (from u-component_of_wind_isobaric & v-component_of_y
Jix) Relative Voricity (from u-component_of_wind_potential_vorticity_surface &
Fir) Speed (from u-component_of_wind_altitude_above_ms| & v-compone nt_-J'_
Fix) Speed (from u-component_of wind_height_above ground & v-component)
1. @ponent_of_wind_isobaric & v-component_of_wind_is

fix) Speed (from u-component_of_wind_potental_vorficily_surface & v-compon
fix) True Wind vectors (from u-component_of_wind_altitude_above_msl| & v-col
fix) True Wind vectors (from u-component_of_wind_height_above_ground & v-g
Fix) True Wind vectors (from u-component_of_wind_isobaric & v-component_of] =

231 T = ik b mf el eombmedbisl o ekisibe meFe e

q] Ii |

Create Displa 3.
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Layer 3 — Wind Speed Isosurface

 Change some of the display characteristics. In the
Layer Controls Select Edit>Change Display Unit to set
the unit to mi/hr.

Color Table: Windspeed N J179 mithr
Edit Color Table

Smoothing: |None
g Change Range...

Isosurface Value: |74 mi/hr ce= | Use Default
1. Transparency F 0%
Dimmer 10%
Radar p| 20%
Satellite p|20% 0 2.
AWIPS »| 40%
System p| 20%

Miscellaneous »| 60%
Transparent  »| 70%
Basic p| BO%

Q0%

YRS 100%

/ ""r__::*-‘-‘ @ Space Science and Engineering Center
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Additional New Functionality in
McIDAS-V

More RGB and channel combos for different
instruments, including the NGFS RGB for VIIRS/ABI.

ProbSevere data can be displayed via local and
remote data.

Layer label updates to make things more consistent
and descriptive across data types.

New enhancements.
Ability to specify lat/lon corners of wireframe box.

Faster movie capturing.




Additional New Functionality in
McIDAS-V (Continued)

 Updated and improved location labels.

* Polling notifications — When new data is available a
popup window will appear letting the user know.

* Globe rotation is smoother, especially at low speeds.

* In scripting, ADDE Imagery can now be centered over
a station instead of a lat/lon or line/element point.

 Many other bug fixes and enhancements.




Nightly Build

 Much of the new functionality is currently in the
2.0betal nightly build. This is automatically created
every day with all of the previous day’s programming
changes, and therefore not everything has been fully
tested. To download the nightly, go to:

https://www.ssec.wisc.edu/mcidas/software/v/unstable/

* The username and password are both: mcv



https://www.ssec.wisc.edu/mcidas/software/v/unstable/
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