
McIDAS-V Tutorial 
Using and Creating Formulas 

updated November 2023 (software version 1.9) 
 

 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 

SSEC's 50-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 

(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 

manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 

Unidata's IDV libraries. The functionality of SSEC's HYDRA software package is also being integrated into 

McIDAS-V for viewing and analyzing hyperspectral satellite data. 

 

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 

McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 

the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 

https://www.ssec.wisc.edu/mcidas/software/v/.   

 

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 

Forums - https://mcidas.ssec.wisc.edu/forums/. The forums also provide the opportunity to share information 

with other users. 

 

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 

McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the 

document entitled McIDAS-V Tutorial – Installation and Introduction.   

 

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 

Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 

Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 

Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources). 

 

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).   

 

 

Introduction 
 

There are three methods of using formulas in McIDAS-V:  system formulas which are provided as part of the 

McIDAS-V software, user-defined formulas which can be created and executed from within McIDAS-V, and 

user-defined formulas which can be defined in Jython code written by the user.  This tutorial will cover the first 

two categories, those that can be created and used within McIDAS-V. 
 

 

 

 

https://www.ssec.wisc.edu/mcidas/software/v/
https://www.ssec.wisc.edu/mcidas/software/v/
https://www.ssec.wisc.edu/mcidas/software/v/
https://mcidas.ssec.wisc.edu/forums/
https://mcidas.ssec.wisc.edu/forums/
https://mcidas.ssec.wisc.edu/forums/
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System Formulas – Simple Subtraction 

 
1. Load the forecast data for Super Typhoon Megi. 

 

a. In the Data Sources tab of the Data Explorer, open the Gridded Data tree and select Local. 

 

b. Under Look in, individually add data sources for the following files: 

 

<local path>/Data/Formulas/TyphoonMegi/gfs_4_20101017_0000_000.grb2 

<local path>/Data/Formulas/TyphoonMegi/gfs_4_20101017_0000_024.grb2 

 

2. Use the Simple Difference formula to subtract the 0 hour forecast from the 24 hour forecast Pressures. 

 

a. In the Field Selector tab, select Formulas under Data Sources. 

 

b. Under Fields, open the Miscellaneous tree and select Simple difference a-b. 

 

c. Under Displays, open the Imagery tree and select Image Display. 

 

d. Click Create Display. 

 

e. In the new Field Selector window, select: 

 

 For Field: a, open and select the gfs_4_20101017_0000_024.grb2 -> 2D grid -> Mass -> Pressure 

reduced to MSL @ Mean sea level 

 

 For Field: b, open and select the gfs_4_20101017_0000_000.grb2 -> 2D grid -> Mass -> Pressure 

reduced to MSL @ Mean sea level 

 

f. Click OK to display the results of the Simple difference a-b formula. 

 

g. Zoom into the Philippines area. The darker region west southwest of the whiter region shows areas 

where pressure drops are forecasted. 

 

h. Drawing a line between the whiter and darker regions gives an indication of the predicted storm motion.  

To add a line, use the Display -> Add Range and Bearing menu item.  Left Click+Drag to move one 

end point over the white region and the other over the dark region.  The Distance will be reported in the 

Legend. 

 

System Formulas – Combining Multiple Formulas 
 

3. Remove all layers via the Edit -> Remove -> All Layers menu item in the Main Display. 

 

4. Add the forecast verification file for the 24 hour forecast: 

 

a. In the Data Sources tab, open the Gridded Data tree and select Local. 

 

b. Add a data source for the file <local path>/ Data/Formulas/TyphoonMegi/ 

gfs_4_20101018_0000_000.grb2. 
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5. Use the Simple Difference formula to subtract the verification grid (Oct 18 – 0Z, 0 hr) from the forecast grid 

(Oct 17 – 0Z, 24 hr).  

 

a. In the Field Selector, under Data Sources, select Formulas.  Under Fields, open the Miscellaneous 

tree and select Any Field.  Under Displays, open the 3D Surface tree and select Topography.  Click 

Create Display. 

 

b. Using the new Field Selector window, select Formulas -> Miscellaneous -> Simple difference a-b.  

Click OK. 

 

c. For Field: a, select gfs_4_20101017_0000_024.grb2 -> 3D -> Mass -> Geopotential height @ isobaric 

surface 

 

d. Click the Level tab and select 100,000 Pa. 

 

e. For Field: b, select gfs_4_20101018_0000_000.grb2 -> 3D -> Mass -> Geopotential height @ isobaric 

surface. 

 

f. Click the Level tab and select 100,000 Pa.  Click OK.    The display will use the (Forecast Grid – 

Verification Grid) equation for model verification. 

 

6. Change the range of the color table to enhance features on the display. 

 

a. From the Legend in the Main Display, Right Click on the color bar and select Change Range…. 

 

b. In the From: text box, enter -200, in the To: text box enter 200.  Click OK. 

 

7. The display now showing is a 2-dimensional display of the (Forecast Grid – 

Verification Grid) results.  However, recall that when the image was displayed, it was 

displayed as a 3D Topography surface.  By default, the vertical range of McIDAS-V 

displays is 0-16,000 m.  To view the data as topography, the vertical range will have to 

be changed to more closely match the range of the data.  In this example, change the 

vertical range to -100 to 100 m. 

 

a. From the tool icons on the left side of the Main Display window, click the Set the 

vertical range icon (shown in the figure to the right). 

 

b. Change the Min Value to -100, Max Value to 100 and Units to m.  Click OK. 

 

8. Sometimes when viewing 3-Dimensional data, the map becomes obscured by the data.  If the map is hidden, 

move the Map layer up, so it is visible on the image. 

 

a. From the Legend, Left Click on Default Background Maps. 

 

b. At the bottom of the Maps tab in the Layer Controls, change the Position slider to a value of 0.3. This 

will slide the map up in the Main Display. 

 

9. Navigate through the display in the Main Display window using Right Click+Drag to visualize the 3D 

characteristics of this topographic display. 
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System Formulas – Creating a Water Vapor Sea Surface Temperature Display 
 

10. Remove all layers and data sources via the Edit -> Remove -> All Layers and Data Sources menu item in 

the Main Display. 

 

11. Create local datasets for global SST, water vapor, IR, and land/sea mask images: 

 

a. From the Main Display menu, select Tools -> Manage ADDE Datasets. 

 

b. Select File -> New Local Dataset. 

 

i. For Dataset, enter GLOBAL.  For Image Type, enter SST.  For Format, verify McIDAS AREA is 

selected. 

 

ii. Click the Browse button, choose <local path>/ Data/Formulas/sea-surface-temperature, and click 

Open. 

 

iii. Click Add Dataset. 

 

c. Repeat step 11 b. for Water vapor. (GLOBAL, WV, <local path>/ Data/Formulas/global-wv).  Add 

Dataset. 

 

d. Repeat step 11 b. for Infrared. (GLOBAL, IR, <local path>/ Data/Formulas/global-ir).  Add Dataset. 

 

e. Repeat step 11 b. for Land-Sea-Mask.  (GLOBAL, Land-Sea-Mask, <local path>/ Data/Formulas 

/land-sea-mask).  Add Dataset. 

 

f. Click OK to close the ADDE Data Manager. 

 

12. Load your Big Blue Marble basemap using the Flat files chooser and display the image: 

 

a. From the Data Sources tab of the Data Explorer, open the General tree and select Flat files. 

 

b. Select <local path>/ Data/Formulas/basemap/blue-marble.jpg for the file to load. 

 

c. For Navigation, select Bounds.   Enter 90 for upper lat, -180 for upper lon, -90 for lower lat and 180 

for lower lon. 

 

d. Click Add Source, and from the Field Selector, click Create Display. 

 

13. Add your Sea Surface Temperature data source. 

 

a. From the Data Sources tab of the Data Explorer, open the Satellite tree and select Imagery. 

 

b. Select <LOCAL-DATA> as the Server. 

 

c. Select GLOBAL for the Dataset and click Connect. 

 

d. Select SST for the Image Type. 
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e. In the Absolute tab, select the 2010-10-20 00:00:00Z time, and click Add Source. 

 

14. Add your Land/Sea Mask data source. 

 

a. Using the Satellite -> Imagery chooser in the Data Sources tab of the Data Explorer, select Land-Sea-

Mask for the Image Type. 

 

b. Select the Absolute tab, select the 2009-07-30 18:00:00Z time, and click Add Source. 

 

15. Create a display of Sea Surface Temperatures over just water areas: 

 

a. In the Field Selector, select Formulas. 

 

b. Open the Image Filters tree, select Discriminate Image Filter, and click Create Display. 

 

c. From the Select input window, enter the following: 

 

brkpoint1: 0 

brkpoint2: 255 

brkpoint3: 8 

brkpoint4: 8 

replace: 0 

 

This formula applies a discriminate filter to two images by comparing elements in each image to 

different high and low breakpoints. Use this filter to mask off a portion of the first source image. 

Breakpoints 1 and 2 specify the range from the first dataset to be used, and break points 3 and 4 are 

for the second dataset.  In this example, values of 8 are used from the land/sea mask and represent 

water regions.  Keep stretch set to Contrast, and BT Min/MT Max set to 0/255. 

 

d. Click OK. 

 

e. To define image1 in the new Field Selector 

window, select SST -> Band: 1 -> Brightness. 

 

f. In the Advanced tab, make sure your fields are 

the same as they are in the image on the right. 

 Click the full size icon ( ).  

 Set the Coordinate Type to be Area 

Coordinates. 

 Set the Location to be Upper Left.  

 For Magnification, change Line Mag and 

Ele Mag values to -2.  

 

g. Repeat steps e and f to define image2 as Land-Sea-Mask -> Band: 1 -> Brightness.  Click OK to 

display the Land/Sea Mask image in the Main Display. 
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16. Change the color bar for the SST display and add some transparency to the color enhancement. 

 

a. From the Legend, Right Click on the color bar of the SST - Image Display and select  

System -> Temperature to change the color table.   

 

b. Right Click on the color bar again and select Edit Color Table. 

 

c. Right Click above the color bar, select Add Breakpoint -> At Data Point.  Enter a value of 2 and click 

OK (as seen in figure to the lower-left). 

 

d. From the Transparency drop down box, select a value of 100%. 

 

e. Right Click on the breakpoint you just created, select Edit Colors -> Transparency(100%) -> Left 

This sets transparency to 100% for all brightness values less than 2 (as seen in figure to the lower-right). 

 

f. Click OK to close the Color Table Editor. 

 

 
 

17. Create a display of the Water Vapor data. 

 

a. Using the Satellite -> Imagery chooser in the Data Sources tab of the Data Explorer, select  WV for the 

Image Type. 

 

b. In the Absolute tab, highlight the 2010-10-18 00:00:00Z time, and click Add Source. 

 

c. From the Field Selector, open the 6.8 um tree, select Brightness.  In the Advanced tab, click the green 

arrow button next to Image Size to get the full domain and resolution of the data and click Create 

Display. 
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18. Add transparency to the water vapor imagery.  Use the same techniques as found in step 16. 

 

a. From the Legend, Right Click on the color bar of the WV - Image Display and select Edit Color Table. 

 

b. Add a breakpoint at the 135 data point, set the transparency to 100% and fill to the left (Edit Colors -> 

Transparency -> Left). 

 

c. Create another breakpoint at 200 and set the transparency to 0%. Now interpolate the transparency to the 

left (Edit Colors -> Transparency -> Interpolate -> Left). 

 

d. Click OK to close the Color Table Editor.  

 
Creating your own Formulas – Simple Example  

 
19. Add your custom formula to McIDAS-V.   

 

a. From the Main Display, select Tools -> Formulas -> Create Formula. 

 

b. In the Description text box, enter:  GCD from 

WV and IR. 

This is how the formula will be shown in the list 

of formulas in the Field Selector. 

 

c. In the Name text box, enter: GCD 

This value will be shown when you mouse over 

the formula in the Field Selector and is also used 

for parameter defaults. 

 

d. In the Formula text box, enter:  

WaterVaporTemperature – InfraredTemperature 

Give your variables meaningful names.  These 

will be listed in the Field Selector. 

(Note:  No spaces are allowed in the variable 

names.) 

 

e. If the bottom Settings and Advanced tabs aren’t 

visible, click the arrows next to Advanced. 

 

f. In the Group text box enter:  Workshop 

You can create a tree structure of multiple groups – each of which can contain multiple formulas. This 

will be the name of the upper-level tree in the list of formulas in the Field Selector. 

 

g. Click Add Formula. 

 

Note: GCD stands for Global Convective Diagnostic.  This is a day-night scheme that uses infrared and 

water vapor imagery to map deep convection by means of geostationary satellite images. 
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20. Add Water Vapor and Infrared data sources to use with the GCD formula. 

 

a. Remove all layers and data sources by selecting Edit -> Remove -> Remove All Layers and Data 

Sources in the Main Display. 

 

b. From the Data Sources tab of the Data Explorer, open the Satellite -> Imagery chooser, and connect to 

the <LOCAL-DATA> GLOBAL dataset. 

 

c. Set the Image Type to WV, and select the Absolute image time of 2010-10-18 00:00:00Z. 

 

d. Click Add Source. 

 

e. From Data Sources tab, change the Image Type to IR, and select the Absolute image time of 2010-10-

18 00:00:00Z. 

 

f. Click Add Source. 

 

21. Display the data using the GCD formula you just created. 

 

a. In the Field Selector tab, select Formulas under Data Sources. 

 

b. Under Fields, open the Workshop tree and select GCD from WV and IR. Select Imagery -> Image 

Display display type. Click Create Display. 

 

c. In the new Field Selector window, for WaterVaporTemperature, select WV -> 6.8 um -> 

Temperature. 

 

d. In the Advanced tab, make sure your fields are the 

same as they are in the image on the right. 

 Click the full size icon ( ).  

 Set the Coordinate Type to be Area Coordinates. 

 Set the Location to be Upper Left.  

 For Magnification, change Line Mag and Ele 

Mag values to -2. 

 

e. From the Region tab, select an area in central Africa. 

 

f. For InfraredTemperature, select IR -> 10.7 um -> 

Temperature and repeat step 21 d. Click OK. 

 

The Results of the GCD formula are displayed in the Main Display.  Hold down the middle mouse button 

and pan around the image to see the different values of GCD listed at the bottom of the Main Display. 
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Creating a Derived Field 

 
22. Remove all layers and data sources from the previous displays. 

 

23. Add a gridded data source.  If you are using real-time data, skip to step 24. 

 

a. In the Data Sources tab of the Data Explorer, navigate to the Gridded Data -> Local chooser. 

 

b. Select the <local path>/Data/Formulas/GFS_CONUS_80km_20160122_1800.nc. 

 

c. Skip to step 25. 

 

24. In the Data Sources tab of the Data Explorer, navigate to the Gridded Data -> Remote chooser. 

 

a. Select Realtime Data -> NCEP Model Data -> Global Forecast System (GFS) -> GFS-CONUS 80km 

-> Latest* and click Add Source. 

 

b. Inspect the 2D native and derived fields. 

 

c. Expand the 2D grid tree, and all of the fields listed directly under 2D grid are native fields, or fields 

included with the data. 

 

d. Expand the 2D grid -> Derived tree to see all of the derived fields.  These derived fields are generated 

through formulas “under the hood”.  The majority of the formulas from these derived fields can be found 

by right-clicking on Formulas in the Field Selector and navigating to Edit Formulas -> Derived 

Quantities. 

 

25. Create a new derived quantity to inspect the difference between Pressure and MSLP. 

 

a. In the Field Selector, right-click on Formulas and select Create Formula. 

 

b. At the top of the Formula Editor window, enter the following: 

 

i. Description: MSLP – pressure (from %N1% & %N2%) 

(1) This is how the derived field will list in the Field Selector.  The ‘N1’ and ‘N2’ will allow for the 

name of the derived field to include the names of the two fields that it was derived from: MSLP 

– pressure (from Pressure_reduced_to_MSL_msl & Pressure_surface) 

 

ii. Name: pdiff 

(1) This is how the derived field can be referred to in a parameter default 

 

iii. Formula: sub(D1, D2) 
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(1) This is the actual formula.  D1 and D2 are used as placeholders for the two fields to be operated 

on.  These fields will be defined in step 25d. 

 
 

c. Expand Advanced. 

 

d. In the Derived tab, do the following: 

 

i. Uncheck For end user and check Create derived quantities. 

 

(1) Unchecking For end user keeps the formula from being listed out with the rest of the formulas 

in the Field Selector.  Checking Create derived quantities creates a derived quantity (field) 

from this formula. 

 

(2) In the Parameters menu, right-click in the text box, navigate through the menu tree to select the 

Pressure_reduced_to_MSL_msl field, type a comma ( , ), and right-click again to choose the 

Pressure_surface field.  These fields are the D1 and D2 specified in the formula (step 25b iii 

above). 

 

(3) The Categories menu here doesn’t have to be used since specific field names are being selected.  

If we were using an alias, such as PRESSURE, then this Categories menu could be used to tell 

McIDAS-V to only look for 2D gridded pressure fields by entering GRID-2D-*. 

 

e. Click Add Formula. 

 

26. Investigate the placement of the derived field in the Field Selector and move it under the 2D grid -> 

Derived tree. 

 

a. In the Field Selector, right-click on the GFS CONUS 80km data source and select Reload Data.  Once 

this is done, the data source will be re-loaded and the new formula created earlier will generate a derived 

quantity.  Note that this derived quantity is listed at the bottom of the Fields panel, and not under 2D 

grid -> Derived like the other 2D derived formulas (with remote data). 

 

b. Move this new derived field to under 2D grid -> derived by editing the formula.  To do this, right-click 

on Formulas in the Field Selector and select Edit Formulas -> Derived Quantities -> MSLP – 

pressure. 
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c. In the Derived tab at the bottom of the Formula Editor window, click the Define Output Categories 

button. 

 

d. This Define Output Categories window allows for specifying where this derived field should be listed.  

To get this field to list under 2D grid -> Derived, select Use Data, choose All for Operand, choose All 

for Category, then enter Derived for Append. 

 
 

- The Operand dropdown refers to which operand in the formula (D1 and D2) will be used.  

This could be useful, for example, if the operands in the formula were from different categories 

such as a 2D and a 3D grid.  Both of these grids are 2D so All can be used. 

- The Category dropdown refers to which categories were defined when creating the formula.  In 

this case, no categories were defined since specific field names were used.  This could be used if 

an alias was used in the Parameters menu when creating the formula.  For example, if TEMP 

(temperature) was specified as the alias, then there could be multiple categories (2D grid and 3D 

grid).  This Category dropdown could then be used to say if you are putting the derived field 

under the 2D or 3D tree in the Field Selector. 

- The Append menu informs McIDAS-V which menu tree (under the category tree) to place the 

derived field.  In this case, the field is put under a tree called Derived which is under the 2D grid 

tree (the tree where the MSLP and surface pressure fields are). 

 

e. Click OK to close the Define Output Categories window. 

 

f. Click Change Formula save the formula and close the Formula Editor window. 

 

g. Reload the data again using the method from 23a and now the derived field will list under 2D grid -> 

Derived. 

 

27. Display the data to see the difference between MSLP and surface pressure. 

 

a. In the Field Selector, choose the 2D grid -> Derived -> MSLP – pressure field.  Select the Plan Views -

> Contour Plan View and the first 5 times.  Click Create Display. 

 

b. Probe the display with the middle mouse button to see the pressure difference in Pascals.  Change the 

display to hPa by going to the Layer Controls for the layer and selecting Edit -> Change Display Unit.  

In this Change Unit window, use the dropdown to select hPa.  Click OK. 
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28. It is possible to create a parameter default so millibars or hPa would be used as the display unit by when the 

display is created.  This can be done by creating a parameter default. 

 

a. In the Main Display, select Tools -> Parameters -> Defaults. 

 

b. From the User Defaults tab, select File -> New Row.  In the Parameter menu, enter pdiff.  This pdiff 

was defined in 25b ii as the name associated with the formula.  Enter a Range of -10 to 400 (or whatever 

range you think is suitable for the data).  For Unit, use the dropdown to select hPa.  Click OK. 

 

c. In the Main Display, create a new tab and then re-display the derived MSLP – pressure field. 

 

 

Zooming, Panning, and Rotating Controls 

 

Zooming Panning Rotating 

 Mouse  

Shift-Left Drag: Select a region 

by pressing the Shift key and 

dragging the left mouse button. 

Shift-Right Drag: Hold Shift key 

and drag the right mouse button. 

Moving up zooms in, moving 

down zooms out. 

Control-Right Mouse Drag: 
Hold Control key and drag right 

mouse to pan. 

Right Mouse Drag: Drag right 

mouse to rotate. 

 Scroll Wheel  

Scroll Wheel-Up: Zoom Out. 

Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-

Up/Down: Rotate 

clockwise/counter clockwise. 

Shift-Scroll Wheel-Up/Down: 

Rotate forward/backward 

clockwise. 

 Arrow Keys  

Shift-Up: Zoom In. 

Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 

Control-Down arrow: Pan Up. 

Control-Right arrow: Pan Left. 

Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 

around vertical axis. 

Up/Down arrow: Rotate 

around horizontal axis. 

Shift-Left/Right arrow: Rotate 

Clockwise/Counterclockwise. 

 


