
McIDAS-V Tutorial  
Using GOES-16 Data 

Created February 2019 (software version 1.8) 
 
McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 
SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 
(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 
manipulate data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's 
IDV libraries. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V 
for viewing and analyzing hyperspectral satellite data. 

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 
McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 
the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 
http://www.ssec.wisc.edu/mcidas/software/v/. 

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 
Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share 
information with other users. 

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 
McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the 
document entitled McIDAS-V Tutorial – Installation and Introduction. 

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 
Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 
Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 
Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources). 
 
Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag). 

ABI Introduction 

McIDAS-V currently supports ABI netCDF data through remote servers as well as through the local file 
chooser on all platforms.  Local servers for ABI data are currently available on OS X and Linux platforms.  This 
tutorial will cover how to access this data through remote servers and different ways that the data can be 
displayed and interrogated in McIDAS-V. 
  

http://www.ssec.wisc.edu/mcidas/software/v/
http://www.ssec.wisc.edu/mcidas/forums/
http://www.ssec.wisc.edu/mcidas/forums/
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Accessing GOES-16 ABI Data from a Remote Server – 1 Timestep 
 
1. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  Select 

atm.ucar.edu as the Server and RTGOESR as the Dataset.  Click Connect. 
 

2. Select FD – GOES-16 FD all bands as the Image Type. 
 

3. In the Times panel, select the Relative tab.  For Number of times, enter 1 and click Add Source to create a 
data source of the most recent time. 
  

4. Display band 13 temperature data. 
 
a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the 

data.  Select the 10.3 um IR Surface & cloud -> Temperature field. 
 

b. From the Displays panel, select the Imagery -> Image Display display type. 
 

c. Select the Region tab to see a low-resolution preview image of the data.  Note that there is a green box 
drawn around the preview image.  Any data inside this bounding box will be displayed. 
 

d. Select the Advanced tab to see information about the band and calibration selected.  These values match 
the domain of the data selected in the Region tab, so it covers the entire domain of the data.  Notice that 
the Image Size is only 904 x 904 when the raw size of the data is 5424 x 5424.  The magnification of the 
data is set to -6, -6.  This reduction in resolution is the default to allow for an efficient display of the 
data.  Modify the Advanced tab to display full resolution data over Florida. 
 
i. Coordinate Type: Latitude/Longitude 

ii. Location: Center 
iii. Lat: 28; Lon: -83.5 
iv. Image Size: 400 x 400 
v. Magnification: 1 x 1 

 
e. Click Create Display. 

 
5. Investigate the display. 

 
a. In the Main Display window, practice navigating around in the display.  To do this, use Control+Right-

Click+Drag to translate the display.  This shifts the data left/right and up/down without rotating the 
display.  Zoom in on the display by scrolling down on the mouse wheel.  As an alternative, select a 
region in the Main Display by using Shift+Left-Click+Drag to zoom in on a specific domain. 
 

b. Probe individual pixel values by holding down the middle mouse button over the display.  This will print 
out probe values at the bottom of the display.  Notice that latitude, longitude, and temperature values are 
included in the probe output. 
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c. Navigate to the Histogram tab of the Layer Controls to see a histogram of band 13 temperature values. 
 

6. Add a data transect to the display. 
 
a. From the Field Selector tab of the Data Explorer, select the Data Transect display type and click 

Create Display. 
 

b. In the Main Display window, there is a red line that is referred to as the data transect.  The values along 
this transect line are output in the Layer Controls tab of the Data Explorer.  The two end points of the 
transect can be moved around by Left-Clicking+Dragging them, or by entering new Lat/Lon values at 
the bottom of the Display tab in the Layer Controls.  The transect line as a whole can be moved by Left-
Clicking+Dragging the triangle in the middle of the transect line.  
 

7. Create a display of the 10.3 micron temperatures so only values of 273K and less are plotted. 
 
a. Add a new two-paneled map display by selecting File -> New Display Tab -> Map Display -> Two 

Panels menu item. 
 

b. Left-Click in the left panel to make this panel active.  The active panel has a blue frame around it, and 
this is the panel any displays will be added to. 
 

c. In the Field Selector tab of the Data Explorer, select the 10.3 um IR Surface & cloud -> Temperature 
field.  Choose the Imagery -> Image Display display type and click Create Display.  
 

d. Create the cloud mask display. 
 
i. Left-Click in the right panel to make this panel active.  The active panel has a blue frame around it, 

and this is the panel any displays will be added to. 
 

ii. In the Field Selector tab of the Data Explorer, select Formulas. 
 

iii. Select the Imagery -> Mask Value formula, the Imagery -> Image Display display type, and click 
Create Display. 
 

iv. In the Select input window, enter the following and then click OK: 
 
1. comparison: < 
2. cutoff: 273 
3. useNaN: 1 

Notes: The comparison is set to < or ‘less then’ since the goal is to display values less than 273, 
which was set as the cutoff value.  Setting useNaN to 1 makes it so that if the pixels were probed 
outside of the masked range (where values are greater than 273) they wouldn’t show a value.  
useNaN can be set to 0 as well, and in this case pixel values greater than 273 would probe as 0.  
Note that if these pixel values are set to 0, then these 0 values will be included in any 
calculations with the data that may be done later. 
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v. In the new Field Selector window, for inputFieldForMask, select 10.3 um IR Surface & cloud -> 
Temperature.  This is the field that is being masked. 
 

vi. For displayFieldToBeMasked, select 10.3 um IR Surface & cloud -> Temperature.  This is the 
field that will be displayed where the inputFieldForMask is less than 273 degrees.  In this case, we 
are displaying the same field that is being masked. 
 

vii. Click OK. 
 

e. Investigate the display.  Note that as one of the panels is navigated, the other will be navigated in the 
same way.  This is because by default panels in the same tab are set to share views.  This setting can be 
disabled in a panel by unchecking Projections -> Share Views in the display panels. 
 

8. Create a display of a subtraction of two bands. 
 
a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One 

Panel menu item, or by clicking the Add new tab ( ) button in the Main Toolbar. 
 

b. In the Field Selector tab of the Data Explorer, select Formulas. 
 

c. Select the Miscellaneous -> Simple difference a-b formula, the Imagery -> Image Display display type, 
and click Create Display. 
 

d. In the new Field Selector window, for a, select the 8.44 um IR Total WV cloud phase, dust -> 
Temperature field.  For field b, select the 7.34 um IR Lower-level WV, winds & SO2-> Temperature 
field. 
 

e. Click OK in the Field Selector window to display the band subtracted data. 
 

f. Right-Click on the colorbar of the ABI layer in the Legend and select the System -> Inverse Gray Scale 
enhancement. 
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g. Add latitude and longitude labels to the display. 
 
i. Left-Click on the blue text for the Default Background Maps layer in the Legend to get to the Layer 

Controls tab of the Data Explorer for the layer. 
 

ii. From the Lat/Lon tab of the Layer Controls, set the following: 
 
1. Check the visibility checkboxes for Lines and Labels to plot them in the display. 
2. Lines: Interval: 5.0 
3. Labels: Interval: 5.0; At Longitudes: -85.0, At Latitudes: 30.0, Color: light blue 
4. Font: Arial; Bold; 20 

 

  
 

h. Investigate the display to see the latitude and longitude lines and labels.  Probe the data to see the 
temperature difference between the two bands. 
 

9. Capture an image of the display. 
 
a. From the Main Display, select the View -> Capture -> Image menu item. 

 
b. In the Save As text field, enter the name to give your image, for example: band_subtraction.gif. 

 
c. Use the dropdown below Save As to select the directory to save your image to. 

 
d. Under Capture What, select Current View.  This will capture an image of the display without including 

any other components of the Main Display such as menu items and the Legend. 
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e. Click Save. 
 

f. View your saved image to verify the image was captured correctly. 
 

 
Accessing GOES-16 ABI Data from a Remote Server – 5 Timesteps 
 
10. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and 

Data Sources menu item from the Main Display. 
 

11. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel 
menu item.  Close any previously-existing tabs. 
 

12. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  In the Relative 
tab of the Times panel, for Number of times, enter 5 and click Add Source. 
 

13. Display a loop of 10.4um Temperature data over Wisconsin and Illinois. 
 
a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the 

data.  Select the 10.3 um IR Surface & cloud -> Temperature field. 
 

b. From the Displays panel, select the Imagery -> Image Display display type. 
 

c. Navigate to the Advanced tab, and enter the following information: 
i. Coordinate Type: Latitude/Longitude 

ii. Location: Center 
iii. Lat: 42; Lon: -89.6 
iv. Image Size: 450 x 450 
v. Magnification: 1 x 1 

 
d. Click Create Display. 

 
14. Investigate the display. 

 
a. The Main Display now has a loop of the 5 most recent times of data in the FD dataset.  As done in step 

5 earlier, navigate around and zoom in/out of the display.  Probe the display by holding down the middle 
mouse button over the data. 
 

b. Use the Time Animation Widget at the top of the display panel to play through a loop of the data. 
 

 
 

c. Click the Properties button ( ) in the Time Animation Widget to modify settings of the animation 
including the dwell rate (the time spent on each frame in the animation).  As an example, set the 
Forward, First, and Last dwell rates to 0.2 and click OK.  This reduced dwell rate allows the display to 
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loop faster. 
 

15. Change the enhancement used in the display. 
 
a. Stop the animation by clicking the Stop Animation button in the Time Animation Widget ( ). 

 
b. Right-Click on the colorbar of the ABI layer in the Legend and select the Satellite -> GOES-R -> ABI 

IR Temperature enhancement.  
 

16. Add a color scale to the display. 
 
a. Right-Click on the ABI layer in the Legend and select Edit -> Properties. 

 
b. In the Properties window, navigate to 

the Color Scale tab and set the 
following: 
i. Visible: Check this option to add 

the color scale to the display. 
ii. Position: Top.  This will position 

the color scale at the top of the 
display. 

iii. Labels -> Visible: Check this 
option to add numerical labels to 
the color scale. 

iv. Labels -> Show Unit: Check this 
to add the display unit to the color 
scale labels. 

v. Labels -> Font: Set the size to 32. 
 

c. Click OK. 
 

17. Create a Data Probe/Time Series display of band 13 temperature data.  This display type allows for plotting 
how temperature values at a specific location change through time throughout the loop. 
 
a. In the Field Selector tab of the Data Explorer, select the Data Probe/Time Series display type and 

click Create Display. 
 

b. The Layer Controls tab of the Data Explorer now shows a time series display of temperature values at 
the location of the probe in the Main Display.  Change the range of the y-axis (temperature values) to 
match the range of the data. 
 
i. At the bottom of the Layer Controls tab, Double-Click on the 186-Band13_TEMP parameter to open 

the Properties window. 
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ii. In the Properties window, change the Range text boxes to a Min of 180 and a Max of 320 to match 
the range of the enhancement in the Main Display. 
 

iii. Click OK to apply the new range in the Layer Controls and close the Properties window. 
 

c. Move the data probe in the Main Display around with Left-Click+Drag.  The time series display in the 
Layer Controls automatically updates itself as the probe’s location changes. 
 

d. The data probe in the Main Display can also be set to a specific latitude/longitude value by using the 
Lat and Lon text boxes at the bottom of the Layer Controls.  For example, enter values of 38.6 for Lat 
and -88.1 for Lon.  Note that you must press Enter in each text field for latitude/longitude to update the 
location of the data probe. 
 

 
Accessing ABI Data from a Remote Server through Scripting 
 
Both of the previous sections of this tutorial can be replicated through scripting.  This section covers creating a 
loop of ABI data and applying an enhancement to the display. 
 
18. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and 

Data Sources menu item from the Main Display. 
 

19. From the Main Display, select Tools -> Formulas -> Jython Shell to open the Jython Shell. 
 

20. The Jython Shell defaults to single-line input mode, where only one line of code can be executed at a time.  
This script is more than one line long, so it requires multi-line input.  To switch to multi-line input, click the 
double-down blue arrow button ( ) to the right of the text entry box. 
 

21. In a text editor, open the Data/GOES16/abiLoop.py file.  Copy this text and paste it into the Jython Shell. 
 

22. To evaluate this code, click the Evaluate button, or use Shift+Enter.  In-line documentation of what the 
script is doing can be found in the script (lines that begin with ‘#’ are comments).  More information about 
McIDAS-V scripting can be found in the User’s Guide as well as the Scripting and User Functions tutorials. 
 

23. After you are done analyzing the display created with the script, close the new display window. 
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Using GOES-16 GLM and Satellite Derived Winds 
 
24. This section of the tutorial uses a new Data Type through the General -> Files/Directories chooser as well 

as a new layout model which is must be 
added via a plugin.  Add this plugin.  
 
a. From the Main Display window, 

navigate to the Tools -> Plugins -> 
Manage menu item to open the 
Plugin Manager. 
 

b. The top of the Plugin Manager lists 
plugins currently installed, and the 
bottom panel lists the various 
plugins available for installation.  
Expand the Data Sources tree and 
click the green Install Plugin button 
next to GLM NetCDF Files. 
 

c. This pops up a message notifying 
the user that McIDAS-V must be 
restarted to complete the installation 
of the plugin.  Click OK through 
this message and restart McIDAS-
V. 
 

25. Display GOES-16 band 14 data. 
 
a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/ABI 

directory. 
 

b. Select the GOES16_CONUS* file. 
 

c. From the Data Type dropdown, select Grid files (netCDF/GRIB/OPeNDAP/GEMPAK). 
 

d. Click Add Source. 
 

e. In the Fields panel of the Field Selector, verify that brightness_temperature is selected. 
 

f. In the Displays panel of the Field Selector, select Imagery -> Image Display. 
 

g. Click Create Display. 
 

26. Modify the display of the GOES-16 band 14 data. 
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a. To make the cold clouds white and the relatively warmer land darker, change the enhancement used by 
the displayed layer by Right-Clicking on the colorbar in the Legend and selecting System -> Inverse 
Gray Scale. 
 

b. Disable the wireframe box around the display by selecting View -> Show -> Wireframe Box in the 
display panel. 
 

c. Other layers will be added to the display in the next several steps.  To maintain the current projection, 
from the display panel, disable Projections -> Auto-Set Projection. 
 

27. Add a data source of six consecutive (2 minutes total) GLM files as group data. 
 
a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/GLM 

directory. 
 

b. Use Shift+Left-Click to select all six OR_GLM-L2-LFCA* files. 
 

c. From the Data Type dropdown, select GLM Groups Data files.  This data type was added from the 
plugin that was installed in step 24 above. 
 

d. Click Add Source. 
 

28. By default, each data point in each GLM file has its own timestep, which would create a loop of potentially 
thousands of frames.  Bin all of the times together so each data point plots at the same timestep. 
 
a. From the Field Selector, Right-Click on the 6 Files Data Source and choose Properties. 

 
b. At the bottom of the Properties tab of this window, find the Time Binning section.  Set the following 

using the dropdown menus:  
 
Bin Size: 5 minutes 
Round To: 1 hour 
 
A bin size of 5 minutes is large enough to contain all of the data.  The round to value of 1 hour sets this 
timestep to be right on the hour, 13Z, thus matching the time of the band 14 data displayed earlier. 
 

c. Click OK at the bottom of the Properties window. 
 

29. Display the GLM data. 
 
a. In the Fields panel of the Field Selector, select Point Data. 

 
b. In the Displays panel of the Field Selector, choose the Point Data -> Point Data Plot display type. 
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c. In the Layout Model subset tab, click the double-down blue arrows next to None and choose GLM -> 
Group.  This layout model was added from the plugin that was installed in step 24 above. 
 

d. Click Create Display. 
 

30. Investigate and modify the display of GLM data.  Note that the points of GLM data are parallax-corrected 
(from the data itself), so they may not perfectly match up with the location of the band 14 imagery, which is 
not parallax-corrected. 
 
a. The pink plus signs in the display represent the GLM group data points.  As you zoom in and out of the 

display, you’ll see the number of points change.  This is because of decluttering that McIDAS-V does to 
the display.  To modify the decluttering, Left-Click on the 6 files data source in the Legend to get to the 
Layer Controls of the layer.  Disable the Declutter checkbox to show every point.  Another option 
would be leaving Declutter enabled (checked) and adjusting the Density slider.  As the slider moves to 
the right, more points will be shown. 
 

b. If you wish to change the size of the plus signs in the display, adjust the Scale value in the Layer 
Controls.  Decreasing the value from 1 (for example, 0.5) will make the points smaller.  Increasing the 
value from 1 (for example, 2) will make the points larger. 
 

31. Add a data source of satellite derived winds. 
 
a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/Derived 

Winds directory. 
 

b. Select the OR_ABI-L2-DMWC* file. 
 

c. From the Data Type dropdown, select netCDF/GEMPAK Point Data files. 
 

d. Click Add Source. 
 

32. Display the satellite derived winds. 
 
a. In the Fields panel of the Field Selector, choose the Point Data field. 

 
b. In the Displays panel of the Field Selector, choose the Point Data -> Point Data Plot display type. 

 
c. A new layout model will be imported to plot the satellite derived winds colored by speed.  To do this, go 

to the Layout Model subset tab of the Field Selector and choose Edit. 
 

d. From the Layout Model Editor window, select File -> Import. 
 

e. From the Layout Model import window, select the <local data>/Data/GOES16/G16_Winds.ism file 
and click Open. 
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f. From the Layout Model Editor window, select File -> Save and close the Layout Model Editor.   
 

g. From the Layout Model subset tab of the Field Selector, click the double-down blue arrows next to 
None and choose G16_Winds <local>. 
 

h. Click Create Display. 
 

33. Investigate and modify the display of GOES-16 satellite derived winds using the same methods used in step 
30 above with GLM data. 

 

 

Zooming, Panning, and Rotating Controls 
 

Zooming Panning Rotating 
 Mouse  
Shift-Left Drag: Select a region 
by pressing the Shift key and 
dragging the left mouse button. 
Shift-Right Drag: Hold Shift key 
and drag the right mouse button. 
Moving up zooms in, moving 
down zooms out. 

Control-Right Mouse Drag: 
Hold Control key and drag right 
mouse to pan. 

Right Mouse Drag: Drag right 
mouse to rotate. 

 Scroll Wheel  
Scroll Wheel-Up: Zoom Out. 
Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-
Up/Down: Rotate 
clockwise/counter clockwise. 
Shift-Scroll Wheel-Up/Down: 
Rotate forward/backward 
clockwise. 

 Arrow Keys  
Shift-Up: Zoom In. 
Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 
Control-Down arrow: Pan Up. 
Control-Right arrow: Pan Left. 
Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 
around vertical axis. 
Up/Down arrow: Rotate 
around horizontal axis. 
Shift-Left/Right arrow: Rotate 
Clockwise/Counterclockwise. 
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	9. Capture an image of the display.
	a. From the Main Display, select the View -> Capture -> Image menu item.
	b. In the Save As text field, enter the name to give your image, for example: band_subtraction.gif.
	c. Use the dropdown below Save As to select the directory to save your image to.
	d. Under Capture What, select Current View.  This will capture an image of the display without including any other components of the Main Display such as menu items and the Legend.
	e. Click Save.
	f. View your saved image to verify the image was captured correctly.
	Accessing GOES-16 ABI Data from a Remote Server – 5 Timesteps
	10. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and Data Sources menu item from the Main Display.
	11. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item.  Close any previously-existing tabs.
	12. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  In the Relative tab of the Times panel, for Number of times, enter 5 and click Add Source.
	13. Display a loop of 10.4um Temperature data over Wisconsin and Illinois.
	a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the data.  Select the 10.3 um IR Surface & cloud -> Temperature field.
	b. From the Displays panel, select the Imagery -> Image Display display type.
	c. Navigate to the Advanced tab, and enter the following information:
	i. Coordinate Type: Latitude/Longitude
	ii. Location: Center
	iii. Lat: 42; Lon: -89.6
	iv. Image Size: 450 x 450
	v. Magnification: 1 x 1
	d. Click Create Display.
	14. Investigate the display.
	a. The Main Display now has a loop of the 5 most recent times of data in the FD dataset.  As done in step 5 earlier, navigate around and zoom in/out of the display.  Probe the display by holding down the middle mouse button over the data.
	b. Use the Time Animation Widget at the top of the display panel to play through a loop of the data.
	c. Click the Properties button () in the Time Animation Widget to modify settings of the animation including the dwell rate (the time spent on each frame in the animation).  As an example, set the Forward, First, and Last dwell rates to 0.2 and click ...
	15. Change the enhancement used in the display.
	a. Stop the animation by clicking the Stop Animation button in the Time Animation Widget ().
	b. Right-Click on the colorbar of the ABI layer in the Legend and select the Satellite -> GOES-R -> ABI IR Temperature enhancement.
	16. Add a color scale to the display.
	a. Right-Click on the ABI layer in the Legend and select Edit -> Properties.
	b. In the Properties window, navigate to the Color Scale tab and set the following:
	i. Visible: Check this option to add the color scale to the display.
	ii. Position: Top.  This will position the color scale at the top of the display.
	iii. Labels -> Visible: Check this option to add numerical labels to the color scale.
	iv. Labels -> Show Unit: Check this to add the display unit to the color scale labels.
	v. Labels -> Font: Set the size to 32.
	c. Click OK.
	17. Create a Data Probe/Time Series display of band 13 temperature data.  This display type allows for plotting how temperature values at a specific location change through time throughout the loop.
	a. In the Field Selector tab of the Data Explorer, select the Data Probe/Time Series display type and click Create Display.
	b. The Layer Controls tab of the Data Explorer now shows a time series display of temperature values at the location of the probe in the Main Display.  Change the range of the y-axis (temperature values) to match the range of the data.
	i. At the bottom of the Layer Controls tab, Double-Click on the 186-Band13_TEMP parameter to open the Properties window.
	ii. In the Properties window, change the Range text boxes to a Min of 180 and a Max of 320 to match the range of the enhancement in the Main Display.
	iii. Click OK to apply the new range in the Layer Controls and close the Properties window.
	c. Move the data probe in the Main Display around with Left-Click+Drag.  The time series display in the Layer Controls automatically updates itself as the probe’s location changes.
	d. The data probe in the Main Display can also be set to a specific latitude/longitude value by using the Lat and Lon text boxes at the bottom of the Layer Controls.  For example, enter values of 38.6 for Lat and -88.1 for Lon.  Note that you must pre...
	Accessing ABI Data from a Remote Server through Scripting
	Both of the previous sections of this tutorial can be replicated through scripting.  This section covers creating a loop of ABI data and applying an enhancement to the display.
	18. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and Data Sources menu item from the Main Display.
	19. From the Main Display, select Tools -> Formulas -> Jython Shell to open the Jython Shell.
	20. The Jython Shell defaults to single-line input mode, where only one line of code can be executed at a time.  This script is more than one line long, so it requires multi-line input.  To switch to multi-line input, click the double-down blue arrow ...
	21. In a text editor, open the Data/GOES16/abiLoop.py file.  Copy this text and paste it into the Jython Shell.
	22. To evaluate this code, click the Evaluate button, or use Shift+Enter.  In-line documentation of what the script is doing can be found in the script (lines that begin with ‘#’ are comments).  More information about McIDAS-V scripting can be found i...
	23. After you are done analyzing the display created with the script, close the new display window.
	Using GOES-16 GLM and Satellite Derived Winds
	24. This section of the tutorial uses a new Data Type through the General -> Files/Directories chooser as well as a new layout model which is must be added via a plugin.  Add this plugin.
	a. From the Main Display window, navigate to the Tools -> Plugins -> Manage menu item to open the Plugin Manager.
	b. The top of the Plugin Manager lists plugins currently installed, and the bottom panel lists the various plugins available for installation.  Expand the Data Sources tree and click the green Install Plugin button next to GLM NetCDF Files.
	c. This pops up a message notifying the user that McIDAS-V must be restarted to complete the installation of the plugin.  Click OK through this message and restart McIDAS-V.
	25. Display GOES-16 band 14 data.
	a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/ABI directory.
	b. Select the GOES16_CONUS* file.
	c. From the Data Type dropdown, select Grid files (netCDF/GRIB/OPeNDAP/GEMPAK).
	d. Click Add Source.
	e. In the Fields panel of the Field Selector, verify that brightness_temperature is selected.
	f. In the Displays panel of the Field Selector, select Imagery -> Image Display.
	g. Click Create Display.
	26. Modify the display of the GOES-16 band 14 data.
	a. To make the cold clouds white and the relatively warmer land darker, change the enhancement used by the displayed layer by Right-Clicking on the colorbar in the Legend and selecting System -> Inverse Gray Scale.
	b. Disable the wireframe box around the display by selecting View -> Show -> Wireframe Box in the display panel.
	c. Other layers will be added to the display in the next several steps.  To maintain the current projection, from the display panel, disable Projections -> Auto-Set Projection.
	27. Add a data source of six consecutive (2 minutes total) GLM files as group data.
	a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/GLM directory.
	b. Use Shift+Left-Click to select all six OR_GLM-L2-LFCA* files.
	c. From the Data Type dropdown, select GLM Groups Data files.  This data type was added from the plugin that was installed in step 24 above.
	d. Click Add Source.
	28. By default, each data point in each GLM file has its own timestep, which would create a loop of potentially thousands of frames.  Bin all of the times together so each data point plots at the same timestep.
	a. From the Field Selector, Right-Click on the 6 Files Data Source and choose Properties.
	b. At the bottom of the Properties tab of this window, find the Time Binning section.  Set the following using the dropdown menus:   Bin Size: 5 minutes Round To: 1 hour  A bin size of 5 minutes is large enough to contain all of the data.  The round t...
	c. Click OK at the bottom of the Properties window.
	29. Display the GLM data.
	a. In the Fields panel of the Field Selector, select Point Data.
	b. In the Displays panel of the Field Selector, choose the Point Data -> Point Data Plot display type.
	c. In the Layout Model subset tab, click the double-down blue arrows next to None and choose GLM -> Group.  This layout model was added from the plugin that was installed in step 24 above.
	d. Click Create Display.
	30. Investigate and modify the display of GLM data.  Note that the points of GLM data are parallax-corrected (from the data itself), so they may not perfectly match up with the location of the band 14 imagery, which is not parallax-corrected.
	a. The pink plus signs in the display represent the GLM group data points.  As you zoom in and out of the display, you’ll see the number of points change.  This is because of decluttering that McIDAS-V does to the display.  To modify the decluttering,...
	b. If you wish to change the size of the plus signs in the display, adjust the Scale value in the Layer Controls.  Decreasing the value from 1 (for example, 0.5) will make the points smaller.  Increasing the value from 1 (for example, 2) will make the...
	31. Add a data source of satellite derived winds.
	a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/Derived Winds directory.
	b. Select the OR_ABI-L2-DMWC* file.
	c. From the Data Type dropdown, select netCDF/GEMPAK Point Data files.
	d. Click Add Source.
	32. Display the satellite derived winds.
	a. In the Fields panel of the Field Selector, choose the Point Data field.
	b. In the Displays panel of the Field Selector, choose the Point Data -> Point Data Plot display type.
	c. A new layout model will be imported to plot the satellite derived winds colored by speed.  To do this, go to the Layout Model subset tab of the Field Selector and choose Edit.
	d. From the Layout Model Editor window, select File -> Import.
	e. From the Layout Model import window, select the <local data>/Data/GOES16/G16_Winds.ism file and click Open.
	f. From the Layout Model Editor window, select File -> Save and close the Layout Model Editor.
	g. From the Layout Model subset tab of the Field Selector, click the double-down blue arrows next to None and choose G16_Winds <local>.
	h. Click Create Display.
	33. Investigate and modify the display of GOES-16 satellite derived winds using the same methods used in step 30 above with GLM data.

