
McIDAS-V Tutorial 
Displaying NASA SPoRT NUCAPS Gridded Data 

created November 2023 (software version 1.9) 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next 

generation in SSEC's 50-year history of sophisticated McIDAS software packages. McIDAS-V displays 

weather satellite (including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V 

can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on 

SSEC's VisAD and Unidata's IDV libraries. The functionality of SSEC's HYDRA software package is also 

being integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data. 

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 

McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 

the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 

https://www.ssec.wisc.edu/mcidas/software/v/.   

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 

Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share 

information with other users. 

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 

Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data 

Sources, Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the 

Field Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources). 

 

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).   

  

https://www.ssec.wisc.edu/mcidas/software/v/
http://www.ssec.wisc.edu/mcidas/forums/
http://www.ssec.wisc.edu/mcidas/forums/
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Introduction 

The data for this tutorial can be downloaded at: 

https://bin.ssec.wisc.edu/pub/mug/mcidas-v/training/data/NUCAPS.zip 

McIDAS-V can be downloaded from the Download McIDAS-V webpage: 

https://www.ssec.wisc.edu/mcidas/software/v/download/ 

If McIDAS-V is already installed, please continue to step 1 on page 6. 

See the main McIDAS-V page (https://www.ssec.wisc.edu/mcidas/software/v/) for more information about 

McIDAS-V including: 

 Sample capabilities 

 System requirements 

 Documentation – User’s Guide and additional tutorials 

 McIDAS-V support forum 

Installation of McIDAS-V 

The installation of McIDAS-V is a simple three-step procedure (download, install, and run). 

1.  Download the appropriate package for your operating system from the McIDAS-V webpage.  This file is 

only the installer and can be placed anywhere on your machine.  When you run the installer in the next 

step, you can then indicate where you want McIDAS-V to be installed.  The system requirements for 

McIDAS-V are also listed on the McIDAS-V webpage. 

2.  Install McIDAS-V by starting the installer by following the instructions appropriate for your operating 

system: 

  Mac OS X  mount the .dmg and double-click the installer 

  Windows  double-click the downloaded .exe file 

 All other platforms open a terminal window and run sh ./<installer>.sh 

 

https://bin.ssec.wisc.edu/pub/mug/mcidas-v/training/data/NUCAPS.zip
https://www.ssec.wisc.edu/mcidas/software/v/download/
https://www.ssec.wisc.edu/mcidas/software/v/
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A GUI will walk you through the installation steps and allow you to create a program group and/or desktop 

icon. 

3.  Run McIDAS-V by following the instructions appropriate for your operating system: 

 Mac OS X  Double-click on the McIDAS-V shortcut icon that was created in /Applications. 

 Windows Double-click on the McIDAS-V shortcut icon that was created on the Desktop. 

 All others At the UNIX prompt from the directory where McIDAS-V was installed,  

   run the command: runMcV 

Note:  By default, McIDAS-V uses 80% of the available memory on your machine. The maximum amount of 

memory is determined by the operating system. To manually change the amount of memory used by 

McIDAS-V, edit the Maximum Heap Size in the Advanced tab of the Preferences by selecting  

Edit -> Preferences... from the main menu. The new amount of memory will be saved and used in 

subsequent sessions. For 32 bit operating systems, it is recommended to set this to no more than 1250 

MB. The maximum value for 32 bit operating systems is 1536 MB. Exit McIDAS-V and start a new 

session to use this new memory setting. 

Welcome Window 
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Upon initial startup, the Welcome to McIDAS-V window will be displayed. 

 

 

Please be sure to read this IMPORTANT NOTICE.  Because McIDAS-V utilizes the latest developments 

in Java 3D programming and video driver updates, it is often necessary to update video drivers to solve some 

seemingly unrelated performance problems.  Do not assume that because you have a new machine, you have 

the latest drivers.  We have found brand new machines with drivers that are more than five years old! 

After reading the notice in the Welcome window, click Quit to close the window, or click Start McIDAS-V 

to close the window and start McIDAS-V.  Once McIDAS-V has been started, this window will not appear 

again. 
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Introduction to McIDAS-V windows 

There are two main windows in the McIDAS-V application - the Data Explorer window and the Main 

Display window. Other windows may appear when needed. 

 

 

Data Explorer (shown on the left) 

The Data Explorer window is central to McIDAS-V. It is used to choose data sources and parameters to 

display, the kinds of displays to make, and times of data to display.  The first time McIDAS-V starts up, the 

Data Explorer defaults to the Satellite -> Imagery chooser.  This chooser, along with several others, uses 

ADDE (Abstract Data Distribution Environment) servers to access data.  McIDAS-V comes with a pre-

configured list of several available free servers which contain real-time and archived atmospheric datasets. 

 

Main Display (shown on the right) 

The Main Display window includes the McIDAS-V display panels, legend, time animation controls, 

viewpoint controls for 3D displays, icons to zoom and pan, menus to control views and projections, and the 

main McIDAS-V menu. Navigating to Help -> User’s Guide in the Main Toolbar brings up the McIDAS-V 

User’s Guide, which has both a table of contents and a search function. 

 

Common Usage Scenario 

To create displays of data with McIDAS-V, a common usage scenario is: 

 Choosing the source of data (local files, remote servers, etc.) 

 Selecting parameters and display type 

 Creating the display 

 Controlling the display 

 Creating a bundle 
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Create a Data Source of a Single Time of Sea Surface Temperature Data 

1. From the Data Sources tab of the Data Explorer, navigate to the General->Files/Directories 

chooser. 

 

2. Using the Data Type dropdown menu, select Grid files (netCDF/GRIB/OPeNDAP/GEMPAK). 

 

3. Using the Look In menu, select the directory containing the files downloaded from ftp. 

 

4. Select the 20210720_1741_gridded_nucaps_noaa20_conus.nc file. 

 

5. Click Add Source. 

 

 

Create a Display of Total Carbon Monoxide 

6. From the Fields panel of the Field Selector, select the 2D grid -> CO_Total field. 

 

7. From the Displays panel of the Field Selector, select the Plan Views -> Color-Shaded Plan View 

display type. 
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8. Click Create Display. 

 

 

Investigate the Display 

9. The display of the CO_Total data appears in the Main Display.  Practice navigating around in the 

display and probing the data. 

 

a. Hold down the middle mouse button to probe the data.  This will give a carbon monoxide 

output in units of 10e18 molecules/cm^2 as well as latitude and longitude values at the bottom 

of the display. 

 

b. Zoom in on the display by scrolling down with the mouse wheel.  Zoom out of the display by 

scrolling up with the mouse wheel. 

 

c. Zoom in on the display by using Shift+Left-Click+Drag to draw a bounding box. 

 

d. Translate the display by using Ctrl+Right-Click+Drag.  This moves the display left and right 

without any rotation. 

 

e. Rotate the display with Right-Click+Drag. 
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Add a Color Scale to the Display 

10. Right-Click on the blue “20210720_1741_gridded_nucaps*” legend label in the Legend of the Main 

Display and select Edit -> Properties to open the Properties window for the layer. 

 

11. From the Properties window, navigate to the Color Scale tab and set the following: 

 

a. Visible: check 

b. Position: Top 

c. Labels -> Visible: check 

d. Labels -> Show Unit: uncheck 

e. Labels -> Font: Arial, Bold, 26 

f. Labels -> Color: White 
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12. Click Apply and then OK in the Properties window to add the color scale to the Main Display. 

 

Expand the Enhancement Range 

13. McIDAS-V defaults to an enhancement range of 5 to 30.  While this range generally captures most 

values in a given scene, fires in the western United States and Canada produced a large amount of 

carbon monoxide over the eastern United States on this day.  Because of this, much of the display is 

solid red, meaning the value at those locations is greater than or equal to 30.  Right-Click on the color 

scale in the Legend and select Change Range. 

 

14. In the Change Range window, change the max value from 30 to 40 and click OK. 

 

15. Investigate the display and observe that it is now easier to determine where the highest concentrations 

of CO exist. 

Capture an Image of the Display 

16. From the Main Display window, select View -> Capture -> Image. 

 

17. From the Save window, navigate to a directory to save the image to. 

 

18. In the File Name field, enter a name, such as: NUCAPS_CO.jpg 

 

19. Click Save. 
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20. From a file explorer window outside of McIDAS-V, navigate to the directory the image was saved to 

and view it. 

Create a Data Source Containing Multiple Times of Data 

21. Remove all layers and data sources from the previous display by selecting Edit -> Remove -> All 

Layers and Data Sources from the Main Display window.  Click Remove all layers and data in the 

window that appears. 

 

22. From the Data Sources tab of the Data Explorer, navigate to the General->Files/Directories 

chooser. 

 

23. Using the Data Type dropdown menu, select Aggregate Grids by Time. 

 

24. Using the Look In menu, select the directory containing the files downloaded from ftp. 

 

25. Use Shift+Left-Click to select all of the files with data from September 2021 (202109*.nc). 

 

26. Click Add Source. 
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Display a Loop of 2 Meter Relative Humidity Data 

27. From the Fields panel of the Field Selector, select the 2D grid -> RelHum_2m field. 

 

28. From the Displays panel of the Field Selector, select the Plan Views -> Color-Shaded Plan View 

display type. 

 

29. Click Create Display. 

 

 

Display a Loop of 2 Meter Relative Humidity Data and Save a Movie 

30. Use Shift+Left-Click+Drag to zoom in over the United States. 

 

31. Use the Time Animation Widget at the top of the display to step through the individual timesteps 

and play a loop of the data. 

 

 
 

32. From the Main Display window, select View -> Capture -> Movie. 

 

33. In the Movie Capture window, verify that Current View is selected under What to capture.  This 

tells McIDAS-V to capture an animation of the current active panel.  The other options under What to 

capture allow for capturing animations of multiple panels, the entire Main Display, as well as the 

everything currently on the screen. 
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34. In the Movie Capture window, click the Time Animation button.  At this point, the Main Display 

window will come to the front and the animation will play.  Ensure that no windows overlap the 

Main Display window while the animation is capturing. 

 

35. In the Save window, navigate to the directory where the data files were copied to at the beginning of 

the tutorial.  Enter a filename, such as “RH_Loop”.  Under Files of Type, select MPEG-4 files 

(*.mp4) and click Save. 

 

 
36. Outside of McIDAS-V, use a file explorer window to navigate to the directory the animation was 

saved to and view it.  Close the Movie Capture window. 
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Display a Single Time of Remote Data 

37. Remove all layers and data sources from the previous display by selecting Edit -> Remove -> All 

Layers and Data Sources from the Main Display window. 

 

38. From the Data Sources tab of the Data Explorer, navigate to the General->Catalogs chooser. 

 

39. In the Catalog text box, enter the following URL and press Enter: 

https://renucaps.ssec.wisc.edu/thredds/catalog.xml 

 

40. The listing of files under Browse is divided into four geographical categories: Alaska, Caribbean, 

CONUS, and Northern Hemisphere.  Select the top (most recent) file under SPoRT NUCAPS CONUS 

and click Add Source. 

 

41. In the Fields panel of the Field Selector, expand 2D grid, and select any field of interest. 

 

42. In the Displays panel of the Field Selector, verify that Imagery->Image Display is selected. 

 

43. Click Create Display. 
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Display a Loop of Remote Data 

44. Remove all layers and data sources from the previous display by selecting Edit -> Remove -> All 

Layers and Data Sources from the Main Display window. 

 

45. From the Data Sources tab of the Data Explorer, navigate to the General->Catalogs chooser. 

 

46. In the Data Source Type dropdown menu, select Aggregate Grids By Time. 

 

47. Use Shift+Left-Click to select the top ten files under SPoRT NUCAPS CONUS. 

 

48. Click Add Source. 

 

49. In the Fields panel of the Field Selector, expand 2D grid, and select any field of interest. 

 

50. In the Displays panel of the Field Selector, verify that Imagery->Image Display is selected. 

 

51. Click Create Display. 
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52. In the Main Display window, use Shift+Left-Click+Drag to zoom in over the United States domain. 

 
53. Use the Time Animation Widget at the top of the Main Display window to loop through the time 

series. 
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Zooming, Panning, and Rotating Controls 

Zooming Panning Rotating 

 Mouse  

Shift-Left Drag: Select a region 

by pressing the Shift key and 

dragging the left mouse button. 

Shift-Right Drag: Hold Shift 

key and drag the right mouse 

button.  Moving up zooms in, 

moving down zooms out. 

Control-Right Mouse Drag: 

Hold Control key and drag right 

mouse to pan. 

Right Mouse Drag: Drag right mouse 

to rotate 

 Scroll Wheel  

Scroll Wheel-Up: Zoom Out. 

Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-Up/Down: 

Rotate Clockwise/Counterclockwise. 

Shift-Scroll Whell-Up/Down: Rotate 

forward/backward clockwise 

 Arrow Keys  

Shift-Up: Zoom In. 

Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 

Control-Down arrow: Pan Up. 

Control-Right arrow: Pan Left. 

Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate around 

vertical axis. 

Up/Down arrow: Rotate around 

horizontal axis. 

Shift-Left/Right arrow: Rotate 

Clockwise/Counterclockwise 

 


