
McIDAS-V Tutorial 
Using HYDRA to Interrogate Hyperspectral Data 

updated November 2023 (software version 1.9) 
 

 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 

SSEC's 50-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 

(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 

manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 

Unidata's IDV libraries. The functionality of SSEC's HYDRA software package is also being integrated into 

McIDAS-V for viewing and analyzing hyperspectral satellite data. 

 

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 

McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 

the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 

https://www.ssec.wisc.edu/mcidas/software/v/.   

 

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 

Forums - https://mcidas.ssec.wisc.edu/forums/. The forums also provide the opportunity to share information 

with other users. 

 

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 

McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the 

document entitled McIDAS-V Tutorial – Installation and Introduction.  

 

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 

Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 

Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 

Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources). 

 

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).   

 

Introduction 

 
HYDRA (HYperspectral-viewer for Development of Research Applications) is a software package developed at 

SSEC, and some of its functionality has been incorporated into McIDAS-V through the Satellite -> HYDRA 

chooser.  The HYDRA chooser is designed to work with multi/hyperspectral data and is capable of performing 

analysis of the data, including statistical information from scatter analysis displays of different bands of data and 

overlaying spectra of various bands. 

 

https://www.ssec.wisc.edu/mcidas/software/v/
https://www.ssec.wisc.edu/mcidas/software/v/
https://www.ssec.wisc.edu/mcidas/software/v/
https://mcidas.ssec.wisc.edu/forums/
https://mcidas.ssec.wisc.edu/forums/
https://mcidas.ssec.wisc.edu/forums/
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 Create a Multispectral Display (AIRS Hyperspectral Data) 
 

1. In the Main Display remove all layers and data sources via the Edit -> Remove -> All Layers and Data 

Sources menu item. 

 

2. Display the data from the AIRS file dated August 08, 2023 at 12:23:21 UTC.    

 

a. In the Data Sources tab of the Data Explorer, open the Satellite -> HYDRA chooser.  

 

b. Navigate to <local path>/Data/Hydra/ 

AIRS.2023.08.08.124.L1B.AIRS_Rad.v5.0.25.0.G23221105157.hdf, and click Add Source. 

 

c. The file loads into the Field Selector with the name of Hydra.  To make the name more descriptive, edit 

the properties of the data source.   

 

 Under Data Sources, Right Click on Hydra.   

 Select Properties.   

 Change Name from Hydra to AIRS 2023/08/08 12:23:21 UTC. 

 Click OK. 

 

d. In the Field Selector, under Fields, select MultiSpectral -> Radiance. 

 

e. In the Field Selector, under Displays, select MultiSpectral Display.  Click Create Display. 

 

3. The MultiSpectral image displays in the 

Main Display. There are four aspects to the 

MultiSpectral display:  

 

 The image in the Main Display.    

 The main spectrum probe in the Main 

Display is the magenta square.  

 The reference spectrum probe in the 

Main Display is the light blue square.    

(NOTE:  The two spectrum probes may 

overlap, with only the magenta square 

visible.   

Left Click+Drag either box to view 

spectra measured in various pixels of 

image.)  

 The spectra of the MultiSpectral layer in 

the Layer Controls.  The default 

wavenumber is 919.50 cm-1 (10.8 µm).   From the Main Display, click Multi Spectral in the Legend to 

view spectra for the AIRS file in the Layer Controls tab of the Data Explorer. 
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4. Add an image description to the Main Display. 

 

a. In the Layer Controls, select Edit -> Properties. 

 

b. In Layer Label field, remove 

%displayname%.  Type 

%datasourcename%.  The macro 

%datasourcename% is linked to the 

description entered in step 2c. 

 

c. If the Show in Layer List box is not 

checked, click to activate this option. 

 

d. Click OK.  The customized label 

appears at the bottom of the Main 

Display. 

 

5. Compare clear vs. cloudy spectra by moving the spectrum probes. 

   

a. In the Main Display, Shift+Left Cick+Drag to zoom the satellite image. 

 

b. Place one probe over a cold cloud top and one over a dark, cloud-free pixel (such as the eye of Hurricane 

Florence).   

 

c. View spectra in the Layer Controls.  (When in the Main Display, click on MultiSpectral in the Legend 

to bring Layer Controls to the front.) 

 

d. Zoom into interesting spectral regions Shift+Left Click+Drag.  Control+Left Click returns the full 

spectra. 

 

e. Choose different wave numbers by Left Click+Dragging the green selector bar or by entering a 

Wavenumber below the spectra. 
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Create a MultiSpectral Display (MODIS data) 
 

1. Remove all layers and data sources from the previous displays. 

 

2. Display the data from the <local path>/Data/Hydra/ 

MYD021KM.A2023230.0930.061.2023230112307.NRT.hdf file. 

 

a. In the left panel of the Data Sources tab of the 

Data Explorer, choose Satellite -> HYDRA, 

navigate to the MODIS file and click Add 

Source. 

 

b. Change data source name. In the Field 

Selector, Right Click on Hydra under Data 

Sources and select Properties. Change Name 

from Hydra to MODIS 2023/08/18 at 

09:30:00 UTC and click OK. 
 

c. Under Fields expand the MultiSpectral drop 

down list and select Emissive_Bands. 
 

d. Under Displays select MultiSpectral Display. 
 

e. Click Create Display. 

 

 An 11.0 µm image over Hurricane Hillary from 09:30:00 UTC on August 18, 2023 is displayed. 

 

3.  Change the band displayed in the 

Main Display.   

 

a. Left Click MultiSpectral in 

Legend to bring Layer 

Controls to front. 

 

b. Change band with either Left 

Click+Drag option to move the 

green selector bar or select the 

Band from the drop-down list 

at the bottom of the Display tab 

of the Layer Controls. 
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Create a Scatter Analysis of two bands 

 

4. Make a scatter analysis (plot) of two bands. 

 

a. In Data Explorer, navigate to the Field Selector tab. If the Data Explorer is not visible, select Window 

-> Show Data Explorer from the Main Display. 

 

b. Select the Emissive_Bands field.  This will be the x-axis in this scatter analysis.  Under Displays, select 

Imagery -> Scatter Analysis.  

 

c. Use the Band dropdown in the MultiSpectral tab in lower right panel to select Band 28 (7.345 µm). 

Click Create Display. 

 

d. A Field Selector window will appear for selection of the y-axis data field.  In this new Field Selector, 

select Emissive_Bands, and then Band 29 (8.503 µm) in the MultiSpectral tab.  Click OK. 

 

5. The scatter analysis will display in the Layer Controls. 

 

 The left image is the first selected field (Emissive_Bands band 28). 

 The middle image is the second selected field (Emissive_Bands band 29).  

 The right plot is the two-field scatter analysis. The x-axis (abscissa values) corresponds to the first 

field selected and the y-axis (ordinate values) corresponds to the second field selected. (In this 

example, band 28 (7.345 µm) versus band 29 (8.503 µm)). 
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6. Analyze the scatter plot and images by highlighting a box or region in any of three panels.  

 

 
 

 

a. To draw a box, click the Box radio button and select one of the colors.  Use Shift+Left Click+Drag 

option to draw box over a region of the scatter plot.  The corresponding points are highlighted in the 

image.  

 

b. Conversely, select a region of interest in one of the images.  The corresponding points are highlighted in 

the scatter plot.   

 

c. To draw a shape, click the Curve radio button.  Use Left Click+Drag option to draw an enclosed shape.  

 

d. To remove a color from the scatter plot, Double Click in that color’s selection box. 

 

7. Click the compute statistics button at the bottom of the Layer Controls. A window with the scatter plot 

statistics will appear.  Also, there is an option to save the statistics as a CSV file. 
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Problem Sets 

 

The previous examples provide general instructions for loading and displaying multi and hyperspectral data.  

The problem sets below introduce new topics related to the data, and challenges to extend concepts covered in 

the lessons.  Attempt completion of each problem set before checking the solutions.  Solutions are provided 

below the problem set. 

 

1. Use the <local path>/Data/Hydra/ MOD021KM.A2023261.1600.061.2023262011632.hdf file to create a 

Normalized Difference Vegetation Index (NDVI) where: 

 

NDVI = [Band 2 (0.86 µm) – Band 1 (0.65 µm)] / [Band 2 (0.86 µm) + Band 2 (0.65 µm)]. 

 

This can be done by displaying the Reflectance data with the “4 Channel Combinations” formula.  Display 

the output of this formula, set the range to -1 to 1, and the enhancement to be Satellite > GOES > NDVI.  

 

2. Use the <local path>/Data/Hydra/MOD021KM.A2023261.1600.061.2023262011632.hdf file to create a 

scatter analysis of Band 31 vs (Band 29 – Band 31).  Make channel 31 the x-axis.  Then, scatter  

Band 31 vs. (Band 31 – Band 32).  Compare the two. 

 

3. Make an online-offline difference of the 2023 AIRS data. 
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Problem Set #1 – Solution 

 

Use the <local path>/Data/Hydra/ MOD021KM.A2023261.1600.061.2023262011632.hdf file to create a 

Normalized Difference Vegetation Index (NDVI) where: 

 

NDVI = [Band 2 (0.86 µm) – Band 1 (0.65 µm)] / [Band 2 (0.86 µm) + Band 2 (0.65 µm)]. 

 

This can be done by displaying the Reflectance data with the “4 Channel Combinations” formula.  Display the 

output of this formula, set the range to -1 to 1, and the enhancement to be Satellite > GOES > NDVI.  

 

1. In the left panel of the Data Sources tab of the Data Explorer, choose Satellite -> HYDRA, navigate to the 

MOD021KM.A2023261.1600.061.2023262011632.hdf MODIS file and click Add Source. 

 

2. In the Fields panel of the Field Selector, choose the MultiSpectral > Reflective_Bands field. 

 

3. In the Displays panel of the Field Selector, choose the Imagery > 4 Channel Combinations display type. 

 

4. Click Create Display. 

 

5. In the Channel Combination Tool tab of the Layer Controls, use the dropdowns to define the bands and 

operators to use to create the NDVI. 

 

 
 

6. Click the Compute New Field button at the bottom of the Layer Controls. 

 

7. In the Fields panel of the Field Selector, choose the MultiSpectral > (((1.0 * a) – (1.0*b)) / ((1.0*c) + (1.0 

*d))) field. 

 

8. In the Displays panel of the Field Selector, choose the Imagery > Image Display display type. 

 

9. Click Create Display. 

 

10. Right-Click on the enhancement in the Legend of the Main Display and choose Change Range.  Enter a 

range of -1 to 1 (the standard range for NDVI) and click OK. 

 

11. Right-Click on the enhancement and select Satellite > GOES > NDVI. 
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Problem Set #2 – Solution 

 

Use the <local path>/Data/Hydra/ MOD021KM.A2023261.1600.061.2023262011632.hdf file to create a 

scatter analysis of Band 31 vs (Band 29 – Band 31).  Make channel 31 the x-axis.  Then, scatter  

Band 31 vs. (Band 31 – Band 32).  Compare the two. 

 

1. Remove all layers via the Edit -> Remove -> All Layers menu item in the Main Display. 

 

2. Create the 4 channel combination.  In the Field Selector: 

 

a. Under Fields, select Emissive_Bands from the MultiSpectral list. 

 

b. Under Displays, select 4 Channel Combinations. 

 

c. Click Create Display. 

 

3. Create the “Band 29 – Band 31” difference image. 

 

a. Select Band 29 in red channel box. 

 

b. To the right of the red drop-down menu, select the minus (-) operator from the drop-down list. 

 

c. Select Band 31 in the green channel box. 

 

d. Click Compute New Field. 

 

4. Repeat step 3 to create the “Band 31 – Band 32” difference image. 

 

a. Select Band 31 in red channel box 

 

b. To the right of the red drop-down menu, select the minus (-) operator from the drop-down list. 

 

c. Select Band 32 in the green channel box. 

 

d. Click Compute New Field. 

 

5. Return to Field Selector to create the Scatter Analysis. 

 

a. Under Fields, select Emissive_Bands. 

 

b. Under Displays, select Scatter Analysis.  

 

c. Click Create Display.  (The default emissive band is band 31.  This will be the x-axis). 

 

d. A Field Selector window appears for the y-axis, data selection.   Select the “Band 29 – Band 31” 

difference image (This is the first ((1.0*a) – (1.0*b)) image in the MultiSpectral drop down list).  

 

e. Click OK. 
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The Scatter Display will display in the Layer Controls. 

 

 
 

6. Repeat step 5 to create a scatter analysis display using band 31 as the x-axis and “Band 31 – Band 32” as the 

y-axis.  “Band 31 – Band 32” will be the second ((1.0*a) – (1.0*b)) image in the MultiSpectral drop down 

list.  The Scatter Display will display in the Layer Controls. 

 

 
 

7. Compare the scatter displays. 
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a. Undock each display: In Layer Controls for each Scatter Display, select View -> Undock from Data 

Explorer.   

 

b. Arrange the scatter displays so both windows are visible on your monitor.   

 

c. Use the scatter analysis tools to draw boxes and curves on the images and scatter plot. 

 

Problem Set #3 - Solution 

Make an online-offline difference of the 2023 AIRS data. 

 

1. Remove all layers and data sources via the Edit -> Remove -> All Layers and Data Sources menu item in 

the Main Display. 

 

2. Load the 2018 AIRS data file through the Satellite -> HYDRA chooser in the Data Sources tab of the Data 

Explorer. 

 

3. Return to the Field Selector, choose the Radiance field, and select 4 Channel Combinations under 

Displays and click Create Display.  

 

4. Enter in the equation 746.01 (red) – 746.97 (green) and hit Enter after each number.  The vertical red and 

green lines in the spectrum will move to 746.01 cm-1 and 746.97 cm-1, respectively.  The red band is the 

online value and the green band is the offline value.  
 

 
 

5. Zoom in over the region by using the Shift+Left Click+Drag option. Reset the spectrum by Control+Left 

Click.  

 

6. Click Compute New Field to create a new field of this online - offline difference.   
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7. The resulting field will be ((1.0*a) – (1.0*b)) in the Field Selector under the MultiSpectral field in the 

Fields list.  Click on this new field and select Image Display under Displays and click Create Display. 

 

 
 

The resulting image from the online-offline calculation shows the vertical temperature gradient – in cloudy 

regions (darker), the difference is small because both the online and offline wave numbers detect clouds.  In 

clear regions (lighter), the difference between the two wave numbers is larger because of the temperature 

gradient through the atmosphere. 
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Spectra 

Select spectra - write wavenumber in box, select channel from pulldown menu, or middle button click 

Shift+Left Click+Drag – (Zoom) Select portion of spectra for magnification.  

Control+Left Click – Return to full spectrum 

Left Click+Drag – Move spectrum right or left  

Middle mouse button (or wheel) click – Read Brightness Temperatures and Wavenumbers. Provides 

Brightness Temperature value and Wavenumber at cursor location. It will also move the green line 

and change the image to that wavenumber. 

Image 

Left Click on a probe and drag – Change probe location (The spectra will display for new location)  

Change band – use spectra window, write wavenumber in box, or middle button click 

Move image up or down – use arrow icons in left utility bar 

Zoom – Shift+Right Click+Drag over window –or- mouse scroll wheel forward or backward 

Return to Original Image View – Click on house icon in left utility bar 


