
McIDAS-V Tutorial 
Displaying Satellite Orbit Tracks Data 

created November 2024 (software version 1.9) 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 

SSEC's 50-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 

(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 

manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 

Unidata's IDV libraries. The functionality of SSEC's HYDRA software package is also being integrated into 

McIDAS-V for viewing and analyzing hyperspectral satellite data. 

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 

McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 

the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 

https://www.ssec.wisc.edu/mcidas/software/v/.   

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 

Forums - https://mcidas.ssec.wisc.edu/forums/. The forums also provide the opportunity to share information 

with other users. 

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 

McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the 

document entitled McIDAS-V Tutorial – Installation and Introduction.   

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 

Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 

Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 

Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources). 

 

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).   

  

https://www.ssec.wisc.edu/mcidas/software/v/
https://mcidas.ssec.wisc.edu/forums/
https://mcidas.ssec.wisc.edu/forums/
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Introduction 

McIDAS-V has the ability of displaying TLE (Two Line Elements) Satellite Orbit Track data through the 

Satellite Orbit Track chooser.  TLE data can be loaded into the Field Selector in three ways: 

 Through a local file on your machine or a mounted drive 

 Through ADDE 

 Through a URL 

This tutorial will describe how to load data through a local file and a URL. Different options for customizing 

the display will be covered as well. 

Displaying TLE Data from a Local File 

1. In the Main Display, remove all layers and data sources via the Edit -> Remove -> All Layers and Data 

Sources menu item. 

 

2. Create a new tab with the File -> New Display Tab -> Map Display -> One Tab menu item. 

 

3. Create a data source of satellite track data from a local file. 

 

a. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Orbit Track chooser. 

 

b. Under Local, verify that File is selected. 

 

c. Navigate to the <local path>/Data/SatelliteTracks directory and select noaa.txt. 

 

d. Click Add Source. 

 

4. Display a full day’s worth of NOAA-21 (JPSS-2) tracks from August 23, 2023. 

 

a. In the Fields panel of the Field Selector, select the NOAA 21 (JPSS-2) [+] field. 

 

b. In the Displays panel, select Satellite Orbit Track. 

 

c. The Time Range panel allows for selecting the beginning and ending date/time of the track to plot.  

McIDAS-V will default to displaying the tracks from 00:00:00Z – 23:59:59Z on the current date.  To 

display the full track from August 23, 2023, click on the calendar widget ( ) next to Begin Date and 

select Aug 23, 2023.  Repeat this process for the End Date field. 

 

d. Click Create Display. 

 

5. Inspect the display of the NOAA-21 tracks. 
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a. When the display is created, you may see horizontal lines going across the display, as is shown here: 

 
 

If you see these horizontal lines, go to the Layer Controls tab of the Data Explorer for the orbit track 

layer and select Edit -> Properties.  At the bottom of the Properties window, uncheck Use Fast 

Rendering and click OK.  Once this is done, the display may look like the following image: 

 
 

There are times where disabling fast rendering can remove spurious lines.  There are other times where 

enabling fast rendering can fix gaps in lines when viewing a polar projection.  In general, if the display’s 

lines don’t look correct, changing the fast rendering setting for the layer is a good idea. 

 

b. Zoom in on the region of interest in the Main Display by using Shift+Left-Click+Drag.  For example, 

select an area over the central United States.  Observe the track times, and determine a good time range 

where the track lines cross through the United States.  The times are written along the track.  For 
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example, you may determine a time range of 19:20 through 19:35 is good.  In the next section of this 

tutorial, this time range will be plotted. 

 

6. Create a new tab via the File -> New Display Tab -> Map Display -> One Panel menu item. 

 

7. Display NOAA-21 satellite tracks for the time range chosen in step 5b. 

 

a. From the Field Selector tab of the Data Explorer select NOAA 21 (JPSS-2) [+]. 

 

b. In the Time Range panel, verify that Aug 23, 2023 is selected for the Begin Date and End Date fields.  

For Begin Time, enter 19:20:00 (or the start time determined in step 5b) and for End Time enter 

19:35:00 (or the end time determined in step 5b) and click Create Display. 

 

8. Modify different aspects of the track line display. 

 

a. Zoom in over the track data in the Main Display by using Shift+Left-Click+Drag. 

 

b. Add swath edge lines to the display by going to the Layer Controls and enabling Swath Edges On/Off.   

 

c. By default, time labels are drawn along the track every 5 minutes.  Change the display to show time 

labels at every minute by going to the Layer Controls, setting Label Interval to 1, and clicking Apply. 

 

d. From the Layer 

Controls, change the 

color of the lines and 

labels in the display to 

yellow by clicking on 

the green Color 

Swatch, selecting 

Yellow, clicking OK in 

the Color window, and 

clicking Apply. 

 

e. From the Layer Controls, change the Track Style from a solid line to a dashed line by using the 

dropdown menu and click Apply. 

 

f. From the Layer Controls, change the Edge Style from a dashed line to a solid line by using the 

dropdown menu and click Apply. 

 

9. Add a SSEC (Space Science and Engineering Center) ground station to the display. 

 

a. From the Ground Stations panel of the Layer Controls, select SSEC for the Ground Stations 

Available menu and click Add Selected. 
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Investigate the display.  A ground station for SSEC has been added to the display over south central Wisconsin.  

There is a ring around the ground station that denotes the region where an antenna at the SSEC ground station 

can detect the NOAA-21 satellite.  The size of this ring is based on the altitude of the satellite as well as the 

Antenna Angle, which is defined at the bottom of the Layer Controls.  This is the angle that the antenna at the 

SSEC ground station scans at.  Once the ground station is added, the final display may look like: 

 

 
 

Displaying TLE Data from a URL 

10. Remove all layers and data sources from the previous displays via the Edit -> Remove ->All Layers and 

Data Sources menu item in the Main Display.  

 

11. Create a new tab via the File -> New Display Tab -> Map Display -> One Panel menu item. 

 

12. Remove all previous tabs, so only the tab created in step 11 is in the Main Display. 

 

13. Create a data source of satellite track data from a URL. 

 

a. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Orbit Tracks chooser. 

 

b. Under Remote, select URL. 

 

c. Verify that the default URL of https://www.celestrak.com/NORAD/elements/noaa.txt is in the text field. 
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d. Click Add Source.  

 

14. Display six hours of NOAA 20 satellite tracks for the current date. 

 

a. From the Field Selector tab of the Data Explorer select NOAA 20. 

 

b. In the Displays panel, select Satellite Orbit Track. 

 

c. In the Time Range panel, verify that the current date is entered for the Begin Date and End Date fields.  

For Begin Time and End Time, enter a 6 hour range.  For example, 02:00:00Z – 08:00:00Z. 

 

d. Click Create Display. 

 

e. If horizontal lines are visible in the display, repeat step 5a to change the fast rendering setting of the 

layer. 

 

15. Add a ground station from the Ground Stations Available menu to the display. 

 

a. From the Ground Stations panel of the Layer Controls, select a station (such as Madrid26) for the 

Ground Stations Available menu and click Add Selected. 

 

b. At the bottom of the Ground Station Controls in the Layer Controls, change the Color to red, Line 

Width to 2, and Line Style to solid.  Click Apply. 

 

c. Note how the ground station in the Main Display changed from the previous step.  At the bottom of the 

Layer Controls, change the Antenna Angle to 20 and click Apply.  With the higher elevation angle, 

you should notice that the ring around the ground station becomes smaller. 

 

16. Add a custom ground station to the display 

 

a. In the Main Display window, choose a latitude/longitude location contained in the region where the 

track lines are located.  To do this, move your cursor over the display and record the latitude/longitude 

readout at the bottom of the window. 

 

b. In the Ground Station Controls panel of the Layer Controls, add a custom ground station at the 

location determined in step 16a at an altitude of 0 meters.  The Label can be chosen by the user.  For 

example, the Custom Ground Station values could be: 

 

Label: Grand Cayman 

Lat: 19.3 

Lon: -81.3 

Alt: 0 
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c. Click Add Custom. 

 

17. Investigate and update the display. 

 

a. After the completion of step 16, the custom ground station will be displayed and it should look similar to 

the ground station added in step 15.  This is because any newly-added stations will use the Color, Line 

Width, Line Style, and Antenna Angle defined at the bottom of the Layer Controls. 

 

b. Change the first station plotted to yellow. 

 

i. For the Ground Stations Plotted menu, select the station added in step 15. 

 

ii. Change the Color at the bottom of the Layer Controls to yellow and click Apply. 

 

At this point, the ground station selected under the Ground Stations Plotted menu should change to 

yellow and the custom ground station displayed in step 16 should remain red. 

 

c. Remove the yellow ground station by clicking Remove Selected next to Ground Stations Plotted.  

This will remove the station selected under the Ground Stations Plotted menu and leave the other in 

the display. 

 

18. Zoom in over your custom ground station and capture an image of the display. 

 

a. Zoom in over the ground station in the Main Display by using Shift+Left-Click+Drag. 

 

b. If the label of the ground station is too small, increase the font size using the controls at the bottom of 

the Layer Controls and click Apply. 

 

c. In the Main Display window, select View -> Capture -> Image. 

 

d. In the Save In menu of the Save window, select the directory to write the image to. 

 

e. In the File Name window, enter a file name.  For example, NOAA20_Ground_Station.jpg. 

 

f. Under Capture What, select Current View. 

 

g. Click Save at the bottom of the Save window. 

 

h. View your image using a software package external to McIDAS-V, such as a web browser. 
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Zooming, Panning, and Rotating Controls 

 

Zooming Panning Rotating 

 Mouse  

Shift-Left Drag: Select a region 

by pressing the Shift key and 

dragging the left mouse button. 

Shift-Right Drag: Hold Shift key 

and drag the right mouse button. 

Moving up zooms in, moving 

down zooms out. 

Control-Right Mouse Drag: 

Hold Control key and drag right 

mouse to pan. 

Right Mouse Drag: Drag right 

mouse to rotate. 

 Scroll Wheel  

Scroll Wheel-Up: Zoom Out. 

Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-

Up/Down: Rotate 

clockwise/counter clockwise. 

Shift-Scroll Wheel-Up/Down: 

Rotate forward/backward 

clockwise. 

 Arrow Keys  

Shift-Up: Zoom In. 

Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 

Control-Down arrow: Pan Up. 

Control-Right arrow: Pan Left. 

Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 

around vertical axis. 

Up/Down arrow: Rotate 

around horizontal axis. 

Shift-Left/Right arrow: Rotate 

Clockwise/Counterclockwise. 

 

 

 

 

 

 

 

 

 

 

  


