
      

McIDAS-V Tutorial 
Displaying Polar Satellite Imagery 

updated November 2023 (software version 1.9) 
 

 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 

SSEC's 50-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 

(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 

manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 

Unidata's IDV libraries. The functionality of SSEC's HYDRA software package is also being integrated into 

McIDAS-V for viewing and analyzing hyperspectral satellite data. 

 

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 

McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 

the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 

http://www.ssec.wisc.edu/mcidas/software/v/. 

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 

Forums - https://mcidas.ssec.wisc.edu/forums/. The forums also provide the opportunity to share information 

with other users. 

 

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 

McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the 

document entitled McIDAS-V Tutorial – Installation and Introduction. 

 

 

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 

Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 

Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 

Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources). 

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag). 

 

 

http://www.ssec.wisc.edu/mcidas/software/v/
https://mcidas.ssec.wisc.edu/forums/
https://mcidas.ssec.wisc.edu/forums/
https://mcidas.ssec.wisc.edu/forums/
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Displaying Local MODIS Data 
 

 

1. Create a local dataset to access the imagery files on your local machine. 

 

a. In the Main Display window of McIDAS-V, select Tools -> Manage ADDE Datasets. 

 

b. In the ADDE Data Manager, select File -> New Local Dataset.  Enter in the following parameters to 

set up a dataset with the MODIS Level 1b HDF files provided with this tutorial: 

 

 Dataset – MODIS 

 Image Type – Canada Fires 

 Format – MODIS MOD 02 – Level-1B Calibrated Geolocated Radiances 

 Directory – select the <local path>/Data/Polar/modis_files directory 

 

 
 

c. Click Add Dataset. 

 

d. Close the ADDE Data Manager by clicking Ok or File -> Close. 

 

2. To load the data in this local dataset, follow these steps. 

a. Click on the  button in the Main Toolbar to go to the Data Explorer. 

 

b. Select the Satellite -> Imagery chooser from the Data Sources tab. 

 

c. Select <LOCAL-DATA> for the Server, select MODIS for the Dataset, and click Connect. 

 

d. Choose the Canada Fires Image Type and select an Absolute time of 14:55 UTC. 

 

e. Click Add Source to show the Field Selector. 

 

f. Select 0.6465 um Land/Cloud Boundaries -> Brightness. 

 

g. In the Advanced, click the green four arrow button to get the full resolution and full domain of the data. 
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h. Click Create Display.  The 14:55 UTC 0.6465 μm image is displayed in the Main Display window. 

 

3. Use the zooming and panning controls in the left toolbar to inspect the image.  Specifically, notice the 

smoke from the fires in southern Quebec, Canada. 

 

a. Reproject the image with a pre-defined domain.  Select Projections -> Predefined -> World.  Use the 

scroll wheel to zoom into the image or Shift+Left Click+Drag a box around the image. 

 

b. Turn off the Auto-set Projection option under the Projections menu.  When this option is checked, the 

projection will automatically change to the native projection of the new layer.  When this option is 

unchecked, all new layers will be reprojected into the current projection. 

 

4. Return to the Field Selector to load a surface/cloud temperature image. 

 

a. Select 3.7882 um Surface/Cloud Temperature -> Temperature. 

 

b. In the Advanced, click the green four arrow button to get the full resolution and full domain of the data. 

 

c. Click Create Display.  The 3.7882 µm temperature image is overlaid on top of the visible image.  To 

see the visible image, turn off the top HDF MOD02 1km file (All Bands...) checkbox in the Legend.  

Turn the visibility of the 0.6465 μm back on. 

 

5. Modify the enhancement range to make the fire pixels easier to locate. 

 

a. Zoom in on the region where the 

data is displayed in the Main 

Display.  

 

b. Right-Click on the grayscale 

enhancement for the 3.7782 μm 

layer in the Legend and choose 

Change Range. 

 

c. In the Change Range window, 

change the To value to 340 and 

click OK. 

 

d. Right-Click on the grayscale 

enhancement for the 3.7882 μm 

layer in the Legend and choose 

the Satellite -> Fire – 

Transparent enhancement.  

This makes high end temperatures yellow, orange, and red, while the lower end cooler temperatures are 

100% transparent, allowing the 0.6465 μm data to be seen. 

 

6. Use the cursor readout option to see the temperature values for the fire pixels. 
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a. Click and drag the middle mouse button to activate the Cursor/Data Readout option and list the 

latitude, longitude, and data value under the cursor.  Since there are two layers in the main display, there 

are two different readouts with the appropriate values and units.  Notice the high 3.7882 μm temperature 

values are located at the location of the fire.  The data probe from the cursor/data readout option shows 

that values in the fire are approximately 50 degrees K warmer than outside of the fire. 

 

7. Edit the maps in the display by using the options in the Layer Controls. 

 

a. Click on Default Background Maps in the Legend to go to the Layer Controls.  The map controls will 

have two tabs.  The first Maps tab lists the available maps, and the second Lat/Lon tab allows the user to 

control latitude and longitude lines and labels. At the bottom of both tabs, there is a Position slider that 

allows you to control the vertical positioning of the maps in the Main Display. 

 

b. In the Maps tab you can remove a map, change its visibility, line width, style and color.  Use these 

options to create your own map display. 

 

c. If you choose, also add latitude and longitude lines and labels in the Lat/Lon tab. 

 

d. To save a map configuration as the default, in the Layer Controls select File -> Default Maps -> Save 

as the Default Map Set.  The next time you open a new tab, window, or start McIDAS-V, the defaults 

will reflect what you selected.  

 

8. Notice that both layers are labeled the same in the Legend. Change the text of the labels in the Main 

Display. 

  

a. Right Click on the top Canada Fires (All Bands) label in the Legend and select Edit -> Properties. 

 

b. Enter the following for the Legend Label: 3.7882um - %datasourcename% 
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9. Display a true color RGB image of the scene and it with the 3.7882 μm data. 

 

a. In the Field Selector, choose Imagery -> MODIS Functions -> MODIS True Color RGB. 

 

b. In the Displays panel, select Imagery -> 3 Color (RGB) Image. 

 

c. Click Create Display. 

 

d. Inspect the display and notice how the true color RGB image is displayed on top of the other layers.  

Bring the 3.7882um layer to the front Right-Clicking on the blue text of the layer in the Legend and 

selecting View -> Bring to Front. 

 

 

Displaying Local NOAA-19 Data 

 

1. Create a local dataset to access the AVHRR (Advanced Very High Resolution Radiometer) NOAA-19 

HRPT (High Resolution Picture Transmission) polar orbiter imagery files on your local machine. 

 

a. In the Main Menu Bar of the Main Display window, select Tools -> Manage ADDE Datasets. This 

will open the ADDE Data Manager. 

 

b. Select File -> New Local Dataset. Enter the following parameters to set up the dataset: 

 

 Dataset – AVHRR 

 Image Type – NOAA-19 

 Format – NOAA AVHRR L 1b 

 Directory – select the <local path>/Data/Polar/AVHRR directory. 

 

 
 

c. Click Add Dataset. 

 

d. Close the ADDE Data Manager by clicking Ok or select File -> Close. 

 

2. Remove all layers and data sources and display AVHRR 3.74 μm Temperature data.  

 

a. In the Main Display select File -> New Display Tab -> Map Display -> One Panel. 
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b. In the Satellite -> Imagery chooser of the Data Sources tab of the Data Explorer, select <LOCAL-

DATA> for the Server, select AVHRR for the Dataset, and click Connect. 

 

c. Choose the NOAA-19 Image Type and select an Absolute time of 14:06:22 UTC. 

  

d. Click Add Source to show the Field Selector. 

 

e. Select 3.74um IR Low Cloud/Fog, Fire Detection -> Temperature. 

 

f. Under Displays click on the Advanced tab.  Click on the green arrow icon next to Image Size to load 

the full image. Change the Magnification to 1 X 1 with the sliders, and click Create Display.  The 

Magnification of 1 X 1 loads and displays the full resolution of the data.  Negative magnification values 

will reduce the amount of data loaded and displayed.  For example, -5 X -5 will sample the data, and 

every fifth line and every fifth element is sent from the server. 

 

g. Change the display to the World projection through the Projections -> Predefined -> World menu item.  

Use Shift+Left-Click+Drag to zoom in over the data. 

 
h. Optionally, modify the display to highlight the fire activity as was done previously with the MODIS 

data.  This can be done by changing the enhancement and adjusting the enhancement range. 

 

 

Problem Sets 
 

The previous examples were intended to give you a general knowledge of how to load and display polar satellite 

data.  The problem sets below are intended to introduce you to new topics related to the data, as well as 

challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem set 

before looking at the solutions, which is provided below the problem set. 

 

1. Using the <local path>/Data/Polar/MOD02/* data, create a local dataset, and display an animation of 3 

times of data on a globe display with a blue marble background basemap.  Disable auto-set projection in the 

new display tab and display the data using Line/Element navigation so the data will plot at the correct 

location for each timestep.  These are all daytime images, so displaying any visible or infrared band will 

produce good images. 
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Problem Set #1 – Solution 

 

Using the <local path>/Data/Polar/MOD02/* data, create a local dataset, and display an animation of 3 times 

of data on a globe display with a blue marble background basemap.  Disable auto-set projection in the new 

display tab and display the data using Line/Element navigation so the data will plot at the correct location for 

each timestep.  These are all daytime images, so displaying any visible or infrared band will produce good 

images. 

 

1. Remove all layers and data sources, create a globe display, and load the data. 

 

a. Remove all layers and data sources. 

 

b. In the Main Display select File -> New Display Tab -> Globe Display -> One Panel. 

 

c. In the Data Sources tab of the Data Explorer, using the Satellite -> Imagery chooser, select <LOCAL-

DATA> for the Server, select MODIS for the Dataset, and click Connect. 

 

d. Choose the Canada Fires Image Type.  In the Relative tab, enter a value of 3 for Number of times. 

  

e. Click Add Source to show the Field Selector. 

 

2. Select the 3.7882 μm Temperature and display the data for all three timesteps. 

 

a. Select 3.7882 um Surface/Cloud Temperature -> Temperature. 

 

b. Under Displays click on the Advanced tab.  For Coordinate Type: choose Image Coordinates. Click 

on the green arrow icon  next to Image Size to load the full-size image.  For Location: choose Upper 

Left, and click Create Display. 

 

3. Animate the globe and add the big blue marble background image.  Then analyze and animate the globe 

display. 

 

a. From the Main Display, select Display -> Add Background Image.  In the Layer Controls for the 

background image, select Blue Marble – Static from the Layer dropdown.. 

 

b. Start the loop by using the Time Animation buttons at the top of the Main Display. 

 

c. Turn on the Auto-Rotate view option (View -> Viewpoint from the Main Display window, or the Auto-

Rotate button  in the Viewpoint Toolbar to the left of the image). 

 

d. Change the orientation of the globe in the Main Display with the mouse controls.  Restart the Auto 

rotate view. 
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Zooming, Panning, and Rotating Controls 
 

Zooming Panning Rotating 

  Mouse  

Shift-Left Drag: Select a region 

by pressing the Shift key and 

dragging the left mouse button. 

Shift-Right Drag: Hold Shift key 

and drag the right mouse button. 

Moving up zooms in, moving 

down zooms out. 

Control-Right Mouse Drag: 

Hold Control key and drag right 

mouse to pan. 

Right Mouse Drag: Drag right 

mouse to rotate. 

 Scroll Wheel  

Scroll Wheel-Up: Zoom Out. 

Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-

Up/Down: Rotate 

clockwise/counterclockwise. 

Shift-Scroll Wheel-Up/Down: 

Rotate forward/backward 

clockwise. 

 Arrow Keys  

Shift-Up: Zoom In. 

Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 

Control-Down arrow: Pan Up. 

Control-Right arrow: Pan Left. 

Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 

around vertical axis. 

Up/Down arrow: Rotate 

around horizontal axis. 

Shift-Left/Right arrow: Rotate 

Clockwise/Counterclockwise. 

 

 


