McIDAS User's Guide
Version 2010.2

[Search Manual] [Table of Contents] [Go to Previous] [Go to Next]

Installing McIDAS-X on Unix or Mac OS X Workstations

The system administrator or person who installs McIDAS-X will use these installation instructions.

The installation instructions follow the table below, which lists the software versions compatible with McIDAS-X 2010.2.

McIDAS-X 2010.2 was tested - and is fully supported - on these versions only. In most cases, you should be able to install and run McIDAS-X 2010.2 on workstations running later editions in the same version series (e.g., if McIDAS-X is tested and supported on version 1.2.1, then versions 1.2.2, 1.2.3, etc. are also likely to work correctly). However, please keep in mind that McIDAS User Services is very limited in its ability to acquire and test versions other than those below and thus is limited in its ability to assist in troubleshooting problems that occur with other versions.

Vendor Operating System Fortran compiler C compiler X Server /
X Window System
Apple® Mac OS® X 10.5.8 Intel gfortran: 4.4.1
(available for free at
gcc: 4.0.1
(packaged with
Xcode 3.1)
XQuartz 2.5.3
(available for free at
OS X Note:
  1. In order to build and install McIDAS-X on Mac OS X, you must install Xcode Development Tools 3.1 on your workstation. Xcode Development Tools 3.1 is included on the OS install media and is available from
HP® HP-UX® 11.11 vendor:
HP Fortran 90 3.1
vendor :
HP C/ANSI C 11.11.16
packaged with
HP-UX 11.11
IBM® AIX® 5L version 5.3.3 vendor :
XLF 8.1.0
g77 : 3.4.4
vendor :
XLC 6.0
gcc : 3.4.4
AIXwindows 5.3.3
Red Hat Enterprise Linux® 4.0 Intel g77 : 3.4.6 gcc : 3.4.6 packaged with
Enterprise Linux 4.0
Enterprise Linux 5.5 Intel gfortran : 4.1.2 gcc : 4.1.2 packaged with
Enterprise Linux 5.5
Enterprise Linux 5.2 PPC gfortran : 4.1.2 gcc : 4.1.2 packaged with
Enterprise Linux 5.2
Linux Notes:
  1. On Linux systems, we recommend that you use the GNOME desktop environment. Other desktops, such as KDE, may not display the McIDAS-X windows correctly.
  2. Enterprise Linux does not install the compress utility by default. So you must install compress if you will be configuring your Enterprise Linux workstation as an ADDE remote server.
Sun Solaris 10 OS SPARC Platform Edition vendor :
Sun Studio 11
g77 : 3.4.6
vendor :
Sun Studio 11
gcc : 3.4.6
packaged with
Solaris 10
Solaris 10 OS x86 Platform Edition g77 : 3.4.6 gcc : 3.4.6 packaged with
Solaris 10


The McIDAS-X installation consists of seven tasks:

If you have questions about the installation, call the McIDAS Help Desk at (608) 262-2455, or send email to McIDAS User Services.

[Search Manual] [Table of Contents] [Go to Previous] [Go to Next]